Re: [rt-users] Attachments don't reach database for one user

2016-03-25 Thread Chanel Wheeler
That did the trick. Thanks!!

chanel

From: rt-users [mailto:rt-users-boun...@lists.bestpractical.com] On Behalf Of 
Dustin Graves
Sent: Thursday, March 24, 2016 4:49 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Attachments don't reach database for one user

Hi Chanel,

I have tested this locally and it appears to me that all attachments should be 
broken for unprivileged users using the SelfService UI. This is a result of the 
changes made in 4.4.0 to attachments.

I have created a patch for this that appears to fix this problem. You will find 
that patch attached. This will be fixed in 4.4.1.

Thank you,
Dustin

-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016


Re: [rt-users] Attachments don't reach database for one user

2016-03-24 Thread Dustin Graves
Hi Chanel,I have tested this locally and it appears to me that all attachments should be broken for unprivileged users using the SelfService UI. This is a result of the changes made in 4.4.0 to attachments.I have created a patch for this that appears to fix this problem. You will find that patch attached. This will be fixed in 4.4.1.Thank you,Dustin

fix_selfservice_attachments.patch
Description: Binary data
On Mar 24, 2016, at 6:09 PM, Chanel Wheeler <chanel.whee...@yavapai.us> wrote:All other unprivileged users can attach files. chanel From: rt-users [mailto:rt-users-boun...@lists.bestpractical.com] On Behalf Of Dustin GravesSent: Thursday, March 24, 2016 3:09 PMTo: rt-users@lists.bestpractical.comSubject: Re: [rt-users] Attachments don't reach database for one user Hi Chanel, On Mar 24, 2016, at 5:58 PM, Chanel Wheeler <chanel.whee...@yavapai.us> wrote: Further experimentation has revealed that if the user sends an attachment by email it works (doesn’t via the web interface). Also, if I promote the user to the privileged level then she can add attachments via the web interface. I tried giving the unprivileged group all possible permissions but it had no effect. Ah, I didn’t realize this user was unprivileged. And this is the only unprivileged users experiencing this trouble? Other unprivileged users and privileged users all are able to attach files normally? I will take a look at this again with the Self-Service interface in mind.chanelThank you,Dustin

signature.asc
Description: Message signed with OpenPGP using GPGMail
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016


Re: [rt-users] Attachments don't reach database for one user

2016-03-24 Thread Chanel Wheeler
All other unprivileged users can attach files.

chanel

From: rt-users [mailto:rt-users-boun...@lists.bestpractical.com] On Behalf Of 
Dustin Graves
Sent: Thursday, March 24, 2016 3:09 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Attachments don't reach database for one user

Hi Chanel,

On Mar 24, 2016, at 5:58 PM, Chanel Wheeler 
<chanel.whee...@yavapai.us<mailto:chanel.whee...@yavapai.us>> wrote:

Further experimentation has revealed that if the user sends an attachment by 
email it works (doesn’t via the web interface). Also, if I promote the user to 
the privileged level then she can add attachments via the web interface. I 
tried giving the unprivileged group all possible permissions but it had no 
effect.

Ah, I didn’t realize this user was unprivileged. And this is the only 
unprivileged users experiencing this trouble? Other unprivileged users and 
privileged users all are able to attach files normally?

I will take a look at this again with the Self-Service interface in mind.


chanel
Thank you,
Dustin
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016


Re: [rt-users] Attachments don't reach database for one user

2016-03-24 Thread Dustin Graves
Hi Chanel,

> On Mar 24, 2016, at 5:58 PM, Chanel Wheeler  wrote:
> 
> Further experimentation has revealed that if the user sends an attachment by 
> email it works (doesn’t via the web interface). Also, if I promote the user 
> to the privileged level then she can add attachments via the web interface. I 
> tried giving the unprivileged group all possible permissions but it had no 
> effect.

Ah, I didn’t realize this user was unprivileged. And this is the only 
unprivileged users experiencing this trouble? Other unprivileged users and 
privileged users all are able to attach files normally?

I will take a look at this again with the Self-Service interface in mind.

> chanel
Thank you,
Dustin


signature.asc
Description: Message signed with OpenPGP using GPGMail
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016


Re: [rt-users] Attachments don't reach database for one user

2016-03-24 Thread Chanel Wheeler
Further experimentation has revealed that if the user sends an attachment by 
email it works (doesn’t via the web interface). Also, if I promote the user to 
the privileged level then she can add attachments via the web interface. I 
tried giving the unprivileged group all possible permissions but it had no 
effect.

chanel

From: Chanel Wheeler
Sent: Tuesday, March 15, 2016 9:31 AM
To: 'Dustin Graves'
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Attachments don't reach database for one user

Yes, everything in the ticket shows up for the faulty user except for the 
attachment. The rights for this user and other basic users of the system are 
the same.

chanel


From: Dustin Graves [mailto:dus...@bestpractical.com]
Sent: Monday, March 14, 2016 1:58 PM
To: Chanel Wheeler
Cc: rt-users@lists.bestpractical.com<mailto:rt-users@lists.bestpractical.com>
Subject: Re: [rt-users] Attachments don't reach database for one user


On Mar 10, 2016, at 5:09 PM, Chanel Wheeler 
<chanel.whee...@yavapai.us<mailto:chanel.whee...@yavapai.us>> wrote:

Hi all,
Hi Chanel,

I have one user that has used RT for a while with no problems. Recently, her 
attachments to web tickets ceased coming through. I’ve watched her add  
attachments and they appear to upload successfully but there’s no trace of them 
in the Attachments table. We tried multiple browsers and the same thing 
happened on each. I logged in as her on my computer and still the problem 
happened. Another person logged in to RT on her computer and successfully 
attached items. So it’s something to do with her account. I’ve taken a look at 
her user record in the db and I don’t see anything amiss.

Any ideas on what I might try?

We’re running RT 4.4 and use LDAP for authentication.

I would start by checking the rights for these two users and how they might be 
different.

Can the faulty user see the missing attachment’s associated 
comment/correspondence? If the user cannot, that is why the attachment is 
missing. A user needs the ShowTicketComments right to see attachments added as 
part of a comment.

If this is not the problem, then I can investigate further.

Thanks!
chanel
Thank you,
Dustin
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016


Re: [rt-users] Attachments don't reach database for one user

2016-03-15 Thread Gordon Scott Messmer
On Tue, Mar 15, 2016 at 9:31 AM, Chanel Wheeler 
wrote:

> Yes, everything in the ticket shows up for the faulty user except for the
> attachment. The rights for this user and other basic users of the system
> are the same.
>
>
>
Is that user using Outlook?  Might it be sending non-plain-text parts of
the message as winmail.dat?
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016


Re: [rt-users] Attachments don't reach database for one user

2016-03-15 Thread Chanel Wheeler
Yes, everything in the ticket shows up for the faulty user except for the 
attachment. The rights for this user and other basic users of the system are 
the same.

chanel


From: Dustin Graves [mailto:dus...@bestpractical.com]
Sent: Monday, March 14, 2016 1:58 PM
To: Chanel Wheeler
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Attachments don't reach database for one user


On Mar 10, 2016, at 5:09 PM, Chanel Wheeler 
<chanel.whee...@yavapai.us<mailto:chanel.whee...@yavapai.us>> wrote:

Hi all,
Hi Chanel,


I have one user that has used RT for a while with no problems. Recently, her 
attachments to web tickets ceased coming through. I’ve watched her add  
attachments and they appear to upload successfully but there’s no trace of them 
in the Attachments table. We tried multiple browsers and the same thing 
happened on each. I logged in as her on my computer and still the problem 
happened. Another person logged in to RT on her computer and successfully 
attached items. So it’s something to do with her account. I’ve taken a look at 
her user record in the db and I don’t see anything amiss.

Any ideas on what I might try?

We’re running RT 4.4 and use LDAP for authentication.

I would start by checking the rights for these two users and how they might be 
different.

Can the faulty user see the missing attachment’s associated 
comment/correspondence? If the user cannot, that is why the attachment is 
missing. A user needs the ShowTicketComments right to see attachments added as 
part of a comment.

If this is not the problem, then I can investigate further.


Thanks!
chanel
Thank you,
Dustin
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016


Re: [rt-users] Attachments don't reach database for one user

2016-03-14 Thread Dustin Graves

> On Mar 10, 2016, at 5:09 PM, Chanel Wheeler  wrote:
> 
> Hi all,
Hi Chanel,

> I have one user that has used RT for a while with no problems. Recently, her 
> attachments to web tickets ceased coming through. I’ve watched her add  
> attachments and they appear to upload successfully but there’s no trace of 
> them in the Attachments table. We tried multiple browsers and the same thing 
> happened on each. I logged in as her on my computer and still the problem 
> happened. Another person logged in to RT on her computer and successfully 
> attached items. So it’s something to do with her account. I’ve taken a look 
> at her user record in the db and I don’t see anything amiss.
> 
> Any ideas on what I might try?
> 
> We’re running RT 4.4 and use LDAP for authentication.

I would start by checking the rights for these two users and how they might be 
different.

Can the faulty user see the missing attachment’s associated 
comment/correspondence? If the user cannot, that is why the attachment is 
missing. A user needs the ShowTicketComments right to see attachments added as 
part of a comment.

If this is not the problem, then I can investigate further.

> Thanks!
> chanel
Thank you,
Dustin


signature.asc
Description: Message signed with OpenPGP using GPGMail
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016


[rt-users] Attachments don't reach database for one user

2016-03-10 Thread Chanel Wheeler
Hi all,

I have one user that has used RT for a while with no problems. Recently, her 
attachments to web tickets ceased coming through. I've watched her add  
attachments and they appear to upload successfully but there's no trace of them 
in the Attachments table. We tried multiple browsers and the same thing 
happened on each. I logged in as her on my computer and still the problem 
happened. Another person logged in to RT on her computer and successfully 
attached items. So it's something to do with her account. I've taken a look at 
her user record in the db and I don't see anything amiss.

Any ideas on what I might try?

We're running RT 4.4 and use LDAP for authentication.

Thanks!
chanel
--
Chanel Wheeler
Programmer/Analyst
Yavapai Library Network
1120 Commerce Dr.
Prescott, AZ  86305

Phone: (928) 442-5741
chanel.whee...@yavapai.us
Open a help desk ticket

-
RT 4.4 and RTIR Training Sessions 
(http://bestpractical.com/services/training.html)
* Hamburg Germany - March 14 & 15, 2016
* Washington DC - May 23 & 24, 2016