[rt-users] URL display of "&" within ticket display

2017-02-13 Thread Scott Aber
When I paste certain URL's into a request tracker message that contain "&", "amp;" is added within the URL after the save and the URL breaks when clicking on it from within the ticket display. The outgoing mail that is sent doesn't include the added "amp;" and the URL is sent fine. This is

[rt-users] RT 4.4: Configuring escalations with various rt-crontool options, but none are working

2017-02-13 Thread Daniel Rauer
Hello everyone. Currently we are quite stuck on enabling ticket escalations based on SLA. The problem is that none of the escalation we tried seems to work: either the crontool throws errors or does basically nothing. What we did so far: - Upgrade to 4.4.1 and made sure all database migrations

[rt-users] Pre-configure users "RT At A Glance" with specific elements - Default Dashboards?

2017-02-13 Thread Cena, Stephen (ext. 300)
We have an instance of RT that is shared across three departments. Each department only needs to be able to see specific queues. Due to the way permissions work in RT, all the queues are visible. My idea to fix the "display" problem is to rewrite some of the widgets to only include the desired

[rt-users] writing extensions for an old version

2017-02-13 Thread Vinicius Fagundes
Hi, I'm starting to learn RT development. And I was designated to create a RT extension, but our RT version is too old (3.8). I couldn't find any documentation about how to do it for this version. I tried follow the current documentation but when I tried to run: perl Makefile.PL I got this

Re: [rt-users] Pre-configure users "RT At A Glance" with specific elements - Default Dashboards?

2017-02-13 Thread Kenneth Marshall
On Mon, Feb 13, 2017 at 03:53:41PM +, Cena, Stephen (ext. 300) wrote: > We have an instance of RT that is shared across three departments. Each > department only needs to be able to see specific queues. Due to the way > permissions work in RT, all the queues are visible. My idea to fix the

Re: [rt-users] Pre-configure users "RT At A Glance" with specific elements - Default Dashboards?

2017-02-13 Thread Cena, Stephen (ext. 300)
Ken - Correct, but there's one thing I left out that might clear this up: The company wants to make the RT installation "read only" to all corporate employees. This is where the "See everything" issue comes into play. Also, the way our tickets can move between queues causes extra 'visibility'

Re: [rt-users] Pre-configure users "RT At A Glance" with specific elements - Default Dashboards?

2017-02-13 Thread Thomas Bätzler
Hey Stephen, * We have an instance of RT that is shared across three departments. Each department only needs to be able to see specific queues. Due to the way permissions work in RT, all the queues are visible. My idea to fix the “display” problem is to rewrite some of the widgets to only

[rt-users] RT mailgate

2017-02-13 Thread Lorraine Johnson
Goodmorning all, I noticed that mails sent outside rt are not being delivered in the system. I think my RT- mailgate is not working. Autopreply messages are also not being received. Kindly help if you have an idea. thank you

Re: [rt-users] writing extensions for an old version

2017-02-13 Thread Martin Wheldon
Hi, If you look in the Makefile.PL you will find somethink like this requires_rt '4.0.0'; modify as required. Can I suggest that you upgrade as v3.8 reached end of life in 2014. Best Regards Martin On 2017-02-13 17:02, Vinicius Fagundes wrote: Hi, I'm starting to learn RT development.

Re: [rt-users] Pre-configure users "RT At A Glance" with specific elements - Default Dashboards?

2017-02-13 Thread Cena, Stephen (ext. 300)
Let me try to explain a little better how we're set up: We have 3 departments: Service A, Service B and Service C. The model the departments opted for was a 'dispatch' queue for all incoming tickets, and then the tickets get transferred to a work queue. Service A has 2 dispatch queues and 1

Re: [rt-users] RT mailgate

2017-02-13 Thread Thomas Bätzler
Lorraine Johnson wrote: * I noticed that mails sent outside rt are not being delivered in the system. I think my RT- mailgate is not working. Autopreply messages are also not being received. * * Kindly help if you have an idea. * * thank you You’ve got the function of

Re: [rt-users] Assets Advanced Search

2017-02-13 Thread Matt Zagrabelny
Which version of RT are you using? -m On Sun, Feb 12, 2017 at 4:09 PM, Chris McClement wrote: > Is there a way of "advanced searching" assets? For example, I'd like to > search for all assets where status != "EOL" etc. When searching tickets > there's always an advanced

Re: [rt-users] Move tickets to queue but don't allow ticket creation

2017-02-13 Thread Jeff Voskamp
On 12/02/17 07:57 AM, Keith Edmunds wrote: We have a "Triage" queue and a number of problem-type queues. Ideally, we'd like to allow tickets to only be created in the Triage queue and then be moved to the appropriate problem queue, but it appears that we need the "Create Ticket" permission on a