Re: [rt-users] Escaping '<' and '>' in comments/replies and canned responses.

2016-06-10 Thread Todd Wade

On 6/7/16 3:05 PM, Barton Chittenden wrote:

Any further thoughts on this? I'm trying to create canned responses that
involve changes to XML configuration files, and all of the tags end up
empty.


What version are you on?

I just pasted some xml in to the ticket content field, created the 
ticket, and hit reply on that transaction and it seems to be working as 
expected:


http://i.imgur.com/6OqivFd.png

This is on 4.4-trunk

Regards,


-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Los Angeles - September, 2016


Re: [rt-users] Escaping '<' and '>' in comments/replies and canned responses.

2016-06-07 Thread Barton Chittenden
On Fri, Apr 22, 2016 at 1:27 PM, Barton Chittenden <
bar...@bywatersolutions.com> wrote:

> In a further twist, html entities display correctly on the "Article
> Display" page, but when the canned response is actually *used*, I see
> html entities in the reply editor... but if I include text like ,
> 'foo' is removed in the reply editor... I have no way of including
> something that looks like an xml tag in a canned response.
>
>
Any further thoughts on this? I'm trying to create canned responses that
involve changes to XML configuration files, and all of the tags end up
empty.
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Los Angeles - September, 2016


Re: [rt-users] Escaping '<' and '>' in comments/replies and canned responses.

2016-04-22 Thread Barton Chittenden
In a further twist, html entities display correctly on the "Article
Display" page, but when the canned response is actually *used*, I see
html entities in the reply editor... but if I include text like ,
'foo' is removed in the reply editor... I have no way of including
something that looks like an xml tag in a canned response.


On Wed, Apr 20, 2016 at 8:56 AM, Barton Chittenden <
bar...@bywatersolutions.com> wrote:

> I've run into several issues in RT with the use of greater than '>' and
> less than '<' symbols in RT.
>
> One issue that I run into with some regularity is pasting the default
> mysql prompt into a ticket. For example, if I paste the following into a
> reply:
>
> mysql> select CURRENT_DATE;
> +--+
> | CURRENT_DATE |
> +--+
> | 2016-04-20   |
> +--+
> 1 row in set (0.00 sec)
>
> The first line is hidden, as if it were text quoted from a previous
> comment or reply.
>
> By and large, I simply try to avoid using un-paired '<' and '>' characters
> in replies, but I just ran into the following issue in a canned response:
>
> The following text in the canned response editor:
>
> "<>" by <>, <>,
> Barcode: <> 
>
> Renders as
>
> "<>" by <>, <>, Barcode: <>
>
> When I view it in Display.
>
> I tried using '\<' and '\>' to escape the greater than and less than
> symbols; that didn't work... using html entities did work,, but ... meh.
>
> Are there any rules for escaping '<' and '>', and, more generally, is
> there any documentation about how RT renders comments/replies and articles?
>
> Thanks,
>
> --Barton
>
-
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016