[sage-release] Re: Sage 6.2.beta3 released

2014-03-05 Thread Dima Pasechnik
On 2014-03-03, Volker Braun vbraun.n...@gmail.com wrote: Get it while it is hot! ;-) As usual you can get the beta release from the develop branch on our git server. suppose I previosuly had beta2 installed from the tarball. What is the git way to get the update? Would 'git pull' followed

[sage-release] Re: Sage 6.2.beta3 released

2014-03-06 Thread Dima Pasechnik
, March 5, 2014 2:27:57 PM UTC, Dima Pasechnik wrote: On 2014-03-05, Nathann Cohen nathan...@gmail.com javascript: wrote: Hell !! suppose I previosuly had beta2 installed from the tarball. What is the git way to get the update? Would 'git pull' followed by 'make' be enough

[sage-release] Re: Sage 6.2.beta3 released

2014-03-06 Thread Dima Pasechnik
On 2014-03-06, Volker Braun vbraun.n...@gmail.com wrote: I've never seen that error. The documentation is built at the end, so that means that Sage was built without errors. Can you try running the doctests? Perhaps some component is not working and somehow makes the

[sage-release] Re: Sage 6.2.beta3 released

2014-03-07 Thread Dima Pasechnik
On 2014-03-07, Nathann Cohen nathann.co...@gmail.com wrote: H I typed make then make doc-clean then make again, and I now have exactly the same problem as Dima O_o OSError: [reference] WARNING: Unable to fetch

[sage-release] Re: Sage 6.2.beta3 released

2014-03-07 Thread Dima Pasechnik
On 2014-03-07, Nathann Cohen nathann.co...@gmail.com wrote: Nathann, congratulations on creating the first Sage-docs tree eating git worm ;-) Come on, I just used git commit --amend to change a commit message. I didn't kill anyone (I hope) :-P all we know at the moment is that the worm likes

[sage-release] Re: Sage 6.2.beta3 released

2014-03-07 Thread Dima Pasechnik
On 2014-03-07, Volker Braun vbraun.n...@gmail.com wrote: I unpacked the sage-6.2.beta3 tarball and ran make make doc-clean make and it worked without error. Somebody who can reproduce the failure should investigate... try switching to the branch of http://trac.sagemath.org/ticket/15521 and

[sage-release] Re: Sage 6.2.beta3 released

2014-03-10 Thread Dima Pasechnik
On 2014-03-10, Nathann Cohen nathann.co...@gmail.com wrote: By this bug, you mean even after a make distclean it does not compile? Or just get to a step where make doesn't work, the latter is probably easy since some packages can trip over headers that were left over by old / incomplete

[sage-release] Re: Sage 6.2.beta4 released

2014-03-12 Thread Dima Pasechnik
I cannot seem to be able to build on OSX 10.6.8 and the usual Sage-supplied gcc even if I do make distclean first. It gets stuck at Singular: ... g++ -O2 -g -fPIC -DLIBSINGULAR -I.. -I/usr/local/src/sage/sage-6.1.rc0/local -pipe -fno-implicit-templates -I..

[sage-release] Re: Sage 6.2.beta4 released

2014-03-12 Thread Dima Pasechnik
On 2014-03-12, Dima Pasechnik dimp...@gmail.com wrote: I cannot seem to be able to build on OSX 10.6.8 and the usual Sage-supplied gcc even if I do make distclean first. It gets stuck at Singular: oops, sorry for noise - wrong PATH, wrong libtool... Please ignore the previous message. -- You

[sage-release] Re: Sage 6.2.beta4 released

2014-03-17 Thread Dima Pasechnik
On 2014-03-17, kcrisman kcris...@gmail.com wrote: On OS X 10.4 PPC, I get the following error. Incidentally, I'm used to GAP compiling toward the very end of the process on this machine, so I was surprised it showed up relatively early. I'd be grateful for any hints; looks like includes

[sage-release] Re: Sage 6.2.beta4 released

2014-03-18 Thread Dima Pasechnik
On 2014-03-18, kcrisman kcris...@gmail.com wrote: On Monday, March 17, 2014 4:19:26 PM UTC-4, Dima Pasechnik wrote: On 2014-03-17, kcrisman kcri...@gmail.com javascript: wrote: On OS X 10.4 PPC, I get the following error. Incidentally, I'm used to GAP compiling toward the very end

[sage-release] Re: Sage 6.2.beta4 released

2014-03-18 Thread Dima Pasechnik
On 2014-03-18, kcrisman kcris...@gmail.com wrote: On Monday, March 17, 2014 4:19:26 PM UTC-4, Dima Pasechnik wrote: On 2014-03-17, kcrisman kcri...@gmail.com javascript: wrote: On OS X 10.4 PPC, I get the following error. Incidentally, I'm used to GAP compiling toward the very end

[sage-release] Re: What to do to build 6.3.beta3?

2014-06-07 Thread Dima Pasechnik
On 2014-06-07, Simon King simon.k...@uni-jena.de wrote: Hi, I was creating a new trac ticket, thus I got sage-6.3.beta3 as starting point. However, ecl does not build. I found the recommendation to simply do sage -f maxima and sage -f ecl. While re-building maxima works, re-building ecl

[sage-release] Re: Sage 6.3.beta2 released

2014-06-08 Thread Dima Pasechnik
On 2014-06-07, John H Palmieri jhpalmier...@gmail.com wrote: On Saturday, June 7, 2014 11:49:43 AM UTC-7, Volker Braun wrote: These are all due to the Singular interface.. I also see them relatively often but usually its only one or two that fail. There was a bug in pexpect that got fixed

[sage-release] weird doctest output for beta3

2014-06-08 Thread Dima Pasechnik
the doctesting tests .pyc file for me, for some reason. To test #16440, I did run ./sage -bt --long --optional=sage,gap_packages,database_gap src/sage/* and at the very end I saw: sage -t --long src/sage/version.py [0 tests, 0.00 s] sage -t --long src/sage/version.pyc AttributeError

[sage-release] Re: Sage 6.3.beta8 released

2014-08-02 Thread Dima Pasechnik
On 2014-08-02, Jan Keitel jocalareanetw...@gmail.com wrote: I can't build this on a 2013 MacBook Air running Mac Os 10.9.4, because Singular fails to build: Error building Sage. The following package(s) may have failed to build: package: singular-3.1.6.p3 log file:

[sage-release] Re: sage-6.3

2014-08-05 Thread Dima Pasechnik
On 2014-08-04, François Bissey francois.bis...@canterbury.ac.nz wrote: On Mon, 04 Aug 2014 14:49:20 Jeroen Demeyer wrote: On 2014-08-04 13:52, Volker Braun wrote: IMHO it is a reasonable burden to make distclean once in a while to back out of broken packages during the beta cycle. As long

[sage-release] Re: Sage-6.3.rc0 released

2014-08-05 Thread Dima Pasechnik
On 2014-08-05, Dima Pasechnik dimp...@gmail.com wrote: On 2014-08-04, Volker Braun vbraun.n...@gmail.com wrote: --=_Part_1781_1329544834.1407173980834 Content-Type: text/plain; charset=UTF-8 Here is the first release candidate. Please give it a test and report any build problems

[sage-release] Re: Sage 6.3 released

2014-08-15 Thread Dima Pasechnik
On 2014-08-15, Volker Braun vbraun.n...@gmail.com wrote: --=_Part_231_1213945713.1408086090167 Content-Type: text/plain; charset=UTF-8 On Friday, August 15, 2014 6:25:05 AM UTC+1, kcrisman wrote: That's silly, especially because often someone else writes your name and in the deluge of

[sage-release] Re: Sage 6.4.beta0 released

2014-08-15 Thread Dima Pasechnik
On 2014-08-15, kcrisman kcris...@gmail.com wrote: --=_Part_8_1811642137.1408080761253 Content-Type: text/plain; charset=UTF-8 See the develop git branch or the source tarball at http://boxen.math.washington.edu/home/release/sage-6.4.beta0.tar.gz When I updated to 6.3, I did

[sage-release] Re: Sage 6.4.beta1 released

2014-08-21 Thread Dima Pasechnik
On 2014-08-20, Jeroen Demeyer jdeme...@cage.ugent.be wrote: On 2014-08-20 12:28, Volker Braun wrote: d2e0ebe Trac #16714: Add a matrix of constraints in a LP There are doctest failures when cbc is installed, see #16858. same applies to the case when GUROBI is installed. But it was always teh

[sage-release] Re: You don't really think that Sage has failed, do you? (a comment about it)

2014-08-26 Thread Dima Pasechnik
On 2014-08-26, kcrisman kcris...@gmail.com wrote: --=_Part_7_243754084.1409079111786 Content-Type: text/plain; charset=UTF-8 Two remarks: 1. It makes no sense for this post to go to the sage-release mailing list. It should go to sage-flame (or maybe sage-devel). It Here is a

[sage-release] Re: Sage 6.4.rc2 released

2014-11-12 Thread Dima Pasechnik
On 2014-11-11, Volker Braun vbraun.n...@gmail.com wrote: --=_Part_731_26183688.1415716496266 Content-Type: text/plain; charset=UTF-8 Get the new develop branch or download the source tarball: http://sage.sagedev.org/home/release/sage-6.4.rc2.tar.gz Please test, in particular the

[sage-release] Re: Sage 6.4.rc2 released

2014-11-12 Thread Dima Pasechnik
On 2014-11-12, 'luisfe' via sage-release sage-release@googlegroups.com wrote: --=_Part_372_48400364.1415800345213 Content-Type: text/plain; charset=UTF-8 Updating from rc1. In the new notebook, if I create a new 3d plot I get a big red square, clicking on the rotate button and the

[sage-release] Re: Sage 6.5.beta2 released

2014-12-05 Thread Dima Pasechnik
On 2014-12-05, Justin C. Walker jus...@mac.com wrote: On Dec 4, 2014, at 11:48 , Volker Braun wrote: As usual, get the develop git branch or the self-contained tarball at http://boxen.math.washington.edu/home/release/pub/sage-6.5.beta2.tar.gz Built from the tarball, w/o problems. All

[sage-release] Re: Sage 6.6.beta5 released

2015-03-14 Thread Dima Pasechnik
On 2015-03-13, William Stein wst...@gmail.com wrote: On Fri, Mar 13, 2015 at 4:57 AM, Volker Braun vbraun.n...@gmail.com wrote: As usual, get the develop branch or the source tarball from http://www.sagemath.org/download-latest.html On 64-bit Ubuntu 14.10, make ptestlong yields one doctest

[sage-release] Re: Sage 6.6.beta1 released

2015-02-23 Thread Dima Pasechnik
On 2015-02-23, John Cremona john.crem...@gmail.com wrote: On 22 February 2015 at 22:27, Volker Braun vbraun.n...@gmail.com wrote: Looks like your system git is incompatible with the Sage libcrypto and the dev scripts launch git without sage-native-execute. THat would be quite serious -- this

Re: [sage-release] Sage 6.7.beta3 released

2015-05-02 Thread Dima Pasechnik
On Friday, 1 May 2015 21:05:56 UTC+1, Justin C. Walker wrote: On Apr 27, 2015, at 21:56 , Volker Braun wrote: As usual, pull the updated git develop branch. The source tarball will appear on http://www.sagemath.org/download-latest.html once the mirrors have caught up Built w/o

Re: [sage-release] Sage 6.7.beta3 released

2015-05-02 Thread Dima Pasechnik
On Saturday, 2 May 2015 17:33:15 UTC+1, Justin C. Walker wrote: On May 2, 2015, at 02:08 , Dima Pasechnik wrote: On Friday, 1 May 2015 21:05:56 UTC+1, Justin C. Walker wrote: On Apr 27, 2015, at 21:56 , Volker Braun wrote: As usual, pull the updated git develop branch

[sage-release] Re: Sage 6.7.beta4 released

2015-05-07 Thread Dima Pasechnik
there are few open pull requests in https://github.com/sagemath/sage/pulls (some of which are trivial typo fixes and can be merged instantly...) Is this going to happen, or is it meant to be done differently? Dima On Tuesday, 5 May 2015 20:59:48 UTC+1, Volker Braun wrote: As usual, get the

Re: [sage-release] Sage 6.7.beta4 released

2015-05-13 Thread Dima Pasechnik
On Wednesday, 13 May 2015 18:32:58 UTC+1, Rob Beezer wrote: Rebuilding on SageMathCloud due to change of underlying hardware (now Intel Haskell). Wow, lazy functional hardware from Intel! It probably needs a kick in the butt now and then :-) Four failures on first run, the last three

[sage-release] Re: Sage 6.7.beta0 released

2015-04-16 Thread Dima Pasechnik
chmod 700 ~/.sage/.python-eggs should fix this On Thursday, 16 April 2015 09:58:52 UTC+1, Sébastien Labbé wrote: On ubuntu 14.04 64 bit make ptestlong gives 266 files with 1 failing doctest, always the same warning: sage -t --long src/doc/de/thematische_anleitungen/sage_gymnasium.rst

[sage-release] Re: Sage 6.8.beta4 released

2015-06-16 Thread Dima Pasechnik
On Tuesday, 16 June 2015 07:24:45 UTC+1, Dima Pasechnik wrote: It appears that on Fedora 20 gcc version 4.8.3 20140911 (Red Hat 4.8.3-7) cannot build a working beta4. I did the usual update, and the resulting Sage does not start. I built from a fresh git clone, and the resulting Sage

[sage-release] Re: Sage 6.8.beta7 released

2015-07-03 Thread Dima Pasechnik
Mirrors crap: build failed as the network went down; restarting resulted in build completing, but it did not build a number of packages. If I try to reinstall them, I get IOError: [Errno 404] Not Found: '//www.mirrorservice.org/sites/www.sagemath.org//spkg/archive/list' Error: failed to

Re: [sage-release] Re: Sage 6.8.beta7 released

2015-07-04 Thread Dima Pasechnik
stringPict ImportError: No module named sympy.printing.pretty.stringpict ``` Mac OSX. Apologies also if I'm missing details that could be helpful. Vince On 4 July 2015 at 22:13, Dima Pasechnik dim...@gmail.com wrote: On Saturday, 4 July 2015 21:02:58 UTC+1, Nathann

Re: [sage-release] Re: Sage 6.8.beta7 released

2015-07-04 Thread Dima Pasechnik
. Vince On 4 July 2015 at 22:13, Dima Pasechnik dim...@gmail.com javascript: wrote: On Saturday, 4 July 2015 21:02:58 UTC+1, Nathann Cohen wrote: Helloo ! It looks like I have a stale list of (pseudo)packages - perhaps each call to sage -i blah duly puts blah

Re: [sage-release] Re: Sage 6.8.beta7 released

2015-07-04 Thread Dima Pasechnik
On Saturday, 4 July 2015 21:02:58 UTC+1, Nathann Cohen wrote: Helloo ! It looks like I have a stale list of (pseudo)packages - perhaps each call to sage -i blah duly puts blah on the list ?! It seems to be something like that: the message that you see which reports which

Re: [sage-release] Re: Sage 6.8.beta7 released

2015-07-05 Thread Dima Pasechnik
fire in case this situation is helpful... V On 4 July 2015 at 23:08, Dima Pasechnik dim...@gmail.com javascript: wrote: On Saturday, 4 July 2015 22:41:35 UTC+1, Vincent Knight wrote: On 4 Jul 2015 10:36 pm, Volker Braun vbrau...@gmail.com wrote: Looks like sympy

[sage-release] Re: Sage 6.8.beta7 released

2015-07-04 Thread Dima Pasechnik
Actually, did we ever have an hg spkg?! There was/is mercurial spkg for sure... It looks like I have a stale list of (pseudo)packages - perhaps each call to sage -i blah duly puts blah on the list ?! This is how the log of that ill-fated build ends:

[sage-release] Re: list of supported platforms

2015-08-05 Thread Dima Pasechnik
On Wednesday, 5 August 2015 09:20:49 UTC+1, Samuel Lelievre wrote: Hi sage-release, The list of supported platforms at http://wiki.sagemath.org/SupportedPlatforms by the way, it certainly needs a software update: this message *No jsMath TeX fonts found* -- using image fonts

Re: [sage-release] Re: Sage 6.8.rc0 released

2015-07-17 Thread Dima Pasechnik
On Friday, 17 July 2015 11:16:52 UTC+1, Jeroen Demeyer wrote: On 2015-07-17 11:49, Dima Pasechnik wrote: Past attempts to install non-existing packages (say, blah) result in interrupts to the build No, this is a misinterpretation. It was something else which failed. anyhow

[sage-release] Re: Sage 6.8.rc0 released

2015-07-17 Thread Dima Pasechnik
Past attempts to install non-existing packages (say, blah) result in interrupts to the build, with error message saying that one cannot install blah. On Thursday, 16 July 2015 00:10:05 UTC+1, Volker Braun wrote As always, you can get the latest beta version from the develop git branch.

[sage-release] Re: Sage 6.8.beta8 released

2015-07-11 Thread Dima Pasechnik
it works (for me at least) if you also have gap_packages installed. So it seems that the fix is trivial, just add gap_packages into the corresponding # optional tags Dima On Saturday, July 11, 2015 at 7:23:56 PM UTC+1, Volker Braun wrote: I can confirm that these fail with database_gap

Re: [sage-release] Re: Sage 6.9.rc2 released

2015-10-05 Thread Dima Pasechnik
On Monday, 5 October 2015 18:15:23 UTC-7, HG wrote: > > Hi, > I build sage 6.9.rc2 on ubuntu 15.04 and got it working but then latex was > n't working in ipython notebook command ouput was between frame like a > table. > By the way a question : Sage 6.9 rc2 can't be otbain with git clone ? >

[sage-release] Re: Sage-6.10.rc2 released

2015-12-17 Thread Dima Pasechnik
Hi Volker, could we please, please get #19712 into 6.10? It is very local, in nature, change, and fixes some crashes and inconsistencies in our new code in sage/graphs/strongly_regular_db.pyx. Thanks, Dima On Wednesday, 16 December 2015 20:19:31 UTC, Volker Braun wrote: > > As always, you

Re: [sage-release] Re: Sage-6.10.rc1 binaries test

2015-12-17 Thread Dima Pasechnik
On Thursday, 17 December 2015 19:30:51 UTC, Volker Braun wrote: > > The patching can be done faster, but it has to work first ;-) Also I'm > pretty sure that it even now is much faster than the unpacking of the > tarball. In any case I've added a message. > unless you've already sped it up,

Re: [sage-release] Sage-6.10.rc1 released

2015-12-15 Thread Dima Pasechnik
this was a result of b2094a8a (Jeroen Demeyer 2015-11-18 15:53:34 +0100 1402) which did change description = G._gap_().StructureDescription().__str__() to description = str(G._gap_().StructureDescription()) but these calls are not 100% the same: sage:

Re: [sage-release] Sage-6.10.rc1 released

2015-12-16 Thread Dima Pasechnik
On Wednesday, 16 December 2015 09:21:21 UTC, Jeroen Demeyer wrote: > > On 2015-12-16 01:01, Dima Pasechnik wrote: > > this was a result of > > b2094a8a (Jeroen Demeyer 2015-11-18 15:53:34 +0100 1402) > > > > which did change > > > > de

Re: [sage-release] Sage 7.0.beta3 released

2016-01-08 Thread Dima Pasechnik
On Friday, 8 January 2016 07:04:31 UTC, HG wrote: > > I have compiled sage-7.0 beta 2 allright. But beta 3 doesn't compile. > It's just for information because I am on ubuntu 16.04 alpha and a > recent update may have cause this. I have ppl1.1 but curiously I can't > compile sage 6.10

[sage-release] Re: Sage 7.0.beta3 released

2016-01-08 Thread Dima Pasechnik
On Friday, 8 January 2016 09:51:18 UTC, HG wrote: > > Leif sorry, I don't know what you mean : > Do I have to type your proc in a shell ? > At the moment I am trying to compile on an ubuntu session 15.10 to see if > I got the same result. > the install logs live in the directory logs/ of your

[sage-release] Re: Sage 6.10 released

2015-12-20 Thread Dima Pasechnik
On Sunday, 20 December 2015 20:22:56 UTC, Marc Mezzarobba wrote: > > Volker Braun wrote: > > a1b60f2 Updated Sage version to 6.10 > > $ ./sage -t src/sage/typeset/ascii_art.py > works for me. Have you sacrificed a black chicken, ran make, etc? -- You received this message because you are

Re: [sage-release] 7.3.beta2: Compilation failed with Brial

2016-05-31 Thread Dima Pasechnik
I presume it would be more productive to work on gcc 6.1 support in Sage, rather than on building old gcc... Did you try reporting the brial problem upstream? https://github.com/BRiAl/BRiAl On Tuesday, May 31, 2016 at 3:43:23 PM UTC+1, Johan S. R. Nielsen wrote: > > > indeed, just build with

Re: [sage-release] 7.3.beta2: Compilation failed with Brial

2016-05-31 Thread Dima Pasechnik
indeed, just build with SAGE_INSTALL_GCC set, as described in http://doc.sagemath.org/html/en/installation/source.html#environment-variables On Tuesday, May 31, 2016 at 1:17:04 PM UTC+1, John H Palmieri wrote: > > Can you force Sage to build its own GCC and use that instead? > > > On Tuesday,

[sage-release] Re: Sage 7.1.beta3 released

2016-02-12 Thread Dima Pasechnik
Hi Volker, could you build and post somewhere the app version of OSX 10.11, for testing the installation? On Thursday, February 11, 2016 at 9:02:43 PM UTC, Volker Braun wrote: > > As always, you can get the latest beta version from the "develop" git > branch. Alternatively, the self-contained

[sage-release] arando down due to a hardware issue

2016-02-12 Thread Dima Pasechnik
Our 32-bit buildbot arando was making noises sounding like a dying fan. I've had to shut down it until I have time to fix it. Dima -- You received this message because you are subscribed to the Google Groups "sage-release" group. To unsubscribe from this group and stop receiving emails from

Re: [sage-release] 7.1.beta1 released

2016-01-28 Thread Dima Pasechnik
On Friday, 29 January 2016 05:13:03 UTC, Rob Beezer wrote: > > Did this get kicked out to the mirrors? > > Nine hours on, and no luck at MIT nor Simon Fraser. But perhaps I'm just > impatient. > at least here it has arrived:

Re: [sage-release] Re: error: Cannot perform incremental update

2016-01-24 Thread Dima Pasechnik
On Sunday, 24 January 2016 12:09:27 UTC, Nathann Cohen wrote: > > > > The definition of insanity is doing the same thing over and over again, > but expecting different results ;-) > > That's what I should answer the next guy who will try the "it's > irresponsible to not vote" lecture on me. >

Re: [sage-release] Re: error: Cannot perform incremental update

2016-01-25 Thread Dima Pasechnik
On Monday, 25 January 2016 07:31:02 UTC, Nathann Cohen wrote: > > >> I am sure if we were electing the best Sage bugs, you won't abstain... > > I vote for http://trac.sagemath.org/ticket/10609 > > Come on, it's ridiculous alright but you cannot vote for it: it's not > even a Sage bug. > A

Re: [sage-release] Re: Sage 7.0 released

2016-01-26 Thread Dima Pasechnik
On Tuesday, 26 January 2016 17:23:48 UTC, kcrisman wrote: > > Untested is broken: > http://ask.sagemath.org/question/32330/sage-notebook-is-not-working/ > This is via the .app bundle, I think. What could have changed to make > this not work? > is it notebook-specfic, or a not working OSX

Re: [sage-release] Sage 7.2.beta1 released

2016-03-28 Thread Dima Pasechnik
On Monday, March 28, 2016 at 11:29:08 PM UTC+1, vdelecroix wrote: > > Yes I do. I see. Having plot code that is sensitive to the LP solver is > bad. Is there already a ticket opened? > I always maintained that the design when installation of a solver makes it default is bad, but to no

[sage-release] Re: Sage 7.0 released

2016-03-08 Thread Dima Pasechnik
the following in your log >C compiler: /usr/bin/clang >C compiler version: >Apple LLVM version 6.0 (clang-600.0.57) (based on LLVM 3.5svn) looks very strange; Sage is not built using clang... On Tuesday, January 19, 2016 at 2:21:53 PM UTC, Volker Braun wrote: > > The "master" git branch has

[sage-release] Re: Sage 7.2.beta6 released

2016-04-29 Thread Dima Pasechnik
On Friday, April 29, 2016 at 10:41:51 AM UTC+1, Dima Pasechnik wrote: > > docs build for me (on Linux), with MAKE="make -j4" > For me the log starts as follows (comparing to your log, it seems that you > do -j1, i.e. single-thread): > > Building reference manua

[sage-release] arando back online [was: Re: arando down due to a hardware issue]

2016-05-09 Thread Dima Pasechnik
Arando is back online. Please feel free to restart the bots there. Cheers, Dima On Friday, February 12, 2016 at 5:33:33 PM UTC, Dima Pasechnik wrote: > > Our 32-bit buildbot arando was making noises sounding like a dying fan. > I've had to shut down it > until I have time to fix

[sage-release] were ubuntu 14.04 binaries of 7.0 meant to work on any x86_64 CPU?

2016-05-11 Thread Dima Pasechnik
It appears that this report https://groups.google.com/d/msg/sage-support/fseE3_tQoQE/BCbFrskFCgAJ is an indication that these binaries are slightly broken; namely, an optional package csdp compiled on it gets faulty executables (they use blas/lapack/atlas in a nontrivial way). Could it be that

Re: [sage-release] Sage 7.2.rc1 released

2016-05-10 Thread Dima Pasechnik
On Tuesday, May 10, 2016 at 3:05:36 AM UTC+1, Justin C. Walker wrote: > > > > On May 7, 2016, at 05:26 , Volker Braun > wrote: > > > > As always, you can get the latest beta version from the "develop" git > branch. Alternatively, the self-contained source tarball is at

Re: [sage-release] Sage 7.3 released

2016-08-05 Thread Dima Pasechnik
On Friday, August 5, 2016 at 7:49:52 AM UTC+1, leif wrote: > > leif wrote: > > Volker Braun wrote: > >> The "master" git branch has been updated to Sage-7.3. As always, you > can > >> get the latest beta version from the "develop" git branch. > >> Alternatively, the self-contained source

[sage-release] Re: Sage 7.6.beta1 released

2017-02-01 Thread Dima Pasechnik
make distclean ? On Wednesday, February 1, 2017 at 4:45:04 PM UTC, kcrisman wrote: > > I hadn't upgraded for a while, git pull develop and I get this failure. > This is on Mac 10.11.6, previous builds have gone fine, but I note this is > not from scratch. make -j2 if it matters. > > $ cat

[sage-release] Re: Sage 7.6.beta2 released

2017-02-02 Thread Dima Pasechnik
On Thursday, February 2, 2017 at 12:30:04 PM UTC, Emmanuel Charpentier wrote: > > On Debioan testing (Core17 + 16 GB RAM), passes ptestlong with one failure > (sage -t --long --warn-long 109.4 src/sage/homology/simplicial_complex.py ) > which is transient (passes with no error when run

[sage-release] Re: Sage 7.6.beta0 released

2017-01-23 Thread Dima Pasechnik
On two systems I built this beta I had to remove ~/.sage/, as with it present Sage just dies. (unless started with ---nodotsage). People with stuff in ~/.sage/ will not be happy. On Saturday, January 21, 2017 at 5:57:13 PM UTC, Volker Braun wrote: > > As always, you can get the latest beta

[sage-release] Re: Sage 7.6.beta0 released

2017-01-24 Thread Dima Pasechnik
On Tuesday, January 24, 2017 at 3:55:57 AM UTC, kcrisman wrote: > > > > > On two systems I built this beta I had to remove ~/.sage/, >> as with it present Sage just dies. (unless started with ---nodotsage). >> >> People with stuff in ~/.sage/ will not be happy. >> >> >>> > Like, say, the

Re: [sage-release] Sage 7.6.beta4 released

2017-02-22 Thread Dima Pasechnik
just in case, these tests work for me, so it could be that sage4 has some weirdness built-in... On Wednesday, February 22, 2017 at 8:46:38 AM UTC, Jeroen Demeyer wrote: > > I just noticed that this doctest was actually introduced in 7.6.beta4 in > #22174, so bisecting will not help... > --

[sage-release] Re: Why is gcc built?

2017-02-22 Thread Dima Pasechnik
I think there is nothing wrong there, it is typical configure output, checking for various options that are not crucial. Looks like gcc spkg will not be built, just as you want. -- You received this message because you are subscribed to the Google Groups "sage-release" group. To unsubscribe

Re: [sage-release] Re: Why is gcc built?

2017-02-23 Thread Dima Pasechnik
one can still have something like: --with-everything # build everything --with-everythingneeded # build missing etc... to encode the most usual cases. -- You received this message because you are subscribed to the Google Groups "sage-release" group. To unsubscribe from this group and stop

[sage-release] Re: Sage 7.6.beta5 released

2017-03-01 Thread Dima Pasechnik
oh, right, sorry, I didn't pay attention. Indeed it works for me in console mode, but in jupyter nb. (where I don't see any warnings or images). On js console I see Failed to load resource: the server responded with a status of 404 (Not Found) OrbitControls.js Failed to load resource: the

[sage-release] Re: Sage 7.5.beta1 released

2016-11-05 Thread Dima Pasechnik
On Saturday, November 5, 2016 at 6:22:22 PM UTC, Emmanuel Charpentier wrote: > > Second attempt, same problem. This is apparently Trac#21782 > , which I've upgraded to blocker. > > Any suggestion to get unstuck ? > this:

Re: [sage-release] Sage 7.5.beta1 released

2016-11-05 Thread Dima Pasechnik
On Saturday, November 5, 2016 at 10:23:09 PM UTC, François wrote: > > Hum… I was reading the patch in reverse… It changes the correct > form of “-Wl,-r” to “-r”. Probably so that it is ignored by gcc > altogether. That probably generate warnings though. > > I can see why gcc complains when

[sage-release] Re: Sage 7.4.rc2 released

2016-10-17 Thread Dima Pasechnik
On Sunday, October 16, 2016 at 8:33:44 AM UTC, Dima Pasechnik wrote: > > builds on OSX 10.12 (after make distclean); running tests now > all tests pass (few needed to be re-run, due to timeouts) Also, builds OK on Arch. > > On Saturday, October 15, 2016 at 11:09:23 AM UT

Re: [sage-release] Re: Sage 7.4.rc2 released

2016-10-17 Thread Dima Pasechnik
On Monday, October 17, 2016 at 7:03:11 AM UTC, Martin R wrote: > > complete from scratch. > > So, a better question is: is there an estimate for how long a complete > build, excluding or including documentation I don't care) should take on my > machine (cpuinfo see above, using MAKE="make

[sage-release] Re: Sage 7.4 released

2016-10-21 Thread Dima Pasechnik
On Tuesday, October 18, 2016 at 10:23:20 PM UTC, Volker Braun wrote: > > The "master" git branch has been updated to Sage-7.4. As always, you can > get the latest beta version from the "develop" git branch. Alternatively, > the self-contained source tarball is at >

[sage-release] Re: OSX 10.12 openssl and other problems

2016-11-23 Thread Dima Pasechnik
pull a 3.5mm > plug here and ship Python without ssl in the next version? > isn't it already broken (no TLS 1.2 support in urllib)? > > On Tuesday, November 22, 2016 at 11:24:19 PM UTC+1, Dima Pasechnik wrote: >> >> 1) In the Xcode for OSX 10.12, there is no more openss

[sage-release] OSX 10.12 openssl and other problems

2016-11-22 Thread Dima Pasechnik
1) In the Xcode for OSX 10.12, there is no more openssl. It used to be in some obscure directory, see build/pkgs/python2/spkg-install, the line cp -rp "${xcode}"/Toolchains/XcodeDefault.xctoolchain/usr/lib/swift-migrator/sdk/MacOSX.sdk/usr/include/openssl Such a path is no longer there, there

Re: [sage-release] Re: Sage 7.5.beta1 released

2016-11-02 Thread Dima Pasechnik
On Wednesday, November 2, 2016 at 9:08:04 AM UTC, Jeroen Demeyer wrote: > > On 2016-11-02 09:37, Dima Pasechnik wrote: > > build failure at fpylll due to undeclared dependency on cysignals > > This is https://trac.sagemath.org/ticket/21795 > > > somehow, cygsignals

[sage-release] Re: Sage 7.4.rc1 released

2016-10-13 Thread Dima Pasechnik
builds and runs all tests on Arch Linux x86_64. On Wednesday, October 12, 2016 at 10:06:31 PM UTC, Volker Braun wrote: > > As always, you can get the latest beta version from the "develop" git > branch. Alternatively, the self-contained source tarball is at >

[sage-release] Re: Sage 7.4.rc2 released

2016-10-16 Thread Dima Pasechnik
builds on OSX 10.12 (after make distclean); running tests now On Saturday, October 15, 2016 at 11:09:23 AM UTC, Volker Braun wrote: > > As always, you can get the latest beta version from the "develop" git > branch. Alternatively, the self-contained source tarball is at >

[sage-release] Re: Sage 7.5.beta6 released

2016-12-10 Thread Dima Pasechnik
On Saturday, December 10, 2016 at 10:13:58 AM UTC, fchap...@gmail.com wrote: > > Hello > > it seems that once again somebody broke the python3 compatibility of the > scripts: > > [sagelib-7.5.beta6] File > "/home/chapoton/sage3/src/sage_setup/autogen/__init__.py", line 9, in > autogen_all >

[sage-release] Re: Sage 7.5.rc2 released

2017-01-06 Thread Dima Pasechnik
I see a reproducible (since few previous betas, in fact) error: (sometimes it's only one [Errno 2], sometimes two) sage -t --warn-long 96.3 src/sage/homology/simplicial_complex.py ** File

Re: [sage-release] Re: Sage 8.0.beta1 released

2017-04-10 Thread Dima Pasechnik
Could it be that you are behind a firewall that blocks git:// port? (we have seen this several times...) Switch to https or ssh. -- You received this message because you are subscribed to the Google Groups "sage-release" group. To unsubscribe from this group and stop receiving emails from it,

[sage-release] Re: Sage 8.0.beta1 released

2017-04-09 Thread Dima Pasechnik
On Sunday, April 9, 2017 at 12:06:15 AM UTC+1, Rebecca Miller wrote: > > Hi Volker, > > I'm unable to pull this new version using git. Has anyone else had a > similar problem? Worked for me. From where are you pulling, and how? what does your git remote -v say? > > > Thanks, >

[sage-release] Re: Sage 7.6.beta5 released

2017-03-01 Thread Dima Pasechnik
On Wednesday, March 1, 2017 at 8:13:36 PM UTC, Eric Gourgoulhon wrote: > > Hi, > > It seems that the three.js viewer is broken in this release: running > show(sphere(), viewer='threejs') > in a Jupyter notebook results in a blank scene, along with the following > warnings: > [W 21:07:03.945

[sage-release] Re: Sage 8.0.rc0 released

2017-07-02 Thread Dima Pasechnik
Is libvpx a new Sage dependency? For me building rc0 fails on Fedora 25 with [dochtml] File "sage/matrix/matrix_mod2_dense.pxd", line 4, in init sage.matrix.matrix_integer_dense (build/cythonized/sage/matrix/matrix_integer_dense.c:55469) [dochtml] ImportError: libvpx.so.2: cannot open shared

Re: [sage-release] Sage 8.0.rc0 released

2017-07-02 Thread Dima Pasechnik
lease/v6exlZDkXGc/DLctGMW7NDsJ > > for example. There are a few more if you search. > > > On 2/07/2017, at 18:28, Dima Pasechnik <dim...@gmail.com > > wrote: > > > > Is libvpx a new Sage dependency? For me building rc0 fails on Fedora 25 > with > >

Re: [sage-release] Re: Sage 8.0.beta10 released

2017-06-12 Thread Dima Pasechnik
this should be fixed by https://trac.sagemath.org/ticket/23225 please review On Monday, June 12, 2017 at 1:44:58 PM UTC+1, tsc...@ucdavis.edu wrote: > > > > On Sunday, June 11, 2017 at 11:45:57 PM UTC-5, François wrote: >> >> On 12/06/17 16:20, tsc...@ucdavis.edu wrote: >> > >> > Given what

[sage-release] Re: Sage 8.1.beta6 released

2017-10-02 Thread Dima Pasechnik
I have opened a blocker https://trac.sagemath.org/ticket/23956 to deal with the ECL extension (or prompt_toolkit, depending on the point of view) bug, Essentially the same bug is here: https://trac.sagemath.org/ticket/22766 IMHO a two-liner triggering a hard segfault is bad, and must be fixed.

[sage-release] Sage 8.1.rc3 released

2017-11-24 Thread Dima Pasechnik
Actually I think #24085 is fixed - pending final checks, but everything points in this direction for sure. -- You received this message because you are subscribed to the Google Groups "sage-release" group. To unsubscribe from this group and stop receiving emails from it, send an email to

Re: [sage-release] Sage 8.2.beta0 released

2017-12-16 Thread Dima Pasechnik
On Sat, Dec 16, 2017 at 4:41 AM, kcrisman wrote: > > > >> One thing we can take here is that perhaps we should think more about what >> meta-info should go into commits. >> One useful, and currently missing, field would the tag of the release it >> was merged in. > > > A year

Re: [sage-release] Sage 8.2.beta0 released

2017-12-15 Thread Dima Pasechnik
branches that they (the pointers to them) should be kept in a database :-) On 15 Dec 2017 21:26, "Andrey Novoseltsev" <novos...@gmail.com> wrote: > On Friday, 15 December 2017 03:48:43 UTC-7, Dima Pasechnik wrote: >> >> >> >> On Friday, December 15, 2

Re: [sage-release] Sage 8.2.beta0 released

2017-12-14 Thread Dima Pasechnik
> that make sense to trac I guess. > > At some point I proposed to have such a mirror as I am running now privately to be in https://github.com/sagemath organisation, but have not heard back from anyone... > François > > > On 14/12/2017, at 22:30, Dima Pasec

Re: [sage-release] Sage 8.2.beta0 released

2017-12-14 Thread Dima Pasechnik
On Fri, Dec 15, 2017 at 5:34 AM, Andrey Novoseltsev <novos...@gmail.com> wrote: > On Thursday, 14 December 2017 07:19:26 UTC-7, Dima Pasechnik wrote: >> >> On Thu, Dec 14, 2017 at 12:38 PM, Volker Braun <vbrau...@gmail.com> wrote: >> > I thought we usually

Re: [sage-release] Sage 8.2.beta0 released

2017-12-15 Thread Dima Pasechnik
On Friday, December 15, 2017 at 7:26:24 AM UTC, Dima Pasechnik wrote: > > On Fri, Dec 15, 2017 at 5:34 AM, Andrey Novoseltsev <novos...@gmail.com> > wrote: > > On Thursday, 14 December 2017 07:19:26 UTC-7, Dima Pasechnik wrote: > >> > >> On Thu, Dec 14

Re: [sage-release] Sage 8.2.beta0 released

2017-12-14 Thread Dima Pasechnik
On Thu, Dec 14, 2017 at 12:38 PM, Volker Braun wrote: > I thought we usually push to github as part of a git hook on trac, though I > haven't checked. on https://github.com/sagemath/sage we only have develop and master branches, rather than the full mirror. In fact, is

  1   2   3   >