[sage-release] Re: Sage 8.9.rc0 released

2019-09-15 Thread Sébastien Labbé
Runing ptestlong with various optional and external packages, I get

Using 
--optional=awali,bliss,cbc,ccache,cryptominisat,dot2tex,e_antic,external,glucose,memlimit,normaliz,notedown,openssl,pandoc_attributes,pycosat,pynormaliz,python2,rst2ipynb,sage
--
sage -t --long src/sage/sat/boolean_polynomials.py  # 1 doctest failed
sage -t --long src/sage/databases/findstat.py  # 8 doctests failed
sage -t --long src/sage/combinat/designs/ext_rep.py  # 1 doctest failed
--
External software detected for doctesting: 
ffmpeg,graphviz,gurobi,imagemagick,internet,latex,pandoc

Rerunning failed tests, I get:

--
sage -t --long src/sage/databases/findstat.py  # 8 doctests failed
--
External software detected for doctesting: internet

The findstat issue is already tracked at 
https://trac.sagemath.org/ticket/25536

-- 
You received this message because you are subscribed to the Google Groups 
"sage-release" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-release+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/sage-release/fd608603-8774-4ad8-9a48-c5a6e366%40googlegroups.com.


Re: [sage-release] Re: Sage 8.9.rc0 released

2019-09-14 Thread Emmanuel Charpentier


Le samedi 14 septembre 2019 10:50:07 UTC+2, Dima Pasechnik a écrit :

[ Snip... ]

>
> I am aware of this issue: it's something coming from GAP's package 
> Semigroups. I'm in touch with GAP people to sort it out. 
>
> Dima 
>

Thank you Dima for letting us know.

I reported this for exhaustivity, not for novelty (I also reported the 
very-well known problem with FLINT flushing for the very same reason...). 
Similarly, the transient failures I see tend to be the same from release to 
release...
 
[ Re-Snip... ]

-- 
You received this message because you are subscribed to the Google Groups 
"sage-release" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-release+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/sage-release/2eac1320-aa66-442c-9aec-f5bff8d4883c%40googlegroups.com.


[sage-release] Re: Sage 8.9.rc0 released

2019-09-14 Thread Emmanuel Charpentier
On another, smaller machine (Debian testing running on core i5 + 8 GB RAM):

   - Transient failures: 13, including 1 related to the optional package 
   gap-packages)

The following files log an error, but cant't be reproduced when ran 
standalone:

| File  |
|---|
| src/sage/combinat/posets/posets.py|
| src/sage/plot/animate.py  |
| src/sage/combinat/matrices/hadamard_matrix.py |
| src/sage/modular/ssmod/ssmod.py   |
| src/sage/misc/latex.py|
| src/sage/misc/persist.pyx |
| src/sage/coding/databases.py  |
| src/sage/repl/load.py |
| src/sage/graphs/graph_latex.py|
| src/sage/misc/remote_file.py  |
| src/sage/interfaces/magma_free.py |
| src/sage/databases/findstat.py|
| src/sage/interfaces/mathematica.py|


   - Permanent failures: 2 (both already reported, one supposedly fixed in 
   a reviewed but not yet merged ticket)
   
| File| Result  
 |
|-+--|
| src/sage/libs/eclib/interface.py| 1 doctest 
failed |
| src/sage/rings/polynomial/polynomial_rational_flint.pyx | 1 doctest 
failed |


NOTE: the (relative) reproducibility of the transient failures during 
ptestalllong may point to (real) bugs occurring only during concurrent 
accesses to some parts of the Sage library (lack of reentrancy...). It 
might be worth to run two or more testsuites on the same machine (or 
rinning with a larger number of concurrent jobs), possibly in a randomized 
order, in order to detecty more of such problems, if any. But this is an 
area where I know that I know absolutely nothing. Thoughs ?

   - The details of permanent failures seem identical to what has already 
   been reported:
   


   - src/sage/libs/eclib/interface.py
   

charpent@p-202-021:/usr/local/sage-python3$ sage -t --long --warn-long 53.8 
src/sage/libs/eclib/interface.py 
Running doctests with ID 2019-09-14-14-58-01-c4a5cbcf.
Git branch: develop
Using 
--optional=build,dochtml,dot2tex,fricas,giacpy_sage,memlimit,python2,sage
Doctesting 1 file.
sage -t --long --warn-long 53.8 src/sage/libs/eclib/interface.py
**
File "src/sage/libs/eclib/interface.py", line 597, in 
sage.libs.eclib.interface.mwrank_EllipticCurve.saturate
Failed example:
E.saturation([Q1,Q2])
Expected:
([(1 : -27 : 1), (157 : 1950 : 1)], 3, 0.801588644684981)
Got:
Attempt to round -0.2617840677e25 to a long int fails, aborting!
([(1 : -27 : 1), (157 : 1950 : 1)], 3, 0.801588644684981)
**
1 item had failures:
   1 of   9 in sage.libs.eclib.interface.mwrank_EllipticCurve.saturate
[192 tests, 1 failure, 5.08 s]
--
sage -t --long --warn-long 53.8 src/sage/libs/eclib/interface.py  # 1 
doctest failed
--
Total time for all tests: 5.1 seconds
cpu time: 5.1 seconds
cumulative wall time: 5.1 seconds


   -   src/sage/rings/polynomial/polynomial_rational_flint.pyx~
   

charpent@p-202-021:/usr/local/sage-python3$ sage -t --long --warn-long 53.8 
src/sage/rings/polynomial/polynomial_rational_flint.pyx
Running doctests with ID 2019-09-14-14-59-16-f1b629e1.
Git branch: develop
Using 
--optional=build,dochtml,dot2tex,fricas,giacpy_sage,memlimit,python2,sage
Doctesting 1 file.
sage -t --long --warn-long 53.8 
src/sage/rings/polynomial/polynomial_rational_flint.pyx
**
File "src/sage/rings/polynomial/polynomial_rational_flint.pyx", line 2055, 
in 
sage.rings.polynomial.polynomial_rational_flint.Polynomial_rational_flint.galois_group
Failed example:
G = f.galois_group(); G
Expected:
Transitive group number 5 of degree 4
Got:
Exception (FLINT memory_manager). Unable to allocate memory.
Transitive group number 5 of degree 4
**
1 item had failures:
   1 of  16 in 
sage.rings.polynomial.polynomial_rational_flint.Polynomial_rational_flint.galois_group
[397 tests, 1 failure, 3.50 s]
--
sage -t --long --warn-long 53.8 
src/sage/rings/polynomial/polynomial_rational_flint.pyx  # 1 doctest failed
--
Total time for all tests: 3.6 seconds
cpu time: 3.4 seconds
cumulative wall time: 3.5 seconds

HTH,

Le vendredi 13 septembre 2019 23:25:10 UTC+2, Emmanuel Charpentier a écrit :
>
> On Debian testing 

Re: [sage-release] Re: Sage 8.9.rc0 released

2019-09-14 Thread dimpase
On Fri, Sep 13, 2019 at 02:25:10PM -0700, Emmanuel Charpentier wrote:
> On Debian testing running on core i7 + 16 GB RAM, ptestallong gets 12 
> transient and 3 permanent faiures (one of the latter being related to the 
> optional gap-packages).
> 
> Head of the log file:
> 
> Git branch: develop
> Using 
> --optional=build,dochtml,dot2tex,external,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
> External software to be detected: 
> cplex,ffmpeg,graphviz,gurobi,imagemagick,internet,latex,macaulay2,magma,maple,mathematica,matlab,octave,pandoc,scilab
> 
> Transient failures:
> 
> | File| Result  
>| P/T |
> |-++-|
> | src/sage/graphs/generators/smallgraphs.py   | 6 doctests 
> failed  | T   |
> | src/sage/combinat/posets/posets.py  | 1 doctest 
> failed   | T   |
> | src/sage/plot/animate.py| 7 doctests 
> failed  | T   |
> | src/sage/combinat/matrices/hadamard_matrix.py   | 2 doctests 
> failed  | T   |
> | src/sage/coding/databases.py| 2 doctests 
> failed  | T   |
> | src/sage/misc/latex.py  | 1 doctest 
> failed   | T   |
> | src/sage/misc/persist.pyx   | 2 doctests 
> failed  | T   |
> | src/sage/repl/load.py   | 1 doctest 
> failed   | T   |
> | src/sage/graphs/graph_latex.py  | 2 doctests 
> failed  | T   |
> | src/sage/combinat/designs/ext_rep.py| 2 doctests 
> failed  | T   |
> | src/sage/misc/remote_file.py| 2 doctests 
> failed  | T   |
> | src/sage/databases/findstat.py  | 11 doctests 
> failed | T   |
> 
> Permanent failures:
> 
> | File| Result  
>| P/T |
> |-++-|
> | src/sage/libs/eclib/interface.py| 1 doctest 
> failed   | P   |
> | src/sage/tests/gap_packages.py  | 1 doctest 
> failed   | P   |
> | src/sage/rings/polynomial/polynomial_rational_flint.pyx | 1 doctest 
> failed   | P   |
> 
> Details for the permanent failures:
> 
> charpent@zen-book-flip:/usr/local/sage-P3-2$ sage -t --long --warn-long 
> 177.6 src/sage/libs/eclib/interface.py  
> Running doctests with ID 2019-09-13-22-58-28-a45b380d.
> Git branch: develop
> Using 
> --optional=build,dochtml,dot2tex,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
> Doctesting 1 file.
> sage -t --long --warn-long 177.6 src/sage/libs/eclib/interface.py
> **
> File "src/sage/libs/eclib/interface.py", line 597, in 
> sage.libs.eclib.interface.mwrank_EllipticCurve.saturate
> Failed example:
> E.saturation([Q1,Q2])
> Expected:
> ([(1 : -27 : 1), (157 : 1950 : 1)], 3, 0.801588644684981)
> Got:
> Attempt to round -0.2617840677e25 to a long int fails, aborting!
> ([(1 : -27 : 1), (157 : 1950 : 1)], 3, 0.801588644684981)
> **
> 1 item had failures:
>1 of   9 in sage.libs.eclib.interface.mwrank_EllipticCurve.saturate
> [192 tests, 1 failure, 3.82 s]
> --
> sage -t --long --warn-long 177.6 src/sage/libs/eclib/interface.py  # 1 
> doctest failed
> --
> Total time for all tests: 3.9 seconds
> cpu time: 3.8 seconds
> cumulative wall time: 3.8 seconds
> 
> charpent@zen-book-flip:/usr/local/sage-P3-2$ sage -t --long --warn-long 
> 177.6 src/sage/tests/gap_packages.py
> Running doctests with ID 2019-09-13-23-00-30-5c509c45.
> Git branch: develop
> Using 
> --optional=build,dochtml,dot2tex,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
> Doctesting 1 file.
> sage -t --long --warn-long 177.6 src/sage/tests/gap_packages.py
> **
> File "src/sage/tests/gap_packages.py", line 8, in sage.tests.gap_packages
> Failed example:
> test_packages(pkgs, only_failures=True)# optional - gap_packages
> Expected:
>   Status   Package   GAP Output
> ++-++
> Got:
> #I  method installed for Matrix matches more than one declaration
>   Status   Package   GAP Output
> ++-++


I am aware of this issue: it's something coming from GAP's package
Semigroups. I'm in touch with GAP people to sort it out.

Dima

> **
> 1 item had failures:
>1 of   5 in sage.tests.gap_packages
> [11 tests, 1 

Re: [sage-release] Re: Sage 8.9.rc0 released

2019-09-14 Thread John Cremona
The eclib/interface issue is fixed by #28472 which has a positive review.

John

On Fri, 13 Sep 2019 at 22:25, Emmanuel Charpentier <
emanuel.charpent...@gmail.com> wrote:

> On Debian testing running on core i7 + 16 GB RAM, ptestallong gets 12
> transient and 3 permanent faiures (one of the latter being related to the
> optional gap-packages).
>
> Head of the log file:
>
> Git branch: develop
> Using
> --optional=build,dochtml,dot2tex,external,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
> External software to be detected:
> cplex,ffmpeg,graphviz,gurobi,imagemagick,internet,latex,macaulay2,magma,maple,mathematica,matlab,octave,pandoc,scilab
>
> Transient failures:
>
> | File| Result
>  | P/T |
>
> |-++-|
> | src/sage/graphs/generators/smallgraphs.py   | 6 doctests
> failed  | T   |
> | src/sage/combinat/posets/posets.py  | 1 doctest
> failed   | T   |
> | src/sage/plot/animate.py| 7 doctests
> failed  | T   |
> | src/sage/combinat/matrices/hadamard_matrix.py   | 2 doctests
> failed  | T   |
> | src/sage/coding/databases.py| 2 doctests
> failed  | T   |
> | src/sage/misc/latex.py  | 1 doctest
> failed   | T   |
> | src/sage/misc/persist.pyx   | 2 doctests
> failed  | T   |
> | src/sage/repl/load.py   | 1 doctest
> failed   | T   |
> | src/sage/graphs/graph_latex.py  | 2 doctests
> failed  | T   |
> | src/sage/combinat/designs/ext_rep.py| 2 doctests
> failed  | T   |
> | src/sage/misc/remote_file.py| 2 doctests
> failed  | T   |
> | src/sage/databases/findstat.py  | 11 doctests
> failed | T   |
>
> Permanent failures:
>
> | File| Result
>  | P/T |
>
> |-++-|
> | src/sage/libs/eclib/interface.py| 1 doctest
> failed   | P   |
> | src/sage/tests/gap_packages.py  | 1 doctest
> failed   | P   |
> | src/sage/rings/polynomial/polynomial_rational_flint.pyx | 1 doctest
> failed   | P   |
>
> Details for the permanent failures:
>
> charpent@zen-book-flip:/usr/local/sage-P3-2$ sage -t --long --warn-long
> 177.6 src/sage/libs/eclib/interface.py
> Running doctests with ID 2019-09-13-22-58-28-a45b380d.
> Git branch: develop
> Using
> --optional=build,dochtml,dot2tex,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
> Doctesting 1 file.
> sage -t --long --warn-long 177.6 src/sage/libs/eclib/interface.py
> **
> File "src/sage/libs/eclib/interface.py", line 597, in
> sage.libs.eclib.interface.mwrank_EllipticCurve.saturate
> Failed example:
> E.saturation([Q1,Q2])
> Expected:
> ([(1 : -27 : 1), (157 : 1950 : 1)], 3, 0.801588644684981)
> Got:
> Attempt to round -0.2617840677e25 to a long int fails, aborting!
> ([(1 : -27 : 1), (157 : 1950 : 1)], 3, 0.801588644684981)
> **
> 1 item had failures:
>1 of   9 in sage.libs.eclib.interface.mwrank_EllipticCurve.saturate
> [192 tests, 1 failure, 3.82 s]
> --
> sage -t --long --warn-long 177.6 src/sage/libs/eclib/interface.py  # 1
> doctest failed
> --
> Total time for all tests: 3.9 seconds
> cpu time: 3.8 seconds
> cumulative wall time: 3.8 seconds
>
> charpent@zen-book-flip:/usr/local/sage-P3-2$ sage -t --long --warn-long
> 177.6 src/sage/tests/gap_packages.py
> Running doctests with ID 2019-09-13-23-00-30-5c509c45.
> Git branch: develop
> Using
> --optional=build,dochtml,dot2tex,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
> Doctesting 1 file.
> sage -t --long --warn-long 177.6 src/sage/tests/gap_packages.py
> **
> File "src/sage/tests/gap_packages.py", line 8, in sage.tests.gap_packages
> Failed example:
> test_packages(pkgs, only_failures=True)# optional - gap_packages
> Expected:
>   Status   Package   GAP Output
> ++-++
> Got:
> #I  method installed for Matrix matches more than one declaration
>   Status   Package   GAP Output
> ++-++
> **
> 1 item had failures:
>1 of   5 in sage.tests.gap_packages
> [11 tests, 1 failure, 2.85 s]
> 

[sage-release] Re: Sage 8.9.rc0 released

2019-09-13 Thread Emmanuel Charpentier
On Debian testing running on core i7 + 16 GB RAM, ptestallong gets 12 
transient and 3 permanent faiures (one of the latter being related to the 
optional gap-packages).

Head of the log file:

Git branch: develop
Using 
--optional=build,dochtml,dot2tex,external,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
External software to be detected: 
cplex,ffmpeg,graphviz,gurobi,imagemagick,internet,latex,macaulay2,magma,maple,mathematica,matlab,octave,pandoc,scilab

Transient failures:

| File| Result  
   | P/T |
|-++-|
| src/sage/graphs/generators/smallgraphs.py   | 6 doctests 
failed  | T   |
| src/sage/combinat/posets/posets.py  | 1 doctest 
failed   | T   |
| src/sage/plot/animate.py| 7 doctests 
failed  | T   |
| src/sage/combinat/matrices/hadamard_matrix.py   | 2 doctests 
failed  | T   |
| src/sage/coding/databases.py| 2 doctests 
failed  | T   |
| src/sage/misc/latex.py  | 1 doctest 
failed   | T   |
| src/sage/misc/persist.pyx   | 2 doctests 
failed  | T   |
| src/sage/repl/load.py   | 1 doctest 
failed   | T   |
| src/sage/graphs/graph_latex.py  | 2 doctests 
failed  | T   |
| src/sage/combinat/designs/ext_rep.py| 2 doctests 
failed  | T   |
| src/sage/misc/remote_file.py| 2 doctests 
failed  | T   |
| src/sage/databases/findstat.py  | 11 doctests 
failed | T   |

Permanent failures:

| File| Result  
   | P/T |
|-++-|
| src/sage/libs/eclib/interface.py| 1 doctest 
failed   | P   |
| src/sage/tests/gap_packages.py  | 1 doctest 
failed   | P   |
| src/sage/rings/polynomial/polynomial_rational_flint.pyx | 1 doctest 
failed   | P   |

Details for the permanent failures:

charpent@zen-book-flip:/usr/local/sage-P3-2$ sage -t --long --warn-long 
177.6 src/sage/libs/eclib/interface.py  
Running doctests with ID 2019-09-13-22-58-28-a45b380d.
Git branch: develop
Using 
--optional=build,dochtml,dot2tex,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
Doctesting 1 file.
sage -t --long --warn-long 177.6 src/sage/libs/eclib/interface.py
**
File "src/sage/libs/eclib/interface.py", line 597, in 
sage.libs.eclib.interface.mwrank_EllipticCurve.saturate
Failed example:
E.saturation([Q1,Q2])
Expected:
([(1 : -27 : 1), (157 : 1950 : 1)], 3, 0.801588644684981)
Got:
Attempt to round -0.2617840677e25 to a long int fails, aborting!
([(1 : -27 : 1), (157 : 1950 : 1)], 3, 0.801588644684981)
**
1 item had failures:
   1 of   9 in sage.libs.eclib.interface.mwrank_EllipticCurve.saturate
[192 tests, 1 failure, 3.82 s]
--
sage -t --long --warn-long 177.6 src/sage/libs/eclib/interface.py  # 1 
doctest failed
--
Total time for all tests: 3.9 seconds
cpu time: 3.8 seconds
cumulative wall time: 3.8 seconds

charpent@zen-book-flip:/usr/local/sage-P3-2$ sage -t --long --warn-long 
177.6 src/sage/tests/gap_packages.py
Running doctests with ID 2019-09-13-23-00-30-5c509c45.
Git branch: develop
Using 
--optional=build,dochtml,dot2tex,fricas,gap_packages,giacpy_sage,libsemigroups,memlimit,python2,sage
Doctesting 1 file.
sage -t --long --warn-long 177.6 src/sage/tests/gap_packages.py
**
File "src/sage/tests/gap_packages.py", line 8, in sage.tests.gap_packages
Failed example:
test_packages(pkgs, only_failures=True)# optional - gap_packages
Expected:
  Status   Package   GAP Output
++-++
Got:
#I  method installed for Matrix matches more than one declaration
  Status   Package   GAP Output
++-++
**
1 item had failures:
   1 of   5 in sage.tests.gap_packages
[11 tests, 1 failure, 2.85 s]
--
sage -t --long --warn-long 177.6 src/sage/tests/gap_packages.py  # 1 
doctest failed
--
Total time for all tests: 2.9 seconds
cpu time: 2.5 seconds
cumulative wall time: 2.8 seconds

charpent@zen-book-flip:/usr/local/sage-P3-2$ sage -t --long --warn-long 
177.6 

[sage-release] Re: Sage 8.9.rc0 released

2019-09-13 Thread Eric Gourgoulhon
On Ubuntu 18.04 running on bi-Xeon E5-2623 (8 cores) + 16 GB RAM:


*- python2: *

  - incremental build (from 8.9.beta9, with -j16) OK 
  - all tests from ptestlong passed

- 
*python3: *

  - incremental build (from 8.9.beta9, with -j16) OK 

  - tests from ptest-python3 passed, except for 1 permanent failure in 
   src/sage/rings/polynomial/polynomial_rational_flint.pyx 
   this is the error tracked at https://trac.sagemath.org/ticket/28334

  - tests from ptestlong passed, except for 

--
sage -t --long --warn-long 52.6 src/sage/libs/eclib/interface.py  # 1 
doctest failed
sage -t --long --warn-long 52.6 
src/sage/rings/polynomial/polynomial_rational_flint.pyx  # 1 doctest failed
sage -t --long --warn-long 52.6 src/sage/repl/attach.py  # 4 doctests failed
sage -t --long --warn-long 52.6 src/sage/libs/singular/function.pyx  # 1 
doctest failed
sage -t --long --warn-long 52.6 
src/sage/numerical/backends/generic_backend.pyx  # 2 doctests failed
--

  The failed doctests are those tracked at 
https://trac.sagemath.org/ticket/28298 

  The files
   - src/sage/libs/eclib/interface.py
   - src/sage/rings/polynomial/polynomial_rational_flint.pyx
  have permanent failures, while
  - src/sage/repl/attach.py
  - src/sage/libs/singular/function.pyx
  - src/sage/numerical/backends/generic_backend.pyx
  have only failed doctests that pass when run standalone. 
 
Eric. 




-- 
You received this message because you are subscribed to the Google Groups 
"sage-release" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-release+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/sage-release/153973d4-2804-4bc2-988f-01df0cca3259%40googlegroups.com.


[sage-release] Re: Sage 8.9.rc0 released

2019-09-11 Thread John H Palmieri


On Wednesday, September 11, 2019 at 4:36:46 PM UTC-7, Volker Braun wrote:
>
> As always, you can get the latest beta version from the "develop" git 
> branch. Alternatively, the self-contained source tarball is at 
> http://www.sagemath.org/download-latest.html 
>

OS X + Python 3: All tests passed!

-- 
You received this message because you are subscribed to the Google Groups 
"sage-release" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-release+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/sage-release/ed35e75d-3bc9-4b7e-856f-1435724ead1f%40googlegroups.com.