[sane-devel] SANE and Canon Scan Lide 120

2015-05-03 Thread Nalin.x.Linux
Dear list, Recently my friend bought a Canon Scan Lide 120 Scanner. Unfortunately it seems to be not supported by SANE. So i would like to develop the driver for lide 120 scanner. Please let me know if the scanner is alrady supported or anyone currently developing the driver. Further guidance

[sane-devel] CanoScan LiDE 120 Untested?

2015-05-10 Thread Simon May
Hi, I've recently bought a Canon LiDE 120. I got my hopes up because on http://sane-project.org/lists/sane-mfgs-cvs.html#Z-CANON the LiDE 100, 110, 200, 210 and 220 were all listed as completely supported and the LiDE 120 is at least marked untested. However, now that I've tried to get it to work

Re: [sane-devel] Canon LiDE 220 unexpected success

2015-03-15 Thread Jochen
Hi Stef, I understand you're asking for a log from somebody with a LiDE 120 doing a preview. Me, I'd be happy to see my LiDE 120 supported by SANE. So if you tell me what to do and how to even make my LiDE 120 do anything loggable, I'll see if I can provide that. Unfortunately, I am not much

[sane-devel] Canon Lide 120

2014-08-26 Thread David Hrbáč
Hi all, Anyone tried Canon Lide 120? I'm looking also for developer for this device. Details on personal email. Thanks, David Hrbáč -- sane-devel mailing list: sane-devel@lists.alioth.debian.org http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel Unsubscribe: Send mail

Re: [sane-devel] CanoScan LiDE 120 Untested?

2015-05-11 Thread Stef
On 10/05/2015 02:31, Simon May wrote: Hi, I've recently bought a Canon LiDE 120. I got my hopes up because on http://sane-project.org/lists/sane-mfgs-cvs.html#Z-CANON the LiDE 100, 110, 200, 210 and 220 were all listed as completely supported and the LiDE 120 is at least marked untested

Re: [sane-devel] Canon Lide 120 produces all black scans :p:

2015-09-08 Thread Thomas C. Hicks
On 09/09/2015 12:38 PM, Stef wrote: On 09/09/2015 06:26, Paradox wrote: I am trying to get a Canon Lide 120 scanner working. I am using Arch, kernel is 4.1.6-1-ARCH. Using the latest sane package from AUR (sane-git) the Hello, this is a mistake in the man page that I'll fix. LIDE 120

Re: [sane-devel] SANE and Canon Scan Lide 120

2016-02-08 Thread Pavel Sayekat
Quoting "Dear list, Recently my friend bought a Canon Scan Lide 120 Scanner. Unfortunately it seems to be not supported by SANE. So i would like to develop the driver for lide 120 scanner. Please let me know if the scanner is alrady supported or anyone currently developing the driver. Fu

Re: [sane-devel] Canon LiDE 120 preview log

2015-03-15 Thread Steven Honeyman
I also have a Canon LiDE 120 that I hope SANE will support soon. If there's any other log/capture files that you need I'd be happy to provide them. Thanks, Steven -- sane-devel mailing list: sane-devel@lists.alioth.debian.org http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel

Re: [sane-devel] Canon LiDE 120 preview log

2015-03-18 Thread Dominique Somphanethabanesouk
Hello, I am sorry for my english french :) If it helps you, here are generated by usbpcap, pcap files for CanoScan lide 120. http://weshare.me/a2da019d6e2b8fcb/canoscan_lide_120_preview.zip http://weshare.me/dc373a1c61c59a97/canoscan_lide_120_numerisation.zip Hoping that it can be used

Re: [sane-devel] SANE and Canon Scan Lide 120

2016-02-26 Thread Pavel Sayekat
Hey Nalin, Now its working, Thanks to Dear Stef. -- View this message in context: http://sane.10972.n7.nabble.com/SANE-and-Canon-Scan-Lide-120-tp19708p20659.html Sent from the SANE - Dev mailing list archive at Nabble.com. -- sane-devel mailing list: sane-devel@lists.alioth.debian.org http

Re: [sane-devel] Canon Lide 120

2016-02-26 Thread Pavel Sayekat
Hi, Now its working, atleast at 300 dpi, I tried with frontend gscan2pdf with latest backend from sane-git, thanks to Stef. regards Pavel -- View this message in context: http://sane.10972.n7.nabble.com/Canon-Lide-120-tp19381p20660.html Sent from the SANE - Dev mailing list archive

Re: [sane-devel] SANE and Canon Scan Lide 120

2016-02-19 Thread Pavel Sayekat
If I send you the USB dump file during scanning, can you do something what is called reverse engineering? -- View this message in context: http://sane.10972.n7.nabble.com/SANE-and-Canon-Scan-Lide-120-tp19708p20640.html Sent from the SANE - Dev mailing list archive at Nabble.com. -- sane

[sane-devel] Fwd: Re: Canon LiDE 120 scanner support

2015-02-24 Thread Stef
Resending since moderated because of too many recipients. Forwarded Message Subject:Re: Canon LiDE 120 scanner support Date: Tue, 24 Feb 2015 21:22:51 +0100 From: Stef stef@free.fr To: brian.bloni...@gmail.com CC: sba...@catern.com, hginsb...@worcester.edu

[sane-devel] Canon CanoScan LiDE 120

2017-12-27 Thread Andy Goss
openSUSE LEAP 42.3 - scanner not detected. Following advice on the openSUSE forum I have built sane version 1.0.27 via git clone git://git.debian.org/sane/sane-backends.git But: Although http://www.sane-project.org/sane-mfgs.html#Z-CANON shows CanoScan LiDE 120 USB 0x04a9/0x190e

Re: [sane-devel] Canon LiDE 220 unexpected success

2015-03-15 Thread Stef
On 14/03/2015 18:12, Jochen wrote: Hi Stef, I understand you're asking for a log from somebody with a LiDE 120 doing a preview. Me, I'd be happy to see my LiDE 120 supported by SANE. So if you tell me what to do and how to even make my LiDE 120 do anything loggable, I'll see if I can provide

Re: [sane-devel] Fwd: Re: Canon LiDE 120 scanner support

2016-02-09 Thread Pavel Sayekat
stef-22 wrote > Resending since "moderated because of too many recipients". > > Forwarded Message > Subject: Re: Canon LiDE 120 scanner support > Date: Tue, 24 Feb 2015 21:22:51 +0100 > From: Stef > stef.dev@ >

Re: [sane-devel] Canon Lide 120 produces all black scans :p:

2016-02-26 Thread Pavel Sayekat
Hi, Now its working, atleast at 300 dpi, I tried with frontend gscan2pdf with latest backend from sane-git, thanks to Stef. regards Pavel Paradox wrote > On 09/09/2015 12:38 PM, Stef wrote: >> On 09/09/2015 06:26, Paradox wrote: >>> I am trying to get a Canon Lide 120 sca

Re: [sane-devel] Canon LiDE 220 unexpected success

2015-02-28 Thread Stef
at end while trying to go too far. This will be fixed by Monday. Regarding LiDE 120 support, I'd need a log recorded with usbpcap of a preview (and only the preview) to check is like older models, this one is close to the 220, and possibly figure out hos to add support for it. Regards

[sane-devel] Canon Lide 120

2015-01-30 Thread webmail4
Hi, There's a few threads about the Canon Lide 120 already. Has anybody gotten further? https://www.mail-archive.com/search?l=sane-devel%40lists.alioth.debian.orgq=lide+120 http://lists.alioth.debian.org/pipermail/sane-devel/2014-October/032768.html In the last link, Stef speculates

Re: [sane-devel] Canon Lide 120 produces all black scans

2015-09-08 Thread Stef
On 09/09/2015 06:26, Paradox wrote: I am trying to get a Canon Lide 120 scanner working. I am using Arch, kernel is 4.1.6-1-ARCH. Using the latest sane package from AUR (sane-git) the scanner is recognized by scanimage. According to the genesys man page the scanner is supported by sane

Re: [sane-devel] SANE and Canon Scan Lide 120

2016-02-08 Thread Nalin.x.Linux
On Mon, Feb 8, 2016 at 6:32 PM, Pavel Sayekat <pavelsaye...@gmail.com> wrote: > Quoting "Dear list, >Recently my friend bought a Canon Scan Lide 120 Scanner. Unfortunately > it > seems to be not supported by SANE. So i would like to develop the driver > for > li

Re: [sane-devel] SANE and Canon Scan Lide 120

2016-02-20 Thread Stef
On 19/02/2016 21:07, Pavel Sayekat wrote: If I send you the USB dump file during scanning, can you do something what is called reverse engineering? -- View this message in context: http://sane.10972.n7.nabble.com/SANE-and-Canon-Scan-Lide-120-tp19708p20640.html Sent from the SANE - Dev

Re: [sane-devel] Producing some results! (SANE and Canon Scan Lide 120)

2016-02-23 Thread Pavel Sayekat
yekat wrote: >> > If I send you the USB dump file during scanning, can you do >> something what is >> > called reverse engineering? >> > >> > >> > >> > -- >> > View this message in context: >> http://sane.10972.n7.nabb

[sane-devel] Glad to know that (SANE and Canon Scan Lide 120)

2016-02-21 Thread Pavel Sayekat
te: > > If I send you the USB dump file during scanning, can you do > something what is > > called reverse engineering? > > > > > > > > -- > > View this message in context: > http://sane.10972.n7.nabble.com/SANE-and-Canon-Scan-Lide-120-tp1

Re: [sane-devel] Canon LiDE 120 Black Image

2015-07-03 Thread Stef
On 02/07/2015 17:16, martin.galle...@free.fr wrote: Hello, I tested the latest build (SANE Genesys backend version 1.0 build 2507 from sane-backends 1.0.25 git) on my LIDE 120. Scanner is recognized, stepper motor are moving but the scan image is 'all black'. I have set the debug level

[sane-devel] Canon Lide 120 produces all black scans

2015-09-08 Thread Paradox
I am trying to get a Canon Lide 120 scanner working. I am using Arch, kernel is 4.1.6-1-ARCH. Using the latest sane package from AUR (sane-git) the scanner is recognized by scanimage. According to the genesys man page the scanner is supported by sane-genesys. Everything seems to be OK

Re: [sane-devel] How can I test CanoScan LiDE 120 with genesys backend?

2015-01-06 Thread willismon...@gmail.com
, and didn't hear back from them. I'm thinking of reaching out again to try and poke them into either helping to fix it, or pointing me in the right direction. Basically it seems like the definitions for each of the scanners are hardcoded into the drivers, I'm sure, as you implied, that the LiDE 120

Re: [sane-devel] Canon LiDE 120 not working

2016-02-09 Thread Pavel Sayekat
Hey, I am not a developer but like you. So thought it will be helpful for us to be in touch cause I vahe the same issue, canon LiDE 120 not working, done the device adding to its respected lists, recompiled the latest source availed me nothing, scanner got recognized but producing only black sheet

Re: [sane-devel] LiDE 120, small changes pushed in git

2015-06-18 Thread martin . gallezot
Stef, Ok got it. Thanks. will try this asap and let you know. Martin. - Mail original - De: Stef stef@free.fr À: martin gallezot martin.galle...@free.fr, sane-devel@lists.alioth.debian.org Envoyé: Mercredi 17 Juin 2015 20:44:23 Objet: Re: [sane-devel] LiDE 120, small changes pushed

Re: [sane-devel] Producing some results! (SANE and Canon Scan Lide 120)

2016-02-23 Thread Stef
t wrote: If I send you the USB dump file during scanning, can you do something what is called reverse engineering? -- View this message in context: http://sane.10972.n7.nabble.com/SANE-and-Canon-Scan-Lide-120-tp19708p20640.html Sent from the SANE - Dev mailing list archive at Nabble.com.

[sane-devel] CanoScan LiDE 120 on Debian 9 Stretch

2017-10-02 Thread Franz Danzi
Hello. I got my CanoScan LiDE 120 working on Debian 9 Stretch ... but it was challenging and showed some weird sideeffects. That's why I report feedback. Here is what I did - as far as I remember. 1. Privileges In the file "/lib/udev/rules.d/60-libsane.rules" I inserted the 2 lin

[sane-devel] How can I test CanoScan LiDE 120 with genesys backend?

2015-01-05 Thread Ginsberg, Hy
Hi All, I have a CanoScan LiDE 120, which is not supported by SANE. The previous model, the LiDE 110, is supported by the genesys backend. I thought that before I tried to return my scanner it would be nice to see if perhaps it is similar enough to the 110 to work, at least partially

Re: [sane-devel] Canon LiDE 120 Black Image

2015-07-02 Thread martin . gallezot
Hello, I tested the latest build (SANE Genesys backend version 1.0 build 2507 from sane-backends 1.0.25 git) on my LIDE 120. Scanner is recognized, stepper motor are moving but the scan image is 'all black'. I have set the debug level of Genesys to 255 Any idea what I am doing wrong ? Thanks

Re: [sane-devel] sane-devel Digest, Vol 128, Issue 21

2016-02-24 Thread Pavel Sayekat
cing some results! (SANE and Canon Scan Lide120) (Pavel Sayekat) 2. Re: Producing some results! (SANE and Canon Scan Lide 120) (Stef) 3. Recent Linux USB issues with SANE (m. allan noah) -- Message: 1 Date: T

[sane-devel] LiDE 120, small changes pushed in git

2015-06-11 Thread Stef
Hello, I have pushed some small changes that should improve support for the LiDE 120 for resolutions up to 600 dpi. Please test this build 2507 of the geneys backend (check this version number in debug logs when testing). Working with some logs sent, then throwing back some code

[sane-devel] Canon LiDE 120 not working

2015-08-06 Thread Edgar Klenske
Hello, I have a Canon LiDE 120 scanner at home, and since the support by sane is untested, I tried to test it. I got the newest version from git (d0e7675), compiled and installed the genesys backend. The scanner is correctly recognized, but when I try to do a scan, the motor only moves a small

Re: [sane-devel] Canon LiDE 120 not working

2016-02-26 Thread Pavel Sayekat
ally have no idea abt it and fearing to damage the > scanner. > > like to hear from you, take care. > Edgar Klenske wrote >> Hello, >> >> I have a Canon LiDE 120 scanner at home, and since the support by sane >> is "untested", I tried to test it. >>

[sane-devel] Canon Lide 120

2016-03-04 Thread srikumar
Using Ubuntu 15.10 and Canon Lide 120 scanner been trying to get the Canon Lide 120 scanner working with the help of Pavel. He has suggested that I post these logs on this page. srikumar@srikumar-desktop:~$ sudo cat /lib/udev/rules.d/40-libsane.rules | grep 190e [sudo] password for srikumar

[sane-devel] Problems with Canpn CanoScan LiDE 120 under OpenBSD/amd64

2015-08-12 Thread Alexander Shendi
Dear list,   I'm trying to use a Canon CanoScan LIDE 120 flatbed scanner under SANE on a laptop running OpenBSD-current/amd64.   I am using version 1.0.25.git compiled with   MAKE=gmake \ CPPFLAGS=-I/usr/local/include -L/usr/local/lib. CFLAGS=$CPPFLAGS -O -g ./configure \    --disable

Re: [sane-devel] Canon LiDE 120 Black Image

2016-02-26 Thread Pavel Sayekat
kend version 1.0 build 2507 >> from sane-backends 1.0.25 git) on my LIDE 120. Scanner is recognized, >> stepper motor are moving but the scan image is 'all black'. >> >> I have set the debug level of Genesys to 255 >> >> Any idea what I am doing wrong ? >>

Re: [sane-devel] HP 8620 <- Re: CanoScan LiDE 120 "Untested"?

2016-02-26 Thread Pavel Sayekat
Hi, Now its working, atleast at 300 dpi, I tried with frontend gscan2pdf with latest backend from sane-git, thanks to Stef. regards Pavel ken wrote > On 05/09/2015 08:31 PM, Simon May wrote: >> Hi, >> >> I've recently bought a Canon LiDE 120. I got my hopes up beca

Re: [sane-devel] Canon LiDE 120 git commit 128c8931b3

2016-02-26 Thread Pavel Sayekat
was warming up the first time) and it >>> moves! and keeps moving, and keeps moving, until it gets to the end >>> and is still moving (making a horrible noise) >>> >>> I pulled the USB, reconnected to a Windows PC and luckily it still >>> works OK. The driver n

Re: [sane-devel] Canon LiDE 220 unexpected success

2015-03-15 Thread webmail4
further right now, since the 120 stopped responding to any commands. I'm waiting for a repair or replacement. Havard -- sane-devel mailing list: sane-devel@lists.alioth.debian.org http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel Unsubscribe: Send mail with subject unsubscribe

Re: [sane-devel] SANE and Canon Scan Lide 120

2016-02-26 Thread Nalin.x.Linux
On Fri, Feb 26, 2016 at 3:41 PM, Pavel Sayekat wrote: > Hey Nalin, > Now its working, Thanks to Dear Stef. Glad to know that. Thanks a lot for doing this. I think now my visually impaired friend can start reading books. Once again I am sorry for making this delay.

Re: [sane-devel] Canon LiDE 120 git commit 128c8931b3

2016-03-09 Thread martin . gallezot
Thanks for the update. Worked for me too. Keep up the good work. Martin - Mail original - De: "Pavel Sayekat" <pavelsaye...@gmail.com> À: sane-devel@lists.alioth.debian.org Envoyé: Vendredi 26 Février 2016 11:24:52 Objet: Re: [sane-devel] Canon LiDE 120 git commit 128c893

Re: [sane-devel] CanoScan LiDE 120 supported or not?

2016-10-08 Thread Fabrice Delente
Hello, I ended up removing all fedora packages for sane (except the backend libs in i386 since removing them also removes wine...) Then I downloaded the latest git for the backends, compiled and installed; the scanner was immediately recognized and working. I guess Fedora's version is too old

[sane-devel] HP 8620 - Re: CanoScan LiDE 120 Untested?

2015-05-11 Thread ken
On 05/09/2015 08:31 PM, Simon May wrote: Hi, I've recently bought a Canon LiDE 120. I got my hopes up because on http://sane-project.org/lists/sane-mfgs-cvs.html#Z-CANON the LiDE 100, 110, 200, 210 and 220 were all listed as completely supported and the LiDE 120 is at least marked untested

Re: [sane-devel] Canon LiDE 120 git commit 128c8931b3

2015-04-06 Thread Steven Honeyman
a scan log with my LiDE 110 close enough to the 120 logs sent to me. So currently I don't know how much code is needed to bring support for this model, since I don't have similar scans to compare. I really need a log done with the WIA driver (NOT the shipped scanning suite) at 150 dpi

Re: [sane-devel] Canon LiDE 120 git commit 128c8931b3

2015-04-03 Thread Stef
moving (making a horrible noise) I pulled the USB, reconnected to a Windows PC and luckily it still works OK. The driver needs some adjustment though for sure! Thanks, Steven. Hello, I haven't been able to generate a scan log with my LiDE 110 close enough to the 120 logs sent to me. So

Re: [sane-devel] Brother DCP-195C Device should be listed in /lib/udev/rules.d/40-libsane.rules

2016-11-14 Thread csola48
;, ATTRS{idProduct}=="190d", ENV{libsane_matched}="yes" # Canon CanoScan LiDE 120 ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="190e", ENV{libsane_matched}="yes" # Canon CanoScan LiDE 220 <= ATTRS{idVendor}=="04a

Re: [sane-devel] Canon LiDE 120 preview log

2015-03-15 Thread Stef
On 15/03/2015 12:23, Mr. Kraus wrote: Hello, what is needed is a log recorded when doing a preview when running windows O/S. The log tool to use is usbpcap http://desowin.org/usbpcap/ . Regards, Stef Hi, here you go! To be complete, I added the log of an actual scan, as well:

[sane-devel] Canon LiDE 120 git commit 128c8931b3

2015-03-30 Thread Steven Honeyman
Hi, I noticed the commit for supporting this scanner appear a couple of weeks ago, and I recompiled and tested it today. Unfortunately it doesn't work. It's detected correctly. (the following is all using xsane, just using preview button) At 75dpi default, preview button does nothing - generic

[sane-devel] CanoScan LiDE 120 supported or not?

2016-09-30 Thread Fabrice Delente
Hello, My PC is on fedora, when I install sane, its backends and the drivers I get my LiDE120 to "move" in xsane (motor gets activated) but can't get no image in return of a preview or a scan. The scanner is recognized with sane-find-scanner and scanimage -L Since scanning didn't work, I

[sane-devel] Motor movement and then time-out with Canon LIDE120

2017-05-17 Thread willismon...@gmail.com
: ➜ ~ scanimage -L device `genesys:libusb:003:006' is a Canon LiDE 120 flatbed scanner ➜ ~ scanimage --device 'genesys:libusb:003:006' --format=tiff > test.tiff scanimage: sane_start: Invalid argument ➜ ~ scanimage --version scanimage (sane-backends) 1.0.25git; backend version 1.0.25 When the comm

Re: [sane-devel] CanoScan LiDE 120 supported or not?

2016-10-07 Thread Olaf Meeuwissen
d scanimage should find the genesys.conf file below /usr/local/. That file should have an entry for the LiDE 120. I think your problem stems from the fact that the udev .rules didn't get installed in a place where udev looks. If my thought is right you should be able to find the scanner

Re: [sane-devel] The previous comment of my mail was about Canon LiDE 120 latest genesys backend

2016-02-24 Thread Pavel Sayekat
Hi, Sorry not to mention the subject in my last mail, so it actually remained clueless what I was talking about. I was talking about the latest git source of sane, specially about genesys backend and canon LiDE 120 doc scan results. regards Pavel "Message: 1 Date: Wed, 24 Feb 2016 18:

Re: [sane-devel] SANE; scanning with LIDE series works under Win, NOT under Lx

2015-06-20 Thread Stijn Verholen
Dear Cedric, Please take into consideration that I am not a SANE expert, nor a Canon LIDE expert. SANE is a modular structure. The dirty under-the-hood work that scanner drivers do to get a scanner working, is abstracted away to SANE drivers (i.e. backends). Everything else is built on top

Re: [sane-devel] SANE; scanning with LIDE series works under Win, NOT under Lx

2015-06-22 Thread Stijn Verholen
should use here) $ SANE_DEBUG_SANEI_USB=80 $ export SANE_DEBUG_SANEI_USB However I know neither where log files are located, nor how I should post them for review. Perhaps s.o. can help me with hints on that. *3)* I edited the sane.d genesys.conf file to include a reference to Canon LiDE 25

Re: [sane-devel] SANE; scanning with LIDE series works under Win, NOT under Lx

2015-06-21 Thread Cedric Bhihe (毕生泰)
files are located, nor how I should post them for review. Perhaps s.o. can help me with hints on that. *3)* I edited the sane.d genesys.conf file to include a reference to Canon LiDE 25 sudo vi /etc/sane.d/genesys.conf # Canon LiDE 25 usb 0x04a9 0x2220* 4)* Following Allan's suggestion I

[sane-devel] SANE; scanning with LIDE series works under Win, NOT under Lx

2015-06-20 Thread Cedric Bhihe (毕生泰)
A good day to everybody. I keep reading about flatbed scanners from Canon (in particular of the LIDE series) not working when USB-plugged in under Linux but working fine under Windows. I have exactly the same problem with a LIDE 25 and an HP 4400c scanner. Yes, both scanners are old

Re: [sane-devel] SANE; scanning with LIDE series works under Win, NOT under Lx

2015-06-20 Thread m. allan noah
will be able to see some difference. allan On Sat, Jun 20, 2015 at 3:00 PM, Cedric Bhihe (毕生泰) cedric.bh...@gmail.com wrote: A good day to everybody. I keep reading about flatbed scanners from Canon (in particular of the LIDE series) not working when USB-plugged in under Linux but working

[sane-devel] Canon CanoScan LiDE 120 "signal 2"

2016-09-17 Thread Matthew Ayres
Hello all, and most especially Stef who I see is responsible for supporting this scanner, I've been trying to get the 120 working under OpenSUSE with a backend install from SANE's git. I've made some definite progress, working from resources found here and there (and despite a cold). The system

Re: [sane-devel] sane-devel Digest, Vol 120, Issue 20

2015-06-20 Thread Cedric Bhihe (毕生泰)
A good day to everybody. I keep reading about flatbed scanners from Canon (in particular of the LIDE series) not working when USB-plugged in under Linux but working fine under Windows. I have exactly the same problem with a LIDE 25 and an HP 4400c scanner. Yes, both scanners are old

Re: [sane-devel] Motor movement and then time-out with Canon LIDE120

2017-05-17 Thread m. allan noah
n. It seems to > have quieted off recently, so I thought I'd give the scanner another shot in > Linux. > > I'm running Ubuntu 17.04, here's the output of an attempt to scan: > > ➜ ~ scanimage -L > device `genesys:libusb:003:006' is a Canon LiDE 120 flatbed scanner > ➜ ~ scanim

Re: [sane-devel] SANE; scanning with LIDE series works under Win, NOT under Lx

2015-06-24 Thread Gerard Klaver
SANE_DEBUG_SANEI_USB However I know neither where log files are located, nor how I should post them for review. Perhaps s.o. can help me with hints on that. *3)* I edited the sane.d genesys.conf file to include a reference to Canon LiDE 25 sudo vi /etc/sane.d/genesys.conf # Canon LiDE 25

Re: [sane-devel] SANE; scanning with LIDE series works under Win, NOT under Lx

2015-06-22 Thread klaverg
on that. 3) I edited the sane.d genesys.conf file to include a reference to Canon LiDE 25 sudo vi /etc/sane.d/genesys.conf # Canon LiDE 25 usb 0x04a9 0x2220 4) Following Allan's suggestion I checked whether my bios/kernel relies on xhci_hcd It does not, apparently. It seems to rely on 'ehci-pci

Re: [sane-devel] Motor movement and then time-out with Canon LIDE120

2017-05-17 Thread willismon...@gmail.com
t; development of the driver on the sane-devel list since then. It seems to > > have quieted off recently, so I thought I'd give the scanner another > shot in > > Linux. > > > > I'm running Ubuntu 17.04, here's the output of an attempt to scan: > > > > ➜ ~ scanima

Re: [sane-devel] scanbd and Canon LiDE 60: buttons not recognized ?

2017-04-15 Thread Florian Gagel
in the README (this all with the 1.5.0 version of scanbd). - Starting scanbd -f -d7, I first got a "scanbd: Can't get the scbtn device list" error. - I edited /usr/local/lib/scanbd/scanbuttond/backends/meta.conf, making it contain the single line "genesys" which was missing before

Re: [sane-devel] scanbd and Canon LiDE 60: buttons not recognized ?

2017-04-15 Thread Wilhelm
ends/meta.conf, making > it contain the single line "genesys" which was missing before. Yes, per default this was not included - I added it to trunk. > - Then the LiDE-60 was recognized by the old backend, together with its > four buttons ! > - However, scanbd f

Re: [sane-devel] scanbd and Canon LiDE 60: buttons not recognized ?

2017-04-15 Thread Florian Gagel
scanner scanbd: group scanner has member: scanbd: saned scanbd: drop privileges to gid: 121 scanbd: Running as effective gid 121 scanbd: drop privileges to uid: 120 scanbd: Running as effective uid 120 scanbd: dbus_init scanbd: dbus match type='signal',interface='org.freedesktop.Hal.Manager' scanbd: SANE_C

Re: [sane-devel] scanbd and Canon LiDE 60: buttons not recognized ?

2017-04-16 Thread Wilhelm
ure --enable-scanbuttond, >>> make, make install, copy manually the >>> old backends to /usr/local/lib/scanbd/scanbuttond as described in the >>> README (this all with the 1.5.0 version of scanbd). >>> - Starting scanbd -f -d7, I first got a "scanbd: Can't g

Re: [sane-devel] scanbd and Canon LiDE 60: buttons not recognized ?

2017-04-16 Thread Wilhelm Meier
> Thanks again Wilhelm and Happy Easter ! >>> >>> Florian >>> >>> Am 15.04.2017 um 17:32 schrieb Wilhelm: >>>> Am 15.04.2017 um 16:13 schrieb Florian Gagel: >>>>> Hi Wilhelm, >>>>> >>>>> thanks for your reply - I mad

Re: [sane-devel] scanbd and Canon LiDE 60: buttons not recognized ?

2017-04-16 Thread Florian Gagel
the 1.5.0 version of scanbd). - Starting scanbd -f -d7, I first got a "scanbd: Can't get the scbtn device list" error. - I edited /usr/local/lib/scanbd/scanbuttond/backends/meta.conf, making it contain the single line "genesys" which was missing before. Yes, per default thi

Re: [sane-devel] scanbd and Canon LiDE 60: buttons not recognized ?

2017-04-15 Thread Wilhelm Meier
d: group scanner has member: > scanbd: saned > scanbd: drop privileges to gid: 121 > scanbd: Running as effective gid 121 > scanbd: drop privileges to uid: 120 > scanbd: Running as effective uid 120 > scanbd: dbus_init > scanbd: dbus match type='signal',interface='org.freedesktop.Hal

[sane-devel] scanbd and Canon LiDE 60: buttons not recognized ?

2017-04-15 Thread Florian Gagel
as effective gid 121 scanbd: drop privileges to uid: 120 scanbd: Running as effective uid 120 scanbd: dbus_init scanbd: dbus match type='signal',interface='org.freedesktop.Hal.Manager' scanbd: SANE_CONFIG_DIR=/usr/local/etc/scanbd scanbd: sane version 1.0 scanbd: Scanning for local-only devices