Re: SDL 2.541_02 Released

2012-06-11 Thread Tobias Leich
Ya, it should.

So in the test it can read the file as an SDL::RWOps-object, but
SDL::Mixer::Music::load_MUS_RW can't handle it.
A few lines later SDL::Mixer::Music::load_MUS($ogg_test_file) failes too.

I'll check my VMs this evening, maybe I can reproduce that thing.

Am 11.06.2012 01:08, schrieb Jeffrey Palmer:
 This problems still occurs occasionally with Alien-SDL 1.434

  
   http://www.cpantesters.org/cpan/report/04921c82-b30c-11e1-9066-3d54fb7543f5

 I created an issue about this a while ago:

 https://github.com/PerlGameDev/SDL/issues/233

 The build option include ogg, but those same tests fail.  Should those
 tests pass with those build options?

 Jeff

 On Sun, Jun 10, 2012 at 1:21 PM, Tobias Leich em...@froggs.de
 mailto:em...@froggs.de wrote:

 Ya, would be sweet to make another dev release, requiring a newer
 Alien::SDL.

 Check t/mixer.t for audio support, its basically just that you try
 to init OGG, and skip if it fails.

 Am 10.06.2012 18:03, schrieb Jeffrey Palmer:
 So are we ready to bump our Alien::SDL prereq (at least in the
 dev release)?  Also, I'm assuming we should skip these tests if
 libogg support isn't available.  What's the proper way to detect
 audio format support?

 Jeff

 On Sat, Jun 9, 2012 at 9:51 PM, Tobias Leich em...@froggs.de
 mailto:em...@froggs.de wrote:

 Hi, the tester is still using the old Alien::SDL, this one
 doesnt build libogg and libvorbis.

 Jeffrey Palmer jeffrey.t.pal...@gmail.com
 mailto:jeffrey.t.pal...@gmail.com hat geschrieben:

 Hi All,
 
 I released SDL 2.541_02 today after Blaizer++ merged in his
 changes that
 were accidentally included in 2.538.  The early test reports
 are in and
 we're still having some issues with the SDL::Mixer::MixMusic
 tests that use
 ogg:
 
 
 
 http://www.cpantesters.org/cpan/report/5399278a-b262-11e1-bea2-18293af89482
 
 
 http://www.cpantesters.org/cpan/report/e352e802-b262-11e1-85c4-09343af89482
 
 If anyone has any problems, or if anyone knows what is
 causing this
 problem, please let us know.
 
 Thanks,
 Jeff




 -- 
 Jeffrey T. Palmer




 -- 
 Jeffrey T. Palmer


AW: SDL 2.541_02 Released

2012-06-11 Thread email

Hi, I know whats wrong and why it didnt happened to me!

1) SDL_mixer loads libs like ogg/vorbis using SDL's loadso functions.  
These functions try to find libs like ogg in path. Since libbogg isnt  
in path when building it using Alien::SDL, it cant find it.


2) It worked on my box because I had the same lib (with exactly the  
same name, libvorbis.so.3) in my LD_LIBRARY_PATH, thats why it found  
the lib.


What we have to do (tested):
1) add these libs to Alien::SDL::ConfigData
2) tell SDL that it has to load these libs using Dynaloader, so  
SDL_mixer dont need to search for it or even load it.


I'll apply patches later.


Re: SDL 2.541_02 Released

2012-06-10 Thread Jeffrey Palmer
So are we ready to bump our Alien::SDL prereq (at least in the dev
release)?  Also, I'm assuming we should skip these tests if libogg support
isn't available.  What's the proper way to detect audio format support?

Jeff

On Sat, Jun 9, 2012 at 9:51 PM, Tobias Leich em...@froggs.de wrote:

 Hi, the tester is still using the old Alien::SDL, this one doesnt build
 libogg and libvorbis.

 Jeffrey Palmer jeffrey.t.pal...@gmail.com hat geschrieben:

 Hi All,
 
 I released SDL 2.541_02 today after Blaizer++ merged in his changes that
 were accidentally included in 2.538.  The early test reports are in and
 we're still having some issues with the SDL::Mixer::MixMusic tests that
 use
 ogg:
 
 
 
 http://www.cpantesters.org/cpan/report/5399278a-b262-11e1-bea2-18293af89482
 
 
 http://www.cpantesters.org/cpan/report/e352e802-b262-11e1-85c4-09343af89482
 
 If anyone has any problems, or if anyone knows what is causing this
 problem, please let us know.
 
 Thanks,
 Jeff




-- 
Jeffrey T. Palmer


Re: SDL 2.541_02 Released

2012-06-10 Thread Tobias Leich
Ya, would be sweet to make another dev release, requiring a newer
Alien::SDL.

Check t/mixer.t for audio support, its basically just that you try to
init OGG, and skip if it fails.

Am 10.06.2012 18:03, schrieb Jeffrey Palmer:
 So are we ready to bump our Alien::SDL prereq (at least in the dev
 release)?  Also, I'm assuming we should skip these tests if libogg
 support isn't available.  What's the proper way to detect audio format
 support?

 Jeff

 On Sat, Jun 9, 2012 at 9:51 PM, Tobias Leich em...@froggs.de
 mailto:em...@froggs.de wrote:

 Hi, the tester is still using the old Alien::SDL, this one doesnt
 build libogg and libvorbis.

 Jeffrey Palmer jeffrey.t.pal...@gmail.com
 mailto:jeffrey.t.pal...@gmail.com hat geschrieben:

 Hi All,
 
 I released SDL 2.541_02 today after Blaizer++ merged in his
 changes that
 were accidentally included in 2.538.  The early test reports are
 in and
 we're still having some issues with the SDL::Mixer::MixMusic
 tests that use
 ogg:
 
 
 
 http://www.cpantesters.org/cpan/report/5399278a-b262-11e1-bea2-18293af89482
 
 
 http://www.cpantesters.org/cpan/report/e352e802-b262-11e1-85c4-09343af89482
 
 If anyone has any problems, or if anyone knows what is causing this
 problem, please let us know.
 
 Thanks,
 Jeff




 -- 
 Jeffrey T. Palmer


Re: SDL 2.541_02 Released

2012-06-10 Thread Jeffrey Palmer
This problems still occurs occasionally with Alien-SDL 1.434


http://www.cpantesters.org/cpan/report/04921c82-b30c-11e1-9066-3d54fb7543f5

I created an issue about this a while ago:

https://github.com/PerlGameDev/SDL/issues/233

The build option include ogg, but those same tests fail.  Should those
tests pass with those build options?

Jeff

On Sun, Jun 10, 2012 at 1:21 PM, Tobias Leich em...@froggs.de wrote:

  Ya, would be sweet to make another dev release, requiring a newer
 Alien::SDL.

 Check t/mixer.t for audio support, its basically just that you try to init
 OGG, and skip if it fails.

 Am 10.06.2012 18:03, schrieb Jeffrey Palmer:

 So are we ready to bump our Alien::SDL prereq (at least in the dev
 release)?  Also, I'm assuming we should skip these tests if libogg support
 isn't available.  What's the proper way to detect audio format support?

  Jeff

 On Sat, Jun 9, 2012 at 9:51 PM, Tobias Leich em...@froggs.de wrote:

 Hi, the tester is still using the old Alien::SDL, this one doesnt build
 libogg and libvorbis.

 Jeffrey Palmer jeffrey.t.pal...@gmail.com hat geschrieben:

 Hi All,
 
 I released SDL 2.541_02 today after Blaizer++ merged in his changes that
 were accidentally included in 2.538.  The early test reports are in and
 we're still having some issues with the SDL::Mixer::MixMusic tests that
 use
 ogg:
 
 
 
 http://www.cpantesters.org/cpan/report/5399278a-b262-11e1-bea2-18293af89482
 
 
 http://www.cpantesters.org/cpan/report/e352e802-b262-11e1-85c4-09343af89482
 
 If anyone has any problems, or if anyone knows what is causing this
 problem, please let us know.
 
 Thanks,
 Jeff




  --
 Jeffrey T. Palmer




-- 
Jeffrey T. Palmer


SDL 2.541_02 Released

2012-06-09 Thread Jeffrey Palmer
Hi All,

I released SDL 2.541_02 today after Blaizer++ merged in his changes that
were accidentally included in 2.538.  The early test reports are in and
we're still having some issues with the SDL::Mixer::MixMusic tests that use
ogg:


http://www.cpantesters.org/cpan/report/5399278a-b262-11e1-bea2-18293af89482

http://www.cpantesters.org/cpan/report/e352e802-b262-11e1-85c4-09343af89482

If anyone has any problems, or if anyone knows what is causing this
problem, please let us know.

Thanks,
Jeff


AW: SDL 2.541_02 Released

2012-06-09 Thread Tobias Leich
Hi, the tester is still using the old Alien::SDL, this one doesnt build libogg 
and libvorbis.

Jeffrey Palmer jeffrey.t.pal...@gmail.com hat geschrieben:

Hi All,

I released SDL 2.541_02 today after Blaizer++ merged in his changes that
were accidentally included in 2.538.  The early test reports are in and
we're still having some issues with the SDL::Mixer::MixMusic tests that use
ogg:


http://www.cpantesters.org/cpan/report/5399278a-b262-11e1-bea2-18293af89482

http://www.cpantesters.org/cpan/report/e352e802-b262-11e1-85c4-09343af89482

If anyone has any problems, or if anyone knows what is causing this
problem, please let us know.

Thanks,
Jeff