hg: jdk8/tl/jdk: 8010430: Math.round has surprising behavior for odd values of ulp 1

2013-09-13 Thread brian . burkhalter
Changeset: 917fffe971c8 Author:bpb Date: 2013-09-11 17:07 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/917fffe971c8 8010430: Math.round has surprising behavior for odd values of ulp 1 Summary: If the effective floating point exponent is zero return the significand

hg: jdk8/tl/jdk: 8024331: j.u.Map.computeIfPresent() default/nondefault implementations don't throw NPE if the remappingFunction is null and the key is absent

2013-09-20 Thread brian . burkhalter
: Explicitly check for null remappingFunction parameter. Reviewed-by: mduigou, forax, psandoz Contributed-by: Brian Burkhalter brian.burkhal...@oracle.com ! src/share/classes/java/util/HashMap.java ! src/share/classes/java/util/Map.java ! test/java/util/Map/Defaults.java

hg: jdk8/tl/jdk: 8016252: More defensive HashSet.readObject

2013-10-09 Thread brian . burkhalter
Changeset: b86e6700266e Author:bpb Date: 2013-10-09 11:47 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/b86e6700266e 8016252: More defensive HashSet.readObject Summary: Add data validation checks in readObject(). Reviewed-by: alanb, mduigou, chegar Contributed-by: Brian

hg: jdk8/tl/jdk: 7189139: BigInteger's staticRandom field can be a source of bottlenecks.

2013-10-09 Thread brian . burkhalter
Contributed-by: Brian Burkhalter brian.burkhal...@oracle.com ! src/share/classes/java/math/BigInteger.java

hg: jdk8/tl/jdk: 8010371: getaddrinfo can fail with EAI_SYSTEM/EAGAIN, causes UnknownHostException to be thrown

2013-10-15 Thread brian . burkhalter
. Reviewed-by: alanb, chegar, michaelm, dsamersoff Contributed-by: Brian Burkhalter brian.burkhal...@oracle.com ! src/solaris/native/java/net/Inet4AddressImpl.c ! src/windows/native/java/net/Inet4AddressImpl.c ! src/windows/native/java/net/Inet6AddressImpl.c

hg: jdk8/tl/jdk: 8026832: Clean up straggling doclint warnings in java.math

2013-10-17 Thread brian . burkhalter
Changeset: e76bb2436b04 Author:bpb Date: 2013-10-17 15:05 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/e76bb2436b04 8026832: Clean up straggling doclint warnings in java.math Summary: Fix empty paragraph tag warnings. Reviewed-by: lancea !

hg: jdk8/tl/jdk: 8026806: Incomplete test of getaddrinfo() return value could lead to incorrect exception for Windows Inet 6

2013-10-22 Thread brian . burkhalter
Changeset: 9758edb6976f Author:bpb Date: 2013-10-22 10:44 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/9758edb6976f 8026806: Incomplete test of getaddrinfo() return value could lead to incorrect exception for Windows Inet 6 Summary: Check getaddrinfo return value before

hg: jdk8/tl/jdk: 7179567: JCK8 tests: api/java_net/URLClassLoader/index.html#Ctor3 failed with NPE; ...

2013-10-22 Thread brian . burkhalter
Changeset: 2be08cdd1ced Author:bpb Date: 2013-10-22 11:25 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/2be08cdd1ced 7179567: JCK8 tests: api/java_net/URLClassLoader/index.html#Ctor3 failed with NPE 6445180: URLClassLoader does not describe the behavior of several methods

hg: jdk8/tl/jdk: 6910473: java.math.BigInteger.bitLength() may return negative int on large numbers; ...

2013-10-30 Thread brian . burkhalter
Changeset: 0734e1584d9d Author:bpb Date: 2013-10-30 17:45 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/0734e1584d9d 6910473: java.math.BigInteger.bitLength() may return negative int on large numbers 8021203: BigInteger.doubleValue/floatValue returns 0.0 instead of

hg: jdk8/tl/jdk: 8027625: test/java/math/BigInteger/ExtremeShiftingTests.java needs @run tag to specify heap size

2013-11-04 Thread brian . burkhalter
Changeset: 92fb6baaebc4 Author:bpb Date: 2013-11-04 08:05 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/92fb6baaebc4 8027625: test/java/math/BigInteger/ExtremeShiftingTests.java needs @run tag to specify heap size Summary: Add @run tag to specify heap size Reviewed-by:

hg: jdk8/tl/jdk: 8022181: Tune algorithm crossover thresholds in BigInteger

2013-12-03 Thread brian . burkhalter
Changeset: c138b0d33980 Author:bpb Date: 2013-12-03 12:25 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/c138b0d33980 8022181: Tune algorithm crossover thresholds in BigInteger Summary: Change multiplication, squaring, division, and base conversion thresholds to values

hg: jdk8/tl/jdk: 2 new changesets

2013-12-05 Thread brian . burkhalter
Changeset: d3c4e8fe98c3 Author:bpb Date: 2013-12-05 07:44 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/d3c4e8fe98c3 8029514: java/math/BigInteger/BigIntegerTest.java failing since thresholds adjusted in 8022181 Summary: Ensure the value returned by getLower() is unsigned.

Re: RFR 8164705: Remove pathname canonicalization from FilePermission

2016-09-01 Thread Brian Burkhalter
At the API level and conceptually this all appears reasonable. I am going to need to take a deeper pass over it all however to comprehend the implementation at any kind of detailed level. The changes mentioned in response to Alan’s comments all appear good. Thanks, Brian On Sep 1, 2016, at

Re: RFR 8164705: Remove pathname canonicalization from FilePermission

2016-09-13 Thread Brian Burkhalter
Not really. Will continue with it. I’m not sure whether Alan is done with it either. Brian On Sep 12, 2016, at 8:34 PM, Weijun Wang <weijun.w...@oracle.com> wrote: > Have you finished the deeper pass? :-) > > Thanks > Max > > On 9/2/2016 8:18, Brian Burkhalter wr

Re: RFR 8164705: Remove pathname canonicalization from FilePermission

2016-09-12 Thread Brian Burkhalter
Only picky comments: not sure but maybe change: 1) vice versa -> and vice versa 2) When it’s set to true -> When true 3) just like before -> as before Brian On Sep 12, 2016, at 12:23 AM, Weijun Wang wrote: > BTW, please also review the release note at > >

Re: RFR: 8184208: update class="striped" tables for accessibility

2017-07-11 Thread Brian Burkhalter
On Jul 11, 2017, at 2:39 PM, Jonathan Gibbons wrote: > Please review this auto-generated update to improve the accessibility of many > of the tables > in the API docs for the java.base module. Looks all right to me. > All the modifiied tables have been visually

Re: RFR for 6443578 and 6202130: UTF-8 in Manifests

2018-05-04 Thread Brian Burkhalter
For more specifics about allowed attachment types see [1]. Brian [1] http://mail.openjdk.java.net/pipermail/code-tools-dev/2018-March/000378.html On May 4, 2018, at 12:51 PM, Roger Riggs wrote: > Just a reminder that OpenJDK can *only* accept patches via

Re: JDK 12 RFR of JDK-8209024: Use SuppressWarnings on serialVersionUID fields in interfaces

2018-08-06 Thread Brian Burkhalter
Hi Joe, Looks fine. Brian On Aug 6, 2018, at 12:11 PM, joe darcy wrote: > Various interfaces in the JDK extend Serializable and declare > serialVersionUID fields. Such fields are ineffectual and > @SuppressWarnings("serial") should be applied to such fields to suppress > future planned

Re: RFR 8211360 : Change #if DEF to #if defined(DEF)

2019-08-20 Thread Brian Burkhalter
Hello Ivan, Looks fine. Brian > On Aug 20, 2019, at 10:38 AM, Ivan Gerasimov > wrote: > > It's a followup for JDK-8211146. > > With that fix several C-preprocessor statements of form #elif __linux__ were > changed to more accurate #elif defined(__linux__). > > grep found a few more

Re: RFR: 8250564: Remove terminally deprecated constructor in GSSUtil

2021-01-05 Thread Brian Burkhalter
On Tue, 5 Jan 2021 21:02:21 GMT, Joe Darcy wrote: > Back in JDK 16, two unintended default constructors were identified and > deprecated for removal. The time has come to remove them. > > Please also review the corresponding CSRs: > > JDK-8258521 Remove terminally deprecated constructor in

Re: [jdk17] RFR: 8266345: (fs) Custom DefaultFileSystemProvider security related loops

2021-07-08 Thread Brian Burkhalter
On Thu, 8 Jul 2021 18:21:31 GMT, Sean Mullan wrote: > Please review this fix to use the platform's default file system to avoid > recursive policy initialization > issues when a SecurityManager is enabled and the VM is configured to use a > custom file system provider. Looks good.

Re: RFR: 8263190: Update java.io, java.math, and java.text to use instanceof pattern variable

2021-03-08 Thread Brian Burkhalter
On Mon, 8 Mar 2021 18:48:30 GMT, Patrick Concannon wrote: > Hi, > > Could someone please review my code for updating the code in the `java.io`, > `java.math`, and `java.text` packages to make use of the `instanceof` pattern > variable? > > Kind regards, > Patrick Looks good and builds

Re: RFR: JDK-8261601: free memory in early return in Java_sun_nio_ch_sctp_SctpChannelImpl_receive0

2021-02-12 Thread Brian Burkhalter
On Fri, 12 Feb 2021 08:50:14 GMT, Matthias Baesken wrote: > There seems to be an early return in > Java_sun_nio_ch_sctp_SctpChannelImpl_receive0 that misses freeing memory. > > Sonar reports : > https://sonarcloud.io/project/issues?id=shipilev_jdk=c=AXck8Cl0BBG2CXpcnjFu=false=BLOCKER=BUG > >

Re: RFR: 8273528: Avoid ByteArrayOutputStream.toByteArray when converting stream to String

2021-09-09 Thread Brian Burkhalter
On Thu, 2 Sep 2021 20:19:40 GMT, Andrey Turbanov wrote: > Using `ByteArrayOutputStream.toString` to convert it's content to a String is > cleaner than `new String(out.toByteArray())`. Also it's a bit faster because > of one less array copy. Marked as reviewed by bpb (Reviewer).

Re: RFR: 8274835: Remove unnecessary castings in java.base

2021-10-06 Thread Brian Burkhalter
On Thu, 9 Sep 2021 20:12:47 GMT, Andrey Turbanov wrote: > Redundant castings make code harder to read. > Found them by IntelliJ IDEA. > I tried to select only casts which are definitely safe to remove. Also didn't > touch primitive types casts. `java.io` change looks all right. -

Re: RFR: 8274075: Fix miscellaneous typos in java.base [v4]

2021-09-22 Thread Brian Burkhalter
On Wed, 22 Sep 2021 15:38:33 GMT, Pavel Rappo wrote: >> 8274075: Fix miscellaneous typos in java.base > > Pavel Rappo has updated the pull request incrementally with one additional > commit since the last revision: > > Add missing "the" > > (

Re: RFR: 8274075: Fix miscellaneous typos in java.base [v2]

2021-09-21 Thread Brian Burkhalter
On Tue, 21 Sep 2021 13:16:02 GMT, Pavel Rappo wrote: >> 8274075: Fix miscellaneous typos in java.base > > Pavel Rappo has updated the pull request incrementally with one additional > commit since the last revision: > > Tweak wording for Throwable constructor parameters

Re: RFR: 8274075: Fix miscellaneous typos in java.base [v2]

2021-09-21 Thread Brian Burkhalter
On Tue, 21 Sep 2021 17:07:45 GMT, Pavel Rappo wrote: >> It does seem a bit strange to say "Throwing a wrapping" > > If we have two exceptions A and B, such that B is the cause of A, then A is > the wrapping exception (the one that wraps or the wrapper) and B is the > wrapped exception (the

Re: RFR: 8274075: Fix miscellaneous typos in java.base [v2]

2021-09-21 Thread Brian Burkhalter
On Tue, 21 Sep 2021 17:39:41 GMT, Pavel Rappo wrote: >> Would "wrappER" be better? > > We can either revert this part of the change or rephrase it. Mind you, > rephrasing might prove tricky because of non-local changes it might > introduce. There's one more occurrence of "wrapped exception" in

Re: RFR: 8283800: Simplify String.indexOf/lastIndexOf calls

2022-03-28 Thread Brian Burkhalter
On Sun, 20 Mar 2022 12:45:34 GMT, Andrey Turbanov wrote: > In a few places String.indexOf/lastIndexOf methods are called with default > parameter for index: `0` for `indexOf`, length() for `lastIndexOf`. > I propose to cleanup such calls. It makes code a bit easier to read. In case > of

Re: RFR: 8284780: Need methods to create pre-sized HashSet and LinkedHashSet [v17]

2022-06-01 Thread Brian Burkhalter
On Fri, 27 May 2022 18:40:32 GMT, XenoAmess wrote: >> as title. > > XenoAmess has updated the pull request incrementally with one additional > commit since the last revision: > > do it as naotoj said `java.io` and `java.nio` look all right. - Marked as reviewed by bpb

Re: RFR: 8284853: Fix varios 'expected' typo

2022-04-13 Thread Brian Burkhalter
On Wed, 13 Apr 2022 20:36:48 GMT, Andrey Turbanov wrote: > Found various typos of expected: `exepected`, `exept`, `epectedly`, > `expeced`, `Unexpeted`, etc. Expect the Unexpeted. - Marked as reviewed by bpb (Reviewer). PR: https://git.openjdk.java.net/jdk/pull/8231

Re: RFR: 8286378: Address possibly lossy conversions in java.base

2022-05-10 Thread Brian Burkhalter
On Tue, 10 May 2022 21:32:10 GMT, Roger Riggs wrote: > PR#8599 8244681: proposes to add compiler warnings for possible lossy > conversions > From the CSR: > > "If the type of the right-hand operand of a compound assignment is not > assignment compatible with the type of the variable, a cast

Re: RFR: 8286378: Address possibly lossy conversions in java.base [v3]

2022-05-11 Thread Brian Burkhalter
On Wed, 11 May 2022 16:30:41 GMT, Roger Riggs wrote: >> PR#8599 8244681: proposes to add compiler warnings for possible lossy >> conversions >> From the CSR: >> >> "If the type of the right-hand operand of a compound assignment is not >> assignment compatible with the type of the variable, a