Re: RFR: 8282632: Cleanup unnecessary calls to Throwable.initCause() in java.security.jgss [v2]

2022-03-07 Thread Rajan Halade
On Sat, 5 Mar 2022 06:49:43 GMT, Andrey Turbanov  wrote:

>> Pass cause exception as constructor parameter is shorter and easier to read.
>
> Andrey Turbanov has updated the pull request incrementally with one 
> additional commit since the last revision:
> 
>   8282632: Cleanup unnecessary calls to Throwable.initCause() in 
> java.security.jgss
>   typo

Marked as reviewed by rhalade (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/7682


Re: RFR: 8282632: Cleanup unnecessary calls to Throwable.initCause() in java.security.jgss [v2]

2022-03-05 Thread Sean Mullan
On Sat, 5 Mar 2022 06:49:43 GMT, Andrey Turbanov  wrote:

>> Pass cause exception as constructor parameter is shorter and easier to read.
>
> Andrey Turbanov has updated the pull request incrementally with one 
> additional commit since the last revision:
> 
>   8282632: Cleanup unnecessary calls to Throwable.initCause() in 
> java.security.jgss
>   typo

Marked as reviewed by mullan (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/7682


Re: RFR: 8282632: Cleanup unnecessary calls to Throwable.initCause() in java.security.jgss [v2]

2022-03-04 Thread Andrey Turbanov
On Fri, 4 Mar 2022 15:39:56 GMT, Sean Mullan  wrote:

>> Andrey Turbanov has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   8282632: Cleanup unnecessary calls to Throwable.initCause() in 
>> java.security.jgss
>>   typo
>
> src/java.security.jgss/share/classes/sun/security/krb5/internal/crypto/dk/ArcFourCrypto.java
>  line 161:
> 
>> 159:Ksign = getHmac(baseKey, new_ss);
>> 160: } catch (Exception e) {
>> 161: throw new GeneralSecurityException("Calculate Checkum 
>> Failed!", e);
> 
> Can you also fix the typo, "Checkum" should be "Checksum". Same comment 
> applies to line 172.

Sure. Fixed

-

PR: https://git.openjdk.java.net/jdk/pull/7682


Re: RFR: 8282632: Cleanup unnecessary calls to Throwable.initCause() in java.security.jgss [v2]

2022-03-04 Thread Andrey Turbanov
> Pass cause exception as constructor parameter is shorter and easier to read.

Andrey Turbanov has updated the pull request incrementally with one additional 
commit since the last revision:

  8282632: Cleanup unnecessary calls to Throwable.initCause() in 
java.security.jgss
  typo

-

Changes:
  - all: https://git.openjdk.java.net/jdk/pull/7682/files
  - new: https://git.openjdk.java.net/jdk/pull/7682/files/524ba92d..490f7ecb

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=jdk=7682=01
 - incr: https://webrevs.openjdk.java.net/?repo=jdk=7682=00-01

  Stats: 2 lines in 1 file changed: 0 ins; 0 del; 2 mod
  Patch: https://git.openjdk.java.net/jdk/pull/7682.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/7682/head:pull/7682

PR: https://git.openjdk.java.net/jdk/pull/7682


Re: RFR: 8282632: Cleanup unnecessary calls to Throwable.initCause() in java.security.jgss

2022-03-04 Thread Sean Mullan
On Thu, 3 Mar 2022 19:33:21 GMT, Andrey Turbanov  wrote:

> Pass cause exception as constructor parameter is shorter and easier to read.

src/java.security.jgss/share/classes/sun/security/krb5/internal/crypto/dk/ArcFourCrypto.java
 line 161:

> 159:Ksign = getHmac(baseKey, new_ss);
> 160: } catch (Exception e) {
> 161: throw new GeneralSecurityException("Calculate Checkum 
> Failed!", e);

Can you also fix the typo, "Checkum" should be "Checksum". Same comment applies 
to line 172.

-

PR: https://git.openjdk.java.net/jdk/pull/7682


Re: RFR: 8282632: Cleanup unnecessary calls to Throwable.initCause() in java.security.jgss

2022-03-04 Thread Сергей Цыпанов
On Thu, 3 Mar 2022 19:33:21 GMT, Andrey Turbanov  wrote:

> Pass cause exception as constructor parameter is shorter and easier to read.

LGTM

-

Marked as reviewed by stsypa...@github.com (no known OpenJDK username).

PR: https://git.openjdk.java.net/jdk/pull/7682