Re: RFR: JDK-8301070: Replace NULL with nullptr in share/memory/ [v2]

2023-01-26 Thread Johan Sjölen
> Hi, this PR changes all occurrences of NULL to nullptr for the subdirectory > share/memory/. Unfortunately the script that does the change isn't perfect, > and so we > need to comb through these manually to make sure nothing has gone wrong. I > also review these changes but things slip past

Re: RFR: JDK-8301070: Replace NULL with nullptr in share/memory/ [v2]

2023-01-26 Thread Johan Sjölen
On Thu, 26 Jan 2023 15:04:06 GMT, Johan Sjölen wrote: >> src/hotspot/share/memory/metaspace/blockTree.hpp line 228: >> >>> 226: DEBUG_ONLY(check_node(insertion_point);) >>> 227: if (n->_word_size == insertion_point->_word_size) { >>> 228: add_to_list(n, insertion_point); //

Re: RFR: JDK-8301070: Replace NULL with nullptr in share/memory/ [v2]

2023-01-26 Thread Johan Sjölen
On Thu, 26 Jan 2023 09:48:06 GMT, Thomas Stuefe wrote: >Small nit. Do we have a unified naming scheme for comments? Yeah, I forgot to update the PR message with all of the info. If you check now you can see what's been decided upon. The discussions can be found in previous PRs, I can link to

Re: RFR: JDK-8301070: Replace NULL with nullptr in share/memory/

2023-01-26 Thread Thomas Stuefe
On Wed, 25 Jan 2023 11:45:47 GMT, Johan Sjölen wrote: > Do the conversion in the share/memory/ sub-directory and all of its files. Metaspace changes are good. src/hotspot/share/memory/metaspace/blockTree.hpp line 228: > 226: DEBUG_ONLY(check_node(insertion_point);) > 227: if

Re: RFR: JDK-8301070: Replace NULL with nullptr in share/memory/

2023-01-26 Thread Stefan Karlsson
On Wed, 25 Jan 2023 11:45:47 GMT, Johan Sjölen wrote: > Do the conversion in the share/memory/ sub-directory and all of its files. Marked as reviewed by stefank (Reviewer). src/hotspot/share/memory/guardedMemory.hpp line 196: > 194:*/ > 195: void* wrap_with_guards(void* base_ptr, size_t

Re: RFR: JDK-8301070: Replace NULL with nullptr in share/memory/

2023-01-25 Thread Johan Sjölen
On Wed, 25 Jan 2023 11:45:47 GMT, Johan Sjölen wrote: > Do the conversion in the share/memory/ sub-directory and all of its files. Passes tier1. - PR: https://git.openjdk.org/jdk/pull/12185

Re: RFR: JDK-8301070: Replace NULL with nullptr in share/memory/

2023-01-25 Thread Johan Sjölen
On Wed, 25 Jan 2023 11:45:47 GMT, Johan Sjölen wrote: > Do the conversion in the share/memory/ sub-directory and all of its files. Found one manual fix src/hotspot/share/memory/heap.cpp line 666: > 664: /** > 665: * Search freelist for an entry on the list with the best fit. > 666: *

RFR: JDK-8301070: Replace NULL with nullptr in share/memory/

2023-01-25 Thread Johan Sjölen
Do the conversion in the share/memory/ sub-directory and all of its files. - Commit messages: - Fix manual issue - Replace NULL with nullptr in share/memory/ Changes: https://git.openjdk.org/jdk/pull/12185/files Webrev: https://webrevs.openjdk.org/?repo=jdk=12185=00 Issue: