[sniffer] Re: Uploading problems

2006-12-12 Thread Serge
Pete,

Is it ok to submit spam where the header and subjet were modified by declude
?



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-12 Thread Pete McNeil
Hello Serge,

Yes.

Wednesday, December 13, 2006, 12:44:13 AM, you wrote:

 Pete,

 Is it ok to submit spam where the header and subjet were modified by declude
 ?



 #
 This message is sent to you because you are subscribed to
   the mailing list sniffer@sortmonster.com.
 To unsubscribe, E-mail to: [EMAIL PROTECTED]
 To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
 To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
 Send administrative queries to  [EMAIL PROTECTED]



-- 
Pete McNeil
Chief Scientist,
Arm Research Labs, LLC.


#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-08 Thread Serge

Hi Pete  all

after  200 PORT command successful. Consider using PASV.
I am getting
425 connection failed

Is this another FW issue ?

would you please share the batch  script you use with wput to upload logs 
on pasv mode


TIA

- Original Message - 
From: Pete McNeil [EMAIL PROTECTED]

To: Message Sniffer Community sniffer@sortmonster.com
Sent: Friday, December 08, 2006 3:22 AM
Subject: [sniffer] Re: Uploading problems



Hello K,

Thursday, December 7, 2006, 9:32:27 PM, you wrote:

snip/

  Since my FTP program hasn't seemed to be able to get log files 
uploaded,

I tried uploading via the command prompt on my mail server...


ftp open ftp.sortmonster.net

Connected to www.sortmonster.net.
220 Hello.
User (www.sortmonster.net:(none)):
331 Please specify the password.



230 Login successful.

ftp
ftp bin

200 Switching to Binary mode.

ftp hash

Hash mark printing On  ftp: (2048 bytes/hash mark) .

ftp send mylogfile061203.log

200 PORT command successful. Consider using PASV.
150 Ok to send data.


  At this point it just hangs, no transfer occurring. In the event that 
it
might be transferring but not displaying the hash marks, I left it sit 
for

over 30 minutes(10mb logfile)...nothing. I'm not sure what else to try.


What you've described usually goes along with a firewall problem.
Firewalls and FTP are always a challenge. What seems to be happening
is that the command channel is working fine, but when it's time to set
up the data channel that fails- and so you don't get any data.

You might try using PASV mode so you don't have to open up your
firewall too much. I think that SFTP also works on this box though
I've not tried it personally.

We have approximately 130 systems uploading log files, so I'm sure the
server side is working ok.

_M

--
Pete McNeil
Chief Scientist,
Arm Research Labs, LLC.


#
This message is sent to you because you are subscribed to
 the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]







#
This message is sent to you because you are subscribed to
 the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-08 Thread K Mitchell
At 09:35 PM 12/8/2006 -0500, K Mitchell wrote:
At 02:11 AM 12/9/2006 -, Serge wrote:
Hi Pete  all

after  200 PORT command successful. Consider using PASV.
I am getting
425 connection failed

Is this another FW issue ?

would you please share the batch  script you use with wput to upload logs 
on pasv mode

Forgot to add in my previous post; I used the wputrc file included with
wput to make a wput.ini file in which I specified PASV

;connection_mode = pasv




-- 
Kirk Mitchell-General Manager[EMAIL PROTECTED]
Keystone Connect Unlock Your World
Altoona, PA  814-941-5000   http://www.keyconn.net



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-08 Thread K Mitchell
At 09:35 PM 12/8/2006 -0500, K Mitchell wrote:

  I've just finished putting mine all together. Each of the components have
been tested individually, tonight shortly after midnight will be the first
test of it in it's entirety. In the way of explanation, here's what I'm
doing each night shortly after midnight:

- moving the current logfile to a subfolder, thus rotating the logfiles
- renaming the file to add the date -this uses the Namedate utility I found
at http://www.informatics-consulting.de/software/namedate.htm
- uploading the file
- moving the file to yet another subfolder -this is because the upload
script uses * to cover the date variable, so it wouldn't be good to have 2
or more dated files in the same folder
- sending myself an email confirming that the process has completed
successfully

  This didn't quite work as planned. Apparently wput doesn't recognize
variables in the filename, so I had to swap some lines and do the upload
before the renaming to add the date. I had been hoping to date it before
sending so that, in the odd chance that my prior log hadn't been processed
yet, the new file would have a different name and upload with no problems.
I'll just have to hope that my logs get processed within 24 hours.

Here's the new .cmd file:

@echo off

c:
cd c:\imail\sniffer
move c:\imail\sniffer\licenseID.log logs

cd c:\imail\sniffer\logs

wput -nd licenseID_*.log ftp://snifferlog:[EMAIL PROTECTED]

echo Log upload completed!  sniffupld.txt

namedate /UYO-1Z:ymd licenseID.log

echo Log dated!  sniffupld.txt

move c:\imail\sniffer\logs\licenseID_*.log sent

echo Log moved to Sent folder!  sniffupld.txt

c:\imail\imail1 -f c:\imail\sniffer\logs\sniffupld.txt -s Sniffer log
upload on %COMPUTERNAME% -t [EMAIL PROTECTED] -u sniffer -h yourdomain.net

echo Confirmation emailed!

del c:\imail\sniffer\logs\sniffupld.txt

:Done



-- 
Kirk Mitchell-General Manager[EMAIL PROTECTED]
Keystone Connect Unlock Your World
Altoona, PA  814-941-5000   http://www.keyconn.net



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-08 Thread K Mitchell
At 12:37 AM 12/9/2006 -0500, K Mitchell wrote:

wput -nd licenseID_*.log ftp://snifferlog:[EMAIL PROTECTED]

  Sorry, this line now becomes:

wput -nd licenseID.log ftp://snifferlog:[EMAIL PROTECTED]



-- 
Kirk Mitchell-General Manager[EMAIL PROTECTED]
Keystone Connect Unlock Your World
Altoona, PA  814-941-5000   http://www.keyconn.net



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-07 Thread K Mitchell
At 06:53 PM 12/3/2006 -0500, Pete McNeil wrote:
Hello K,

FTP access for log files is restricted for security reasons. The
information your provide below shows you attempting to do a number of
things that are not allowed - for example, directory listings. It is
possible that the system disconnected you for security reasons
(thought I doubt it).

Uploading log files should be very simple.

  That's what I thought, but for some reason it no longer works as well as
it used to. Up until a couple of months ago, I never had any issues
uploading logfiles. Then I started getting periodic transfer failures that
increased in frequency until I'm at the point now where nothing seems to work.

Connect, login, put your file.

  Since my FTP program hasn't seemed to be able to get log files uploaded,
I tried uploading via the command prompt on my mail server...

ftp open ftp.sortmonster.net
Connected to www.sortmonster.net.
220 Hello.
User (www.sortmonster.net:(none)):
331 Please specify the password.

230 Login successful.
ftp
ftp bin
200 Switching to Binary mode.
ftp hash
Hash mark printing On  ftp: (2048 bytes/hash mark) .
ftp send mylogfile061203.log
200 PORT command successful. Consider using PASV.
150 Ok to send data.

  At this point it just hangs, no transfer occurring. In the event that it
might be transferring but not displaying the hash marks, I left it sit for
over 30 minutes(10mb logfile)...nothing. I'm not sure what else to try.


-- 
Kirk Mitchell-General Manager[EMAIL PROTECTED]
Keystone Connect Unlock Your World
Altoona, PA  814-941-5000   http://www.keyconn.net



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-07 Thread K Mitchell
At 10:22 PM 12/7/2006 -0500, Pete McNeil wrote:
Hello K,

   At this point it just hangs, no transfer occurring. In the event that it
 might be transferring but not displaying the hash marks, I left it sit for
 over 30 minutes(10mb logfile)...nothing. I'm not sure what else to try.

What you've described usually goes along with a firewall problem.
Firewalls and FTP are always a challenge. What seems to be happening
is that the command channel is working fine, but when it's time to set
up the data channel that fails- and so you don't get any data.

  There is no firewall. I have TCP port filtering set up on the machine,
but both 20 and 21 are open.





-- 
Kirk Mitchell-General Manager[EMAIL PROTECTED]
Keystone Connect Unlock Your World
Altoona, PA  814-941-5000   http://www.keyconn.net



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-07 Thread Jay Sudowski - Handy Networks LLC
You will very likely need to use passive mode then, as TCP Port
filtering works very much the same way as a firewall, at least as it
applies to FTP.

-Jay


-Original Message-
From: Message Sniffer Community [mailto:[EMAIL PROTECTED] On
Behalf Of K Mitchell
Sent: Thursday, December 07, 2006 11:29 PM
To: Message Sniffer Community
Subject: [sniffer] Re: Uploading problems


At 10:22 PM 12/7/2006 -0500, Pete McNeil wrote:
Hello K,

   At this point it just hangs, no transfer occurring. In the event
that it
 might be transferring but not displaying the hash marks, I left it
sit for
 over 30 minutes(10mb logfile)...nothing. I'm not sure what else to
try.

What you've described usually goes along with a firewall problem.
Firewalls and FTP are always a challenge. What seems to be happening
is that the command channel is working fine, but when it's time to set
up the data channel that fails- and so you don't get any data.

  There is no firewall. I have TCP port filtering set up on the machine,
but both 20 and 21 are open.





-- 
Kirk Mitchell-General Manager[EMAIL PROTECTED]
Keystone Connect Unlock Your World
Altoona, PA  814-941-5000   http://www.keyconn.net



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]




#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-07 Thread K Mitchell
At 09:36 PM 12/7/2006 -0700, Jay Sudowski - Handy Networks LLC wrote:
You will very likely need to use passive mode then, as TCP Port
filtering works very much the same way as a firewall, at least as it
applies to FTP.

Any recommendations on a command line PASV-capable FTP client?



-- 
Kirk Mitchell-General Manager[EMAIL PROTECTED]
Keystone Connect Unlock Your World
Altoona, PA  814-941-5000   http://www.keyconn.net



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-07 Thread K Mitchell
At 11:16 PM 12/7/2006 -0700, Jay Sudowski - Handy Networks LLC wrote:
Give this a try: http://www.ncftp.com/download/

  Just did about 5 minutes ago. It won't run without specifying a
destination directory, and sortmonster ftp won't allow any directory settings.


Thanks though  :o)



-- 
Kirk Mitchell-General Manager[EMAIL PROTECTED]
Keystone Connect Unlock Your World
Altoona, PA  814-941-5000   http://www.keyconn.net



#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]



[sniffer] Re: Uploading problems

2006-12-07 Thread Matt

Try WPUT

   http://sourceforge.net/projects/wput/

Matt



K Mitchell wrote:

At 11:16 PM 12/7/2006 -0700, Jay Sudowski - Handy Networks LLC wrote:
  

Give this a try: http://www.ncftp.com/download/



  Just did about 5 minutes ago. It won't run without specifying a
destination directory, and sortmonster ftp won't allow any directory settings.


Thanks though  :o)



  


[sniffer] Re: Uploading problems

2006-12-03 Thread Pete McNeil
Hello K,

FTP access for log files is restricted for security reasons. The
information your provide below shows you attempting to do a number of
things that are not allowed - for example, directory listings. It is
possible that the system disconnected you for security reasons
(thought I doubt it).

Uploading log files should be very simple.

Connect, login, put your file.

If you follow that protocol you should have no problems unless your
previously uploaded file has not yet been processed and you've used
the same file name (no timestamp). It is not permitted to overwrite an
existing file.

We've made no changes to the ftp system -- in theory, if it ever works
it should still be working.

Hope this helps,

_M

Sunday, December 3, 2006, 1:39:28 PM, you wrote:

   Still having issues uploading my log files. Sometimes the uploads go
 smoothly, other times it starts the transfer, then errors out partway
 through. Here's a log of yet another failed transfer;


 connecting to 207.97.229.114:21
 Connected to 207.97.229.114 port 21
 220 Hello.
 USER snifferlog
 331 Please specify the password.
 PASS (hidden)
 230 Login successful.
 PWD
 550 Permission denied.
 SYST
 215 UNIX Type: L8
 Host type (S): UNIX (standard)
 TYPE A
 200 Switching to ASCII mode.
 PORT 63,175,74,17,12,152
 200 PORT command successful. Consider using PASV.
 LIST
 550 Permission denied.
 ! Retrieve of folder listing failed (0)
 sending logfile01.log as logfile01.log (1 of 2)
 TYPE I
 200 Switching to Binary mode.
 PORT 63,175,74,17,12,154
 200 PORT command successful. Consider using PASV.
 STOR logfile01.log
 150 Ok to send data.
 ! Send error: connection reset
 Transmitted 27779584 bytes in 930.4 secs, (292.72 Kbps), transfer failed
 ! Receive error: Blocking call cancelled






-- 
Pete McNeil
Chief Scientist,
Arm Research Labs, LLC.


#
This message is sent to you because you are subscribed to
  the mailing list sniffer@sortmonster.com.
To unsubscribe, E-mail to: [EMAIL PROTECTED]
To switch to the DIGEST mode, E-mail to [EMAIL PROTECTED]
To switch to the INDEX mode, E-mail to [EMAIL PROTECTED]
Send administrative queries to  [EMAIL PROTECTED]