Re: Replication broken.. no helpful errors?

2007-09-07 Thread Bill Au
As I had pointed out in my first reply to this thread, you had a directory named temp-snapshot.20070816120113 in your data directory on the slave. Snapinstaller was mistakenly treating that as the lastest snapshot and was installing that every time it was called. Snapinstaller didn't trigger a

Re: Replication broken.. no helpful errors?

2007-09-06 Thread Bill Au
The snapinstaller script opens a new searcher by calling commit. From the attached debug output it looks like that actually worked: + /opt/solr/bin/commit + [[ 0 != 0 ]] + logExit ended 0 Try running the /opt/solr/bin/commit directly with the -V option. Bill On 9/5/07, Matthew Runo [EMAIL

Re: Replication broken.. no helpful errors?

2007-09-06 Thread Matthew Runo
The thing is that a new searcher is not opened if I look in the stats.jsp page. The index version never changes. When I run.. sudo /opt/solr/bin/commit -V -u tomcat5 ..I get a new searcher opened, but even though it (in theory) installed the new index, I see no docs in there. During the

Re: Replication broken.. no helpful errors?

2007-09-06 Thread Yonik Seeley
On 9/6/07, Matthew Runo [EMAIL PROTECTED] wrote: The thing is that a new searcher is not opened if I look in the stats.jsp page. The index version never changes. The index version is read from the index... hence if the lucene index doesn't change (even if a ew snapshot was taken), the version

Re: Replication broken.. no helpful errors?

2007-09-05 Thread Matthew Runo
It seems that the scripts cannot open new searchers at the end of the process, for some reason. Here's a message from cron, but I'm not sure what to make of it... It looks like the files properly copied over, but failed the install. I removed the temp* directory, but still SOLR could not

Re: Replication broken.. no helpful errors?

2007-09-05 Thread Matthew Runo
If it helps anyone, this index is around a gig in size. ++ | Matthew Runo | Zappos Development | [EMAIL PROTECTED] | 702-943-7833 ++ On Sep 5, 2007, at 3:14 PM, Matthew Runo

Re: Replication broken.. no helpful errors?

2007-08-31 Thread Bill Au
latest snapshot /opt/solr/data/temp-snapshot.20070816120113 already installed It looks like you have a directory named temp-snapshot.20070816120113 in your data directory. You should remove it. One of the other script might have left that behind somehow. I will update the snapinstaller