Re: CVS commit: src/lib/libc/gen

2011-03-15 Thread Joerg Sonnenberger
On Tue, Mar 15, 2011 at 03:47:04AM +, Eric Haszlakiewicz wrote:
 Module Name:  src
 Committed By: erh
 Date: Tue Mar 15 03:47:04 UTC 2011
 
 Modified Files:
   src/lib/libc/gen: Makefile.inc
 Added Files:
   src/lib/libc/gen: commaize_number.3 commaize_number.c
 
 Log Message:
 PR#7540, add a commaize_number function, which inserts comma into a string
  of digits to make it more readable.  This is soon to be used in /bin/ls.

Wouldn't a flag for humanize_number be a much better approach for this?
Also, this doesn't belong into libc.

Joerg


re: CVS commit: src/lib/libc/gen

2011-03-15 Thread matthew green

 Module Name:  src
 Committed By: erh
 Date: Tue Mar 15 03:47:04 UTC 2011
 
 Modified Files:
   src/lib/libc/gen: Makefile.inc
 Added Files:
   src/lib/libc/gen: commaize_number.3 commaize_number.c
 
 Log Message:
 PR#7540, add a commaize_number function, which inserts comma into a string
  of digits to make it more readable.  This is soon to be used in /bin/ls.

was this discussed anywhere?  this API seems suboptimal to me and
almost certainly has locale issues.

also the function name is very ugly.


.mrg.


re: CVS commit: src/lib/libc/gen

2011-03-15 Thread matthew green

 On Tue, Mar 15, 2011 at 11:26:05AM +0100, Joerg Sonnenberger wrote:
  On Tue, Mar 15, 2011 at 03:47:04AM +, Eric Haszlakiewicz wrote:
   Module Name:  src
   Committed By: erh
   Date: Tue Mar 15 03:47:04 UTC 2011
   
   Modified Files:
 src/lib/libc/gen: Makefile.inc
   Added Files:
 src/lib/libc/gen: commaize_number.3 commaize_number.c
   
   Log Message:
   PR#7540, add a commaize_number function, which inserts comma into a string
of digits to make it more readable.  This is soon to be used in /bin/ls.
  
  Wouldn't a flag for humanize_number be a much better approach for this?
  Also, this doesn't belong into libc.
 
 There is also the point that the ' printf modifier is supposed to do
 this if the current locale has a thousand separator. As such, I would
 like to see this reverted and done properly.

i concur.  fortunately, you also missed bumping the the libc minor
so this can go away as a bad build issue...


.mrg.


Re: CVS commit: src/include (commaize_number)

2011-03-15 Thread Antti Kantee
On Tue Mar 15 2011 at 05:25:51 -0700, Paul Goyette wrote:
 Module Name:src
 Committed By:   pooka
 Date:   Tue Mar 15 12:21:08 UTC 2011
 
 Modified Files:
 src/include: stdlib.h
 
 Log Message:
 put in a proto for commaize_number()
 (nb. doing this purely as the minimum work solution to get a working build)
 
 
 Maybe we shouldn't fix the build here, since there's also the issue of 
 bumping the minor version of libc which was not done.  With a build 
 break we don't have any compatability issues, but if we let a working 
 build ship with this, don't we have to keep it ~forever?

There's honoring compatibility and then there's just being silly.

-- 
älä karot toivorikkauttas, kyl rätei ja lumpui piisaa


Re: CVS commit: src/include (commaize_number)

2011-03-15 Thread Christos Zoulas
In article 20110315123136.gj2...@cs.hut.fi,
Antti Kantee  po...@netbsd.org wrote:
On Tue Mar 15 2011 at 05:25:51 -0700, Paul Goyette wrote:
 Module Name:src
 Committed By:   pooka
 Date:   Tue Mar 15 12:21:08 UTC 2011
 
 Modified Files:
 src/include: stdlib.h
 
 Log Message:
 put in a proto for commaize_number()
 (nb. doing this purely as the minimum work solution to get a working build)
 
 
 Maybe we shouldn't fix the build here, since there's also the issue of 
 bumping the minor version of libc which was not done.  With a build 
 break we don't have any compatability issues, but if we let a working 
 build ship with this, don't we have to keep it ~forever?

There's honoring compatibility and then there's just being silly.

Remove it; there is %'format

christos



Re: CVS commit: src/include (commaize_number)

2011-03-15 Thread Paul Goyette

On Tue, 15 Mar 2011, Antti Kantee wrote:


On Tue Mar 15 2011 at 05:25:51 -0700, Paul Goyette wrote:

Module Name:src
Committed By:   pooka
Date:   Tue Mar 15 12:21:08 UTC 2011

Modified Files:
   src/include: stdlib.h

Log Message:
put in a proto for commaize_number()
(nb. doing this purely as the minimum work solution to get a working build)



Maybe we shouldn't fix the build here, since there's also the issue of
bumping the minor version of libc which was not done.  With a build
break we don't have any compatability issues, but if we let a working
build ship with this, don't we have to keep it ~forever?


There's honoring compatibility and then there's just being silly.


OK, color me silly !:)



-
| Paul Goyette | PGP Key fingerprint: | E-mail addresses:   |
| Customer Service | FA29 0E3B 35AF E8AE 6651 | paul at whooppee.com|
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette at juniper.net |
| Kernel Developer |  | pgoyette at netbsd.org  |
-


Re: CVS commit: src/lib/libc/gen

2011-03-15 Thread David Laight
On Tue, Mar 15, 2011 at 12:26:05PM +0100, Joerg Sonnenberger wrote:
 On Tue, Mar 15, 2011 at 11:26:05AM +0100, Joerg Sonnenberger wrote:
  On Tue, Mar 15, 2011 at 03:47:04AM +, Eric Haszlakiewicz wrote:
   Module Name:  src
   Committed By: erh
   Date: Tue Mar 15 03:47:04 UTC 2011
   
   Modified Files:
 src/lib/libc/gen: Makefile.inc
   Added Files:
 src/lib/libc/gen: commaize_number.3 commaize_number.c
   
   Log Message:
   PR#7540, add a commaize_number function, which inserts comma into a string
of digits to make it more readable.  This is soon to be used in /bin/ls.
  
  Wouldn't a flag for humanize_number be a much better approach for this?
  Also, this doesn't belong into libc.
 
 There is also the point that the ' printf modifier is supposed to do
 this if the current locale has a thousand separator. As such, I would
 like to see this reverted and done properly.

IIRC scanf() and the number processing sort are also required to parse
numbers with the locale's 1000 separator.
This is all fubar when the thousand sep is ' ' or '.'.

David

-- 
David Laight: da...@l8s.co.uk


Re: CVS commit: src/sys/kern

2011-03-15 Thread YAMAMOTO Takashi
hi,

 On 12.03.11 08:16, YAMAMOTO Takashi wrote:
 Module Name: src
 Committed By:yamt
 Date:Sat Mar 12 07:16:50 UTC 2011
 
 Hi, nice to read/hear you're alive.
 
 Christoph

thank you.

YAMAMOTO Takashi