Re: [spip-dev] SPIP 2.1 - erreur codepage lors de l'installation de plugins [non résolu !]

2010-06-29 Par sujet Pat
--, par amour des choses bien faites et des gentils utilisateurs de SPIP ! Pat

Re: [spip-dev] SPIP 2.1 - erreur codepage lors de l'installation de plugins

2010-06-29 Par sujet Pat
. Les caractères du plugin.xml n'ont rien à voir, il doit manquer un filtre tenant compte du charset du site. Pat

Re: [spip-dev] SPIP 2.1 - erreur codepage lors de l'installation de plugins

2010-06-25 Par sujet Pat
Le 24/06/2010 09:33, klaus++ a écrit : je constate une erreur d'affichage des caractères spéciaux lors de l'installation des plugins sous SPIP 2.1. Je confirme ce bug. Y compris sous SPIP 2.0. Pat

[spip-dev] [librairies++] Re: Pour SPIP 2.2 à Condition que... ?

2010-04-19 Par sujet Pat
cela impliquerait également un système de gestion des versions et des mises à jours. A voir comment simplifier tout ça et stabiliser une API simple de gestion des plugins/extensions/librairies... Pat Le 19/04/2010 13:56, RastaPopoulos a écrit : La 2.1 est sortie. Le plugin Bonux n'ajoute plus

Re: [spip-dev] suggestion: au lieu de

2010-04-14 Par sujet Pat
Oups : $GLOBALS['debut_italique']="<em$GLOBALS[class_spip]>" pat Le 14/04/2010 14:08, Pat a écrit : Et le code de mes_options : $GLOBALS['debut_italique']="<em\$GLOBALS[class_spip]>" $GLOBALS['fin_italique']=""

Re: [spip-dev] suggestion: au lieu de

2010-04-14 Par sujet Pat
Salut, Il y a aussi le Couteau Suisse pour ceux qui l'utilisent : Affichage public > SPIP et ses raccourcis… où on peut tout redéfinir. Et le code de mes_options : $GLOBALS['debut_italique']="<em\$GLOBALS[class_spip]>" $GLOBALS['fin_italique']="&qu

Re: [spip-dev] suppression des class=spip

2010-04-12 Par sujet Pat
Bonjour, A titre d'info, le Couteau Suisse propose la gestion de ces variables : Affichage public > SPIP et ses raccourcis… > Les styles de SPIP par défaut Pat Le 12/04/2010 10:37, Paolo a écrit : Bonjour, L'article sur SPIP 2.0 (http://www.spip.net/fr_article3784.html) no

Re: [spip-dev] incompatibilité ascendante ?

2010-03-17 Par sujet Pat
+1 Pat Le 17/03/2010 15:24, davux a écrit : Wed, 17 Mar 2010 14:41:04 +0100, denisb: 1- [(#VAL{rien.gif}|timestamp)] les écritures 1, 2 et 3 précédentes sont donc à remplacer par : 10- [(#VAL{rien.gif}|appliquer_filtre{timestamp})] Ça c'est le genre de blague qui fait que

Re: [spip-dev] incompatibilité ascendante ?

2010-03-17 Par sujet Pat
partie privée ? PHP lui-même ne bippe que si le filtre n'existe pas au moment de l'exécution... Pat Le 17/03/2010 14:41, denisb a écrit : 1- [(#VAL{rien.gif}|timestamp)] 2- [(#PLUGIN{spip_bonux}|oui) [(#VAL{rien.gif}|timestamp)]] 3- <INCLURE{fond=test, env}> (avec le fichier 'test.htm

Re: [spip-dev] Problème de perfs lié à sha256

2010-03-04 Par sujet Pat
pip('auth/sha256.inc'); + $authenticated[$h] = sha256($h); } - include_spip('auth/sha256.inc'); - return sha256($action.$id_auteur.$pass.@$GLOBALS['meta'][$alea]); + + return $authenticated[$h]; ça donne toujours un gain dans les perfs ? Pat Le 03/03/2010 2

Re: [spip-dev] SPIP 2.1, établir une liste d'incompatibilités (et solutions)

2010-03-02 Par sujet Pat
Ah non, la fonction filtrer n'a qu'un seul argument et ne peut s'utiliser que comme ceci : #VAL{accesrestreint_article_restreint}|filtrer Pat Le 01/03/2010 16:13, Martin Arnaud a écrit : Le 1 mars 2010 à 15:46, Pierre Fiches a écrit : + http://trac.rezo.net/trac/spip/ticket/1862 Je

Re: [spip-dev] Remarques sur les extensions/plugins de la 2.1

2010-03-02 Par sujet Pat
, plugins/actifs ou même plugins/actifs_totalement_indesactivables ? Pat

[spip-dev] SPIP 2.1 : creer_chaine_url

2010-02-24 Par sujet Pat
Bonjour, Le pipeline 'creer_chaine_url' a-t-il définitivement disparu de SPIP 2.1 !? Merci

Re: [spip-dev] SPIP, XML et CDATA sont dans un bateau

2010-01-25 Par sujet Pat
Ticket créé : http://trac.rezo.net/trac/spip/ticket/1854 Pat denisb a écrit : ah mais avec ton patch, si l'erreur : "erreur : tag fermant ![CDATA[toto & lulu sont là.]] manquant ::" disparaît bien, c'est *tout* le "![CDATA[toto & lulu sont là.]]" qui est considéré

Re: [spip-dev] SPIP, XML et CDATA sont dans un bateau

2010-01-17 Par sujet Pat
re ? Pat a écrit le 11/12/2009 : Bonjour à tous, Le fichier xml actuel ne traite pas les données CDATA. En parcourant le code j'ai trouvé le bug et joint le patch pour SPIP 2.0, sachant qu'il faut corriger toutes les versions de SPIP... Merci d'avance. Pat Index: xml.php

Re: [spip-dev] SPIP, XML et CDATA sont dans un bateau

2009-12-20 Par sujet Pat
Oui, l'erreur disparait : le CDATA est tel quel, je ne voulais pas trahir la pensé de celui qui a écrit ce code à l'origine. En effet serait-il judicieux de parser ces données et de les mettre en $text... mais tu mets quoi comme tag ? CDATA ? Pat denisb a écrit : denisb a écrit : (et pas

Re: [spip-dev] SPIP, XML et CDATA sont dans un bateau

2009-12-19 Par sujet Pat
Re, Dois-je faire un ticket pour ce malheureux caractère de trop ? Pat Pat a écrit : Bonjour à tous, Le fichier xml actuel ne traite pas les données CDATA. En parcourant le code j'ai trouvé le bug et joint le patch pour SPIP 2.0, sachant qu'il faut corriger toutes les versions de SPIP

Re: [spip-dev] Page blanche à la publication

2009-12-16 Par sujet Pat
Ya peut-être qq-chose dans ton texte qui fait paniquer SPIP ? Pat Yohann Prigent a écrit : C'est ni le CS ni Bonux ! (je viens d'essayer en les désactivant). Ca doit venir du core alors, quelqu'un peut confirmer ? Le 16 déc. 2009 à 23:37, Pat a écrit : Et là, il faut les désactiver un par un

Re: [spip-dev] Page blanche à la publication

2009-12-16 Par sujet Pat
Et là, il faut les désactiver un par un... Idem en ce qui concerne les lames du CS... Allez au boulot ! Pat Yohann Prigent a écrit : Le 16 déc. 2009 à 23:10, cedric.mo...@yterium.com a écrit : Un plugin ? Des plugins : cfg(1.14.1),corbeille(0.7),couteau_suisse(1.8.10.03),player(0.68

Re: [spip-dev] r14711 - spip/ecrire/inc

2009-12-11 Par sujet Pat
Salut Marcimat, Pourquoi ne pas avoir également utilisé cette constante sur la page ?exec=mots_tous, histoire d'unifier un peu ? Pat marci...@free.fr a écrit : Author: marci...@free.fr Date: 2009-11-03 11:47:36 +0100 (mar, 03 nov 2009) New Revision: 14711 Log: Introduction de la constante

[spip-dev] SPIP, XML et CDATA sont dans un bateau

2009-12-11 Par sujet Pat
Bonjour à tous, Le fichier xml actuel ne traite pas les données CDATA. En parcourant le code j'ai trouvé le bug et joint le patch pour SPIP 2.0, sachant qu'il faut corriger toutes les versions de SPIP... Merci d'avance. Pat Index: xml.php

Re: [spip-dev] Ordre des fonctions d'autorisation : surcharges impossibles ? + Propagations

2009-12-06 Par sujet Pat
Bonjour, Je republie mon patch car une erreur de frappe (et d'inattention!) y figurait. Pat Pat a écrit : Bon, en faisant quelques recherches supplémentaires, je m'aperçois que le sujet des autorisations est un vaste et délicat sujet. Qu'on m'arrête tout de suite si mon propos est stérile

Re: [spip-dev] Ordre des fonctions d'autorisation : surcharges impossibles ? + Propagations

2009-12-04 Par sujet Pat
Stephane a écrit : Pat a écrit : Donc, pour que l'autorisation 'faire' 'qqchose' soit donnée, il faudrait que : 1. l'autorisation de 'faire' soit positive (ou que la fonction associée ne soit pas trouvée) 2. puis, idem pour celle de 'qqchose', 3. et enfin, idem pour celle de

Re: [spip-dev] Ordre des fonctions d'autorisation : surcharges impossibles ? + Propagations

2009-12-04 Par sujet Pat
soit pas trouvée) 2. puis, idem pour celle de 'qqchose', 3. et enfin, idem pour celle de 'faire' 'qqchose' Pat Pat a écrit : En ce qui concerne les surcharges, chacune des _dist ne devrait être appelées amha que si la non _dist associée ne soit pas trouvée. C'est le sens du patch que

Re: [spip-dev] Ordre des fonctions d'autorisation : surcharges impossibles ?

2009-12-04 Par sujet Pat
autoriser_cs_configurer_dist() alors que autoriser_configurer_dist() interdit de configurer quoi que ce soit. Pour programmer une exception, alors la porte de sortie est toujours de créer un nouveau 'faire' : autoriser_configurerlecouteau_dist() ! Pat P.S. : dans un tout autre domaine, SPIP

Re: [spip-dev] Ordre des fonctions d'autorisation : surcharges impossibles ?

2009-12-03 Par sujet Pat
Pat a écrit : Hors, SPIP 2(mais non 1.92) embraye directement sur autoriser_configurer(), fonction qui existe déjà dans autoriser.php. Ceci est une vilaine bêtise, au temps pour moi. C'est le plugin "Autorité" qui surcharge cette fonction, évidemment SPIP ne surcharge rien.

Re: [spip-dev] Ordre des fonctions d'autorisation : surcharges impossibles ?

2009-12-03 Par sujet Pat
elle existe... Pat Fil a écrit : Ca me semblait plus logique comme ça afin de pouvoir surcharger plus facilement une _dist du core, mais effectivement du coup ça coince avec un _dist qui tente d'affiner une pas _dist ... je ne crois pas qu'il y ait quiconque que ça plante si on change de logique

[spip-dev] Ordre des fonctions d'autorisation : surcharges impossibles ?

2009-12-03 Par sujet Pat
autoriser_cs_configurer() n'existe pas ! Comment pouvoir la surcharger dans ce cas ? Merci d'avance. Pat PJ : patch au cas où. Index: autoriser.php === --- autoriser.php (révision 14775) +++ autoriser.php (copie de travail

Re: [spip-dev] r14608 - branches/spip-2.0/ecrire/auth spip/ecrire/auth

2009-10-14 Par sujet Pat
Avec toutes ces corrections depuis qq semaines, puis-je suggérer la sortie d'une version stable 2.0.10 ? Pat e...@rezo.net a écrit : Author: e...@rezo.net Date: 2009-10-14 09:29:18 +0200 (mer, 14 oct 2009) New Revision: 14608 Log: Plutôt que de dupliquer une fonction ([14601]), généraliser

Re: [spip-dev] Mise à jour de SPIP 1.7.2 à 2.0.9 SVN problématique

2009-09-21 Par sujet Pat
Le problème a été soulevé régulièrement. A tel point que le Couteau suisse, quand on arrive à l'activer, détecte cette anomalie. Il serait utile de rechercher la commande SQL qui ne passe pas lors de la mise à jour... Pat RealET a écrit : Bonsoir, Après cette migration, je n'arrivais pas à

Re: [spip-dev] [important] version stable 2.0.9 obsolète sur spip.net

2009-09-03 Par sujet Pat
Ah OK, je comprends mieux... Il faut une 2.0.9 SVN ;-) Pat Ben. a écrit : Si rien ne s'y oppose, je vous remercie de bien vouloir reconstruire le paquet. ah non il faut faire une 2.0.10 on reconstruit pas une 2.0.9 bis Cordialement Ben.

[spip-dev] [important] version stable 2.0.9 obsolète sur spip.net

2009-09-03 Par sujet Pat
balises, beaucoup d'utilisateurs ne peuvent pas mettre à jour SPIP et le bug subsiste :( Mais les corrections sur SPIP ne sont-elle pas automatiquement prises en compte ? Si rien ne s'y oppose, je vous remercie de bien vouloir reconstruire le paquet. Pat

Re: [spip-dev] version PHP pour SPIP 2.1 ?

2009-08-24 Par sujet Pat
réponse. Pat Committo,Ergo:sum a écrit : Le 24 août 09 à 00:34, Pat a écrit : Bonjour, Je viens d'installer un SPIP 2.1 sur un PHP 4.3.10 Cela crée cette erreur : Warning: Wrong parameter count for str_replace() in d:\!developpement internet\easyphp1-8\www\svn\ecrire\inc\utils.php on line 398

[spip-dev] version PHP pour SPIP 2.1 ?

2009-08-24 Par sujet Pat
? La révision [14315] de esj introduit ce changement. Voila, c'était juste une indication. Merci Pat

Re: [spip-dev] Bug sur : mise à jour du CS indispensable pour SPIP 2.0

2009-05-08 Par sujet Pat
paramètres supplémentaires (http://trac.rezo.net/trac/spip/changeset/10301) que le Couteau Suisse intègre désormais. Pat Yohann Prigent a écrit : Salut, Je crains qu'il n'y ait un bug sur le modele ... <formulaire|login> dans un article me renvoie pareil pour <formulaire|recherche>... Une idée ?

Re: [spip-dev] Bug Pagination {ajax} ?

2009-03-30 Par sujet Pat
Je plussoie. J'ai remarqué aussi quelques défauts non déterministes sur onAjaxLoad dernièrement sans avoir vraiment mis le nez dedans. Je remonte les infos si j'en trouve. Pat Matthieu Marcillaud a écrit : Bonjour, - Soit une 2.0 svn [13854] - Soit une (presque) dist, sans plugin, - Soit une

Re: [spip-dev] Le Bug est dans le pré

2009-03-19 Par sujet Pat
Eh oui, suis allé trop vite moi aussi! Voici la correction, c'était tout simple effectivement : return recuperer_fond(str_replace('../','',$fond),array('fond'=>$fond)); Fil et Cédric, merci de vos réponses. Pat, désolé pour le bruit. Fil a écrit : Non, c'est une erreur bloquante cette f

Re: [spip-dev] Le Bug est dans le pré

2009-03-19 Par sujet Pat
renvoient pas tous de warning à ce sujet... Pat Fil a écrit : Non, c'est une erreur bloquante cette fois : vérifier les droits d'écriture. Le système a rencontré une erreur lors de l'écriture du fichier tmp/couteau-suisse/1ac2e6ce1759c835f172f0d220fb4128.html. Veuillez, en tant euh ma modif n'est

Re: [spip-dev] Le Bug est dans le pré

2009-03-19 Par sujet Pat
ecrire/tmp/couteau-suisse. Pat Fil a écrit : define('_DIR_CS_TMP', sous_repertoire(_DIR_TMP, "couteau-suisse")); ? Je dois le passer en absolu, c'est ca ? $fond = _DIR_CS_TMP . md5($code); essaie avec $fond = str_replace('../', '', _DIR_CS_TMP) . md5($code); Il faut voir

Re: [spip-dev] Le Bug est dans le pré

2009-03-18 Par sujet Pat
Mais quoi de mieux que : define('_DIR_CS_TMP', sous_repertoire(_DIR_TMP, "couteau-suisse")); ? Je dois le passer en absolu, c'est ca ? J'y peux rien moi si chemin() va voir systématiquement en '../' ! Pat cedric.mo...@yterium.com a écrit : Le 18 mars 09 à 15:57, Pat a écrit :

Re: [spip-dev] Le Bug est dans le pré

2009-03-18 Par sujet Pat
s($base) OR $GLOBALS['var_mode']=='recalcul') ecrire_fichier($base, $code); include_spip('public/assembler'); return recuperer_fond($fond, array('fond'=>$fond)); // $f = inclure_page($fond, array('fond'=>$fond)); // return $f['texte']; } Pat Fil a écrit :

Re: [spip-dev] Le Bug est dans le pré

2009-03-18 Par sujet Pat
', sous_repertoire(_DIR_TMP, "couteau-suisse")); $fond = _DIR_CS_TMP . md5($code); Pat cedric.mo...@yterium.com a écrit : Le 18 mars 09 à 14:12, Pat a écrit : Remarqué sur SPIP 2.0.6, sur : find_in_path('../tmp/couteau-suisse/1ac2e6ce1759c835f172f0d220fb4128.html') Le bug n'est

Re: [spip-dev] Bug sur is_dir()

2009-03-18 Par sujet Pat
e installé Eclipse !! Pat Fil a écrit : Bon, je te laisse voir ce qu'il en est alors. ben attends t'y es presque, abandonne pas -- Fil

Re: [spip-dev] Bug sur is_dir()

2009-03-18 Par sujet Pat
hmm... nan je seche... il me faut un pro lol Que j'essaie is_readable() ou file_exists(), le warning apparait, free rejete le test. Le "@" parait incontournable qq part, non? Pat Fil a écrit : Bon, je te laisse voir ce qu'il en est alors. ben attends t'y es presque, abandonne pas -- Fil

Re: [spip-dev] Bug sur is_dir()

2009-03-18 Par sujet Pat
OK, je pensais de toute façon que si le dir est rejeté par le système, c'est qu'il n'existe pas. Bon, je te laisse voir ce qu'il en est alors. Pat Fil a écrit : La fonction find_in_path() (inc/utils.php) utilise un is_dir() sans précaution. Sous free, voici les répertoires parcourus, presque

[spip-dev] Bug sur is_dir()

2009-03-18 Par sujet Pat
on line 698 Je pense que free n'aime pas trop ../../ Je propose de remplacer dans SPIP : $dirs[$a] = (is_dir($a) || !$a) ; par : $dirs[$a] = (@is_dir($a) || !$a) ; (patch joint) Pat Index: utils.php === --- utils.php

Re: [spip-dev] Filtre Replace avec retour chariot

2009-03-05 Par sujet Pat
C'était aussi une façon de simplifier par exemple :

Re: [spip-dev] #NOTES sont calculés deux fois - bug?

2009-03-05 Par sujet Pat
Cet article de Vincent use du point d'interrogation : http://www.spip-contrib.net/-Balise-TEXTE-en-mode-brut- Pat

Re: [spip-dev] modification de

2009-01-30 Par sujet Pat
['DESCRIPTIF_SITE_SPIP'][]='traiter_adresse(propre(%s))'; !! Attention, ces lignes vont tuer le traitement des autres plugins présents !!! D'ailleurs, il me semblait que #TEXTE devait passer dans propre()... Pat

Re: [spip-dev] Define _ID_WEBMESTRE et liste des auteurs

2009-01-28 Par sujet Pat
La version 1.8.06.00 du Couteau Suisse montre les webmestres sur la page des auteurs. Les webmestres peuvent également se (dé)coopter grâce à la lame "Liste des webmestres". Pat RealET a écrit : Bonjour, Est-ce que la liste des auteurs ecrire/?exec=auteurs pourrait montrer les web

Re: [spip-dev] [bug] inc/lien.php - nettoyer_raccourcis_typo()

2009-01-06 Par sujet Pat
ok, mais pour cela, il faudrait cette ligne : $titre = $titre ? $titre['titre'] : $type . $id; et non : $titre = $titre ? $titre['titre'] : $match[0]; Pat denisb a écrit : Pat a écrit : Au passage, je comprends pas trop pkoi : if (!$titre) $titre = $match; si pas de titre

[spip-dev] [bug] inc/lien.php - nettoyer_raccourcis_typo()

2009-01-06 Par sujet Pat
e($id, $type, $connect); $titre = $titre['titre']; if (!$titre) $titre = $match; Au passage, je comprends pas trop pkoi : if (!$titre) $titre = $match; Merci 1000x pour la correction ! Pat

Re: [spip-dev] |replace dans la doc

2008-12-22 Par sujet Pat
On en avait parlé sur IRC... |replace{"200[56]",2007} ne marche pas non plus. Pat Matthieu Marcillaud a écrit : Hop, Dans la documentation de SPIP.net ici, http://www.spip.net/fr_article901.html#replace est écrit : «Par exemple pour remplacer tous les 2005 ou 2006 du texte en 2007

Re: [spip-dev] forums de spip-contrib

2008-12-22 Par sujet Pat
notifications par mail deviennent vite obsolètes : pour retrouver un vieux message, ça devient vite une galère pour un forum un peu fourni... Je dis ça, mais je dis rien ! Pat Suske a écrit : Emmanuel Saint-James a écrit : Non seulement on le voit mal, mais en plus on ne sait pas à quoi il sert

Re: [spip-dev] r13393 - in branches/spip-2.0/ecrire: . base

2008-12-11 Par sujet Pat
Bon je viens de créer un ticket pour ce problème : http://trac.rezo.net/trac/spip/ticket/1668 Merci d'avance. Pat Pat a écrit : Merci, mais ce post est incomplet. Il manque encore la fonction objet_type() : function objet_type($table_objet){ $type = preg_replace(',^spip_|s

Re: [spip-dev] sql_showtable

2008-12-09 Par sujet Pat
Et t'as trouvé quoi ? Un couteau ? Pat, k'a pas pu s'en empêcher ! Bernard Blazin a écrit : Bon, c'est bon j'ai trouvé! BB

Re: [spip-dev] r13393 - in branches/spip-2.0/ecrire: . base

2008-12-07 Par sujet Pat
($table_objet){ $type = preg_replace(',^spip_|[sx]$,', '', $table_objet); return $type; } et encore... c'est vraiment ignorer les langues étrangères qui pourraient définir des tables... Sinon, patch join. Pat ced...@yterium.com a écrit : Author: ced...@yterium.com Date: 2008-12-06

[spip-dev] RC1 et page des plugins

2008-11-25 Par sujet Pat
rder-color:#C5E41C rgb(197, 228, 28) -moz-use-text-color; border-style:solid solid none; border-width:1px 1px 0px; -> ? display:-moz-inline-box; font-size:10px; margin:0px; padding:3px; width:96%; } Pat

Re: [spip-dev] Erreur sur survol des boutons de RC1 ?

2008-11-24 Par sujet Pat
Cette erreur a déjà été signalée : http://trac.rezo.net/trac/spip/ticket/1624 Pat Paolo a écrit : Bonsoir, Avec IE8 beta 2, il y a un une erreur lorsque la souris survole les icônes « A suivre », « Édition », etc. dans l'espace privé de SPIP 2.0.0 rc1 SVN [13252]. L'erreur provoquée est

Re: [spip-dev] Changement de config URL arbo ?

2008-11-21 Par sujet Pat
pas bourré de choses obsolètes, sinon, active temporairement l'inclusion en amont dans l'outil "Comportements du CS") Comme tu es en SPIP 2.0 dev, il vaut mieux aussi mettre à jour SPIP. Pat Nicolas Hoizey a écrit : Effectivement, mais je pensais que le paramètre global était quand m

[spip-dev] [BUG JQUERY/IE - SPIP 2] Survol des boutons privés

2008-11-21 Par sujet Pat
_lang(show). Je propose (patch joint) : if(!jQuery('#menu_langues0').length) return; Un ticket pour si peu ? Merci. Pat Index: boutons.php === --- boutons.php (revision 13241) +++ boutons.php (working copy) @@ -594,6 +594,7 @@

Re: [spip-dev] Le bouton "Valider" plugin a disparu - rc1 SVN [13240]

2008-11-21 Par sujet Pat
sur la doc. Je crois que cette page est à revoir. Pat Pierre Bourgeois a écrit : cedric.mo...@yterium.com a écrit : damned ! il est pourtant la chez moi ... Vide ton cache peut etre (si tu as une css pas très à jour ?) Cédric Vider le cache ou le contenu de temp n'a rien résolu. C'est en

Re: [spip-dev] blocage complet site en spip 2.0.0

2008-11-21 Par sujet Pat
/mes_options.php par exemple, qui doit déménager dans config/) Pat denisb a écrit : André LEFRANC a écrit : Question comment passer à spip 2.0.0 ??? en utilisant le bon spip_loader ? http://www.spip-contrib.net/IMG/txt/spip_loader_2RC1.txt (enregistré sous le nom 'spip_loader_2RC1.php')

Re: [spip-dev] Les RSS ne filtrent pas les balise HTML dans les titres

2008-10-25 Par sujet Pat
+1 RealET a écrit : * Pat tapuscrivait, le 25/10/2008 03:11: Salut, C'est le plugin typo_exposants et le couteau suisse qui font ça. Ils font effectivement ça, mais rien n'interdit de le faire manuellement... Donc, c'est tellement simple à changer dans SPIP pour régler le problème

Re: [spip-dev] Les RSS ne filtrent pas les balise HTML dans les titres

2008-10-25 Par sujet Pat
Salut, C'est le plugin typo_exposants et le couteau suisse qui font ça. Ya peut-être moyen de paramétrer les traitements de la balise #TITRE pour que le backend ne soit pas concerné par les mises en exposant... Pat RealET a écrit : Bonsoir, Sur un site, j'ai des balises HTML dans les

Re: [spip-dev] tester_variable() en vieille def

2008-10-17 Par sujet Pat
ah OK Voici les plugins de la zone qui utilisent cette fonction : - barre typo écologique - barre typo extensible - enluminures typographiques - couteau suisse (découpe en page) - pagination articles - SPIP-album Pat Committo,Ergo:sum a écrit

Re: [spip-dev] petit bug de lien introduit par r12922

2008-10-17 Par sujet Pat
Merci, mais : Fatal error: Call to undefined function: tester_variable() in d:\!developpement internet\easyphp1-8\www\svn\tmp\couteau-suisse\mes_fonctions.php on line 232 la fonction tester_variable() est toujours viable? Pat Committo,Ergo:sum a écrit : Le 17 oct. 08 à 09:37, Paolo

Re: [spip-dev] [manque] chaînes de langue dans les éléments éditoriaux

2008-10-11 Par sujet Pat
Exact, je viens d'y rajouter la gestion des arguments, à l'instar de SPIP 2.0. Exemple : <:chaine{arg1=un texte, arg2=un autre texte}:> Pat Paolo a écrit : C'est dans « Blocs multilingues » du couteau suisse.

Re: [spip-dev] r12909 - in branches/spip-2.0/ecrire: action public urls

2008-10-09 Par sujet Pat
sites potentiellement malveillants y figurent en nombre. On me parlait ya pas longtemps d'image de SPIP : ici elle est en jeu. Pat JLuc a écrit : cam.la...@azerttyu.net a écrit : 2008/10/8 Pat <patrice.vanneufvi...@laposte.net>: Oups, kesdoncesite ? C'est pourri par les spams !

Re: [spip-dev] r12909 - in branches/spip-2.0/ecrire: action public urls

2008-10-09 Par sujet Pat
protégé d'urgence, sinon on n'en parle pas. Merci Pat cam.la...@azerttyu.net a écrit : 2008/10/8 Pat <patrice.vanneufvi...@laposte.net>: Oups, kesdoncesite ? C'est pourri par les spams ! Si tu suivais tu le saurais :) Pour etre exact : http://s5.scriibe.net/spip.php?page=s5_rubr

Re: [spip-dev] Lenteurs d'affichage dans spip

2008-10-09 Par sujet Pat
. En fin de compte, il faut nous dire quelles lames tu utilises. Si l'une d'entre elle n'est pas optimisée, ben faut bosser dessus... Pat

Re: [spip-dev] Menus privé verticaux

2008-10-09 Par sujet Pat
Oups, me suis planté, c'est pas config_options.php mais config_outils.php ! Pat a écrit : Ben qui veut l'ajouter ? Rien de plus facile : config_options.php : (...)

Re: [spip-dev] Menus privé verticaux

2008-10-09 Par sujet Pat
> 'Bandeau de l\'interface prive : remplace le menu horizontal de SPIP en un menu vertical.', 'menus_verticaux:nom' => 'Menus verticaux', Chez moi c'est OK avec SPIP 2.0 Par contre faudrait tester aussi en SPIP 1.92... Pat JLuc a écrit : ça passerait bien en plugin ! Ou en l

Re: [spip-dev] r12909 - in branches/spip-2.0/ecrire: action public urls

2008-10-09 Par sujet Pat
Oups, kesdoncesite ? C'est pourri par les spams ! Pat cam.la...@azerttyu.net a écrit : mis à jour : http://s5.scriibe.net/var_mode-urls.html

Re: [spip-dev] Define _ID_WEBMESTRE et liste des auteurs

2008-10-08 Par sujet Pat
le plugin 'autorité' la montre je crois Pat RealET a écrit : Bonjour, Est-ce que la liste des auteurs ecrire/?exec=auteurs pourrait montrer les webmestres du site ?

Re: [spip-dev] {ajax} et callback

2008-10-07 Par sujet Pat
quot;).length)jQuery("div.decoupe_haut").css("display","none"); cs_init.apply(document); }); Pat toutati a écrit : bon, ça marche très bien, super <INCLURE{fond=inc-mesimages}{ajax}> par contre le javascript qui tourne sur ce morceau ne fonctionne plus d

Re: [spip-dev] Suppression de document ou d'image

2008-10-05 Par sujet Pat
Merci Fil, alors je fais un ticket ! ... histoire que d'autres ne vivent pas le même cauchemar que moi hier!! Pat Fil a écrit : La suppression des documents lorsqu'on édite un article ne passe pas en ajax chez moi et peut entrainer une perte de l'article en cours d'édition... non ça n'est

[spip-dev] Suppression de document ou d'image

2008-10-05 Par sujet Pat
Bonjour, La suppression des documents lorsqu'on édite un article ne passe pas en ajax chez moi et peut entrainer une perte de l'article en cours d'édition... Je ne sais pas si c'est voulu à la base... Merci Pat

Re: [spip-dev] [12814 beta 2] Edition : Images en double

2008-09-29 Par sujet Pat
uisez peut-être ? Pat RealET a écrit : Sur http://demo.spip.org/dev/ecrire/?exec=articles_article=40 Impossible de joindre une image à cet article, aussi bien en mode edit de l'article que dans le portfolio.

Re: [spip-dev] [12810 beta 2] alignement à droite d'une colonne commençant par du gras : bug ou volontaire ?

2008-09-29 Par sujet Pat
Merci, je suis tombé sur le même problème. Pat Committo,Ergo:sum a écrit : 12818: objection acceptée (mais c'est bien parce que je suis un saint tous les jours) Committo,Ergo:Sum

Re: [spip-dev] r12773 - in branches/spip-2.0/ecrire: inc public

2008-09-24 Par sujet Pat
Super, et si _NO_CACHE==0 alors que le cache n'a jamais été créé, que renvoit SPIP ? une page blanche ? Pat cedric.mo...@yterium.com a écrit : define('_NO_CACHE',-1); -> ne jamais utiliser le cache ni meme creer les fichiers cache define('_NO_CACHE',1); -> ne pas utiliser le fichier en

Re: [spip-dev] pipeline 'charger_langue'

2008-09-15 Par sujet Pat
c'est la globale $GLOBALS[$GLOBALS['idx_lang']] la responsable. dès que je la retire sa définition, c bon. peut-être les pipelines sont appelés trop tôt... en fait j'en sais rien, je ne connais pas assez bien le code de spip. Pat cedric.mo...@yterium.com a écrit : 12676 le supprime, mais je ne

[spip-dev] pipeline 'charger_langue'

2008-09-15 Par sujet Pat
ce nouveau pipeline (rev 12665) me fait planter ma version locale : Site en travaux Attention : un problème technique (serveur SQL) empêche l'accès à cette partie du site. Merci de votre compréhension. mais j'ai peut-être manqué un truc ? Pat

Re: [spip-dev] Impossible de créer une nouvelle base mysql

2008-08-12 Par sujet Pat
Tu n'as peut-être droit qu'à une seule base sur ton hébergement. Ce cas est fréquent... Pat Aris a écrit : Impossible de créer une nouvelle base mysql SPIP 2.0.0 dev [12316] Par cntre installation dans une base existente sans problèe Aris

Re: [spip-dev] filtre sur #LOGIN_PUBLIC

2008-08-03 Par sujet Pat
arf, dsl pour le bruit, ce passage de devel m'avait échappé ! une petite proposition cependant : générer une erreur de filtre si l'ancienne syntaxe est utilisée... Pat Matthieu Marcillaud a écrit : Pat a écrit : le filtre sur #LOGIN_PUBLIC est-il tjrs pris en compte ? j'ai du mal à faire

[spip-dev] filtre sur #LOGIN_PUBLIC

2008-08-02 Par sujet Pat
Hello, Quitte à dire une bétise, je me lance... le filtre sur #LOGIN_PUBLIC est-il tjrs pris en compte ? j'ai du mal à faire fonctionner un simple [(#LOGIN_PUBLIC|?article1)] en tout cas, aucune redirection en vue... Pat

[spip-dev] .htaccess et SPIP v1.9.3

2008-07-31 Par sujet Pat
Juste un petit truc en passant, le fichier .htaccess contient encore une référence à "SPIP v1.9.3" Pat

Re: [spip-dev] Variable dans le corps d'un article?

2008-06-24 Par sujet Pat
JLuc a écrit : Pat a écrit : Sur un site, j'utilise le raccourcis [tarif:FormuleX] qui est remplacé par la globale $tarif['FormuleX'] Sur un autre site, j'ai une lame qui recense toutes les variables variables spip ou 'locales' ? Variables php dans ce cas. Voici le code. Il donne accès

Re: [spip-dev] Variable dans le corps d'un article?

2008-06-22 Par sujet Pat
, seul un admin toutes rubriques a accès au contenu de ces variables. Si ça vous intéresse et si vous utilisez le Couteau suisse, je peux faire une copie du code. Pat Constant Depièreux a écrit : Bonjour, J'administre plusieurs sites dont certains articles sont communs. Afin de faciliter leur

[spip-dev] [bug] Re: Forum de messagerie incomplet

2008-06-03 Par sujet Pat
Avez-vous jeté un oeil à ce bug ? Pat a écrit : Bonjour, Il semble que certaines réponses aux messages ne soient pas prises en compte. En recherchant un peu, j'ai vu que la pagination était en cause dans inc/discuter.php : (ligne 46) function inc_discuter_dist($id, $script, $objet

[spip-dev] [Couteau Suisse] Ordre des articles dans une rubrique

2008-05-27 Par sujet Pat
Voila, la fonction est ajoutée au Couteau Suisse (version 1.7.18.02) Pat + Nouvel outil : *Tri des articles* En naviguant sur le site en partie privée (./?exec=auteurs), choisissez ici le tri à utiliser pour afficher vos articles à l’intérieur de vos rubriques. Les propositions ci-dessous

[spip-dev] [resolu] Cannot use a scalar value as an array in public/composer.php on line 711

2008-05-27 Par sujet Pat
lignes sont surement obsolètes, je les vire. Merci ! Pat

Re: [spip-dev] Cannot use a scalar value as an array in public/composer.php on line 711

2008-05-27 Par sujet Pat
Pat a écrit : Bonjour, Je viens de mettre à jour un site en svn et j'obtiens ce message : Warning: Cannot use a scalar value as an array in /home.2/stageblo/www/ecrire/public/composer.php on line 711 Voici la ligne de code en question : $GLOBALS['debug']['aucasou'] = array ($table

[spip-dev] [urgent] Re: Forum des messages tout pété

2008-05-27 Par sujet Pat
oi je me suis borné à remplacer dans inc/discuter.php et inc/forum.php : "#formulaire" par "=toto#formulaire" Merci d'avance ! Euh, le pb évoqué ci-dessus n'est pas non plus réglé. SPIP est tellement complexe que c'est pas évident de déboguer un truc qu'on n'a pas du to

Re: [spip-dev] ordre des articles dans une rubrique

2008-05-26 Par sujet Pat
Fil a écrit : cf. http://trac.rezo.net/trac/spip/changeset/11492 pour une astuce (je ne sais pas si elle est déjà dans le couteau-suisse) Pas encore, sauf si cette constante est définitive dans SPIP ;-) Pat

[spip-dev] Forum de messagerie incomplet

2008-05-25 Par sujet Pat
quot; : (ligne 46) function inc_discuter_dist($id, $script, $objet, $statut='prive', $debut=0, $pas=10, $id_parent = 0) là ça marche... mais je connais pas assez bien le code pour proposer un correctif correct dans tous les cas. Pat

[spip-dev] Cannot use a scalar value as an array in public/composer.php on line 711

2008-05-24 Par sujet Pat
); Avez-vous des pistes ? un pb dans la base ? Merci Pat

[spip-dev] [Resolu] SVN - double fonction : chercher_rubrique()

2008-05-09 Par sujet Pat
Pat a écrit : Fatal error: Cannot redeclare chercher_rubrique() (previously declared in /www/ecrire/inc/filtres.php:2482) in /www/dist/prive/editer/article_fonctions.php on line 3 Désolé pour le bruit. Une mise à jour de SPIP par simple écrasement de la dist ne suffit pas. Il faut retirer

[spip-dev] SVN - double fonction : chercher_rubrique()

2008-05-09 Par sujet Pat
Petit souci en SVN de ce soir. A l'appel de l'url ecrire/?exec=articles_edit_article=24, on obtient: Fatal error: Cannot redeclare chercher_rubrique() (previously declared in /www/ecrire/inc/filtres.php:2482) in /www/dist/prive/editer/article_fonctions.php on line 3 Pat

Re: [spip-dev] un petit bug dans la messagerie interne ?

2008-05-07 Par sujet Pat
seul à constater ce pb ? Je confirme. Pat

  1   2   3   4   >