Re: [spip-dev] Ô mega ! c’est SPIP 4.0 alpha

2021-05-04 Par sujet team spipfactoy

merci pour le test

alors sans doute liés a l'hebrgeur qui bloque un truc

je vais creuser 


Le 04/05/2021 à 15:00, jacq...@jack31.org a écrit :

Le 03/05/2021 à 18:58, team spipfactoy a écrit :

j'ai bien mes articles , mais aucune image et rien dans documents

*/ecrire/?exec=documents est vide*


Bonjour,
Pour en avoir le coeur net, en local je viens d'installer un SPIP 4.0 
alpha, avec base sqlite. Je renseigne l'identité du site, paramètre 
GD2 et je créée deux rubriques avec trois articles. J'y insère logos 
et photos.
Je créée un nouveau site SPIP 4.0 Alpha, j'y mets la base sqlite du 
site précédent et dans le dossier IMG je copie mes dossiers jpg et logo.
J'ouvre le nouveau site : il est exactement identique au premier avec 
les photos, les logos...

(php 7.3)

Donc tout va bien,
Jacques


--
spipfactory.fr (Mutualisation sous habillage ESCAL sur la branche stable 4.0.0)
spipfactory.com (#SPIP_VERSION - site de test basé sur la branche de 
développement)

Si tu ne sais pas ce que tu fais. Ne le fait pas. Simplement. ;)
(Marcimat)

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Dépôt identité graphique

2021-05-04 Par sujet team spipfactoy

Excellent, ça evitera les moteurs de recherche sur le terme image spip

merci beaucoup


Le 04/05/2021 à 15:28, tcharlss a écrit :

Hello,

Les éléments relatifs à l'identité graphique de Spip ont été migrés du 
svn vers le git : https://git.spip.net/spip-contrib-graphismes/identite


On y trouve donc les sources du logo, avec les déclinaisons, la 
police, et plus tard tout ce qui aura trait à l'éventuel futur design 
system.


Il y a également un dossier pour les illustrations : je pense qu'on 
pourra y placer celles utilisées dans les annonces de sortie par 
exemple (donc les chouettes logos d'articles faits par erational).
J'y ai aussi ajouté la gravure historique du polatouche utilisée un 
temps sur spip.net. Elle est issue d'une planche libre de droit, mais 
trouver une source de bonne facture non phagocytée par les sites 
marchands ne fut pas simple.


Le dépôt est dans une orga contrib, donc ouvert à tout⋅es. Mais merci 
de ne pas y mettre tout et n'importe quoi : c'est pour le branding 
censé être « officiel ». Enfin officiel n'est peut-être pas le bon 
terme, disons co-opté.


Et pour finir je pense qu'en complément il faudrait une page sur 
spip.net pour que les gens puissent récupérer facilement ces éléments 
: pour faire des plaquettes de formation, pour les hébergeurs qui 
aiment encore SPIP et veulent indiquer qu'il est supporté, etc.


___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


--
spipfactory.fr (Mutualisation sous habillage ESCAL sur la branche stable 4.0.0)
spipfactory.com (#SPIP_VERSION - site de test basé sur la branche de 
développement)

Si tu ne sais pas ce que tu fais. Ne le fait pas. Simplement. ;)
(Marcimat)

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

[spip-dev] spip-loader.php

2021-05-04 Par sujet team spipfactoy

Bonjour,

Je commencerais par Super taf , super outils et merci pour ce que vous 
faites pour SPIP.


je vous remonte un constat et voir si il vous semble utile de la prendre 
en compte



suite a l'annonce de via [Spip-Ann] "Ô mega ! c’est SPIP 4.0 alpha"

Cette version alpha s’adresse à toutes les personnes impatientes qui 
veulent tester les nouveautés avant la sortie officielle.


j'ai voulu faire la mise a jour avec spip_loader (test) et  je constate 
l'info donné  par le menu déroulant est spip 4.0 lors que l'article 
annonce *SPIP 4.0 alpha*.


on pourrais lui reprocher de ne pas avoir prie en compte

*Attention* : C’est une version /alpha/, elle peut encore contenir des 
bugs. De plus certains plugins ne sont plus distribués en standard, 
consultez la section traitant de ce sujet. Ne faites pas de mise à 
jour vers cette version depuis un site en production sans savoir ce 
que vous faites.



mais spip-loader est distribuer par https://www.spip.net/fr_article5705.html


le soucis  rencontrer est que spip-loader affiche spip 4.0, cela prête a 
confusion , il s'attend a voir spip 4.0.Alpha


https://wtf.roflcopter.fr/pics/gallery#1jdR862l/j3sOFnDu.png


surtout que la version précédente on a bien spip-dev. dans le menu 
déroulant



ce n'est qu'un piste amélioration d'un utilisateur lambda de spip, en 
aucun cas une critique vis a vis de ceux celles qui maintienne spip_loader



--

spipfactory.com (#SPIP_VERSION - site de test basé sur la branche de 
développement)

Si tu ne sais pas ce que tu fais. Ne le fait pas. Simplement. ;)
(Marcimat)

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] [Spip-zone-commit] [fullcalendarcompat] Compatible SPIP 4.0 (et nécessaire pour faire (...)

2021-05-03 Par sujet team spipfactoy


Le 03/05/2021 à 22:06, spip.fra...@lien-d-amis.net a écrit :

La compatibilité va de:
-dev



-alpha   la plupart des erreurs signalées sont résolues, mais il peut encore y 
avoir de graves problèmes connus en suspens, y compris des problèmes de 
sécurité. Le projet n'est pas complètement testé, il peut donc y avoir de 
nombreux bugs inconnus.Le public cible est les développeurs qui souhaitent 
participer aux tests, au débogage et au développement du projet.



-beta   toutes les pertes de données critiques et les bogues de sécurité sont 
résolus.Ne convient généralement pas aux sites de production, mais peut être 
utilisé sur certains sites de production si l'administrateur du site connaît 
bien le projet et sait gérer les problèmes restants.



-rc  créée que lorsque tous les problèmes de type de bogue critiques sont 
signalés corrigés dans la file d'attente des problèmes du projet. Cette balise 
ne doit être utilisée que lorsque le développeur estime que le projet est prêt 
à être utilisé sur un site de production. il doit au minimum resté un mois en rc




Sachant qu'il peut y avoir plusieurs versions, par exemple
-alpha1
-alpha2
Etc





*
*

*merci pour l'explication , la numérotation quand a elle applique le  
systéme GoRoCo ?? ou autre chose franck ?*




-Message d'origine-
De : RealET 
Envoyé : lundi 3 mai 2021 21:58
À : spip-dev@rezo.net
Objet : Re: [spip-dev] [Spip-zone-commit] [fullcalendarcompat] Compatible SPIP 
4.0 (et nécessaire pour faire (...)

spip.fra...@lien-d-amis.net a écrit le 03/05/2021 à 21:26 :

Hello 
La bonne écriture pour qu'il ne fonctionne qu'avec spip 4, c'est plutôt:
compatibilite="[4.0.0-alpha;4.0.*]"

L'idée, c'est *justement* que ça fonctionne aussi en 3.3 pour ceux qui l'ont 
déjà pour qu'ils puissent mettre à jour d'abord les plugins, puis SPIP.
Pragmatisme vs idéalisme ;-)

PS : et pour ma part, les écritures avec x.y.z-dev/alpha/rc c'est assez abscons 
pour savoir si dev continuera à fonctionner en alpha par exemple

;-)


--
RealET


___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


--
spipfactory.fr (Mutualisation sous habillage ESCAL sur la branche stable 4.0.0)
spipfactory.com (#SPIP_VERSION - site de test basé sur la branche de 
développement)

Si tu ne sais pas ce que tu fais. Ne le fait pas. Simplement. ;)
(Marcimat)

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Ô mega ! c’est SPIP 4.0 alpha

2021-05-03 Par sujet team spipfactoy

*Super ;) merci pour le taf*

Le 03/05/2021 à 18:12, erational a écrit :

Nous sommes heureux de vous présenter la version alpha de SPIP 4.0.

*Attention : **
**C’est une version alpha, elle peut encore contenir des bugs, **
**ne l’utilisez pas sur un site en production sans savoir ce que vous 
faites. *



Juste pour info ...

soit un site en *SPIP 4.0.0-alpha GIT [master: 3ae75b65 
]* 
+ écran de sécurité 1.4.1  en sqlite


*j'exporte le fichier /base/sqlite    et le repertoire /IMG*

dans un site *SPIP 4.0.0-alpha GIT [master: 3ae75b65 
]* 
+ écran de sécurité 1.4., fraichement installé



j'ai bien mes articles , mais aucune image et rien dans documents

*/ecrire/?exec=documents est vide *



___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] GIS

2021-05-03 Par sujet team spipfactoy


Le 03/05/2021 à 10:36, Bruno Bergot a écrit :


Si tu nous avait donnée l'erreur sql générée, j'aurais pu te répondre 
en 2 minutes que c'est le symptôme classique d'un site qui a installé 
gis geometries et qui l'a désactivé, comme indiqué dans la doc (à la 
fin) : https://contrib.spip.net/GIS-Geometries


++
b_b 



je n'avais aucune erreur sql a l'ecran seul une image echec avec croix 
rouge lors de la création d'un point geolocalisé


et pas d'enregistrement


ou aurais je pu avoir une information suplémentaire que j'aurais pu 
transmettre



Merci


*Remarques*

Si vous désactivez GIS Geometries les lignes et les polygones de vos 
cartes seront affichés sous forme de points correspondants au centre 
de la forme géométrique.


Malgré cela, *il est recommandé de désinstaller le plugin si vous n’en 
avez plus besoin*, afin d’être certain d’effacer le champ |geo| (de 
type GEOMETRY) de la table |gis|, sans quoi vous rencontrerez une 
erreur SQL lors de la création d’un nouveau point avec GIS.


Si votre carte affiche des lignes ou des polygones, *l’activation du 
clustering fonctionnera uniquement sur les points* (cf paramètre 
|cluster|  du modèle de GIS), 
et les autres formes ne seront pas affichées.




--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] alpha 4.0.0 => rétropédalage

2021-05-03 Par sujet team spipfactoy


Le 03/05/2021 à 10:01, Matthieu Marcillaud a écrit :

Le 03/05/2021 à 09:48, team spipfactoy a écrit :

Bonjour, pour info

week-end studieux mais inefficace pour moi


L'expérience  spip 4.0.0  Alpha est OFF


Si tu ne sais pas ce que tu fais. Ne le fait pas. Simplement.


Je suis d'accord, mais si jammais on est presuadé d'avoir suivie les 
procédures et doc


est ce quil n'est pas légitime de poser la question


et je veux bien me prendre un RTFM , mais avec le lien



Et attends une version finale. Et pas un truc encore en dev.
On n'a même pas encore publié l'annonce de la sortie de l'alpha !



j'ai bien compris ça , et ne vous inquiéter pas des que la stable sortira.

je passerais en stable et je ne vous remonte plus des constats d'un 
utilisateur lambda





Zut. Tu envoies plein de mails indéchiffrables sur la liste spip-dev 
alors que c'est du ressort de spip-user (que tu pourrais envoyer en 
format texte par ailleurs plutôt que html ! ça serait bien plus lisible).


si j'ai bien compris les mails que j'envoie doivent être adressé a spip-user

concernant spip 4.0.0 alpha et les plugins

je penser l'inverse, j'en suis dsl  , je vais rectifié




Depuis le temps, tu pourrais comprendre que : oui, les plugins ne sont 
*pas* encore déclarés compatible SPIP 4.0.0-alpha (c'est en cours, 
çava se faire tranquillement). C'est ce qui tue ta mutu.


j'ai du encore une fois mal m'exprimer

c'est la page admin des plugins qui en mutu spip 4.0.0 ne delivre plus 
les infos des plugins , même avec un changement de borne




Donc merci de ne pas plomber l'ambiance.
Nous, on a la hype :)


je ne souhaiter pas plomber l'ambiance, je signaler

comme j'ai pu signaler des truc de casser ou des liens obsoletes

je vais éviter les signalements et vous laisse travailler



MM.


et je reitére bravo pour tous ce que vous faites

@micalement



___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

[spip-dev] alpha 4.0.0 => rétropédalage

2021-05-03 Par sujet team spipfactoy

Bonjour, pour info

week-end studieux mais inefficace pour moi


L'expérience  spip 4.0.0  Alpha est OFF , je temporise un peu ... (comme 
dit par jack31 sur IRC, revert si tu peu)


j'ai été dans l'incapacité de passer une mutualisation spip de 42 sites de

*SPIP 3.3.0-dev GIT [master: 33a30511 
] 
.. *a *...SPIP 4.0.0-alpha GIT [master: 
2618378c 
]*



il y a je ne sais quoi de différent puisque la mutu fonctionne 
parfaitement en SPIP 3.3.0-dev GIT [master: 33a30511 
]



en SPIP 4.0.0-alpha GIT [master: 2618378c 
]


ma page est vide de plugins


ecrire/?exec=admin_plugin


donc impossible de voir les plugins installer, donc de les gérer


alors que les pages

/ecrire/?exec=admin_plugin=actif

/ecrire/?exec=admin_plugin=inactif


affiche bien les plugins,  mais si on souhaite installé un plugin




l'install d'un plugin en mutualisation

*Actions demandées :* • Désactiver le plugin « Adminer » (version : 
4.8.0.0)

• Activer le plugin « Adminer » (version : 4.8.0.0)




  Actions réalisées

  * La désactivation du plugin « Adminer » (version : 4.8.0.0) ne
s’est pas correctement déroulée
  * L’activation du plugin « Adminer » (version : 4.8.0.0) s’est
correctement déroulée



bien sur comme dit par rastapopoulos et jean marie sur la liste :  le 
define été en place, et les bornes plugins changé. (j'avais omis 
l'information)



ce que je n'avais pas précisé dans le message d'origine

version PHP 7.4 -


@micalement et merci les gurus SPIP

--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] alpha 4.0.0

2021-05-02 Par sujet team spipfactoy

merci pour l'info

mais ça ne change rien a mon affichage des plugins.


Comme conseiller j'ai revert a J-3 jours sur *SPIP 3.3.0-dev GIT 
[master: 62ef8d55 
]* 



qui fonctionné sans probléme en mutualisation


Merci a tous

ps/ je vais attendre que ça se stabilise un peu


Le 02/05/2021 à 19:09, YannX SPIP(hot) a écrit :

Le 02/05/2021 à 18:56, a...@rezo.net a écrit :
pas de souci. Il faut aller dans l’espace de gestion de son site pour 
«régler les limites de PHP», et «allow_url_fopen». Par défaut c’est 
bloqué, et donc ça bloque spip_loader et les mises à jour de plugins. 


Merci pour l'information !

Copiée et enregistrée.

Cdlt


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] alpha 4.0.0

2021-05-02 Par sujet team spipfactoy

Merci a tous pour les pistes je suis de retour

et je plante donc de nouveau le décor


Une mutualisation spip chez l'hébergeur infomaniak en php 7.4


*SPIP 4.0.0-alpha GIT [master: 2618378c 
]* 
est un logiciel libre distribué sous licence GPL 
.

+ écran de sécurité 1.4.1


Modifié  les bornees plugins temporairement en

compatibilite="[;["


dans le fichiers mes_options.php

define('_DEV_VERSION_SPIP_COMPAT',"3.2.99");




l'install d'un plugin en mutualisation

*Actions demandées :* • Désactiver le plugin « Adminer » (version : 
4.8.0.0)

• Activer le plugin « Adminer » (version : 4.8.0.0)




  Actions réalisées

  * La désactivation du plugin « Adminer » (version : 4.8.0.0) ne
s’est pas correctement déroulée
  * L’activation du plugin « Adminer » (version : 4.8.0.0) s’est
correctement déroulée




le hic c'est que ma page est vide de plugins sauf ceux qui sont dans 
le site maitre



ecrire/?exec=admin_plugin






Une idée, une piste, un tuto



sachant qu'en


3.3.0-dev GIT [master: 62ef8d55]


je n'avais pas ce probléme


je peu faire un revert a J-2



a vous lire merci pour l'aide


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

[spip-dev] alpha 4.0.0

2021-05-02 Par sujet team spipfactoy

hello

*SPIP 4.0.0-alpha GIT [master: 2618378c 
]* 
est un logiciel libre distribué sous licence GPL 
.

+ écran de sécurité 1.4.1


l'install d'un plugin en mutualisation

*Actions demandées :* • Désactiver le plugin « Adminer » (version : 
4.8.0.0)

• Activer le plugin « Adminer » (version : 4.8.0.0)




  Actions réalisées

  * La désactivation du plugin « Adminer » (version : 4.8.0.0) ne
s’est pas correctement déroulée
  * L’activation du plugin « Adminer » (version : 4.8.0.0) s’est
correctement déroulée




le hic c'est que ma pageest vide de plugins


ecrire/?exec=admin_plugin



Une idée, une piste, un tuto


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] GIS

2021-05-02 Par sujet team spipfactoy

bon bon

si ça peu servir j'ai reussie a remettre en route si ça peu servir


GIS a evolué et lors du passage a GIS

Version :
   4.50.5 GIT [master: 2c5d041c]


je ne pouvais plus enregistré de point, j'ai constaté que la structure 
de la base n'est pas identique donc petit bouleau sur le fichier sql 
pour le mettre en forme


Voici les actions faites pour récupérer mes données!

1. Dans Adminer exporter la table spip-gis (a priori il n'y a rien dans
   la table spip_gis_liens, en tout cas dans mon site)
   Modifier le fichier sql pour qu'il soit compatible avec la nouvelle
   table spip_gis (voir ci-dessous)

2. Désinstaller GIS dans l'onglet Actifs de la gestion des plugins

3. Activer GIS dans l'onglet Inactifs de la gestion des plugins

4. Importer la table sql modifiée, tous les points devraient être
   récupérés!


Table ancienne version:

CREATE TABLE `spip_gis` (
  `id_gis` bigint(21) NOT NULL AUTO_INCREMENT,
  `titre` text NOT NULL,
  `descriptif` text NOT NULL,
  `lat` double DEFAULT NULL,
  `lon` double DEFAULT NULL,
*`geo` geometry NOT NULL,*
  `zoom` tinyint(4) DEFAULT NULL,
*`type` varchar(25) NOT NULL DEFAULT '',*
  `adresse` text NOT NULL,
  `pays` text NOT NULL,
  `code_pays` varchar(255) NOT NULL DEFAULT '',
  `region` text NOT NULL,
  `departement` text NOT NULL,
  `ville` text NOT NULL,
  `code_postal` varchar(255) NOT NULL DEFAULT '',
  `color` varchar(25) NOT NULL DEFAULT '',
  `weight` varchar(4) NOT NULL DEFAULT '',
  `opacity` varchar(4) NOT NULL DEFAULT '',
  `fillcolor` varchar(25) NOT NULL DEFAULT '',
  `fillopacity` varchar(4) NOT NULL DEFAULT '',
*`pseudo_hasard` float NOT NULL DEFAULT '0',*


Table nouvelle version :

REATE TABLE `spip_gis` (
  `id_gis` bigint(21) NOT NULL AUTO_INCREMENT,
  `titre` text NOT NULL,
  `descriptif` text NOT NULL,
  `lat` double DEFAULT NULL,
  `lon` double DEFAULT NULL,
  `zoom` tinyint(4) DEFAULT NULL,
  `adresse` text NOT NULL,
  `pays` text NOT NULL,
  `code_pays` varchar(255) NOT NULL DEFAULT '',
  `region` text NOT NULL,
  `departement` text NOT NULL,
  `ville` text NOT NULL,
  `code_postal` varchar(255) NOT NULL DEFAULT '',
  `color` varchar(25) NOT NULL DEFAULT '',
  `weight` varchar(4) NOT NULL DEFAULT '',
  `opacity` varchar(4) NOT NULL DEFAULT '',
  `fillcolor` varchar(25) NOT NULL DEFAULT '',
  `fillopacity` varchar(4) NOT NULL DEFAULT '',

Les champs geo, type et fillopacity ont disparus, donc il faut les 
retirer du fichier sql pour les importer dans la nouvelle version;


voila,


Le 30/04/2021 à 19:19, team spipfactoy a écrit :


Bonjour,

qu'est ce qui pourrais m'empecher d'enregistrer un point GIS dans un 
article sur une mutualisation chez l'hebergeur infomaniak


SPIP strictement identique sur le même serveur


Un site hors mutu n'ayant pas de soucis

**SPIP 3.3.0-dev GIT [master: 3d4c2ecb 
<https://git.spip.net/spip/spip/commit/3d4c2ecbdb34283026b08287ad1bb3a9cefc1af0>]* 
+ GIS *Version :4.50.5 GIT [master: 2c5d041c]


*Plugins actifs :* agenda   calendrier_mini filtres_images  
jquery_ui  organiseur safehtml statistiques   
tri_par_rubrique
aide    compagnon    forum   mediabox petitions    
saisies  svp urls_etendues
archiviste  compresseur  fullcalendarcompat  medias plan 
sites    svp_stats  verifier
bigup   dump ieconfig    mots porte_plume  
spip_proprietaire    tarteaucitron  vertebres
breves  escal    ieconfigplus    nospam revisions    
squelettes_par_rubrique  textwheel  yaml



les sites en mutu qui on le probléme

**SPIP 3.3.0-dev GIT [master: 3d4c2ecb 
<https://git.spip.net/spip/spip/commit/3d4c2ecbdb34283026b08287ad1bb3a9cefc1af0>]*  
+GIS***Version :4.50.5 GIT [master: 2c5d041c]


*Plugins actifs : a*genda  calendrier_mini filtres_images  
jquery_ui  organiseur safehtml statistiques   
tri_par_rubrique
aide    compagnon    forum   mediabox petitions    
saisies  svp urls_etendues
archiviste  compresseur  fullcalendarcompat  medias plan 
sites    svp_stats  verifier
bigup   dump ieconfig    mots porte_plume  
spip_proprietaire    tarteaucitron  vertebres
breves  escal    ieconfigplus    nospam revisions    
squelettes_par_rubrique  textwheel  yaml*

*

*
*

Une idée, une piste, un tuto

merci*
*

*
*

*
*

*
*

--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

[spip-dev] GIS

2021-04-30 Par sujet team spipfactoy

Bonjour,

qu'est ce qui pourrais m'empecher d'enregistrer un point GIS dans un 
article sur une mutualisation chez l'hebergeur infomaniak


SPIP strictement identique sur le même serveur


Un site hors mutu n'ayant pas de soucis

**SPIP 3.3.0-dev GIT [master: 3d4c2ecb 
]* 
+ GIS ***Version :4.50.5 GIT [master: 2c5d041c]


*Plugins actifs :* agenda   calendrier_mini filtres_images  
jquery_ui  organiseur safehtml statistiques   
tri_par_rubrique
aide    compagnon    forum   mediabox petitions    
saisies  svp    urls_etendues
archiviste  compresseur  fullcalendarcompat  medias plan 
sites    svp_stats  verifier
bigup   dump ieconfig    mots porte_plume  
spip_proprietaire    tarteaucitron  vertebres
breves  escal    ieconfigplus    nospam revisions    
squelettes_par_rubrique  textwheel  yaml



les sites en mutu qui on le probléme

**SPIP 3.3.0-dev GIT [master: 3d4c2ecb 
]* 
+GIS***Version :4.50.5 GIT [master: 2c5d041c]


*Plugins actifs : a*genda  calendrier_mini filtres_images  
jquery_ui  organiseur safehtml statistiques   
tri_par_rubrique
aide    compagnon    forum   mediabox petitions    
saisies  svp    urls_etendues
archiviste  compresseur  fullcalendarcompat  medias plan 
sites    svp_stats  verifier
bigup   dump ieconfig    mots porte_plume  
spip_proprietaire    tarteaucitron  vertebres
breves  escal    ieconfigplus    nospam revisions    
squelettes_par_rubrique  textwheel  yaml*

*

*
*

Une idée, une piste, un tuto

merci*
*

*
*

*
*

*
*

--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] SPIP 4 — proposition d'enlever quelques plugins-dist par défaut

2021-04-30 Par sujet team spipfactoy

*Bonjour,*

Mes deux sous d'un simple rapporteur d'utilisateur.


Lorsque j'install spip + les 26 plugins du core (je cite la doc) pour un 
nouveau


A mon humble avis, il doit embarquer seulement ce qui est nécessaire à 
son fonctionnement minimum (cela permettra au dev , une maintenance plus 
aisé, ils on déjà assez de boulot comme ça).


Aux webmestre de rajouter ce dont il a besoin comme pour les plugins  
des contributeurs


et donc un repertoire plugin-dist , mais que dit la doc ?

Le répertoire |plugins-dist| permet de définir les plugins installés, 
actifs et non désactivables, dès l’installation de SPIP. Il suffit de 
placer les plugins souhaités dans ce répertoire.


Dans la distribution de SPIP, des plugins sont présents par défaut.


et ç'est complété par


  * « Compresseur », pour compresser les Javascript, CSS et HTML,
  * « Filtres images et couleurs », donnant accès aux traitements
graphiques et typographiques,
  * « Porte Plume », fournissant une barre d’outils d’édition des
raccourcis SPIP,
  * « SafeHTML », pour nettoyer les forums et les flux de syndication
d’éléments indésirables.


puis

Il y en a d’autres. On en trouvera la liste complète et à jour sur 
l’autodoc du source 
.


Donc moins il y a de plugins embarqué plus la maintenance est facile 
(m'enfin je l'espére)


*par contre pour l'aide je verrais bien deux boutons dans la barre de 
menu simplement qui redirige vers la futur aide tourné rédacteur et 
l'autre sur les raccourcis *


d’ailleurs il existe  un truc 
(https://contrib.spip.net/Manuel-de-redaction-du-site)



on aurais une entré sur l'aide via la boussole egalement un peu comme

 *


   SPIP.net 

   La documentation officielle et téléchargement de SPIP

   En savoir plus 
 *


   Programmer SPIP-La documentation pour développer avec (...)
   Programmer SPIP 

   La documentation pour développer avec SPIP

   En savoir plus 
 *


   SPIP Code-La documentation du code de SPIP SPIP Code
   

   La documentation du code de SPIP


*donc go go go pour alléger au maximum.*


Après il y avais un truc par ici ou ça discuter deja

https://contrib.spip.net/plugins-dist-indispensables-ou-non



--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Refonte du jeu d'icônes : retours et commentaires

2021-04-29 Par sujet team spipfactoy


Le 29/04/2021 à 14:56, erational a écrit :


Coucou,

SPIP 3.3 dispose d'un backoffice refondu avec un CSS chouette et un 
support du SVG.


Suite aux discussions, j'ai repris tout le jeu d'icônes au format PNG 
en SVG.


Voici la ligne de conduite pour cette refonte
https://contrib.spip.net/Quelques-notes-pour-les-icones-SVG-de-SPIP 



Ce ticket est pour enregistrer les retours, les oublis, les bugs de ce 
nouveau jeu.

Merci d'être constructif et précis (évitons les "j'aime" / "j'aime pas").

https://core.spip.net/issues/4751



Cool

juste une question pour ma gouverne

c'est voulu le petit trait a coté du deroulant rubrique

https://wtf.roflcopter.fr/pics/gallery#3QSNLGTC/W7XCHAck.png


on deroule au survol , mais on enroule pas survol

bon hesiter pas a quemender je suis jammais clair dans mes explications



--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

[spip-dev] Fwd: il est frais mon spip loader ?, mais il fonctionne pas

2021-04-16 Par sujet team spipfactoy


merci pour l'info ...

ce qui m'inquiéte le plus est la date de article 2013


Le 16/04/2021 à 21:28, Bruno Bergot a écrit :
Avec cette info cruciale on peut enfin faire une recherche à ta place 
sur le web : "spip_loader infomaniak" => premier résultat :


https://www.erational.org/Spip_loader-et-hebergement-Infomaniak.html 
(qui est pété, alerte errational !)


donc 
https://web.archive.org/web/20160430051218/http://www.erational.org/Spip_loader-et-hebergement-Infomaniak.html 



Bref, spip_loader ne fonctionne pas chez infomaniak, c'est connu 
depuis longue date, et on n'y peut rien, désolé.


++
b_b 



ne serais t'il pas pertinent d'avoir ces infos sur

https://www.spip.net/fr_article5705.html


lien de documentation donner par la page https://www.spip.net/fr_download


merci

--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] il est frais mon spip loader ?, mais il fonctionne pas

2021-04-16 Par sujet team spipfactoy

Bonsoir je tiens a remercier tous les dev de spip

tant sur irc et la liste de m'avoir toujours aider.


le spip_loader a été installé chez l'hebergeur infomaniak pour info




Le 16/04/2021 à 09:25, team spipfactoy a écrit :


Bonjour,


sur un spip_loader.php, telecharger ce jour sur via le lien donné par 
le site spip.net


https://www.spip.net/spip-dev/INSTALL/spip_loader.php


lorsque je le lance , j'ai le droit a :

*Fatal error*: Uncaught Exception: Impossible de récupérer le fichier 
https://www.spip.net/spip-dev/INSTALL/spip_loader_list.json in 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php:276Stack 
trace: #0 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php(243): 
SL_lister_versions_spip() #1 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php(118): 
SL_lister_branches_proposees('3.2') #2 {main} thrown in 
*/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php* 
on line *276*


*
*

*que puis je faire ?*

*
*

a vous lire pour faire des test avant de passé par une install de spip 
par FTP



--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] il est frais mon spip loader ?, mais il fonctionne pas

2021-04-16 Par sujet team spipfactoy


Le 16/04/2021 à 19:50, jacq...@jack31.org a écrit :

Le 16/04/2021 à 19:46, team spipfactoy a écrit :


donc on peu considerer que spip_loader ne  fonctionne plus et quil ne 
faut plus le distribuer.


Tu peux arrêter de dire n'importe quoi ? Je me suis servi plusieurs 
fois de spip_loader.php sans aucun problème aujourd'hui.



bon arreter de me faire passer pour imbecile en sortant les phrases du 
contexte, j'essaye comme je peu d'aider la communauté


j'ai telecharger spip loader et ça ne fonctionné pas



je remonter simplement un probléme depuis chez moi le probléme est 
résolu



Tu n'as plus de problème d'install alors ? Ce serait mieux de le dire.


j'ai pas dis que je n'avais plus le probléme avec spiploader, j'ai dis 
j'ai resolu le probléme d'installation de spip


en passant par spip cli ou par ftp

d’ailleurs j'ai vu passer des messages


je peu eventuellement refaire un test d'install avec si spip_loader 
est encore d'actu



Inutile ça fonctionne !
Jacques


et bien super si spip_loader fonctionne et que moi je suis un imbecile 
qui n'exprime que des conneries histoire d'emmerder la communauté en 
signalant une coquille vu au niveau d'un néophytes qui n'a pas 
l'expertise des gurus spip



bise



--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] il est frais mon spip loader ?, mais il fonctionne pas

2021-04-16 Par sujet team spipfactoy

merci pour l'info

donc on peu considerer que spip_loader ne  fonctionne plus et quil ne 
faut plus le distribuer.


je remonter simplement un probléme depuis chez moi le probléme est résolu

je peu eventuellement refaire un test d'install avec si spip_loader est 
encore d'actu



merci d'avoir répondu

Le 16/04/2021 à 19:44, BoOz a écrit :

Il est temps de passer à spip-cli alors !

https://contrib.spip.net/SPIP-Cli <https://contrib.spip.net/SPIP-Cli>

Après tu fais juste : spip dl

BoOz



Le ven. 16 avr. 2021 à 09:29, team spipfactoy 
mailto:teamspipfact...@gmail.com>> a écrit :


pour completer


            throw new \Exception("Impossible de récupérer le
fichier " . _URL_SPIP_LOADER_LIST);

a priori il trouve pas la liste des spip a telecharger



Le 16/04/2021 à 09:25, team spipfactoy a écrit :


Bonjour,


sur un spip_loader.php, telecharger ce jour sur via le lien donné
par le site spip.net <http://spip.net>

https://www.spip.net/spip-dev/INSTALL/spip_loader.php
<https://www.spip.net/spip-dev/INSTALL/spip_loader.php>


lorsque je le lance , j'ai le droit a :


*Fatal error*: Uncaught Exception: Impossible de récupérer le
fichier
https://www.spip.net/spip-dev/INSTALL/spip_loader_list.json
<https://www.spip.net/spip-dev/INSTALL/spip_loader_list.json> in

/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php:276Stack
<http://spipfactory.com/spip_loader.php:276Stack> trace: #0

/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php(243)
<http://spipfactory.com/spip_loader.php(243)>:
SL_lister_versions_spip() #1

/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php(118)
<http://spipfactory.com/spip_loader.php(118)>:
SL_lister_branches_proposees('3.2') #2 {main} thrown in

*/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php
<http://spipfactory.com/spip_loader.php>* on line *276*


*
*

*que puis je faire ?*

*
*

a vous lire pour faire des test avant de passé par une install de
spip par FTP


-- 
spipfactory.fr  <http://spipfactory.fr>


En répondant a ce courriel vous acceptez implicitement la diffusion, 
l’échange de la conversation, sauf avis contraire clairement exprimé.


-- 
spipfactory.fr  <http://spipfactory.fr>


En répondant a ce courriel vous acceptez implicitement la diffusion, 
l’échange de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
<https://listes.rezo.net/mailman/listinfo/spip-dev>
doc: https://www.spip.net/ <https://www.spip.net/>
dev: https://core.spip.net/ <https://core.spip.net/>
irc://irc.freenode.net/spip <http://irc.freenode.net/spip>


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] il est frais mon spip loader ?, mais il fonctionne pas

2021-04-16 Par sujet team spipfactoy

pour completer

            throw new \Exception("Impossible de récupérer le fichier " 
. _URL_SPIP_LOADER_LIST);

a priori il trouve pas la liste des spip a telecharger



Le 16/04/2021 à 09:25, team spipfactoy a écrit :


Bonjour,


sur un spip_loader.php, telecharger ce jour sur via le lien donné par 
le site spip.net


https://www.spip.net/spip-dev/INSTALL/spip_loader.php


lorsque je le lance , j'ai le droit a :

*Fatal error*: Uncaught Exception: Impossible de récupérer le fichier 
https://www.spip.net/spip-dev/INSTALL/spip_loader_list.json in 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php:276Stack 
trace: #0 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php(243): 
SL_lister_versions_spip() #1 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php(118): 
SL_lister_branches_proposees('3.2') #2 {main} thrown in 
*/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php* 
on line *276*


*
*

*que puis je faire ?*

*
*

a vous lire pour faire des test avant de passé par une install de spip 
par FTP



--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

[spip-dev] il est frais mon spip loader ?, mais il fonctionne pas

2021-04-16 Par sujet team spipfactoy

Bonjour,


sur un spip_loader.php, telecharger ce jour sur via le lien donné par le 
site spip.net


https://www.spip.net/spip-dev/INSTALL/spip_loader.php


lorsque je le lance , j'ai le droit a :

*Fatal error*: Uncaught Exception: Impossible de récupérer le fichier 
https://www.spip.net/spip-dev/INSTALL/spip_loader_list.json in 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php:276Stack 
trace: #0 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php(243): 
SL_lister_versions_spip() #1 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php(118): 
SL_lister_branches_proposees('3.2') #2 {main} thrown in 
*/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/sites/spipfactory.com/spip_loader.php* 
on line *276*


*
*

*que puis je faire ?*

*
*

a vous lire pour faire des test avant de passé par une install de spip 
par FTP



**

--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Une 4.0 plutôt qu'une 3.3

2021-04-15 Par sujet team spipfactoy

Hello si je peu 

mais cela n'est que mon avis.


Spip a toujours travaillé sur la durée, avec du tout en allant en 
fonction des disponibilitées de chacun,


alors en tant qu'utilisateur de spip je sais que la version qui sort et 
ceux quelque soit la version


est déjà dépassé, car les dev sont déjà sur l'amélioration de la version 
suivante.



Alors le parfait n'existe pas,et si la version que j'utilise ne me 
convient pas, je dis rien car je sais que derrière il y aura encore un 
truc mieux mais pas forcement aussi aboutie que le souhait des devs



de toute manière l'urgent est fait, /l'impossible/ est en cours, pour le 
reste, /prévoir un délai/.


ça fais trop longtemps qu'on entend parler de la 3.3, je l'attendais le 
1 Avril, j'ose espérer  le 1° Mai ,  le jour de la fête du travail des 
devs de spip








--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] erreurs spip

2021-03-23 Par sujet team spipfactoy

Pour info

la mise a jour des plugins en tache cron a fait planté la mutualisation, 
je suis obligé de revenir en arriere




*aurais tu une piste de travail car ça fait deux fois que le problème 
arrive, ayant été absent le plugin saisies ou statistique a subi des 
modifs ?*



par
Matthieu Marcillaud
, RastaPopoulos
, Joseph
, Les Développements Durables
, Maïeul

Version :
3.50.2 GIT [master: 5c88d700]
État
stable
Préfixe
saisies
Répertoire :
plugins-dist/pluginSF/saisies/



Le 23/03/2021 à 18:53, Aide SpipFactory a écrit :


Erreur dans les plugins : 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/mutusf/plugins-dist/pluginSF/saisies/saisies_options.php, 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/mutusf/plugins-dist/pluginSF/saisies/saisies_fonctions.php, 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/mutusf/plugins-dist/pluginSF/saisies/saisies_pipelines.php, 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/mutusf/plugins-dist/statistiques/stats_autoriser.php, 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/mutusf/plugins-dist/statistiques/base/stats.php, 
/home/clients/b313813ae3dfa81e21eb5a95d7ad323f/mutusf/plugins-dist/statistiques/stats_pipelines.php





la tache cron


Mise à jour de saisies :
From https://git.spip.net/spip-contrib-extensions/saisies
   5c88d70..d695a26  master -> origin/master
 + 52e1dd6...15a0162 reecriture_heritage -> 
origin/reecriture_heritage  (forced update)

Updating 5c88d70..d695a26
Fast-forward
 saisies.css.html   | 5 +
 saisies/input.html | 2 +-
 saisies/radio.html | 2 +-
 3 files changed, 7 insertions(+), 2 deletions(-)


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Demande d'inscription

2021-03-09 Par sujet team spipfactoy

+1

Le 09/03/2021 à 17:03, RastaPopoulos a écrit :

  Illes veulent juste ajouter un ticket et suivre leur demande.

-- RastaPopoulos


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet team spipfactoy

moi d emon coté j'ai

ecrire/?exec=configurer_svp


Autoriser l’activation des paquets obsolètes ?
Les paquets obsolètes sont des paquets locaux présents qui sont plus 
anciens que d’autres paquets locaux. L’obsolescence est établie sur la 
base de l’état (stable, test, dev) du paquet ainsi que sur la base de 
sa version. Activez cette option si vous souhaitez malgré tout pouvoir 
activer ces plugins obsolètes.

Oui


et du coup

*Compatibilité forcée*
Les plugins compatibles avec SPIP |3.2.99| peuvent être activés.


et donc sur

*SPIP 3.3.0-dev GIT [master: 6aa33239 
]* 




Le 17/02/2021 à 15:12, CSI a écrit :

Bonjour,

Le 17/02/2021 à 14:51, Bruno Bergot a écrit :

Des choses que de webmestres/intégrateurices peuvent faire pour aider ?



Oui, tester la version 3.3 intensivement :)
Une question à 1€ à ce sujet. Hier on a envisagé de passer un site en 
3.3 pour tester justement, mais c'est un site live. J'ai vu que pas 
mal de gens essayaient déjà, je me suis dit pourquoi pas ... mais la 
question c'est plutôt les plugins, j'en ai à peu près 70% marquée 
comme non compatibles. Que conseillez vous ? je change à la mano les 
bornes de tous ces plugins et on voit ? j'imagine que faire ça va 
casser les mises à jours desdits plugins ? une autre méthode ?


++
b_b

--
Pierre
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet team spipfactoy


Le 17/02/2021 à 14:51, Bruno Bergot a écrit :

Oui, tester la version 3.3 intensivement :)

++
b_b



en mutu actuellement 42 sites


on ma remonté mais c'est pas lié a spip 3.3, mais plus au plugins


 Une "feature" dans SPIP
 


 Pb pour Migrer un site SPIP en HTML5
 


 Plugin "CISF" & "minibando" Incompatible
 


 Plugin "METADONNÉES PHOTO" & "GALLERIA" Incompatible
 


 Plugins VIDÉOS & création d’articles
 


 Plugins CIWIDGET & création d’articles
 


 Plugins image_responsive & medias_responsive_mod + newsletters
 


 Plugins Adaptative Image + Escal
 


 Plugins Spam referer
 


_


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet team spipfactoy


Le 17/02/2021 à 10:37, Matthieu Marcillaud a écrit :


À part sortir une 3.3, je ne vois pas de solution. 


la gazette nous le dit



  côté core

*SPIP 3.3 : en route pour la beta!*

La version de dev SPIP3.3 passe bientôt en beta! Vous allez pouvoir la 
tester et signaler tout éventuel dysfonctionnement rencontré (annonce 
à venir 


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] erreur sql 1064 spip 3.3.0 dev

2021-02-12 Par sujet team spipfactoy
meri j'ai donc realisé la mise a jour sur *SPIP 3.3.0-dev GIT [master: 
be3b4611 
<https://git.spip.net/spip/spip/commit/be3b4611c254c615646990c15151b6765fe1d497>]* 



effectivement ça fonctionne

merci pour la piste


Le 12/02/2021 à 12:55, Bruno Bergot a écrit :

Re,

Le 12/02/2021 à 11:32, team spipfactoy a écrit :

hello dans le fil

mais toujours HS


Le 12/02/2021 à 09:08, Bruno Bergot a écrit :

Salut,

Ça provient certainement de 
https://git.spip.net/spip/statistiques/commit/b0fdcb00dd1ac061bed6dbc320829f7d15cbede8 
& 
https://git.spip.net/spip/spip/commit/1b6c32826813ac67144a96bb94b95ce5e834a290 



Tu as bien ces deux commits chez toi ?




Tu ne réponds pas à ma question ci-dessus :)

PS : je ne reproduis pas sur spip.net qui est en SPIP 3.3.0-dev GIT 
[master: d83e9c5b].


++
b_b


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] erreur sql 1064 spip 3.3.0 dev

2021-02-12 Par sujet team spipfactoy


Le 12/02/2021 à 12:55, Bruno Bergot a écrit :

Re,

Le 12/02/2021 à 11:32, team spipfactoy a écrit :

hello dans le fil

mais toujours HS


Le 12/02/2021 à 09:08, Bruno Bergot a écrit :

Salut,

Ça provient certainement de 
https://git.spip.net/spip/statistiques/commit/b0fdcb00dd1ac061bed6dbc320829f7d15cbede8 
& 
https://git.spip.net/spip/spip/commit/1b6c32826813ac67144a96bb94b95ce5e834a290 



Tu as bien ces deux commits chez toi ?




Tu ne réponds pas à ma question ci-dessus :)

PS : je ne reproduis pas sur spip.net qui est en SPIP 3.3.0-dev GIT 
[master: d83e9c5b].


*
*

*alors je suis en SPIP 3.3.0-dev GIT [master: be3b4611 
<https://git.spip.net/spip/spip/commit/be3b4611c254c615646990c15151b6765fe1d497>]* 



alors si je met a jour via https://git.spip.net/spip/statistiques.git

je supose que statistique est a jour




++
b_b


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] erreur sql 1064 spip 3.3.0 dev

2021-02-12 Par sujet team spipfactoy

hello dans le fil

mais toujours HS


Le 12/02/2021 à 09:08, Bruno Bergot a écrit :

Salut,

Ça provient certainement de 
https://git.spip.net/spip/statistiques/commit/b0fdcb00dd1ac061bed6dbc320829f7d15cbede8 
& 
https://git.spip.net/spip/spip/commit/1b6c32826813ac67144a96bb94b95ce5e834a290


Tu as bien ces deux commits chez toi ?


alors je vais regardé mais SPIP est mis a jour toute les nuits via


cd ~/mutusf
    dossier=($(ls -d *))
    for i in "${dossier[@]}"
    do
#    if [ -d "$i/.svn" ];then svn up ./$i ;fi
    if [ -d "$i/.git" ];then echo "Mise à jour de $i :"; cd 
$i; git pull; cd .. ; fi

    done


j'ai relancé et j'ai


Already up-to-date.
Mise à jour de medias :
Updating aa863d4..6f6a70f
error: Your local changes to the following files would be overwritten 
by merge:

    action/ajouter_documents.php
Please, commit your changes or stash them before you can merge.
Aborting


et


Mise à jour de sites :
Updating 11f6e42..9e0d5bd
error: Your local changes to the following files would be overwritten 
by merge:

    genie/syndic.php
Please, commit your changes or stash them before you can merge.
Aborting



j'ai donc effacer et reinstaller

uid100178@h2web120:~/mutusf/plugins-dist$ git clone 
https://git.spip.net/spip/medias.git


uid100178@h2web120:~/mutusf/plugins-dist$ git clone 
https://git.spip.net/spip/sites.git


uid100178@h2web120:~/mutusf/plugins-dist$ git clone 
https://git.spip.net/spip/statistiques.git





Tu as bien vidé ton cache ?


tout a fait




++
b_b





Le 10/02/2021 à 20:21, team spipfactoy a écrit :



j'ai l'erreur suivante  lorsque je consulte les stats
/ecrire/?exec=stats_visites




squelette boucle Ligne
1 *Erreur SQL 1064*
You have an error in your SQL syntax; check the manual that 
corresponds to your MySQL server version for the right syntax to use 
near 'par_ordre_liste 
'176','67','279','58','597','3832','3604','333','3835','3843','3' at 
line 5


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] [Spip-zone-commit] Accès git

2021-01-18 Par sujet team spipfactoy

Magnifique TONTON et en plus avec humour

Edgard aurais dit (humour de beauf) d'ailleurs pourquoi Edgard ce permet 
cette réflexion ?



Le 18/01/2021 à 17:11, Eric Lupinacci a écrit :

Bon on va se calmer là un peu tous.
Moi je suis d'accord avec... Camille, puisque c'est nous qui nous 
occupons des comptes.
Si le compte n'a pas été créé sur git ou si il a été supprimé c'est 
une... *ERREUR* (mode Rasta ;-))


Donc non Joel tu n'es pas une victime d'un autoritarisme et d'un 
sectarisme sournois mais de deux péquins qui se sont plantés malgré 
leur cerveau démesurément développé.
Je sais qu'à un moment j'ai aussi demandé à Camille de supprimer une 
liste de fake users.
Donc on a probablement dérapé mais c'était avant le grand incident du 
point médian qui a depuis refondé le monde que nous connaissons.


Nous nous excusons platement pour cet impair (donnable) et acceptons 
d'emblée notre sentence.


++
Eric


Le lun. 18 janv. 2021 à 17:02, Maïeul Rouquette > a écrit :


Le 18/01/2021 à 16:09, RastaPopoulos a écrit :
> Le 18/01/2021 à 16:02, tcharlss a écrit :
>>
Et bien si c'était le cas, sur le principe je trouverais ça très gênant.
>> Supprimer un compte en catimini sans prévenir personne ? Pas
très classe, j'espère que ça a pas été le cas ici.
>
> Moi non plus je ne trouverais pas ça légitime si ça a été fait
sans annoncer clairement.
>
> Mais là priori il n'y a très probablement rien eu de bizarre :
> - rien n'a changé sur les listes et il peut parfaitement poster
puisqu'on voit et répond à ses messages… donc aucun rapport sur ce
point
> - Camille a clairement expliqué que *pour les anciens comptes de
la forge*, donc spécifiquement pour le code, lors du passage en
Git il y a eu du nettoyage de certains comptes non utilisés depuis
fort longtemps et que donc il faut juste lui re-créer un compte
pour le Gitea
>
> … si la charte est acceptée.
>
Je plussoie. Quoi que l'on pense du comportement de Joël (et je pense
que j'étais en première ligne pour montrer que je le trouvais
totalement
inadapté) aucune décision unilatérale à ce sujet (aka sans
commission)
serait contraire à la charte.

Mais cela tombe bien, cela n'a pas été le cas.

Cela étant, La piqûre de rappel de Cédric était sans doute nécessaire
sur le fond, même si la forme a pu semer le trouble le trouble.

La charte de SPIP rappel des valeurs historiques de SPIP qui n'ont
été
formalisées que récemment dans cette charte. La modalité d'emploi
de la
charte, et notamment de la manière de gérer les violations de la
charte,
reste encore à mesurer à l'épreuve des faits. J'espère que le cas
Joël
ne nous y obligera pas.
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev

doc: https://www.spip.net/ 
dev: https://core.spip.net/ 
irc://irc.freenode.net/spip 


___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


--
spipfactory.fr

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] plugin Associaspip

2021-01-16 Par sujet team spipfactoy
on a laissé complètement tombé car nos compétences nous on pas permis de 
coupler spip + interface privé + compta


on c'est tourné vers spip pour le public

et garradin en autonome pour la comptabilité.

avec courant 2021 si tout va bien basculé le public sur garradin si la 
partie wiki/web de garradin est finalisé


puisque garradin a l'air d'utilisé le principe des boucles spip


la partie compta + gestion des membres pour une asso est primordial , 
c'est ce qui manque a spip.


3000 asso tourne sous garradin et ceux avec qui je suis en contact 
utilise spip pour l'interface public.



merci d'avoir répondu

et merci au dev de spip pour ce merveilleux outils pour ceux et celles 
qui connaisse rien en dev, malgré les effets de bord quelquefois ;)


Le 16/01/2021 à 19:04, cam.lafit a écrit :

Hello

Il y aussi toute la solution dolispip (dolibarr couplé à dolibarr).
C'est ce qui est utilisé entre autre avec les sites des RMLL.

Km

Le 04/12/2020 à 08:22, Team Stéphane a écrit :

*Bonjour,*

pour répondre plus précisément a la question de JLuc , je suis en train
de relire tout les infos qui concerne associaspip et garradin


*ma question est :*

Ce plugin a t'il encore une vie ?, ou est il passé au oubliettes ?

a vous lire 


Le 03/12/2020 à 12:42, JLuc a écrit :

Le 02/12/2020 à 20:52, Team Stéphane a écrit :

Je suis a la recherche d'un DEV pour étudier, voir réaliser un plugin
pour spip de comptabilité en interface privé.
qui sera reversé a la communauté et déposé sur git spip
il devra reprendre la partie compta de  garradin
(https://framalibre.org/content/garradin)
(voir si on peu transformer ça en brique de spip)

Qu'apporterait / devrait apporter cette intégration par rapport à
avoir Garradin à côté de SPIP ?


le reste pour une association étant déja fourni par spip
(https://contrib.spip.net/Gestion-d-association-complete)

JLuc

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


--
spipfactory.fr

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

[spip-dev] Hello qui pourrais me renseigner

2021-01-03 Par sujet team spipfactoy

Bon An a tous
Bonjour on me remonte le probléme suivant


 Je viens de m'apercevoir, qu'il m'était aujourd'hui impossible :
- de publier sur la liste spip-dev
- de publier sur la liste spip
- de mettre à jour les plugins dont je m'occupe
- de faire un simple bug report

est ce que c'est normal

--
spipfactory.fr

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Migration Git - Galaxie - Scories

2020-12-28 Par sujet team spipfactoy
je suis d'accord avec b_b d'autant plus qu'il ne refléte pas la réalité 
des choses en terme de stat d'utilisation d'un plugin


Le 28/12/2020 à 15:09, Bruno Bergot a écrit :




Je reviens sur la question d'ajouter stats.spip.net à la boussole. Je 
doute de l'intérêt pour les personnes tomberaient sur ce lien depuis 
le menu "Découverte" de la boussole, le site est "un peu" brut, amha 
c'est plus un outil interne qu'autre chose.


++
b_b


--
spipfactory.fr

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip