Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-11 Par sujet Matthieu Marcillaud
Le 04/03/2021 à 17:15, Matthieu Marcillaud a écrit : Les versions PHP maintenues sont 7.3+ à ce jour. Sur le sujet de monter la version minimale, scssphp se pose aussi la question pour sa version 2, et fait un petit bilan de certains CMS (qui utilisent scssphp) au passage : 

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-07 Par sujet spip.franck
: spip.fra...@lien-d-amis.net Envoyé : dimanche 7 mars 2021 10:22 À : 'Matthieu Marcillaud' ; 'spip-dev@rezo.net' Objet : RE: [spip-dev] Version PHP minimum SPIP 3.3 Hello Marcimat  A voir, mais je pense qu'il manque en spip 3.2 au moins : https://core.spip.net/projects/spip/repository

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-07 Par sujet spip.franck
://core.spip.net/issues/4603 Quand cela sera fait, je regarderais en faisant d'autres tests en php 7.4 Franck -Message d'origine- De : Matthieu Marcillaud Envoyé : jeudi 4 mars 2021 22:57 À : spip-dev@rezo.net Objet : Re: [spip-dev] Version PHP minimum SPIP 3.3 Le 04/03/2021 à 19:12, CSI a écrit

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-06 Par sujet YannX SPIP(hot)
Le 05/03/2021 à 08:16, Pierre KUHN a écrit : Bonjour, Bis Minimum 7.4 !!! Si on regarde les stats.spip.org on a encore manifestement des sites en  5.3 donc peut être que déjà 7.2 serait bien il me semble. Je plussoie, connaissant deux situations de ce type : - une petite asso d'insertion

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-05 Par sujet RealET
nicod_ a écrit le 05/03/2021 à 12:17 : Le 05/03/2021 à 08:16, Pierre KUHN a écrit : Si on regarde les stats.spip.org on a encore manifestement des sites en   5.3 Qui ne seront jamais mis à jour, probablement. Je viens d'en voir un passer directement de 5.3 à 7.2 (une asso avec un dédié)...

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-05 Par sujet nicod_
Le 05/03/2021 à 08:16, Pierre KUHN a écrit : Si on regarde les stats.spip.org on a encore manifestement des sites en  5.3 Qui ne seront jamais mis à jour, probablement. -- nicod_ ___ liste: https://listes.rezo.net/mailman/listinfo/spip-dev doc:

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-05 Par sujet Eric Lupinacci
Hello, Le ven. 5 mars 2021 à 09:51, RealET a écrit : > RastaPopoulos a écrit le 05/03/2021 à 08:46 : > > Le 04/03/2021 à 17:54, RealET a écrit : > >> Après, d'un point de vue politico-phylosophique, SPIP a toujours > cherché à pouvoir être utilisé dans des environnements accessibles au >

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-05 Par sujet CSI
Bonjour, Le 05/03/2021 à 09:42, Cerdic a écrit : Je rappelle que SPIP n’est pas uniquement un produit commercial hein ;) Il y a des utilisateurs auto-hébergés qui maintiennent eux-même leurs serveurs et pour lesquels passer d’une debian à une autre (ou idem si c’est une autre

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-05 Par sujet RealET
RastaPopoulos a écrit le 05/03/2021 à 08:46 : Le 04/03/2021 à 17:54, RealET a écrit : Après, d'un point de vue politico-phylosophique, SPIP a toujours cherché à pouvoir être utilisé dans des environnements accessibles au maximum de personnes et de pays. De ce point de vue, la compatibilité 

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-05 Par sujet Cerdic
Je rappelle que SPIP n’est pas uniquement un produit commercial hein ;) Il y a des utilisateurs auto-hébergés qui maintiennent eux-même leurs serveurs et pour lesquels passer d’une debian à une autre (ou idem si c’est une autre distrib) n’est pas trivial, et que historiquement c’est pour ces

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-05 Par sujet Jacques B
Le 05/03/2021 à 08:46, RastaPopoulos a écrit : Même les pages persos Free gratuites proposent PHP 7.3 ! free ils ont un serveur de test en php 7.3 et si j'ai bien compris même php 5.6 n'est pas possible sur tous leurs serveurs http://les.pages.perso.chez.free.fr/migrations/php5v6.io Mais

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-05 Par sujet Stephane Santon
Bonjour, Le 05/03/2021 à 08:16, Pierre KUHN a écrit : Minimum 7.4 !!! Si on regarde les stats.spip.org on a encore manifestement des sites en  5.3 donc peut être que déjà 7.2 serait bien il me semble. Je crois qu'il parle de compatibilité minimum à atteindre, et non de version minimum

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Guilain Denisselle - Hôtel Conseil
Sur Plesk c'est 5.2 à 8.0 -Message d'origine- De : Pierre KUHN Envoyé : vendredi 5 mars 2021 08:55 À : spip-dev@rezo.net Objet : Re: [spip-dev] Version PHP minimum SPIP 3.3 > Quels sont les versions de PHP proposées par chaque hébergeur un peu > connu en France, en Europe

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Pierre KUHN
Quels sont les versions de PHP proposées par chaque hébergeur un peu connu en France, en Europe ?Chez O2switch et planethoster il propose toutes les version php de 4.4 à 8.0 Et je pense que tout ceux qui on cpanel pour géré les serveurs on cette possibilité.

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet RastaPopoulos
Le 04/03/2021 à 17:54, RealET a écrit : > Après, d'un point de vue politico-phylosophique, SPIP a toujours cherché à > pouvoir être utilisé dans des environnements accessibles au maximum de > personnes et de pays. > De ce point de vue, la compatibilité PHP 5.6 est peut-être bienvenue. Mais

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet RastaPopoulos
Le 04/03/2021 à 22:56, Matthieu Marcillaud a écrit : > Du coup, dans ma grande motivation, je viens de reporter différents commits > pour PHP 7.2 et 7.3 en SPIP 3.2 qui enlèvent pas mal de deprecated et  > certains warnings. > > Puis dans la foulée, j'ai reporté aussi des éléments pour la compat

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Pierre KUHN
Bonjour, Minimum 7.4 !!! Si on regarde les stats.spip.org on a encore manifestement des sites en 5.3 donc peut être que déjà 7.2 serait bien il me semble. ___ liste: https://listes.rezo.net/mailman/listinfo/spip-dev doc: https://www.spip.net/ dev:

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Maïeul Rouquette
Le 04/03/2021 à 22:56, Matthieu Marcillaud a écrit : Le 04/03/2021 à 19:12, CSI a écrit : Bonjour, [...] Donc perso si je suis tout à fait d'accord pour quitter PHP 5.6, je préfèrerai que la nouvelle limite basse soit 7.0 ou alors que 3.2 soit préalablement rendu compatible avec 7.3 (j'en

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Matthieu Marcillaud
Le 04/03/2021 à 19:12, CSI a écrit : Bonjour, [...] Donc perso si je suis tout à fait d'accord pour quitter PHP 5.6, je préfèrerai que la nouvelle limite basse soit 7.0 ou alors que 3.2 soit préalablement rendu compatible avec 7.3 (j'en ai qui tournent sur 7.3 Ce n'est pas idiot

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet David Prévot
Salut, Le 04/03/2021 à 12:15, Matthieu Marcillaud a écrit : […] on avait monté la version minimum de PHP […] parce que [des] distributions Debian pouvaient peut être être encore dessus. […] Les versions PHP maintenues sont 7.3+ à ce jour. […] Buster 10 — 7.3 [ Bientôt supplantée par…]

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet spip.franck
mais devoir mettre php 7.1 ou 7.2 mini pour spip 3.3.1 par exemple à cause des mises à jour des libs que spip embarque, c'est un peu embêtant... Franck -Message d'origine- De : Matthieu Marcillaud Envoyé : jeudi 4 mars 2021 17:15 À : spip-dev@rezo.net Objet : [spip-dev] Version PHP

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Bruno Bergot
Re, Le 04/03/2021 à 17:54, RealET a écrit : Après, d'un point de vue politico-phylosophique, SPIP a toujours cherché à pouvoir être utilisé dans des environnements accessibles au maximum de personnes et de pays. De ce point de vue, la compatibilité PHP 5.6 est peut-être bienvenue. Je doute

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Bruno Bergot
Hop, Le 04/03/2021 à 17:15, Matthieu Marcillaud a écrit : Hello, Il y a maintenant longtemps, on avait monté la version minimum de PHP requise pour SPIP 3.3 à PHP 5.6 parce que (de mémoire) quelques distributions Debian pouvaient peut être être encore dessus. On est quelques un·es à se

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet nicod_
Le 04/03/2021 à 17:15, Matthieu Marcillaud a écrit : Hello, Il y a maintenant longtemps, on avait monté la version minimum de PHP requise pour SPIP 3.3 à PHP 5.6 parce que (de mémoire) quelques distributions Debian pouvaient peut être être encore dessus. On est quelques un·es à se dire que

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet CSI
Bonjour, Le 04/03/2021 à 17:15, Matthieu Marcillaud a écrit : Hello, Il y a maintenant longtemps, on avait monté la version minimum de PHP requise pour SPIP 3.3 à PHP 5.6 parce que (de mémoire) quelques distributions Debian pouvaient peut être être encore dessus. On est quelques un·es à se

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet RealET
Matthieu Marcillaud a écrit le 04/03/2021 à 17:15 : Hello, Il y a maintenant longtemps, on avait monté la version minimum de PHP requise pour SPIP 3.3 à PHP 5.6 parce que (de mémoire) quelques distributions Debian pouvaient peut être être encore dessus. On est quelques un·es à se dire que

Re: [spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Maïeul Rouquette
Le 04/03/2021 à 17:15, Matthieu Marcillaud a écrit : Hello, Il y a maintenant longtemps, on avait monté la version minimum de PHP requise pour SPIP 3.3 à PHP 5.6 parce que (de mémoire) quelques distributions Debian pouvaient peut être être encore dessus. On est quelques un·es à se dire que

[spip-dev] Version PHP minimum SPIP 3.3

2021-03-04 Par sujet Matthieu Marcillaud
Hello, Il y a maintenant longtemps, on avait monté la version minimum de PHP requise pour SPIP 3.3 à PHP 5.6 parce que (de mémoire) quelques distributions Debian pouvaient peut être être encore dessus. On est quelques un·es à se dire que bon, le temps est passé encore (comme d'hab) et que