Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet CSI

Bonjour,

Ok merci super, pas besoin donc de changer toutes ces bornes, ça me 
rassure !


Le 17/02/2021 à 16:09, nicod_ a écrit :

Le 17/02/2021 à 15:12, CSI a écrit :

Bonjour,

Le 17/02/2021 à 14:51, Bruno Bergot a écrit :
Des choses que de webmestres/intégrateurices peuvent faire pour 
aider ?




Oui, tester la version 3.3 intensivement :)
Une question à 1€ à ce sujet. Hier on a envisagé de passer un 
site en 3.3 pour tester justement, mais c'est un site live. J'ai vu 
que pas mal de gens essayaient déjà, je me suis dit pourquoi pas 
... mais la question c'est plutôt les plugins, j'en ai à peu près 
70% marquée comme non compatibles. Que conseillez vous ? je change 
à la mano les bornes de tous ces plugins et on voit ? j'imagine que 
faire ça va casser les mises à jours desdits plugins ? une autre 
méthode ?


Si tu passes en 3.3 (dans la version de dév), elle a une constante 
spécifique qui fait qu'elle accepte par défaut les plugins dont la 
borne supérieure est 3.2.*
Ça sert justement à tester les plugins lors du dév d'une nouvelle 
version majeure.


Tu n'as donc rien à faire, tous tes plugins compatibles 3.2.* 
resteront activés.
Et tu pourras justement les tester, et modifier leurs borne s'ils sont 
100% compatibles, ou bien le signaler à leurs auteurs.


Par contre, quand la 3.3 officielle (non dév) sortira, il faudra bien 
sûr que tous tes plugins aient une borne 3.3 et plus 3.2



--
Pierre

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet nicod_

Le 17/02/2021 à 15:12, CSI a écrit :

Bonjour,

Le 17/02/2021 à 14:51, Bruno Bergot a écrit :

Des choses que de webmestres/intégrateurices peuvent faire pour aider ?



Oui, tester la version 3.3 intensivement :)
Une question à 1€ à ce sujet. Hier on a envisagé de passer un site en 
3.3 pour tester justement, mais c'est un site live. J'ai vu que pas mal 
de gens essayaient déjà, je me suis dit pourquoi pas ... mais la 
question c'est plutôt les plugins, j'en ai à peu près 70% marquée comme 
non compatibles. Que conseillez vous ? je change à la mano les bornes de 
tous ces plugins et on voit ? j'imagine que faire ça va casser les mises 
à jours desdits plugins ? une autre méthode ?


Si tu passes en 3.3 (dans la version de dév), elle a une constante 
spécifique qui fait qu'elle accepte par défaut les plugins dont la borne 
supérieure est 3.2.*
Ça sert justement à tester les plugins lors du dév d'une nouvelle 
version majeure.


Tu n'as donc rien à faire, tous tes plugins compatibles 3.2.* resteront 
activés.
Et tu pourras justement les tester, et modifier leurs borne s'ils sont 
100% compatibles, ou bien le signaler à leurs auteurs.


Par contre, quand la 3.3 officielle (non dév) sortira, il faudra bien 
sûr que tous tes plugins aient une borne 3.3 et plus 3.2


--
nicod_
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet team spipfactoy

moi d emon coté j'ai

ecrire/?exec=configurer_svp


Autoriser l’activation des paquets obsolètes ?
Les paquets obsolètes sont des paquets locaux présents qui sont plus 
anciens que d’autres paquets locaux. L’obsolescence est établie sur la 
base de l’état (stable, test, dev) du paquet ainsi que sur la base de 
sa version. Activez cette option si vous souhaitez malgré tout pouvoir 
activer ces plugins obsolètes.

Oui


et du coup

*Compatibilité forcée*
Les plugins compatibles avec SPIP |3.2.99| peuvent être activés.


et donc sur

*SPIP 3.3.0-dev GIT [master: 6aa33239 
]* 




Le 17/02/2021 à 15:12, CSI a écrit :

Bonjour,

Le 17/02/2021 à 14:51, Bruno Bergot a écrit :

Des choses que de webmestres/intégrateurices peuvent faire pour aider ?



Oui, tester la version 3.3 intensivement :)
Une question à 1€ à ce sujet. Hier on a envisagé de passer un site en 
3.3 pour tester justement, mais c'est un site live. J'ai vu que pas 
mal de gens essayaient déjà, je me suis dit pourquoi pas ... mais la 
question c'est plutôt les plugins, j'en ai à peu près 70% marquée 
comme non compatibles. Que conseillez vous ? je change à la mano les 
bornes de tous ces plugins et on voit ? j'imagine que faire ça va 
casser les mises à jours desdits plugins ? une autre méthode ?


++
b_b

--
Pierre
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet team spipfactoy


Le 17/02/2021 à 14:51, Bruno Bergot a écrit :

Oui, tester la version 3.3 intensivement :)

++
b_b



en mutu actuellement 42 sites


on ma remonté mais c'est pas lié a spip 3.3, mais plus au plugins


 Une "feature" dans SPIP
 


 Pb pour Migrer un site SPIP en HTML5
 


 Plugin "CISF" & "minibando" Incompatible
 


 Plugin "METADONNÉES PHOTO" & "GALLERIA" Incompatible
 


 Plugins VIDÉOS & création d’articles
 


 Plugins CIWIDGET & création d’articles
 


 Plugins image_responsive & medias_responsive_mod + newsletters
 


 Plugins Adaptative Image + Escal
 


 Plugins Spam referer
 


_


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet CSI

Bonjour,

Ok j'imagine que le message de Rastapopoulos qui s'est croisé avec le 
mien répond à ma question. Merci.


Le 17/02/2021 à 15:12, CSI a écrit :

Bonjour,

Le 17/02/2021 à 14:51, Bruno Bergot a écrit :
Des choses que de webmestres/intégrateurices peuvent faire pour 
aider ?




Oui, tester la version 3.3 intensivement :)
Une question à 1€ à ce sujet. Hier on a envisagé de passer un 
site en 3.3 pour tester justement, mais c'est un site live. J'ai vu 
que pas mal de gens essayaient déjà, je me suis dit pourquoi pas ... 
mais la question c'est plutôt les plugins, j'en ai à peu près 70% 
marquée comme non compatibles. Que conseillez vous ? je change à la 
mano les bornes de tous ces plugins et on voit ? j'imagine que faire 
ça va casser les mises à jours desdits plugins ? une autre méthode ?


++
b_b

--
Pierre
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet Victor / tokiop



Le 17/02/2021 à 14:51, Bruno Bergot a écrit :
> Hop,
> 
> Le 17/02/2021 à 14:05, Victor / tokiop a écrit :
>>
>> Même si certains hébergeurs proposent des versions plus anciennes, ce n'est 
>> pas toujours le cas, et l'incompatibilité avec 7.4 ne rassure pas chez les 
>> admins qui bichonnent un peu les serveurs / màj / sécu.
>>
> 
> Faut pas pousser, je connais des admins très sympa chez des chatons qui 
> proposent plein de version de PHP de la 5.6 à la 7.x à leurs adhérents, et ça 
> n'est pas forcément le plus gros problème de sécu pour un hébergeur...

Désolé, c'etait pas pour pousser ou mettre la pression, pas d'inquiétude de mon 
coté :)

C'est des retours d'admin/inté institutionnels qui gèrent pas mal de Spip, 
suivent peut être pas le développement de près, et se posaient des questions 
sur la situation.

>> Est ce que la 3.3 vous semble assez stable pour être utilisée en prod ? 
>> Spip.net semble tourner avec, est ce que c'est le cas de beaucoup d'autres 
>> sites ? Hormis la question de stabilité, l'indisponibilité de beaucoup de 
>> plugins compatibles peut être bloquante.
>>
> 
> Ben justement, on est en sprint depuis presque deux semaines pour une release 
> qui si on tient le rythme devrait avoir lieu dans... wait for it... quelques 
> jours, ou semaines max :)

Excellent, bon courage ! <3

>> Des choses que de webmestres/intégrateurices peuvent faire pour aider ?
>>
> 
> Oui, tester la version 3.3 intensivement :)

C'est noté, je vais déjà tester des montées en version de quelques sites en 
local.
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet CSI

Bonjour,

Le 17/02/2021 à 14:51, Bruno Bergot a écrit :

Des choses que de webmestres/intégrateurices peuvent faire pour aider ?



Oui, tester la version 3.3 intensivement :)
Une question à 1€ à ce sujet. Hier on a envisagé de passer un site 
en 3.3 pour tester justement, mais c'est un site live. J'ai vu que pas 
mal de gens essayaient déjà, je me suis dit pourquoi pas ... mais la 
question c'est plutôt les plugins, j'en ai à peu près 70% marquée 
comme non compatibles. Que conseillez vous ? je change à la mano les 
bornes de tous ces plugins et on voit ? j'imagine que faire ça va 
casser les mises à jours desdits plugins ? une autre méthode ?


++
b_b

--
Pierre
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet RastaPopoulos
Le 17/02/2021 à 14:51, Bruno Bergot a écrit :
> Oui, tester la version 3.3 intensivement 

Et tester les plugins non encore marqués compat, pour justement dire aux devs 
si ça marche ou pas et changer la borne le cas échéant (ou au moins savoir 
qu'il faut chercher quoi faire pour être compat)

-- 
RastaPopoulos

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet Bruno Bergot

Hop,

Le 17/02/2021 à 14:05, Victor / tokiop a écrit :


Même si certains hébergeurs proposent des versions plus anciennes, ce n'est pas 
toujours le cas, et l'incompatibilité avec 7.4 ne rassure pas chez les admins 
qui bichonnent un peu les serveurs / màj / sécu.



Faut pas pousser, je connais des admins très sympa chez des chatons qui 
proposent plein de version de PHP de la 5.6 à la 7.x à leurs adhérents, 
et ça n'est pas forcément le plus gros problème de sécu pour un hébergeur...



À part sortir une 3.3, je ne vois pas de solution.


Ça serait idéal, est ce qu'il reste de gros chantiers en cours ?

Est ce que la 3.3 vous semble assez stable pour être utilisée en prod ? 
Spip.net semble tourner avec, est ce que c'est le cas de beaucoup d'autres 
sites ? Hormis la question de stabilité, l'indisponibilité de beaucoup de 
plugins compatibles peut être bloquante.



Ben justement, on est en sprint depuis presque deux semaines pour une 
release qui si on tient le rythme devrait avoir lieu dans... wait for 
it... quelques jours, ou semaines max :)



Des choses que de webmestres/intégrateurices peuvent faire pour aider ?



Oui, tester la version 3.3 intensivement :)

++
b_b
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet Victor / tokiop
Le 17/02/2021 à 10:37, Matthieu Marcillaud a écrit :
> Alors clairement je doute fortement que SPIP 3.2 fonctionne avec PHP 7.4 sans 
> warnings bloquants (impactants le fonctionnement), voire fatales. Et je doute 
> encore plus que l'on reporte les corrections faites à ce sujet (trop 
> nombreuses) de la 3.3 vers la 3.2.

Quelques retours si ça peut aider : en 3.2.9, sous php 7.4 sans affichage des 
warnings en prod, sur des sites pas minimaliste, le seul dysfonctionnement 
remarqué, c'est le bouton "réactiver le cache" qui reste affiché en permanence, 
ce qui est gênant mais pas bloquant. Si vous avez remarqué d'autres plus 
importants ça m'intéresse !

Même si certains hébergeurs proposent des versions plus anciennes, ce n'est pas 
toujours le cas, et l'incompatibilité avec 7.4 ne rassure pas chez les admins 
qui bichonnent un peu les serveurs / màj / sécu.

> À part sortir une 3.3, je ne vois pas de solution.

Ça serait idéal, est ce qu'il reste de gros chantiers en cours ?

Est ce que la 3.3 vous semble assez stable pour être utilisée en prod ? 
Spip.net semble tourner avec, est ce que c'est le cas de beaucoup d'autres 
sites ? Hormis la question de stabilité, l'indisponibilité de beaucoup de 
plugins compatibles peut être bloquante.

Des choses que de webmestres/intégrateurices peuvent faire pour aider ?

En tout cas merci à toute l'équipe pour le taf et le suivi !

Victor
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip


Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet team spipfactoy


Le 17/02/2021 à 10:37, Matthieu Marcillaud a écrit :


À part sortir une 3.3, je ne vois pas de solution. 


la gazette nous le dit



  côté core

*SPIP 3.3 : en route pour la beta!*

La version de dev SPIP3.3 passe bientôt en beta! Vous allez pouvoir la 
tester et signaler tout éventuel dysfonctionnement rencontré (annonce 
à venir 


--
spipfactory.fr

En répondant a ce courriel vous acceptez implicitement la diffusion, l’échange 
de la conversation, sauf avis contraire clairement exprimé.

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-17 Par sujet Matthieu Marcillaud

Le 16/02/2021 à 19:53, David Prévot a écrit :

[...]

Bullseye (la prochaine version stable de Debian) fournira PHP 7.4. Elle 
proposera SPIP 3.2.9 (fingers crossed, early testing welcome…).


Alors clairement je doute fortement que SPIP 3.2 fonctionne avec PHP 7.4 
sans warnings bloquants (impactants le fonctionnement), voire fatales. 
Et je doute encore plus que l'on reporte les corrections faites à ce 
sujet (trop nombreuses) de la 3.3 vers la 3.2.


À part sortir une 3.3, je ne vois pas de solution.

MM.
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-16 Par sujet chanka...@choc0.net

hello
Le 16/02/2021 à 19:53, David Prévot a écrit :


Bullseye (la prochaine version stable de Debian) fournira PHP 7.4. 
Elle proposera SPIP 3.2.9 (fingers crossed, early testing welcome…). 
le paquet Debian de SPIP a été mis à jour hier il me semble, avec la 
v3.2.9, mais effectivement c'est bien pour bullseye :

https://packages.debian.org/fr/bullseye/spip


--

chan

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-16 Par sujet David Prévot

Salut,

Le 16/02/2021 à 12:08, Bruno Bergot a écrit :

Je voulais savoir si vous aviez des retours sur l'utilisation d'un php 
7.3 ou 7.4 ?

[…]
Seule la version 3.3 de SPIP sera compatible avec PHP > 7.2, tu peux 
tenter une 3.2 en PHP 7.3, mais c'est à tes risques et périls (ça peut 
passer moyennant quelques warnings).


Pour information, Buster (la version stable de Debian publiée il y a une 
paire d’année) est fournie avec PHP 7.3. Elle propose SPIP 3.2.4 (avec 
correctifs de sécurité), avec l’intégration d’un correctif à #4205 (qui 
posait problème lors de la mise à jour de plugins) depuis fin 2019.


Je n’ai pas eu de remontée de problème spécifique à PHP 7.3 (à part 
celui déjà cité, mais qui ne concerne pas la version 3.2 de SPIP 
actuelle). Les journaux ne sont pas jolis (warnings, you’ve been warned…).


Bullseye (la prochaine version stable de Debian) fournira PHP 7.4. Elle 
proposera SPIP 3.2.9 (fingers crossed, early testing welcome…).


Amicalement

David

___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip

Re: [spip-dev] Quelle version de php utiliser ?

2021-02-16 Par sujet Bruno Bergot

Hop,

Le 16/02/2021 à 17:04, Axel a écrit :

Bonjour,
Sur la page : https://www.spip.net/fr_article4351.html
Je vois que la version de spip 3.2 nécessite un php 7.2 "maximum" :

- PHP 5.4.0 minimum, PHP 7.2 maximum

Mais sur la page :
https://www.php.net/supported-versions.php
Je vois que la version 7.2 de php n'est plus maintenue...



Oui, plus maintenue, mais toujours utilisable chez pas mal d'hebergeurs, 
tout comme PHP 7.0 ou 5.6 ;)



Je voulais savoir si vous aviez des retours sur l'utilisation d'un php 7.3
ou 7.4 ?



Seule la version 3.3 de SPIP sera compatible avec PHP > 7.2, tu peux 
tenter une 3.2 en PHP 7.3, mais c'est à tes risques et périls (ça peut 
passer moyennant quelques warnings).


++
b_b
___
liste: https://listes.rezo.net/mailman/listinfo/spip-dev
doc: https://www.spip.net/
dev: https://core.spip.net/
irc://irc.freenode.net/spip