Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet dd

Le 08/09/2019 à 16:23, Franck a écrit :

Hello 
Tu peux donner ta version de spip et de php stp ?


-Message d'origine-
De : dd 
Envoyé : dimanche 8 septembre 2019 15:47
À : spip-zone@rezo.net
Objet : [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

Il y a des messages d'erreur lorsque l'on veut mettre à jour le plugin Agenda 
3.32.0 - stable

vers la version dispo 3.32.1 :
  Impossible d’activer le plugin ../plugins/auto/agenda/v3.32.1
  Utilise le plugin FULLTEXT en version ≥ 1.0.0.
  Utilise le plugin CORBEILLE en version ≥ 3.1.1.
  Utilise le plugin SAISIES en version ≥ 3.27.0.
  Impossible d’activer le plugin
../plugins/auto/fullcalendar_facile/v2.4.3
  Nécessite le plugin AGENDA en version ≥ 3.18.4.

dd




En local ça fonctionne donc sans doute une histoire de cache en effet.
Merci


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet Jean-Christophe Villeneuve
De mémoire pour un cas similaire, j'avais supprimé le dépôt, vidé le 
cache puis remis le dépot


JC

Le 08/09/2019 à 18:40, Franck a écrit :

Sinon, il y a quoi d'autres comme plugins sur le site ? Possible qu'il y a une 
incompatibilité entre deux plugs aussi...
Sinon, fullcalendar_facile necessite:
- Agenda qui lui-même necessite:
-Mini Calendrier

- organiseur

Donc à voir en commençant par mettre à jour mini calendrier, puis organiseur et 
enfin agenda ???
Cela dit, logiquement, j'avais regardé toutes les dépendances, et il n'y avait 
pas de raison que cela bloque.
Franck

-Message d'origine-
De : dd 
Envoyé : dimanche 8 septembre 2019 18:23
À : spip-zone@rezo.net
Objet : Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

Le 08/09/2019 à 17:19, Pierre KUHN a écrit :

Mettre à jour les autres plugin avant déjà.


Il n'y a pas de plugin FULLTEXT ni CORBEILLE installés sur ce site.


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone




spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet Franck
Sinon, il y a quoi d'autres comme plugins sur le site ? Possible qu'il y a une 
incompatibilité entre deux plugs aussi...
Sinon, fullcalendar_facile necessite:
- Agenda qui lui-même necessite:
-Mini Calendrier 

- organiseur

Donc à voir en commençant par mettre à jour mini calendrier, puis organiseur et 
enfin agenda ???
Cela dit, logiquement, j'avais regardé toutes les dépendances, et il n'y avait 
pas de raison que cela bloque.
Franck

-Message d'origine-
De : dd  
Envoyé : dimanche 8 septembre 2019 18:23
À : spip-zone@rezo.net
Objet : Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

Le 08/09/2019 à 17:19, Pierre KUHN a écrit :
> Mettre à jour les autres plugin avant déjà.


Il n'y a pas de plugin FULLTEXT ni CORBEILLE installés sur ce site.


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet dd

Le 08/09/2019 à 17:19, Pierre KUHN a écrit :

Mettre à jour les autres plugin avant déjà.



Il n'y a pas de plugin FULLTEXT ni CORBEILLE installés sur ce site.


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet Pierre KUHN
Mettre à jour les autres plugin avant déjà.

Le dim. 8 sept. 2019 à 17:14, Franck  a écrit :

> Arf comme ça, j'ai pas d'idée, je pensais à une trop grande version de
> php, ou même une trop vielle version de spip. Mais c'est pas ça.
> J'ai fait une vérification des dépendances et cela me semble bon, elles
> sont toutes compatible spip 3.2
> Donc, comme ça, j'ai pas trop d'idée... et si tu vide le cache et
> recommence, cela fait pareil ?
> Après, à voir en faisant :
> https://www.spip.net/fr_article4453.html#Debloquer-SVP
> Franck
>
>
> -Message d'origine-
> De : dd 
> Envoyé : dimanche 8 septembre 2019 16:29
> À : spip-zone@rezo.net
> Objet : Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1
>
> Le 08/09/2019 à 16:23, Franck a écrit :
> > Hello 
> > Tu peux donner ta version de spip et de php stp ?
> >
> >
> > -Message d'origine-
> > De : dd 
> > Envoyé : dimanche 8 septembre 2019 15:47 À : spip-zone@rezo.net Objet
> > : [SPIP Zone] erreur MAJ plugin Agenda 3.32.1
> >
> > Il y a des messages d'erreur lorsque l'on veut mettre à jour le plugin
> > Agenda 3.32.0 - stable
> > > vers la version dispo 3.32.1
> >
> > dd
> >
> Voilà :
> SPIP 3.2.4 [24285]
> PHP Version 7.1.30
>
> 
> spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone
>
> 
> spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone
>

spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet Franck
Arf comme ça, j'ai pas d'idée, je pensais à une trop grande version de php, ou 
même une trop vielle version de spip. Mais c'est pas ça.
J'ai fait une vérification des dépendances et cela me semble bon, elles sont 
toutes compatible spip 3.2
Donc, comme ça, j'ai pas trop d'idée... et si tu vide le cache et recommence, 
cela fait pareil ?
Après, à voir en faisant : 
https://www.spip.net/fr_article4453.html#Debloquer-SVP
Franck


-Message d'origine-
De : dd  
Envoyé : dimanche 8 septembre 2019 16:29
À : spip-zone@rezo.net
Objet : Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

Le 08/09/2019 à 16:23, Franck a écrit :
> Hello 
> Tu peux donner ta version de spip et de php stp ?
> 
> 
> -Message d'origine-
> De : dd 
> Envoyé : dimanche 8 septembre 2019 15:47 À : spip-zone@rezo.net Objet 
> : [SPIP Zone] erreur MAJ plugin Agenda 3.32.1
> 
> Il y a des messages d'erreur lorsque l'on veut mettre à jour le plugin 
> Agenda 3.32.0 - stable
> > vers la version dispo 3.32.1 
> 
> dd
> 
Voilà :
SPIP 3.2.4 [24285]
PHP Version 7.1.30


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet dd

Le 08/09/2019 à 16:23, Franck a écrit :

Hello 
Tu peux donner ta version de spip et de php stp ?


-Message d'origine-
De : dd 
Envoyé : dimanche 8 septembre 2019 15:47
À : spip-zone@rezo.net
Objet : [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

Il y a des messages d'erreur lorsque l'on veut mettre à jour le plugin Agenda 
3.32.0 - stable
> vers la version dispo 3.32.1 


dd


Voilà :
SPIP 3.2.4 [24285]
PHP Version 7.1.30


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet Franck
Hello 
Tu peux donner ta version de spip et de php stp ?


-Message d'origine-
De : dd  
Envoyé : dimanche 8 septembre 2019 15:47
À : spip-zone@rezo.net
Objet : [SPIP Zone] erreur MAJ plugin Agenda 3.32.1

Il y a des messages d'erreur lorsque l'on veut mettre à jour le plugin Agenda 
3.32.0 - stable

vers la version dispo 3.32.1 :
 Impossible d’activer le plugin ../plugins/auto/agenda/v3.32.1
 Utilise le plugin FULLTEXT en version ≥ 1.0.0.
 Utilise le plugin CORBEILLE en version ≥ 3.1.1.
 Utilise le plugin SAISIES en version ≥ 3.27.0.
 Impossible d’activer le plugin
../plugins/auto/fullcalendar_facile/v2.4.3
 Nécessite le plugin AGENDA en version ≥ 3.18.4.

dd


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


[SPIP Zone] erreur MAJ plugin Agenda 3.32.1

2019-09-08 Par sujet dd
Il y a des messages d'erreur lorsque l'on veut mettre à jour le plugin 
Agenda 3.32.0 - stable


vers la version dispo 3.32.1 :
Impossible d’activer le plugin ../plugins/auto/agenda/v3.32.1
Utilise le plugin FULLTEXT en version ≥ 1.0.0.
Utilise le plugin CORBEILLE en version ≥ 3.1.1.
Utilise le plugin SAISIES en version ≥ 3.27.0.
Impossible d’activer le plugin 
../plugins/auto/fullcalendar_facile/v2.4.3

Nécessite le plugin AGENDA en version ≥ 3.18.4.

dd


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] [Spip-zone-commit] r117714 -_plugins_/ckeditor-spip-plugin/branches/ckeditor-4.x

2019-09-08 Par sujet Franck
Yop 

Bon alors avec un peu de retard, j’ai même demander à eric sur l’irc car tu me 
faisais avoir un doute même si ton cas aurait été unique sur la zone 

Bref, juste pour dire que non faut mettre les mêmes bornes de compatibilité 
dans paquet et plugin.xml car il s’agit du même plug !

Normalement, devrait pas y avoir de problèmes !

Franck

 

 

De : cam.la...@azerttyu.net  
Envoyé : jeudi 5 septembre 2019 12:13
À : Franck 
Cc : spip-zone ; spip 
Objet : Re: [Spip-zone-commit] r117714 
-_plugins_/ckeditor-spip-plugin/branches/ckeditor-4.x

 

Bonjour

 

Le mar. 3 sept. 2019 à 17:59, Franck mailto:spip.fra...@lien-d-amis.net> > a écrit :

Hello 
Pourquoi ne pas le mettre dans le dossier "lib" de la zone ?
https://zone.spip.net/trac/spip-zone/browser/spip-zone/_libs_

 

Car la zone n'est pas là pour héberger de l'archive. Subversion n'est pas fan 
et encore moins trac à jouer le role de proxy pour des zip.

J'aurais préféré mettre ceci sur files.spip.net   mais à 
priori ce n'est pas possible donc j'ai basculé sur contrib.

Si meilleure solution je prends.

 

En soit https://zone.spip.net/trac/spip-zone/browser/spip-zone/_libs_ me semble 
une très mauvaise pratique.

 

Sinon, je ne sais pas si tu fais bien de mettre 2.1.30 comme version mini de 
spip et non pas 3.2 pour le sad ...

 

Pas de sad :)

 

En tout cas, si tu tiens vraiment à mettre 2.1.30 comme version mini, faut que 
tu fasses des modifications dans paquets et plugin.xml
Dans paquet.xml, il faudrait mettre :

https://zone.spip.net/trac/spip-zone/browser/spip-zone/_plugins_/ckeditor-spip-plugin/branches/ckeditor-4.x/paquet.xml#L6
compatibilite="[2.1.30;3.2.*]"

et dans plugin.xml
https://zone.spip.net/trac/spip-zone/browser/spip-zone/_plugins_/ckeditor-spip-plugin/branches/ckeditor-4.x/plugin.xml#L97


 

C'est bien volontaire. On a un traitement bien distinct entre les 2 fichiers. 
plugin.xml ne peut fonctionner qu'avec spip2 tandis que paquet.xml uniquement 
avec spip3.

Leur intervalle est donc resteint à leur cas d'usage.

Il y a des contraintes de surcharge de squelettes dont jquery pour spip2 qu'on 
ne doit en aucun voir dans spip3. Le blocage au niveau des version garanti que 
cela ne se produira jamais.

 

Possible que je me sois planté dans la logique :)

 

Km


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] [Spip-zone-commit] r117771 - _plugins_/zippeur/trunk

2019-09-08 Par sujet Eric Lupinacci
Ok.

++
Eric


Le dim. 8 sept. 2019 à 11:12, Maïeul Rouquette  a écrit :

> Tu as parfaitement raison sur le fond.
> Simplement j'éais un peu pressé par le temps.
> Le dimanche 08 septembre 2019 à 11:09 +0200, Eric Lupinacci a écrit :
> > Hello,
> >
> > Je rebondis sur ce commit à propos de l'utilisation de l'API SQL.
> > La correction est l'ajout d'une quote manquante (en vert foncé autour
> > de $extension" :
> > $enbase =
> > sql_fetsel('id_zip,fichiers,date_modif','spip_zippeur',"`nom`='$nom'
> > and `extension`='$extension'");
> >
> > Je trouve que cette écriture est bien compliquée (d'ailleurs on a
> > oublié une quote) en utilisant 3 types de quotes différentes et donc
> > pas hyper maintenable surtout quand on a la possibilité d'utiliser les
> > features de l'API pour simplifier l'écriture de la façon suivante:
> >
> > $select = array('id_zip', 'fichiers', 'date_modif');
> > $where = array("nom=" . sql_quote($nom), "extension=" .
> > sql_quote($extension));
> > $enbase = sql_fetsel($select, 'spip_zippeur', $where);
> >
> > Ne devrions nous pas encourager ce type d'écriture plus maintenable à
> > mon avis et faire les modifications au fil des commits ?
> >
> >
> > ++
> > Eric
> >
> >
>
>

spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] [Spip-zone-commit] r117771 - _plugins_/zippeur/trunk

2019-09-08 Par sujet Maïeul Rouquette
Tu as parfaitement raison sur le fond. 
Simplement j'éais un peu pressé par le temps. 
Le dimanche 08 septembre 2019 à 11:09 +0200, Eric Lupinacci a écrit :
> Hello,
> 
> Je rebondis sur ce commit à propos de l'utilisation de l'API SQL.
> La correction est l'ajout d'une quote manquante (en vert foncé autour
> de $extension" :
> $enbase =
> sql_fetsel('id_zip,fichiers,date_modif','spip_zippeur',"`nom`='$nom'
> and `extension`='$extension'");
> 
> Je trouve que cette écriture est bien compliquée (d'ailleurs on a
> oublié une quote) en utilisant 3 types de quotes différentes et donc
> pas hyper maintenable surtout quand on a la possibilité d'utiliser les
> features de l'API pour simplifier l'écriture de la façon suivante:
> 
> $select = array('id_zip', 'fichiers', 'date_modif');
> $where = array("nom=" . sql_quote($nom), "extension=" .
> sql_quote($extension));
> $enbase = sql_fetsel($select, 'spip_zippeur', $where);
> 
> Ne devrions nous pas encourager ce type d'écriture plus maintenable à
> mon avis et faire les modifications au fil des commits ?
> 
> 
> ++
> Eric
> 
> 


spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone


Re: [SPIP Zone] [Spip-zone-commit] r117771 - _plugins_/zippeur/trunk

2019-09-08 Par sujet Eric Lupinacci
Hello,

Je rebondis sur ce commit à propos de l'utilisation de l'API SQL.
La correction est l'ajout d'une quote manquante (en vert foncé autour de
$extension" :
$enbase =
sql_fetsel('id_zip,fichiers,date_modif','spip_zippeur',"`nom`='$nom' and
`extension`='$extension'");

Je trouve que cette écriture est bien compliquée (d'ailleurs on a oublié
une quote) en utilisant 3 types de quotes différentes et donc pas hyper
maintenable surtout quand on a la possibilité d'utiliser les features de
l'API pour simplifier l'écriture de la façon suivante:

$select = array('id_zip', 'fichiers', 'date_modif');
$where = array("nom=" . sql_quote($nom), "extension=" .
sql_quote($extension));
$enbase = sql_fetsel($select, 'spip_zippeur', $where);

Ne devrions nous pas encourager ce type d'écriture plus maintenable à mon
avis et faire les modifications au fil des commits ?


++
Eric


Le ven. 6 sept. 2019 à 20:44,  a écrit :

> Author: mai...@maieul.net
> Date: 2019-09-06 18:43:47 + (Fri, 06 Sep 2019)
> New Revision: 117771
>
> Modified:
>_plugins_/zippeur/trunk/paquet.xml
>_plugins_/zippeur/trunk/zippeur_fonctions.php
> Log:
> quote manquante, merci Pierre K
>
>
> Details: https://zone.spip.org/trac/spip-zone/changeset/117771
>
> ___
> spip-zone-com...@rezo.net -
> https://listes.rezo.net/mailman/listinfo/spip-zone-commit
>

spip-zone@rezo.net - https://listes.rezo.net/mailman/listinfo/spip-zone