Re: [SlimDevices: SqueezeCenter] Search not working

2019-10-18 Thread dolodobendan
slartibartfast wrote: > This is getting even more strange. If I search for "brown eyes" I get 45 > results and playing "all songs" plays 11 of them. If I search for "brown > eyes pogues" I get 6 results and playing "all songs" does nothing. If I > search for "pink" I get 42 results and playing

Re: [SlimDevices: SqueezeCenter] Search not working

2019-10-17 Thread dolodobendan
mruano wrote: > 28360 Only results that have the same position (here: position 2) in both searches (shown above in the quote) will be shown in Squeeze Ctrl (for Windows, at least) with duration. Results with different positions in each search (like "13. Aria: Nell'impero...", positions 4 and

Re: [SlimDevices: SqueezeCenter] Search not working

2019-10-16 Thread dolodobendan
mherger wrote: > I can confirm there's a problem if the Fulltext Search plugin has been > enabled. In this case the search would find stuff which the simplified > link would not. > > Please file a but on https://github.com/Logitech/slimserver/issues - > thanks! > > -- > > Michael There

Re: [SlimDevices: SqueezeCenter] Search not working

2019-10-16 Thread dolodobendan
Found it in: 'Annouce-Squeeze-Control-is-now-available-as-a-UWP-app-for-Windows-10' (https://forums.slimdevices.com/showthread.php?106060-Annouce-Squeeze-Control-is-now-available-as-a-UWP-app-for-Windows-10=937532=1#post937532) And the next page. QLMS 7.9.2@2.04 x64 (digimaster) with perl

Re: [SlimDevices: SqueezeCenter] Search not working

2019-10-16 Thread dolodobendan
slartibartfast wrote: > The only strange thing I found was that the tracks are played in a > different order to the results list. > I mentioned this behavior before somewhere, maybe I'll find it again. I think it was: In the WebUI, type in the Search Field. Do not hit enter or the search

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-10-05 Thread dolodobendan
Thank you, although scanning the music files was not the problem. Everything worked except: LMS couldn't read the music files from clients' playlists (writing them with LMS was no problem). Example: - Play music with player A. - Save playlist "Test". - Restart LMS. - Player A's playlist is

Re: [SlimDevices: SqueezeCenter] Duplicate Albums

2019-09-28 Thread dolodobendan
phred wrote: > This is not turning out to be as easy as I thought it would be. > Playlists are not an issue. There's only one of each. > > It's the actual music files that are being duplicated. As stated > previously, one set is coming from Z:\ and the other is coming from > \\192.168.x.xxx.

Re: [SlimDevices: SqueezeCenter] Duplicate Albums

2019-09-27 Thread dolodobendan
phred wrote: > Ahhh ... silly me. Thanks again. > I now see what the problem is... all my music is stored on a NAS, which > is mapped to drive letter Z. One location path for each album is Z and > the other is the IP of the NAS. > > Should be easy enough to fix. And I found a great little

Re: [SlimDevices: SqueezeCenter] How can I get "All Artists" to display artists only?

2019-09-07 Thread dolodobendan
streifenleopard wrote: > Also ich weiß auch nicht so genau, ein Problem ist, dass die > Übersetzungen nicht immer nachvollziehbar sind. Ich habe das > installiert, was im zweiten Screenshot zu sehen ist. > > Hallo, doch ich habe welche, die halt manchmal eingetragen sind und > manchmal nicht.

Re: [SlimDevices: SqueezeCenter] How can I get "All Artists" to display artists only?

2019-09-06 Thread dolodobendan
artists that are not album artists but must > exclude composers or conductors etc. > streifenleopard wrote: > Ah ok, ich muss eine neue Bibliothek anlegen? Ich habe gar keine > klassische Musik. Das verstehe ich nicht. Wo kommen dann die Composers und Conductors her? Bzw., wenn Du keine ha

Re: [SlimDevices: SqueezeCenter] How can I get "All Artists" to display artists only?

2019-09-03 Thread dolodobendan
streifenleopard wrote: > Hallo, > aber ich finde unter Custom Browse keine Möglichkeit, die Einträge zu > modifizieren. Es gibt eine Node die Artists heißt, und die ist exakt > genauso wie die Standard-Interpreten. > Wenn Du alles mit Composer herausfilterst (=eine Klassik-Library, eine

Re: [SlimDevices: SqueezeCenter] How can I get "All Artists" to display artists only?

2019-09-03 Thread dolodobendan
streifenleopard wrote: > Danke, > muss ich das so einrichten? > Es will irgendwie nicht, dh es erscheint kein Menü... > 28076 Das ist ja jetzt Custom Scan. Das solltest Du für Deine Pläne nicht brauchen, es sei denn, Du möchtest Menüs von Tags erstellen, die nicht von Haus aus von LMS

Re: [SlimDevices: SqueezeCenter] How can I get "All Artists" to display artists only?

2019-08-31 Thread dolodobendan
streifenleopard wrote: > Danke, ich habs geschafft, das zu installieren, aber ich weiß nicht, wo > ich da was einstellen kann? Muss ich Skripte schreiben und die in einen > Ordner kopieren oder was? Multi Library: Web-Oberfläche. Extras / Multi Library / Create new library / Standard library

Re: [SlimDevices: SqueezeCenter] How can I get "All Artists" to display artists only?

2019-08-30 Thread dolodobendan
streifenleopard wrote: > Thanks but isn't Custom Browse something you ll have to pay for? What > Multi Library is I don't know... It was, 'but now it isn't' (https://forums.slimdevices.com/showthread.php?107707-Announce-Erlands-commercial-plugins-available-for-free). 'Multi Library '

Re: [SlimDevices: SqueezeCenter] LMS library empty after rescan

2019-08-28 Thread dolodobendan
digimaster wrote: > > What i mean, in the QNAP QTS you can make a group like music, and make > the user squeezeboxserver and the user(s) who manage the musicfile, both > part of it. > Then if those file have read/executed rights, squeezeboxserver can read > and see them, but not write or

Re: [SlimDevices: SqueezeCenter] LMS library empty after rescan

2019-08-27 Thread dolodobendan
steklo wrote: > It might turn out to be a struggle for me as well... Of course I would > have preferred all files would have come in with owner 999 and > permissions 750. Then no action would be necessary. But as some of my > files had owner 1000 I would have to work on these anyway. Changing

Re: [SlimDevices: SqueezeCenter] How can I get "All Artists" to display artists only?

2019-08-27 Thread dolodobendan
streifenleopard wrote: > Thank you for your reply. > This is what I tried but under it returns all shrewd people (i.e. > Composers etc.) too and I don't want this. Oh, you're right. I never use "All Artists" because it's just too crowded. streifenleopard wrote: > This is why I thought I'd

Re: [SlimDevices: SqueezeCenter] LMS library empty after rescan

2019-08-27 Thread dolodobendan
steklo wrote: > Last weekend I copied some new albums into the music folder my NAS. > Connecting with Cyberduck showed that all new files had permissions 750 > and owner was 999 for the larger part of them and 1000 for the rest. > Don't ask me why - all files come from the same place and get

Re: [SlimDevices: SqueezeCenter] How can I get "All Artists" to display artists only?

2019-08-26 Thread dolodobendan
streifenleopard wrote: > Hello, > I have had this problem for a while but I cannot seem to figure out how > to set up LMS. > all I want is that every artist in my collection is displayed under > "Artist" or "All Artists" or whatever might be in the menu. This must > also include artists that are

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-25 Thread dolodobendan
digimaster wrote: > Yep but it more how the script makes the needed startup line. There are > checks in the script checking the different options and values. > Feared as much. Thank you! QLMS 7.9.2@2.09.8 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-25 Thread dolodobendan
digimaster wrote: > No that won't work, could make LMS crash. > Yup, already tried that. ;) But why did it crash? --cachedir is a regular startup parameter, is it not? QLMS 7.9.2@2.09.8 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4

[SlimDevices: SqueezeCenter] LMS asks for confirmation to overwrite untitled playlist but theres no untitled.m3u

2019-08-24 Thread dolodobendan
I just saved a playlist without giving it a name ("Untitled") and I was asked if I wanted to overwrite the existing one. But there was no existing one. It really doesn't matter, but as it seems to be a bug, there you go. :p QLMS 7.9.2@2.09.8 x64 (digimaster) with perl 5.28 dedicated to me.

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-24 Thread dolodobendan
digimaster wrote: > Linux it very demanding on rights and ownership. It worked before. :p digimaster wrote: > You could make group music, where you make the share user and > squeezeboxserver part of. Then it should work as before. > Good point, I'll try that next time! For now, I'm back

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-23 Thread dolodobendan
digimaster wrote: > Permissions are very important, I already pointed that in several > messages. All my music file have 0755. And all are not owned by > squeezeboxserver but by me. On my Qnap the music files are handled by > several script. > > But 0755 is very important. I know, but: It

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-23 Thread dolodobendan
digimaster wrote: > Oké but this could be from changing the Cache/prefs directory. Lms is > very sensitive about that, if on something is different LMS won't start > or quit. > > Regarding the client Playlist, no idea and tried to reproduce it but at > my side everything works. The only thing

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-23 Thread dolodobendan
digimaster wrote: > > Regarding the client go to the prefs directory, and do cat client. > and look what it shows. I check it here, I get information about the > songs > Same here. As I said, the file is not empty, but LMS somehow cannot find the files (which worked before, that's how

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-23 Thread dolodobendan
digimaster wrote: > The PLYLSDR is for the one you set in the music setup. Has nothing to do > with the client Playlist. I was sure it rewrote the permissions for the playlists in prefs. But maybe it was I who did several things at once again and simply got confused. digimaster wrote: >

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-23 Thread dolodobendan
I removed all playlists, played something (and a new playlist was created), restarted LMS, the playlist file is still there (and not empty), but the playlist itself is empty because they file supposedly doesn't exist. QLMS 7.9.2@2.09.8 x64 (digimaster) with perl 5.28 dedicated to me. :D /

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-23 Thread dolodobendan
digimaster wrote: > For example, if in .QLMS.conf you set, > > LMS_EXTRA="--cachedir /DIR/WHERE/IT/SHOULD/SET/CACHE" > LMS_EXTRA="--prefsdir /DIR/WHERE/IT/SHOULD/SET/PREFS" > Or if you want to do both LMS_EXTRA="--cachedir > /DIR/WHERE/IT/SHOULD/SET/CACHE"" --prefsdir >

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-22 Thread dolodobendan
I set the m3u files in /share/CACHEDEV1_DATA/.qpkg/LogitechMediaServer/SlimServer/prefs to Group: everyone Owner: squeezeboxserver Octal: 0777 and disabled startup rewriting of these files in .conf. The players' playlists still appear empty when restarting QLMS. QLMS 7.9.2@2.09.8 x64

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-22 Thread dolodobendan
My players' playlists keep being displayed as empty. Did you change something regarding permissions? server.log: Code: [19-08-22 22:18:12.7837] Slim::Formats::Playlists::Base::playlistEntryIsValid (126) Warning:

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-21 Thread dolodobendan
digimaster wrote: > For example, if in .QLMS.conf you set, > > LMS_EXTRA="--cachedir /DIR/WHERE/IT/SHOULD/SET/CACHE" > LMS_EXTRA="--prefsdir /DIR/WHERE/IT/SHOULD/SET/PREFS" > Or if you want to do both LMS_EXTRA="--cachedir > /DIR/WHERE/IT/SHOULD/SET/CACHE"" --prefsdir >

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-21 Thread dolodobendan
kidstypike wrote: > Don't advise in forums when you've had a couple is my advice. And I > should know . . . Oh! :rolleyes: It was just one cocktail! I NEEDED that. And now back to the topic... Cheers! ;) QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-21 Thread dolodobendan
kidstypike wrote: > I'm not sure I understand what you're getting at. > > I've just done as I suggested, (deleted Library.db) restarted LMS, and a > scan is already running . . . finished, and look at the speed of it! > > I misread, sorry. To my defense, I was having a Harvey Wallbanger at

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-21 Thread dolodobendan
kidstypike wrote: > Oh dear, when LMS is stopped you don't see all the files. 'Not hiding file extensions' (https://www.howtogeek.com/205086/beginner-how-to-make-windows-show-file-extensions/) might also help. kidstypike wrote: > So, with LMS stopped, just delete the Library file and restart

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-21 Thread dolodobendan
digimaster wrote: > Regarding inside the SlimServer directory, some thing I got no idea. > About the question off the Cache outside the SlimServer, yes can be done > with the LMS_EXTRA option inside .QLMS.conf. There is a option for LMS > to set the Cache directory, look on the wiki for it. >

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-08-21 Thread dolodobendan
digimaster wrote: > > == QLogitechMediaServer version 2.09.08 > = 16-08-2019 I just upgraded to this version and everything seems to work as expected. However, all my players' playlists (the current ones) are empty, despite their respective m3us

Re: [SlimDevices: SqueezeCenter] LMS library empty after rescan

2019-08-21 Thread dolodobendan
d6jg wrote: > If I was running a Pi (I have) it would be much faster than the QNAP!!! > I actually use an old dual core HP Microserver with 8GB RAM and a single > SSD but the files on the NAS (a really old 4 disk/raid 5 TS419P) via > NFS. > The HP running VB2.4 is much faster (and more

Re: [SlimDevices: SqueezeCenter] LMS library empty after rescan

2019-08-21 Thread dolodobendan
d6jg wrote: > > EDIT. I have relaised you may be using QLogitechMediaServer in which > case ignore most of above. :p d6jg wrote: > > I'm afraid I don't use that, my QNAP is too old, but instead I use > another Linux PC with LMS and mount the NAS via NFS. > A common practice. Some people

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread dolodobendan
Man in a van wrote: > works for me ;) Let's solve your problems then. You are willing to follow the instructions. (Works for me, too.) QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread dolodobendan
Man in a van wrote: > > "and now, let us return to our listeners" You're right, of course. What about: Wiping the cache, clearing the logs, rescanning, trying to play the file, and then uploading (not just talking about) the logs? Or, instead of wiping the cache, reinstalling LMS. QLMS

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread dolodobendan
Man in a van wrote: > that's me chum :p bear of little brain :rolleyes::p:) I have absolutely no idea what you're saying. :o :D QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread dolodobendan
Man in a van wrote: > I don't think the OP is a troll, confuseddefinatelynot a native > English speaker I guess (which is why I refrained from "wind yer neck in > son!". I thought that would not be conducive to the old "entente > cordiale" :):)). > > I think this is the OP > >

Re: [SlimDevices: SqueezeCenter] LMS library empty after rescan

2019-08-19 Thread dolodobendan
steklo wrote: > Some of the newly added tracks had owner 999 (squeezeboxserver), some > owner 1000 (me) – none of them appeared in LMS. All of those tracks that > had been added successfully before had owner 999. If you copied all the files from the same computer and with the same user account

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread dolodobendan
kidstypike wrote: > One hour later and still nothing. > > I think I've done my bit for the cause. > > Anyone else any ideas? > > 27984 Apart from "Don't feed the troll."? No. QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4

Re: [SlimDevices: SqueezeCenter] LMS library empty after rescan

2019-08-18 Thread dolodobendan
steklo wrote: > I tried some things this afternoon. > > First I took a look at my music folder via Cyberduck (an SFTP client > available for Mac): > > I realized that for most albums the owner was set to 999, but for some - > all of them among the newly added albums I was missing, but still

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-17 Thread dolodobendan
Just zip it. QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4 dolodobendan's Profile: http://forums.slimdevices.com/member.php?userid=67663 View this thread:

Re: [SlimDevices: SqueezeCenter] Search by surname shows no albums

2019-08-17 Thread dolodobendan
slartibartfast wrote: > I don't see any albums if I search for Springsteen or Bruce. I only see > the Artist and Tracks which have Springsteen or Bruce in the name. Seems > to me the odd thing is that you do see albums that don't actually have > "Bruce" in the album name when you search for

Re: [SlimDevices: SqueezeCenter] LMS library empty after rescan

2019-08-17 Thread dolodobendan
steklo wrote: > Well, seems I was a bit too optimistically: > > Yesterday I added a number of new albums to my library and performed the > usual "delete-and-rescan" procedure. The result is that LMS shows all > albums that had been there before but none of the newly added. I > re-checked if the

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread dolodobendan
mrw wrote: > That is exactly as I remember matters working with MS-DOS. 'C:' would > pick up the system's idea of the current working directory for that > disk/partition, not its root. Um, sure, but that's true for every partition. 'cd' changes the directory only, 'x:' changes the partition

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread dolodobendan
kidstypike wrote: > That seems to have sorted the problem. > Works here, too. QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4 dolodobendan's Profile:

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread dolodobendan
Disc and Folders: Code: [19-08-16 15:38:03.8461] Slim::Control::Queries::readDirectoryQuery (2772) readDirectoryQuery [19-08-16 15:38:05.3991] Slim::Control::Queries::readDirectoryQuery (2772) readDirectoryQuery [19-08-16 15:38:05.3997]

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread dolodobendan
mherger wrote: > > Discs and Folders is per player. > > Could you please enable INFO logging for control.queries or the like, > and see what request Browse Disc And Folders is sending vs. selecting a > > folder in the settings? > Sure. I didn't know what "or the like" was, so I used

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread dolodobendan
kidstypike wrote: > Discs and Folders is per player. > > LMS Settings > Player tab > Additional Browse Modes. I always forget about the player tab. Thank you! QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread dolodobendan
mherger wrote: > > Go to the plugin's settings, where you can enable it (it's "Dateisystem" > > in the German version). Now I feel a bit stupid. Einstellungen / Plugins / "Erweiterte Musik Menüs". Clicking on "Einstellungen" on the right. There's no such thing as "Dateisystem" but "Erweiterte

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread dolodobendan
mherger wrote: > > What Windows versions are all you guys using? > Windows 10 Pro #1903 mherger wrote: > > Would browsing "Files and Folders" be working (available through the > Addditional Browse Modes plugin)? I thought I knew what you meant, but I don't. I have "Additional Browse

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread dolodobendan
mherger wrote: > > My guess is, his music is somewhere on c:. I don't have access to the > > folders on c: (they are not shown) with the Web UI either, the other > > partitions work fine. I do have access to c: with the LMS control > panel. > > LMS runs under my user account (admin rights). >

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-15 Thread dolodobendan
Paul Webster wrote: > > In any case, the fact that no-one else has reported it probably means it > is local issue to your installation. Or, people don't add new folders all the time using the Web UI. My guess is, his music is somewhere on c:. I don't have access to the folders on c: (they

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-18 Thread dolodobendan
bpa wrote: > I just played the Rachel Meadows podcast - from start to finish looking > at the timebar on the Default not Material UI. It starts with the > -46:23 time (i.e. time left to play) and then gets updated to -45:14. > It played right through the end stopping without chopping off end

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-18 Thread dolodobendan
bpa wrote: > Have you started an independent timer as well ? you can't rely on the > LMS on screen timer as it may do odd things if playing duration overuns > calculated duration. Next time... The duration in the XML file is 47:53. LMS calculated it to 46:47. It stopped at 46:26. When I

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-18 Thread dolodobendan
I just started the latest podcast (XML: 47:53, corrected to 46:47). Let's see what happens. QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4 dolodobendan's Profile:

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-17 Thread dolodobendan
bpa wrote: > I think the estimated duration is the correct method - when I play the > 45:13 URL in Chrome - it too shows 45:13. > > The XML value is plain wrong. > > The question now is understand where the other number come from. > Multiple the various duration times by 12,000 to get a byte

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-17 Thread dolodobendan
My respect. Now the playing time is 45:17 (LMS) and 45:13 (VLC). I will play the whole podcast tomorrow again. It should play to the end now, right? LMS shows 45:17 while it is 45:13. No reason to stop before it runs out of bytes? QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-17 Thread dolodobendan
bpa wrote: > Example of the issues from the NBC news feed you ref > > The XML for one item in the list. When parsing the XML it is assumed to > be playlist and the *itunes:duration* and *enclosure* are the main items > used items. Note the use of itunes tags and also *length* is zero !! > >

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-17 Thread dolodobendan
bpa wrote: > First there is no hard defined international (e.g. ISO, IEEE, IETF) > standard for management of podcasts. A lot of what is used is de-facto > and has evolved as "normal" or "usual". So many of the norms were > initially defined & used by Apple & iTunes but "extended" by others to

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-07-16 Thread dolodobendan
bpa wrote: > In the case of the BBC - there have been programmes which comment on the > news - after broadcast legal action is taken and so some items were > removed. > In other cases, a discussion talked about a topic (e.g. suicide, > terorist attack) and shortly afterwards a real similar

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-16 Thread dolodobendan
bpa wrote: > In the case of the BBC - there have been programmes which comment on the > news - after broadcast legal action is taken and so some items were > removed. > In other cases, a discussion talked about a topic (e.g. suicide, > terorist attack) and shortly afterwards a real similar

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-07-15 Thread dolodobendan
bpa wrote: > There are times depending on formats when remote streaming when duration > changes between what is told by the file header and is delivered by the > file audio contents (as file is streamed LMS doesn't get the most of the > contents until after playing has started) - with BBC

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-07-15 Thread dolodobendan
doobre wrote: > Hi there all, as the title says, I regularly listen to BBC streamed > podcasts, trouble is it will just stop at random, maybe after 50mins or > only 7mins. Pressing play again the stream starts from the beginning > again, and I must jump through to roughly where it stopped. >

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-07-15 Thread dolodobendan
bpa wrote: > > Most time no single / good solution was found as problem is often not > reproducible but provide more details such as specific program being > played, how is it "found", LMS version, player type, uk/nonuk, etc. > > I reproduce it (=streams stops one to two minutes too early)

Re: [SlimDevices: SqueezeCenter] WebUI: Custom browse menu with umlaut not accessible (but it is with Material)

2019-07-12 Thread dolodobendan
afriend wrote: > Native support for more tags, related to classical music or not, would > be nice, agreed. But my guess is that it won't probably happen anytime > soon. It appears it would take quite a lot of work and testing to set it > up with all the changes to the database and creating the

Re: [SlimDevices: SqueezeCenter] WebUI: Custom browse menu with umlaut not accessible (but it is with Material)

2019-07-11 Thread dolodobendan
afriend wrote: > -Kind of- means that there's still a quirk in the menu creation part I > need to work out. But that's only related to compilation albums showing > up on the second menu level where they shouldn't.. So nothing serious. > As for custom tags... I don't use custom tags (with my

Re: [SlimDevices: SqueezeCenter] WebUI: Custom browse menu with umlaut not accessible (but it is with Material)

2019-07-10 Thread dolodobendan
afriend wrote: > I thought CustomBrowse and MultiLibrary used utf-8 allowing for special > characters like umlauts. Anyway I stopped using CustomBrowse and > MultiLibrary (since they're no longer maintained and all) and created my > own plugin. It basically achieves what those two used to do

Re: [SlimDevices: SqueezeCenter] WebUI: Custom browse menu with umlaut not accessible (but it is with Material)

2019-06-21 Thread dolodobendan
Still a thing with the latest nightly build. I had a look at the links in Home / My Music. A comparison between the audiobook and the classical music link shows that not all necessary info makes it to the link: Code:

[SlimDevices: SqueezeCenter] WebUI: Custom browse menu with umlaut not accessible (but it is with Material)

2019-06-17 Thread dolodobendan
When I click on this menu I get an error message: Code: 404 Not Found: player=xxx[/B] I think it worked at some point. With the Material skin, I can access this menu, iPeng also has no problems. QLMS 7.9.2@2.04 x64 (digimaster) with perl

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-31 Thread dolodobendan
scala wrote: > Great, thanks! This should be a sticky post on top of the forum! Yes. QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4 dolodobendan's Profile:

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-31 Thread dolodobendan
scala wrote: > > PS: please tell me how I can make you a donation in support of the > excellent work LMS (Michael Herger): http://www.herger.net/slim/ QLMS (Digimaster): https://www.qnapclub.eu/de/qpkg/545 piCorePlayer (Paul, Greg, Ralphy and Steen): https://picoreplayer.org/ Squeezelite and

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-31 Thread dolodobendan
scala wrote: > > PS: please tell me how I can make you a donation in support of the > excellent work LMS (Michael Herger): http://www.herger.net/slim/ QLMS (Digimaster): https://www.qnapclub.eu/de/qpkg/545 Didn't find the ones for Squeezelite(-X), will add them later. QLMS 7.9.2@2.04 x64

Re: [SlimDevices: SqueezeCenter] New option to allow for correct sorting

2019-03-18 Thread dolodobendan
Blackfiction wrote: > I agree, support for OPUS, WORK and MOVEMENT would be great! OPUS and MOVEMENT would be fun, but they'd not be crucial like RECORDING. That's why I'd like to see WORK, RECORDING and one (or more) customizable tag(s). QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28

Re: [SlimDevices: SqueezeCenter] Help, LMS does not work anymore on Qnap

2019-03-17 Thread dolodobendan
karlek wrote: > But be sure, that you have QLMS offered in the QNAP-Club repository > before you remove your old LMS. It's not working now, so... :p rienm wrote: > Well, I installed the Qnap-club store..but I can’t find > QLMS.. not suited for my old NAS, I suppose... > So, I have

Re: [SlimDevices: SqueezeCenter] Help, LMS does not work anymore on Qnap

2019-03-16 Thread dolodobendan
rienm wrote: > > What can I do? Remove LMS & SSOTS and install 'QLMS' (https://forums.slimdevices.com/showthread.php?108702-QLogitechMediaServer-for-Qnap-with-QTS-4-2-or-higher-and-x86_64-I686-X86-support-!). QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L

Re: [SlimDevices: SqueezeCenter] New option to allow for correct sorting

2019-03-16 Thread dolodobendan
Shozzer wrote: > classical music presents particular challenges. We'd need three more tags for that. WORK, RECORDING and something customizable, I use OCCASION. And menus would need to one to two more levels. With pop music it's 1. ARTIST / 2. ALBUM. Here you'd need 1. COMPOSER / 2. WORK / 3.

Re: [SlimDevices: SqueezeCenter] New Layout?

2019-03-12 Thread dolodobendan
kidstypike wrote: > Hackers can (and do) change your skin just for kicks. Or bored regular people. QLMS 7.9.2@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4 dolodobendan's Profile:

Re: [SlimDevices: SqueezeCenter] Advanced Search: Artist (composer) does not contain comma

2019-03-06 Thread dolodobendan
mherger wrote: > > ',%', '% ,%', '2', '1' > > I guess you configured LMS to only search at the beginning of words, but > > not in words. Thus only "lastname, firstname" would not match, as it's > looking for "lastname ,firstname" (see the space?). You'd have to tell > LMS to search in

Re: [SlimDevices: SqueezeCenter] Advanced Search: Artist (composer) does not contain comma

2019-03-06 Thread dolodobendan
mherger wrote: > > Instead of some albums, I get a lot albums, maybe even all, that > don't > > match the search parameters. What am I missing here? > > Enable the database.sql logging to see what SQL results from your > search. > > -- > > Michael This is the search: Code:

[SlimDevices: SqueezeCenter] Advanced Search: Artist (composer) does not contain comma

2019-03-05 Thread dolodobendan
I tried to find all tracks with composers that have no "," in the composer tag using the advanced search. No comma means that I most certainly entered the composer's name "First Name Last Name" instead of "Last Name, First Name", so there's your back story. :) That's what I did: 26896 Search

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-03 Thread dolodobendan
digimaster wrote: > Oké nice that with 2.04.00 it works. Gone leave it as is. > > A tip all the entries which can be 0 or 1 in the .QLMS.conf, you also > set by donning touch .(option name) in the .qpkg/LogitehMediaServer > directory. For example .NOIMAGE will set LMS not scan images, .NOVIDEO

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
Everything works fine here. No procs needed: Here's .QLMS.conf and the folder of QLMS: 26876 26877 +---+ |Filename: QLMS2.png| |Download:

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
Started the #501 station: Code: [19-03-02 17:01:20.2000] main::init (387) Starting Logitech Media Server (v7.9.2, 1550612824, Tue Feb 19 23:22:28 CET 2019) perl 5.028001 - x86_64-linux-thread-multi [19-03-02 17:01:23.7417]

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
digimaster wrote: > Keep in mind the line before a error is mostly the thing causing it. > Send from my mobile Phone Yes, but in this case I could have this temp writing error without the #501 error and vice versa. In my book that's a good sign that it's not correlated. I think that it's

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
digimaster wrote: > Oke here is the test version. > If there is a file called .PROC in the .qpkg/LogitechMediaServer > directory, /proc will be R/W ( like in version 2.03.31 ) > If you remove it, and restart, /proc will be read like of version > 2.03.35. > You could also do this, by adding a

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
digimaster wrote: > Oké but in the log still the error on file nor found. Keep in mind that > the proc has to be done before starting lms. Every stop removes it. > > Gone make a test version, so we can be sure. > > Send from my mobile Phone Ok, wait a second. QLMS 7.9.2@2.03.31 x64

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
I made backups of cache & prefs, uninstalled QLMS completely and installed the latest (2.04) version. Looks good! Tested with both perl 5.024 and 5.28: Code: [19-03-02 14:36:04.2801] MAIN::INIT (387) STARTING LOGITECH MEDIA SERVER (V7.9.2, 1550612824, TUE FEB 19

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
digimaster wrote: > The difference between 2.03.31 and 2.03.35 > Is that /proc and /sys went from read and write to read only. > > And thats should not be a problem occurding to me. > You could try in ssh shell, stop LMS. > mkdir -m 0755 >

Re: [SlimDevices: SqueezeCenter] LogitechMediaServer for Qnap x86_64 with qts 4.2 or higher

2019-03-02 Thread dolodobendan
digimaster wrote: > Oké then it has some thing to do with perl 5.28. Strange one should > think works the same. > > Send from my mobile Phone He didn't say he already tested it. Playing of Radio Paradise AAC 320/128: Works fine with v.2.03.31 & perl 5.28. Now trying ~40 & perl 5.024 & 5.28

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
digimaster wrote: > Suggestion have a good look at the log, and look for the entry before a > error, mostly that what causing the error. In the log it says missing a > file, command. > > The same with the radio stream, it's gives a bit implemented yet. Try > the perl 5.24, another hat trouble

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-02 Thread dolodobendan
digimaster wrote: > Look at your trouble. > It does not lays in LMS > But in the plugin CostumScan > The error > SlimServer/Cache/InstalledPlugins/Plugins/CustomScan/SQL/dbupgrade_valuesort.sql > No such file or directory > Its trying to write some thing, which it cant, and then trieds to do

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-01 Thread dolodobendan
Or maybe I just don't know what triggers the problem: Code: [19-03-01 20:01:39.1953] main::init (387) Starting Logitech Media Server (v7.9.2, 1550612824, Tue Feb 19 23:22:28 CET 2019) perl 5.028001 - x86_64-linux-thread-multi [19-03-01 20:01:42.7103]

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-01 Thread dolodobendan
digimaster wrote: > The only way it wont be triggered, after deleting .INSTALLED is, when > you have Update and Nightly updated disabled, and use the restart > command. I stopped QLMS, deleted .INSTALLED and restarted QLMS. Update and Nightly were both enabled. QLMS 7.9.2@2.03.31 x64

Re: [SlimDevices: SqueezeCenter] QLogitechMediaServer for Qnap with QTS 4.2 or higher and x86_64/I686/X86 support !

2019-03-01 Thread dolodobendan
digimaster wrote: > Oke nice thats it work. > And yes gone keep the temp directory in. > Tip to get a clean installion, do backup which will only backup the > settings from Cache, prefs and the .QLMS.conf file. > Also it will backup the .MusicIP/MusiMagic directory. > Then if you want to be

  1   2   3   4   >