Re: [SlimDevices: SqueezeCenter] Logitech Media Server 7.9.0 is out!

2018-02-06 Thread mrw
mherger wrote: > >> https://github.com/Logitech/slimserver/tree/public/7.9/CPAN/arch > > > > This is perl 5, version 24, subversion 1 (v5.24.1) built for > > arm-linux-gnueabi-thread-multi-64int > > (with 75 registered patches, see perl -V for more detail) > > If you check above link you'll

Re: [SlimDevices: SqueezeCenter] Logitech Media Server 7.9.0 is out!

2018-02-18 Thread mrw
mherger wrote: > > Hmm... might be a legacy from before Andy wrote Image::Scale. > Thanks. That was my thought. mrw's Profile: http://forums.slimdevices.com/member.php?userid=38299 View this thread:

Re: [SlimDevices: SqueezeCenter] Logitech Media Server 7.9.0 is out!

2018-02-18 Thread mrw
mherger wrote: > > The packages already have huge overhead... and armel isn't that popular > any more. > > Have you tried building yourself? It's not too difficult. Takes some > patience, though... > > -- > > Michael Thanks for your response, understood. With some application of

Re: [SlimDevices: SqueezeCenter] Does LMS use IPv6 at all?

2019-04-02 Thread mrw
Owen Smith wrote: > What is that line doing with "tunein" in it This seems to cover it: https://github.com/Logitech/slimserver/commit/7420d4cb356056e557824236fb9a71ba5167e741 The code in question is only executed if there's nothing in cache, and the lookup failed. Motivation in the attached

Re: [SlimDevices: SqueezeCenter] Does LMS use IPv6 at all?

2019-04-03 Thread mrw
Owen Smith wrote: > It does mean that if the occasional DNS lookup fails after an LMS cache > entry has timed out this code could make matters worse. While making matters better ! I have never (knowingly) experienced the issue, and can't add anything of value. The actual bug report referred

Re: [SlimDevices: SqueezeCenter] Does LMS use IPv6 at all?

2019-04-04 Thread mrw
Owen Smith wrote: > I changed my broadband router and I'm debugging multiple problems. I'm > using my FM tuner for Classic FM to avoid this one so it is low > priority. I may still end up going back to my old router, gigabit PPPoE > and working IPv6 suddenly don't seem as important as they did

Re: [SlimDevices: SqueezeCenter] Does LMS use IPv6 at all?

2019-04-04 Thread mrw
Owen Smith wrote: > I'm on G.Fast with 160 megabits down 49.94 megabits up (literally those > are the sync speeds) with a G.Fast PPPoE modem, As a matter of interest, who is your provider ? mrw's Profile:

Re: [SlimDevices: SqueezeCenter] Does LMS use IPv6 at all?

2019-04-05 Thread mrw
Owen Smith wrote: > Andrews & Arnold https://www.aa.net.uk > > Not cheap, in fact quite expensive. But worth it. Tech support by email > or IRC or whatever you want. Shibboleet compliant. I once queried > something about the encoding of the emails they sent out, and tech > support replied with

Re: [SlimDevices: SqueezeCenter] Does LMS use IPv6 at all?

2019-04-08 Thread mrw
Owen Smith wrote: > How does the protocol used for Classic FM on radiotime work? It is > clearly very different to DASH in the iPlayer plugin. Before I turned up > the NAT session pools size per IP, Classic FM dropped out every couple > of minutes whereas iPlayer was completely solid (and

Re: [SlimDevices: SqueezeCenter] Troubleshooting Podcast Halting Error

2019-02-20 Thread mrw
While idly gazing out of the window, I've just played this on a Squeezeplay desktop with Wireshark in the background. The remote server issued a very final looking "FIN" after transmitting about 7.1M bytes of data in a period of 3 minutes. Play time was worth about 7 minutes, and the player

Re: [SlimDevices: SqueezeCenter] Does LMS use IPv6 at all?

2019-04-11 Thread mrw
Owen Smith wrote: > So what is there about the Classic FM traffic that I can use to trigger > QoS? I guess it needs to be either from or to a well know port and/or IP > address. If the ports are known I could use them but I have no idea what > they are. I can use the IP address of the Receiver

Re: [SlimDevices: SqueezeCenter] Does LMS use IPv6 at all?

2019-04-08 Thread mrw
Owen Smith wrote: > Or is there some periodic outgoing traffic which keeps the fetch going? There would be a continuous 'stream' of acknowledgement packets sent out by the player to the server as each packet is received, despite there being only one initial 'GET' request. At least that's my

Re: [SlimDevices: SqueezeCenter] Tunein Radio options missing in Web GUI

2019-07-03 Thread mrw
I have noticed for some years that a playing URL/track as understood by the web GUI is not necessarily the same as a playing URL/track as understood by a Squeezeplay/Jive based player. Essentially, the web GUI seems to look at what I might call a 'resolved' url/track/playlist object, that is

Re: [SlimDevices: SqueezeCenter] Tunein Radio options missing in Web GUI

2019-07-03 Thread mrw
bpa wrote: > I'm not sure how Squeezeplay handles the issue I would need to look in detail to confirm. bpa wrote: > > I'm not sure which part of BBCiPlayer plugin is being referenced but I > know Triode made effort to hide the playing URL (e.g. DASH, HLS or MP3) > to make the "iplayer" URL

Re: [SlimDevices: SqueezeCenter] Tunein Radio options missing in Web GUI

2019-07-03 Thread mrw
bpa wrote: > With "YLE Klassinen" which has WMA and HLS - there is no problem. I was > toggling between players and one was not capable of WMA and the HLS > stream is 256kbps same as WMA not 64kbps as reported by Tune-in so I got > confused. > Thank you. I didn't see the problem as you

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-07-15 Thread mrw
doobre wrote: > Hi there all, as the title says, I regularly listen to BBC streamed > podcasts, trouble is it will just stop at random, maybe after 50mins or > only 7mins. Pressing play again the stream starts from the beginning > again, and I must jump through to roughly where it stopped. Any

Re: [SlimDevices: SqueezeCenter] Unable to reach LMS web gui after fresh installation

2019-08-12 Thread mrw
bvrulez wrote: > As I said above I am running 7.9.2 nightly now and it is fine but it > would be interesting to know why the stable version of 7.9.1 did crash > this way. Raspbian Buster will be using Perl v5.28, I think. (Verify that assertion with -perl -v-). Support for Perl v5.28 is not

Re: [SlimDevices: SqueezeCenter] LMS web interface keeps becoming unresponsive on Debian 10

2019-08-12 Thread mrw
Probably off target, but: Is this the first time that Debian x86-64 has seen Audio::Scan v1.02 ? Debian Buster is perl v5.28. Previous Debian has perl v5.24. I don't think Audio::Scan v1.02 made it to x86-64 perl v5.24. i386 and various arms seemed to get it, but not x86-64.

Re: [SlimDevices: SqueezeCenter] Plugins updating unexpectedly

2019-08-14 Thread mrw
slartibartfast wrote: > Is that expected behaviour? It seems to ignore the checkbox completely. I confirm your observation. My, possibly flawed, memory of this is that this is unexpected behaviour. mrw's Profile:

Re: [SlimDevices: SqueezeCenter] Can't choose (add) library folders

2019-08-16 Thread mrw
mherger wrote: > But turns out that > some combinations of them would not return the root folder when opening > > "c:", but the "current folder" on that drive. Eg. imagine LMS is running > > from "c:\program files\squeezebox". If it now asked for files in "C:", > it would get the list of

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread mrw
kidstypike wrote: > Anyone else any ideas? Well, you could have a listen to John Adams "Short Ride in a Fast Machine" courtesy of @JohnB. Rather fun, I haven't heard it before. Or you could take advantage of the fact that it is not raining to go and pick up your next prescription of pills.

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread mrw
carlmart wrote: > I think I provided some hints when I downloaded the file that was sent > for me to download, and I clearly specified that the cue file included > didn't work on my LMS setup. This might be quite similar. I assume that you mean the file that was provided earlier by @JohnB, and

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread mrw
carlmart wrote: > What would be the point of that? To firmly rule in or out your Windows based LMS installation as being the culprit. carlmart wrote: > > My server for now is my PC, but I will assemble another one, that I > already have the parts of, with an Asus mobo and Intel CPU, with

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread mrw
carlmart wrote: > But shouldn't I mention that that absolutely none of the cue files works > in my whole album collection? It's impossible for all the cue files to > be wrong. Right and wrong are rather binary terms ! It does suggest that there might be some consistent issue that arises with

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-19 Thread mrw
slartibartfast wrote: > I suspect if it works on your system but not on Calmart's then it will > work on everyone else's, which suggests that the files themselves are > not the issue. Agree, because it worked fine on my armel based Debian system. The generated command line was identical,

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-21 Thread mrw
carlmart wrote: > Now another question about LMS, and Jivelite too: is there a control > button to advance to the following track and go back to the track > before? Apparently not, just asking. Yes, but I'm not going to add to your and my confusion by trying to show you where it is. I shall

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-21 Thread mrw
carlmart wrote: > When I get to install my Linux server system I will come back to this > forum to get LMS to work with the Linux server. Just make sure that you learn how to operate the Linux server first. Get the feel of how to use the 'command line', how files can be edited, what 'file

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-21 Thread mrw
bpa wrote: > My own preference would be to use strtod_l and then make sure it only > uses the "C" locale - using strtod with different untested locales may > still have surprises. > > Windows Flac.exe was built with VS so I'm trying to setup it up so I can > rebuild flac with extra message to

Re: [SlimDevices: SqueezeCenter] "Cannot allocate memory" error

2019-08-21 Thread mrw
SpiderJon wrote: > When trying to play some types of radio stream (specifically, those from > the BBC iPlayer plugin), I get the error > > Slim::Control::Request::execute (1888) Error: While trying to run > function coderef [Slim::Control::Commands::playlistJumpCommand]: [open2: > fork failed:

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
bpa wrote: > It seems the 3rd party support application flac.exe uses Windows locale > when parsing the time in the skip parameter > > The fractional part (i.e. .06) of the time value of "--skip=29:04.06" > may be valid for some locales but not for others. > > However according to this bug

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
Well, here are my findings on a linux box: Running LMS with LANG=pt_BR.UTF-8, I seem to have @calmart's problem. The cue file (@JohnB's offering) won't play. LMS does seem to use 'full stop' regardless of the environment, and flac fails as @reinholdk describes. I can fix that modifying the

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
bpa wrote: > > There is some attempt to be locale independent. I saw that. And I have no idea what it seeks to achieve ! mrw's Profile: http://forums.slimdevices.com/member.php?userid=38299 View this thread:

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
bpa wrote: > Looking through flac code - the parsing of skip & until time does not > seem to have a locale dependency - the fractional part can be either a > comma or a dot. > So it is not clear what effect mrw has found with LOCALE > C++ -strtod- is doing the conv

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
mrw wrote: > I saw that. And I have no idea what it seeks to achieve ! Now I do. It sets the locale to the environment settings on non-Windows, and perhaps, or perhaps not, on Windows. http://www.cplusplus.com/reference/clocale/setloc

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
reinholdk wrote: > > It's not a command line length issue, because up to 8191 characters are > allowed. Worth trying the latest sox.exe & flac.exe (from the current Windows LMS installer) on the Win 7 box ? mrw's

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
carlmart wrote: > 1) There might be someone that can adapt this to LMS on Windows. I don't know enough about Windows to know whether something along the lines of my 'fix' could work. I have my doubts, I don't know why. carlmart wrote: > 2) In my final system I will have to install LMS on the

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-22 Thread mrw
ralphy wrote: > I've applied your patch to the source tree (vs2008) I used to build the > flac.exe that's currently provided with LMS and rebuilt it. > > It's 'available here' > (https://sourceforge.net/projects/lmsclients/files/utility/flac/flac-nolocale-win32.zip/download). > > > > I

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-22 Thread mrw
bpa wrote: > My own preference would be to use strtod_l and then make sure it only > uses the "C" locale - using strtod with different untested locales may > still have surprises. > > Windows Flac.exe was built with VS so I'm trying to setup it up so I can > rebuild flac with extra message to

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-22 Thread mrw
bpa wrote: > The trouble with my different patch using strtod_l is that Win32 doesn't > follow the C standard lib and so to create a patch that compiles OK I > had to get Vs2019 working - which I eventually did. I think I have now have a patch that would work. Will upload when done. Let me

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
carlmart wrote: > So it seems there's no apparent solution in the distance. I don't think we've seen the result of the tests suggested by @JohnB whose purpose is to verify that the pipeline commands were working as expected, when executed from the command line. That may help narrow down the

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
carlmart wrote: > So it seems there's no apparent solution in the distance. Remind us: Which version of Logitech Media Server are you using ? Many of us will be using the latest and greatest "nightly" builds available here: http://downloads.slimdevices.com/nightly/index.php?ver=7.9

Re: [SlimDevices: SqueezeCenter] Web Interface not updating to reflect working plugins.

2019-08-20 Thread mrw
mherger wrote: > > It did contain £ > > Would it work without this one? > > And sticking strictly with ASCII characters can sometimes help curiously configured servers. :) mrw's Profile:

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-20 Thread mrw
reinholdk wrote: > I think it's a typo in the command line given by JohnB. At the end of > the command the arguments for sox.exe are given as > Code: > > -q -t flac - -t flac -C 0 "C:\Musica\Test.flac" > > > I've no knowledge about sox but assume

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-23 Thread mrw
I've posted an issue report on the slimserver github as a kick off to get the problem fixed: -flac - seeking within files doesn't function in many locales, and breaks playback-: https://github.com/Logitech/slimserver/issues/277 If I got anything wrong or incomplete, my apologies. Please

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-23 Thread mrw
ralphy wrote: > A patch3 win32 build is 'available here' > (https://sourceforge.net/projects/lmsclients/files/utility/flac/flac-patch3-win32.zip/download). > > Runs on XP and newer versions of windows. Thank you, Ralphy. Worked successfully on my wine / windows setup, in that only '.' would

Re: [SlimDevices: SqueezeCenter] LMS server dies at stratup

2019-08-25 Thread mrw
One reason known to me is that the log file cannot be written to, or its directory doesn't exist, or somesuch. That might be worth checking, although it seems unlikely to be the cause if all you did was a simple upgrade.

Re: [SlimDevices: SqueezeCenter] Multiple files per cue sheet

2019-08-23 Thread mrw
RobbH wrote: > assigning the same track(s) to multiple albums Exactly what I decided to do with a John Coltrane Giant Steps re-release last week, and failed for the same reason. Playlists don’t do it for me. I did look at the cue sheet parser earlier this week, and felt that it could probably

Re: [SlimDevices: SqueezeCenter] Players losing connection to LMS?

2019-08-21 Thread mrw
slartibartfast wrote: > Anyone? No ! There may be something on the Radio, but I've never looked. On the very few occasions this has happened to me I've done much as you have, or restarted the radio. I've put it down to quirkiness around DHCP lease renewal. But it happens so rarely that I have

Re: [SlimDevices: SqueezeCenter] Players losing connection to LMS?

2019-08-21 Thread mrw
slartibartfast wrote: > Now Red can mean anything. But it doesn't confuse the users... mrw's Profile: http://forums.slimdevices.com/member.php?userid=38299 View this thread:

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-21 Thread mrw
bpa wrote: > The patch approach means it is easier to keep in step with official > releases of the flac utility. I've drafted up a patch to flac, and have attached it for any one interested. I'm no programmer, so any comments welcome before I take it further. It appears to be working

Re: [SlimDevices: SqueezeCenter] Local 'ogg flac' stream no longer plays after update to latest 7.9.2 nightly.

2019-08-27 Thread mrw
vinnielo wrote: > Is there way to allow LMS to parse certain playlist files containing Ogg > FLAC streams? > PLS and M3U. > > Two examples: > Absolute Radio > http://network.absoluteradio.co.uk/core/audio/oggflac/live.pls?service=ar > Mellow Magic

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-22 Thread mrw
bpa wrote: > I've built a Windows version of 2nd patch and test gave same result as > above when the equivalent 4 combinations of "Decimal symbol" and > "Digital Grouping symbol" are tested. Goodness me ! Did I get it right ?

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-22 Thread mrw
bpa wrote: > As expected the Control Panel / Region and language / Additional > Setting/Numbers - "Decimal symbol" and "Digital Grouping symbol" make > the difference and take effect immediately. Sounds promising. I've made a third patch, attached. The approach here is to simply force flac to

Re: [SlimDevices: SqueezeCenter] Playing cue files with LMS

2019-08-21 Thread mrw
bpa wrote: > I haven't been able to reproiduce the prpoblem. Trying to install PT_BR > locale on my ubuntu has failed - not sure why. > Adding -pt_BR.UTF-8 UTF-8- to the bottom of -/etc/locale.gen-, and then running -locale-gen- is all I needed to do on my debian box. Not something I do

Re: [SlimDevices: SqueezeCenter] Question / Problem regarding Picture of Radio Station / Podcast

2019-09-13 Thread mrw
slimhase wrote: > If it would just stay with the image from the xml, all would be good > (for these podcasts; there are probably other ones, which are > implemented correctly) That presupposes that we can all agree on ‘correct’ behaviour. The publisher may have a different context in mind.

Re: [SlimDevices: SqueezeCenter] Question / Problem regarding Picture of Radio Station / Podcast

2019-09-12 Thread mrw
slimhase wrote: > Hi Michael; > I have the following 'problem': > PS: Is it usual in Germany to dye the wool before it's taken off the sheep ? Great time saver. :) mrw's Profile:

Re: [SlimDevices: SqueezeCenter] Question / Problem regarding Picture of Radio Station / Podcast

2019-09-12 Thread mrw
slimhase wrote: > Hi Michael; > I have the following 'problem': > When I look at i.e. a podcast list, each podcast has its own unique icon > / image. > But when I select one podcast from the list and go to the now playing > screen (i.e. material skin, but also std skin), it briefly shows the >

Re: [SlimDevices: SqueezeCenter] LMS Bad (?) Install on armel debian

2019-09-18 Thread mrw
mikeh49 wrote: > Good suggestions, unfortunately don't work. I had already tried quotes, > here's the escape attempt: This works fine for me: Code: dpkg -r logitechmediaserver

Re: [SlimDevices: SqueezeCenter] LMS Bad (?) Install on armel debian

2019-09-18 Thread mrw
mikeh49 wrote: > AFAIK, the 5.28 arm build supplied in the package is for armhf, e.g., > rPi. Correct. mikeh49 wrote: > I need it for armel I've pushed a commit with the binaries I have built to a forked LMS, under a branch -my_feature/armel_5.28_binaries-. You should be able to retrieve

Re: [SlimDevices: SqueezeCenter] LMS Bad (?) Install on armel debian

2019-09-18 Thread mrw
mikeh49 wrote: > I think the stuff in the CPAN 5.28 sub directories is wreckage from my > attempt to build the CPAN modules for Perl 5.28. I am 99.9% certain that you are right. I would expect you to find therein the sub-folders + files that you put in there, and that are not part of the Debian

Re: [SlimDevices: SqueezeCenter] LMS Bad (?) Install on armel debian

2019-09-18 Thread mrw
mikeh49 wrote: > @mwr - Thanks, got them will try with a new install. I really don't know what issues you are having. The first paragraph or two of this thread shows how I install an LMS 'deb' package from the command line, using -apt-.

Re: [SlimDevices: SqueezeCenter] LMS Bad (?) Install on armel debian

2019-09-18 Thread mrw
mherger wrote: > You could add that link to > https://github.com/Logitech/slimserver/issues/269 ;-) > Why didn't I think of that ! Duly linked: https://github.com/Logitech/slimserver/issues/269#issuecomment-532895009

Re: [SlimDevices: SqueezeCenter] LMS Bad (?) Install on armel debian

2019-09-19 Thread mrw
Well done ! Looks like a nice device. mikeh49 wrote: > I don't understand the install where it says the home directory > /usr/share/squeezeboxserver was not created. It was. It probably already existed, hence not created because no need...

Re: [SlimDevices: SqueezeCenter] Upgraded to 7.9.2. Library/My Music won't play any music.

2019-07-20 Thread mrw
SlimChances wrote: > I wonder if it would help to delete your cache file. On macOS this should be available on the 'Advanced' tab on the 'Logitech Media Server' item in System Preferences. mrw's Profile:

Re: [SlimDevices: SqueezeCenter] Podcasts stop before they're supposed to end

2019-07-18 Thread mrw
bpa wrote: > All pointing to a sloppy standard and a sloppy feed. There have been a few examples of a few 'sloppy feeds' over the last twelve months or so, hence some of the relatively recent changes. And there is also the possibility of an 'Atom' feed.

Re: [SlimDevices: SqueezeCenter] LMS web interface keeps becoming unresponsive on Debian 10

2019-07-25 Thread mrw
bpa wrote: > Also check your OpenSSL libraries are up to date Also, make sure that you have the -ca-certificates- package installed. It provides root certificates for verifying secure SSL/TLS connections. You almost certainly do, but it is worth checking, as an absence of root certificates

Re: [SlimDevices: SqueezeCenter] LMS Bad (?) Install on armel debian

2019-09-20 Thread mrw
mikeh49 wrote: > Interesting. So the deb package installer will leave the > CPAN/5.28/arch/armel directory in place while replacing (or not) the > other arch directories. Yes. To be precise, the -CPAN/arch/5.28/arm-linux-gnueabi-thread-multi-64int- directory. This particular sub-tree simply

Re: [SlimDevices: SqueezeCenter] LMS Bad (?) Install on armel debian

2019-09-20 Thread mrw
mikeh49 wrote: > Will the armel perl modules be picked up in a future 7.9.2 nightly? I suggest that you assume not. The binaries only benefit a handful of users. But, once installed, the binaries do not conflict with the regular LMS debian package, so you should be able to update LMS without

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-10-19 Thread mrw
Might the ancient -BashPodder-, or something similar, assist your podcatching ? I believe it might generate a playlist. mrw's Profile: http://forums.slimdevices.com/member.php?userid=38299 View this thread:

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-10-17 Thread mrw
bigcookie wrote: > Is there a chance to introduce caching in the 3rd party podcast > application? So it caches and the server doesnt need to keep the stream > open My guess is "only with disproportionate effort". One would not only need to download and cache, but also maintain the cache...

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-10-17 Thread mrw
bigcookie wrote: > Not sure if this helps - I thought it might be useful to share. Well, on a whim I subscribed to the podcast and played out the episode that you referenced (the latest one). Although I did not understand the content of Herr Steingart's briefing, he continued to brief me

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-10-17 Thread mrw
mrw wrote: > he continued to brief me through my Squeezebox Classic without a hitch, > for the full duration of the episode. Well, an update. I have now repeated the process, on the current and an earlier episode, and am now experiencing the same issue as -bigcookie-, that is, pl

Re: [SlimDevices: SqueezeCenter] podcasts just stop at random

2019-11-02 Thread mrw
bigcookie wrote: > Attached the script and conf file. Good work ! I'll keep it by me in case I should become similarly afflicted. mrw's Profile: http://forums.slimdevices.com/member.php?userid=38299 View this thread:

Re: [SlimDevices: SqueezeCenter] No network and apps not listing in LMS but are available from squeezelite player

2019-11-13 Thread mrw
Learnincurve wrote: > Thanks. > > Trying that: > [19-11-13 20:02:06.2725] Slim::Networking::Repositories::__ANON__ (146) > Failed to fetch > https://bpa-code.github.io/bpaplugins/files/betarelease-repo.xml: 404 > Not Found > Try *https://bpa-code.github.io/bpaplugins/betarelease-repo.xml*

Re: [SlimDevices: SqueezeCenter] Radio Paradise hickups still ongoing, solution?

2019-11-13 Thread mrw
Ron F. wrote: > OKay... > > Things have changed. I don't know if this is related or not, but I > updated LMS to the latest commit, 5862496f..., Nov 13, and now the RP > FLAC Interactive streams no longer work at all. The FLAC Regular streams > play, but with zero metadata. I will have to

Re: [SlimDevices: SqueezeCenter] Radio Paradise hickups still ongoing, solution?

2019-11-13 Thread mrw
mrw wrote: > The latest commit, 5862496f, touches oggflac. > https://github.com/Logitech/slimserver/pull/290/commits/dafc93c559a150296a3c45af4d8619158ccbdf97 > > I can't see why it would impact, but as a first step, could you rule it > out (or in) by removing the

Re: [SlimDevices: SqueezeCenter] Local 'ogg flac' stream no longer plays after update to latest 7.9.2 nightly.

2019-11-13 Thread mrw
vinnielo wrote: > Is there way to allow LMS to parse certain playlist files containing Ogg > FLAC streams? > PLS and M3U. > Fixed in latest LMS. The required entry has now been placed into -types.conf-. Commit:

Re: [SlimDevices: SqueezeCenter] LMS dying and restarting every 5 secs (7.9.2, Debian 10 i386)

2019-11-17 Thread mrw
I found no need to specify the architecture, it uses the platform architecture. I don't know if there are any intel wrinkles to that, though. I made up the attached 'dummy' package, which depends on all the build package requirements. Helps with installing the build dependencies, and clearing

Re: [SlimDevices: SqueezeCenter] LMS dying and restarting every 5 secs (7.9.2, Debian 10 i386)

2019-11-17 Thread mrw
I built on Debian 10, Perl 5.28 for another unsupported architecture, Debian’s armel, without issue. The script found my installed Perl, which was 5.28, without fuss. Singling out the build products you want is slightly gnarly, only the binaries, basically, plus one other. I posted my armel

Re: [SlimDevices: SqueezeCenter] No network and apps not listing in LMS but are available from squeezelite player

2019-11-17 Thread mrw
Ron F. wrote: > PERL modules could now find where the certificates are kept on Ubuntu: > /etc/ssl/certs. > > Why this became necessary I still do not understand and I don't know > what the normal mechanism is that PERL uses to find ca-certificates, but > this stopgap measure has taken care of

Re: [SlimDevices: SqueezeCenter] LMS dying and restarting every 5 secs (7.9.2, Debian 10 i386)

2019-11-17 Thread mrw
Perl would be 5.28. I don't see any i386 binaries for perl 5.28 in LMS. That would explain the failure. Perl 5.24 is supported (Debian 9, I think). mrw's Profile: http://forums.slimdevices.com/member.php?userid=38299

Re: [SlimDevices: SqueezeCenter] LMS dying and restarting every 5 secs (7.9.2, Debian 10 i386)

2019-11-17 Thread mrw
mrw wrote: > Perl would be 5.28. > > I don't see any i386 binaries for perl 5.28 in LMS. That would explain > the failure. Perl 5.24 is supported (Debian 9, I think). More info here, I think. https://github.com/Logitech/slimserve

Re: [SlimDevices: SqueezeCenter] Unable to reach LMS web gui after fresh installation

2019-11-18 Thread mrw
Shellness wrote: > > Code: > > echo 2 >/proc/sys/abi/cp15_barrier > > Any idea why I have needed to enter it again? I don't think I have > upgraded the OS in that time (I have updated LMS at every > opportunity). Should I set up a cron job that

Re: [SlimDevices: SqueezeCenter] No network and apps not listing in LMS but are available from squeezelite player

2019-11-14 Thread mrw
Ron F. wrote: > OK, I did that, here is what was returned: Is the package -ca-certificates- installed ? Absence, or breakage, would cause that error. Or -ca-certificates- just needs updating ? Edit: crossed with @bpa.

Re: [SlimDevices: SqueezeCenter] Local 'ogg flac' stream no longer plays after update to latest 7.9.2 nightly.

2019-11-14 Thread mrw
vinnielo wrote: > Thanks. Sadly, Bauer have now pulled their Ogg FLAC streams. [emoji24] > I noticed that, too, and share your pain ! But at least LMS can now handle this type of stream in future, should it ever gain traction...

Re: [SlimDevices: SqueezeCenter] Radio Paradise hickups still ongoing, solution?

2019-11-14 Thread mrw
d6jg wrote: > Regular is continuous - a normal Internet Radio stream > Interactive allows you to jump tracks - it receives RP in about 20 > minute chunks and allows you to skip tracks inside that chunk if you > don't like it. Thanks @philippe_44 and @d6jg for putting me on track.