RE: FormBean question...

2003-09-16 Thread Mainguy, Mike
This is by design. If you want to ensure this will not happen, you need to set all the values to or null beforehand for fields that should be empty. The short answer is change the field name. Especially if you are going to store data in a form in the session you will have a big mess on your

RE: FormBean question...

2003-09-16 Thread alanbrown
PROTECTED] Sent: Tuesday, September 16, 2003 4:35 AM To: 'Struts Users Mailing List' Subject: RE: FormBean question... This is by design. If you want to ensure this will not happen, you need to set all the values to or null beforehand for fields that should be empty. The short answer is change

RE: FormBean question...

2003-09-16 Thread alanbrown
: alanbrown [mailto:[EMAIL PROTECTED] Sent: Wednesday, July 16, 2003 10:55 AM To: 'Struts Users Mailing List' Subject: RE: FormBean question... Really? That seems strange. I thought that the reason we name the formbean in the strutsconfig file is so struts knows which bean it is using to populate

RE: [FormBean] Question concerning memory / casting

2002-09-13 Thread Andrew Hill
Ummm. In (1) did you mean to say ProductFB prodFB = (ProductFB)form; ??? If you did then I would have thought the second more runtime efficient (I could well be wrong of course. Will be intersting to see what others say), though I prefer the first as its easier to read, maintain, and write :-)

Re: [FormBean] Question concerning memory / casting

2002-09-13 Thread Michael Delamere
).getPrice(); ((ProductFB)form).getPackaging(); ((ProductFB)form).getAttributes(); Thanks! - Original Message - From: Andrew Hill [EMAIL PROTECTED] To: Struts Users Mailing List [EMAIL PROTECTED] Sent: Friday, September 13, 2002 12:52 PM Subject: RE: [FormBean] Question concerning memory / casting

Re: [FormBean] Question concerning memory / casting

2002-09-13 Thread Dave Derry
Agree with your assesment re: 1 should be ProductFB prodFB = (ProductFB)form; As written I wouldn't expect to get much usefull info. ;-} I don't understand why you think 2 would be more efficient tho'. In 1, prodFB is merely an alias for form. I wouldn't expect any runtime difference. But since

Re: [FormBean] Question concerning memory / casting

2002-09-13 Thread Eddie Bush
I would think that both should be equally performant. However, I find myself doing things the first way because I: * don't have to type so much. * am inherently lazy (closest-path kind of lazy). * think it's a lot more understandable when you're reading it later. * the () pairs