Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-13 Thread Marco Pesenti Gritti
Landed with some cleanup and little fixes. Please test it and see if I broke anything in the process. I removed is_dir (and the po check which use it) because the return True was too much of an hack. Happy to consider a better fix for that as a separate patch. Thanks! Marco

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-13 Thread Simon Schampijer
As a little note so I don't forget: In the latest version Sucrose 0.82.2 when you did a ./setup release the bundle number did not get updated. Not sure how much was refactored now. I can file a ticket as well. Simon Marco Pesenti Gritti wrote: Also we need to provide commands to generate

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-13 Thread Marco Pesenti Gritti
Please open a ticket yeah. This patch did not touch that code. Marco On Fri, Jun 13, 2008 at 12:56 PM, Simon Schampijer [EMAIL PROTECTED] wrote: As a little note so I don't forget: In the latest version Sucrose 0.82.2 when you did a ./setup release the bundle number did not get updated. Not

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-12 Thread Jameson Chema Quinn
here you go. Sorry for the delay. On Tue, Jun 10, 2008 at 2:51 PM, Marco Pesenti Gritti [EMAIL PROTECTED] wrote: On Mon, Jun 9, 2008 at 7:00 PM, Jameson Chema Quinn [EMAIL PROTECTED] wrote: Here is the new version of the patch. Tell me if there are any problems applying it cleanly, and I

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-08 Thread Marco Pesenti Gritti
On Sun, Jun 8, 2008 at 3:51 AM, Jameson Chema Quinn [EMAIL PROTECTED] wrote: Sorry, Marco, but here is yet another version of the patch. I decided to refactor the Config class out of bundlebuilder - all it was carrying in the common start() case was bundle_name; and as for other cases, it is

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-08 Thread Marco Pesenti Gritti
On Sun, Jun 8, 2008 at 3:51 AM, Jameson Chema Quinn [EMAIL PROTECTED] wrote: Sorry, Marco, but here is yet another version of the patch. I decided to refactor the Config class out of bundlebuilder - all it was carrying in the common start() case was bundle_name; and as for other cases, it is

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-08 Thread Marco Pesenti Gritti
-import subprocess +from subprocess import Popen, PIPE import re import gettext from optparse import OptionParser +import warnings +import subprocess warnings seem unused, doesn't pylint warn you about it? Since you are importing subprocess just use that for Popen and PIPE. +from

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-08 Thread Jameson Chema Quinn
Some quick responses, before I dig into this... On Sun, Jun 8, 2008 at 4:08 AM, Marco Pesenti Gritti [EMAIL PROTECTED] wrote: -import subprocess +from subprocess import Popen, PIPE import re import gettext from optparse import OptionParser +import warnings +import subprocess warnings

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-08 Thread Marco Pesenti Gritti
On Sun, Jun 8, 2008 at 1:59 PM, Jameson Chema Quinn [EMAIL PROTECTED] wrote: It doesn't make sense for activitybundle to expose something a generic as list_files, especially since you are just using it to walk files inside that module. So I should duplicate the code of list_files? (This is my

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-08 Thread Jameson Chema Quinn
Here is the revised patch. It has your suggested changes, plus a couple more: - Check for existence of po directory in Builder - Config.__init__() is cleaned up. Now gets bundle name from activity.info. start() no longer needs a bundle name, and has deprecation warning. Also I put things in a

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-08 Thread Marco Pesenti Gritti
On Sun, Jun 8, 2008 at 9:26 PM, Jameson Chema Quinn [EMAIL PROTECTED] wrote: Here is the revised patch. It has your suggested changes, plus a couple more: - Check for existence of po directory in Builder - Config.__init__() is cleaned up. Now gets bundle name from activity.info. start() no

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-08 Thread Marco Pesenti Gritti
Also, you left this in. +print path Marco ___ Sugar mailing list Sugar@lists.laptop.org http://lists.laptop.org/listinfo/sugar

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-07 Thread Marco Pesenti Gritti
I'm still getting a few pylint errors, you don't?. Also can you please answer the question/notes I posted before I go ahead an do a full review? Thanks, Marco ___ Sugar mailing list Sugar@lists.laptop.org http://lists.laptop.org/listinfo/sugar

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-07 Thread Jameson Chema Quinn
I'm away from my machine, but quick response, I'll say more later. On Sat, Jun 7, 2008 at 6:51 AM, Marco Pesenti Gritti [EMAIL PROTECTED] wrote: I'm still getting a few pylint errors, you don't?. I was just getting defined outside of __init__ for ActivityBundle.manifest ... I don't know how

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-07 Thread Jameson Chema Quinn
bundleManifest.all2.patch /*here*/ = (bundleMANIFEST.patch + bundleManifest.subpatch + bundleMANIFEST.sub2.patch /*here*/) bundleMANIFEST.sub2.patch makes bundle.Bundle.is_file public, makes version an attribute of bundlebuilder.RawActivity (and all children), and fixes a minor versioning bug in

Re: [sugar] [PATCH] Bundlebuilder use manifest, fix_manifest function

2008-06-06 Thread Jameson Chema Quinn
Changes: bundle.py Added zip-agnostic _is_file() method to bundle class; used in activitybundle for checking MANIFEST without unpacking activitybundle.py Moved basic logic for processing MANIFEST, including list_files, to activitybundle.py ; this is necessary for checking when installing a