Re: [Sugar-devel] [ANNOUNCE] [SOLVED] git.sugarlabs.org migration

2010-11-12 Thread Aleksey Lim
On Thu, Nov 11, 2010 at 11:37:33PM +, Aleksey Lim wrote:
 
 Activity watching [5]
 Track for particular events.

The useful feature that was hidden in original Gitorious (dunno why,
though it works for me), is sending emails each time something from the
favorite was triggered, e.g., new commits were pushed. Click on
Email notifications button in your Dashboard.

-- 
Aleksey
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] Coding style: line continuations

2010-11-12 Thread Martin Dengler
On Fri, Nov 12, 2010 at 03:27:15AM +0800, C. Scott Ananian wrote:
 On Fri, Nov 12, 2010 at 2:09 AM, Simon Schampijer si...@schampijer.de
 wrote:
  In general I would do what the spec says if there is no good reason not to
  [1]. The example they have does not really handle all the cases, though.
  Neither pep8 nor pylint does favor any formatting. So I guess we are a bit
  free here.
 
 I belive PEP8's example is rather definitive:
 
 ... Make sure to indent the continued line appropriately.  The preferred
 place to break around a binary operator is *after* the operator, not before
 it.[ ...]
 I don't think there's any ambiguity there, actually.

Indeed, so I think we should accept that: it's written down that way
and the issue is otherwise open to legitimate argument (I think it's a
overly prescriptive, though[1]).

   --scott

Martin

[1] When the boolean logic joining the tests are quite important
relative to the tests themselves, the boolean operators benefit from
emphasis:

if (width == 0
and height == 0
and color == 'red'
and emphasis == 'strong'
or highlight  100):

...rather than:

if (width == 0 and
height == 0 and
color == 'red' and
emphasis == 'strong' or
highlight  100):

But we can argue about this point for a while.  That example really
sucks, since it uses implicit precedence in ways that are quite liable
to require people to refer to the documentation[2]:

if w and h and c and e or hi:

...if I saw that in code I'd want it changed to:

if (w and h and c and e) or hi:

...which is what it means, not:

if w and h and c and (e or hi):

I had to convince myself:
 
w = False
h = True
c = True
e = True
hi = True

print w and h and c and e or hi
print (w and h and c and e) or hi
print w and h and c and (e or hi)

...yields:
True
True
False

[2]  http://docs.python.org/reference/expressions.html#summary




pgpv8aqtmB41F.pgp
Description: PGP signature
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] Coding style: line continuations

2010-11-12 Thread Martin Dengler
On Thu, Nov 11, 2010 at 05:39:50PM +0100, Sascha Silbe wrote:
 Excerpts from Sugar Labs Bugs's message of Wed Oct 27 11:11:49 UTC 2010:
 
   {{{
   249 self._shared_activity.connect('buddy-joined',
   250 self._buddy_joined_cb)
   }}}
   In emacs I just use tab for that, the next line then gets aligned under
   the buddy joined. Same below:
   {{{
   290 logger.debug('Tube address: %s', \
   291
   self.tubes_chan[telepathy.CHANNEL_TYPE_TUBES].GetDBusTubeAddress(id))
   }}}
 
 We should agree on a continuation style, otherwise we'll confuse new
 contributors.

Agreed - but like your example, anyone who's using \ inside
parentheses is almost certainly already confused.

 In cases where using four spaces would make the code harder to read
 because the block following it uses the same indentation width I add
 four more spaces (i.e. eight total):
 
 if (really_really_long_variable_name  another_long_variable_name and
 long_variable_name[another_long_variable_name] == 'bar'):
 print whatever
 
 
 I applied this style for the clean-up patch series.

That style can be questioned, but even I can't be bothered to quibble
on such a point, so I agree with you; want if you haven't already
documented it that way, I will.

 Sascha

Martin


pgpY26pfUlhev.pgp
Description: PGP signature
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] [ANNOUNCE] [SOLVED] git.sugarlabs.org migration

2010-11-12 Thread Bastien
Aleksey Lim alsr...@member.fsf.org writes:

 This is a summary of successful migration of git.sugarlabs.org to different
 host and new Gitorios code base (which is 1.5 year ahead of previously
 used on git.sugarlabs.org).

Congrats for all the work!

 Team support [1]
 Gitorious now supports the creation of teams. Anyone can create a team,
 which lets users share repositories, promote their team on the team page
 and gives custom URLs for projects and their repositories.

Would be nice to have new teams announced on the sugar-devel@ mailing
list, so that people have a simple way to know about them and to join
them.  

-- 
 Bastien
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] [Election] Membership and candidate lists finalized

2010-11-12 Thread Walter Bender
Thanks for getting this done. It is great to have such a strong
candidate list and the addition of so many new members.

-walter


-- 
Walter Bender
Sugar Labs
http://www.sugarlabs.org
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


[Sugar-devel] [RELEASE] sugar-toolkit-0.84.14

2010-11-12 Thread Simon Schampijer
== Source ==

http://download.sugarlabs.org/sources/sucrose/glucose/sugar-toolkit/sugar-toolkit-0.84.14.tar.bz2

== News ==

* Release 0.84.14 (Simon Schampijer)
* Add new activity numbering scheme #10379 (Simon Schampijer)
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


[Sugar-devel] [RELEASE] sugar-0.84.25

2010-11-12 Thread Simon Schampijer
== Source ==

http://download.sugarlabs.org/sources/sucrose/glucose/sugar/sugar-0.84.25.tar.bz2

== News ==

* Release 0.84.25 (Simon Schampijer)
* Adapt bundleregistry to use the new activity version scheme #10379 (Simon 
Schampijer)
* Sugar Ad-hoc icons show in search results when connect/disconnect to AP OLPC 
#10412 (Simon Schampijer)
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] [Election] Membership and candidate lists finalized

2010-11-12 Thread Rafael Enrique Ortiz Guerrero
On Fri, Nov 12, 2010 at 7:37 AM, Walter Bender walter.ben...@gmail.comwrote:

 Thanks for getting this done. It is great to have such a strong
 candidate list and the addition of so many new members.

 -walter


Welcome to all new members!.

Rafael Ortiz


  --
 Walter Bender
 Sugar Labs
 http://www.sugarlabs.org
 ___
 Sugar-devel mailing list
 Sugar-devel@lists.sugarlabs.org
 http://lists.sugarlabs.org/listinfo/sugar-devel

___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] [Election] Membership and candidate lists finalized

2010-11-12 Thread Hernan Pachas
Welcome to Sugar!!!

---hernan


2010/11/12 Rafael Enrique Ortiz Guerrero raf...@sugarlabs.org



 On Fri, Nov 12, 2010 at 7:37 AM, Walter Bender walter.ben...@gmail.comwrote:

 Thanks for getting this done. It is great to have such a strong
 candidate list and the addition of so many new members.

 -walter


 Welcome to all new members!.

 Rafael Ortiz


  --
 Walter Bender
 Sugar Labs
 http://www.sugarlabs.org
 ___
 Sugar-devel mailing list
 Sugar-devel@lists.sugarlabs.org
 http://lists.sugarlabs.org/listinfo/sugar-devel



 ___
 Sugar-devel mailing list
 Sugar-devel@lists.sugarlabs.org
 http://lists.sugarlabs.org/listinfo/sugar-devel


___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] [Dextrose] [PATCH] Copying files multiple times results in bogus names. (SL#2060)

2010-11-12 Thread Shanjit Singh Jajmann
Hi all,

Firstly, I thank you all for having a look at the patch.

What i was trying to do was change the file names to
file_name(copy_number_of_the_file, starting with 2).
i had done so because of an earlier conversation with Aleksay and Sascha.

My most recent conversation with Aleksay has made me aware of the impact of
my changes and thus i would be incorporating the changes suggested above.


Thanks again.

Regards
Shan



On Thu, Nov 11, 2010 at 3:46 PM, Martin Dengler mar...@martindengler.comwrote:

 On Wed, Nov 10, 2010 at 05:57:18PM -0300, Gonzalo Odiard wrote:
  Mhh, is sufficient with doing the split out of the while

 looks good

  Gonzalo

 Martin


 ___
 Sugar-devel mailing list
 Sugar-devel@lists.sugarlabs.org
 http://lists.sugarlabs.org/listinfo/sugar-devel


___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


[Sugar-devel] [PATCH V2] Copying files multiple times results in bogus names. (SL#2060)

2010-11-12 Thread shanjit
From: Shanjit Singh Jajmann shan...@seeta.in

For every existing file copied to the location, the names are explicitly 
changed to filename_copynumber. e.g. games_1.png, games_2.png. games_3.jpg and 
so on.
---
 src/jarabe/journal/model.py |2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/src/jarabe/journal/model.py b/src/jarabe/journal/model.py
index 81ca7d4..81d1663 100644
--- a/src/jarabe/journal/model.py
+++ b/src/jarabe/journal/model.py
@@ -529,8 +529,8 @@ def _get_file_name(title, mime_type):
 def _get_unique_file_name(mount_point, file_name):
 if os.path.exists(os.path.join(mount_point, file_name)):
 i = 1
+name, extension = os.path.splitext(file_name)
 while len(file_name) = 255:
-name, extension = os.path.splitext(file_name)
 file_name = name + '_' + str(i) + extension
 if not os.path.exists(os.path.join(mount_point, file_name)):
 break
-- 
1.7.2.2

___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


[Sugar-devel] Dextrose Roadmap.

2010-11-12 Thread David Farning
The premise behind Dextrose is that OLPC is a NGO based on economies
of scale and Sugar Labs is a community project building a common
platform.  As such, there is a niche for a team of experts to
distribute and support software stacks which meet specific deployment
needs.

As with any hard project, we have had our share of false starts and
dead ends:)  As such, communication has not been as clear as it could
be.  In order to make it easier for upstream projects and deployments
to work with Dextrose, I would like to send meeting summaries to
sugar-devel, please let me know if it creates too much noise.  For
Dextrose specific issues there is a mailing list at
http://lists.sugarlabs.org/listinfo/dextrose .

I have attached a project diagram.

Flow:
'Feedback' will flow up the stack.
Developers will will implement a 'Fix' based on feedback.
AC will distribute and support a 'Finished Product' back down the stack.

Personnel:
AC has hired several full time developers to help facilitate this
process.  These developers will be augmented by contractors hired for
specific tasks.

Sugar-Upstream -- Alsroot and Silbe -- As two of the most senior Sugar
developers.  Alsroot and Silbe focus on upstream development.

Dextrose Development -- Martin(tch) is the lead dextrose developer.
Martin is responsible for overall dextrose development.

Product Manager -- Steven(smparrish) Steven is the product manager.
Steven is responsible for coordinating the needs and requests of
deployment with available developer resources.

Onsite developer -- Anish will be working onsite at ParaguayEduca to
ensure that the needs and requests of the deployment are met.

AC will spend the next 5 months proving that we can add value to the
ecosystem.  After we prove value we will implement a business model
for sustainability.  In general I encourage developers and deployments
to interact with AC on the level which is most comfortable.  Free
end-user download will always be available at
http://wiki.sugarlabs.org/go/Dextrose .

We had our first Dextrose Roadmap meeting this morning.  Logs are
available at http://meeting.sugarlabs.org/sugar-meeting/2010-11-12 .

I hope that AC can become a valuable member of the OLPC/Sugar ecosystem.

david
attachment: Diagram1.png___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] [PATCH V2] Copying files multiple times results in bogus names. (SL#2060)

2010-11-12 Thread Sascha Silbe
Excerpts from shanjit's message of Fri Nov 12 16:50:01 +0100 2010:

 For every existing file copied to the location, the names are explicitly 
 changed to filename_copynumber. e.g. games_1.png, games_2.png. games_3.jpg 
 and so on.

The patch is fine, thanks!

It would be nice if you could tweak the description a bit:
- please wrap lines at 79 characters
- the template is filename_copynumber.extension

You can do that right before pushing the patch, no need to send it to
the list again (but you may do so if you like, of course).

Reviewed-By: Sascha Silbe sascha-...@silbe.org

Sascha

--
http://sascha.silbe.org/
http://www.infra-silbe.de/


signature.asc
Description: PGP signature
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


[Sugar-devel] [PATCH V3] Copying files multiple times results in bogus names. (SL#2060)

2010-11-12 Thread shanjit
From: Shanjit Singh Jajmann shan...@seeta.in

For every existing file copied to the location, the names are explicitly 
changed to filename_copynumber.extension e.g. games_1.png, games_2.png, 
games_3.jpg and so on.

---
v1 - v2. Parenthesis idea removed, i initialised from 1.
v2 - v3. Line wrapping and .extension added.  
---
 src/jarabe/journal/model.py |2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/src/jarabe/journal/model.py b/src/jarabe/journal/model.py
index 81ca7d4..81d1663 100644
--- a/src/jarabe/journal/model.py
+++ b/src/jarabe/journal/model.py
@@ -529,8 +529,8 @@ def _get_file_name(title, mime_type):
 def _get_unique_file_name(mount_point, file_name):
 if os.path.exists(os.path.join(mount_point, file_name)):
 i = 1
+name, extension = os.path.splitext(file_name)
 while len(file_name) = 255:
-name, extension = os.path.splitext(file_name)
 file_name = name + '_' + str(i) + extension
 if not os.path.exists(os.path.join(mount_point, file_name)):
 break
-- 
1.7.2.2

___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel


Re: [Sugar-devel] [PATCH V3] Copying files multiple times results in bogus names. (SL#2060)

2010-11-12 Thread Daniel Drake
On 12 November 2010 19:01,  shan...@seeta.in wrote:
 From: Shanjit Singh Jajmann shan...@seeta.in

This is not your own work. You shouldn't put your name on it like this.

Daniel
___
Sugar-devel mailing list
Sugar-devel@lists.sugarlabs.org
http://lists.sugarlabs.org/listinfo/sugar-devel