Re: [freenet-support] Insert error

2004-07-24 Thread Toad
Umm, build 5029 ?!?!? That is _REALLY_ old. On Fri, Jul 23, 2004 at 08:02:26PM -0400, Nick Tarleton wrote: When trying to insert a NIM (on the Swedish Cannabis site, which uses a standard-looking NIM form), I get this message: The Insert Request failed. Reason: Request failed

[freenet-support] Blackdown reply

2004-07-24 Thread NickP
I have Blackdown, your command java -version 21 | head -n 1 | sed s/java version \\(.*\)\/\1/ produces this one line: 1.4.2-rc1 I have NPTL, and Freenet is working (so far). Nick. ___ Support mailing list [EMAIL PROTECTED]

[freenet-support] Re: Stable build 5086 and major vulnerability fix

2004-07-24 Thread Rudolf Krist
I have also only been able to download the 5085 build (today c. 10:00 am) ___ Support mailing list [EMAIL PROTECTED] http://news.gmane.org/gmane.network.freenet.support Unsubscribe at http://dodo.freenetproject.org/cgi-bin/mailman/listinfo/support Or

[freenet-support] Build 5085 crashing with signal 11

2004-07-24 Thread Nomen Nescio
Java HotSpot(TM) Client VM (build 1.4.2_03-b02, mixed mode) on Linux 2.6.7, Athlon XP. After running for about 12 hours, the node dies with this message on the console: Unexpected Signal : 11 occurred at PC=0x4041DCFE Function=(null)+0x4041DCFE

[freenet-support] start-freenet.sh patch to disable NPTL on SuSE Linux

2004-07-24 Thread Nomen Nescio
Since version 9.1 SuSE is using NPTL by default. To tell an application not to use NPTL, it is recommended to set LD_ASSUME_KERNEL to 2.4.1. You'll find a trivial patch to start-freenet.sh attached to this mail. --- start-freenet.sh.bak2004-07-22 22:43:47.0 +0200 +++

Re: [freenet-support] start-freenet.sh patch to disable NPTL on SuSE Linux

2004-07-24 Thread Toad
Will be committed to unstable soon. On Sun, Jul 25, 2004 at 12:00:03AM +0200, Nomen Nescio wrote: Since version 9.1 SuSE is using NPTL by default. To tell an application not to use NPTL, it is recommended to set LD_ASSUME_KERNEL to 2.4.1. You'll find a trivial patch to start-freenet.sh

Re: [freenet-support] Build 5085 crashing with signal 11

2004-07-24 Thread Toad
You need at least 1.4.2_05, or you will get NumberFormatExceptions and NullPointerExceptions in BigInteger.doubleValue(). On Sat, Jul 24, 2004 at 03:30:04PM +0200, Nomen Nescio wrote: Java HotSpot(TM) Client VM (build 1.4.2_03-b02, mixed mode) on Linux 2.6.7, Athlon XP. After running for about

Re: [freenet-support] Insert error

2004-07-24 Thread Nick Tarleton
I meant to say 5085. (I know, WT bloody F?) -Original Message- From: Toad [EMAIL PROTECTED] Sent: Jul 24, 2004 9:21 AM To: Nick Tarleton [EMAIL PROTECTED], [EMAIL PROTECTED] Subject: Re: [freenet-support] Insert error Umm, build 5029 ?!?!? That is _REALLY_ old. On Fri, Jul 23, 2004 at

[freenet-support] Connection bug in recent builds

2004-07-24 Thread Toad
Recent builds, both stable and unstable, have a bug that causes connections to fail with crypto related errors. This is probably not due to NativeBigInteger, as it happens on stable, which doesn't have NBI. Iakin has produced it reliably, although most nodes seem to work anyway. It can be reliably

[freenet-support] 5086

2004-07-24 Thread Nicholas Sturm
Finally got a 5086 after suppressing previous jars by renaming. -- Nick ___ Support mailing list [EMAIL PROTECTED] http://news.gmane.org/gmane.network.freenet.support Unsubscribe at http://dodo.freenetproject.org/cgi-bin/mailman/listinfo/support Or

Re: [freenet-support] start-freenet.sh patch to disable NPTL on SuSE Linux

2004-07-24 Thread Nomen Nescio
On Sat, Jul 24, 2004 at 11:06:23PM +0100, Toad wrote: Will be committed to unstable soon. Having read http://people.redhat.com/drepper/assumekernel.html I think we can do away with the distribution check and set LD_ASSUME_KERNEL to 2.4.1 for all Linux distributions. Patch for start-freenet.sh

Re: [freenet-support] start-freenet.sh patch to disable NPTL on SuSE Linux

2004-07-24 Thread Salah Coronya
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Nomen Nescio wrote: On Sat, Jul 24, 2004 at 11:06:23PM +0100, Toad wrote: Will be committed to unstable soon. That might not be such a good idea, it'll blow up Gentoo: http://bugs.gentoo.org/show_bug.cgi?id=45004 I run into the problem. However