[freenet-support] Unable to install Freenet 0.7 on Ubuntu 8.04 and Java 1.5

2008-07-28 Thread Avi Kak

Thanks Julien!

My system already had the Sun packages.
However, I needed to delete the packages

gij 
gij-4.2

After that I was able to install Freenet.

Avi


On Sun, 2008-07-27 at 08:59 +0200, Julien Cornuwel wrote:
> -BEGIN PGP SIGNED MESSAGE-
> Hash: SHA1
> 
> Avi Kak a ?crit :
> 
> | gij (GNU libgcj) version 4.2.3 (Ubuntu 4.2.3-2ubuntu6)
> 
> You have to use Sun's JVM :
> 
> $ sudo aptitude install sun-java6-jre
> $ sudo update-java-alternatives -s java-6-sun
> 
> Regards,
> -BEGIN PGP SIGNATURE-
> Version: GnuPG v1.4.9 (MingW32)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> 
> iEYEARECAAYFAkiMHNgACgkQmY5qNqKdYw2R1QCfUhRae6TUTj1Ovk58G23uRbWt
> /QgAoMkVjidFiwlrTeJ3ZeQhImHSK9oL
> =g354
> -END PGP SIGNATURE-
> ___
> Support mailing list
> Support at freenetproject.org
> http://news.gmane.org/gmane.network.freenet.support
> Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
> Or mailto:support-request at freenetproject.org?subject=unsubscribe




[freenet-support] Unable to install Freenet 0.7 on Ubuntu 8.04 and Java 1.5

2008-07-27 Thread Avi Kak

Hello:

I am unable to install Freenet 0.7 on Ubuntu 8.04
and Java 1.5.  I also tried with Java 1.6, but I 
get the same error message.

After downloading freenet07.tar.gz and doing the
usual things, I executed

./run.sh start

in the freenet directory.  Each time I get the
following error message

-

Enabling the auto-update feature
Detecting tcp-ports availability...
Downloading update.sh
#
It seems that you are using a buggy JVM...
The installer will refuse to run until you switch to a decent one
#
You are currently using:
java version "1.5.0"
gij (GNU libgcj) version 4.2.3 (Ubuntu 4.2.3-2ubuntu6)

Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is
NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.
#
The full error message is :
#
Error while handling the CA :JKS
java.security.KeyStoreException: JKS
   at java.security.KeyStore.getInstance(libgcj.so.81)
   at java.security.KeyStore.getInstance(libgcj.so.81)
   at Sha1Test.main(Sha1Test.java:46)
Caused by: java.security.NoSuchAlgorithmException: Algorithm [JKS] of
type [KeyStore] from provider
[gnu.javax.security.auth.callback.GnuCallbacks: name=GNU-CALLBACKS
version=2.1] is not found
   at gnu.java.security.Engine.getInstance(libgcj.so.81)
   at gnu.java.security.Engine.getInstance(libgcj.so.81)
   at java.security.KeyStore.getInstance(libgcj.so.81)
   ...2 more

---

Any help would be much appreciated.

Thanks.

Avi






[freenet-support] Unable to install Freenet 0.7 on Ubuntu 8.04 and Java 1.5

2008-07-27 Thread Avi Kak

Hello:
 
I am unable to install Freenet 0.7 on Ubuntu 8.04
and Java 1.5.  I also tried with Java 1.6, but I 
get the same error message.

After downloading freenet07.tar.gz and doing the
usual things, I executed

./run.sh start

in the freenet directory.  Each time I get the
following error message

-

Enabling the auto-update feature
Detecting tcp-ports availability...
Downloading update.sh
#
It seems that you are using a buggy JVM...
The installer will refuse to run until you switch to a decent one
#
You are currently using:
java version 1.5.0
gij (GNU libgcj) version 4.2.3 (Ubuntu 4.2.3-2ubuntu6)

Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is
NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.
#
The full error message is :
#
Error while handling the CA :JKS
java.security.KeyStoreException: JKS
   at java.security.KeyStore.getInstance(libgcj.so.81)
   at java.security.KeyStore.getInstance(libgcj.so.81)
   at Sha1Test.main(Sha1Test.java:46)
Caused by: java.security.NoSuchAlgorithmException: Algorithm [JKS] of
type [KeyStore] from provider
[gnu.javax.security.auth.callback.GnuCallbacks: name=GNU-CALLBACKS
version=2.1] is not found
   at gnu.java.security.Engine.getInstance(libgcj.so.81)
   at gnu.java.security.Engine.getInstance(libgcj.so.81)
   at java.security.KeyStore.getInstance(libgcj.so.81)
   ...2 more

---

Any help would be much appreciated.

Thanks.

Avi



___
Support mailing list
Support@freenetproject.org
http://news.gmane.org/gmane.network.freenet.support
Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
Or mailto:[EMAIL PROTECTED]


Re: [freenet-support] Unable to install Freenet 0.7 on Ubuntu 8.04 and Java 1.5

2008-07-27 Thread Avi Kak

Thanks Julien!

My system already had the Sun packages.
However, I needed to delete the packages

gij 
gij-4.2

After that I was able to install Freenet.

Avi


On Sun, 2008-07-27 at 08:59 +0200, Julien Cornuwel wrote:
 -BEGIN PGP SIGNED MESSAGE-
 Hash: SHA1
 
 Avi Kak a écrit :
 
 | gij (GNU libgcj) version 4.2.3 (Ubuntu 4.2.3-2ubuntu6)
 
 You have to use Sun's JVM :
 
 $ sudo aptitude install sun-java6-jre
 $ sudo update-java-alternatives -s java-6-sun
 
 Regards,
 -BEGIN PGP SIGNATURE-
 Version: GnuPG v1.4.9 (MingW32)
 Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
 
 iEYEARECAAYFAkiMHNgACgkQmY5qNqKdYw2R1QCfUhRae6TUTj1Ovk58G23uRbWt
 /QgAoMkVjidFiwlrTeJ3ZeQhImHSK9oL
 =g354
 -END PGP SIGNATURE-
 ___
 Support mailing list
 Support@freenetproject.org
 http://news.gmane.org/gmane.network.freenet.support
 Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
 Or mailto:[EMAIL PROTECTED]

___
Support mailing list
Support@freenetproject.org
http://news.gmane.org/gmane.network.freenet.support
Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
Or mailto:[EMAIL PROTECTED]