[freenet-support] Cannot get Freenet 0.7 to run on SuSE 10.1.

2006-06-10 Thread Blue Raven
I am having trouble getting Freenet 0.7 to run on my system.  I am running
SuSE 10.1 on a machine with an AMD Athlon 64 processor.  I attempted to
install the node manually since I couldn't seem to get the web-installer or
self extracting JAR to work.

I followed the following instructions:

wget 
http://downloads.freenetproject.org/alpha/freenet-ext.jar
wget 
http://downloads.freenetproject.org/alpha/freenet-cvs-snapshot.jar.url
wget -i freenet-cvs-snapshot.jar.url
java -Xmx100M  -cp
freenet-ext.jar:freenet-cvs-snapshot.jar freenet.node.Node freenet.ini


Whenever I run the last command I get the following error:

Exception in thread "main" java.lang.NoClassDefFoundError: freenet/node/Node


Once I receive that error I am returned to the command prompt and the node
does not start.  Any insight would be appreciated.
-- next part --
An HTML attachment was scrubbed...
URL: 



[freenet-support] Cannot get Freenet 0.7 to run on SuSE 10.1.

2006-06-10 Thread Blue Raven
I am having trouble getting Freenet 0.7 to run on my system. I am running SuSE 10.1 on a machine with an AMD Athlon 64 processor. I attempted to install the node manually since I couldn't seem to get the web-installer or self extracting JAR to work.
I followed the following instructions:
wget http://downloads.freenetproject.org/alpha/freenet-ext.jar
wget http://downloads.freenetproject.org/alpha/freenet-cvs-snapshot.jar.url
wget -i freenet-cvs-snapshot.jar.url
java -Xmx100M -cp freenet-ext.jar:freenet-cvs-snapshot.jar freenet.node.Node freenet.iniWhenever I run the last command I get the following error:
Exception in thread main java.lang.NoClassDefFoundError: freenet/node/NodeOnce I receive that error I am returned to the command prompt and the node does not start. Any insight would be appreciated.

___
Support mailing list
Support@freenetproject.org
http://news.gmane.org/gmane.network.freenet.support
Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
Or mailto:[EMAIL PROTECTED]

[freenet-support] Freenet not working w/ openSuSE 10.0 on a 64 bit system.

2006-05-16 Thread Blue Raven
I downloaded and untarred the tarball for freenet.  When I try to run it I
get the following:

Detected freenet-ext.jar
Detected freenet.jar
Sun java detected.
Sun Java 1.4.2 detected.
Starting Freenet now: Command line: java -Xmx128m
-XX:MaxDirectMemorySize=128m freenet.node.Main
Done
os.arch = amd64
ERROR: The resource net/i2p/util/libjbigi-linux-none.so was not a valid
library for this platform
java.lang.UnsatisfiedLinkError: /tmp/jbigi32654lib.tmp:
/tmp/jbigi32654lib.tmp: cannot open shared object file: No such file or
directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1647)
at java.lang.Runtime.load0(Runtime.java:769)
at java.lang.System.load(System.java:967)
at net.i2p.util.NativeBigInteger.loadFromResource(
NativeBigInteger.java:497)
at net.i2p.util.NativeBigInteger.loadNative(NativeBigInteger.java
:413)
at net.i2p.util.NativeBigInteger.(NativeBigInteger.java:120)
at freenet.crypt.Util.(Util.java:89)
at freenet.crypt.Yarrow.generator_init(Yarrow.java:241)
at freenet.crypt.Yarrow.(Yarrow.java:83)
at freenet.crypt.Yarrow.(Yarrow.java:69)
at freenet.crypt.ThrottledAsyncEntropyYarrow.(
ThrottledAsyncEntropyYarrow.java:32)
at freenet.Core.getRandSource(Core.java:754)
at freenet.node.Node.init(Node.java:3454)
at freenet.node.Main.main(Main.java:476)
INFO: Native BigInteger library jbigi not loaded - using pure java

When it gets to this point it just hangs.  The only thing I could find about
it in the archives is here:

http://archives.freenetproject.org/pipermail/support/2006-January/000481.html

I read the original message and the response.  The response says that it
should still work despite the error message.  I have confirmed that it does
not.  I was wondering if there has been any sort of update on this issue.
You should know that I am running on almost the exact same setup as the
original poster.  Any information would be helpful.
-- next part --
An HTML attachment was scrubbed...
URL: 



[freenet-support] Freenet not working w/ openSuSE 10.0 on a 64 bit system.

2006-05-16 Thread Blue Raven
I downloaded and untarred the tarball for freenet. When I try to run it I get the following:Detected freenet-ext.jarDetected freenet.jarSun java detected.Sun Java 1.4.2 detected.Starting Freenet now: Command line: java -Xmx128m -XX:MaxDirectMemorySize=128m 
freenet.node.MainDoneos.arch = amd64ERROR: The resource net/i2p/util/libjbigi-linux-none.so was not a valid library for this platformjava.lang.UnsatisfiedLinkError: /tmp/jbigi32654lib.tmp: /tmp/jbigi32654lib.tmp: cannot open shared object file: No such file or directory
 at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1647) at 
java.lang.Runtime.load0(Runtime.java:769) at java.lang.System.load(System.java:967) at net.i2p.util.NativeBigInteger.loadFromResource(NativeBigInteger.java:497) at net.i2p.util.NativeBigInteger.loadNative
(NativeBigInteger.java:413) at net.i2p.util.NativeBigInteger.clinit(NativeBigInteger.java:120) at freenet.crypt.Util.clinit(Util.java:89) at freenet.crypt.Yarrow.generator_init
(Yarrow.java:241) at freenet.crypt.Yarrow.init(Yarrow.java:83) at freenet.crypt.Yarrow.init(Yarrow.java:69) at freenet.crypt.ThrottledAsyncEntropyYarrow.init(ThrottledAsyncEntropyYarrow.java
:32) at freenet.Core.getRandSource(Core.java:754) at freenet.node.Node.init(Node.java:3454) at freenet.node.Main.main(Main.java:476)INFO: Native BigInteger library jbigi not loaded - using pure java
When it gets to this point it just hangs. The only thing I could find about it in the archives is here:
http://archives.freenetproject.org/pipermail/support/2006-January/000481.htmlI read the original message and the response. The response says that it should still work despite the error message. I have confirmed that it does not. I was wondering if there has been any sort of update on this issue. You should know that I am running on almost the exact same setup as the original poster. Any information would be helpful.

___
Support mailing list
Support@freenetproject.org
http://news.gmane.org/gmane.network.freenet.support
Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
Or mailto:[EMAIL PROTECTED]