Re: Can't Boot Qtopia from microSD

2008-08-06 Thread Andy Green
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

Somebody in the thread at some point said:

| I changed the kernel name based on something I read stating it had to be
| called uImage.bin (is that wrong?)

It needs to match whatever you called it on the kernel commandline in
U-Boot, our ones use uImage.bin.

| 3. I upgraded my NAND U-boot to a post-July 23 version. I think I have
| the August 5 version now.

Great.

| 4. I edited by NAND U-boot menu to include:
| setenv menu_9 Boot from microSD part2 (ext2+ext2): setenv bootargs
| \${bootargs_base} rootfstype=ext2 root=/dev/mmcblk0p2 rootdelay=5
| \${mtdparts} ro\; mmcinit\; ext2load mmc 1 0x3200
| \${sd_image_name}\; bootm 0x3200

Ignoring the menu stuff for a moment, here is a canned one liner to do
something like what you want

setenv bootcmd  mmcinit \; ext2load mmc 2 0x3200 uImage.bin \;
setenv bootargs \${mtdparts} rootfstype=ext2 root=/dev/mmcblk0p2
console=ttySAC2,115200 loglevel=4 init=/sbin/init \; bootm 0x3200 ; boot

Notice on ext2load the first number is the partition index it should
use, counting from 1.

- -Andy
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iEYEARECAAYFAkiZXZwACgkQOjLpvpq7dMrZEACeIF7knB0jDkU2FkkYR03iKMGo
UAIAoIjFUKKff0Q+RAzA7j+v8L+ajji3
=+TDp
-END PGP SIGNATURE-

___
support mailing list
support@lists.openmoko.org
https://lists.openmoko.org/mailman/listinfo/support


Re: Can't Boot Qtopia from microSD

2008-08-06 Thread Shakthi Kannan
Hi Brian,

--- On Wed, Aug 6, 2008 at 1:37 PM, Brian C [EMAIL PROTECTED] wrote:
| If someone has Qtopia (or any other distro, for that matter) booting
| from microSD, I'd appreciate very step-by-step instructions
\--

Some quick notes I had made:

1. Download qtopia-4.3.2-gta02-flash-07221045.tgz from:

http://wiki.openmoko.org/wiki/Latest_Images#Qtopia_image_from_qtopia.net

It extracts to:

  qtopia-4.3.2-gta02-flash-07221045.jffs2
  uImage_2008_07_16_gta02_73eeb0333fc771cb696ff9bf17c517c741434b59.bin

2. Prepare SD card (from USB 4-in-1 card reader):

   fdisk /dev/sdb

First partition is 8M.
Use remaining disk space for second partition.

3. Create vfat on /dev/sdb1

   mkfs.vfat /dev/sdb1

Rename the uImage kernel to uImage.bin and copy it to the first partition.

4. Create ext2 filesystem on /dev/sdb2

   mke2fs /dev/sdb2

5. Prepare the .tar.gz from .jffs2:

http://wiki.openmoko.org/wiki/Userspace_root_image#Mounting_the_JFFS2_image_on_a_loop_back_device_.28Kernel_Memory_MTD_Emulation.29

modprobe mtdcore
modprobe jffs2
modprobe mtdram total_size=59024
 /* default is 4 MByte - set to max. available size */
modprobe mtdchar
modprobe mtdblock

Check cat /proc/mtd:
# dev:size   erasesize  name
# mtd0: 039a4000 0002 mtdram test device

Use mtdram device file (mtd0, in the above):

sudo dd if=rootfs.jffs2 of=/dev/mtd0
mount -t jffs2 /dev/mtdblock0 /mnt
sudo tar czf qtopia-4.3.2-gta02-rootfs-07172049.tar.gz -C /mnt .

6. Install root filesystem on the Neo device:

scp qtopia-4.3.2-gta02-rootfs-07172049.tar.gz
[EMAIL PROTECTED]:/media/mmcblk0p2/

 cd /media/mmcblk0p2
 tar xzf qtopia-4.3.2-gta02-rootfs-07172049.tar.gz
 rm qtopia-4.3.2-gta02-rootfs-07172049.tar.gz
 rm -f /media/mmcblk0p2/boot/*

7. Press AUX button, choose boot from SD card (VFAT+ext2) and boot
into Qtopia :)

SK

-- 
Shakthi Kannan
http://www.shakthimaan.com

___
support mailing list
support@lists.openmoko.org
https://lists.openmoko.org/mailman/listinfo/support


Re: Can't Boot Qtopia from microSD

2008-08-06 Thread Matthew McCormick
Brian C [EMAIL PROTECTED] writes:


 2. partition2 is where I want to put Qtopia.
 After formatting it ext2 and mounting the partition, I did:
 wget http://qtopia.net/downloads/neo/qtopia-4.3.2-gta02-flash-07221045.tgz
 tar zvxf qtopia-4.3.2-gta02-flash-07221045.tgz
 mv uImage*.bin uImage.bin

 I changed the kernel name based on something I read stating it had to be
 called uImage.bin (is that wrong?)


You must follow the instructions on the wiki.  You did not extract the
rootfs.


 4. I edited by NAND U-boot menu to include:
 setenv menu_9 Boot from microSD part2 (ext2+ext2): setenv bootargs
 \${bootargs_base} rootfstype=ext2 root=/dev/mmcblk0p2 rootdelay=5
 \${mtdparts} ro\; mmcinit\; ext2load mmc 1 0x3200
 \${sd_image_name}\; bootm 0x3200

Your partitions numbers are wrong from what you have said.  I added a
warning to
watch partition numbers and what to change.


 Thanks for any help.  If I figure all this out, there is going to be a
 single crystal clear wiki page on this when I get done.

Please do _not_ try to make a single crystal clear wiki page.  Please fix
relevant sections of the wiki, but do not try to concatenate all sections to
one
page for what you, personally, are trying to do.  This leads to multiple
crummy
pages.
___
support mailing list
support@lists.openmoko.org
https://lists.openmoko.org/mailman/listinfo/support


Re: Can't Boot Qtopia from microSD

2008-08-06 Thread Matthew McCormick
On Wed, Aug 6, 2008 at 8:33 AM, Matthew McCormick 
[EMAIL PROTECTED] wrote:

 Brian C [EMAIL PROTECTED] writes:

 
  2. partition2 is where I want to put Qtopia.
  After formatting it ext2 and mounting the partition, I did:
  wget
 http://qtopia.net/downloads/neo/qtopia-4.3.2-gta02-flash-07221045.tgz
  tar zvxf qtopia-4.3.2-gta02-flash-07221045.tgz
  mv uImage*.bin uImage.bin
 
  I changed the kernel name based on something I read stating it had to be
  called uImage.bin (is that wrong?)
 

 You must follow the instructions on the wiki.  You did not extract the
 rootfs.


BTW, the page should be looking at is here
http://wiki.openmoko.org/wiki/Qtopia
___
support mailing list
support@lists.openmoko.org
https://lists.openmoko.org/mailman/listinfo/support


Re: Can't Boot Qtopia from microSD

2008-08-06 Thread Mike Montour
Andy Green wrote:

 setenv bootcmd  mmcinit \; ext2load mmc 2 0x3200 uImage.bin \;
 setenv bootargs \${mtdparts} rootfstype=ext2 root=/dev/mmcblk0p2
 console=ttySAC2,115200 loglevel=4 init=/sbin/init \; bootm 0x3200 ; boot
 
 Notice on ext2load the first number is the partition index it should
 use, counting from 1.

Minor correction - the parameter for ext2load and fatload is 
device:partition, so partition 2 would be ext2load mmc 1:2  
IIRC this is documented in the online help for fatload but not for 
ext2load.

For troubleshooting you can also run mmcinit; ext2ls mmc 1:2 / from 
the u-boot console to make sure that u-boot is able to access the 
partition, and to see what files are on the card. There is also a 
fatls command to look at a VFAT partition.


___
support mailing list
support@lists.openmoko.org
https://lists.openmoko.org/mailman/listinfo/support


Re: Can't Boot Qtopia from microSD

2008-08-06 Thread arne anka
 of them come back FATAL no such module, like so:

 [EMAIL PROTECTED]:/mnt/qtopia# modprobe mtdcore
 FATAL: Module mtdcore not found.
 [EMAIL PROTECTED]:/mnt/qtopia# modprobe jffs2
 FATAL: Module jffs2 not found.
 [EMAIL PROTECTED]:/mnt/qtopia# modprobe mtdram total_size=59024
 FATAL: Module mtdram not found.
 [EMAIL PROTECTED]:/mnt/qtopia# modprobe mtdchar
 FATAL: Module mtdchar not found.
 [EMAIL PROTECTED]:/mnt/qtopia# modprobe mtdblock
 FATAL: Module mtdblock not found.

every one of these is probably not part of a standard variety installation.
have a look at google to find out what packages of your distribution  
contain these modules.

___
support mailing list
support@lists.openmoko.org
https://lists.openmoko.org/mailman/listinfo/support


Re: Can't Boot Qtopia from microSD

2008-08-06 Thread Andy Green
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

Somebody in the thread at some point said:

| You are right that I did not extract the rootfs, but that is because 1)
| I do not know how to extract the rootfs and 2) none of the various
| instructions on the wiki (which are inconsistent) worked for me.  For
| instance, when I do the various modprobe commands that are listed, all
| of them come back FATAL no such module, like so:
|
| [EMAIL PROTECTED]:/mnt/qtopia# modprobe mtdcore
| FATAL: Module mtdcore not found.
| [EMAIL PROTECTED]:/mnt/qtopia# modprobe jffs2
| FATAL: Module jffs2 not found.
| [EMAIL PROTECTED]:/mnt/qtopia# modprobe mtdram total_size=59024
| FATAL: Module mtdram not found.
| [EMAIL PROTECTED]:/mnt/qtopia# modprobe mtdchar
| FATAL: Module mtdchar not found.
| [EMAIL PROTECTED]:/mnt/qtopia# modprobe mtdblock
| FATAL: Module mtdblock not found.

These are all built-in to the monolithic kernels from us, so there are
no modules for them.  They're all needed to boot from mtd / jffs2 which
is normal for us.

| I should also emphasize to an earlier responder that I want to place
| both the kernel and the rootfs on the same ext2 partition, namely
| partition 2.  I believe this is possible, and I'd prefer it to having
| the kernel in the first FAT partition.

| Andy's email will likely be helpful here, but clearly I have to figure
| out how to extract the jffs2 first.

There should be a .tar.gz floating around for rootfs normally as well,
these are obviously more amenable to unpacking into the rootfs.

- -Andy
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iEYEARECAAYFAkiZ1/4ACgkQOjLpvpq7dMqdAgCgk37ZNuBM92BpaIPqs9OpWjKq
ScIAn05sPELF+ulrpwpD6wdw0ABX020I
=CsKG
-END PGP SIGNATURE-

___
support mailing list
support@lists.openmoko.org
https://lists.openmoko.org/mailman/listinfo/support


Re: Can't Boot Qtopia from microSD

2008-08-06 Thread Andy Green
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

Somebody in the thread at some point said:
| Andy Green wrote:
|
| setenv bootcmd  mmcinit \; ext2load mmc 2 0x3200 uImage.bin \;
| setenv bootargs \${mtdparts} rootfstype=ext2 root=/dev/mmcblk0p2
| console=ttySAC2,115200 loglevel=4 init=/sbin/init \; bootm 0x3200
; boot
|
| Notice on ext2load the first number is the partition index it should
| use, counting from 1.
|
| Minor correction - the parameter for ext2load and fatload is
| device:partition, so partition 2 would be ext2load mmc 1:2 
| IIRC this is documented in the online help for fatload but not for
| ext2load.
|
| For troubleshooting you can also run mmcinit; ext2ls mmc 1:2 / from
| the u-boot console to make sure that u-boot is able to access the
| partition, and to see what files are on the card. There is also a
| fatls command to look at a VFAT partition.

My mistake, I just edited my canned one I use for first partition off
the top of my head.  One way or another personally I only ever pulled
kernel from the first partition on SD Card myself, VFAT or EXT3.

- -Andy
-BEGIN PGP SIGNATURE-
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iEYEARECAAYFAkiZ2GcACgkQOjLpvpq7dMrApwCcCsMPGTV4FDanCxmZxUhEJLgs
OE0AninO8pLv3/lFF2UCWdPmeskpS7DK
=+KGy
-END PGP SIGNATURE-

___
support mailing list
support@lists.openmoko.org
https://lists.openmoko.org/mailman/listinfo/support