Re: [swift-evolution] [swift-evolution-announce] [Review] SE-0176: Remove ownership keyword support in protocols

2017-09-23 Thread T.J. Usiyan via swift-evolution
* What is your evaluation of the proposal? + 1 * Is the problem being addressed significant enough to warrant a change to Swift? Yes * Does this proposal fit well with the feel and direction of Swift? Yes, so long as we actually consider whether or not we want to allow these keywords eventually.

Re: [swift-evolution] Standard ReactiveSteam definitions for Swift

2017-09-23 Thread Dave DeLong via swift-evolution
> On Sep 23, 2017, at 1:24 AM, Georgios Moschovitis via swift-evolution > wrote: > > Copied from the corresponding Github issue, I would like to hear opinions > from the broader community on this: > > I am wondering if the correct 'translation' to Swift of: > >

Re: [swift-evolution] Enums and Source Compatibility

2017-09-23 Thread Karl Wagner via swift-evolution
Yes, it’s binary compatiblity (ABI). And yes, you’re right that inlineable code is especially fragile to changes made in later versions of the library. See: https://github.com/apple/swift/blob/master/docs/LibraryEvolution.rst#inlineable-code > > On

Re: [swift-evolution] Question about async await

2017-09-23 Thread Trevör Anne Denise via swift-evolution
> Le 20 sept. 2017 à 21:15, Jean-Daniel a écrit : > > > >> Le 20 sept. 2017 à 08:36, Trevör Anne Denise via swift-evolution >> > a écrit : >> >>> >>> Le 18 sept. 2017 à 18:07, Pierre Habouzit

Re: [swift-evolution] Standard ReactiveSteam definitions for Swift

2017-09-23 Thread Georgios Moschovitis via swift-evolution
Copied from the corresponding Github issue, I would like to hear opinions from the broader community on this: I am wondering if the correct 'translation' to Swift of: ``` onNext() onError() ``` is really: ``` on(next:) on(error:) ``` maybe something closer to Foundation's naming conventions