Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-18 Thread Jean-Denis Muys via swift-evolution
I don't agree with the line of reasoning that goes something like that: "Event though you have , I want to forbid every one from using additive feature X because I don't like it, given " I also don't understand why this would impede qualified import syntax. What is wrong with: import func

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-18 Thread Georgios Moschovitis via swift-evolution
> I'd almost always prefer to have another three lines of a protocolvisible, > than three lines of imports. Maybe you just need an editor that can fold the imports (e.g. JetBrains) ___ swift-evolution mailing list swift-evolution@swift.org

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-17 Thread Charles Constant via swift-evolution
> Having one import per line is much more readable and maintainable This depends on how much importance you give to "import" declarations. If you feel they equally important as the rest of your code, I can understand why you would want to see them. I don't. My preference is to see as much of the

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-17 Thread Said Sikira via swift-evolution
-1. I disagree. Having one import per line is much more readable and maintainable especially when you have statements like `import func Framework.someMethod`. Being able to use `let a, b, c, …` doesn’t have to do anything with importing modules since those are completely different features of

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-17 Thread Jay Abbott via swift-evolution
-1 - I don't like this. I never understood the desire for *extreme* vertical conciseness, it tends to make code less readable in general and definitely makes diffs a lot harder harder to read. On Sun, 16 Oct 2016 at 11:26 Anton Zhilin via swift-evolution < swift-evolution@swift.org> wrote: >

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-16 Thread Anton Zhilin via swift-evolution
Purely additive feature, not for Swift 4 Phase 1. And a -1 from me for reasons already mentioned. ___ swift-evolution mailing list swift-evolution@swift.org https://lists.swift.org/mailman/listinfo/swift-evolution

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-16 Thread Nicholas Maccharoli via swift-evolution
+1 2016年10月16日日曜日、Rien via swift-evolutionさんは書きました: > Specifically, I don’t care much. Say -0.1 :-) > > In general I am against “savings lines”. > While very short modules (< 10) do indeed profit from having fewer lines, > most modules don’t. > Having a few more lines,

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-16 Thread Rien via swift-evolution
Specifically, I don’t care much. Say -0.1 :-) In general I am against “savings lines”. While very short modules (< 10) do indeed profit from having fewer lines, most modules don’t. Having a few more lines, even empty ones, can do a lot to improve code readability imo. Probably my Ada experience

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-16 Thread Robert Widmann via swift-evolution
-1. This is not going to work particularly well with qualified import syntax (import {class|struct|enum|typealias} Module.Decl) and blurs disparate imports with each other. I'd rather see grouping of related imports than save a few lines. ~Robert Widmann 2016/10/16 3:14、Richard Wei via

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-16 Thread Richard Wei via swift-evolution
+1. Since we can do `let a, b, c, ...`, it makes sense for `import` to support comma-separated lists. -Richard > On Oct 15, 2016, at 20:24, Erica Sadun via swift-evolution > wrote: > > >> On Oct 15, 2016, at 6:41 PM, Charles Constant via swift-evolution >>

Re: [swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-15 Thread Erica Sadun via swift-evolution
> On Oct 15, 2016, at 6:41 PM, Charles Constant via swift-evolution > wrote: > > How would we all feel about allowing multiple modules with one import > statement? > > Eg: the option to write > > import Cocoa, Foo, Bar.Baz > > in addition to just: > >

[swift-evolution] [pitch] "import" declaration, support for comma-separated modules

2016-10-15 Thread Charles Constant via swift-evolution
How would we all feel about allowing multiple modules with one import statement? Eg: the option to write *import Cocoa, Foo, Bar.Baz * in addition to just: *import Cocoa * *import Foo * *import Bar.Baz * When I'm writing smaller files that import a few modules, I'd