Re: [systemd-devel] udev now crashes in daemon mode

2015-05-26 Thread Mantas Mikulėnas
Thanks, finally got around to rebooting, and udev now starts properly.
However, when the cleanuphook calls udevadm control --exit, it takes
quite a while (though the system later boots normally). With --debug
enabled, I see:

 udevd message (EXIT) received
 [10-20 seconds pass]
 timeout, giving up waiting for workers to finish

I tried running it manually from the initramfs shell, and udev had no
workers at all at that point.

This is with the latest 185abfc3d6b build.

On Sun, May 24, 2015 at 4:30 PM, Tom Gundersen t...@jklm.no wrote:

 Hi Mantas,



 On Sun, May 24, 2015 at 11:40 AM, Mantas Mikulėnas graw...@gmail.com
 wrote:
  So, udev v220 crashes in my initramfs with the following message:
 
  starting version v220
  Assertion 'manager-pid == getpid()' failed at src/udev/udevd.c:568,
  function ev
  Aborting.
 
  It seems main calls manager_new() before forking, so the parent PID is
  stored instead of child PID.
 
  (I'm using Arch Linux with the traditional mkinitcpio-based initramfs,
 which
  starts udev using systemd-udevd --daemon --resolve-names=never.)

 Thanks for the report. This should be fixed now in git, please let me
 know if that is not the case.

 Cheers,

 Tom




-- 
Mantas Mikulėnas graw...@gmail.com
___
systemd-devel mailing list
systemd-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/systemd-devel


Re: [systemd-devel] udev now crashes in daemon mode

2015-05-26 Thread Filipe Brandenburger
Hi Tom,

On Sun, May 24, 2015 at 6:30 AM, Tom Gundersen t...@jklm.no wrote:
 On Sun, May 24, 2015 at 11:40 AM, Mantas Mikulėnas graw...@gmail.com wrote:
 So, udev v220 crashes in my initramfs with the following message:

 starting version v220
 Assertion 'manager-pid == getpid()' failed at src/udev/udevd.c:568,
 function ev
 Aborting.

 It seems main calls manager_new() before forking, so the parent PID is
 stored instead of child PID.

 (I'm using Arch Linux with the traditional mkinitcpio-based initramfs, which
 starts udev using systemd-udevd --daemon --resolve-names=never.)

 Thanks for the report. This should be fixed now in git, please let me
 know if that is not the case.

I was testing the same setup (ArchLinux with mkinitcpio), seeing the
same crash in udevd from initramfs and I can confirm that
040e689654ef08 (udevd: event - fix event queue in daemenozied mode)
fixed it. Thanks!

HTH,
Filipe
___
systemd-devel mailing list
systemd-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/systemd-devel


Re: [systemd-devel] udev now crashes in daemon mode

2015-05-24 Thread Tom Gundersen
Hi Mantas,



On Sun, May 24, 2015 at 11:40 AM, Mantas Mikulėnas graw...@gmail.com wrote:
 So, udev v220 crashes in my initramfs with the following message:

 starting version v220
 Assertion 'manager-pid == getpid()' failed at src/udev/udevd.c:568,
 function ev
 Aborting.

 It seems main calls manager_new() before forking, so the parent PID is
 stored instead of child PID.

 (I'm using Arch Linux with the traditional mkinitcpio-based initramfs, which
 starts udev using systemd-udevd --daemon --resolve-names=never.)

Thanks for the report. This should be fixed now in git, please let me
know if that is not the case.

Cheers,

Tom
___
systemd-devel mailing list
systemd-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/systemd-devel