Re: Message is being sent while being edited

2020-04-23 Thread Thomas Fernandez
Hello Paul,

On Thu, 23 Apr 2020 08:26:15 -0400 GMT (23-Apr-20, 19:26 +0700 GMT),
Paul Van Noord wrote:

TF> Kindly support https://bt.ritlabs.com/view.php?id=1998

 Did it.

>>> Thanks. I am putting this reply in the Outbox now, testing the new
>>> 18.MSI. Then, I will open it again and wait.

>>> This is the edited version.

TF>> So, what happened is that the message stayed in the Outbox, unparked,
TF>> while I had opened it in the editor again. I waited two sending
TF>> perdiods (my TB is set to send/receive every 10 minutes, so I waited
TF>> almost 30 minutes), and the message did not get sent.

TF>> So, while there is no "park" icon, it appears that the problem is
TF>> fixed in 9.1.18 (but I tested it only once). Can anybody confirm?

> I get a similar experience... Nice it seems fixed. Not nice there was no
> announcement. I vote for closing the incident report.

It used to be that the reporter can close a report. That does not seem
the case any more. But I added a note that I consider it fixed.

--

Cheers,
Thomas.




'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-23 Thread Paul Van Noord
4/23/2020  8:21 AM

On 4/22/2020 The Bat Beta wrote:

TF Kindly support https://bt.ritlabs.com/view.php?id=1998

>>> Did it.

>> Thanks. I am putting this reply in the Outbox now, testing the new
>> 18.MSI. Then, I will open it again and wait.

>> This is the edited version.

TF> So, what happened is that the message stayed in the Outbox, unparked,
TF> while I had opened it in the editor again. I waited two sending
TF> perdiods (my TB is set to send/receive every 10 minutes, so I waited
TF> almost 30 minutes), and the message did not get sent.

TF> So, while there is no "park" icon, it appears that the problem is
TF> fixed in 9.1.18 (but I tested it only once). Can anybody confirm?

I get a similar experience... Nice it seems fixed. Not nice there was no
announcement. I vote for closing the incident report.

- --
Paul

32bit TB 9.1.18  Windows 7 Pro 7600 
No IMAP  No OTFE



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-23 Thread Andrew Savchenko
Hello Thomas,

Thursday, April 23, 2020, 12:22:33 PM, you wrote:

> So, while there is no "park" icon, it appears that the problem is
> fixed in 9.1.18 (but I tested it only once). Can anybody confirm?

This is initial version... Saving.

This sentence is added while the letter is in the Outbox. Let's see if 
it gets sent automatically... No.

Looks like it was "automagically" fixed in v9.1.18



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-22 Thread Thomas Fernandez
Hello Thomas,

On Thu, 23 Apr 2020 09:29:38 +0700 GMT (23-Apr-20, 9:29 +0700 GMT),
Thomas Fernandez wrote:

> Hello Paul,

> On Wed, 22 Apr 2020 11:57:59 -0400 GMT (22-Apr-20, 22:57 +0700 GMT),
> Paul Van Noord wrote:

> Over here it is 10 minutes. Please try opening the mail again and
> re-read, maybe edit, when the time hits and TB sends messages. It will
> send this message, even though you have re-opened it and are editing
> it.

 Can confirm. Is this an error? I've been using TheBat! since very late
 v8 builds, maybe behaviour was different earlier on.

TF>>> I consider it an error (bug), because TB does something the user does
TF>>> clearly not intend. If he wanted the original version to be sent, he
TF>>> wouldn't have opened it again in th editor.

TF>>> Kindly support https://bt.ritlabs.com/view.php?id=1998

>> Did it.

> Thanks. I am putting this reply in the Outbox now, testing the new
> 18.MSI. Then, I will open it again and wait.

> This is the edited version.

So, what happened is that the message stayed in the Outbox, unparked,
while I had opened it in the editor again. I waited two sending
perdiods (my TB is set to send/receive every 10 minutes, so I waited
almost 30 minutes), and the message did not get sent.

So, while there is no "park" icon, it appears that the problem is
fixed in 9.1.18 (but I tested it only once). Can anybody confirm?

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.18 (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-22 Thread Thomas Fernandez
Hello Paul,

On Wed, 22 Apr 2020 11:57:59 -0400 GMT (22-Apr-20, 22:57 +0700 GMT),
Paul Van Noord wrote:

 Over here it is 10 minutes. Please try opening the mail again and
 re-read, maybe edit, when the time hits and TB sends messages. It will
 send this message, even though you have re-opened it and are editing
 it.

>>> Can confirm. Is this an error? I've been using TheBat! since very late
>>> v8 builds, maybe behaviour was different earlier on.

TF>> I consider it an error (bug), because TB does something the user does
TF>> clearly not intend. If he wanted the original version to be sent, he
TF>> wouldn't have opened it again in th editor.

TF>> Kindly support https://bt.ritlabs.com/view.php?id=1998

> Did it.

Thanks. I am putting this reply in the Outbox now, testing the new
18.MSI. Then, I will open it again and wait.

This is the edited version.

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.18 (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-22 Thread Paul Van Noord
4/22/2020  11:59 AM

Hi The,

On 4/22/2020 The Bat Beta wrote:

TF> Hello Paul,

TF> On Tue, 21 Apr 2020 08:23:00 -0400 GMT (21-Apr-20, 19:23 +0700 GMT),
TF> Paul Van Noord wrote:

 Messages used to be "parked" when opened again from the Outbox in the
 editor, to prevent this problem. That's how it should be.

G>>> My account fetches all 2 minutes.
G>>> If i put a mail in Outbox, reopen it, change something, the Autosave
G>>> feature (Editor settings, after 60 sec) detects changes and sets to Parked.
G>>> So no previous mail can be sent from Outbox.

G>>> But you are right, for better usability the message should be switched
G>>> to Parked if opened in editor.

G>>> Please report that as a bug to The Bat! bugtracker.

>> Saving  an edited Outbox message will Park it... It does Not Park while
>> editing! You and Thomas are correct. I support the bugtracker entry.

TF> Here you go: https://bt.ritlabs.com/view.php?id=1998 Thank you very
TF> much.

Done.

- --
Paul

32bit TB 9.1.16  Windows 7 Pro 7600 
No IMAP  No OTFE



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-22 Thread Paul Van Noord
4/22/2020  11:57 AM

Hi The,

On 4/22/2020 The Bat Beta wrote:

TF> Hello Andrew,

TF> On Tue, 21 Apr 2020 20:46:47 +0930 GMT (21-Apr-20, 18:16 +0700 GMT),
TF> Andrew Savchenko wrote:

>>> Over here it is 10 minutes. Please try opening the mail again and
>>> re-read, maybe edit, when the time hits and TB sends messages. It will
>>> send this message, even though you have re-opened it and are editing
>>> it.

>> Can confirm. Is this an error? I've been using TheBat! since very late
>> v8 builds, maybe behaviour was different earlier on.

TF> I consider it an error (bug), because TB does something the user does
TF> clearly not intend. If he wanted the original version to be sent, he
TF> wouldn't have opened it again in th editor.

TF> Kindly support https://bt.ritlabs.com/view.php?id=1998

Did it.

- --
Paul

32bit TB 9.1.16  Windows 7 Pro 7600 
No IMAP  No OTFE



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-22 Thread Dimitar Tomov
On Wednesday, April 22, 2020, 8:24:16 AM, you wrote:

> Hello Dimitar,

> On Tue, 21 Apr 2020 14:15:13 +0300 GMT (21-Apr-20, 18:15 +0700 GMT),
> Dimitar Tomov wrote:

>>> Steps to reproduce:

>>> I have the account set to send/receive every 10 minutes.

>>> Compose a message.
>>> Put it into the Outbox
>>> Open it again from the Outbox, for editing.
>>> While it is being edited, the previous version will be sent

>>>  ***

>>> Messages used to be "parked" when opened again from the Outbox in the
>>> editor, to prevent this problem. That's how it should be.

>>> Any confirmations?

>> I cannot confirm. I have combined delivery ON. When I "put in outbox",
>> the message is not parked. When I open it for editing, it is still not
>> parked. But if I press "receive" it does not get sent. If I press
>> "send queued", I get "nothing to send". This is on smtp account.

> Maybe it only happens when sending automatically. By the way, do you
> use IMAP or POP?

> --

> Cheers,
> Thomas.

> Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
> under Windows 10.0 Build 18362


> 
> 'Using TBBETA' information:
> http://www.silverstones.com/thebat/TBUDLInfo.html


Dear Thomas,

This is a POP account. I did not test on IMAP.

Best regards,
Dimitar  mailto:dito...@gmail.com
TheBat! 9.1.12 Pro (64-bit, non-OTFE) on Windows 10.0 14393 



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-22 Thread Thomas Fernandez
Hello Gwen,

On Wed, 22 Apr 2020 08:04:54 +0200 GMT (22-Apr-20, 13:04 +0700 GMT),
Gwen wrote:

>> Kindly support https://bt.ritlabs.com/view.php?id=1998

> Confirmed in tracker.

Thanks.

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-22 Thread Thomas Fernandez
Hello Andrew,

On Wed, 22 Apr 2020 15:04:47 +0930 GMT (22-Apr-20, 12:34 +0700 GMT),
Andrew Savchenko wrote:

>> Kindly support https://bt.ritlabs.com/view.php?id=1998

> Kindly supported. Also, added the "drafts" tag.

Thanks., I don't actually know what the tags are for.

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-22 Thread Gwen
Hello Thomas,

On Wed, 22 Apr 2020, at 12:30:03 [GMT +0700] (which was 07:30 where I
live) Thomas wrote:

> Kindly support https://bt.ritlabs.com/view.php?id=1998

Confirmed in tracker.

-- 
Regards
Gwen

Using The Bat! Version 9.1.16.3 (BETA) (32-bit) on Windows 10.0 (Build 18363 )

pgpOvEoAU_leN.pgp
Description: PGP signature

'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-21 Thread Andrew Savchenko
Hello Thomas,

Wednesday, April 22, 2020, 3:00:03 PM, you wrote:

> Kindly support https://bt.ritlabs.com/view.php?id=1998

Kindly supported. Also, added the "drafts" tag.


-- 
Regards,
A



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello Gwen,

On Tue, 21 Apr 2020 15:19:08 +0200 GMT (21-Apr-20, 20:19 +0700 GMT),
Gwen wrote:

>> Steps to reproduce:
>>
>> I have the account set to send/receive every 10 minutes.
>>
>> Compose a message.
>> Put it into the Outbox
>> Open it again from the Outbox, for editing.
>> While it is being edited, the previous version will be sent
>>
>>  ***
>>
>> Messages used to be "parked" when opened again from the Outbox in the
>> editor, to prevent this problem. That's how it should be.
>>
>> Any confirmations?

> Please report to bugtracker, i will confirm it.

Here you go: https://bt.ritlabs.com/view.php?id=1998

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello Miroslav,

On Tue, 21 Apr 2020 14:40:56 +0200 GMT (21-Apr-20, 19:40 +0700 GMT),
Miroslav Florensen wrote:

> Hello Paul,

 And that is a bug.

> yes, it's a showstopper!

Kindly support https://bt.ritlabs.com/view.php?id=1998

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello Paul,

On Tue, 21 Apr 2020 08:23:00 -0400 GMT (21-Apr-20, 19:23 +0700 GMT),
Paul Van Noord wrote:

>>> Messages used to be "parked" when opened again from the Outbox in the
>>> editor, to prevent this problem. That's how it should be.

G>> My account fetches all 2 minutes.
G>> If i put a mail in Outbox, reopen it, change something, the Autosave
G>> feature (Editor settings, after 60 sec) detects changes and sets to Parked.
G>> So no previous mail can be sent from Outbox.

G>> But you are right, for better usability the message should be switched
G>> to Parked if opened in editor.

G>> Please report that as a bug to The Bat! bugtracker.

> Saving  an edited Outbox message will Park it... It does Not Park while
> editing! You and Thomas are correct. I support the bugtracker entry.

Here you go: https://bt.ritlabs.com/view.php?id=1998 Thank you very
much.

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello Andrew,

On Tue, 21 Apr 2020 20:46:47 +0930 GMT (21-Apr-20, 18:16 +0700 GMT),
Andrew Savchenko wrote:

>> Over here it is 10 minutes. Please try opening the mail again and
>> re-read, maybe edit, when the time hits and TB sends messages. It will
>> send this message, even though you have re-opened it and are editing
>> it.

> Can confirm. Is this an error? I've been using TheBat! since very late
> v8 builds, maybe behaviour was different earlier on.

I consider it an error (bug), because TB does something the user does
clearly not intend. If he wanted the original version to be sent, he
wouldn't have opened it again in th editor.

Kindly support https://bt.ritlabs.com/view.php?id=1998

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello Viktor,

On Tue, 21 Apr 2020 19:33:16 +0200 GMT (22-Apr-20, 0:33 +0700 GMT),
Viktor Kabelac wrote:

> Hello Thomas,

> Tuesday, April 21, 2020, 9:03:43 AM, you wrote:
>> Steps to reproduce:
>> I have the account set to send/receive every 10 minutes.
>> Compose a message.
>> Put it into the Outbox
>> Open it again from the Outbox, for editing.
>> While it is being edited, the previous version will be sent

> Doesn't happen to me, similar to Dimitar (and on IMAP, too):
> - I have set my TheBat! to delayed delivery +1 minute
> (I had difficulty finding that setting in the editor window and still
> haven't found any persistent setting for that. Also creating a custom delay
> doesn't let it show in the manu immediately...kinda counter-intuitive to me
> all in all)

> Still:
> - I compose a message, have it saved to Outbox
> - I reopen the message
> - Message is not parked, it has a clock symbol
> - Message doesn't get send "under my hands" - not by scheduled
> sending and not by manual Alt-F2 on the main window

Maybe IMAP handles this differently, I don't have a clock symbol.

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello Dimitar,

On Tue, 21 Apr 2020 14:15:13 +0300 GMT (21-Apr-20, 18:15 +0700 GMT),
Dimitar Tomov wrote:

>> Steps to reproduce:

>> I have the account set to send/receive every 10 minutes.

>> Compose a message.
>> Put it into the Outbox
>> Open it again from the Outbox, for editing.
>> While it is being edited, the previous version will be sent

>>  ***

>> Messages used to be "parked" when opened again from the Outbox in the
>> editor, to prevent this problem. That's how it should be.

>> Any confirmations?

> I cannot confirm. I have combined delivery ON. When I "put in outbox",
> the message is not parked. When I open it for editing, it is still not
> parked. But if I press "receive" it does not get sent. If I press
> "send queued", I get "nothing to send". This is on smtp account.

Maybe it only happens when sending automatically. By the way, do you
use IMAP or POP?

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-21 Thread Paul Van Noord
4/21/2020  1:46 PM

Hi Viktor,

On 4/21/2020 you wrote:

VK> Still:
VK> - I compose a message, have it saved to Outbox
VK> - I reopen the message
VK> - Message is not parked, it has a clock symbol
VK> - Message doesn't get send "under my hands" - not by scheduled
VK> sending and not by manual Alt-F2 on the main window

Is this also true using the latest beta:  9.1.16.3 ?
- --
Paul

32bit TB 9.1.16  Windows 7 Pro 7600 
No IMAP  No OTFE



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Viktor Kabelac
Hello Thomas,

Tuesday, April 21, 2020, 9:03:43 AM, you wrote:
> Steps to reproduce:
> I have the account set to send/receive every 10 minutes.
> Compose a message.
> Put it into the Outbox
> Open it again from the Outbox, for editing.
> While it is being edited, the previous version will be sent

Doesn't happen to me, similar to Dimitar (and on IMAP, too):
- I have set my TheBat! to delayed delivery +1 minute
(I had difficulty finding that setting in the editor window and still
haven't found any persistent setting for that. Also creating a custom delay
doesn't let it show in the manu immediately...kinda counter-intuitive to me
all in all)

Still:
- I compose a message, have it saved to Outbox
- I reopen the message
- Message is not parked, it has a clock symbol
- Message doesn't get send "under my hands" - not by scheduled sending and not 
by manual Alt-F2 on the main window


-- 
Cheers
 Viktor Kabelacmailto:tbbeta-l...@kabelac.cz
TheBat! 9.1.14.2 (BETA) Pro (x32, no OTFE) on Windows 10.0 x64 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-21 Thread Paul Van Noord
4/21/2020  11:19 AM

Hi The,

On 4/21/2020 The Bat Beta wrote:

M> Hello Paul,

>> After 30 years it is not "normal".

M> A  few  days  ago,  in a different thread, you claimed you had 32 years
M> experience  with  TB. Am I  correct in thinking that you started using
M> TB before Ritlabs was founded?

No, you are correct. It should have been 22 years...
- --
Paul

32bit TB 9.1.16  Windows 7 Pro 7600 
No IMAP  No OTFE



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread MAU
Hello Paul,

> After 30 years it is not "normal".

A  few  days  ago,  in a different thread, you claimed you had 32 years
experience  with  TB. Am I  correct in thinking that you started using
TB before Ritlabs was founded?


-- 
Best regards,

Miguel A. Urech (Els Poblets (Alicante - Spain)
Using The Bat!  Version 9.1.16 (64-bit) on Windows 10.0  18363




'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Gwen
Hello Thomas,

On Tue, 21 Apr 2020, at 14:03:43 [GMT +0700] (which was 09:03 where I
live) Thomas wrote:

> Steps to reproduce:
>
> I have the account set to send/receive every 10 minutes.
>
> Compose a message.
> Put it into the Outbox
> Open it again from the Outbox, for editing.
> While it is being edited, the previous version will be sent
>
>  ***
>
> Messages used to be "parked" when opened again from the Outbox in the
> editor, to prevent this problem. That's how it should be.
>
> Any confirmations?

Please report to bugtracker, i will confirm it.

-- 
Regards
Gwen

Using The Bat! Version 9.1.16.3 (BETA) (32-bit) on Windows 10.0 (Build 18363 )

pgppy8hkh1TR4.pgp
Description: PGP signature

'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Miroslav Florensen
Hello Paul,

>>> And that is a bug.

yes, it's a showstopper!

--
Best wishes
Miroslav

BAT-MAIL.DE.VU - http://thebat.bplaced.net



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-21 Thread Paul Van Noord
4/21/2020  8:26 AM

Hi The,

On 4/21/2020 The Bat Beta wrote:

M> Hello Thomas,

>> I click with the mouse on the "Put message in Outbox" icon. And the
>> message doese get put into the Outbox. When they then open it again,
>> it is not "parked", i.e. the version that was put into the Outbox is
>> sent even though I am editing it again.
>>
>> And that is a bug.

M> I  will  try  to  confirm  it later, but I don't think it is a bug but
M> normal  behaviour.  Like Zann suggests in his message, I think you may
M> be  confusing  "putting  in  the  Outbox"  with "saving as Draft", the
M> difference  being that the first does not park the message (that's why
M> it  will be sent with a combined delivery), while saving as draft does
M> park it and will not be sent until you unpark it. That's what I think,
M> but I am not 100% sure.

After 30 years it is not "normal".

- --
Paul

32bit TB 9.1.16  Windows 7 Pro 7600 
No IMAP  No OTFE



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Paul Van Noord
4/21/2020  8:23 AM

Hi The,

On 4/21/2020 The Bat Beta wrote:

TF> Hello TBBETA,

TF> Steps to reproduce:

TF> I have the account set to send/receive every 10 minutes.

TF> Compose a message.
TF> Put it into the Outbox
TF> Open it again from the Outbox, for editing.
TF> While it is being edited, the previous version will be sent

TF>  ***

TF> Messages used to be "parked" when opened again from the Outbox in the
TF> editor, to prevent this problem. That's how it should be.

TF> Any confirmations?

Agreed

- --
Paul

32bit TB 9.1.16  Windows 7 Pro 7600 
No IMAP  No OTFE



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-21 Thread Paul Van Noord
4/21/2020  8:19 AM

Hi The,

On 4/21/2020 The Bat Beta wrote:

G> Hello The,

G> On Tue, 21 Apr 2020, at 14:03:43 [GMT +0700] (which was 09:03 where I
G> live) Thomas wrote:

>> Messages used to be "parked" when opened again from the Outbox in the
>> editor, to prevent this problem. That's how it should be.

G> My account fetches all 2 minutes.
G> If i put a mail in Outbox, reopen it, change something, the Autosave
G> feature (Editor settings, after 60 sec) detects changes and sets to Parked.
G> So no previous mail can be sent from Outbox.

G> But you are right, for better usability the message should be switched
G> to Parked if opened in editor.

G> Please report that as a bug to The Bat! bugtracker.

Saving  an edited Outbox message will Park it... It does Not Park while
editing! You and Thomas are correct. I support the bugtracker entry.

- --
Paul

32bit TB 9.1.16  Windows 7 Pro 7600 
No IMAP  No OTFE



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Gwen
Hello The,

On Tue, 21 Apr 2020, at 14:03:43 [GMT +0700] (which was 09:03 where I
live) Thomas wrote:

> I have the account set to send/receive every 10 minutes.
>
> Compose a message.
> Put it into the Outbox
> Open it again from the Outbox, for editing.
> While it is being edited, the previous version will be sent
>
>  ***
>
> Messages used to be "parked" when opened again from the Outbox in the
> editor, to prevent this problem. That's how it should be.

My account fetches all 2 minutes.
If i put a mail in Outbox, reopen it, change something, the Autosave
feature (Editor settings, after 60 sec) detects changes and sets to Parked.
So no previous mail can be sent from Outbox.

But you are right, for better usability the message should be switched
to Parked if opened in editor.

Please report that as a bug to The Bat! bugtracker.

-- 
Regards
Gwen

Using The Bat! Version 9.1.16.3 (BETA) (32-bit) on Windows 10.0 (Build 18363 )

pgpcQ8DEpfxz8.pgp
Description: PGP signature

'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-21 Thread Andrew Savchenko
Hello Thomas,

Tuesday, April 21, 2020, 7:49:28 PM, you wrote:

> Over here it is 10 minutes. Please try opening the mail again and
> re-read, maybe edit, when the time hits and TB sends messages. It will
> send this message, even though you have re-opened it and are editing
> it.

Can confirm. Is this an error? I've been using TheBat! since very late
v8 builds, maybe behaviour was different earlier on.


-- 
Regards,
A



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Dimitar Tomov
On Tuesday, April 21, 2020, 10:03:43 AM, you wrote:

> Hello TBBETA,

> Steps to reproduce:

> I have the account set to send/receive every 10 minutes.

> Compose a message.
> Put it into the Outbox
> Open it again from the Outbox, for editing.
> While it is being edited, the previous version will be sent

>  ***

> Messages used to be "parked" when opened again from the Outbox in the
> editor, to prevent this problem. That's how it should be.

> Any confirmations?

> --

> Cheers,
> Thomas.

> Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
> under Windows 10.0 Build 18362


> 
> 'Using TBBETA' information:
> http://www.silverstones.com/thebat/TBUDLInfo.html


Dear Thomas,

I cannot confirm. I have combined delivery ON. When I "put in outbox",
the message is not parked. When I open it for editing, it is still not
parked. But if I press "receive" it does not get sent. If I press
"send queued", I get "nothing to send". This is on smtp account.

Best regards,
Dimitar  mailto:dito...@gmail.com
TheBat! 9.1.12 Pro (64-bit, non-OTFE) on Windows 10.0 14393 



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello Andrew,

On Tue, 21 Apr 2020 18:38:09 +0930 GMT (21-Apr-20, 16:08 +0700 GMT),
Andrew Savchenko wrote:

> Hello Thomas,

> Tuesday, April 21, 2020, 6:28:40 PM, you wrote:

>> And that is a bug. I only need someone to confirm that this is not
>> unique to my machine, so that I can open a bug report. Please give it
>> a try.

> For what it worth - I have "delayed delivery" setup so that message is
> being put into the Outbox for a minute before being actually sent.

> This allows 2nd chance to re-read what is written and prevents from
> sending unfinished letter by CTRL+Enter.

Over here it is 10 minutes. Please try opening the mail again and
re-read, maybe edit, when the time hits and TB sends messages. It will
send this message, even though you have re-opened it and are editing
it.

> This function works as expected and I do not have any trouble with it.

It used to work correctly, naemly that it won't be sent while being
edited. I do haev trouble with a message being sent, while I
re-opened it.

Just as a question: You have delayed delivery so that you can re-read
it, right? What if you then notice that you want to change something?
Do you still want the unchanged message to be sent?

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello MAU,

On Tue, 21 Apr 2020 11:13:09 +0200 GMT (21-Apr-20, 16:13 +0700 GMT),
MAU wrote:

> Hello Thomas,

>> I click with the mouse on the "Put message in Outbox" icon. And the
>> message doese get put into the Outbox. When they then open it again,
>> it is not "parked", i.e. the version that was put into the Outbox is
>> sent even though I am editing it again.
>>
>> And that is a bug.

> I  will  try  to  confirm  it later, but I don't think it is a bug but
> normal  behaviour.  Like Zann suggests in his message, I think you may
> be  confusing  "putting  in  the  Outbox"  with "saving as Draft", the
> difference  being that the first does not park the message (that's why
> it  will be sent with a combined delivery), while saving as draft does
> park it and will not be sent until you unpark it. That's what I think,
> but I am not 100% sure.

No, I do not make that mistake. I use "save as draft" when I don't
want to send the message now, or when it is unfinished. When I click
on "put in Outbox", I mean it.

And a moment later, I change my mind and re-open it. No, it does not
make sense to me that the message is sent if it is re-openend and I am
obviously working on it again.

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread MAU
Hello Thomas,

> I click with the mouse on the "Put message in Outbox" icon. And the
> message doese get put into the Outbox. When they then open it again,
> it is not "parked", i.e. the version that was put into the Outbox is
> sent even though I am editing it again.
>
> And that is a bug.

I  will  try  to  confirm  it later, but I don't think it is a bug but
normal  behaviour.  Like Zann suggests in his message, I think you may
be  confusing  "putting  in  the  Outbox"  with "saving as Draft", the
difference  being that the first does not park the message (that's why
it  will be sent with a combined delivery), while saving as draft does
park it and will not be sent until you unpark it. That's what I think,
but I am not 100% sure.


-- 
Best regards,

Miguel A. Urech (Els Poblets (Alicante - Spain)
Using The Bat!  Version 9.1.16 (64-bit) on Windows 10.0  18363



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re[2]: Message is being sent while being edited

2020-04-21 Thread Andrew Savchenko
Hello Thomas,

Tuesday, April 21, 2020, 6:28:40 PM, you wrote:

> And that is a bug. I only need someone to confirm that this is not
> unique to my machine, so that I can open a bug report. Please give it
> a try.

For what it worth - I have "delayed delivery" setup so that message is 
being put into the Outbox for a minute before being actually sent.

This allows 2nd chance to re-read what is written and prevents from 
sending unfinished letter by CTRL+Enter.

This function works as expected and I do not have any trouble with it.


-- 
Regards,
A



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello Zann,

On Tue, 21 Apr 2020 00:54:14 -0700 GMT (21-Apr-20, 14:54 +0700 GMT),
Zann wrote:

> Are you sure you are not confusing putting in the outbox (Shift-F2)
> with saving as draft (Alt-F2)? Turning OFF Combined delivery should help too?

I do not want to turn off combined delivery. Why would I? It should
not have anything to do with it,

I click with the mouse on the "Put message in Outbox" icon. And the
message doese get put into the Outbox. When they then open it again,
it is not "parked", i.e. the version that was put into the Outbox is
sent even though I am editing it again.

And that is a bug. I only need someone to confirm that this is not
unique to my machine, so that I can open a bug report. Please give it
a try.

I am not looking for workarounds - I am now "parking" them manually in
the Outbox - I want to report a bug, so that it can be fixed.

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Re: Message is being sent while being edited

2020-04-21 Thread Zann
Hi Thomas,

Are you sure you are not confusing putting in the outbox (Shift-F2) with saving 
as draft (Alt-F2)? Turning OFF Combined delivery should help too?

-Z.



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html


Message is being sent while being edited

2020-04-21 Thread Thomas Fernandez
Hello TBBETA,

Steps to reproduce:

I have the account set to send/receive every 10 minutes.

Compose a message.
Put it into the Outbox
Open it again from the Outbox, for editing.
While it is being edited, the previous version will be sent

 ***

Messages used to be "parked" when opened again from the Outbox in the
editor, to prevent this problem. That's how it should be.

Any confirmations?

--

Cheers,
Thomas.

Message reply created with The Bat! Version 9.1.16.3 (BETA) (64-bit)
under Windows 10.0 Build 18362



'Using TBBETA' information:
http://www.silverstones.com/thebat/TBUDLInfo.html