npppd: crashes/random behaviour due to non-zeroed struct

2014-05-07 Thread Anders Berggren
Hi, I had a problem where npppd sometimes started with random configurations, and resolved it by callocing the struct in subject. Cheers! Anders --- /usr/src/usr.sbin/npppd/npppd/parse.y.orig Wed May 7 09:25:49 2014 +++ /usr/src/usr.sbin/npppd/npppd/parse.y Wed May 7 09:26:20 2014 @@

Re: [Patch fuse] fusefs_link return code

2014-05-07 Thread Sylvestre Gallon
On Mon, May 05, 2014 at 08:40:10PM +0800, Helg wrote: This patch fixes a bug where fusefs_link does not return an error on subsequent invocations if a fuse filesystem does not implement hard links. As an aside, returning ENOSYS in this case is contrary to the link(2) man page (and different

Re: npppd: crashes/random behaviour due to non-zeroed struct

2014-05-07 Thread Anders Berggren
I had a problem where npppd sometimes started with random configurations, and resolved it by callocing the struct in subject. Thanks, committed. Thank you, much appreciated! I don't think this causes a crash. Did it? It most likely exited normally because of an invalid (because of the

[PATCH 0/2] libssl pqueue simplify allocations

2014-05-07 Thread Dimitris Papastamos
Hi all, * No need to check for NULL before free. * No need to cast the return value of the allocation functions. * Do not use malloc() + memset(), simply use calloc() Tested against the regression tests for pqueue. ok? === ---

[PATCH 1/2] libssl simplify pqueue_find()

2014-05-07 Thread Dimitris Papastamos
Hi, Simplify pqueue_find() to the very essential bits. This change should exhibit no functional changes or side-effects. Tested against the regression tests for pqueue. ok? === --- pqueue.orig/pqueue.c +++ pqueue/pqueue.c @@

[PATCH 2/2] libssl remove magic number in pqueue.c

2014-05-07 Thread Dimitris Papastamos
Hi, * Use sizeof() instead of hardcoding the size. Tested against the regression tests for pqueue. ok? === --- pqueue.orig/pqueue.c +++ pqueue/pqueue.c @@ -160,7 +160,8 @@ pqueue_find(pqueue_s *pq, unsigned char pitem

Remove p2p loopback hack in nd6_rtrequest()

2014-05-07 Thread Martin Pieuchot
Diff below stops abusing nd6_rtrequest() for loopback interfaces, which means we can remove the special hack below and reduce the differences with arp_rtrequest(). This diff introduces two changes in the inet6 routing table, but they should not matter. The first one is that the gateway of the

Re: Remove ln -F

2014-05-07 Thread Ingo Schwarze
Hi, Philip Guenther wrote on Tue, May 06, 2014 at 09:35:18AM -0700: On Tue, May 6, 2014 at 9:18 AM, Kenneth Westerback wrote: On 6 May 2014 11:45, Ingo Schwarze schwa...@usta.de wrote: if somebody wants to commit, ok schwarze@. Otherwise, i'm accepting OKs. See inline for a note on the

[PATCH]: Convert select() to poll() in amd/info_hes.c

2014-05-07 Thread Dimitris Papastamos
Hi, This piece of code now uses poll() instead of select(). I have not got round to test this yet, but I will as soon as I have a working setup. Thoughts? === RCS file: /cvs/src/usr.sbin/amd/amd/info_hes.c,v retrieving revision

Re: Support for LC_TIME

2014-05-07 Thread Ingo Schwarze
Hi, POSIX doesn't require support for any locales except POSIX and C. While LC_CTYPE and LC_COLLATE make some sense, LC_MONETARY, LC_NUMERIC, and LC_TIME are badly overengineered, pointless bloat, causing nothing but surprising, erratic behaviour and portability problems when trying to parse

Re: [PATCH] comparison between signed and unsigned in rcs

2014-05-07 Thread Fritjof Bornebusch
On Tue, May 06, 2014 at 10:57:57PM +0200, Fritjof Bornebusch wrote: Hi tech, if I compile rcs, gcc prints a few warnings like this: - comparison between signed and unsigned - signed and unsigned type in conditional expression I'm not quite sure if the typecasts are at the correct place,

Re: [PATCH] comparison between signed and unsigned in rcs

2014-05-07 Thread Jérémie Courrèges-Anglas
Fritjof Bornebusch frit...@alokat.org writes: [...] Does no one want to check the diff and give me some feedback? Regardless of the content of your diff, the date of your mail was: Date: Tue, 6 May 2014 22:57:57 +0200 I doubt there are developers that are paid full-time to improve rcs,

Re: [Patch] Add router alert option to igmp packets

2014-05-07 Thread Jérémie Courrèges-Anglas
Martin Pieuchot mpieuc...@nolizard.org writes: Hello Florian, On 26/04/14(Sat) 22:22, Florian Riehm wrote: On 04/26/14 20:35, Alexander Bluhm wrote: /* * To avoid byte-swapping the same value over and over again. */ FreeBSD has code matching this

Re: [PATCH] comparison between signed and unsigned in rcs

2014-05-07 Thread Fritjof Bornebusch
On Wed, May 07, 2014 at 08:05:35PM +0200, J??r??mie Courr??ges-Anglas wrote: Fritjof Bornebusch frit...@alokat.org writes: [...] Does no one want to check the diff and give me some feedback? Regardless of the content of your diff, the date of your mail was: Date: Tue, 6 May 2014

Re: zless is less

2014-05-07 Thread Ingo Schwarze
Hi Vadim, Vadim Zhukov wrote on Sat, May 03, 2014 at 05:44:26PM +0400: Just run into the following issue with zmore/zless: if you have PAGER envvar set, it's no matter whatever you'll call, zmore or zless - it'll always run $PAGER. The problem is that I have PAGER=/usr/bin/more but

Re: [PATCH]: Convert select() to poll() in amd/info_hes.c

2014-05-07 Thread patrick keshishian
On Wed, May 07, 2014 at 02:47:32PM +0100, Dimitris Papastamos wrote: Hi, This piece of code now uses poll() instead of select(). I have not got round to test this yet, but I will as soon as I have a working setup. Thoughts?

[PATCH] rcs void casts

2014-05-07 Thread Fritjof Bornebusch
Hi tech, there are a few void casts in rcs. But I have a question about that. Are these casts really necessary? I've read that the compiler warns, because of unused variables. But no compiler warnings about that on amd64. That's why I just added this small diff, in order to get feedback if the

Re: [PATCH] rcs void casts

2014-05-07 Thread Ingo Schwarze
Hi Fritjof, Fritjof Bornebusch wrote on Wed, May 07, 2014 at 10:32:05PM +0200: there are a few void casts in rcs. But I have a question about that. Are these casts really necessary? No, they are not necessary. I've read that the compiler warns, because of unused variables. But no compiler

Re: [PATCH] rcs void casts

2014-05-07 Thread Fritjof Bornebusch
On Wed, May 07, 2014 at 10:58:03PM +0200, Ingo Schwarze wrote: Hi Fritjof, Fritjof Bornebusch wrote on Wed, May 07, 2014 at 10:32:05PM +0200: there are a few void casts in rcs. But I have a question about that. Are these casts really necessary? No, they are not necessary. I've

Re: Support for LC_TIME

2014-05-07 Thread Antoine Jacoutot
On Wed, May 07, 2014 at 07:44:51PM +0200, Ingo Schwarze wrote: Hi, POSIX doesn't require support for any locales except POSIX and C. While LC_CTYPE and LC_COLLATE make some sense, LC_MONETARY, LC_NUMERIC, and LC_TIME are badly overengineered, pointless bloat, causing nothing but

Re: Fix loop test in vipw

2014-05-07 Thread Ingo Schwarze
Hi Ben, Ben Cornett wrote on Mon, Apr 28, 2014 at 08:49:36PM +: I agree that one probably never gets a short write there in practice, but if there is going to be a loop, it may as well be correct. That's what i think, too. So i finally committed your patch, thanks for sending it. Yours,

[PATCH] rcs merge

2014-05-07 Thread Fritjof Bornebusch
Hi tech, I think labels = 3 is more readable than 3 = labels. fritjof Index: merge.c === RCS file: /cvs/src/usr.bin/rcs/merge.c,v retrieving revision 1.7 diff -u -p -r1.7 merge.c --- merge.c 23 Jul 2010 21:46:05 - 1.7