Re: Stop using direct syscall(2) from perl(1)

2023-07-17 Thread George Koehler
On Sun, 9 Jul 2023 13:29:58 -0700 Andrew Hewus Fresh wrote: > + case SYS_truncate: > + { > + const char * path = va_arg(args, const char *); > + off_t length = va_arg(args, off_t); > + ret = truncate(path, length); > + } > +

Re: vfs: drop proc from VOP_OPEN

2023-07-17 Thread Thordur Bjornsson
Note, this opens up pending items for cleanup, from my notes: - fuse_file_open (into fb_setup) - nfs_vinvalbuf (and vinvalbuf itself). I'm skeptical of touching the latter until I have (again) some facsimile of the setup that lives in theo's basement :) On Sat, Jul 15, 2023 at 02:20:36PM +0200,

Re: tcp lro by default, call for testing

2023-07-17 Thread Alexander Bluhm
On Mon, Jul 10, 2023 at 02:07:01PM +0200, Jan Klemkow wrote: > On Sat, Jul 08, 2023 at 05:15:26PM +0300, Alexander Bluhm wrote: > > I am not aware of any more limitations when enabling LRO for TCP > > in the network drivers. The feature allows to receive agregated > > packets larger than the MTU.

vfs: drop proc from VOP_OPEN

2023-07-17 Thread Thordur Bjornsson
First of a few. Many thanks to mpi@ for adding the curproc assert's! Two questions: - NOCRED: Best this should just be NULL ? - FSCRED: This is only AFAICT used for mounts Not 100% clear, but this could perhaps be done away with at the loss of some metadata (it just forces spec_open to open

Re: deadfs cleanup

2023-07-17 Thread Thordur Bjornsson
ping beck@ stacking vp->v_lock (rwlock, couldn't bring myself to call it interlock) diffs ontop of this to kill v_id and VXLOCK. Could use an eyeball or two :) On Tue, Jul 11, 2023 at 09:34:01PM +0200, thib4711 wrote: > deadfs cleanup > > chkvnlock() is useless, since deadfs vops are only ever

Re: [PATCH] When appropriate, replace the waitpid calls with wait in sbin/init/init.c

2023-07-17 Thread rhl120
I understand that wait and waitpid are only wrappers around wait4 but I was talking about the arguments passed to the wrappers themselves (aka 3 for waitpid and 1 for wait) but I understand your decision, thanks for the feedback. Have a nice day.

Re: [PATCH] When appropriate, replace the waitpid calls with wait in sbin/init/init.c

2023-07-17 Thread Theo de Raadt
rhl120 wrote: > Hello, this commit fixes nothing. To me it is just an instance of using > the right tool for the right job. Sorry, you are incorrect. > I could also argue that there is a > performance improvement (because the call passes less arguments) but > that is probably negligible.

Re: [PATCH] When appropriate, replace the waitpid calls with wait in sbin/init/init.c

2023-07-17 Thread rhl120
Hello, this commit fixes nothing. To me it is just an instance of using the right tool for the right job. I could also argue that there is a performance improvement (because the call passes less arguments) but that is probably negligible. I personally would not consider the modified code to be

Re: [PATCH] When appropriate, replace the waitpid calls with wait in sbin/init/init.c

2023-07-17 Thread Theo de Raadt
What are you fixing by making this less precise? rhl120 wrote: > Hello, while browsing the source code of init, I found a couple of calls to > waitpid which, I believe, could be replaced with wait(NULL). As far as I can > tell lib/libc/gen/wait.c and lib/libc/gen/waitpid.c backup my belief

Re: vfs: drop unnecessary cache_purge()s

2023-07-17 Thread Thordur Bjornsson
On Mon, Jul 17, 2023 at 11:38:49AM +0200, Sebastien Marie wrote: > On Sat, Jul 15, 2023 at 09:21:40AM +0200, Thordur Bjornsson wrote: > > yes, vclean() will call cache_purge() after calling VOP_RECLAIM(). so we > ended-up > to have called cache_purge() several times. > > but the vnode isn't in

Re: vnode: drop comment, nonsensical where it is

2023-07-17 Thread Sebastien Marie
On Mon, Jul 17, 2023 at 11:40:55AM +0200, Claudio Jeker wrote: > On Wed, Jul 12, 2023 at 12:25:19PM +0200, thib4711 wrote: > > The line comment in struct vnode is fine; > > > > diff --git sys/sys/vnode.h sys/sys/vnode.h > > index 30787afddd8..b2f0fa4b60c 100644 > > --- sys/sys/vnode.h > > +++

Re: vnode: drop comment, nonsensical where it is

2023-07-17 Thread Claudio Jeker
On Wed, Jul 12, 2023 at 12:25:19PM +0200, thib4711 wrote: > The line comment in struct vnode is fine; > > diff --git sys/sys/vnode.h sys/sys/vnode.h > index 30787afddd8..b2f0fa4b60c 100644 > --- sys/sys/vnode.h > +++ sys/sys/vnode.h > @@ -74,12 +74,7 @@ enum vtagtype { > "unused",

Re: vfs: drop unnecessary cache_purge()s

2023-07-17 Thread Sebastien Marie
On Sat, Jul 15, 2023 at 09:21:40AM +0200, Thordur Bjornsson wrote: > VOP_RECLAIM is only ever called from vclean() to cleanup fs dependent > data, and vclean() calls cache_purge(). > > Makes all of the reclaim implementations the same in this regard. for now, I am still unsure about the change.

Re: vfs: drop a bunch of cast macros

2023-07-17 Thread Claudio Jeker
On Mon, Jul 17, 2023 at 11:05:03AM +0200, Sebastien Marie wrote: > On Wed, Jul 12, 2023 at 12:26:01PM +0200, thib4711 wrote: > > make it obvious in the vfsops assignment that an op isnt supported. > > I agree that it is more readable. > > ok semarie@ OK claudio@ as well. Semarie can you commit

Re: vfs: drop a bunch of cast macros

2023-07-17 Thread Sebastien Marie
On Wed, Jul 12, 2023 at 12:26:01PM +0200, thib4711 wrote: > make it obvious in the vfsops assignment that an op isnt supported. I agree that it is more readable. ok semarie@ thanks. -- Sebastien Marie > diff --git sys/isofs/cd9660/cd9660_extern.h sys/isofs/cd9660/cd9660_extern.h > index

[PATCH] When appropriate, replace the waitpid calls with wait in sbin/init/init.c

2023-07-17 Thread rhl120
Hello, while browsing the source code of init, I found a couple of calls to waitpid which, I believe, could be replaced with wait(NULL). As far as I can tell lib/libc/gen/wait.c and lib/libc/gen/waitpid.c backup my belief but on the other hand I am very new to this stuff so I may be wrong so