Re: iked: more ibuf cleanup

2023-07-27 Thread Theo Buehler
On Thu, Jul 27, 2023 at 03:31:32PM +0200, Claudio Jeker wrote: > Use ibuf_data() instead of direct access to ibuf->buf. > In some cases use ibuf_add_buf(). ok > - print_hex(t->buf, 0, ibuf_length(t)); > + print_hex(ibuf_data(t), 0, ibuf_length(t)); There's a lot of these. Maybe worth

Re: iked: more ibuf cleanup

2023-07-27 Thread Tobias Heider
On Thu, Jul 27, 2023 at 03:31:32PM +0200, Claudio Jeker wrote: > Use ibuf_data() instead of direct access to ibuf->buf. > In some cases use ibuf_add_buf(). > > -- > :wq Claudio ok tobhe@ > > Index: crypto.c > === > RCS file:

iked: more ibuf cleanup

2023-07-27 Thread Claudio Jeker
Use ibuf_data() instead of direct access to ibuf->buf. In some cases use ibuf_add_buf(). -- :wq Claudio Index: crypto.c === RCS file: /cvs/src/sbin/iked/crypto.c,v retrieving revision 1.44 diff -u -p -r1.44 crypto.c --- crypto.c

Re: iked: more ibuf cleanup

2023-07-16 Thread Theo Buehler
On Sun, Jul 16, 2023 at 04:24:15PM +0200, Claudio Jeker wrote: > Rename ibuf_get() to ibuf_getdata() by merging the two functions together. > I want to use ibuf_get() as part of the ibuf API so this needs to move. > Also use ibuf_add_zero() in a place of ibuf_reserve() and remove a check > for

Re: iked: more ibuf cleanup

2023-07-16 Thread Tobias Heider
On Sun, Jul 16, 2023 at 04:24:15PM +0200, Claudio Jeker wrote: > Rename ibuf_get() to ibuf_getdata() by merging the two functions together. > I want to use ibuf_get() as part of the ibuf API so this needs to move. > Also use ibuf_add_zero() in a place of ibuf_reserve() and remove a check > for

iked: more ibuf cleanup

2023-07-16 Thread Claudio Jeker
Rename ibuf_get() to ibuf_getdata() by merging the two functions together. I want to use ibuf_get() as part of the ibuf API so this needs to move. Also use ibuf_add_zero() in a place of ibuf_reserve() and remove a check for buf->buf == NULL in ibuf_length() which has nothing to do there. -- :wq