Re: convert bgpd to stdint.h types

2022-02-04 Thread Claudio Jeker
On Fri, Feb 04, 2022 at 07:20:21PM +0100, Theo Buehler wrote: > On Fri, Feb 04, 2022 at 03:59:34PM +0100, Claudio Jeker wrote: > > This is something I wanted to do for a while. Switch from u_intXY_t to > > uintXY_t from stdint.h. The diff is mostly mechanical and was done with > > sed -i

Re: convert bgpd to stdint.h types

2022-02-04 Thread David Gwynne
ok On Sat, 5 Feb 2022, 01:08 Claudio Jeker, wrote: > This is something I wanted to do for a while. Switch from u_intXY_t to > uintXY_t from stdint.h. The diff is mostly mechanical and was done with > sed -i 's/u_intX_t/uintX_t/g' but uint8_t changes the tab spacing and so > I had a look over

Re: m_pullup alingment crash armv7 sparc64

2022-02-04 Thread David Gwynne
On Thu, Feb 03, 2022 at 11:39:50PM +0100, Alexander Bluhm wrote: > On Thu, Feb 03, 2022 at 10:22:46PM +1000, David Gwynne wrote: > > bpf should know better than this. it has all the information it needs to > > align the payload properly, it just doesnt make enough of an effort. can > > you try the

always align data in m_pullup on all archs

2022-02-04 Thread David Gwynne
as discussed in "m_pullup alingment crash armv7 sparc64", at worst it doesnt hurt to have m_pullup maintain the data alignment of payloads, and at best it will encourage aligned loads even if the arch allows unaligned accesses. aligned loads are faster than unaligned. ok? Index: uipc_mbuf.c

rpki-client: check certificate policies

2022-02-04 Thread Theo Buehler
It was pointed out to Claudio that rpki-client does not enforce certificate policies. The diff below does that. It has two parts. In cert.c we check that the certificate policy extension matches the specification in RFC 6487, section 4.8.9, as amended by RFC 7318 section 2. That's maybe a bit

Re: always align data in m_pullup on all archs

2022-02-04 Thread Alexander Bluhm
On Fri, Feb 04, 2022 at 07:32:52PM +1000, David Gwynne wrote: > as discussed in "m_pullup alingment crash armv7 sparc64", at worst it > doesnt hurt to have m_pullup maintain the data alignment of payloads, > and at best it will encourage aligned loads even if the arch allows > unaligned accesses.

Re: rpki-client: check certificate policies

2022-02-04 Thread Theo Buehler
On Fri, Feb 04, 2022 at 12:03:41PM +0100, Claudio Jeker wrote: > On Fri, Feb 04, 2022 at 10:41:03AM +0100, Theo Buehler wrote: > > It was pointed out to Claudio that rpki-client does not enforce > > certificate policies. > > > > The diff below does that. It has two parts. > > > > In cert.c we

Re: rpki-client: check certificate policies

2022-02-04 Thread Claudio Jeker
On Fri, Feb 04, 2022 at 03:56:18PM +0100, Theo Buehler wrote: > On Fri, Feb 04, 2022 at 12:03:41PM +0100, Claudio Jeker wrote: > > On Fri, Feb 04, 2022 at 10:41:03AM +0100, Theo Buehler wrote: > > > It was pointed out to Claudio that rpki-client does not enforce > > > certificate policies. > > >

Re: uvm_unmap_kill_entry(): unwire with map lock held

2022-02-04 Thread Martin Pieuchot
On 04/02/22(Fri) 03:39, Klemens Nanni wrote: > [...] > ... with the lock grabbed in uvm_map_teardown() that is, otherwise > the first call path can lock against itself (regress/misc/posixtestsuite > is a reproduce for this): > > vm_map_lock_read_ln+0x38 > uvm_fault_unwire+0x58 >

Re: m_pullup alingment crash armv7 sparc64

2022-02-04 Thread Alexander Bluhm
On Fri, Feb 04, 2022 at 07:27:38PM +1000, David Gwynne wrote: > On Thu, Feb 03, 2022 at 11:39:50PM +0100, Alexander Bluhm wrote: > > On Thu, Feb 03, 2022 at 10:22:46PM +1000, David Gwynne wrote: > > > bpf should know better than this. it has all the information it needs to > > > align the payload

openbgpd vs illumos

2022-02-04 Thread Claudio Jeker
On illumos sun is defined by some header so better not use sun as a variable name. Rename variable to sa_un to reduce hacks in -portable. -- :wq Claudio Index: bgpctl/bgpctl.c === RCS file: /cvs/src/usr.sbin/bgpctl/bgpctl.c,v

Re: openbgpd vs illumos

2022-02-04 Thread David Gwynne
Ok On Fri, 4 Feb 2022, 21:19 Claudio Jeker, wrote: > On illumos sun is defined by some header so better not use sun as a > variable name. Rename variable to sa_un to reduce hacks in -portable. > > -- > :wq Claudio > > Index: bgpctl/bgpctl.c >

Re: hardware checksum ix and ixl

2022-02-04 Thread David Gwynne
On Fri, Jan 28, 2022 at 05:26:01PM +0100, Alexander Bluhm wrote: > On Wed, Jan 26, 2022 at 11:05:51AM +0100, Claudio Jeker wrote: > > On Wed, Jan 26, 2022 at 01:29:42AM +0100, Alexander Bluhm wrote: > > > Hi, > > > > > > There were some problems with ix(4) and ixl(4) hardware checksumming > > >

Re: always align data in m_pullup on all archs

2022-02-04 Thread David Gwynne
On Fri, Feb 04, 2022 at 11:39:56AM +0100, Alexander Bluhm wrote: > On Fri, Feb 04, 2022 at 07:32:52PM +1000, David Gwynne wrote: > > as discussed in "m_pullup alingment crash armv7 sparc64", at worst it > > doesnt hurt to have m_pullup maintain the data alignment of payloads, > > and at best it

Re: rpki-client: check certificate policies

2022-02-04 Thread Claudio Jeker
On Fri, Feb 04, 2022 at 10:41:03AM +0100, Theo Buehler wrote: > It was pointed out to Claudio that rpki-client does not enforce > certificate policies. > > The diff below does that. It has two parts. > > In cert.c we check that the certificate policy extension matches the > specification in RFC

Re: convert bgpd to stdint.h types

2022-02-04 Thread Theo Buehler
On Fri, Feb 04, 2022 at 03:59:34PM +0100, Claudio Jeker wrote: > This is something I wanted to do for a while. Switch from u_intXY_t to > uintXY_t from stdint.h. The diff is mostly mechanical and was done with > sed -i 's/u_intX_t/uintX_t/g' but uint8_t changes the tab spacing and so > I had a

Ship ubsan_minimal library in base?

2022-02-04 Thread Greg Steuck
How do people feel about shipping the minimal UBSan runtime library[1] in the base system? It takes very little to build (Makefile + a few ifdefs that both jca@ and I hacked together). The library is tiny and useful enough for finding UB in base. % ls -l