vfs: drop unnecessary cache_purge()s

2023-07-16 Thread Thordur Bjornsson
VOP_RECLAIM is only ever called from vclean() to cleanup fs dependent data, and vclean() calls cache_purge(). Makes all of the reclaim implementations the same in this regard. diff --git sys/isofs/cd9660/cd9660_node.c sys/isofs/cd9660/cd9660_node.c index bce99d77c22..300277f3b37 100644 ---

Re: iked: more ibuf cleanup

2023-07-16 Thread Theo Buehler
On Sun, Jul 16, 2023 at 04:24:15PM +0200, Claudio Jeker wrote: > Rename ibuf_get() to ibuf_getdata() by merging the two functions together. > I want to use ibuf_get() as part of the ibuf API so this needs to move. > Also use ibuf_add_zero() in a place of ibuf_reserve() and remove a check > for

Re: iked: more ibuf cleanup

2023-07-16 Thread Tobias Heider
On Sun, Jul 16, 2023 at 04:24:15PM +0200, Claudio Jeker wrote: > Rename ibuf_get() to ibuf_getdata() by merging the two functions together. > I want to use ibuf_get() as part of the ibuf API so this needs to move. > Also use ibuf_add_zero() in a place of ibuf_reserve() and remove a check > for

iked: more ibuf cleanup

2023-07-16 Thread Claudio Jeker
Rename ibuf_get() to ibuf_getdata() by merging the two functions together. I want to use ibuf_get() as part of the ibuf API so this needs to move. Also use ibuf_add_zero() in a place of ibuf_reserve() and remove a check for buf->buf == NULL in ibuf_length() which has nothing to do there. -- :wq