move p_emul to process

2011-07-07 Thread Ted Unangst
I don't think we're ever going to support different threads of a process running with different emulations, so move p_emul and p_emuldata to struct process. This uses the p__pgid kinfo_proc hack to allow p_emul to remain as a macro so I don't have to rewrite half the kernel. Index: bin/ps/print.c

libedit readline bugs

2011-07-07 Thread Nicholas Marriott
EL_BIND and EL_SETTC must have their argument lists end in NULL. ok? Index: readline.c === RCS file: /cvs/src/lib/libedit/readline.c,v retrieving revision 1.9 diff -u -p -r1.9 readline.c --- readline.c 7 Jul 2011 05:40:42 -

Re: Stop exposing opipe to userspace

2011-07-07 Thread Matthew Dempsky
On Thu, Jul 07, 2011 at 07:41:13PM -0700, Matthew Dempsky wrote: > Shrinks an i386 kernel by 190 bytes!! tedu@ suggested just moving sys_pipe() into sys_pipe.c and merging it with opipe(). ok? Index: kern/syscalls.master === RCS fi

Re: new small, fast, always on priority queueing

2011-07-07 Thread Henning Brauer
now with unfucked antispoof and without debug printf per packet! this has gathered enough oks to go in in roughly 12 hours, so speak up now or never if you have anything to say on the topic Index: sbin/pfctl/parse.y === RCS file: /cv

Support for AT_EACCES, AT_SYMLINK_NOFOLLOW, and AT_SYMLINK_FOLLOW

2011-07-07 Thread Matthew Dempsky
The diff below adds the remaining necessary functionality for the *at() functions. Changes: - Functions each check that they're given the right flags and return EINVAL otherwise. - AT_SYMLINK_NOFOLLOW and AT_SYMLINK_FOLLOW are pretty trivial; just control whether the FOLLOW or NOFOLL

Re: checksum revamp

2011-07-07 Thread Henning Brauer
disregard this for now. i fucking hate checksums.

Stop exposing opipe to userspace

2011-07-07 Thread Matthew Dempsky
I'm pretty sure nothing in userspace needs the old sys_opipe() system call entry point. sys_pipe is still implemented using it, so just rename it to "opipe()" and continue using in the kernel. As a bonus, this made me notice that linux_sys_pipe() was reimplementing sys_pipe() (except without corr

Re: new small, fast, always on priority queueing

2011-07-07 Thread Henning Brauer
now with even more straightforward if_detach_queues ? sys2 ? sys/ID Index: sbin/pfctl/parse.y === RCS file: /cvs/src/sbin/pfctl/parse.y,v retrieving revision 1.603 diff -u -p -r1.603 parse.y --- sbin/pfctl/parse.y 7 Jul 2011 00:47:19

Re: wcsdup

2011-07-07 Thread Nicholas Marriott
Hi On Tue, Jul 05, 2011 at 08:12:44PM +0200, Stefan Sperling wrote: > On Tue, Jul 05, 2011 at 01:52:06PM -0400, Todd C. Miller wrote: > > Also, what is that > > 'L' doing there before the "foobar"? Is it some sort of wide char > > thing I'm not aware of? > > > > L"" is C99 notation for wide char

More buffer cache - the real diff.

2011-07-07 Thread Bob Beck
(apologies for the earlier oops.) Want more buffer cache? please have a try with this. This diff breaks the buffer cache into the dma'able region, and the above dma-able region of memory. buffers are always allocated in the dma'able region, and as they age they are moved above the dma'able r

Re: Bigger Buffer Cache - Flip Buffers above/below the DMA'able rea

2011-07-07 Thread Bob Beck
oops. ignore this - diff in wrong directory.. On 7 July 2011 15:53, Bob Beck wrote: > Want more buffer cache? please have a try with this. > > This diff breaks the buffer cache into the dma'able region, and the > above dma-able region of memory. buffers are always allocated in > the dma'

Bigger Buffer Cache - Flip Buffers above/below the DMA'able rea

2011-07-07 Thread Bob Beck
Want more buffer cache? please have a try with this. This diff breaks the buffer cache into the dma'able region, and the above dma-able region of memory. buffers are always allocated in the dma'able region, and as they age they are moved above the dma'able region if such memory exists. I

Re: Anyone interested in writing a driver for this?

2011-07-07 Thread Theo de Raadt
> Agreed, > > "In all countries that are members of the Berne Convention, copyright > is automatic and need not be obtained through official registration > with any government office. Once an idea has been reduced to tangible > form, for example by securing it in a fixed medium (such as a drawing,

cwm: uppercase #define

2011-07-07 Thread Thomas Pfaff
Uppercase two #define so we can immediately see they won't change. Index: kbfunc.c === RCS file: /cvs/xenocara/app/cwm/kbfunc.c,v retrieving revision 1.55 diff -u -p -r1.55 kbfunc.c --- kbfunc.c24 Jun 2011 06:06:24 - 1.55

Re: Anyone interested in writing a driver for this?

2011-07-07 Thread Zeb Packard
Agreed, "In all countries that are members of the Berne Convention, copyright is automatic and need not be obtained through official registration with any government office. Once an idea has been reduced to tangible form, for example by securing it in a fixed medium (such as a drawing, sheet music

Re: Introducing rrw locks;

2011-07-07 Thread Thordur Bjornsson
On Thu, Jul 07, 2011 at 06:59:53PM +, Thordur Bjornsson wrote: > On Wed, Jul 06, 2011 at 10:05:00PM +, Thordur Bjornsson wrote: > > I really need to hear back from you guys with reports, i.e. on > what, with what fs and a short description of what you toyed with > maybe ? Due to tree chu

Re: libevent wide character functions

2011-07-07 Thread Todd C. Miller
On Thu, 07 Jul 2011 12:22:28 +0200, Stefan Sperling wrote: > The proper way to fix this is to add conversion from/to the various > character sets into unicode code points within mbrtowc() and wcrtomb() > in citrus_none.c. This wouldn't need anything special like iconv. > A couple of statically def

Re: Anyone interested in writing a driver for this?

2011-07-07 Thread Antti Harri
On Thursday 07 July 2011 20:45:48 Peter J. Philipp wrote: > Kenchy has no license on his libusb program so its info can easily be used > to make a BSD licensed driver out of this. No license means it's not free. "LICENSE: No specific license, please feel free to do what you want with it. If you

Re: Anyone interested in writing a driver for this?

2011-07-07 Thread Peter J. Philipp
On Thu, Jul 07, 2011 at 07:45:48PM +0200, Peter J. Philipp wrote: > Hi, > > I have a USB device called a "USB FM transmitter" from Keene Electronics. > It looks like this when I plug it in. I've found someone to send it to. If they have no luck they said they'd take it along to the next hackatho

Re: Introducing rrw locks;

2011-07-07 Thread Thordur Bjornsson
On Wed, Jul 06, 2011 at 10:05:00PM +, Thordur Bjornsson wrote: I really need to hear back from you guys with reports, i.e. on what, with what fs and a short description of what you toyed with maybe ? ciao, thib. > Hi, > > > This diff introduces rrwlocks or recursive/re-entrant rwlocks. Th

Anyone interested in writing a driver for this?

2011-07-07 Thread Peter J. Philipp
Hi, I have a USB device called a "USB FM transmitter" from Keene Electronics. It looks like this when I plug it in. uaudio0 at uhub1 port 1 configuration 1 interface 0 "HOLTEK B-LINK USB Audio" rev 1.10/1.00 addr 3 uaudio0: audio rev 1.00, 2 mixer controls audio1 at uaudio0 uhidev0 at uhub1 port

FFS trim support part 1

2011-07-07 Thread Ted Unangst
All the cool kids have new TRIM supporting drives. FFS should support trim too, so that FFS can be cool again. In order to do so, we need to insert a few more operations in the block freeing code path, which this diff does. This diff doesn't actually add trim support, nor is the interface with t

More archs should write disklabel where it will be read

2011-07-07 Thread Kenneth R Westerback
Without changing behaviour for native disklabels, allow some more archs that call readdoslabel() to read/write disklabels to same place as readdoslabel() reads from. The hppa paren chunk are to make hppa and hppa64 disksubr.c identical again. ok? Ken Index: hppa/hppa/disksubr.c =

Re: libevent wide character functions

2011-07-07 Thread Nicholas Marriott
Er yes I meant libedit, sorry :-). On Thu, Jul 07, 2011 at 09:50:42AM +0100, Nicholas Marriott wrote: > Let's turn 'em on. > > Not much supports them but we might as well have them. > > ok? > > > Index: Makefile > === > RCS file:

Bee Gees - Discografia mas pendrive de regalo

2011-07-07 Thread Discos MP3 - Solo de Oferta
1- Brilliant From Birth / 2- Unreleased demos from / 3- Rare pecious and beautiful / 4- Spicks & Specks / 5- The Bee Gees sing and play / 4 Barry Gubb Songs / 6- Collection / 7- First / 8- Horizontal

Re: libevent wide character functions

2011-07-07 Thread Stefan Sperling
On Thu, Jul 07, 2011 at 09:50:42AM +0100, Nicholas Marriott wrote: > Let's turn 'em on. > > Not much supports them but we might as well have them. > > ok? > > > Index: Makefile > === > RCS file: /cvs/src/lib/libedit/Makefile,v > re

libevent wide character functions

2011-07-07 Thread Nicholas Marriott
Let's turn 'em on. Not much supports them but we might as well have them. ok? Index: Makefile === RCS file: /cvs/src/lib/libedit/Makefile,v retrieving revision 1.10 diff -u -p -r1.10 Makefile --- Makefile30 Jun 2010 00:05:35 -0