Re: ipmi(4) - Support ipmitool IOCTL etc.

2015-09-21 Thread Masao Uebayashi
I've added a patch to sysutils/ipmitool; apply it and rebuild. https://github.com/uebayasi/openbsd-ipmi/blob/ipmi19/ipmitool.patch On Fri, Sep 18, 2015 at 05:48:52PM +0900, Masao Uebayashi wrote: > I've prepared a set of patches to make OpenBSD's ipmi(4) work with ipmitool > via /dev/ipmi

Clarify error/warning reporting in style(9)

2015-09-21 Thread Michael McConville
Could also say "Use the err(3) and warn(3) family of functions." That's what the err(3) man page intro refers to it as. Index: share/man/man9/style.9 === RCS file: /cvs/src/share/man/man9/style.9,v retrieving revision 1.59 diff -u -p

poll magic for pflogd

2015-09-21 Thread Ted Unangst
I think this will help pflogd sleep better at night... My understanding of the pcap/bpf timeout is that it will always wait that long, even if packets are received, so that you don't get one read() per packet. But using this timeout doesn't mean wait forever until you get something. We can put a

Re: ports.7: tweak wording + punctuation

2015-09-21 Thread Ingo Schwarze
Hi Michael, Michael Reed wrote on Mon, Sep 21, 2015 at 04:42:02PM -0400: > Index: src/share/man/man7/ports.7 > === > RCS file: /cvs/src/share/man/man7/ports.7,v > retrieving revision 1.103 > diff -u -p -r1.103 ports.7 > --- src/share

Re: ports.7: Ar -> Va

2015-09-21 Thread Ingo Schwarze
Hi Michael, Michael Reed wrote on Mon, Sep 21, 2015 at 04:50:07PM -0400: > The variables below take arguments, but are not arguments themselves. > Given that, change the markup accordingly. Committed, thanks. Ingo > Index: src/share/man/man7/ports.7 >

ports.7: Ar -> Va

2015-09-21 Thread Michael Reed
Hi all, The variables below take arguments, but are not arguments themselves. Given that, change the markup accordingly. Regards, Michael Index: src/share/man/man7/ports.7 === RCS file: /cvs/src/share/man/man7/ports.7,v retrieving

ports.7: tweak wording + punctuation

2015-09-21 Thread Michael Reed
Hi, I found the wording in ports.7 awkward in a few places, which this patch aims to fix. Besides that, there's a few small punctuation changes. I've tried to only touch low-hanging fruit to avoid any bikeshedding, but if you think any change is too subjective just let me know. Regards, Michael

Re: lighter sleep

2015-09-21 Thread Philip Guenther
On Mon, Sep 21, 2015 at 8:37 AM, wrote: ... > I don't want error messages or any feedback produced by the machine and > the operating system in any other language than English in C locale, > even if my locale is set to native (non-English). You know that you can set LC_MESSAGES to a different va

Re: lighter sleep

2015-09-21 Thread lists
On Mon, 21 Sep 2015 16:53:12 +0200 Alexandre Ratchov wrote: > On Mon, Sep 21, 2015 at 02:29:03PM +, Christian Weisgerber wrote: > > On 2015-09-21, Stefan Sperling wrote: > > > > > The function that parses funny numbers is iswdigit() which gets a wchar_t. > > > But sleep(1) doesn't need that

Re: lighter sleep

2015-09-21 Thread Stefan Sperling
On Mon, Sep 21, 2015 at 01:25:04PM -0400, Ted Unangst wrote: > Stefan Sperling wrote: > > > > Just remove the setlocale() call to leave sleep(1) in the default "C" > > locale. > > here's a diff that does that. you're right, there's no need to rewrite ctype > if it hasn't been altered. I also ch

Re: lighter sleep

2015-09-21 Thread Ted Unangst
Stefan Sperling wrote: > > Just remove the setlocale() call to leave sleep(1) in the default "C" locale. here's a diff that does that. you're right, there's no need to rewrite ctype if it hasn't been altered. I also checked that there are no calls to err() or strerror() or whatever, and so there

mg(1) dired mode - line numbers and delete functions

2015-09-21 Thread Mark Lumsden
Hi, Line numbers are not handled very well in the dired mode delete functions. This diff should fix that. ok? -lum Index: dired.c === RCS file: /cvs/src/usr.bin/mg/dired.c,v retrieving revision 1.73 diff -u -p -u -p -r1.73 dired.c

Re: remove SIGALRM handling from sleep(1)

2015-09-21 Thread Philip Guenther
On Mon, Sep 21, 2015 at 2:06 AM, Mark Kettenis wrote: ... >> AFAICT, we don't use SIGALRM in any of our install or rc scripting, so >> let's remove the unnecessary signal work. >> >> ok? > > Why? The standard still allows our current behaviour. And it's not a > particular invasive bit of code.

cpuspeed in apm info

2015-09-21 Thread Ted Unangst
The frequency of the cpu is likely to be of interest (in fact, it is to me). We can include it in the apm info. Index: arch/i386/i386/apm.c === RCS file: /cvs/src/sys/arch/i386/i386/apm.c,v retrieving revision 1.113 diff -u -p -r1.11

Re: lighter sleep

2015-09-21 Thread Alexandre Ratchov
On Mon, Sep 21, 2015 at 02:29:03PM +, Christian Weisgerber wrote: > On 2015-09-21, Stefan Sperling wrote: > > > The function that parses funny numbers is iswdigit() which gets a wchar_t. > > But sleep(1) doesn't need that. > > The sole somewhat realistic use of i18n in sleep(1) is the decima

Re: lighter sleep

2015-09-21 Thread Mark Kettenis
> From: Christian Weisgerber > Date: Mon, 21 Sep 2015 14:29:03 + (UTC) > > On 2015-09-21, Stefan Sperling wrote: > > > The function that parses funny numbers is iswdigit() which gets a wchar_t. > > But sleep(1) doesn't need that. > > The sole somewhat realistic use of i18n in sleep(1) is t

Re: lighter sleep

2015-09-21 Thread Christian Weisgerber
On 2015-09-21, Stefan Sperling wrote: > The function that parses funny numbers is iswdigit() which gets a wchar_t. > But sleep(1) doesn't need that. The sole somewhat realistic use of i18n in sleep(1) is the decimal separator, so you could do $ sleep 1,5 in an appropriate locale. Of course th

Re: kill struct inpcbtable's inpt_lastport

2015-09-21 Thread David Hill
On Sat, Sep 19, 2015 at 07:57:00PM +0200, Vincent Gross wrote: > On 09/18/15 23:39, David Hill wrote: > > On Fri, Sep 18, 2015 at 11:05:55PM +0200, Vincent Gross wrote: > >> On 09/18/15 15:18, David Hill wrote: > >>> Is this 'if (count)' statement needed? We know first > last, so count > >>> will

Re: iked(8) cleanup

2015-09-21 Thread Mike Belopuhov
On 19 September 2015 at 20:08, Michael McConville wrote: > Drop some unnecessary NULL checks OK for those. > explicitly bzero sensitive memory. > While SADB_GETSPI doesn't export keys, I think this change won't harm nevertheless, so OK for it as well.

Re: Drop a distracting function from locate(1)

2015-09-21 Thread Bob Beck
Holy bikeshed batman.. Did I accidentally stumble into a FreeBSD list?

Re: Drop a distracting function from locate(1)

2015-09-21 Thread lists
On Mon, 21 Sep 2015 07:47:55 +0200 Otto Moerbeek wrote: > On Sun, Sep 20, 2015 at 07:43:46AM -0400, Michael McConville wrote: > > > Otto Moerbeek wrote: > > > I do not agree. You only have to remeber "that function does sensible > > > error checking" and you do not have to remember at each spot

Re: lighter sleep

2015-09-21 Thread Bob Beck
On Monday, 21 September 2015, Stefan Sperling wrote: > On Sun, Sep 20, 2015 at 09:40:05PM -0600, Bob Beck wrote: > > I concur, I don't want to see a plethora of "isnumber" > > "ismaybeanumber" bullshit in the tree that > > do the same thing "isdigit" does.. if for whatever reason we want > > isdi

Re: no more _subdir in man.conf

2015-09-21 Thread Ingo Schwarze
Hi Jan, Jan Stary wrote on Thu, Sep 17, 2015 at 04:53:34PM +0200: > The new man.conf does not recognize _subdir Committed, thanks. Ingo > Index: man.1 > === > RCS file: /cvs/src/usr.bin/mandoc/man.1,v > retrieving revision 1.11

Re: perlpod conversion: crypto.3

2015-09-21 Thread Ingo Schwarze
Hi, Michael Reed wrote on Sat, Sep 19, 2015 at 05:01:38PM -0400: > This was done with pod2mdoc This one was left unprocessed when we started the POD to mdoc conversion because in OpenBSD, we generally hate manual pages in the style of string(3) and curses(3). They tend to be incomplete and outd

Re: [RFC] [PATCH] Implementation of POSIX message queues

2015-09-21 Thread Dimitris Papastamos
Hi everyone, I had a chance to test this patch more and iron out some bugs. The main changes from the previous version are: * Uses pool(9) for allocations smaller than MQ_DEF_MSGSIZE. * Add poll support. * Fix a memory leak in domqrecv() that would eventually exhaust all available kernel memo

Re: rc.conf.8 should ref rcctl(8)

2015-09-21 Thread Jason McIntyre
On Fri, Sep 18, 2015 at 03:07:03PM -0400, Rob Pierce wrote: > Reference the rcctl(8) utility in rc.conf.8 (which discusses rc.conf.local). > > Rob > this and the other rcctl patches committed (though tweaked slightly). thanks, jmc > Index: rc.conf.8 > ==

Re: bsd.port.mk.5: Use Xr where appropriate

2015-09-21 Thread Ingo Schwarze
Hi Michael, committed with minimal tweaks, thanks. Ingo Michael Reed wrote on Sun, Sep 20, 2015 at 03:54:09PM -0400: > Index: src/share/man/man5/bsd.port.mk.5 > === > RCS file: /cvs/src/share/man/man5/bsd.port.mk.5,v > retrieving

Re: remove SIGALRM handling from sleep(1)

2015-09-21 Thread Mark Kettenis
> Date: Mon, 21 Sep 2015 01:37:27 -0700 > From: Philip Guenther > > POSIX no longer requires sleep(1) to exit with status zero when sent > SIGALRM: > > > If the sleep utility receives a SIGALRM signal, one of the following > actions shall be taken: > >1. Terminate normally with a

remove SIGALRM handling from sleep(1)

2015-09-21 Thread Philip Guenther
POSIX no longer requires sleep(1) to exit with status zero when sent SIGALRM: If the sleep utility receives a SIGALRM signal, one of the following actions shall be taken: 1. Terminate normally with a zero exit status. 2. Effectively ignore the signal. 3. Provide the default

Re: lighter sleep

2015-09-21 Thread Stefan Sperling
On Sun, Sep 20, 2015 at 09:40:05PM -0600, Bob Beck wrote: > I concur, I don't want to see a plethora of "isnumber" > "ismaybeanumber" bullshit in the tree that > do the same thing "isdigit" does.. if for whatever reason we want > isdigit to be more efficient because > the most important thing I hav

mg(1) - kill-paragraph tidy up

2015-09-21 Thread Mark Lumsden
Hi, The kill-buffer command in mg doesn't behave quite as I would expect, if you invoke it multiple times via C-u #, then follow with M-_ (undo) or C-y (paste), only the last buffer killed (re)appears and not the multiple paragraphs that I think should. This diff changes that behaviour. Also, by