Re: netstart: implicit up and explicit down for hostname.if conf files

2018-03-13 Thread Theo de Raadt
No. I don't see any study of who this affects negatively.

interface queue transmit mitigation (again)

2018-03-13 Thread David Gwynne
this adds transmit mitigation back to the tree. it is basically the same diff as last time. the big difference this time is that all the tunnel drivers all defer ip_output calls, which avoids having to play games with NET_LOCK in the ifq transmit paths. tests? ok? Index: ifq.c

Re: netstart: implicit up and explicit down for hostname.if conf files

2018-03-13 Thread Bryan Vyhmeister
On Wed, Mar 14, 2018 at 10:27:10AM +1000, David Gwynne wrote: > this makes netstart run "hostname foo0 up" for every interface that > is configured. however, if you do not want an interface to be brought > up on boot (you may just want to configure it) you can disable this > by putting "down" in

Re: Bugfix: acme-client 301 redirect issue

2018-03-13 Thread Stuart Henderson
On 2018/03/11 17:52, Florian Obser wrote: > > I think we should just follow the 301. I didn't hear back from @letsencrypt_ops about why they were issue 301s, but I do agree it makes sense to follow them. > OK? > > diff --git netproc.c netproc.c > index 26033a3fc3c..14da5a8c1a9 100644 > ---

netstart: implicit up and explicit down for hostname.if conf files

2018-03-13 Thread David Gwynne
this makes netstart run "hostname foo0 up" for every interface that is configured. however, if you do not want an interface to be brought up on boot (you may just want to configure it) you can disable this by putting "down" in the file. this has two uses. the first is to simplify config for

netinet6 - bcopy -> memcpy

2018-03-13 Thread David Hill
Hello - A few bcopy to memcpy conversions where the memory does not overlap. OK? Index: netinet6/icmp6.c === RCS file: /cvs/src/sys/netinet6/icmp6.c,v retrieving revision 1.221 diff -u -p -r1.221 icmp6.c --- netinet6/icmp6.c14

Re: Kernel size beyond 16 MB on amd64

2018-03-13 Thread Stuart Henderson
On 2018/03/12 17:50, Franco Fichtner wrote: > Hi, > > With regard to a commit[1] by Theo in 2013, several questions > in the years before and a partial lift of the limitation on > i386 a while back (2015?) I'd like to ask what the future plans > are for OpenBSD. > > Peeking at NetBSD, where the

Re: Kernel size beyond 16 MB on amd64

2018-03-13 Thread Mike Larkin
On Tue, Mar 13, 2018 at 04:15:23PM +0100, Franco Fichtner wrote: > > > On 13. Mar 2018, at 4:04 PM, Ted Unangst wrote: > > > > Franco Fichtner wrote: > >> What can we do to help? > > > > Write smaller code... > > Fair enough. ;) > > On a more serious note, I'm referring

Re: Kernel size beyond 16 MB on amd64

2018-03-13 Thread Franco Fichtner
> On 13. Mar 2018, at 4:04 PM, Ted Unangst wrote: > > Franco Fichtner wrote: >> What can we do to help? > > Write smaller code... Fair enough. ;) On a more serious note, I'm referring to: https://marc.info/?l=openbsd-tech=112152576800634=2 "Immediate reboots" is what

Re: Kernel size beyond 16 MB on amd64

2018-03-13 Thread Ted Unangst
Franco Fichtner wrote: > What can we do to help? Write smaller code...

Re: correctly calculate RFC7217 based IPv6 address

2018-03-13 Thread Mark Kettenis
> Date: Tue, 13 Mar 2018 13:49:01 +0100 > From: Peter Hessler > > On 2018 Mar 13 (Tue) at 12:41:17 +0100 (+0100), Florian Obser wrote: > :(sending this to tech@ so that more people see this) > : > :semarie@ pointed out on bugs@ ( >

Re: ksh: __func__ in warnings

2018-03-13 Thread Boris Radulov
> Please disregard my concern about consistency, I was missing something, > not you Sorry if it came out as out of place. I just feel like starting to introduce the macro in places where the function name is outright wrong might be a good idea, since if the function was changed once it makes

Re: correctly calculate RFC7217 based IPv6 address

2018-03-13 Thread Peter Hessler
On 2018 Mar 13 (Tue) at 12:41:17 +0100 (+0100), Florian Obser wrote: :(sending this to tech@ so that more people see this) : :semarie@ pointed out on bugs@ ( :https://marc.info/?l=openbsd-bugs=152084960013726=2 ) that his :RFC7217 IPv6 address changed after an upgrade. Of course it should not. :

Re: ksh: __func__ in warnings

2018-03-13 Thread Klemens Nanni
On Tue, Mar 13, 2018 at 12:33:36PM +0100, Klemens Nanni wrote: > On Tue, Mar 13, 2018 at 04:39:16PM +0800, Michael W. Bombardieri wrote: > > Some errors and warnings printed by ksh have the function name > > prefixed. __func__ could be used here instead of hard-coding > > the name. The names are

Re: SSL_TXT_SSLV2

2018-03-13 Thread Jeremie Courreges-Anglas
On Sat, Mar 10 2018, Stuart Henderson wrote: > mail/dovecot's default config has a problem because SSL_TXT_SSLV2 > is defined but SSLv2 is not allowed in a protocol string. End result > is that unless you specify your own ssl_protocols line, Dovecot will > start but client

Re: ksh: __func__ in warnings

2018-03-13 Thread Boris Radulov
>Not sure if touching all error messages for __func__ is worth it or just >too much churn in the end. He already converted some so I don't see a reason to not introduce at least that diff. If someone comes across something, he could just fix it then and there if this issue is well-known. On

correctly calculate RFC7217 based IPv6 address

2018-03-13 Thread Florian Obser
(sending this to tech@ so that more people see this) semarie@ pointed out on bugs@ ( https://marc.info/?l=openbsd-bugs=152084960013726=2 ) that his RFC7217 IPv6 address changed after an upgrade. Of course it should not. The reason for that was a mistake in the original implementation: In the

Re: ksh: __func__ in warnings

2018-03-13 Thread Klemens Nanni
On Tue, Mar 13, 2018 at 04:39:16PM +0800, Michael W. Bombardieri wrote: > Some errors and warnings printed by ksh have the function name > prefixed. __func__ could be used here instead of hard-coding > the name. The names are wrong for tty_init(), j_set_async(), > j_change(), x_file_glob() and

ksh: __func__ in warnings

2018-03-13 Thread Michael W. Bombardieri
Hello, Some errors and warnings printed by ksh have the function name prefixed. __func__ could be used here instead of hard-coding the name. The names are wrong for tty_init(), j_set_async(), j_change(), x_file_glob() and c_ulimit() afaics. - Michael Index: c_ksh.c