Re: ix(4) need support for X553

2019-12-02 Thread Hrvoje Popovski
On 18.11.2019. 0:31, Hrvoje Popovski wrote: > On 14.11.2019. 1:06, Stuart Henderson wrote: >> Apart from the obvious style(9) problems, can anyone give me guidance on >> how to approach this diff? I'm quite uneasy at the amount of changes but >> these >> nics are quite important, they're all over

Re: ix(4) need support for X553

2019-11-22 Thread Colin Hyatt Bortner
On Thu, Nov 14, 2019, at 1:06 AM, Stuart Henderson wrote: *snip* > > I have an A2SDi-2C-HLN4F that I need to put in service soon (not so > bothered about the ix on this box, I'm using 4xSFP+ ixl, but giving it > a spin) - applying my merged diff (https://junkpile.org/ixgbe.diff2) > and adding

Re: ix(4) need support for X553

2019-11-17 Thread Hrvoje Popovski
On 14.11.2019. 1:06, Stuart Henderson wrote: > Apart from the obvious style(9) problems, can anyone give me guidance on > how to approach this diff? I'm quite uneasy at the amount of changes but these > nics are quite important, they're all over the place on Atom C3xxx boards > which are pretty

Re: ix(4) need support for X553

2019-11-13 Thread Stuart Henderson
Apart from the obvious style(9) problems, can anyone give me guidance on how to approach this diff? I'm quite uneasy at the amount of changes but these nics are quite important, they're all over the place on Atom C3xxx boards which are pretty much the main "next step up" from APUs. I have an

Re: ix(4) need support for X553

2019-11-04 Thread Joerg Goltermann
Hello, thank you so much, I did some tests with my X553 and the system survived all of my tests. Running tcpbench and unplugging the cables several times, ifconfig down & up. I think, the performance looks good too: cpu0 at mainbus0: apid 4 (boot processor) cpu0: Intel(R) Atom(TM) CPU C3558 @

Re: ix(4) need support for X553

2019-10-31 Thread sven falempin
On Thu, Oct 31, 2019 at 9:49 AM sven falempin wrote: > > > On Thu, Oct 31, 2019 at 9:17 AM Stuart Henderson > wrote: > >> On 2019/10/31 08:25, sven falempin wrote: >> > Thank you, the ./dev/pci/pcidevs_data.h, pcidevs.h are completly >> removed from this >> >> The pcidevs update is no longer

Re: ix(4) need support for X553

2019-10-31 Thread sven falempin
On Thu, Oct 31, 2019 at 9:17 AM Stuart Henderson wrote: > On 2019/10/31 08:25, sven falempin wrote: > > Thank you, the ./dev/pci/pcidevs_data.h, pcidevs.h are completly > removed from this > > The pcidevs update is no longer needed since pcidevs r1.1889. > > > I may have time to test it against

Re: ix(4) need support for X553

2019-10-31 Thread Stuart Henderson
On 2019/10/31 08:25, sven falempin wrote: > Thank you, the ./dev/pci/pcidevs_data.h,  pcidevs.h are completly removed > from this The pcidevs update is no longer needed since pcidevs r1.1889. > I may have time to test it against 6.6, see if it is still working since 6.4 > (where it was >

Re: ix(4) need support for X553

2019-10-31 Thread sven falempin
On Wed, Oct 30, 2019 at 5:43 PM Stuart Henderson wrote: > On 2019/10/30 07:34, sven falempin wrote: > > https://github.com/dohnuts/wip/blob/master/ixgbe.diff > > > > Needs lots of cleaning > > > > On Wed, Oct 30, 2019 at 6:59 AM Joerg Goltermann wrote: > > > > > Hello, > > > > > > I have a new

Re: ix(4) need support for X553

2019-10-30 Thread Stuart Henderson
On 2019/10/30 07:34, sven falempin wrote: > https://github.com/dohnuts/wip/blob/master/ixgbe.diff > > Needs lots of cleaning > > On Wed, Oct 30, 2019 at 6:59 AM Joerg Goltermann wrote: > > > Hello, > > > > I have a new Lanner NCA-1510A (with a Intel C3558) which has some > > X553 SGMII

Re: ix(4) need support for X553

2019-10-30 Thread sven falempin
https://github.com/dohnuts/wip/blob/master/ixgbe.diff Needs lots of cleaning On Wed, Oct 30, 2019 at 6:59 AM Joerg Goltermann wrote: > Hello, > > I have a new Lanner NCA-1510A (with a Intel C3558) which has some > X553 SGMII ethernet ports. Unfortunately there is no support in ix(4) > for this

ix(4) need support for X553

2019-10-30 Thread Joerg Goltermann
Hello, I have a new Lanner NCA-1510A (with a Intel C3558) which has some X553 SGMII ethernet ports. Unfortunately there is no support in ix(4) for this type. Is anyone working on an update for the ix(4) to support the new hardware? I took a look at the actual ix(4) and it's a bit confusing.