Re: httpd request rewrite

2018-05-29 Thread Hiltjo Posthuma
On Tue, May 29, 2018 at 06:48:31PM +0200, Reyk Floeter wrote: > Hi, > > it's about time. > > server "default" { > listen on * port 80 > location match "/de/(.*)" { > request rewrite "/ch/%1" > } > } > > You can also you

const for OPENSSL_uni2asc, EVP_PKEY_size and X509_NAME_get_index_by_{OBJ,NID}

2018-05-29 Thread Theo Buehler
Of these four functions, only OPENSSL_uni2asc() has const in OpenSSL. jsing suggested that we could add const to the the name arguments of X509_NAME_get_index_by_{OBJ,NID}() when I touched some functions nearby. Lastly, the change to EVP_PKEY_size() will be needed in an upcoming diff. Note that

Re: httpd request rewrite

2018-05-29 Thread Reyk Floeter
On Tue, May 29, 2018 at 06:48:31PM +0200, Reyk Floeter wrote: > it's about time. > > server "default" { > listen on * port 80 > location match "/de/(.*)" { > request rewrite "/ch/%1" > } > } > > Tests? OK? > I didn't

httpd 2/3: rename "root strip" to "request strip"

2018-05-29 Thread Reyk Floeter
Hi, this diff applies on top of the previous one. Rename "root strip" to "request strip" The root strip option name was semantically incorrect as it does not strip the root but the request path. This is a grammar change and it also needs a heads up and a change in other

httpd 1/3: don't encode the query string twice

2018-05-29 Thread Reyk Floeter
Hi, the first diff fixes a bug that I found with the work on rewrites. The http_query is already url_encoded; don't encode it twice. This fixes a bug in the macros and log file handler that double-encoded the query. This does not change FCGI as it was already handling the

httpd 3/3: request rewrite

2018-05-29 Thread Reyk Floeter
Hi, as mentioned in the big diff before, this implements rewrites. This diff applies on top of the previous ones. Implement the "request rewrite" option for internal rewrites. For example: location match "/page/(%d+)/.*" { request rewrite

Re: httpd 2/3: rename "root strip" to "request strip"

2018-05-29 Thread Reyk Floeter
On Wed, May 30, 2018 at 12:32:12AM +0200, Reyk Floeter wrote: > Hi, > > this diff applies on top of the previous one. > > Rename "root strip" to "request strip" > > The root strip option name was semantically incorrect as it does not > strip the root but the request path. This

Re: errors in usage.c - libusbhid

2018-05-29 Thread David Bern
Sorry for the spamming. After some research and finding that my fix for issue nr: 2 ( hid_usage_in_page() ) will break the functionality inside /usr.bin/usbhidaction/usbhidaction.c https://goo.gl/1cWFtR (link to usbhidaction.c) I now change my patch to only include a fix for issue nr: 1 More

Re: httpd request rewrite

2018-05-29 Thread Reyk Floeter
On Tue, May 29, 2018 at 10:00:22PM +0200, Hiltjo Posthuma wrote: > On Tue, May 29, 2018 at 06:48:31PM +0200, Reyk Floeter wrote: > > Hi, > > > > it's about time. > > > > server "default" { > > listen on * port 80 > > location match "/de/(.*)" { > >

Re: IPL_VM for `f_mtx'

2018-05-29 Thread Martin Pieuchot
On 29/05/18(Tue) 10:00, Mathieu - wrote: > Mark Kettenis wrote: > > > Date: Mon, 28 May 2018 12:24:22 +0200 > > > From: Mathieu - > > > > > > Mark Kettenis wrote: > > > > > Date: Mon, 28 May 2018 11:23:47 +0200 > > > > > From: Martin Pieuchot > > > > > > > > > > As found by tb@ and visa@,

Re: IPL_VM for `f_mtx'

2018-05-29 Thread Mathieu -
Mark Kettenis wrote: > > Date: Mon, 28 May 2018 12:24:22 +0200 > > From: Mathieu - > > > > Mark Kettenis wrote: > > > > Date: Mon, 28 May 2018 11:23:47 +0200 > > > > From: Martin Pieuchot > > > > > > > > As found by tb@ and visa@, `f_mtx' need to block interrupts as long as > > > > it can be

in_ioctl: one case per ioctl

2018-05-29 Thread Theo Buehler
We can finally get rid of one switch in both, in_ioctl() and in_ioctl_change_ifaddr(). With this diff we have one case per ioctl, each case dealing with an ioctl starts with a privilege check before any global data is modified and the code paths are now straightforward. One thing that I don't

Re: Change CMakeLists.txt in LibreSSL to use target_include_directores

2018-05-29 Thread Brent Cook
On Thu, May 24, 2018 at 10:10:58AM +, Cameron Palmer wrote: > It is beneficial for projects that depend on LibreSSL libraries and are built > with CMake to use target_link_libraries and automatically receive the PUBLIC > or INTERFACE headers without needing to specify include_directories.

Re: Libressl question

2018-05-29 Thread Brent Cook
On Mon, Feb 12, 2018 at 09:27:16AM -0600, ed...@pettijohn-web.com wrote: > Has there been any discussion of packaging libtls separately from libressl > for portable use? With my limited skills I was able to write a program to > talk to smtpd and starttls using nothing but the manuals. I

Add sizes for free() in cryptosoft.c

2018-05-29 Thread Frederic Cambus
Hi tech@, Add sizes for free() in cryptosoft.c. Comments? OK? Index: sys/crypto/cryptosoft.c === RCS file: /cvs/src/sys/crypto/cryptosoft.c,v retrieving revision 1.83 diff -u -p -r1.83 cryptosoft.c --- sys/crypto/cryptosoft.c 2

Re: add const to the return value of BIO_s_file()

2018-05-29 Thread Brent Cook
ok bcook@ On Mon, May 28, 2018 at 3:23 PM, Theo Buehler wrote: > This is the first trivial part of the last batch of diffs catching up > with OpenSSL's const additions. > > As usual, sthen kindly ran the whole diff through a ports bulk build. > > Only this small change caused some fallout,

Re: FreeBSD tabs(1) ported to OpenBSD

2018-05-29 Thread Il Ka
Minor note: instead of including compilation instructions to code, is not it better to use bsd make system? Following Makefile does the trick: PROG=tabs LDADD+=-lncursesw .include With it you can "make" and "make install" your app. -- Sent from:

Re: [Patch] mg(1): Experimental UTF-8 support

2018-05-29 Thread Leonid Bobrov
On Tue, May 29, 2018 at 03:33:08PM +0200, Henning Brauer wrote: > Hi, > > very welcome! > > I have applied the diff and don't notice immediate breakage. Pls poke You didn't notice cursor movement bugs? o_O Well, I'm giving example: авыавыавы To move from start to end of that word, you have to

ssh: xmss vs sphincs

2018-05-29 Thread Daniel Cegiełka
Hi, Sorry if this is a more "misc-list" topic, but according to Cryptography Services[1] team: "SPHINCS[2] is the more recent one (vs XMSS), combining a good numbers of advances in the field and even more! Bringing the statelessness we were all waiting for." Would SPHINCS be not a better choice

Some tweaks for the VIA PadLock driver

2018-05-29 Thread Frederic Cambus
Hi tech@, Return error values directly where appropriate, instead of using the err variable. While there, remove TODO about bitching. We haven't felt the need to bitch since the driver was commited, and we do not bitch in aesni_setup() either. Comments? OK? Index: sys/arch/amd64/amd64/via.c

httpd request rewrite

2018-05-29 Thread Reyk Floeter
Hi, it's about time. server "default" { listen on * port 80 location match "/de/(.*)" { request rewrite "/ch/%1" } } You can also you the macros as in the "block return" external redirects. So maybe

Add sizes for free() for octeon

2018-05-29 Thread Frederic Cambus
Hi tech@, Add sizes for free() for octeon. Comments? OK? Index: sys/arch/octeon/dev/amdcf.c === RCS file: /cvs/src/sys/arch/octeon/dev/amdcf.c,v retrieving revision 1.5 diff -u -p -r1.5 amdcf.c --- sys/arch/octeon/dev/amdcf.c 30