ospf(6)d: do not unlink the control socket

2020-09-16 Thread Remi Locherer
In 2018 we discussed that it is OK when ripd leaves its control socket laying around: https://marc.info/?l=openbsd-tech=154101413029926=2 When mestre@ adapted ldpd in June this year I was reminded to also adapt ospfd and ospf6d for consistent. OK? Remi Index: ospfd/control.c

Re: systat(1): vmstat: compute rates with CLOCK_UPTIME

2020-09-16 Thread Theo de Raadt
Two days ago during my work on ongoing work for non-acpi suspend, kettenis and I observed the same thing. your diff works very well for me.

Re: sigabort(), p_sigmask & p_siglist

2020-09-16 Thread Martin Pieuchot
On 16/09/20(Wed) 06:09, Miod Vallat wrote: > > > Diff below introduces an helper for sending an uncatchable SIGABRT and > > annotate that `p_siglist' and `p_sigmask' are updated using atomic > > operations. > > Why not use sigexit(p, SIGABRT); for that purpose? That's a better solution indeed.

Re: KASSERT() for VOP_*

2020-09-16 Thread Martin Pieuchot
On 09/09/20(Wed) 08:41, Martin Pieuchot wrote: > This is mostly the same diff that has been backed out months ago with > the VOP_CLOSE() case fixed. VOP_CLOSE() can accept a NULL argument > instead of `curproc' when garbage collecting passed FDs. > > The intent is to stop passing a "struct proc

Re: sigabort(), p_sigmask & p_siglist

2020-09-16 Thread Theo de Raadt
Something doesn't feel right. db_kill_cmd finds a process, called p, then kills it. In your new diff calling sigexit, take note of the comment at the top: * Force the current process to exit with the specified signal, dumping core current process? Doesn't look like it, it looks like it kills

Re: sigabort(), p_sigmask & p_siglist

2020-09-16 Thread Martin Pieuchot
On 16/09/20(Wed) 02:08, Theo de Raadt wrote: > Something doesn't feel right. > > db_kill_cmd finds a process, called p, then kills it. In your new diff > calling sigexit, take note of the comment at the top: > > * Force the current process to exit with the specified signal, dumping core > >

Re: sigabort(), p_sigmask & p_siglist

2020-09-16 Thread Miod Vallat
> Diff below introduces an helper for sending an uncatchable SIGABRT and > annotate that `p_siglist' and `p_sigmask' are updated using atomic > operations. Why not use sigexit(p, SIGABRT); for that purpose?

syslogd close higher fds on pipe exec

2020-09-16 Thread Martijn van Duren
I don't think we should keep these fds around on exec. OK? Index: privsep.c === RCS file: /cvs/src/usr.sbin/syslogd/privsep.c,v retrieving revision 1.71 diff -u -p -r1.71 privsep.c --- privsep.c 5 Jul 2019 13:23:27 -

Re: diff: pfctl: error message for nonexisting rtable

2020-09-16 Thread Klemens Nanni
On Wed, Sep 16, 2020 at 06:22:00PM +0900, YASUOKA Masahiko wrote: > Let me continue this separetely. Yes, let's get your diff in for release and then work out the other approach. > Make pfctl check if the rtable really exists when parsing the config. The diff is a bit hard to read (nothing you

Re: sigabort(), p_sigmask & p_siglist

2020-09-16 Thread Miod Vallat
> Something doesn't feel right. > > db_kill_cmd finds a process, called p, then kills it. In your new diff > calling sigexit, take note of the comment at the top: > > * Force the current process to exit with the specified signal, dumping core > > current process? Doesn't look like it, it

Re: diff: pfctl: error message for nonexisting rtable

2020-09-16 Thread YASUOKA Masahiko
Hi, So, it seems we need to more code and test for pf(4) part. Let me continue this separetely. On Mon, 14 Sep 2020 11:07:53 +0200 Klemens Nanni wrote: > On Mon, Sep 14, 2020 at 02:09:27PM +0900, YASUOKA Masahiko wrote: >> Make pfctl check if the rtable really exists when parsing the config. >

Re: diff: pfctl: error message for nonexisting rtable

2020-09-16 Thread YASUOKA Masahiko
Hi, On Wed, 16 Sep 2020 12:04:55 +0200 Klemens Nanni wrote: > Using the function verb would reads a bit clearer/more intuitive, > i.e. Yes, "if (!rtable_exists($2))" seems better. >> @@ -5887,17 +5897,37 @@ rdomain_exists(u_int rdomain) >> >> len = sizeof(info); >> if (sysctl(mib,

rpki-client: POSIX compliant TZ variable

2020-09-16 Thread Mathias
Hello. Below is a patch for changing "UTC" into "UTC0" for TZ assignments. The former is not POSIX compliant. From /usr/src/lib/libc/time/Theory: The POSIX TZ string takes the following form: stdoffset[dst[offset],date[/time],date[/time]] where: std and

Re: diff: pfctl: error message for nonexisting rtable

2020-09-16 Thread Klemens Nanni
On Wed, Sep 16, 2020 at 07:49:19PM +0900, YASUOKA Masahiko wrote: > New diff is using -1 for ENOENT. > > Also domainid == 0 is a valid domain id, but previous diff cannot make > a cache of it since 0 is the default value. So new diff is doing > > - static u_int

Re: drop support for afs, nnpfs, and procfs from security(8)

2020-09-16 Thread Todd C . Miller
On Wed, 16 Sep 2020 18:17:36 +0200, Ingo Schwarze wrote: > Does anyone think that explicitely excluding these file system > types might still be useful, or is the following simplification > OK? No functional change intended. I think those bits can go. OK millert@ - todd

drop support for afs, nnpfs, and procfs from security(8)

2020-09-16 Thread Ingo Schwarze
Hi, by chance, i noticed that security(8) is careful to avoid scanning filesystems of the types "afs", "nnpfs", and "procfs". According to "ls /sbin/mount*", no such file systems are supported, and the only page "man -ak any=afs any=nnpfs any=procfs" brings up seems to be sshd_config(5) talking

examples/acme-client.conf spaces -> tabs

2020-09-16 Thread navan
Convert leading spaces to tabs, matching the rest of the file. Index: acme-client.conf === RCS file: /cvs/src/etc/examples/acme-client.conf,v retrieving revision 1.3 diff -u -p -r1.3 acme-client.conf --- acme-client.conf14 Sep

Re: systat(1): vmstat: compute rates with CLOCK_UPTIME

2020-09-16 Thread Scott Cheloha
On Wed, Sep 16, 2020 at 01:20:16AM -0600, Theo de Raadt wrote: > Two days ago during my work on ongoing work for non-acpi suspend, > kettenis and I observed the same thing. > > your diff works very well for me. Okay, so I'm not the only one. Let's do the full patch: - All rates in the vmstat