Re: [PATCH] Define IMSG_DATA_SIZE() in imsg.h

2018-05-27 Thread Klemens Nanni
On Sun, May 27, 2018 at 01:12:21AM +0300, Consus wrote: > +++ b/usr.sbin/httpd/httpd.h > @@ -195,7 +195,6 @@ struct imsgev { > if (IMSG_DATA_SIZE(imsg) < sizeof(*p)) \ > fatalx("bad length imsg received"); \ > } while (0) > -#define

[PATCH] Define IMSG_DATA_SIZE() in imsg.h

2018-05-26 Thread Consus
To reduce code duplication a little bit. diff --git a/lib/libutil/imsg.h b/lib/libutil/imsg.h index 8bf9414789b..8436e157b38 100644 --- a/lib/libutil/imsg.h +++ b/lib/libutil/imsg.h @@ -23,6 +23,7 @@ #define IBUF_READ_SIZE 65535 #define IMSG_HEADER_SIZE sizeof(struct imsg_hdr)