[Touch-packages] [Bug 1602680] Re: ecryptfs not work with libnss3/libnss3-1d Version 2:3.23-0ubuntu0.12.04.1

2016-07-13 Thread Grek-336
ulimit -a with the old 2:3.21-0ubuntu0.12.04.3 Version after login.
core file size  (blocks, -c) 0
data seg size   (kbytes, -d) unlimited
scheduling priority (-e) 0
file size   (blocks, -f) unlimited
pending signals (-i) 28223
max locked memory   (kbytes, -l) 64
max memory size (kbytes, -m) unlimited
open files  (-n) 1024
pipe size(512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority  (-r) 0
stack size  (kbytes, -s) 8192
cpu time   (seconds, -t) unlimited
max user processes  (-u) 28223
virtual memory  (kbytes, -v) unlimited
file locks  (-x) unlimited

My Laptop (Lenovo X121e AMD E300 processor) buying 12/04

The installed Ubuntu version is the first 12.04. No upgrade to newer
Kernel.

The AMD E-Serie has no AES-NI extension.

The encryption of the home directory doing by installation for 4 years
and never change.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nss in Ubuntu.
https://bugs.launchpad.net/bugs/1602680

Title:
  ecryptfs not work with libnss3/libnss3-1d Version
  2:3.23-0ubuntu0.12.04.1

Status in nss package in Ubuntu:
  Incomplete

Bug description:
  After updating libnss3 and libnss3-1d from 2:3.21-0ubuntu0.12.04.3 to
  2:3.23-0ubuntu0.12.04.1 last night it is not longer possible to mount
  my home directory encrypted with ecryptfs.

  Automatic by login or with ecryptfs-recover-private or else not work.

  After downgrade to Version 2:3.21-0ubuntu0.12.04.3 if works fine.

  syslog:

  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: do_hash: PK11_HashBuf() error; 
SECFailure = [-1]; PORT_GetError() = [-8128]
  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: Error generating passphrase 
signature; rc = [-22]
  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: Error attempting to unwrap 
passphrase from file [/home/michael/.ecryptfs/wrapped-passphrase]; rc = [-22]

  
-

  lsb_release -rd

  Description:  Ubuntu 12.04.5 LTS
  Release:  12.04


  apt-cache policy libnss3 libnss3-1d after downgrade to previous
  version

  libnss3:
Installiert: 2:3.21-0ubuntu0.12.04.3
Kandidat:2:3.23-0ubuntu0.12.04.1
Versionstabelle:
   2:3.23-0ubuntu0.12.04.1 0
  500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 
Packages
  500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 
Packages
   *** 2:3.21-0ubuntu0.12.04.3 0
  100 /var/lib/dpkg/status
   3.13.1.with.ckbi.1.88-1ubuntu6 0
  500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
  libnss3-1d:
Installiert: 2:3.21-0ubuntu0.12.04.3
Kandidat:2:3.23-0ubuntu0.12.04.1
Versionstabelle:
   2:3.23-0ubuntu0.12.04.1 0
  500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 
Packages
  500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 
Packages
   *** 2:3.21-0ubuntu0.12.04.3 0
  100 /var/lib/dpkg/status
   3.13.1.with.ckbi.1.88-1ubuntu6 0
  500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

  I have marked the bug as security vulnerability because

  I must use older version they be more unsafe than the new one to work
  with my laptop.

  Unfortunately I go to holiday tomorrow. I'll be back at next monday
  18. July 2016

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nss/+bug/1602680/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1283003] Re: [Bluetooth + 14.04] Bluetooth headsets are not working after last couple of updates

2016-07-13 Thread andrew.gedz
I've got problem with Jabra Rox Wireless in pairing mode hangs up ubuntu
16.04(current) also same problem on  previously installed 14.04. What
info I can provide to help to investigate this ?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1283003

Title:
  [Bluetooth + 14.04] Bluetooth headsets are not working after last
  couple of updates

Status in Blueman:
  New
Status in blueman package in Ubuntu:
  Fix Released
Status in bluez package in Ubuntu:
  Confirmed
Status in gnome-bluetooth package in Ubuntu:
  Confirmed

Bug description:
  Hi,

  I found a bug in Ubuntu 14.04 !

  I tried to pair a bluetooth stereo headset (A2DP compatible). The
  pairing process goes well, but after that I can't select it on the
  audio preferences.

  When I select it, it only shows the last selected item options and don't do 
anything. (he should switch to the headset output).
  I must mention that it worked very well on Ubuntu 12.04.

  This bug can be in the bluetooth stack or in unity-control-center or
  maybe pulseaudio. I actually have no idea.

To manage notifications about this bug go to:
https://bugs.launchpad.net/blueman/+bug/1283003/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1588237] Re: Inconsistent behaviour of Num Lock

2016-07-13 Thread Daniel van Vugt
** Changed in: mir
   Importance: Undecided => Medium

** Changed in: mir (Ubuntu)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mir in Ubuntu.
https://bugs.launchpad.net/bugs/1588237

Title:
  Inconsistent behaviour of Num Lock

Status in Canonical System Image:
  Confirmed
Status in Mir:
  In Progress
Status in mir package in Ubuntu:
  Triaged

Bug description:
  How to reproduce:
  M10 with external Keyboard and Screen, after restart on OTA11.
  To use numbers in the unlock screen, the num key has to be active.
  After unlocking, use a search field in the homescope or any other scope.

  Expected behaviour:
  The numblock should work, as the num key is still active.

  Actual behaviour:
  The numblock only works, when you deactivate the num key.

  This is the same for the browserbar or the telegram chat.
  After some time, the behaviour changes, so the numblock behaviour seems to be 
inconsistent.

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1588237/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1573755] Re: Compose and dead keys stopped working

2016-07-13 Thread Gunnar Hjalmarsson
I can reproduce this XIM problem on a system which was upgraded to
16.04, but not on a fresh Ubuntu 16.04. However: If I create and switch
to a new user, the problem is not present. In other words: Some
leftovers from previous version(s) in the home directory of my main user
prevent the XIM input method from working properly.

Resetting the gtk-im-module gsettings key, as mentioned by Piotr,
doesn't help for me. Neither does removing of the whole gsettings
database ~/.config/dconf/user

For the record: On Ubuntu and most flavors, switching to some other
input method can be done from the Language Support GUI. Doing so changes
the ~/.xinputrc file instead of removing it.

** Summary changed:

- Compose and dead keys stopped working
+ Compose and dead keys stopped working with XIM after upgrade to 16.04

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ibus in Ubuntu.
https://bugs.launchpad.net/bugs/1573755

Title:
  Compose and dead keys stopped working with XIM after upgrade to 16.04

Status in firefox package in Ubuntu:
  Invalid
Status in gnome-terminal package in Ubuntu:
  Invalid
Status in ibus package in Ubuntu:
  Confirmed
Status in nautilus package in Ubuntu:
  Invalid
Status in thunderbird package in Ubuntu:
  Invalid

Bug description:
  After upgrading to 16.04, entering characters using dead keys and
  using the Compose key stopped working in Gnome Terminal, acting like
  they are normal (non-dead) keys.

  Other applications, even those who use the same libvte (e.g. ROXTerm),
  don't have this issue.

  This happens with both the "Belgian" and "English international with
  AltGr dead keys" layouts.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: gnome-terminal 3.18.3-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Fri Apr 22 20:45:33 2016
  InstallationDate: Installed on 2013-12-16 (857 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 
(20131016.1)
  SourcePackage: gnome-terminal
  UpgradeStatus: Upgraded to xenial on 2016-04-22 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1573755/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1582979] Re: package linux-image-3.16.0-71-generic 3.16.0-71.92~14.04.1 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1

2016-07-13 Thread cltien
Try to partial upgrade as full upgrade shows error. Anyway partial
upgrade still failed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1582979

Title:
  package linux-image-3.16.0-71-generic 3.16.0-71.92~14.04.1 failed to
  install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools
  exited with return code 1

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  Just happened after software update, I did not restart, instead, I
  powered off and powered on the next day.

  ProblemType: Package
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.16.0-71-generic 3.16.0-71.92~14.04.1
  ProcVersionSignature: Ubuntu 3.16.0-71.92~14.04.1-generic 3.16.7-ckt27
  Uname: Linux 3.16.0-71-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
  Date: Tue May 17 23:32:21 2016
  DuplicateSignature: 
package:linux-image-3.16.0-71-generic:3.16.0-71.92~14.04.1:run-parts: 
/etc/kernel/postinst.d/initramfs-tools exited with return code 1
  ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
  InstallationDate: Installed on 2015-12-06 (163 days ago)
  InstallationMedia: Edubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 
(20150218.1)
  RelatedPackageVersions:
   dpkg 1.17.5ubuntu5.6
   apt  1.0.1ubuntu2.13
  SourcePackage: initramfs-tools
  Title: package linux-image-3.16.0-71-generic 3.16.0-71.92~14.04.1 failed to 
install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1582979/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1493574] Re: [vegeta] Phone app makes screen stay black during call (so you can't hang up)

2016-07-13 Thread Lorn Potter
In #46, there is a difference of an ALS entry. (Pat's does not have one, while 
the one containing
an error has one) but the error is contained in the ALS/PS, while LHJ_PS looks 
normal. These functions that look like they pertain to calibration. 

As in the log from #45 seems to point to ALS/PS reading from mt-i2c, it
could originate in the hardware, but the software doesn't recover.
Whether that software is the driver, android sensors or powerd or
something else would require digging through the code. My guess is the
(als) driver doesn't handle this well.

It is interesting that this seems to happen on krillin as well, but
apparently not all devices. I'm not familiar enough with these to
devices to know if they use the same als/ps chip or share driver code.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to powerd in Ubuntu.
https://bugs.launchpad.net/bugs/1493574

Title:
  [vegeta] Phone app makes screen stay black during call (so you can't
  hang up)

Status in Canonical System Image:
  Incomplete
Status in vegetahd:
  New
Status in powerd package in Ubuntu:
  Confirmed
Status in unity-system-compositor package in Ubuntu:
  Confirmed

Bug description:
  A similar, if not the same bug, has been reported to be fixed for
  OTA6. This bug report explains that it's no necessary to wait for a
  minute or so on the phone call, but the screen turns black
  immediately, and doesn't turn back on again to allow hanging up via a
  screen control.

  Potential duplicate: https://bugs.launchpad.net/canonical-devices-
  system-image/+bug/1483127

  Device: Aquaris E5 HD Ubuntu Edition
  OS version: 15.04 (r5)

  A) Incoming phone call:
     - Accept the incoming call by sliding the grey middle button to the 
green button
     - Watch the screen turning black
     - Bring the phone to your ear, speak (as in a normal phone call)
     - Take the phone away from your ear, note that the screen stays black

     How to hang up anyway: (workaround)
     - (continued from above, screen stays black after taking it away from 
your ear)
     - Press the screen lock/unlock button (= button above volume control)
     - Screen with phone app shows for about half a second, then turns 
black again
     - Press the screen lock/unlock button again, and try to press the red 
hangup button quickly
     - Repeat the previous step until hanging up succeeds

  B) Outbound phone call:
     - Open the phone app
     - Slide up Recent calls list from bottom edge, select a phone number
     - Press green dial button to initiate the call
     - Watch the phone dialling and the screen turning black
     - Bring the phone to your ear, speak (as in a normal phone call)
     - Take the phone away from your ear, note that the screen stays black

     How to hang up anyway: (workaround)
     - (same procedure as in A. above)
     - Difference in behavior:
   * In some calls after pressing the lock/unlock button for the first 
time the screen stays alight (doesn't turn black again after half a second).

  
  Jean-Baptiste Lallement confirms on the ubuntu-phone mailing list:
  In both cases, covering/uncovering the proximity sensor should turn the 
screen on, if the screen has not been turned off with the power button. (This 
is not happening.)

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1493574/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602628] Re: can't drag/move window if it's semi-maximized

2016-07-13 Thread Daniel van Vugt
Semi-maximization works, and windows are still draggable if you use the
traditional middle/right click on the maximize button.

What you're doing though isn't really semi-maximize.
Ctrl+Super+Left/Right means to fill half the screen. So it might be an
intentional design decision that state is not movable.

I know this is different to how it works in Unity7, but it might not be
a bug.

** Changed in: unity8 (Ubuntu)
   Status: Triaged => Incomplete

** Also affects: ubuntu-ux
   Importance: Undecided
   Status: New

** Summary changed:

- can't drag/move window if it's semi-maximized
+ can't drag/move window if it's semi-maximized by Ctrl+Super+Left/Right

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1602628

Title:
  can't drag/move window if it's semi-maximized by Ctrl+Super+Left/Right

Status in Ubuntu UX:
  New
Status in unity8 package in Ubuntu:
  Incomplete

Bug description:
  ubuntu 16.10
  can't drag/move window if it's semi-maximized

  open random app, semi-miaximize left or rigt (CTRL SUPER + Left or
  Right), try to move the window by draggin' it from the title bar.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-ux/+bug/1602628/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1536751] Re: Font/text rendering is irregular and not pixel-aligned on low DPI screens

2016-07-13 Thread Daniel van Vugt
When it's fully extended the fonts look bad. So this is not a texture
coordinate problem. I think the surface texture is correctly pixel
aligned but we haven't yet made sure the font hinting within the surface
is also pixel-aligned. Unity7 text still looks nicer and more polished
than Unity8.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1536751

Title:
  Font/text rendering is irregular and not pixel-aligned on low DPI
  screens

Status in QtMir:
  New
Status in fontconfig package in Ubuntu:
  Incomplete
Status in freetype package in Ubuntu:
  Incomplete
Status in harfbuzz package in Ubuntu:
  Confirmed
Status in qtbase-opensource-src package in Ubuntu:
  Incomplete
Status in ubuntu-font-family-sources package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in unity8 package in Ubuntu:
  Confirmed

Bug description:
  This is a Dell Vostro 3550 laptop with a fresh install of 16.04 and
  unity8 Mir session

  the version of qtdeclarative5-qtmir-plugin is
  0.4.7+16.04.20160104-0ubuntu1

  As you can see from the screenshots the text has low details and, in
  the case of indicators descriptions at the top, almost disappears.

  The text could be fixed by using Text.NativeRendering instead of 
Text.QtRendering for the QML labels on low dpi screens, although text doesn't 
seem to be the only issue here. The icons are definitely lacking detail as well 
(QML Image's smoothing is enabled maybe?).
  Also the dots of the infographic don't look like circles at all, they're 
missing pixels and many of them look like a C more than an O.

  It looks to me like something is setting the wrong resolution, because
  it looks quite bad. But the screenshots are 1366x768 so I think that's
  not the case.

  NOTE: Unity7 looks perfectly fine and detailed

To manage notifications about this bug go to:
https://bugs.launchpad.net/qtmir/+bug/1536751/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1303354] Re: [Apps Scope] App Summary appears to be part of Description

2016-07-13 Thread Rodney Dawes
** No longer affects: click (Ubuntu)

** No longer affects: unity8

** No longer affects: unity8 (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to click in Ubuntu.
https://bugs.launchpad.net/bugs/1303354

Title:
  [Apps Scope] App Summary appears to be part of Description

Status in Click Package Index:
  Invalid
Status in Software Center Agent:
  Fix Released
Status in Ubuntu UX:
  Fix Released
Status in unity-scope-click package in Ubuntu:
  Triaged

Bug description:
  The tagline in app descriptions looks like it is part of the main
  description, without any spacing or difference in font, which makes it
  hard to read. Is it possible to make the tagline bold or separated in
  some way?

  Desired solution
  -
  Separate out tagline from rest of info and place directly below screenshots - 
see attached design including the tagline / strapline

To manage notifications about this bug go to:
https://bugs.launchpad.net/click-package-index/+bug/1303354/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1469377] Re: [scopes] bottom edge should show favourite apps

2016-07-13 Thread Rodney Dawes
** Changed in: unity-scope-click (Ubuntu)
   Importance: Undecided => Wishlist

** Also affects: unity8 (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1469377

Title:
  [scopes] bottom edge should show favourite apps

Status in Ubuntu UX:
  Triaged
Status in unity-scope-click package in Ubuntu:
  New
Status in unity8 package in Ubuntu:
  New

Bug description:
  Placing the settings on the bottom edge is a waste of 'resources'.
  Once the dash is more or less set up, it won't be changed to often. My
  suggestion is to place the settings in the header and therefore make a
  favourite app via available via the bottom edge.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-ux/+bug/1469377/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1546641] Re: unity-settings-daemon crashed with SIGSEGV in up_exported_daemon_get_lid_is_closed()

2016-07-13 Thread Daniel van Vugt
Got the bug back on xenial. Applied the proposed fix 0.99.4-2ubuntu0.3
and rebooted three times. The bug has not returned. All fixed, thanks.

** Tags removed: verification-needed
** Tags added: verification-done

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to upower in Ubuntu.
https://bugs.launchpad.net/bugs/1546641

Title:
  unity-settings-daemon crashed with SIGSEGV in
  up_exported_daemon_get_lid_is_closed()

Status in Upower:
  Unknown
Status in unity-settings-daemon package in Ubuntu:
  Triaged
Status in upower package in Ubuntu:
  Fix Released
Status in unity-settings-daemon source package in Xenial:
  Triaged
Status in upower source package in Xenial:
  Fix Committed
Status in unity-settings-daemon source package in Yakkety:
  Triaged
Status in upower source package in Yakkety:
  Fix Released

Bug description:
  https://errors.ubuntu.com/problem/8ca9c548fc4e2fc1d4bf827bbd85c72df59313f8

  Ubuntu 16.04 crashes immediately on login. Default settings not
  applied and appearance is a bit ugly (incorrect font hinting, in-
  window menus etc).

  SRU TEST CASE (upower)
  --
  On affected machines, unity-settings-daemon crashes immediately on login, as 
due to a kernel bug upowerd takes a very long time to start. With the fixed 
package the crash is fixed. Power status information will still be wrong, but 
at least theme, hotkeys, and all other unity-settings-daemon functionality will 
work.

  This can be synthetically tested with:

     DBUS_SYSTEM_BUS_ADDRESS=foo upower --dump

  With the current xenial version this causes a segfault, while with the
  fix you get a proper error message.

  Fix: https://cgit.freedesktop.org/upower/commit/?id=932a6a39e3
 https://cgit.freedesktop.org/upower/commit/?id=4e83fabac
  (The second one is not crucial, but provides a much better failure mode for 
the "upower" CLI tool).

  Regression potential: This changes the core behaviour of libupower.
  The patch is carefully written to be backwards compatible to the
  extent possible, but changing the behaviour is necessary to fix this
  bug (see commit log for details). Thus clients such as unity-control-
  center, unity-settings-daemon, or mate-power-manager should be tested
  as part of the verification.

  ---

  ProblemType: Crash
  DistroRelease: Ubuntu 16.04
  ProcVersionSignature: Ubuntu 4.4.0-6.21-generic 4.4.1
  Uname: Linux 4.4.0-6-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CrashCounter: 1
  Date: Wed Feb 17 13:52:13 2016
  ExecutablePath: /usr/lib/unity-settings-daemon/unity-settings-daemon
  InstallationDate: Installed on 2016-02-08 (8 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160205)
  ProcCmdline: /usr/lib/unity-settings-daemon/unity-settings-daemon
  ProcEnviron:
   LANGUAGE=pt_BR:pt:en
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=pt_BR.UTF-8
   SHELL=/bin/false
  SegvAnalysis:
   Segfault happened at: 0x3aae60fe69 : 
mov(%rbx),%rdi
   PC (0x3aae60fe69) ok
   source "(%rbx)" (0x) not located in a known VMA region (needed 
readable region)!
   destination "%rdi" ok
  SegvReason: reading NULL VMA
  Signal: 11
  SourcePackage: unity-settings-daemon
  StacktraceTop:
   up_exported_daemon_get_lid_is_closed () from 
/usr/lib/x86_64-linux-gnu/libupower-glib.so.3
   gsd_power_manager_start () from 
/usr/lib/unity-settings-daemon-1.0/libpower.so
   ?? () from /usr/lib/unity-settings-daemon-1.0/libpower.so
   gnome_settings_plugin_info_activate ()
   ?? ()
  Title: unity-settings-daemon crashed with SIGSEGV in 
up_exported_daemon_get_lid_is_closed()
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:

To manage notifications about this bug go to:
https://bugs.launchpad.net/upower/+bug/1546641/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1581241] Re: bluetooth headset doesn't automatically configure for a2dp correctly (regression)

2016-07-13 Thread Ethan Blanton
I have isolated a method for making things work, for others who may have
similar problems:

1) Connect headset by turning it on.
2) Set headset to headset (not a2dp) mode using blueman-manager
3) Disconnect headset from blueman-manager
4) Reconnect headset from blueman-manager; it will show Audio Profile: off
5) Set audio profile to A2DP

At this point, it generally seems to work.  Shorter sequences have not
yet reliably worked for me.  Some parts of the dance can be done in
pavucontrol, but it's easiest to do it all in one place.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1581241

Title:
  bluetooth headset doesn't automatically configure for a2dp correctly
  (regression)

Status in bluez package in Ubuntu:
  New

Bug description:
  I have a bluetooth headset capable of several modes of connection
  (headset, handsfree, and a2dp).  In 15.10, once I had correctly
  configured it for a2dp once, applications using pulseaudio could use
  it freely each time it was connected to the machine.

  In 16.04, upon connection, applications that attempt to use it appear
  to hang waiting for something.  I have to fiddle with its settings
  (and sorry I can't be more specific, but it's not clear to me exactly
  what sequence fixes it; I change it to/from headset and A2DP in
  blueman a few times, do the same in pavucontrol, etc., and at some
  point it starts working) for several minutes to get it working in a2dp
  mode.  It appears that after connection I can put it in headset mode
  and start playing to it immediately, but of course the audio quality
  is horrible.

  Once I've fiddled it into working, it works until disconnected, and
  upon reconnect it behaves the same as before I fiddled it into
  submission: a2dp connection, but clients accessing it hang.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: bluez 5.37-0ubuntu5
  ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  Date: Thu May 12 18:38:16 2016
  InstallationDate: Installed on 2015-06-04 (342 days ago)
  InstallationMedia: Lubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: Dell Inc. XPS13 9333
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-22-generic.efi.signed 
root=/dev/mapper/lubuntu--vg-root ro quiet splash vt.handoff=7
  SourcePackage: bluez
  UpgradeStatus: Upgraded to xenial on 2016-04-22 (20 days ago)
  dmi.bios.date: 11/07/2014
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A06
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: 0.1
  dmi.modalias: 
dmi:bvnDellInc.:bvrA06:bd11/07/2014:svnDellInc.:pnXPS139333:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
  dmi.product.name: XPS13 9333
  dmi.sys.vendor: Dell Inc.
  hciconfig:
   hci0:Type: BR/EDR  Bus: USB
BD Address: 5C:51:4F:7C:03:11  ACL MTU: 1021:5  SCO MTU: 96:5
UP RUNNING PSCAN 
RX bytes:1391 acl:0 sco:0 events:164 errors:0
TX bytes:27517 acl:0 sco:0 commands:163 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1581241/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1571042] Re: Cannot install i386 Qt dev packages on amd64 system

2016-07-13 Thread katsiki
This might be related to the problem I reported,
https://bugs.launchpad.net/ubuntu/+source/appstream/+bug/1601971

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1571042

Title:
  Cannot install i386 Qt dev packages on amd64 system

Status in qtbase-opensource-src package in Ubuntu:
  New

Bug description:
  $ sudo apt-get update
  Get:1 http://by.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
  Hit:2 http://security.ubuntu.com/ubuntu xenial-security InRelease
  Hit:3 http://by.archive.ubuntu.com/ubuntu xenial-updates InRelease
  Hit:4 http://by.archive.ubuntu.com/ubuntu xenial-backports InRelease
  Get:5 http://by.archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1.183 
kB]
  Get:6 http://by.archive.ubuntu.com/ubuntu xenial/main i386 Packages [1.178 kB]
  Get:7 http://by.archive.ubuntu.com/ubuntu xenial/main Translation-en [563 kB]
  Get:8 http://by.archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata 
[635 kB]
  Get:9 http://by.archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [404 
kB]
  Get:10 http://by.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages 
[7.543 kB]
  Get:11 http://by.archive.ubuntu.com/ubuntu xenial/universe i386 Packages 
[7.523 kB]  
  
  Get:12 http://by.archive.ubuntu.com/ubuntu xenial/universe Translation-en 
[4.361 kB]  
 
  Get:13 http://by.archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 
Metadata [1.805 kB] 
   
  Get:14 http://by.archive.ubuntu.com/ubuntu xenial/universe DEP-11 64x64 Icons 
[7.448 kB]  
 
  Get:15 http://by.archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages 
[146 kB]
   
  Get:16 http://by.archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages 
[142 kB]

  Get:17 http://by.archive.ubuntu.com/ubuntu xenial/multiverse Translation-en 
[107 kB]
   
  Get:18 http://by.archive.ubuntu.com/ubuntu xenial/multiverse amd64 DEP-11 
Metadata [7.840 B]  
 
  Get:19 http://by.archive.ubuntu.com/ubuntu xenial/multiverse DEP-11 64x64 
Icons [235 kB]  
 
  Fetched 33,5 MB in 25s (1.329 kB/s)   

 
  AppStream cache update completed, but some metadata was ignored due to errors.
  Reading package lists... Done

  $ sudo apt-get install qtbase5-dev:i386
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.
  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
   qtbase5-dev:i386 : Depends: libgles2-mesa-dev:i386 but it is not going to be 
installed or
   libgles2-dev:i386 but it is not installable
  E: Unable to correct problems, you have held broken packages.

  $ dpkg --print-foreign-architectures
  i386

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: qtbase5-dev 5.5.1+dfsg-16ubuntu7
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Uname: Linux 4.4.0-18-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Fri Apr 15 21:43:15 2016
  InstallationDate: Installed on 2016-04-15 (0 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160415)
  SourcePackage: qtbase-opensource-src
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1571042/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602900] [NEW] libzmq3 crashes when 'getifaddrs()' is unavailable

2016-07-13 Thread Adam Seering
Public bug reported:

libzmq3 crashes when used on a computer where the kernel is unable to
provide any information about network-device addresses.

This is uncommon with normal Ubuntu configurations.  But is currently
always the case with Ubuntu as run under the new Windows Subsystem for
Linux.

This has already been diagnosed and fixed upstream:
https://github.com/jupyter/notebook/issues/1331

I have backported the fix; an updated package (based on the stock Ubuntu 14.04 
package but with the backport as an added patch) is available in this PPA:
https://launchpad.net/~aseering/+archive/ubuntu/wsl

This has been reported in a couple other bugtrackers.  Even with the fix in a 
PPA, there's still some amount of user confusion:
https://github.com/jupyter/notebook/issues/1331
https://github.com/Microsoft/BashOnWindows/issues/185

It would be great if this fix could be pulled into Ubuntu 14.04
directly, so that people stop hitting this bug.

** Affects: zeromq3 (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to zeromq3 in Ubuntu.
https://bugs.launchpad.net/bugs/1602900

Title:
  libzmq3 crashes when 'getifaddrs()' is unavailable

Status in zeromq3 package in Ubuntu:
  New

Bug description:
  libzmq3 crashes when used on a computer where the kernel is unable to
  provide any information about network-device addresses.

  This is uncommon with normal Ubuntu configurations.  But is currently
  always the case with Ubuntu as run under the new Windows Subsystem for
  Linux.

  This has already been diagnosed and fixed upstream:
  https://github.com/jupyter/notebook/issues/1331

  I have backported the fix; an updated package (based on the stock Ubuntu 
14.04 package but with the backport as an added patch) is available in this PPA:
  https://launchpad.net/~aseering/+archive/ubuntu/wsl

  This has been reported in a couple other bugtrackers.  Even with the fix in a 
PPA, there's still some amount of user confusion:
  https://github.com/jupyter/notebook/issues/1331
  https://github.com/Microsoft/BashOnWindows/issues/185

  It would be great if this fix could be pulled into Ubuntu 14.04
  directly, so that people stop hitting this bug.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/zeromq3/+bug/1602900/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1342400] Re: avahi-daemon constantly reporting "Invalid response packet from host"

2016-07-13 Thread Mathew Hodson
** Tags removed: verification-neededd
** Tags added: verification-needed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to avahi in Ubuntu.
https://bugs.launchpad.net/bugs/1342400

Title:
  avahi-daemon constantly reporting "Invalid response packet from host"

Status in avahi package in Ubuntu:
  Fix Released
Status in avahi source package in Precise:
  Fix Released
Status in avahi source package in Trusty:
  Fix Committed
Status in avahi package in Debian:
  Fix Released

Bug description:
  After installing Ubuntu 14.04 (Release: 14.04) and looking for other
  information in /var/log/syslog, I see that syslog is being flooded by
  "Invalid response packet from host" messages from avahi-daemon.

  I searched around to see why this might be and ran across the following avahi 
mailing list post along with a patch to fix it:
  http://lists.freedesktop.org/archives/avahi/2012-July/002171.html

  >>>
  I would say you can safely ignore it, since any machine on your
  network running a recent OSX version will cause these messages.
  Here's a patch with what we change to avoid these messages flooding
  syslog.

  -Justin
  <<<

  The patch which fixes this is here:
  
http://lists.freedesktop.org/archives/avahi/attachments/20120719/1e71846e/attachment.obj

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/avahi/+bug/1342400/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1433590] Re: apparmor dbus denial for org.freedesktop.Accounts and make Other vibrations work

2016-07-13 Thread Zhang Enwei
Thanks Seth and Tyler.
IMHO the start time of one process may always be different value. So... this 
solution is not correct.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1433590

Title:
  apparmor dbus denial for org.freedesktop.Accounts and make Other
  vibrations work

Status in Canonical System Image:
  Triaged
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Fix Released
Status in ubuntu-system-settings package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in usensord package in Ubuntu:
  In Progress

Bug description:
  This affects vivid and (somewhat recently?) 14.09.

  At some point, apps started to request access to
  org.freedesktop.Accounts for something, but I'm not sure what. It has
  been conjectured in this bug that it is due to vibration settings.
  Filing against ubuntu-system-settings for now, but please feel free to
  move to the correct package.

  This happens with webapps:
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"

  and QML apps:
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"

  The following rules allow the requested access:
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.DBus.{Introspectable,Properties}"
 member=Introspect
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.Accounts"
 member=FindUserById
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts/User[0-9]*"
 interface="org.freedesktop.DBus.Properties"
 member=Get
 peer=(name=org.freedesktop.Accounts,label=unconfined),

  However, the above is too lenient and constitutes a privacy leak for
  apps. FindUserById could be used by a malicious app to enumerate
  usernames on multiuser systems and because we can't mediate method
  data with apparmor, the Get() method can be used to obtain any
  information provided by this interface.

  The following can be used to see what can be leaked to a malicious app:
  gdbus introspect --system -d org.freedesktop.Accounts -o 
/org/freedesktop/Accounts/User`id -u phablet`

  This can be solved in a couple of ways:
  1. add whatever information the app is trying to access to a new helper 
service that only exposes things that the app needs. This could be a single 
standalone service, perhaps something from ubuntu-system-settings, that could 
expose any number of things-- the current locale, if the locale changed, if the 
grid units changed, the vibration settings, etc. Since this service wouldn't 
have any sensitive information, you could use standard dbus 
properties/Get()/etc 
  2. add a new dbus API to an existing service such that apparmor rules can 
then be used to allow by method (eg, GetVibration() or something)

  I won't dictate the implementation except to mention that '1' seems
  like something generally useful and I believe that it was something
  the ubuntu-system-settings devs were already looking at for detecting
  locale changes without rebooting.


  Original description
  starting an app in vivid (image 135 on arale currently)

  produces a bunch of dbus denials in syslog ... (there is also a
  /dev/tty one but i think this is just because soemthing tries to write
  an error to console ... so transient)

  

[Touch-packages] [Bug 1522675] Re: /root/.synaptic/ not created due to locking status

2016-07-13 Thread Bill Miller
It's not just synaptic.  Happens with aptitude as well.  I suspect it's
a new requirement for a user named '_apt' which doesn't exist (because
it wasn't added).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1522675

Title:
  /root/.synaptic/ not created due to locking status

Status in apt package in Ubuntu:
  Invalid
Status in synaptic package in Ubuntu:
  Confirmed
Status in synaptic package in Debian:
  New

Bug description:
  Recently we got new versions for synaptic 0.82+build1 & apt 1.1.3, but
  now get that error when installing/upgrading some packages:

  Setting up libc6-dbg:amd64 (2.21-0ubuntu5) ...
  Processing triggers for libc-bin (2.21-0ubuntu5) ...
  W: Can't drop privileges for downloading as file 
'/root/.synaptic/tmp//tmp_cl' couldn't be accessed by user '_apt'. - 
pkgAcquire::Run (13: Permission denied)

  From nautilus, i'm seeing a /root/ folder locked (x on its icon) and
  the folder is empty (no /.synaptic/ sub-folder or file), so the above
  error.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: synaptic 0.82+build1
  ProcVersionSignature: Ubuntu 4.3.0-1.10-generic 4.3.0
  Uname: Linux 4.3.0-1-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.19.2-0ubuntu8
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Fri Dec  4 05:23:25 2015
  SourcePackage: synaptic
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1522675/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1435923] Re: [greeter/desktop] the password entry is not focused by default

2016-07-13 Thread Launchpad Bug Tracker
This bug was fixed in the package unity8 - 8.12+16.10.20160711-0ubuntu1

---
unity8 (8.12+16.10.20160711-0ubuntu1) yakkety; urgency=medium

  [ Josh Arenson ]
  * Add a SessionsModel to lightdm to support the greeter's session
chooser
  * Add unity8-greeter package which contains a basic, but usable
LightDM greeter. (LP: #1324602)

  [ Michael Terry ]
  * Make sure indicators and launcher hide when power button is pressed
on greeter. (LP: #1595569)
  * Fix tablet greeter focus to be always-on, no longer hiding the OSK
or forcing a mouse click to type a password. (LP: #1435923)

 -- Michael Terry   Mon, 11 Jul 2016
17:24:20 +

** Changed in: unity8 (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1435923

Title:
  [greeter/desktop] the password entry is not focused by default

Status in Canonical System Image:
  Triaged
Status in unity8 package in Ubuntu:
  Fix Released

Bug description:
  Using current vivid in desktop mode (desktop-next live session or
  installed), the greeter screen for password has an entry, but this one
  is not getting the keyboard focus by default, which is annoying since
  you can't directly type your password then

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1435923/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1595569] Re: Indicators panel doesn't close when turning screen off

2016-07-13 Thread Launchpad Bug Tracker
This bug was fixed in the package unity8 - 8.12+16.10.20160711-0ubuntu1

---
unity8 (8.12+16.10.20160711-0ubuntu1) yakkety; urgency=medium

  [ Josh Arenson ]
  * Add a SessionsModel to lightdm to support the greeter's session
chooser
  * Add unity8-greeter package which contains a basic, but usable
LightDM greeter. (LP: #1324602)

  [ Michael Terry ]
  * Make sure indicators and launcher hide when power button is pressed
on greeter. (LP: #1595569)
  * Fix tablet greeter focus to be always-on, no longer hiding the OSK
or forcing a mouse click to type a password. (LP: #1435923)

 -- Michael Terry   Mon, 11 Jul 2016
17:24:20 +

** Changed in: unity8 (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1595569

Title:
  Indicators panel doesn't close when turning screen off

Status in Canonical System Image:
  In Progress
Status in unity8 package in Ubuntu:
  Fix Released

Bug description:
  Steps:
  * open indicators
  * press power button to turn the screen off
  * press power button to turn the screen on

  Expected:
  * greeter shown

  Current:
  * indicators panel shown

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: unity8 8.12+16.04.20160617-0ubuntu1 [origin: 
LP-PPA-ci-train-ppa-service-stable-phone-overlay]
  ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
  Uname: Linux 4.4.0-24-generic x86_64
  NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu Jun 23 10:17:32 2016
  InstallationDate: Installed on 2016-05-06 (47 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  SourcePackage: unity8
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1595569/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1324602] Re: [split] unity8-greeter doesn't run on desktop configurations

2016-07-13 Thread Launchpad Bug Tracker
This bug was fixed in the package unity8 - 8.12+16.10.20160711-0ubuntu1

---
unity8 (8.12+16.10.20160711-0ubuntu1) yakkety; urgency=medium

  [ Josh Arenson ]
  * Add a SessionsModel to lightdm to support the greeter's session
chooser
  * Add unity8-greeter package which contains a basic, but usable
LightDM greeter. (LP: #1324602)

  [ Michael Terry ]
  * Make sure indicators and launcher hide when power button is pressed
on greeter. (LP: #1595569)
  * Fix tablet greeter focus to be always-on, no longer hiding the OSK
or forcing a mouse click to type a password. (LP: #1435923)

 -- Michael Terry   Mon, 11 Jul 2016
17:24:20 +

** Changed in: unity8 (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1324602

Title:
  [split] unity8-greeter doesn't run on desktop configurations

Status in unity8 package in Ubuntu:
  Fix Released

Bug description:
  Installing unity8-greeter, from the split greeter silo, on an
  unity8-mir desktop configuration leads to a non working lightdm

  * installing unity8-greeter leads to an empty screen with a cursor
  (looking like a Mir one), which runs for some seconds and do what
  looks like a respawn

  -> editing the unity8-greeter-wrapper to set the qpa to mirclient
  corrected the respawn issue but giving an empty screen still

  * install ubuntu-touch-session gives a working greeter but unlocking
  doesn't start the session

  * GreeterShell.qml has an issue and does unlock only in when autologin
  is enabled, editing that makes unlock dismiss the greeter

  but the session still doesn't start, unlocking the greeter gives a
  screen looking like the phone one ... that needs extra debugging

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1324602/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1574120] Re: Notebook doesn't suspend when lid is closed after update to 16.04

2016-07-13 Thread Daniel Gomes
I have an HP 15 Pavilion (AMD A8) and have the same issue. Updating the
kernel to 4.6 does not fix it. Editing the systemd file mentioned above
also does not resolve it. The only way to get the laptop to suspend is
from the drop down menu on the top right. Clicking suspend, suspends it
as expected, in less than 5 seconds. Turns on normally on lid open. Hope
that's helpful.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1574120

Title:
  Notebook doesn't suspend when lid is closed after update to 16.04

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  My notebook does not suspend after upgrading from 15.10 to 16.04.

  According to system settings the notebook should suspend when lid is
  closed but actually this does not happen. Instead it continues to run
  as if nothing had happened.

  With the previous versions of ubuntu (14.04-15.10) everything worked
  fine.

  My System: HP Pavilion dv7.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: acpi (not installed)
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sat Apr 23 23:11:15 2016
  InstallationDate: Installed on 2015-10-29 (176 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  SourcePackage: acpi
  UpgradeStatus: Upgraded to xenial on 2016-04-22 (1 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1574120/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1598770] Re: Unity in low-graphics mode has animations and unneeded redraws

2016-07-13 Thread Jason Gerard DeRose
@Marco: thanks for the FYI!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nux in Ubuntu.
https://bugs.launchpad.net/bugs/1598770

Title:
  Unity in low-graphics mode has animations and unneeded redraws

Status in compiz package in Ubuntu:
  Fix Released
Status in nux package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released
Status in unity-control-center package in Ubuntu:
  Fix Released
Status in compiz source package in Xenial:
  Fix Committed
Status in nux source package in Xenial:
  Fix Committed
Status in unity source package in Xenial:
  Fix Committed
Status in unity-control-center source package in Xenial:
  Fix Committed

Bug description:
  [Impact]

  When unity is in Low graphics mode (because of software rendering)
  there are still window animations and fade effects which we should get
  rid of.

  
  [Test case]

  This should apply naturally to a (virtual-)machine with no hardware
  acceleration or There are multiple ways to force low-gfx mode:

  1) Add an upstart job such as:

  cat << EOF > ~/.config/upstart/lowgfx.conf
  start on starting unity7

  pre-start script
#initctl set-env --global UNITY_LOW_GFX_MODE=1
initctl set-env --global LIBGL_ALWAYS_SOFTWARE=1
  end script
  EOF 

  
  2) Run unity with:
 COMPIZ_CONFIG_PROFILE=ubuntu-lowgfx

  On login unity should use opaque views (dash, switcher, launcher,
  shortcut-dialogs) with no fading and reduced effects. Windows should
  also use smaller shadows.

  
  [Regression potential]

  Some settings from unity-control-center couldn't be applied to normal
  profile. Low graphics mode might be used as normal one.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1598770/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1590099] Re: Need to support pointer confinement

2016-07-13 Thread Launchpad Bug Tracker
** Branch linked: lp:~dandrader/qtmir/cursorConfinement

** Branch linked: lp:~dandrader/unity8/cursorConfinement

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1590099

Title:
  Need to support pointer confinement

Status in Mir:
  Fix Committed
Status in MirAL:
  Triaged
Status in mir package in Ubuntu:
  Triaged
Status in qtmir package in Ubuntu:
  In Progress
Status in unity8 package in Ubuntu:
  In Progress

Bug description:
  We need to support pointer confinement set by the client. This way we
  can generate relative mouse events on a surface without the cursor
  being able to leave the edge of the window.

To manage notifications about this bug go to:
https://bugs.launchpad.net/mir/+bug/1590099/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1433590] Re: apparmor dbus denial for org.freedesktop.Accounts and make Other vibrations work

2016-07-13 Thread Tyler Hicks
Seth is right about PIDs not being sufficient for identifying a process.
Additionally, you cannot trust a /proc/PID/comm to identify what binary
was used to start the process. See the proc(5) man page for details on
how to trivially change your own comm to something that would trick the
check added in the merge proposal.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1433590

Title:
  apparmor dbus denial for org.freedesktop.Accounts and make Other
  vibrations work

Status in Canonical System Image:
  Triaged
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Fix Released
Status in ubuntu-system-settings package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in usensord package in Ubuntu:
  In Progress

Bug description:
  This affects vivid and (somewhat recently?) 14.09.

  At some point, apps started to request access to
  org.freedesktop.Accounts for something, but I'm not sure what. It has
  been conjectured in this bug that it is due to vibration settings.
  Filing against ubuntu-system-settings for now, but please feel free to
  move to the correct package.

  This happens with webapps:
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"

  and QML apps:
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"

  The following rules allow the requested access:
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.DBus.{Introspectable,Properties}"
 member=Introspect
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.Accounts"
 member=FindUserById
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts/User[0-9]*"
 interface="org.freedesktop.DBus.Properties"
 member=Get
 peer=(name=org.freedesktop.Accounts,label=unconfined),

  However, the above is too lenient and constitutes a privacy leak for
  apps. FindUserById could be used by a malicious app to enumerate
  usernames on multiuser systems and because we can't mediate method
  data with apparmor, the Get() method can be used to obtain any
  information provided by this interface.

  The following can be used to see what can be leaked to a malicious app:
  gdbus introspect --system -d org.freedesktop.Accounts -o 
/org/freedesktop/Accounts/User`id -u phablet`

  This can be solved in a couple of ways:
  1. add whatever information the app is trying to access to a new helper 
service that only exposes things that the app needs. This could be a single 
standalone service, perhaps something from ubuntu-system-settings, that could 
expose any number of things-- the current locale, if the locale changed, if the 
grid units changed, the vibration settings, etc. Since this service wouldn't 
have any sensitive information, you could use standard dbus 
properties/Get()/etc 
  2. add a new dbus API to an existing service such that apparmor rules can 
then be used to allow by method (eg, GetVibration() or something)

  I won't dictate the implementation except to mention that '1' seems
  like something generally useful and I believe that it was something
  the ubuntu-system-settings devs were already looking at for detecting
  locale changes without rebooting.


  Original description
  starting an app in vivid (image 135 on arale currently)

  

[Touch-packages] [Bug 1596811] Re: Please merge qtbase-opensource-src 5.6.1+dfsg-3

2016-07-13 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: qtbase-opensource-src (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1596811

Title:
  Please merge qtbase-opensource-src 5.6.1+dfsg-3

Status in qtbase-opensource-src package in Ubuntu:
  Confirmed

Bug description:
  Please upgrade Qt in Ubuntu to 5.6.

  Much of Qt 5.6 already auto-synced to yakkety but it needs qtbase to
  be updated:

  http://qa.ubuntuwire.org/ftbfs/#qt5

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1596811/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602568] Re: Consider version 5.6 for Yakety

2016-07-13 Thread Dmitry Shachnev
*** This bug is a duplicate of bug 1596811 ***
https://bugs.launchpad.net/bugs/1596811

** This bug has been marked a duplicate of bug 1596811
   Please merge qtbase-opensource-src 5.6.1+dfsg-3

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1602568

Title:
  Consider version 5.6 for Yakety

Status in qtbase-opensource-src package in Ubuntu:
  New

Bug description:
  I suggest to switch from Qt version 5.5 to Qt version 5.6 (or version
  5.7) for the next ubuntu release, due to a strange behaviour in the
  callback mechanism for function objects. See
  http://stackoverflow.com/questions/38337254/qt5-function-object-as-
  callback-copying/38345908#38345908. I do not know if the new and in my
  opinion correct behaviour affect old apps or not. If not, I am happy
  to see an official upgrade.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1602568/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602836] Re: Grouped properties in StyleHints don't work for simple values.

2016-07-13 Thread Tim Peeters
** Changed in: ubuntu-ui-toolkit (Ubuntu)
   Status: Confirmed => In Progress

** Changed in: ubuntu-ui-toolkit (Ubuntu)
 Assignee: (unassigned) => Tim Peeters (tpeeters)

** Changed in: ubuntu-ui-toolkit (Ubuntu)
   Importance: Undecided => High

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1602836

Title:
  Grouped properties in StyleHints don't work for simple values.

Status in ubuntu-ui-toolkit package in Ubuntu:
  In Progress

Bug description:
  For example:

  import QtQuick 2.4
  import Ubuntu.Components 1.3

  Item {
  width: units.gu(40)
  height: units.gu(71)

  Button {
  objectName: "Button"
  id: button
  gradient: UbuntuColors.greyGradient
  StyleHints {
  ignoreUnknownProperties: false
  gradientProxy.topColor: "orange"
  }
  }
  }

  gives:

  file:///home/ubuntu/dev/ubuntu-ui-
  
toolkit/m/fixGroupedStyleProperties/tests/unit/subtheming/GroupPropertyValueHints.qml:28:9:
  QML StyleHints: Style 'ButtonStyle' has no property called
  'gradientProxy.topColor'

  and the color is not set.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1602836/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1439771] Re: wpa_supplicant[874]: dbus: Failed to construct signal after 'suspend'

2016-07-13 Thread Jason Robinson
Seen on 16.04 with rtl8723be wifi driver, network-manager
1.2.0-0ubuntu0.16.04.2. Happens no suspend/resume AND flight mode
toggle. Worked around the suspend problem by making systemd restart
network-manager service after suspend, which restores network
connections.

Jul 13 23:45:39 lenovo NetworkManager[2544]:   [1468442739.4325] manager: 
WiFi now enabled by radio killswitch
Jul 13 23:45:39 lenovo kernel: [  406.193741] IPv6: ADDRCONF(NETDEV_UP): 
wlp4s0: link is not ready
Jul 13 23:45:39 lenovo wpa_supplicant[1101]: dbus: 
wpa_dbus_get_object_properties: failed to get object properties: (none) none
Jul 13 23:45:39 lenovo wpa_supplicant[1101]: dbus: Failed to construct signal
Jul 13 23:45:39 lenovo NetworkManager[2544]:   [1468442739.9209] device 
(wlp4s0): supplicant interface state: starting -> ready
Jul 13 23:45:39 lenovo NetworkManager[2544]:   [1468442739.9210] device 
(wlp4s0): state change: unavailable -> disconnected (reason 
'supplicant-available') [20 30 42]
Jul 13 23:45:39 lenovo kernel: [  406.242502] IPv6: ADDRCONF(NETDEV_UP): 
wlp4s0: link is not ready
Jul 13 23:45:47 lenovo wpa_supplicant[1101]: rfkill: WLAN soft blocked
Jul 13 23:45:47 lenovo wpa_supplicant[1101]: rfkill: WLAN soft blocked
Jul 13 23:45:47 lenovo NetworkManager[2544]:   [1468442747.0170] manager: 
WiFi now disabled by radio killswitch
Jul 13 23:45:47 lenovo NetworkManager[2544]:   [1468442747.0173] device 
(wlp4s0): state change: disconnected -> unavailable (reason 'none') [30 20 0]
Jul 13 23:45:47 lenovo systemd[1]: Starting Load/Save RF Kill Switch Status...
Jul 13 23:45:47 lenovo systemd[1]: Started Load/Save RF Kill Switch Status.
Jul 13 23:45:47 lenovo wpa_supplicant[1101]: nl80211: deinit ifname=wlp4s0 
disabled_11b_rates=0
Jul 13 23:45:51 lenovo NetworkManager[2544]:   [1468442751.1801] manager: 
WiFi now enabled by radio killswitch
Jul 13 23:45:51 lenovo kernel: [  417.961786] IPv6: ADDRCONF(NETDEV_UP): 
wlp4s0: link is not ready
Jul 13 23:45:51 lenovo wpa_supplicant[1101]: dbus: 
wpa_dbus_get_object_properties: failed to get object properties: (none) none
Jul 13 23:45:51 lenovo wpa_supplicant[1101]: dbus: Failed to construct signal
Jul 13 23:45:51 lenovo NetworkManager[2544]:   [1468442751.6681] device 
(wlp4s0): supplicant interface state: starting -> ready
Jul 13 23:45:51 lenovo kernel: [  418.008598] IPv6: ADDRCONF(NETDEV_UP): 
wlp4s0: link is not ready
Jul 13 23:45:51 lenovo NetworkManager[2544]:   [1468442751.6683] device 
(wlp4s0): state change: unavailable -> disconnected (reason 
'supplicant-available') [20 30 42]
Jul 13 23:45:51 lenovo wpa_supplicant[1101]: rfkill: WLAN soft blocked

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1439771

Title:
  wpa_supplicant[874]: dbus: Failed to construct signal after 'suspend'

Status in network-manager package in Ubuntu:
  Confirmed

Bug description:
  The Wifi network can't connect after the wake up from suspend. Xubuntu
  15.04

  I'll post more useful details (journalctl log) as a comment to this
  bug report.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: dbus 1.8.12-1ubuntu5
  Uname: Linux 4.0.0-04rc5-generic x86_64
  ApportVersion: 2.17-0ubuntu1
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Thu Apr  2 18:18:56 2015
  InstallationDate: Installed on 2015-03-27 (5 days ago)
  InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
  SourcePackage: dbus
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1439771/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1594776] Re: add-apt-repository explodes on missing ppa

2016-07-13 Thread Launchpad Bug Tracker
This bug was fixed in the package software-properties - 0.96.24.1

---
software-properties (0.96.24.1) yakkety; urgency=medium

   * tests/test_shortcuts.py: make the tests python2 compatible.

 -- Brian Murray   Wed, 13 Jul 2016 12:26:53 -0700

** Changed in: software-properties (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1594776

Title:
  add-apt-repository explodes on missing ppa

Status in software-properties package in Ubuntu:
  Fix Released
Status in software-properties source package in Xenial:
  Triaged

Bug description:
  Just saw this on freshly updated Xenial. I think it's trying to be
  helpful and tell me what PPAs a particular LP team has published, but
  in the end it explodes:

  $ sudo add-apt-repository ppa:juju/next
  Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 102, 
in _get_https_content_py3
  lp_page = urllib.request.urlopen(request, cafile=LAUNCHPAD_PPA_CERT)
File "/usr/lib/python3.5/urllib/request.py", line 162, in urlopen
  return opener.open(url, data, timeout)
File "/usr/lib/python3.5/urllib/request.py", line 471, in open
  response = meth(req, response)
File "/usr/lib/python3.5/urllib/request.py", line 581, in http_response
  'http', request, response, code, msg, hdrs)
File "/usr/lib/python3.5/urllib/request.py", line 509, in error
  return self._call_chain(*args)
File "/usr/lib/python3.5/urllib/request.py", line 443, in _call_chain
  result = func(*args)
File "/usr/lib/python3.5/urllib/request.py", line 589, in http_error_default
  raise HTTPError(req.full_url, code, msg, hdrs, fp)
  urllib.error.HTTPError: HTTP Error 404: Not Found

  During handling of the above exception, another exception occurred:

  Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 327, 
in get_ppa_info
  ret = get_ppa_info_from_lp(user, ppa)
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 92, 
in get_ppa_info_from_lp
  return get_info_from_lp(lp_url)
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 88, 
in get_info_from_lp
  return _get_https_content_py3(lp_url)
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 108, 
in _get_https_content_py3
  raise PPAException("Error reading %s: %s" % (lp_url, reason), e)
  softwareproperties.ppa.PPAException: 'Error reading 
https://launchpad.net/api/1.0/~juju/+archive/ubuntu/next: Not Found'

  During handling of the above exception, another exception occurred:

  Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 393, 
in shortcut_handler
  return PPAShortcutHandler(shortcut)
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 356, 
in __init__
  info = get_ppa_info(self.shortcut)
File "/usr/lib/python3/dist-packages/softwareproperties/ppa.py", line 339, 
in get_ppa_info
  _get_suggested_ppa_message(user, ppa))
  softwareproperties.shortcuts.ShortcutException: Cannot add PPA: 
'ppa:~juju/ubuntu/next'.
  The team named '~juju' has no PPA named 'ubuntu/next'
  Please choose from the following available PPAs:
   * '1.22':  1.22 Updates
   * '1.22-proposed':  1.22 Proposed
   * '1.23':  1.23 Updates
   * 'daily':  Juju Daily
   * 'devel':  juju devel packages
   * 'enablement':  Juju Enablement
   * 'experimental':  juju experimental packages
   * 'golang':  juju-golang
   * 'proposed':  juju proposed packages
   * 'stable':  juju stable packages
  Error: 'ppa:juju/next' invalid

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1594776/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1543921] Re: Make sure color fonts work

2016-07-13 Thread Gunnar Hjalmarsson
On 2016-07-13 11:06, Joakim Koed wrote:
> Gunnar: maybe you should also look at this:
> https://github.com/bohoomil/fontconfig-ultimate/issues/157
> it would be cool if that was patched.

If you want to see that in Ubuntu, you'd better suggest it be applied
upstream. Probably not important enough to justify an Ubuntu specific
patch.

Is that what this bug report is about? (The description is not crystal
clear.)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to fontconfig in Ubuntu.
https://bugs.launchpad.net/bugs/1543921

Title:
  Make sure color fonts work

Status in fontconfig package in Ubuntu:
  Incomplete

Bug description:
  Can someone please confirm that color fonts work in latest Ubuntu?

  Please install a sample font from:

https://github.com/behdad/color-
  emoji/blob/master/specification/examples/PhantomOpenEmoji.ttf

  then, at least in Chrome, you should be able to see color glyphs
  correctly.  In other apps, you probably will see them grayscale, but
  they should be there and of the correct size.

  This requires a recent fontconfig, and hopefully with default config
  that doesn't mess up with bitmap color fonts.  All reports I've
  received say that it doesn't work, hence this bug.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/fontconfig/+bug/1543921/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602836] Re: Grouped properties in StyleHints don't work for simple values.

2016-07-13 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: ubuntu-ui-toolkit (Ubuntu)
   Status: New => Confirmed

** Branch linked: lp:~tpeeters/ubuntu-ui-
toolkit/fixGroupedStyleProperties

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1602836

Title:
  Grouped properties in StyleHints don't work for simple values.

Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed

Bug description:
  For example:

  import QtQuick 2.4
  import Ubuntu.Components 1.3

  Item {
  width: units.gu(40)
  height: units.gu(71)

  Button {
  objectName: "Button"
  id: button
  gradient: UbuntuColors.greyGradient
  StyleHints {
  ignoreUnknownProperties: false
  gradientProxy.topColor: "orange"
  }
  }
  }

  gives:

  file:///home/ubuntu/dev/ubuntu-ui-
  
toolkit/m/fixGroupedStyleProperties/tests/unit/subtheming/GroupPropertyValueHints.qml:28:9:
  QML StyleHints: Style 'ButtonStyle' has no property called
  'gradientProxy.topColor'

  and the color is not set.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1602836/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602836] [NEW] Grouped properties in StyleHints don't work for simple values.

2016-07-13 Thread Tim Peeters
Public bug reported:

For example:

import QtQuick 2.4
import Ubuntu.Components 1.3

Item {
width: units.gu(40)
height: units.gu(71)

Button {
objectName: "Button"
id: button
gradient: UbuntuColors.greyGradient
StyleHints {
ignoreUnknownProperties: false
gradientProxy.topColor: "orange"
}
}
}

gives:

file:///home/ubuntu/dev/ubuntu-ui-
toolkit/m/fixGroupedStyleProperties/tests/unit/subtheming/GroupPropertyValueHints.qml:28:9:
QML StyleHints: Style 'ButtonStyle' has no property called
'gradientProxy.topColor'

and the color is not set.

** Affects: ubuntu-ui-toolkit (Ubuntu)
 Importance: Undecided
 Status: Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1602836

Title:
  Grouped properties in StyleHints don't work for simple values.

Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed

Bug description:
  For example:

  import QtQuick 2.4
  import Ubuntu.Components 1.3

  Item {
  width: units.gu(40)
  height: units.gu(71)

  Button {
  objectName: "Button"
  id: button
  gradient: UbuntuColors.greyGradient
  StyleHints {
  ignoreUnknownProperties: false
  gradientProxy.topColor: "orange"
  }
  }
  }

  gives:

  file:///home/ubuntu/dev/ubuntu-ui-
  
toolkit/m/fixGroupedStyleProperties/tests/unit/subtheming/GroupPropertyValueHints.qml:28:9:
  QML StyleHints: Style 'ButtonStyle' has no property called
  'gradientProxy.topColor'

  and the color is not set.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1602836/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602834] [NEW] obsolete conffiles not cleaned up on upgrade

2016-07-13 Thread Michael Biebl
Public bug reported:

Hi,

the following conffile is marked as obsolete in my dpkg status db

 /etc/bash_completion.d/ufw 50de7ccdcddb779093156f133d9c0a5e obsolete

Ufw now ships /usr/share/bash-completion/completions/ufw, so the
conffile should be removed on upgrades.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ufw 0.35-0ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
Uname: Linux 4.4.0-28-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Jul 13 22:19:52 2016
InstallationDate: Installed on 2011-11-10 (1706 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
SourcePackage: ufw
UpgradeStatus: Upgraded to xenial on 2016-04-21 (82 days ago)

** Affects: ufw (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ufw in Ubuntu.
https://bugs.launchpad.net/bugs/1602834

Title:
  obsolete conffiles not cleaned up on upgrade

Status in ufw package in Ubuntu:
  New

Bug description:
  Hi,

  the following conffile is marked as obsolete in my dpkg status db

   /etc/bash_completion.d/ufw 50de7ccdcddb779093156f133d9c0a5e obsolete

  Ufw now ships /usr/share/bash-completion/completions/ufw, so the
  conffile should be removed on upgrades.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: ufw 0.35-0ubuntu2
  ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
  Uname: Linux 4.4.0-28-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Wed Jul 13 22:19:52 2016
  InstallationDate: Installed on 2011-11-10 (1706 days ago)
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
  PackageArchitecture: all
  SourcePackage: ufw
  UpgradeStatus: Upgraded to xenial on 2016-04-21 (82 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ufw/+bug/1602834/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1534674] Re: [AdaptivePageLayout] Add function to return the top Page of a PageColumn

2016-07-13 Thread Tim Peeters
 I have a AdaptivePageLayout on main window. And when the app starts, I 
push the contact list on it
 if the device rotates and there is more space for a new page, I push a 
ContactDetail page if the column property changes on AdaptivePageLayout
 the problem is
 if the user has already navigate to another page, I do not want to 
push this page
 right now there is not API to query AdaptivePageLayout how many page 
is visible, or the depth of it

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1534674

Title:
  [AdaptivePageLayout] Add function to return the top Page of a
  PageColumn

Status in ubuntu-ui-toolkit package in Ubuntu:
  Triaged

Bug description:
  Add a function that will return a reference to the top Page object in
  a specific PageColumn.

  Suggestion:

  getPageInColumn(int columnIndex)

  Use Case:

  In uReadIt I have at most a 3-column layout. I would like a user
  action on an item in the first column to add a Page to the 3rd column.
  This requires knowing the current page in the 2nd column in order to
  call pageStack.addPageToNextColumn(secondPage, "SourcePage.qml").

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1534674/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1433590] Re: apparmor dbus denial for org.freedesktop.Accounts and make Other vibrations work

2016-07-13 Thread Seth Arnold
A pid alone does not suffice to uniquely identify a process. pid+process
start time can uniquely identify a process. Without looking deeply this
probably needs to be reworked.

Thanks

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1433590

Title:
  apparmor dbus denial for org.freedesktop.Accounts and make Other
  vibrations work

Status in Canonical System Image:
  Triaged
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Fix Released
Status in ubuntu-system-settings package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in usensord package in Ubuntu:
  In Progress

Bug description:
  This affects vivid and (somewhat recently?) 14.09.

  At some point, apps started to request access to
  org.freedesktop.Accounts for something, but I'm not sure what. It has
  been conjectured in this bug that it is due to vibration settings.
  Filing against ubuntu-system-settings for now, but please feel free to
  move to the correct package.

  This happens with webapps:
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"

  and QML apps:
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"

  The following rules allow the requested access:
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.DBus.{Introspectable,Properties}"
 member=Introspect
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.Accounts"
 member=FindUserById
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts/User[0-9]*"
 interface="org.freedesktop.DBus.Properties"
 member=Get
 peer=(name=org.freedesktop.Accounts,label=unconfined),

  However, the above is too lenient and constitutes a privacy leak for
  apps. FindUserById could be used by a malicious app to enumerate
  usernames on multiuser systems and because we can't mediate method
  data with apparmor, the Get() method can be used to obtain any
  information provided by this interface.

  The following can be used to see what can be leaked to a malicious app:
  gdbus introspect --system -d org.freedesktop.Accounts -o 
/org/freedesktop/Accounts/User`id -u phablet`

  This can be solved in a couple of ways:
  1. add whatever information the app is trying to access to a new helper 
service that only exposes things that the app needs. This could be a single 
standalone service, perhaps something from ubuntu-system-settings, that could 
expose any number of things-- the current locale, if the locale changed, if the 
grid units changed, the vibration settings, etc. Since this service wouldn't 
have any sensitive information, you could use standard dbus 
properties/Get()/etc 
  2. add a new dbus API to an existing service such that apparmor rules can 
then be used to allow by method (eg, GetVibration() or something)

  I won't dictate the implementation except to mention that '1' seems
  like something generally useful and I believe that it was something
  the ubuntu-system-settings devs were already looking at for detecting
  locale changes without rebooting.


  Original description
  starting an app in vivid (image 135 on arale currently)

  produces a bunch of dbus denials in syslog ... (there is also a
  /dev/tty one but i think this is just because soemthing tries to write
  an 

[Touch-packages] [Bug 1580444] Re: Can't plug in USB audio device "TEAC AI-101 Audio"

2016-07-13 Thread msknight
Same here.

TEAC AI-101 Dac/Amp connecting to Linux Mint 17.3 Rosa \n \l - 64 bit
VERSION="14.04.4 LTS, Trusty Tahr"

3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015
x86_64 x86_64 x86_64 GNU/Linux

On connecting the Teac to USB 2, the device turns up in the sound
control window properly, and I can select it, but when I try to send
audio to it, nothing comes out and the applications stall. They don't
report anything, they just hang until I select a different sound output
and then they continue as if nothing happened... but on selecting the
Teac, nothing wants to move.

On connecting the Teac to USB 3, it seems to connect and disconnect.
Doesn't even flicker a presence in the sound window.

I did try to connect via Bluetooth as well, but it wouldn't connect for
some reason. Sees it, pairs with it, trusts it, but doesn't want to use
it as a device. At that point, I ran out of time.

USB2
[612629.199542] usb 5-2.4.2: new high-speed USB device number 18 using ehci-pci
[612629.915629] usb 5-2.4.2: new high-speed USB device number 19 using ehci-pci
[612630.009199] usb 5-2.4.2: New USB device found, idVendor=0644, idProduct=8051
[612630.009208] usb 5-2.4.2: New USB device strings: Mfr=1, Product=2, 
SerialNumber=3
[612630.009213] usb 5-2.4.2: Product: TEAC AI-101 Audio
[612630.009217] usb 5-2.4.2: Manufacturer: TEAC
[612630.009221] usb 5-2.4.2: SerialNumber: ACEGIKMOQS

USB3
[613059.985196] usb 1-1: new high-speed USB device number 12 using xhci_hcd
[613060.118318] usb 1-1: New USB device found, idVendor=0644, idProduct=8051
[613060.118325] usb 1-1: New USB device strings: Mfr=1, Product=2, 
SerialNumber=3
[613060.118329] usb 1-1: Product: TEAC AI-101 Audio
[613060.118332] usb 1-1: Manufacturer: TEAC
[613060.118335] usb 1-1: SerialNumber: ACEGIKMOQS
[613102.527644] usb 1-1: USB disconnect, device number 12

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-lib in Ubuntu.
https://bugs.launchpad.net/bugs/1580444

Title:
  Can't plug in USB audio device "TEAC AI-101 Audio"

Status in alsa-lib package in Ubuntu:
  New

Bug description:
  I can't use this device; it shows up in dmesg, but it seems that
  systemd hangs when trying to use udev to configure it. The important
  message (I think) is:

  usb 3-1: 13:0: cannot get min/max values for control 2 (id 13)

  AND, here is from syslog:
  May 10 23:46:59 dude systemd-udevd[302]: worker [5911] terminated by signal 9 
(Killed)
  May 10 23:46:59 dude systemd-udevd[302]: worker [5911] failed while handling 
'/devices/pci:00/:00:1a.0/usb3/3-1/3-1:1.0/sound/card3/controlC3'
  May 10 23:47:19 dude kernel: [114738.341243] usb 3-1: 13:0: cannot get 
min/max values for control 2 (id 13)

  ...

  I tried to use alsactl to force an init of this card; the very long
  log is attached.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: libasound2 1.1.0-0ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  Date: Wed May 11 00:11:40 2016
  Dependencies:
   gcc-6-base 6.0.1-0ubuntu1
   libasound2-data 1.1.0-0ubuntu1
   libc6 2.23-0ubuntu3
   libgcc1 1:6.0.1-0ubuntu1
  InstallationDate: Installed on 2015-05-28 (348 days ago)
  InstallationMedia: Ubuntu-Server 15.04 "Vivid Vervet" - Release amd64 
(20150422)
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: alsa-lib
  UpgradeStatus: Upgraded to xenial on 2016-05-09 (1 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/1580444/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1534674] Re: [AdaptivePageLayout] Add function to return the top Page of a PageColumn

2016-07-13 Thread Tim Peeters
** Changed in: ubuntu-ui-toolkit (Ubuntu)
   Importance: Wishlist => High

** Changed in: ubuntu-ui-toolkit (Ubuntu)
 Assignee: (unassigned) => Tim Peeters (tpeeters)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1534674

Title:
  [AdaptivePageLayout] Add function to return the top Page of a
  PageColumn

Status in ubuntu-ui-toolkit package in Ubuntu:
  Triaged

Bug description:
  Add a function that will return a reference to the top Page object in
  a specific PageColumn.

  Suggestion:

  getPageInColumn(int columnIndex)

  Use Case:

  In uReadIt I have at most a 3-column layout. I would like a user
  action on an item in the first column to add a Page to the 3rd column.
  This requires knowing the current page in the 2nd column in order to
  call pageStack.addPageToNextColumn(secondPage, "SourcePage.qml").

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1534674/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602805] [NEW] the update-Service was stopped

2016-07-13 Thread Berger Gerhard
Public bug reported:

Ubuntu 14.04 LTS was installed in 2014 by my friend. Since some months I could 
not do the
regular up-date of ubuntu 14.04. LTS. Die Installation erfordert Pakete, denen 
nicht vertraut
werden kann.
This is my second question.
Who can me help?
Gerhard Berger

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu8.1
ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
Uname: Linux 3.13.0-77-generic i686
.tmp.unity.support.test.0:
 
ApportVersion: 2.14.1-0ubuntu3.20
Architecture: i386
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Wed Jul 13 20:23:44 2016
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DpkgLog:
 
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics 
Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Lenovo ThinkPad R60/T60/X60 series [17aa:201a]
   Subsystem: Lenovo ThinkPad R60/T60/X60 series [17aa:201a]
InstallationDate: Installed on 2014-12-06 (585 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release i386 (20140722.2)
MachineType: LENOVO 1703WMG
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-77-generic 
root=UUID=bb5b4686-52d4-4137-8fc2-efdfbecac3cd ro drm.debug=0xe plymouth:debug
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/19/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 7BETD6WW (2.17 )
dmi.board.name: 1703WMG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: 
dmi:bvnLENOVO:bvr7BETD6WW(2.17):bd06/19/2008:svnLENOVO:pn1703WMG:pvrThinkPadX60s:rvnLENOVO:rn1703WMG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 1703WMG
dmi.product.version: ThinkPad X60s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11.3+14.04.20150313-0ubuntu1
version.libdrm2: libdrm2 2.4.64-1~ubuntu14.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.6
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.6
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Wed Jul 13 12:34:18 2016
xserver.configfile: default
xserver.errors:
 
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id   16384 
 vendor LEN
xserver.version: 2:1.15.1-0ubuntu2.7

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-bug i386 trusty ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1602805

Title:
  the update-Service was stopped

Status in xorg package in Ubuntu:
  New

Bug description:
  Ubuntu 14.04 LTS was installed in 2014 by my friend. Since some months I 
could not do the
  regular up-date of ubuntu 14.04. LTS. Die Installation erfordert Pakete, 
denen nicht vertraut
  werden kann.
  This is my second question.
  Who can me help?
  Gerhard Berger

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: xorg 1:7.7+1ubuntu8.1
  ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
  Uname: Linux 3.13.0-77-generic i686
  .tmp.unity.support.test.0:
   
  ApportVersion: 2.14.1-0ubuntu3.20
  Architecture: i386
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  Date: Wed Jul 13 20:23:44 2016
  DistUpgraded: Fresh install
  DistroCodename: trusty
  DistroVariant: ubuntu
  DpkgLog:
   
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GraphicsCard:
   Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics 
Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
 Subsystem: Lenovo ThinkPad R60/T60/X60 series [17aa:201a]
 Subsystem: Lenovo ThinkPad R60/T60/X60 series [17aa:201a]
  InstallationDate: Installed on 2014-12-06 (585 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release i386 
(20140722.2)
  MachineType: LENOVO 1703WMG
  PccardctlIdent:
   Socket 0:
 no product info available
  PccardctlStatus:
   Socket 0:
 no card
 

[Touch-packages] [Bug 1598770] Re: Unity in low-graphics mode has animations and unneeded redraws

2016-07-13 Thread Treviño
Jason, this is bug #1599900, already under our care.

Thanks

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nux in Ubuntu.
https://bugs.launchpad.net/bugs/1598770

Title:
  Unity in low-graphics mode has animations and unneeded redraws

Status in compiz package in Ubuntu:
  Fix Released
Status in nux package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released
Status in unity-control-center package in Ubuntu:
  Fix Released
Status in compiz source package in Xenial:
  Fix Committed
Status in nux source package in Xenial:
  Fix Committed
Status in unity source package in Xenial:
  Fix Committed
Status in unity-control-center source package in Xenial:
  Fix Committed

Bug description:
  [Impact]

  When unity is in Low graphics mode (because of software rendering)
  there are still window animations and fade effects which we should get
  rid of.

  
  [Test case]

  This should apply naturally to a (virtual-)machine with no hardware
  acceleration or There are multiple ways to force low-gfx mode:

  1) Add an upstart job such as:

  cat << EOF > ~/.config/upstart/lowgfx.conf
  start on starting unity7

  pre-start script
#initctl set-env --global UNITY_LOW_GFX_MODE=1
initctl set-env --global LIBGL_ALWAYS_SOFTWARE=1
  end script
  EOF 

  
  2) Run unity with:
 COMPIZ_CONFIG_PROFILE=ubuntu-lowgfx

  On login unity should use opaque views (dash, switcher, launcher,
  shortcut-dialogs) with no fading and reduced effects. Windows should
  also use smaller shadows.

  
  [Regression potential]

  Some settings from unity-control-center couldn't be applied to normal
  profile. Low graphics mode might be used as normal one.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1598770/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1588646] Re: "Show all"/"Show less" are still not translated yet

2016-07-13 Thread Aron Xu
** Changed in: ubuntu-translations
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1588646

Title:
  "Show all"/"Show less" are still not translated yet

Status in Canonical System Image:
  Confirmed
Status in Ubuntu Translations:
  Fix Released
Status in unity8 package in Ubuntu:
  Invalid

Bug description:
  current build number: 326
  device name: arale
  channel: ubuntu-touch/rc-proposed/meizu.zh
  last update: 2016-06-03 13:37:10
  version version: 326
  version ubuntu: 20160603
  version device: 20160523-003fdb2
  version custom: 20160504-975-22-7

  Steps:
  1.Swipe to photo scope 
  2.Scroll all the way down 
  3.Tap on "Show all" /"Show less"

  Expectation:
  All the content should be translated in Chinese 

  Actual result:
  "Show all"/"Show less" are still not translated yet

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1588646/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1588634] Re: "Chinese(Pinyin)" isn't translated in OSK

2016-07-13 Thread Aron Xu
** Changed in: ubuntu-translations
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-keyboard in Ubuntu.
https://bugs.launchpad.net/bugs/1588634

Title:
  "Chinese(Pinyin)" isn't translated in OSK

Status in Canonical System Image:
  Triaged
Status in Ubuntu Translations:
  Fix Released
Status in ubuntu-keyboard package in Ubuntu:
  Triaged

Bug description:
  Test Env:
  current build number: 326
  device name: arale
  channel: ubuntu-touch/rc-proposed/meizu.zh
  last update: 2016-06-03 12:45:19
  version version: 326
  version ubuntu: 20160603
  version device: 20160523-003fdb2
  version custom: 20160504-975-22-7

  Steps:
  1.Go to system settings->Language & Text->keyboard layouts
  2.Add simplified chinese input
  3.Go to OSK
  4.Tap "global" button to bring up input switch menu

  Actual result:
  "Chinese(Pinyin)" isn't translated, see attached 

  Expected result:
  It should display "简体拼音"

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1588634/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1598770] Re: Unity in low-graphics mode has animations and unneeded redraws

2016-07-13 Thread Jason Gerard DeRose
Here's another screenshot that shows the SegvAnalysis.

In my testing thus far, this failure (assuming it's related to this
unity/nux change) only seems to happen when trying to install under
qemu. I tried -vga qxl, -vga std, and -vga virtio... none of them yield
a working installation. Compiz always fails to start.

** Attachment added: "Screenshot from 2016-07-13 10-56-41.png"
   
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1598770/+attachment/4700300/+files/Screenshot%20from%202016-07-13%2010-56-41.png

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nux in Ubuntu.
https://bugs.launchpad.net/bugs/1598770

Title:
  Unity in low-graphics mode has animations and unneeded redraws

Status in compiz package in Ubuntu:
  Fix Released
Status in nux package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released
Status in unity-control-center package in Ubuntu:
  Fix Released
Status in compiz source package in Xenial:
  Fix Committed
Status in nux source package in Xenial:
  Fix Committed
Status in unity source package in Xenial:
  Fix Committed
Status in unity-control-center source package in Xenial:
  Fix Committed

Bug description:
  [Impact]

  When unity is in Low graphics mode (because of software rendering)
  there are still window animations and fade effects which we should get
  rid of.

  
  [Test case]

  This should apply naturally to a (virtual-)machine with no hardware
  acceleration or There are multiple ways to force low-gfx mode:

  1) Add an upstart job such as:

  cat << EOF > ~/.config/upstart/lowgfx.conf
  start on starting unity7

  pre-start script
#initctl set-env --global UNITY_LOW_GFX_MODE=1
initctl set-env --global LIBGL_ALWAYS_SOFTWARE=1
  end script
  EOF 

  
  2) Run unity with:
 COMPIZ_CONFIG_PROFILE=ubuntu-lowgfx

  On login unity should use opaque views (dash, switcher, launcher,
  shortcut-dialogs) with no fading and reduced effects. Windows should
  also use smaller shadows.

  
  [Regression potential]

  Some settings from unity-control-center couldn't be applied to normal
  profile. Low graphics mode might be used as normal one.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1598770/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602680] Re: ecryptfs not work with libnss3/libnss3-1d Version 2:3.23-0ubuntu0.12.04.1

2016-07-13 Thread Tyler Hicks
What is the output of `ulimit -a` on your system?

You may be hitting the maximum amount of locked memory for the process
handling the login.

** Changed in: nss (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nss in Ubuntu.
https://bugs.launchpad.net/bugs/1602680

Title:
  ecryptfs not work with libnss3/libnss3-1d Version
  2:3.23-0ubuntu0.12.04.1

Status in nss package in Ubuntu:
  Incomplete

Bug description:
  After updating libnss3 and libnss3-1d from 2:3.21-0ubuntu0.12.04.3 to
  2:3.23-0ubuntu0.12.04.1 last night it is not longer possible to mount
  my home directory encrypted with ecryptfs.

  Automatic by login or with ecryptfs-recover-private or else not work.

  After downgrade to Version 2:3.21-0ubuntu0.12.04.3 if works fine.

  syslog:

  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: do_hash: PK11_HashBuf() error; 
SECFailure = [-1]; PORT_GetError() = [-8128]
  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: Error generating passphrase 
signature; rc = [-22]
  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: Error attempting to unwrap 
passphrase from file [/home/michael/.ecryptfs/wrapped-passphrase]; rc = [-22]

  
-

  lsb_release -rd

  Description:  Ubuntu 12.04.5 LTS
  Release:  12.04


  apt-cache policy libnss3 libnss3-1d after downgrade to previous
  version

  libnss3:
Installiert: 2:3.21-0ubuntu0.12.04.3
Kandidat:2:3.23-0ubuntu0.12.04.1
Versionstabelle:
   2:3.23-0ubuntu0.12.04.1 0
  500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 
Packages
  500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 
Packages
   *** 2:3.21-0ubuntu0.12.04.3 0
  100 /var/lib/dpkg/status
   3.13.1.with.ckbi.1.88-1ubuntu6 0
  500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
  libnss3-1d:
Installiert: 2:3.21-0ubuntu0.12.04.3
Kandidat:2:3.23-0ubuntu0.12.04.1
Versionstabelle:
   2:3.23-0ubuntu0.12.04.1 0
  500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 
Packages
  500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 
Packages
   *** 2:3.21-0ubuntu0.12.04.3 0
  100 /var/lib/dpkg/status
   3.13.1.with.ckbi.1.88-1ubuntu6 0
  500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

  I have marked the bug as security vulnerability because

  I must use older version they be more unsafe than the new one to work
  with my laptop.

  Unfortunately I go to holiday tomorrow. I'll be back at next monday
  18. July 2016

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nss/+bug/1602680/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1567540] Re: ntpd crashed with SIGABRT (was: ntp crashes everytime the network goes up or down.)

2016-07-13 Thread ChristianEhrhardt
Hi,
the fix has to go to the development release first (Yakkety).
The merge is waiting for a review quite a while already.

Thanks you for the push on this, I'll take this as an opportunity to raise
the priority of the merge.

Christian Ehrhardt
Software Engineer, Ubuntu Server
Canonical Ltd

On Wed, Jul 13, 2016 at 6:30 PM, Bob Jones <
r.a.n.d.o.m.d.e.v.4+ubu...@gmail.com> wrote:

> Have you finished "thinking about" fixing the broken NTP in Xenial yet ?
> Its becoming a bit of a joke to be without such a key package (let alone
> the hacks that have had to be put in place to keep server time accurate
> !).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1567540
>
> Title:
>   ntpd crashed with SIGABRT (was: ntp crashes everytime the network goes
>   up or down.)
>
> Status in NTP:
>   Fix Released
> Status in ntp package in Ubuntu:
>   Triaged
> Status in ntp source package in Xenial:
>   Confirmed
>
> Bug description:
>   ntp crashes every time the network goes up or down while the system is
> running and also crashes after booting up without network.
>   ---
>   ApportVersion: 2.20.1-0ubuntu1
>   Architecture: amd64
>   CurrentDesktop: XFCE
>   DistroRelease: Ubuntu 16.04
>   InstallationDate: Installed on 2016-03-12 (26 days ago)
>   InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64
> (20160224)
>   NtpStatus: ntpq: read: Connection refused
>   Package: ntp 1:4.2.8p4+dfsg-3ubuntu4
>   PackageArchitecture: amd64
>   ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-17-generic
> root=UUID=306314bc-efcb-4c2d-b0e9-e05ec92ed0f0 ro
>   ProcVersionSignature: Ubuntu 4.4.0-17.33-generic 4.4.6
>   Tags:  xenial
>   Uname: Linux 4.4.0-17-generic x86_64
>   UpgradeStatus: No upgrade log present (probably fresh install)
>   UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>   _MarkForUpload: True
>   ---
>   ApportVersion: 2.20.1-0ubuntu1
>   Architecture: amd64
>   CurrentDesktop: XFCE
>   DistroRelease: Ubuntu 16.04
>   InstallationDate: Installed on 2016-03-12 (31 days ago)
>   InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64
> (20160224)
>   NtpStatus: ntpq: read: Connection refused
>   Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
>   PackageArchitecture: amd64
>   ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic
> root=UUID=306314bc-efcb-4c2d-b0e9-e05ec92ed0f0 ro
>   ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
>   Tags:  xenial
>   Uname: Linux 4.4.0-18-generic x86_64
>   UpgradeStatus: No upgrade log present (probably fresh install)
>   UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>   _MarkForUpload: True
>   ---
>   ApportVersion: 2.20.1-0ubuntu1
>   Architecture: amd64
>   CurrentDesktop: XFCE
>   DistroRelease: Ubuntu 16.04
>   InstallationDate: Installed on 2016-04-13 (0 days ago)
>   InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64
> (20160412)
>   NtpStatus: ntpq: read: Connection refused
>   Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
>   PackageArchitecture: amd64
>   ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic
> root=UUID=13f57794-2e19-4a56-836a-94185bba5ec5 ro quiet splash
>   ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
>   Tags:  xenial
>   Uname: Linux 4.4.0-18-generic x86_64
>   UpgradeStatus: No upgrade log present (probably fresh install)
>   UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>   _MarkForUpload: True
>   ---
>   ApportVersion: 2.20.1-0ubuntu1
>   Architecture: amd64
>   CurrentDesktop: XFCE
>   DistroRelease: Ubuntu 16.04
>   InstallationDate: Installed on 2016-04-13 (0 days ago)
>   InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64
> (20160412)
>   NtpStatus: ntpq: read: Connection refused
>   Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
>   PackageArchitecture: amd64
>   ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic
> root=UUID=13f57794-2e19-4a56-836a-94185bba5ec5 ro quiet splash
>   ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
>   Tags:  xenial
>   Uname: Linux 4.4.0-18-generic x86_64
>   UpgradeStatus: No upgrade log present (probably fresh install)
>   UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>   _MarkForUpload: True
>   ---
>   ApportVersion: 2.20.1-0ubuntu2
>   Architecture: amd64
>   CurrentDesktop: XFCE
>   DistroRelease: Ubuntu 16.04
>   InstallationDate: Installed on 2016-04-14 (3 days ago)
>   InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64
> (20160412)
>   NtpStatus: ntpq: read: Connection refused
>   Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
>   PackageArchitecture: amd64
>   ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-20-generic
> root=UUID=b9c0528f-e81f-4b08-9b31-032f14f72ccd ro quiet splash vt.handoff=7
>   ProcVersionSignature: Ubuntu 4.4.0-20.36-generic 4.4.6
>   Tags:  xenial
>   Uname: Linux 4.4.0-20-generic x86_64
>   UpgradeStatus: No upgrade log present (probably fresh install)
>   UserGroups: adm cdrom dip lpadmin plugdev 

[Touch-packages] [Bug 1582803] Re: [SRU]bug report script uses invalid nm options

2016-07-13 Thread Aron Xu
This works for me, marking as verification-done.

** Tags removed: verification-needed
** Tags added: verification-done xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1582803

Title:
  [SRU]bug report script uses invalid nm options

Status in network-manager package in Ubuntu:
  Fix Committed
Status in network-manager source package in Xenial:
  Fix Committed

Bug description:
  [Impact]
  Xenial reports have those warnings "Error: Object 'nm' is unknown, try 'nmcli 
help'." the "nm-cli" syntax changed and the hook needs to be updated

  [Test Case]
  Future apport report to errors.ubuntu.com should have proper information 
output from nmcli command, rather than throwing an error message.

  [Regression Potential]
  This is a simple change of the command line option on information collection, 
which should be safe.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1582803/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602680] Re: ecryptfs not work with libnss3/libnss3-1d Version 2:3.23-0ubuntu0.12.04.1

2016-07-13 Thread Marc Deslauriers
FYI, I couldn't reproduce this earlier either.

I installed a new Ubuntu 12.04.5 VM with encrypted home, and was able to
successfully upgrade to the newer nss without any issues.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nss in Ubuntu.
https://bugs.launchpad.net/bugs/1602680

Title:
  ecryptfs not work with libnss3/libnss3-1d Version
  2:3.23-0ubuntu0.12.04.1

Status in nss package in Ubuntu:
  New

Bug description:
  After updating libnss3 and libnss3-1d from 2:3.21-0ubuntu0.12.04.3 to
  2:3.23-0ubuntu0.12.04.1 last night it is not longer possible to mount
  my home directory encrypted with ecryptfs.

  Automatic by login or with ecryptfs-recover-private or else not work.

  After downgrade to Version 2:3.21-0ubuntu0.12.04.3 if works fine.

  syslog:

  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: do_hash: PK11_HashBuf() error; 
SECFailure = [-1]; PORT_GetError() = [-8128]
  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: Error generating passphrase 
signature; rc = [-22]
  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: Error attempting to unwrap 
passphrase from file [/home/michael/.ecryptfs/wrapped-passphrase]; rc = [-22]

  
-

  lsb_release -rd

  Description:  Ubuntu 12.04.5 LTS
  Release:  12.04


  apt-cache policy libnss3 libnss3-1d after downgrade to previous
  version

  libnss3:
Installiert: 2:3.21-0ubuntu0.12.04.3
Kandidat:2:3.23-0ubuntu0.12.04.1
Versionstabelle:
   2:3.23-0ubuntu0.12.04.1 0
  500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 
Packages
  500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 
Packages
   *** 2:3.21-0ubuntu0.12.04.3 0
  100 /var/lib/dpkg/status
   3.13.1.with.ckbi.1.88-1ubuntu6 0
  500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
  libnss3-1d:
Installiert: 2:3.21-0ubuntu0.12.04.3
Kandidat:2:3.23-0ubuntu0.12.04.1
Versionstabelle:
   2:3.23-0ubuntu0.12.04.1 0
  500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 
Packages
  500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 
Packages
   *** 2:3.21-0ubuntu0.12.04.3 0
  100 /var/lib/dpkg/status
   3.13.1.with.ckbi.1.88-1ubuntu6 0
  500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

  I have marked the bug as security vulnerability because

  I must use older version they be more unsafe than the new one to work
  with my laptop.

  Unfortunately I go to holiday tomorrow. I'll be back at next monday
  18. July 2016

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nss/+bug/1602680/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602680] Re: ecryptfs not work with libnss3/libnss3-1d Version 2:3.23-0ubuntu0.12.04.1

2016-07-13 Thread Tyler Hicks
Hello - Sorry for the trouble you're having.

I've downgraded a clean, up to date 12.04 amd64 VM to libnss3 and
libnss3-1d version 2:3.21-0ubuntu0.12.04.3. Then I set up a new user
with encrypted home (`adduser --encrypt-home foo`). I verified that I
can log in and access the encrypted home directory and then upgraded
libnss3 and libnss3-1d to version 2:3.23-0ubuntu0.12.04.1. I could still
successfully log in and access the encrypted home after upgrading.

In addition, I locally rebuilt ecryptfs-utils in Precise as there are
some test cases which get run as part of the build process which
excercise the same code that you're having trouble with. They all still
pass with the newer NSS version.

Did anything else change on your system around that time? Do you have
any other information which may be helpful in reproducing the bug so
that we can work towards getting you a fix?

I'm going to make this a public, non-security bug since there's no
vulnerability. It will be helpful for other affected users to comment on
the report.

** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nss in Ubuntu.
https://bugs.launchpad.net/bugs/1602680

Title:
  ecryptfs not work with libnss3/libnss3-1d Version
  2:3.23-0ubuntu0.12.04.1

Status in nss package in Ubuntu:
  New

Bug description:
  After updating libnss3 and libnss3-1d from 2:3.21-0ubuntu0.12.04.3 to
  2:3.23-0ubuntu0.12.04.1 last night it is not longer possible to mount
  my home directory encrypted with ecryptfs.

  Automatic by login or with ecryptfs-recover-private or else not work.

  After downgrade to Version 2:3.21-0ubuntu0.12.04.3 if works fine.

  syslog:

  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: do_hash: PK11_HashBuf() error; 
SECFailure = [-1]; PORT_GetError() = [-8128]
  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: Error generating passphrase 
signature; rc = [-22]
  Jul 13 01:29:36 Michael-Thinkpad-X121e-SSD 
ecryptfs-insert-wrapped-passphrase-into-keyring: Error attempting to unwrap 
passphrase from file [/home/michael/.ecryptfs/wrapped-passphrase]; rc = [-22]

  
-

  lsb_release -rd

  Description:  Ubuntu 12.04.5 LTS
  Release:  12.04


  apt-cache policy libnss3 libnss3-1d after downgrade to previous
  version

  libnss3:
Installiert: 2:3.21-0ubuntu0.12.04.3
Kandidat:2:3.23-0ubuntu0.12.04.1
Versionstabelle:
   2:3.23-0ubuntu0.12.04.1 0
  500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 
Packages
  500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 
Packages
   *** 2:3.21-0ubuntu0.12.04.3 0
  100 /var/lib/dpkg/status
   3.13.1.with.ckbi.1.88-1ubuntu6 0
  500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
  libnss3-1d:
Installiert: 2:3.21-0ubuntu0.12.04.3
Kandidat:2:3.23-0ubuntu0.12.04.1
Versionstabelle:
   2:3.23-0ubuntu0.12.04.1 0
  500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 
Packages
  500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 
Packages
   *** 2:3.21-0ubuntu0.12.04.3 0
  100 /var/lib/dpkg/status
   3.13.1.with.ckbi.1.88-1ubuntu6 0
  500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

  I have marked the bug as security vulnerability because

  I must use older version they be more unsafe than the new one to work
  with my laptop.

  Unfortunately I go to holiday tomorrow. I'll be back at next monday
  18. July 2016

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nss/+bug/1602680/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1595707] Re: [SRU]crash in nmc_find_connection

2016-07-13 Thread Aron Xu
No more crash discovered, tagging as verification-done.

** Tags removed: verification-needed
** Tags added: verification-done

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1595707

Title:
  [SRU]crash in nmc_find_connection

Status in NetworkManager:
  Fix Released
Status in network-manager package in Ubuntu:
  Fix Released
Status in network-manager source package in Xenial:
  Fix Committed
Status in network-manager source package in Yakkety:
  Fix Released

Bug description:
  [Impact]

  Ubuntu error tracker receives some reports agains 1.2.0 for a crash in 
nmc_find_connection() when connecting to a password protected wlan connection, 
by running command: nmcli device connect wlan0
  T he problem page at 
https://errors.ubuntu.com/problem/16ece0c3816c93d9c763402902edf04448cbe6c8 
contains more details.

  [Test Case]
  After applying the patch, errors.ubuntu.com should stop receiving new crash 
reports for this problem.

  [Regression Potential]
  The fix is making the connection list available for certain 
nmc_secrets_requested() call, which should be harmless.

To manage notifications about this bug go to:
https://bugs.launchpad.net/network-manager/+bug/1595707/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1598770] Re: Unity in low-graphics mode has animations and unneeded redraws

2016-07-13 Thread Jason Gerard DeRose
Possibly as a result of this change, unity/compiz is failing to start
when trying to install from the latest 16.04.1 daily ISO under qemu
(xenial-desktop-amd64.iso 20160713, sha1sum
c9b1ad9b1044c4e68684395daa3f85e016491c3a).

I attached a screenshot as I couldn't file a bug from within the qemu VM
(apport doesn't seem able to launch firefox).

** Attachment added: "Screenshot from 2016-07-13 10-36-40.png"
   
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1598770/+attachment/4700286/+files/Screenshot%20from%202016-07-13%2010-36-40.png

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nux in Ubuntu.
https://bugs.launchpad.net/bugs/1598770

Title:
  Unity in low-graphics mode has animations and unneeded redraws

Status in compiz package in Ubuntu:
  Fix Released
Status in nux package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released
Status in unity-control-center package in Ubuntu:
  Fix Released
Status in compiz source package in Xenial:
  Fix Committed
Status in nux source package in Xenial:
  Fix Committed
Status in unity source package in Xenial:
  Fix Committed
Status in unity-control-center source package in Xenial:
  Fix Committed

Bug description:
  [Impact]

  When unity is in Low graphics mode (because of software rendering)
  there are still window animations and fade effects which we should get
  rid of.

  
  [Test case]

  This should apply naturally to a (virtual-)machine with no hardware
  acceleration or There are multiple ways to force low-gfx mode:

  1) Add an upstart job such as:

  cat << EOF > ~/.config/upstart/lowgfx.conf
  start on starting unity7

  pre-start script
#initctl set-env --global UNITY_LOW_GFX_MODE=1
initctl set-env --global LIBGL_ALWAYS_SOFTWARE=1
  end script
  EOF 

  
  2) Run unity with:
 COMPIZ_CONFIG_PROFILE=ubuntu-lowgfx

  On login unity should use opaque views (dash, switcher, launcher,
  shortcut-dialogs) with no fading and reduced effects. Windows should
  also use smaller shadows.

  
  [Regression potential]

  Some settings from unity-control-center couldn't be applied to normal
  profile. Low graphics mode might be used as normal one.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1598770/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1567540] Re: ntpd crashed with SIGABRT (was: ntp crashes everytime the network goes up or down.)

2016-07-13 Thread Bob Jones
Have you finished "thinking about" fixing the broken NTP in Xenial yet ?
Its becoming a bit of a joke to be without such a key package (let alone
the hacks that have had to be put in place to keep server time accurate
!).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ntp in Ubuntu.
https://bugs.launchpad.net/bugs/1567540

Title:
  ntpd crashed with SIGABRT (was: ntp crashes everytime the network goes
  up or down.)

Status in NTP:
  Fix Released
Status in ntp package in Ubuntu:
  Triaged
Status in ntp source package in Xenial:
  Confirmed

Bug description:
  ntp crashes every time the network goes up or down while the system is 
running and also crashes after booting up without network.
  --- 
  ApportVersion: 2.20.1-0ubuntu1
  Architecture: amd64
  CurrentDesktop: XFCE
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-03-12 (26 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160224)
  NtpStatus: ntpq: read: Connection refused
  Package: ntp 1:4.2.8p4+dfsg-3ubuntu4
  PackageArchitecture: amd64
  ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-17-generic 
root=UUID=306314bc-efcb-4c2d-b0e9-e05ec92ed0f0 ro
  ProcVersionSignature: Ubuntu 4.4.0-17.33-generic 4.4.6
  Tags:  xenial
  Uname: Linux 4.4.0-17-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  --- 
  ApportVersion: 2.20.1-0ubuntu1
  Architecture: amd64
  CurrentDesktop: XFCE
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-03-12 (31 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160224)
  NtpStatus: ntpq: read: Connection refused
  Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
  PackageArchitecture: amd64
  ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic 
root=UUID=306314bc-efcb-4c2d-b0e9-e05ec92ed0f0 ro
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Tags:  xenial
  Uname: Linux 4.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  --- 
  ApportVersion: 2.20.1-0ubuntu1
  Architecture: amd64
  CurrentDesktop: XFCE
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-04-13 (0 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160412)
  NtpStatus: ntpq: read: Connection refused
  Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
  PackageArchitecture: amd64
  ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic 
root=UUID=13f57794-2e19-4a56-836a-94185bba5ec5 ro quiet splash
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Tags:  xenial
  Uname: Linux 4.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  --- 
  ApportVersion: 2.20.1-0ubuntu1
  Architecture: amd64
  CurrentDesktop: XFCE
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-04-13 (0 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160412)
  NtpStatus: ntpq: read: Connection refused
  Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
  PackageArchitecture: amd64
  ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic 
root=UUID=13f57794-2e19-4a56-836a-94185bba5ec5 ro quiet splash
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Tags:  xenial
  Uname: Linux 4.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  --- 
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: XFCE
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-04-14 (3 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160412)
  NtpStatus: ntpq: read: Connection refused
  Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
  PackageArchitecture: amd64
  ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-20-generic 
root=UUID=b9c0528f-e81f-4b08-9b31-032f14f72ccd ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.4.0-20.36-generic 4.4.6
  Tags:  xenial
  Uname: Linux 4.4.0-20-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  --- 
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: XFCE
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-04-14 (3 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160412)
  NtpStatus: ntpq: read: Connection refused
  Package: ntp 1:4.2.8p4+dfsg-3ubuntu5
  PackageArchitecture: amd64
  ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-20-generic 
root=UUID=b9c0528f-e81f-4b08-9b31-032f14f72ccd ro quiet splash vt.handoff=7
  ProcVersionSignature: 

[Touch-packages] [Bug 1602690] Re: Increase focus frame line weight to 2dp

2016-07-13 Thread Christian Dywan
** Changed in: ubuntu-ui-toolkit (Ubuntu)
 Assignee: (unassigned) => Christian Dywan (kalikiana)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1602690

Title:
  Increase focus frame line weight to 2dp

Status in Ubuntu UX:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu RTM:
  New

Bug description:
  After reviewing the focus frame recently can we increase the line
  weight to 2dp.

  This applies to the focus frame: 
  src/Ubuntu/Components/Themes/Ambiance/1.3/FocusShape.qml (line 29)

  And the list item frame:
  ubuntu-ui-toolkit/src/Ubuntu/Components/plugin/uclistitem.cpp (line 1132)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-ux/+bug/1602690/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1044549] Re: The "Access Prompt" randomly pop up!

2016-07-13 Thread Fred Béland
If the prompt is caused by a google online account with dual factor
authentication and you want to maintain the goa functionality, you can
set an App Password in your google account settings and enter it at the
prompt. This avoids having to delete the accounts.conf file.

This solution solved my issue on Linux Mint 17.3; my Evolution is set up
to use the gnome online accounts for imap functionality.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gcr in Ubuntu.
https://bugs.launchpad.net/bugs/1044549

Title:
  The "Access Prompt" randomly pop up!

Status in gcr package in Ubuntu:
  Triaged

Bug description:
  Access Prompt randomly pop up and prompt you for the password. Have you ever 
when opened  Youtube, Facebook, Launchpad account!n And now opened a picture of 
the computer when  pop up"Access Prompt"
  I use autologin.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: gcr 3.5.90-0ubuntu1
  ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
  Uname: Linux 3.5.0-13-generic x86_64
  ApportVersion: 2.5.1-0ubuntu4
  Architecture: amd64
  Date: Fri Aug 31 22:33:44 2012
  ExecutablePath: /usr/lib/gcr/gcr-prompter
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
  SourcePackage: gcr
  UpgradeStatus: No upgrade log present (probably fresh install)
  XsessionErrors:
   (gnome-settings-daemon:1401): libappindicator-WARNING **: Unable to connect 
to the Notification Watcher: 
GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.48 was not 
provided by any .service files
   (gnome-control-center:2016): background-cc-panel-WARNING **: Could not load 
/usr/share/themes/Adwaita/index.theme: Nincs ilyen fájl vagy könyvtár
   (gnome-control-center:2016): GLib-GIO-CRITICAL **: g_settings_set_value: 
assertion `G_IS_SETTINGS (settings)' failed
   (gnome-control-center:2016): Gtk-CRITICAL **: gtk_builder_get_object: 
assertion `GTK_IS_BUILDER (builder)' failed
   (gnome-control-center:2016): Gtk-CRITICAL **: 
gtk_icon_view_get_selected_items: assertion `GTK_IS_ICON_VIEW (icon_view)' 
failed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gcr/+bug/1044549/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1543051] Re: New helpers version fail on "unknown initscript"

2016-07-13 Thread cobraking1993
Hi,

Here I am having a doubt, I am having a ltsp-chroot environment. and I am 
trying to install openssh-server in it, and I have got some waring message 
there as follows. 
" Running in chroot, ignoring request.
invoke-rc.d: policy-rc.d denied execution of restart."
When I checked the ltsp-client I haven't get the ssh startup script there. Is 
there anything I need to done with the "init-system-helpers".

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to init-system-helpers in
Ubuntu.
https://bugs.launchpad.net/bugs/1543051

Title:
  New helpers version fail on "unknown initscript"

Status in init-system-helpers package in Ubuntu:
  Fix Released

Bug description:
  On version 1.26:

  invoke-rc.d: unknown initscript, /etc/init.d/ofono not found.
  Running in chroot, ignoring request.
  invoke-rc.d: policy-rc.d denied execution of start.

  And happily continues.

  On version 1.28, however:
  invoke-rc.d: unknown initscript, /etc/init.d/ofono not found.
  dpkg: error processing package ofono (--configure):
   subprocess installed post-installation script returned error exit status 100

  While this might be an ofono issue, the behaviour change causes
  previously working packages to be uninstallable.

  First noticed in buildd:
  
https://launchpadlibrarian.net/236956211/buildlog_ubuntu-xenial-amd64.unity8_8.11+16.04.20160208-0ubuntu1_BUILDING.txt.gz

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: init-system-helpers 1.28ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
  Uname: Linux 4.4.0-2-generic x86_64
  ApportVersion: 2.19.4-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Mon Feb  8 11:25:36 2016
  PackageArchitecture: all
  SourcePackage: init-system-helpers
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/init-system-helpers/+bug/1543051/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1600305] Re: Touch Problem on MX4

2016-07-13 Thread Ronny Fuchs
here the unity8 log file, maybe it helps

** Attachment added: "unity8.log"
   
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1600305/+attachment/4700270/+files/unity8.log

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1600305

Title:
  Touch Problem on MX4

Status in Canonical System Image:
  Incomplete
Status in unity8 package in Ubuntu:
  New

Bug description:
  Can't swipe on the left- and rightside

  Devise-Information:
  current build number: 13
  device name: arale
  channel: ubuntu-touch/stable/meizu.en
  last update: 2016-06-02 05:58:37
  version version: 13
  version ubuntu: 20160524.1
  version tag: OTA-11
  version device: 20160331-e143fc2
  version custom: 20160504-975-19-6

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1600305/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1260103] Re: oxide should use an app-specific path for shared memory files

2016-07-13 Thread Chris Coulson
That won't work for child processes, where the environment variable
won't exist. Also, we should have something that works for current apps
on the phone (I assume there's a different environment variable for
that). If you're not using PathService, there would at least need to be
a command line option to make this work.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1260103

Title:
  oxide should use an app-specific path for shared memory files

Status in Oxide:
  In Progress
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Oxide creates shared memory files as /run/shm/.org.chromium.Chromium.*. This 
results in an AppArmor rule like the following:
owner /run/shm/.org.chromium.Chromium.* rwk, 

  But this rule is too lenient because a malicious app could enumerate
  these files and attack shared memory of other applications. Therefore,
  these paths need to be made application specific.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oxide/+bug/1260103/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1601836] Re: Openssl libcrypto performance issue

2016-07-13 Thread Frank Heimes
Some add. IBM info:

---Problem Description---
The openssl s390x assembly code is not available, causing a fallback to openssl 
internal C-code. The performance degradation is up to a factor 4 for asymmetric 
(RSA, ...)  and a factor >10 for symmetric cipher like SHA & AES.

Contact Information = bastian.pfei...@de.ibm.com

---uname output---
4.4.0-28-generic #47-Ubuntu SMP Fri Jun 24 10:14:29 UTC 2016 s390x s390x s390x 
GNU/Linux

Machine Type = 2964, 701

---Debugger---
A debugger is not configured

---Steps to Reproduce---
#Run a benchmark
openssl speed sha1

#Check if CPACF was used
cpacfstatsd
cpacfstats

Userspace tool common name: OpenSSL 1.0.2g-fips  1 Mar 2016

The userspace tool has the following bit modes: 64-bit

Userspace rpm: OpenSSL 1.0.2g-fips  1 Mar 2016

Userspace tool obtained from project website:  na

*Additional Instructions for bastian.pfei...@de.ibm.com:
-Attach ltrace and strace of userspace application.

To me it seems the following compiler flags

-DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM
-DSHA512_ASM -DAES_ASM -DAES_CTR_ASM -DAES_XTS_ASM -DGHASH_ASM

are completely missing. Probably openssl was configured with the 'no-
asm' option. This option, for example, is applied for s390 as defined in
the openssl Configure file.

"debian-s390","gcc:-DB_ENDIAN
${debian_cflags}::-D_REENTRANT::-ldl:RC4_CHAR RC4_CHUNK DES_INT
DES_UNROLL:${no_asm}:dlfcn:linux-
shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",

"debian-s390x","gcc:-DB_ENDIAN 
${debian_cflags}::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK 
DES_INT 
DES_UNROLL:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
---
Its the same code as in bug IBM140645(LP1601836), right,  where I report 
performance improvements using modified s390x code already upstream on openssl 
github. Tested by a locally installed openssl source package.

The issue reported here says that the s390x CPACF assembly code is not
configured into the openssl build of Ubuntu at all and thus is not
available in openssl client/server workloads;  a fallback to very slow
C-code is the result.

Probably, just some compiler flags are missing ...

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1601836

Title:
  Openssl libcrypto performance issue

Status in OpenSSL:
  New
Status in Ubuntu on IBM z Systems:
  New
Status in openssl package in Ubuntu:
  New

Bug description:
  == Comment: #0 - Bastian Pfeifer  - 2016-04-22 
03:37:03 ==
  ---Problem Description---
  Performance problem with s390x assembly code in the openssl libcrypto library:
  CPACF functions such as SHA, AES ... queries the CPACF facility bits too 
often.

  Problematic code can be found here:
  https://github.com/openssl/openssl/blob/master/crypto/sha/asm/sha1-s390x.pl

  What happens is that for every e.g SHA1 call the code first tests if
  the HW function is available. That's the case for all the CPACF
  functions.

  However what the lib should do is to query only once, safe the value
  and then use the function. The problem is that the Hipervisor in
  certain scenarios is required to intercept the query instructions,
  which makes this really expensive.

   
  Contact Information = bastian.pfei...@de.ibm.com 
   
  ---uname output---
  4.4.0-18-generic #34-Ubuntu SMP 
   
  Machine Type = 2964, 701 NC9 
   
  ---Debugger---
  A debugger is not configured
   
  ---Steps to Reproduce---
   n/a
   
  Userspace tool common name: OpenSSL 
   
  The userspace tool has the following bit modes: 64-bit 

  Userspace rpm: OpenSSL 1.0.2g  1 Mar 2016

  Userspace tool obtained from project website:  na 
   
  *Additional Instructions for bastian.pfei...@de.ibm.com:
  -Attach ltrace and strace of userspace application.

  == Comment: #8 - Bastian Pfeifer  - 2016-06-02 
07:05:00 ==
  We performed tests on the new SHA,AES and GHASH code and report performance 
improvements especially for SHA (up to 20%).

  Here are the links to the new s390x assembly code which should be used
  to create patches for the UBUNTU specific openssl versions.

  1)
  https://github.com/openssl/openssl/blob/master/crypto/s390xcpuid.S
  2)
  https://github.com/openssl/openssl/blob/master/crypto/s390xcap.c
  3)
  https://github.com/openssl/openssl/blob/master/crypto/sha/asm/sha1-s390x.pl
  4)
  https://github.com/openssl/openssl/blob/master/crypto/sha/asm/sha512-s390x.pl
  5)
  https://github.com/openssl/openssl/blob/master/crypto/aes/asm/aes-s390x.pl
  6)
  https://github.com/openssl/openssl/blob/master/crypto/modes/asm/ghash-s390x.pl

  In case of AES I was forced to change the following code in aes-
  s390x.pl

  .globlAES_set_decrypt_key
  .type AES_set_decrypt_key,\@function

  goes to

  .globlprivate_AES_set_decrypt_key
  .type private_AES_set_decrypt_key,\@function


[Touch-packages] [Bug 1602737] SOS report for systemd PCI Roce Interface renaming

2016-07-13 Thread bugproxy
Default Comment by Bridge

** Attachment added: "SOS report for systemd PCI Roce Interface renaming"
   
https://bugs.launchpad.net/bugs/1602737/+attachment/4700239/+files/sosreport-HGrauer-20160713144947.tar.xz

** Changed in: ubuntu
 Assignee: (unassigned) => Skipper Bug Screeners (skipper-screen-team)

** Package changed: ubuntu => systemd (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1602737

Title:
  PCI RoCE Interface could not be renamed from default name with link
  file

Status in systemd package in Ubuntu:
  New

Bug description:
  == Comment: #0 - Helmut Grauer  - 2016-07-13 
09:05:27 ==
  Try to rename PCI Roce Interface with .link file

  root@s35lp02:/etc/systemd/network# cat 10-net.link
  [Match]
  Path=pci-:00:00.0*
  MACAddress=82:01:14:07:85:70

  [Link]
  Name=hug0
  root@s35lp02:/etc/systemd/network#

  do  a reboot and journalctl show old interface name for RoCE PCI
  Interface

  Jul 13 14:39:40 s35lp02 kernel: mlx4_en 0001:00:00.0: Activating port:1
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 1: Using 32 TX 
rings
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 1: Using 4 RX 
rings
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 1:   frag:0 - 
size:1522 prefix:0 stride:1536
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 1: Initializing 
port
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en 0001:00:00.0: Activating port:2
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 2: Using 32 TX 
rings
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 2: Using 4 RX 
rings
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 2:   frag:0 - 
size:1522 prefix:0 stride:1536
  Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 2: Initializing 
port
  Jul 13 14:39:40 s35lp02 kernel: mlx4_core :00:00.0 enp0s0: renamed from 
eth0
  Jul 13 14:39:40 s35lp02 kernel: mlx4_core :00:00.0 enp0s0d1: renamed from 
eth1
  Jul 13 14:39:40 s35lp02 kernel: mlx4_core 0001:00:00.0 enP1p0s0d1: renamed 
from eth3
  Jul 13 14:39:40 s35lp02 kernel: mlx4_core 0001:00:00.0 enP1p0s0: renamed from 
eth2
  Jul 13 14:39:40 s35lp02 kernel: EXT4-fs (dasda1): mounting ext3 file system 
using the ext4 subsystem
  Jul 13 14:39:40 s35lp02 kernel: EXT4-fs (dasda1): mounted filesystem with 
ordered data mode. Opts: (null)

  udevadm test show the following output

  oot@s35lp02:/etc/systemd/network# udevadm test /class/net/enp0s0
  calling: test
  version 229
  This program is for debugging only, it does not run any program
  specified by a RUN key. It may show incorrect results, because
  some values may be different, or not available at a simulation run.

  === trie on-disk ===
  tool version:  229
  file size: 6841701 bytes
  header size 80 bytes
  strings1755245 bytes
  nodes  5086376 bytes
  Load module index
  timestamp of '/etc/systemd/network' changed
  Skipping overridden file: /usr/lib/systemd/network/99-default.link.
  Skipping overridden file: /usr/lib/systemd/network/10-net.link.
  Skipping overridden file: /lib/systemd/network/99-default.link.
  Skipping overridden file: /lib/systemd/network/10-net.link.
  Parsed configuration file /etc/systemd/network/99-default.link
  Parsed configuration file /lib/systemd/network/90-mac-for-usb.link
  Parsed configuration file /etc/systemd/network/11-net.link
  Parsed configuration file /etc/systemd/network/10-net.link
  Created link configuration context.
  timestamp of '/etc/udev/rules.d' changed
  Reading rules file: /lib/udev/rules.d/40-vm-hotadd.rules
  Reading rules file: /lib/udev/rules.d/40-z90crypt.rules
  Reading rules file: /etc/udev/rules.d/41-cio-ignore.rules
  Reading rules file: /etc/udev/rules.d/41-dasd-eckd-0.0.af06.rules
  Reading rules file: /etc/udev/rules.d/41-dasd-eckd-0.0.af07.rules
  Reading rules file: /etc/udev/rules.d/41-generic-ccw-0.0.0009.rules
  Reading rules file: /etc/udev/rules.d/41-qeth-0.0.b100.rules
  Reading rules file: /etc/udev/rules.d/41-qeth-0.0.f500.rules
  Reading rules file: /lib/udev/rules.d/50-firmware.rules
  Reading rules file: /lib/udev/rules.d/50-udev-default.rules
  Reading rules file: /lib/udev/rules.d/55-dm.rules
  Reading rules file: /lib/udev/rules.d/55-scsi-sg3_id.rules
  Reading rules file: /lib/udev/rules.d/56-dm-mpath-lvm.rules
  Reading rules file: /lib/udev/rules.d/56-lvm.rules
  Reading rules file: /lib/udev/rules.d/58-scsi-sg3_symlink.rules
  Reading rules file: /lib/udev/rules.d/59-dasd.rules
  Reading rules file: /lib/udev/rules.d/60-block.rules
  Reading rules file: /lib/udev/rules.d/60-cdrom_id.rules
  Reading rules file: /lib/udev/rules.d/60-crda.rules
  Reading rules file: /lib/udev/rules.d/60-drm.rules
  Reading rules file: /lib/udev/rules.d/60-evdev.rules
  Reading rules file: 

[Touch-packages] [Bug 1602737] [NEW] PCI RoCE Interface could not be renamed from default name with link file

2016-07-13 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

== Comment: #0 - Helmut Grauer  - 2016-07-13 09:05:27 
==
Try to rename PCI Roce Interface with .link file

root@s35lp02:/etc/systemd/network# cat 10-net.link
[Match]
Path=pci-:00:00.0*
MACAddress=82:01:14:07:85:70

[Link]
Name=hug0
root@s35lp02:/etc/systemd/network#

do  a reboot and journalctl show old interface name for RoCE PCI
Interface

Jul 13 14:39:40 s35lp02 kernel: mlx4_en 0001:00:00.0: Activating port:1
Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 1: Using 32 TX rings
Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 1: Using 4 RX rings
Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 1:   frag:0 - 
size:1522 prefix:0 stride:1536
Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 1: Initializing port
Jul 13 14:39:40 s35lp02 kernel: mlx4_en 0001:00:00.0: Activating port:2
Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 2: Using 32 TX rings
Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 2: Using 4 RX rings
Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 2:   frag:0 - 
size:1522 prefix:0 stride:1536
Jul 13 14:39:40 s35lp02 kernel: mlx4_en: 0001:00:00.0: Port 2: Initializing port
Jul 13 14:39:40 s35lp02 kernel: mlx4_core :00:00.0 enp0s0: renamed from eth0
Jul 13 14:39:40 s35lp02 kernel: mlx4_core :00:00.0 enp0s0d1: renamed from 
eth1
Jul 13 14:39:40 s35lp02 kernel: mlx4_core 0001:00:00.0 enP1p0s0d1: renamed from 
eth3
Jul 13 14:39:40 s35lp02 kernel: mlx4_core 0001:00:00.0 enP1p0s0: renamed from 
eth2
Jul 13 14:39:40 s35lp02 kernel: EXT4-fs (dasda1): mounting ext3 file system 
using the ext4 subsystem
Jul 13 14:39:40 s35lp02 kernel: EXT4-fs (dasda1): mounted filesystem with 
ordered data mode. Opts: (null)

udevadm test show the following output

oot@s35lp02:/etc/systemd/network# udevadm test /class/net/enp0s0
calling: test
version 229
This program is for debugging only, it does not run any program
specified by a RUN key. It may show incorrect results, because
some values may be different, or not available at a simulation run.

=== trie on-disk ===
tool version:  229
file size: 6841701 bytes
header size 80 bytes
strings1755245 bytes
nodes  5086376 bytes
Load module index
timestamp of '/etc/systemd/network' changed
Skipping overridden file: /usr/lib/systemd/network/99-default.link.
Skipping overridden file: /usr/lib/systemd/network/10-net.link.
Skipping overridden file: /lib/systemd/network/99-default.link.
Skipping overridden file: /lib/systemd/network/10-net.link.
Parsed configuration file /etc/systemd/network/99-default.link
Parsed configuration file /lib/systemd/network/90-mac-for-usb.link
Parsed configuration file /etc/systemd/network/11-net.link
Parsed configuration file /etc/systemd/network/10-net.link
Created link configuration context.
timestamp of '/etc/udev/rules.d' changed
Reading rules file: /lib/udev/rules.d/40-vm-hotadd.rules
Reading rules file: /lib/udev/rules.d/40-z90crypt.rules
Reading rules file: /etc/udev/rules.d/41-cio-ignore.rules
Reading rules file: /etc/udev/rules.d/41-dasd-eckd-0.0.af06.rules
Reading rules file: /etc/udev/rules.d/41-dasd-eckd-0.0.af07.rules
Reading rules file: /etc/udev/rules.d/41-generic-ccw-0.0.0009.rules
Reading rules file: /etc/udev/rules.d/41-qeth-0.0.b100.rules
Reading rules file: /etc/udev/rules.d/41-qeth-0.0.f500.rules
Reading rules file: /lib/udev/rules.d/50-firmware.rules
Reading rules file: /lib/udev/rules.d/50-udev-default.rules
Reading rules file: /lib/udev/rules.d/55-dm.rules
Reading rules file: /lib/udev/rules.d/55-scsi-sg3_id.rules
Reading rules file: /lib/udev/rules.d/56-dm-mpath-lvm.rules
Reading rules file: /lib/udev/rules.d/56-lvm.rules
Reading rules file: /lib/udev/rules.d/58-scsi-sg3_symlink.rules
Reading rules file: /lib/udev/rules.d/59-dasd.rules
Reading rules file: /lib/udev/rules.d/60-block.rules
Reading rules file: /lib/udev/rules.d/60-cdrom_id.rules
Reading rules file: /lib/udev/rules.d/60-crda.rules
Reading rules file: /lib/udev/rules.d/60-drm.rules
Reading rules file: /lib/udev/rules.d/60-evdev.rules
Reading rules file: /lib/udev/rules.d/60-gnupg.rules
Reading rules file: /lib/udev/rules.d/60-persistent-alsa.rules
Reading rules file: /lib/udev/rules.d/60-persistent-input.rules
Reading rules file: /lib/udev/rules.d/60-persistent-storage-dm.rules
Reading rules file: /lib/udev/rules.d/60-persistent-storage-tape.rules
Reading rules file: /lib/udev/rules.d/60-persistent-storage.rules
Reading rules file: /lib/udev/rules.d/60-persistent-v4l.rules
Reading rules file: /lib/udev/rules.d/60-readahead.rules
Reading rules file: /lib/udev/rules.d/60-serial.rules
Reading rules file: /lib/udev/rules.d/60-vlan-network-interface.rules
Reading rules file: /lib/udev/rules.d/61-persistent-storage-android.rules
Reading rules file: /lib/udev/rules.d/64-btrfs.rules
Reading rules file: /lib/udev/rules.d/69-lvm-metad.rules
Reading rules file: 

[Touch-packages] [Bug 1433590] Re: apparmor dbus denial for org.freedesktop.Accounts and make Other vibrations work

2016-07-13 Thread Zhang Enwei
I have compiled the usensord binary based on current solution.
I did some tests and it works well.
Since settings part is not ready, I am using below command to change the 
property whose default value is 0(means not vibrate).
dbus-send --session --print-reply --type=method_call 
--dest='com.canonical.usensord' /com/canonical/usensord/haptic 
org.freedesktop.DBus.Properties.Set string:"com.canonical.usensord.haptic" 
string:"OtherVibrate" uint32:1

Code is here: https://code.launchpad.net/~zhangew401/usensord/fix-lp-1433590
and the logic is
do vibration for OSK always.
do vibration for others only when the property is 1(means enabled in settings)

The property is saved in file, /home/phablet/.config/usensord/prop so
that it will be restored after factory reset.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1433590

Title:
  apparmor dbus denial for org.freedesktop.Accounts and make Other
  vibrations work

Status in Canonical System Image:
  Triaged
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Fix Released
Status in ubuntu-system-settings package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in usensord package in Ubuntu:
  In Progress

Bug description:
  This affects vivid and (somewhat recently?) 14.09.

  At some point, apps started to request access to
  org.freedesktop.Accounts for something, but I'm not sure what. It has
  been conjectured in this bug that it is due to vibration settings.
  Filing against ubuntu-system-settings for now, but please feel free to
  move to the correct package.

  This happens with webapps:
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"

  and QML apps:
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"

  The following rules allow the requested access:
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.DBus.{Introspectable,Properties}"
 member=Introspect
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.Accounts"
 member=FindUserById
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts/User[0-9]*"
 interface="org.freedesktop.DBus.Properties"
 member=Get
 peer=(name=org.freedesktop.Accounts,label=unconfined),

  However, the above is too lenient and constitutes a privacy leak for
  apps. FindUserById could be used by a malicious app to enumerate
  usernames on multiuser systems and because we can't mediate method
  data with apparmor, the Get() method can be used to obtain any
  information provided by this interface.

  The following can be used to see what can be leaked to a malicious app:
  gdbus introspect --system -d org.freedesktop.Accounts -o 
/org/freedesktop/Accounts/User`id -u phablet`

  This can be solved in a couple of ways:
  1. add whatever information the app is trying to access to a new helper 
service that only exposes things that the app needs. This could be a single 
standalone service, perhaps something from ubuntu-system-settings, that could 
expose any number of things-- the current locale, if the locale changed, if the 
grid units changed, the vibration settings, etc. Since this service wouldn't 
have any sensitive information, you could use standard dbus 
properties/Get()/etc 
  2. add a new dbus API to an 

[Touch-packages] [Bug 1599695] Re: When running cmake from QtC on a webbrowser-app branch it fails

2016-07-13 Thread Andrew Hayzen
I've been trying both 'Desktop' and 'Ubuntu SDK Desktop Kit', resulting
in the same error. If you need logs a particular one let me know.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to webbrowser-app in Ubuntu.
https://bugs.launchpad.net/bugs/1599695

Title:
  When running cmake from QtC on a webbrowser-app branch it fails

Status in webbrowser-app package in Ubuntu:
  Incomplete

Bug description:
  When running cmake from QtC on a webbrowser-app branch in Xenial it
  fails with the following error:

  CMake Error at src/Ubuntu/CMakeLists.txt:31 (message):
    Invalid chromium version: ''

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+bug/1599695/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1596117] Re: clicking enter/return hides keyboard and there is no way to show it again without clicking the lock button

2016-07-13 Thread Daniel
Seems to be fixed now (updated on July 12, 2016)

** Changed in: libusermetrics (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libusermetrics in Ubuntu.
https://bugs.launchpad.net/bugs/1596117

Title:
  clicking enter/return hides keyboard and there is no way to show it
  again without clicking the lock button

Status in libusermetrics package in Ubuntu:
  Fix Released

Bug description:
  This obviously is a bug - once I click return/enter button on the keyboard 
when entering a passphrase, the keyboard is hidden and there is not way to show 
it again (unless i click the physical lock button and unlock it again).
  It is not working on Meizu PRO 5 (Ubuntu Edition) OTA 11 version 112 (did not 
try 113 - it never boots up).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libusermetrics/+bug/1596117/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1599695] Re: When running cmake from QtC on a webbrowser-app branch it fails

2016-07-13 Thread Alexandre Abreu
@Andrew: could you make sure that you select the right Generator in the
Run CMake popup "Ubuntu SDK Desktop Kit" is the right one?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to webbrowser-app in Ubuntu.
https://bugs.launchpad.net/bugs/1599695

Title:
  When running cmake from QtC on a webbrowser-app branch it fails

Status in webbrowser-app package in Ubuntu:
  Incomplete

Bug description:
  When running cmake from QtC on a webbrowser-app branch in Xenial it
  fails with the following error:

  CMake Error at src/Ubuntu/CMakeLists.txt:31 (message):
    Invalid chromium version: ''

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+bug/1599695/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602256] Re: sometimes "systemd-coredump[]: Coredump file descriptor missing." is seen, upstream #2984

2016-07-13 Thread Martin Pitt
OK, thanks, setting back to triaged. So the current SRU does not fix
this, but having the patch cannot hurt either, it just does not fix
*this* bug apparently.

** Changed in: systemd (Ubuntu Xenial)
   Status: Fix Committed => Triaged

** Changed in: systemd (Ubuntu Xenial)
 Assignee: Martin Pitt (pitti) => (unassigned)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1602256

Title:
  sometimes "systemd-coredump[]: Coredump file descriptor missing."
  is seen, upstream #2984

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Xenial:
  Triaged

Bug description:
  Please include this upstream fix/pull request:

  coredump: use next_datagram_size_fd instead of ioctl(FIONREAD) #3237
  https://github.com/systemd/systemd/pull/3237

  Reported as
  sometimes "systemd-coredump[]: Coredump file descriptor missing." is 
seen, upstream #2984
  https://github.com/systemd/systemd/issues/2984

  Or make a release using systemd tag=v230

   :~$ lsb_release -rd
  Description:Ubuntu 16.04 LTS
  Release:16.04

  :~$ apt-cache policy systemd
  systemd:
    Installed: 229-4ubuntu6
    Candidate: 229-4ubuntu6
    Version table:
   *** 229-4ubuntu6 500
  500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 
Packages
  100 /var/lib/dpkg/status
   229-4ubuntu4 500
  500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

  SRU INFORMATION
  ---
  This only affects systemd-coredump which we don't use in Ubuntu by default 
(we use Apport), so the regression potential is very low. There is no 
straightforward reproducer for this (see upstream bug report: 
https://github.com/systemd/systemd/issues/2984). But our systemd package has 
integration tests for coredump: 
http://anonscm.debian.org/cgit/pkg-systemd/systemd.git/tree/debian/tests/boot-and-services?h=ubuntu-xenial#n436
 

  Thus if the updated package still succeeds its autopkgtests, this
  should provide sufficient regression testing for this bug.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1602256/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1567670] Re: you can drop nssdb integration

2016-07-13 Thread Marc Deslauriers
yakkety sync dropped the delta. Marking as fix released.

** Changed in: nss (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nss in Ubuntu.
https://bugs.launchpad.net/bugs/1567670

Title:
  you can drop nssdb integration

Status in nss package in Ubuntu:
  Fix Released

Bug description:
  Hi, freeipa-client doesn't need /etc/pki/nssdb anymore but uses it's
  own db (/etc/ipa/nssdb) by now, so you can drop the delta to debian
  from xenial and up at least.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nss/+bug/1567670/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1598770] Re: Unity in low-graphics mode has animations and unneeded redraws

2016-07-13 Thread Mateusz Stachowski
That finally worked.

Changing launcher icons size works and workspaces also work without
unneeded animations.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nux in Ubuntu.
https://bugs.launchpad.net/bugs/1598770

Title:
  Unity in low-graphics mode has animations and unneeded redraws

Status in compiz package in Ubuntu:
  Fix Released
Status in nux package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released
Status in unity-control-center package in Ubuntu:
  Fix Released
Status in compiz source package in Xenial:
  Fix Committed
Status in nux source package in Xenial:
  Fix Committed
Status in unity source package in Xenial:
  Fix Committed
Status in unity-control-center source package in Xenial:
  Fix Committed

Bug description:
  [Impact]

  When unity is in Low graphics mode (because of software rendering)
  there are still window animations and fade effects which we should get
  rid of.

  
  [Test case]

  This should apply naturally to a (virtual-)machine with no hardware
  acceleration or There are multiple ways to force low-gfx mode:

  1) Add an upstart job such as:

  cat << EOF > ~/.config/upstart/lowgfx.conf
  start on starting unity7

  pre-start script
#initctl set-env --global UNITY_LOW_GFX_MODE=1
initctl set-env --global LIBGL_ALWAYS_SOFTWARE=1
  end script
  EOF 

  
  2) Run unity with:
 COMPIZ_CONFIG_PROFILE=ubuntu-lowgfx

  On login unity should use opaque views (dash, switcher, launcher,
  shortcut-dialogs) with no fading and reduced effects. Windows should
  also use smaller shadows.

  
  [Regression potential]

  Some settings from unity-control-center couldn't be applied to normal
  profile. Low graphics mode might be used as normal one.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1598770/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602690] Re: Increase focus frame line weight to 2dp

2016-07-13 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: ubuntu-ui-toolkit (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1602690

Title:
  Increase focus frame line weight to 2dp

Status in Ubuntu UX:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu RTM:
  New

Bug description:
  After reviewing the focus frame recently can we increase the line
  weight to 2dp.

  This applies to the focus frame: 
  src/Ubuntu/Components/Themes/Ambiance/1.3/FocusShape.qml (line 29)

  And the list item frame:
  ubuntu-ui-toolkit/src/Ubuntu/Components/plugin/uclistitem.cpp (line 1132)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-ux/+bug/1602690/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1260103] Re: oxide should use an app-specific path for shared memory files

2016-07-13 Thread Olivier Tilloy
And here is what such a patch would look like:

diff --git a/base/files/file_util_posix.cc b/base/files/file_util_posix.cc
index 42de931..f9dec07 100644
--- a/base/files/file_util_posix.cc
+++ b/base/files/file_util_posix.cc
@@ -139,6 +139,10 @@ std::string TempFileName() {
 #if defined(GOOGLE_CHROME_BUILD)
   return std::string(".com.google.Chrome.XX");
 #else
+  const char* tmp = getenv("SNAP_NAME");
+  if (tmp) {
+return std::string("snap.").append(tmp).append(".XX");
+  }
   return std::string(".org.chromium.Chromium.XX");
 #endif
 }


** Changed in: oxide
Milestone: None => branch-1.17

** Changed in: oxide
   Status: Triaged => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1260103

Title:
  oxide should use an app-specific path for shared memory files

Status in Oxide:
  In Progress
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Oxide creates shared memory files as /run/shm/.org.chromium.Chromium.*. This 
results in an AppArmor rule like the following:
owner /run/shm/.org.chromium.Chromium.* rwk, 

  But this rule is too lenient because a malicious app could enumerate
  these files and attack shared memory of other applications. Therefore,
  these paths need to be made application specific.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oxide/+bug/1260103/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1260103] Re: oxide should use an app-specific path for shared memory files

2016-07-13 Thread Olivier Tilloy
> I would modify base::GetShmemTempDir() to lookup a path via
> base::PathService and then have Oxide override this.

GetShmemTempDir() tries to create a temp file under /dev/shm/, so the problem 
is not the path itself, it’s the name of the temp file under that path.
IIUC what needs to be modified is the TempFileName() function, to return 
something like "snap.${SNAP_NAME}.XX", if SNAP_NAME is defined, and fall 
back to the default value, ".org.chromium.Chromium.XX".

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1260103

Title:
  oxide should use an app-specific path for shared memory files

Status in Oxide:
  In Progress
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Oxide creates shared memory files as /run/shm/.org.chromium.Chromium.*. This 
results in an AppArmor rule like the following:
owner /run/shm/.org.chromium.Chromium.* rwk, 

  But this rule is too lenient because a malicious app could enumerate
  these files and attack shared memory of other applications. Therefore,
  these paths need to be made application specific.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oxide/+bug/1260103/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1595580] Re: Upgrade to version 9.0 from June 2016

2016-07-13 Thread Sebastien Bacher
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/1:9.0-1.1ubuntu1

** Changed in: pulseaudio (Ubuntu)
   Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1595580

Title:
  Upgrade to version 9.0 from June 2016

Status in pulseaudio package in Ubuntu:
  Fix Released

Bug description:
  Please upgrade to version 9.0 from June 2016, see also
  https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/9.0/

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1595580/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1559731] Re: Battery indicator turns red at 30% on desktop

2016-07-13 Thread Martin Pitt
Hello Omer, or anyone else affected,

Accepted indicator-power into xenial-proposed. The package will build
now and be available at https://launchpad.net/ubuntu/+source/indicator-
power/12.10.6+16.04.20160708-0ubuntu1 in a few hours, and then in the
-proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed.  Your feedback will aid us getting this update
out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-needed to verification-done. If it does not fix the
bug for you, please add a comment stating that, and change the tag to
verification-failed.  In either case, details of your testing will help
us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance!

** Changed in: indicator-power (Ubuntu Xenial)
   Status: Triaged => Fix Committed

** Tags added: verification-needed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to indicator-power in Ubuntu.
https://bugs.launchpad.net/bugs/1559731

Title:
  Battery indicator turns red at 30% on desktop

Status in Canonical System Image:
  Fix Committed
Status in indicator-power package in Ubuntu:
  Fix Released
Status in indicator-power source package in Xenial:
  Fix Committed

Bug description:
  The indicator turns red as soon as battery goes 30%

  Please refer to the attached screenshot.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: indicator-power 12.10.6+16.04.20160105-0ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-14.30-generic 4.4.5
  Uname: Linux 4.4.0-14-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sun Mar 20 20:43:32 2016
  InstallationDate: Installed on 2016-03-18 (1 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160313)
  SourcePackage: indicator-power
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1559731/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602690] Re: Increase focus frame line weight to 2dp

2016-07-13 Thread Jamie Young
** Changed in: ubuntu-ux
   Importance: Undecided => High

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1602690

Title:
  Increase focus frame line weight to 2dp

Status in Ubuntu UX:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  New
Status in ubuntu-ui-toolkit package in Ubuntu RTM:
  New

Bug description:
  After reviewing the focus frame recently can we increase the line
  weight to 2dp.

  This applies to the focus frame: 
  src/Ubuntu/Components/Themes/Ambiance/1.3/FocusShape.qml (line 29)

  And the list item frame:
  ubuntu-ui-toolkit/src/Ubuntu/Components/plugin/uclistitem.cpp (line 1132)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-ux/+bug/1602690/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1260103] Re: oxide should use an app-specific path for shared memory files

2016-07-13 Thread Olivier Tilloy
For applications packaged as snaps, snappy-debug suggests writing to
"/dev/shm/snap.$SNAP_NAME.*".

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1260103

Title:
  oxide should use an app-specific path for shared memory files

Status in Oxide:
  Triaged
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Confirmed

Bug description:
  Oxide creates shared memory files as /run/shm/.org.chromium.Chromium.*. This 
results in an AppArmor rule like the following:
owner /run/shm/.org.chromium.Chromium.* rwk, 

  But this rule is too lenient because a malicious app could enumerate
  these files and attack shared memory of other applications. Therefore,
  these paths need to be made application specific.

To manage notifications about this bug go to:
https://bugs.launchpad.net/oxide/+bug/1260103/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1594841] Re: Systemic failure in handling of OAuth revocations

2016-07-13 Thread Alberto Mardegan
Just found this (read near the bottom):
  https://gist.github.com/arirubinstein/fd5453537436a8757266f908c3e41538
It appears that Google might have an *undocumented* API to exchange an API 
token for a web session. I'm not suggesting that we use it, I'm just linking it 
here for reference.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-system-settings-
online-accounts in Ubuntu.
https://bugs.launchpad.net/bugs/1594841

Title:
  Systemic failure in handling of OAuth revocations

Status in Canonical System Image:
  New
Status in YouTube Scope:
  New
Status in ubuntu-system-settings-online-accounts package in Ubuntu:
  New

Bug description:
  Current handling of OAuth tokens in the system is quite poor,
  especially in failure cases.

  The way webapp authentication works via online-accounts, is a complete
  facade. The OAuth tokens are not even used, but instead the cookies
  are copied from the account plug-in's web view, and stored under
  ~/.config/ for the app. This means that when the cookies expire, and
  you still have an account configured you end up being presented with a
  logged out experience on the web site, depending on what URL is being
  used, and what site it is. For example, on Untappd, it has happened
  several times where, despite having my account existing and enabled in
  system settings, that upon opening Untappd, I have been presented with
  the page requiring me to log in. In Twitter, one is simply redirected
  to a fairly simplistic page requesting entry of username and password,
  with no explanation at all.

  Conversely, if for these services, one does go to the site's settings
  page, and revokes access for the OAuth token, absolutely nothing
  changes. The online accounts UI does not pop up requiring one to log
  in again. The app will continue working just fine, until the cookies
  in question expire, the webapp's configuration is deleted, or the
  account is removed.

  Furthermore, in scopes which do use the account, behavior is very
  unacceptable when a token is revoked/expired on the server side. For
  example, if one opens the YouTube scope, and logs in, everything seems
  to be fine. But if one goes to
  https://security.google.com/settings/security/permissions for the
  account in question, and revokes the token access for Ubuntu to use
  YouTube, the result upon refresh of the scope is a blank view. There
  is no way to log in again. There are no videos to watch. All that
  appears in the scope-registry.log for this situation is the following:

  YouTube scope is authenticated
  Something weird happened
  ERROR: HTTP request timeout

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1594841/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602690] Re: Increase focus frame line weight to 2dp

2016-07-13 Thread Andrea Bernabei
** Also affects: ubuntu-ui-toolkit (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: ubuntu-ux
   Importance: Undecided
   Status: New

** Changed in: ubuntu-ux
 Assignee: (unassigned) => Jamie Young (jamiedawsonyoung)

** Changed in: ubuntu-ux
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1602690

Title:
  Increase focus frame line weight to 2dp

Status in Ubuntu UX:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  New
Status in ubuntu-ui-toolkit package in Ubuntu RTM:
  New

Bug description:
  After reviewing the focus frame recently can we increase the line
  weight to 2dp.

  This applies to the focus frame: 
  src/Ubuntu/Components/Themes/Ambiance/1.3/FocusShape.qml (line 29)

  And the list item frame:
  ubuntu-ui-toolkit/src/Ubuntu/Components/plugin/uclistitem.cpp (line 1132)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-ux/+bug/1602690/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1598770] Re: Unity in low-graphics mode has animations and unneeded redraws

2016-07-13 Thread Treviño
You also have to run unity-control-center with that environment
variable:

  COMPIZ_CONFIG_PROFILE=ubuntu-lowgfx unity-control-center

This is automatic when this is forced with upstart, otherwise you've to
do it by hand.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nux in Ubuntu.
https://bugs.launchpad.net/bugs/1598770

Title:
  Unity in low-graphics mode has animations and unneeded redraws

Status in compiz package in Ubuntu:
  Fix Released
Status in nux package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released
Status in unity-control-center package in Ubuntu:
  Fix Released
Status in compiz source package in Xenial:
  Fix Committed
Status in nux source package in Xenial:
  Fix Committed
Status in unity source package in Xenial:
  Fix Committed
Status in unity-control-center source package in Xenial:
  Fix Committed

Bug description:
  [Impact]

  When unity is in Low graphics mode (because of software rendering)
  there are still window animations and fade effects which we should get
  rid of.

  
  [Test case]

  This should apply naturally to a (virtual-)machine with no hardware
  acceleration or There are multiple ways to force low-gfx mode:

  1) Add an upstart job such as:

  cat << EOF > ~/.config/upstart/lowgfx.conf
  start on starting unity7

  pre-start script
#initctl set-env --global UNITY_LOW_GFX_MODE=1
initctl set-env --global LIBGL_ALWAYS_SOFTWARE=1
  end script
  EOF 

  
  2) Run unity with:
 COMPIZ_CONFIG_PROFILE=ubuntu-lowgfx

  On login unity should use opaque views (dash, switcher, launcher,
  shortcut-dialogs) with no fading and reduced effects. Windows should
  also use smaller shadows.

  
  [Regression potential]

  Some settings from unity-control-center couldn't be applied to normal
  profile. Low graphics mode might be used as normal one.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1598770/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602649] Re: need an option to disable launcher's autohide on desktop

2016-07-13 Thread dinamic
gsettings set com.canonical.Unity8 autohide-launcher false

works as expected, i don't even know what i expected to happen! maybe
unicorns LOL, i'm so stooopid X-)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1602649

Title:
  need an option to disable launcher's autohide on desktop

Status in ubuntu-system-settings package in Ubuntu:
  New
Status in unity8 package in Ubuntu:
  Fix Released

Bug description:
  need an option to disable launcher's autohide on desktop
  you can't disable autohide now

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-system-settings/+bug/1602649/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1599695] Re: When running cmake from QtC on a webbrowser-app branch it fails

2016-07-13 Thread Olivier Tilloy
Okay, so same problem really, except that now the QtCreator environment
fails to locate the minimal plugin instead of the xcb one. I’m puzzled
as it works just fine here on my laptop. There must be something
different in our configurations.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to webbrowser-app in Ubuntu.
https://bugs.launchpad.net/bugs/1599695

Title:
  When running cmake from QtC on a webbrowser-app branch it fails

Status in webbrowser-app package in Ubuntu:
  Incomplete

Bug description:
  When running cmake from QtC on a webbrowser-app branch in Xenial it
  fails with the following error:

  CMake Error at src/Ubuntu/CMakeLists.txt:31 (message):
    Invalid chromium version: ''

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+bug/1599695/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1069449] Re: LibreOffice Calc messed up UI

2016-07-13 Thread Andreas Wehler
Libreoffice 5.1.4.2, Xubuntu 16.04.

Hi. I've experienced font distortions all the time when editing within
the new Libreoffice. The distortions go away with redraw by Ctrl+L or
Shift+Ctrl+R . That's extremely annoying, never had that before.

Now I found a solution: 
  Tools / Options / View 
  Section: Graphics Output
--> Activate "Use OpenGL for all rendering
--> Activate "Force OpenGL even if blacklisted (on restart)

This cures the problem, for me at least!
(See attached defect snapshot)


** Attachment added: "Distorted font on editing a calc cell"
   
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1069449/+attachment/4700139/+files/Snap_038.png

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1069449

Title:
  LibreOffice Calc messed up UI

Status in xorg package in Ubuntu:
  Expired

Bug description:
  Sometimes when I open a spreadsheet (.ods file) in Calc I get a really
  messed up UI. The column letters, row numbers, worksheet names, font
  and font size in their respective drop boxes are all an unreadable,
  pixelated mess.

  See the screenshot linked to below. (I removed the contents of the
  spreadsheet itself which is why I have a big white box, this isn't
  part of the issue).

  I occasionally get the same distorted text when typing into a Calc
  cell, it resolves itself when I hit enter and confirm the cell
  contents.

  See the screenshot here - http://www.speed-
  shot.co.uk/images/Other/libreoffice1.png

  Sorry I don't know how to embed it. If that is even possible.

  This has only happened since I updated to 12.10 running on Unity.

  1) The release of Ubuntu you are using, System -> About Ubuntu

  Ubuntu 12.10

  2) The version of the package you are using

  libreoffice-calc 1:3.6.2~rc2-0ubuntu3

  3) What you expected to happen

  A readable UI.

  4) What happened instead.

  See screenshot.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1069449/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1599695] Re: When running cmake from QtC on a webbrowser-app branch it fails

2016-07-13 Thread Andrew Hayzen
I tried the change in comment 7, and now it errors with:
'This application failed to start because it could not find or load the Qt 
platform plugin "minimal"'

Full logs here [4] [5].

4 - http://pastebin.ubuntu.com/19270432/
5 - http://pastebin.ubuntu.com/19270459/

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to webbrowser-app in Ubuntu.
https://bugs.launchpad.net/bugs/1599695

Title:
  When running cmake from QtC on a webbrowser-app branch it fails

Status in webbrowser-app package in Ubuntu:
  Incomplete

Bug description:
  When running cmake from QtC on a webbrowser-app branch in Xenial it
  fails with the following error:

  CMake Error at src/Ubuntu/CMakeLists.txt:31 (message):
    Invalid chromium version: ''

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+bug/1599695/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1523817] Re: ComboButton needs keyboard support

2016-07-13 Thread Jamie Young
Discussed this with Femma. The behaviour for focus and select is
correct. I would like to increase the weight of the focus frame but I
will log this as a separate bug.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1523817

Title:
  ComboButton needs keyboard support

Status in Canonical System Image:
  In Progress
Status in ubuntu-ui-toolkit package in Ubuntu:
  In Progress
Status in ubuntu-ui-toolkit package in Ubuntu RTM:
  In Progress

Bug description:
  The ComboButton needs to open and close with a keyboard, via
  Space/Enter key, Up/Down arrows change the current choice while the
  dropdown is visible.

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1523817/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602649] Re: need an option to disable launcher's autohide on desktop

2016-07-13 Thread dinamic
thanks! :D but i need to do so in a graphical way :P a UI setting
somewhere

i guess there is a plan to make the launcher more customizable, since
there are already settings in gsettings, righ? i also need to be able to
change the launcher size, it's too big/wide now. i keep it at 20 in
unity7

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1602649

Title:
  need an option to disable launcher's autohide on desktop

Status in ubuntu-system-settings package in Ubuntu:
  New
Status in unity8 package in Ubuntu:
  Fix Released

Bug description:
  need an option to disable launcher's autohide on desktop
  you can't disable autohide now

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-system-settings/+bug/1602649/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602628] Re: can't drag/move window if it's semi-maximized

2016-07-13 Thread Lukáš Tinkl
** Changed in: unity8 (Ubuntu)
 Assignee: (unassigned) => Lukáš Tinkl (lukas-kde)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1602628

Title:
  can't drag/move window if it's semi-maximized

Status in unity8 package in Ubuntu:
  Triaged

Bug description:
  ubuntu 16.10
  can't drag/move window if it's semi-maximized

  open random app, semi-miaximize left or rigt (CTRL SUPER + Left or
  Right), try to move the window by draggin' it from the title bar.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1602628/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602649] Re: need an option to disable launcher's autohide on desktop

2016-07-13 Thread Michał Sawicz
This is already available for unity8:

$ gsettings get com.canonical.Unity8 autohide-launcher

** Also affects: ubuntu-system-settings (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: unity8 (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1602649

Title:
  need an option to disable launcher's autohide on desktop

Status in ubuntu-system-settings package in Ubuntu:
  New
Status in unity8 package in Ubuntu:
  Fix Released

Bug description:
  need an option to disable launcher's autohide on desktop
  you can't disable autohide now

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-system-settings/+bug/1602649/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1599775] Re: "low-graphics mode" in VirtualBox guest, but X server running

2016-07-13 Thread Michael Thayer
Sorry, that doesn't do it yet.  (Shame I didn't manage to fix this for
5.0.0.)  However I realised that Mesa has exactly the same problem, so I
have taken a look at their code to see what they do.  Also looks like a
bit of a hack, but since nothing relevant can afford not to work with
Mesa it should be a safe one.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1599775

Title:
  "low-graphics mode" in VirtualBox guest, but X server running

Status in lightdm package in Ubuntu:
  New

Bug description:
  I sometimes get the "low-graphics mode" message when starting an
  Ubuntu 16.04 virtual machine inside of VirtualBox (current development
  code trunk, somewhere past version 5.1 beta 3 and a debug build).
  When I switch to VT-7 I find the X server running without any visible
  issues (I am the upstream developer of the guest graphics drivers, so
  I have a reasonable but not infallible understanding of the X server).

  The virtual machine has Guest Additions installed, same vintage and
  also a debug build.  Two screens are enabled as is 3D acceleration.
  The host system is also Ubuntu 16.04.  I am still trying to work out
  what triggers the message, but in my last attempts a cold boot failed
  to produce it, while a clean reboot did, but only when the host system
  was not under load (under load as in building VirtualBox).

  Searching the lightdm log files led me to the message "CRITICAL **:
  session_get_login1_session_id: assertion 'session != NULL' failed",
  which in turn led me to this similar-looking Debian bug:

  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=814760

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: lightdm 1.18.1-0ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
  Uname: Linux 4.4.0-28-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu Jul  7 10:49:27 2016
  InstallationDate: Installed on 2016-06-08 (28 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  SourcePackage: lightdm
  UpgradeStatus: No upgrade log present (probably fresh install)

  IRC discussion at:

https://irclogs.ubuntu.com/2016/07/07/%23ubuntu-devel.html#t07:52

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1599775/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602628] Re: can't drag/move window if it's semi-maximized

2016-07-13 Thread Michał Sawicz
** Changed in: unity8 (Ubuntu)
   Status: New => Triaged

** Changed in: unity8 (Ubuntu)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1602628

Title:
  can't drag/move window if it's semi-maximized

Status in unity8 package in Ubuntu:
  Triaged

Bug description:
  ubuntu 16.10
  can't drag/move window if it's semi-maximized

  open random app, semi-miaximize left or rigt (CTRL SUPER + Left or
  Right), try to move the window by draggin' it from the title bar.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1602628/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1599775] Re: "low-graphics mode" in VirtualBox guest, but X server running

2016-07-13 Thread Paul Sladen
This changeset was applied upstream:

https://www.virtualbox.org/changeset/62201/vbox/trunk/src/VBox/Additions/common/crOpenGL/egl.c

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1599775

Title:
  "low-graphics mode" in VirtualBox guest, but X server running

Status in lightdm package in Ubuntu:
  New

Bug description:
  I sometimes get the "low-graphics mode" message when starting an
  Ubuntu 16.04 virtual machine inside of VirtualBox (current development
  code trunk, somewhere past version 5.1 beta 3 and a debug build).
  When I switch to VT-7 I find the X server running without any visible
  issues (I am the upstream developer of the guest graphics drivers, so
  I have a reasonable but not infallible understanding of the X server).

  The virtual machine has Guest Additions installed, same vintage and
  also a debug build.  Two screens are enabled as is 3D acceleration.
  The host system is also Ubuntu 16.04.  I am still trying to work out
  what triggers the message, but in my last attempts a cold boot failed
  to produce it, while a clean reboot did, but only when the host system
  was not under load (under load as in building VirtualBox).

  Searching the lightdm log files led me to the message "CRITICAL **:
  session_get_login1_session_id: assertion 'session != NULL' failed",
  which in turn led me to this similar-looking Debian bug:

  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=814760

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: lightdm 1.18.1-0ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
  Uname: Linux 4.4.0-28-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu Jul  7 10:49:27 2016
  InstallationDate: Installed on 2016-06-08 (28 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  SourcePackage: lightdm
  UpgradeStatus: No upgrade log present (probably fresh install)

  IRC discussion at:

https://irclogs.ubuntu.com/2016/07/07/%23ubuntu-devel.html#t07:52

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1599775/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1433590] Re: apparmor dbus denial for org.freedesktop.Accounts and make Other vibrations work

2016-07-13 Thread Zhang Enwei
** Changed in: usensord (Ubuntu)
   Status: Confirmed => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor-easyprof-ubuntu
in Ubuntu.
https://bugs.launchpad.net/bugs/1433590

Title:
  apparmor dbus denial for org.freedesktop.Accounts and make Other
  vibrations work

Status in Canonical System Image:
  Triaged
Status in apparmor-easyprof-ubuntu package in Ubuntu:
  Fix Released
Status in ubuntu-system-settings package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in usensord package in Ubuntu:
  In Progress

Bug description:
  This affects vivid and (somewhat recently?) 14.09.

  At some point, apps started to request access to
  org.freedesktop.Accounts for something, but I'm not sure what. It has
  been conjectured in this bug that it is due to vibration settings.
  Filing against ubuntu-system-settings for now, but please feel free to
  move to the correct package.

  This happens with webapps:
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"
  Apr  7 08:42:17 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=2632 
profile="com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.0.26" 
peer_pid=1596 peer_profile="unconfined"

  and QML apps:
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.DBus.Introspectable" member="Introspect" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"
  Apr  7 08:43:40 ubuntu-phablet dbus[797]: apparmor="DENIED" 
operation="dbus_method_call"  bus="system" path="/org/freedesktop/Accounts" 
interface="org.freedesktop.Accounts" member="FindUserById" mask="send" 
name="org.freedesktop.Accounts" pid=3377 
profile="com.ubuntu.calculator_calculator_1.3.339" peer_pid=1596 
peer_profile="unconfined"

  The following rules allow the requested access:
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.DBus.{Introspectable,Properties}"
 member=Introspect
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts"
 interface="org.freedesktop.Accounts"
 member=FindUserById
 peer=(name=org.freedesktop.Accounts,label=unconfined),
dbus (send)
 bus=system
 path="/org/freedesktop/Accounts/User[0-9]*"
 interface="org.freedesktop.DBus.Properties"
 member=Get
 peer=(name=org.freedesktop.Accounts,label=unconfined),

  However, the above is too lenient and constitutes a privacy leak for
  apps. FindUserById could be used by a malicious app to enumerate
  usernames on multiuser systems and because we can't mediate method
  data with apparmor, the Get() method can be used to obtain any
  information provided by this interface.

  The following can be used to see what can be leaked to a malicious app:
  gdbus introspect --system -d org.freedesktop.Accounts -o 
/org/freedesktop/Accounts/User`id -u phablet`

  This can be solved in a couple of ways:
  1. add whatever information the app is trying to access to a new helper 
service that only exposes things that the app needs. This could be a single 
standalone service, perhaps something from ubuntu-system-settings, that could 
expose any number of things-- the current locale, if the locale changed, if the 
grid units changed, the vibration settings, etc. Since this service wouldn't 
have any sensitive information, you could use standard dbus 
properties/Get()/etc 
  2. add a new dbus API to an existing service such that apparmor rules can 
then be used to allow by method (eg, GetVibration() or something)

  I won't dictate the implementation except to mention that '1' seems
  like something generally useful and I believe that it was something
  the ubuntu-system-settings devs were already looking at for detecting
  locale changes without rebooting.


  Original description
  starting an app in vivid (image 135 on arale currently)

  produces a bunch of dbus denials in syslog ... (there is also a
  /dev/tty one but i think this is just because soemthing tries to write
  an error to console ... so transient)

  http://paste.ubuntu.com/10620834/

To manage notifications about this 

[Touch-packages] [Bug 645404] Re: Support Private PPAs

2016-07-13 Thread Stuart Bishop
Private PPAs are accessed with basic auth using https: URLs to private-
ppa.launchpad.net.

https://stub:secretkeyfromlp@private-
ppa.launchpad.net/teamname/ppaname/ubuntu

It would be great if add-apt-repository accepted this or a similar URL,
use it to retrieve the signing key security and add it as a source.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/645404

Title:
  Support Private PPAs

Status in software-properties package in Ubuntu:
  Confirmed

Bug description:
  Software properties add-apt-repository currently does not support
  adding private PPAs.

  software-properties should connect to the API and observe that it gets
  permission denied trying to read the ppa. Then it can reconnect to the
  API asking for authentication, which will open a browser window where
  you can do the openid ritual. Then using that token it ought to be
  possible for it to get the password etc.

  
  ProblemType: BugDistroRelease: Ubuntu 12.04
  Package: python-software-properties 0.82.4

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/645404/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1536751] Re: Font/text rendering is irregular and not pixel-aligned on low DPI screens

2016-07-13 Thread Daniel d'Andrada
On 13/07/2016 06:45, Daniel van Vugt wrote:
> The second part of the problem is that Unity8 (especially in the
> indicator pulldown) failing to apply a nice hinting setting to make the
> glyph curves aligned to pixel boundaries more often. So a glyph that
> should be represented as one pixel thickness is rendered as two half
> pixels in greyscale, which is ugly.
>
About the indicators: do you see blurry text only *while* you're 
dragging it down or do you see it also afterwards, when its fully extended?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1536751

Title:
  Font/text rendering is irregular and not pixel-aligned on low DPI
  screens

Status in QtMir:
  New
Status in fontconfig package in Ubuntu:
  Incomplete
Status in freetype package in Ubuntu:
  Incomplete
Status in harfbuzz package in Ubuntu:
  Confirmed
Status in qtbase-opensource-src package in Ubuntu:
  Incomplete
Status in ubuntu-font-family-sources package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in unity8 package in Ubuntu:
  Confirmed

Bug description:
  This is a Dell Vostro 3550 laptop with a fresh install of 16.04 and
  unity8 Mir session

  the version of qtdeclarative5-qtmir-plugin is
  0.4.7+16.04.20160104-0ubuntu1

  As you can see from the screenshots the text has low details and, in
  the case of indicators descriptions at the top, almost disappears.

  The text could be fixed by using Text.NativeRendering instead of 
Text.QtRendering for the QML labels on low dpi screens, although text doesn't 
seem to be the only issue here. The icons are definitely lacking detail as well 
(QML Image's smoothing is enabled maybe?).
  Also the dots of the infographic don't look like circles at all, they're 
missing pixels and many of them look like a C more than an O.

  It looks to me like something is setting the wrong resolution, because
  it looks quite bad. But the screenshots are 1366x768 so I think that's
  not the case.

  NOTE: Unity7 looks perfectly fine and detailed

To manage notifications about this bug go to:
https://bugs.launchpad.net/qtmir/+bug/1536751/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602649] [NEW] need an option to disable launcher's autohide on desktop

2016-07-13 Thread dinamic
Public bug reported:

need an option to disable launcher's autohide on desktop
you can't disable autohide now

** Affects: unity8 (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1602649

Title:
  need an option to disable launcher's autohide on desktop

Status in unity8 package in Ubuntu:
  New

Bug description:
  need an option to disable launcher's autohide on desktop
  you can't disable autohide now

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1602649/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1600305] Re: Touch Problem on MX4

2016-07-13 Thread Cédric Bellegarde
I can confirm this issue, happen time to time for me while scrolling in
apps...

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1600305

Title:
  Touch Problem on MX4

Status in Canonical System Image:
  Incomplete
Status in unity8 package in Ubuntu:
  New

Bug description:
  Can't swipe on the left- and rightside

  Devise-Information:
  current build number: 13
  device name: arale
  channel: ubuntu-touch/stable/meizu.en
  last update: 2016-06-02 05:58:37
  version version: 13
  version ubuntu: 20160524.1
  version tag: OTA-11
  version device: 20160331-e143fc2
  version custom: 20160504-975-19-6

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1600305/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602636] [NEW] using 100 % cpu

2016-07-13 Thread AboAlfadl
Public bug reported:

using 100 % cpu

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
Uname: Linux 4.4.0-28-generic x86_64
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Wed Jul 13 13:36:36 2016
DistUpgraded: 2016-04-24 23:10:17,549 DEBUG icon theme changed, re-reading
DistroCodename: xenial
DistroVariant: ubuntu
ExtraDebuggingInterest: I just need to know a workaround
GraphicsCard:
 Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) 
(prog-if 00 [VGA controller])
   Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:3824]
InstallationDate: Installed on 2015-12-14 (212 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: LENOVO 80K6
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-28-generic 
root=UUID=73fd1edc-d964-40d3-a1dd-b1ca4118cce6 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to xenial on 2016-04-24 (79 days ago)
dmi.bios.date: 03/19/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: C2CN17WW(V1.03)
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Lenovo Z51-70
dmi.board.vendor: LENOVO
dmi.board.version: No DPK
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo Z51-70
dmi.modalias: 
dmi:bvnLENOVO:bvrC2CN17WW(V1.03):bd03/19/2015:svnLENOVO:pn80K6:pvrLenovoZ51-70:rvnLENOVO:rnLenovoZ51-70:rvrNoDPK:cvnLENOVO:ct10:cvrLenovoZ51-70:
dmi.product.name: 80K6
dmi.product.version: Lenovo Z51-70
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.2+16.04.20160526-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Wed Jul 13 13:32:18 2016
xserver.configfile: default
xserver.errors:
 
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id5579 
 vendor CMN
xserver.version: 2:1.18.3-1ubuntu2.2

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug compiz-0.9 ubuntu xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1602636

Title:
  using 100 % cpu

Status in xorg package in Ubuntu:
  New

Bug description:
  using 100 % cpu

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
  Uname: Linux 4.4.0-28-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  Date: Wed Jul 13 13:36:36 2016
  DistUpgraded: 2016-04-24 23:10:17,549 DEBUG icon theme changed, re-reading
  DistroCodename: xenial
  DistroVariant: ubuntu
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) 
(prog-if 00 [VGA controller])
 Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:3824]
  InstallationDate: Installed on 2015-12-14 (212 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: LENOVO 80K6
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-28-generic 
root=UUID=73fd1edc-d964-40d3-a1dd-b1ca4118cce6 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to xenial on 2016-04-24 (79 days ago)
  dmi.bios.date: 03/19/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: C2CN17WW(V1.03)
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: Lenovo Z51-70
  dmi.board.vendor: LENOVO
  dmi.board.version: No DPK
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo Z51-70
  dmi.modalias: 
dmi:bvnLENOVO:bvrC2CN17WW(V1.03):bd03/19/2015:svnLENOVO:pn80K6:pvrLenovoZ51-70:rvnLENOVO:rnLenovoZ51-70:rvrNoDPK:cvnLENOVO:ct10:cvrLenovoZ51-70:
 

[Touch-packages] [Bug 1602637] [NEW] using 100 % cpu

2016-07-13 Thread AboAlfadl
Public bug reported:

using 100 % cpu

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
Uname: Linux 4.4.0-28-generic x86_64
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Wed Jul 13 13:36:36 2016
DistUpgraded: 2016-04-24 23:10:17,549 DEBUG icon theme changed, re-reading
DistroCodename: xenial
DistroVariant: ubuntu
ExtraDebuggingInterest: I just need to know a workaround
GraphicsCard:
 Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) 
(prog-if 00 [VGA controller])
   Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:3824]
InstallationDate: Installed on 2015-12-14 (212 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: LENOVO 80K6
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-28-generic 
root=UUID=73fd1edc-d964-40d3-a1dd-b1ca4118cce6 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to xenial on 2016-04-24 (79 days ago)
dmi.bios.date: 03/19/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: C2CN17WW(V1.03)
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Lenovo Z51-70
dmi.board.vendor: LENOVO
dmi.board.version: No DPK
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo Z51-70
dmi.modalias: 
dmi:bvnLENOVO:bvrC2CN17WW(V1.03):bd03/19/2015:svnLENOVO:pn80K6:pvrLenovoZ51-70:rvnLENOVO:rnLenovoZ51-70:rvrNoDPK:cvnLENOVO:ct10:cvrLenovoZ51-70:
dmi.product.name: 80K6
dmi.product.version: Lenovo Z51-70
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.2+16.04.20160526-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Wed Jul 13 13:32:18 2016
xserver.configfile: default
xserver.errors:
 
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id5579 
 vendor CMN
xserver.version: 2:1.18.3-1ubuntu2.2

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug compiz-0.9 ubuntu xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1602637

Title:
  using 100 % cpu

Status in xorg package in Ubuntu:
  New

Bug description:
  using 100 % cpu

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
  Uname: Linux 4.4.0-28-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  Date: Wed Jul 13 13:36:36 2016
  DistUpgraded: 2016-04-24 23:10:17,549 DEBUG icon theme changed, re-reading
  DistroCodename: xenial
  DistroVariant: ubuntu
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) 
(prog-if 00 [VGA controller])
 Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:3824]
  InstallationDate: Installed on 2015-12-14 (212 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: LENOVO 80K6
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-28-generic 
root=UUID=73fd1edc-d964-40d3-a1dd-b1ca4118cce6 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to xenial on 2016-04-24 (79 days ago)
  dmi.bios.date: 03/19/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: C2CN17WW(V1.03)
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: Lenovo Z51-70
  dmi.board.vendor: LENOVO
  dmi.board.version: No DPK
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo Z51-70
  dmi.modalias: 
dmi:bvnLENOVO:bvrC2CN17WW(V1.03):bd03/19/2015:svnLENOVO:pn80K6:pvrLenovoZ51-70:rvnLENOVO:rnLenovoZ51-70:rvrNoDPK:cvnLENOVO:ct10:cvrLenovoZ51-70:
 

[Touch-packages] [Bug 1602606] Re: Totem Movie error message

2016-07-13 Thread Colin Watson
** Package changed: debconf (Ubuntu) => totem (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to debconf in Ubuntu.
https://bugs.launchpad.net/bugs/1602606

Title:
  Totem Movie error message

Status in totem package in Ubuntu:
  New

Bug description:
  Video rendered by Kdenlive - lossless - mpeg-2 - when viewed in Totem
  Movie Player displays an error message 'An error occurred the stream
  is in the wrong format' but it does work in Microsoft Windows (sad to
  say). I'm using Ubuntu 16.04.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/totem/+bug/1602606/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1602628] [NEW] can't drag/move window if it's semi-maximized

2016-07-13 Thread dinamic
Public bug reported:

ubuntu 16.10
can't drag/move window if it's semi-maximized

open random app, semi-miaximize left or rigt (CTRL SUPER + Left or
Right), try to move the window by draggin' it from the title bar.

** Affects: unity8 (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unity8 in Ubuntu.
https://bugs.launchpad.net/bugs/1602628

Title:
  can't drag/move window if it's semi-maximized

Status in unity8 package in Ubuntu:
  New

Bug description:
  ubuntu 16.10
  can't drag/move window if it's semi-maximized

  open random app, semi-miaximize left or rigt (CTRL SUPER + Left or
  Right), try to move the window by draggin' it from the title bar.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1602628/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1383184] Re: Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported

2016-07-13 Thread Carlos Laviola
Still unsupported as of 16.04 and yakkety for my hardware (Dell Latitude
E7270).

The workaround involves replacing
"/lib/firmware/ath10k/QCA6174/hw3.0/board.bin" with a version from
Killer Networking's website, as per:

http://www.killernetworking.com/product-support/knowledge-base/17-linux

The required file is directly available at:

http://www.killernetworking.com/support/K1535_Debian/board.bin

The machine is a Dell Latitude E7270. Here's the lspci output:

01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless 
Network Adapter [168c:003e] (rev 32)
Subsystem: Dell QCA6174 802.11ac Wireless Network Adapter [1028:0310]
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- SERR- 
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1383184

Title:
  Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported

Status in HWE Next:
  Fix Released
Status in HWE Next wily series:
  Fix Released
Status in linux package in Ubuntu:
  Fix Released
Status in linux-firmware package in Ubuntu:
  Fix Released
Status in network-manager package in Ubuntu:
  Invalid
Status in linux source package in Wily:
  Fix Released
Status in linux-firmware source package in Wily:
  Fix Released

Bug description:
  =

  CURRENT STATUS:

  Wily(15.10) could not work with and don't need Adam's dkms package 1.0
  or 1.1

  Wily(15.10) has already fixed the driver part, and the firmware part
  is in progress.

  For now, you guys could use 15.10(purge the ath10k-dkms if you tried
  installing it), and make a copy of
  https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-
  firmware.git/plain/ath10k/QCA6174 into /lib/firmware/ath10k/

  15.10 will work in a week by a simple `apt upgrade`

  Distros before 15.10(lower than 4.2 kernel) please keep using the
  dkms(which will be relocated soon)

  =

  Card detail: Qualcomm Atheros Device [168c:003e] (rev 20)
  Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]

  This is on a fully updated Ubuntu Server 14.04 installation, with the 
ubuntu-desktop environment installed. This happened in order to get the md raid 
drivers for raid0 on my system, as the desktop version doesn't support them.
  ---
  ApportVersion: 2.14.1-0ubuntu3.5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  matanis2333 F pulseaudio
   /dev/snd/controlC0:  matanis2333 F pulseaudio
  CRDA: Error: [Errno 2] No such file or directory
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=1b192ee3-f592-43e9-bdcf-08b91c0aa9b6
  InstallationDate: Installed on 2014-10-16 (3 days ago)
  InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.3)
  IwConfig:
   p2p1  no wireless extensions.

   lono wireless extensions.
  MachineType: Micro-Star International Co., Ltd. GT72 2QE
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
  ProcFB: 0 EFI VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic.efi.signed 
root=UUID=80998dbb-1f89-4eda-be90-25e35e1c0a90 ro
  ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
  RelatedPackageVersions:
   linux-restricted-modules-3.13.0-37-generic N/A
   linux-backports-modules-3.13.0-37-generic  N/A
   linux-firmware 1.127.7
  RfKill:

  Tags:  trusty
  Uname: Linux 3.13.0-37-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 09/15/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: E1781IMS.10D
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: MS-1781
  dmi.board.vendor: Micro-Star International Co., Ltd.
  dmi.board.version: REV:0.C
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrE1781IMS.10D:bd09/15/2014:svnMicro-StarInternationalCo.,Ltd.:pnGT722QE:pvrREV0.C:rvnMicro-StarInternationalCo.,Ltd.:rnMS-1781:rvrREV0.C:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: GT72 2QE
  dmi.product.version: REV:0.C
  dmi.sys.vendor: Micro-Star International Co., Ltd.

  Qualcomm Atheros Device [168c:003e] (rev 20)

  mainline commit d63955b33b3bee45d784ffdfafeb93076c765660

  [6.221281] ath10k_pci :02:00.0: pci irq msi interrupts 1 irq_mode 0 
reset_mode 0
  [6.417386] 

[Touch-packages] [Bug 1536751] Re: Font/text rendering is irregular and not pixel-aligned on low DPI screens

2016-07-13 Thread Andrea Bernabei
@Daniel:

I think font hinting is disabled by default for QML Text elements,
because Text uses distance fields rendering by default (more info at
http://blog.qt.io/blog/2011/07/15/text-rendering-in-the-qml-scene-graph/
)

That was changed in the Label component of our UI toolkit so that it
uses "NativeRendering" when the Grid Unit is <= 10, distance fields
otherwise. See comment #19.

So that could potentially be fixed by using Label instead of the
standard QML Text in indicators/dash/etc

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-ui-toolkit in
Ubuntu.
https://bugs.launchpad.net/bugs/1536751

Title:
  Font/text rendering is irregular and not pixel-aligned on low DPI
  screens

Status in QtMir:
  New
Status in fontconfig package in Ubuntu:
  Incomplete
Status in freetype package in Ubuntu:
  Incomplete
Status in harfbuzz package in Ubuntu:
  Confirmed
Status in qtbase-opensource-src package in Ubuntu:
  Incomplete
Status in ubuntu-font-family-sources package in Ubuntu:
  Confirmed
Status in ubuntu-ui-toolkit package in Ubuntu:
  Confirmed
Status in unity8 package in Ubuntu:
  Confirmed

Bug description:
  This is a Dell Vostro 3550 laptop with a fresh install of 16.04 and
  unity8 Mir session

  the version of qtdeclarative5-qtmir-plugin is
  0.4.7+16.04.20160104-0ubuntu1

  As you can see from the screenshots the text has low details and, in
  the case of indicators descriptions at the top, almost disappears.

  The text could be fixed by using Text.NativeRendering instead of 
Text.QtRendering for the QML labels on low dpi screens, although text doesn't 
seem to be the only issue here. The icons are definitely lacking detail as well 
(QML Image's smoothing is enabled maybe?).
  Also the dots of the infographic don't look like circles at all, they're 
missing pixels and many of them look like a C more than an O.

  It looks to me like something is setting the wrong resolution, because
  it looks quite bad. But the screenshots are 1366x768 so I think that's
  not the case.

  NOTE: Unity7 looks perfectly fine and detailed

To manage notifications about this bug go to:
https://bugs.launchpad.net/qtmir/+bug/1536751/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1578011] Re: Laptop sometimes doesn't detect external monitor when docked

2016-07-13 Thread Christopher M. Penalver
** Changed in: xorg (Ubuntu)
   Status: Incomplete => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1578011

Title:
  Laptop sometimes doesn't detect external monitor when docked

Status in xorg package in Ubuntu:
  New

Bug description:
  Lenovo Thinkpad Yoga S1 sometimes doesn't detect external monitor when
  docked with a Onelink Pro dock. Problem has also occurred on a non-Pro
  OneLink dock.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  .tmp.unity_support_test.0:

  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  BootLog: /dev/sda1: clean, 860723/30769152 files, 38024704/123073521 blocks
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Wed May  4 11:47:20 2016
  DistUpgraded: 2016-04-23 16:11:36,997 DEBUG icon theme changed, re-reading
  DistroCodename: xenial
  DistroVariant: ubuntu
  DkmsStatus:
   virtualbox, 5.0.18, 4.2.0-35-generic, x86_64: installed
   virtualbox, 5.0.18, 4.4.0-21-generic, x86_64: installed
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] 
(rev 0b) (prog-if 00 [VGA controller])
     Subsystem: Lenovo Haswell-ULT Integrated Graphics Controller [17aa:2217]
  InstallationDate: Installed on 2015-12-02 (153 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: LENOVO 20C0S1CWAU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic 
root=UUID=bbf6846f-7622-4638-8e7e-286b6badb71d ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to xenial on 2016-04-23 (10 days ago)
  dmi.bios.date: 01/14/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: GQET48WW (1.28 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20C0S1CWAU
  dmi.board.vendor: LENOVO
  dmi.board.version: 0B98417 PRO
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvrGQET48WW(1.28):bd01/14/2016:svnLENOVO:pn20C0S1CWAU:pvrThinkPadS1Yoga:rvnLENOVO:rn20C0S1CWAU:rvr0B98417PRO:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 20C0S1CWAU
  dmi.product.version: ThinkPad S1 Yoga
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.67-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2
  xserver.bootTime: Wed May  4 08:27:55 2016
  xserver.configfile: default
  xserver.errors:
   Wacom ISDv4 EC Pen stylus: Invalid type 'cursor' for this device.
   Wacom ISDv4 EC Pen stylus: Invalid type 'touch' for this device.
   Wacom ISDv4 EC Pen stylus: Invalid type 'pad' for this device.
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id1079
   vendor LGD
  xserver.version: 2:1.18.3-1ubuntu2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1578011/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1598770] Re: Unity in low-graphics mode has animations and unneeded redraws

2016-07-13 Thread Mateusz Stachowski
I've forced the lowgfx setting with command from comment #9 and the fade
in fade out animations are gone.

But I can't change the launcher icons size. The slider in control center
isn't working. Also The workspace switcher can't be enabled and it
disapeared from launcher. I have it enabled in regular gfx.

This is the version of unity-control-center:
15.04.0+16.04.20160705-0ubuntu1

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to nux in Ubuntu.
https://bugs.launchpad.net/bugs/1598770

Title:
  Unity in low-graphics mode has animations and unneeded redraws

Status in compiz package in Ubuntu:
  Fix Released
Status in nux package in Ubuntu:
  Fix Released
Status in unity package in Ubuntu:
  Fix Released
Status in unity-control-center package in Ubuntu:
  Fix Released
Status in compiz source package in Xenial:
  Fix Committed
Status in nux source package in Xenial:
  Fix Committed
Status in unity source package in Xenial:
  Fix Committed
Status in unity-control-center source package in Xenial:
  Fix Committed

Bug description:
  [Impact]

  When unity is in Low graphics mode (because of software rendering)
  there are still window animations and fade effects which we should get
  rid of.

  
  [Test case]

  This should apply naturally to a (virtual-)machine with no hardware
  acceleration or There are multiple ways to force low-gfx mode:

  1) Add an upstart job such as:

  cat << EOF > ~/.config/upstart/lowgfx.conf
  start on starting unity7

  pre-start script
#initctl set-env --global UNITY_LOW_GFX_MODE=1
initctl set-env --global LIBGL_ALWAYS_SOFTWARE=1
  end script
  EOF 

  
  2) Run unity with:
 COMPIZ_CONFIG_PROFILE=ubuntu-lowgfx

  On login unity should use opaque views (dash, switcher, launcher,
  shortcut-dialogs) with no fading and reduced effects. Windows should
  also use smaller shadows.

  
  [Regression potential]

  Some settings from unity-control-center couldn't be applied to normal
  profile. Low graphics mode might be used as normal one.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1598770/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1591935] Re: [CTA] audio record works for call audio

2016-07-13 Thread John McAleely
re-opening, and moving this bug to clarify status. The general solution
proposed here is the one we wish to use in the future, but we assume
that we can simply disable this feature at lower levels in devices
launched before this bug is fixed.

OEM bug #1597028 covers this.

** Changed in: canonical-devices-system-image
   Status: Fix Committed => Confirmed

** Changed in: canonical-devices-system-image
Milestone: fi => backlog

** Changed in: canonical-devices-system-image
   Importance: Critical => High

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1591935

Title:
  [CTA] audio record works for call audio

Status in Canonical System Image:
  Confirmed
Status in pulseaudio package in Ubuntu:
  Confirmed
Status in trust-store package in Ubuntu:
  Confirmed

Bug description:
  krillin:ubuntu-touch/rc-proposed/bq-aquaris.en,#350

  Install the app 'Recorder' from the Ubuntu Store.

  Confirm it works by opening and making a recording. Note that the app
  requests permission to access the microphone, and you grant this with
  the usual trust store prompt.

  Now move to the phone app, and place a regular phone call. With the
  call active, open Recorder again, and start recording.

  Stop recording after some time, and hang up the call.

  return to the recorder app, and play the recording made during the
  phone call. Audio from both the local microphone and the remote
  handset (Which the user heard during the call) will be present on the
  track.

  It was expected that no audio from the call could be captured by
  applications.

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1591935/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


  1   2   >