[Touch-packages] [Bug 1697153] Re: package libnl-genl-3-200:amd64 3.2.27-1ubuntu0.16.04.1 failed to install/upgrade: Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie sollten es nochmal

2017-06-14 Thread Manfred
I tried all, all command other tried, but this failure remains ... 
I am more USER then SW Engineer ... 
What else can I do?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libnl3 in Ubuntu.
https://bugs.launchpad.net/bugs/1697153

Title:
  package libnl-genl-3-200:amd64 3.2.27-1ubuntu0.16.04.1 failed to
  install/upgrade: Paket ist in einem sehr schlechten inkonsistenten
  Zustand - Sie sollten es  nochmal installieren, bevor Sie die
  Konfiguration versuchen.

Status in libnl3 package in Ubuntu:
  Incomplete

Bug description:
  linux-libc-dev:amd64 (4.4.0-79.100) wird eingerichtet ...
  Fehler traten auf beim Bearbeiten von:
   libnl-genl-3-200:amd64
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libnl-genl-3-200:amd64 3.2.27-1ubuntu0.16.04.1
  ProcVersionSignature: Ubuntu 4.4.0-78.99-generic 4.4.62
  Uname: Linux 4.4.0-78-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.6
  AptOrdering:
   libnl-3-200: Install
   libnl-3-200: Configure
   libnl-genl-3-200: Configure
   libnl-route-3-200: Configure
   NULL: ConfigurePending
  Architecture: amd64
  Date: Sat Jun 10 10:30:10 2017
  Dependencies:
   gcc-6-base 6.0.1-0ubuntu1
   libc6 2.23-0ubuntu7
   libgcc1 1:6.0.1-0ubuntu1
   libnl-3-200 3.2.27-1ubuntu0.16.04.1
  ErrorMessage: Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie 
sollten es  nochmal installieren, bevor Sie die Konfiguration versuchen.
  InstallationDate: Installed on 2016-04-03 (432 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: libnl3
  Title: package libnl-genl-3-200:amd64 3.2.27-1ubuntu0.16.04.1 failed to 
install/upgrade: Paket ist in einem sehr schlechten inkonsistenten Zustand - 
Sie sollten es  nochmal installieren, bevor Sie die Konfiguration versuchen.
  UpgradeStatus: Upgraded to xenial on 2016-11-29 (192 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libnl3/+bug/1697153/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1698056] Re: package libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempti

2017-06-14 Thread Apport retracing service
** Tags removed: need-duplicate-check

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1698056

Title:
  package libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1 failed to
  install/upgrade: package is in a very bad inconsistent state; you
  should  reinstall it before attempting configuration

Status in network-manager package in Ubuntu:
  New

Bug description:
  i was trying to install a software dia from
  https://sourceforge.net/projects/dia-installer/?source=typ_redirect
  when i came across this issue

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1
  ProcVersionSignature: Ubuntu 4.4.0-78.99-generic 4.4.62
  Uname: Linux 4.4.0-78-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  Date: Thu Jun 15 09:43:23 2017
  DuplicateSignature:
   package:libnm-glib-vpn1:amd64:1.2.6-0ubuntu0.16.04.1
   Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
   dpkg: error processing package libnm-glib-vpn1:amd64 (--configure):
package is in a very bad inconsistent state; you should
  ErrorMessage: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2016-06-17 (362 days ago)
  InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 
(20150218.1)
  IpRoute:
   default via 192.168.1.1 dev wlan0  proto static  metric 600 
   169.254.0.0/16 dev wlan0  scope link  metric 1000 
   192.168.1.0/24 dev wlan0  proto kernel  scope link  src 192.168.1.7  metric 
600
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
   WimaxEnabled=true
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: network-manager
  Title: package libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1 failed to 
install/upgrade: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
  UpgradeStatus: Upgraded to xenial on 2016-08-01 (317 days ago)
  nmcli-dev:
   DEVICE  TYPE  STATEDBUS-PATH  
CONNECTION  CON-UUID  CON-PATH  
 
   wlan0   wifi  connected/org/freedesktop/NetworkManager/Devices/0  
DNA-A2136036aba9-f380-4b67-9382-b8ebbb6ecd8e  
/org/freedesktop/NetworkManager/ActiveConnection/2 
   eth0ethernet  unavailable  /org/freedesktop/NetworkManager/Devices/1  -- 
 ----   
  
   lo  loopback  unmanaged/org/freedesktop/NetworkManager/Devices/2  -- 
 ----
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.2.6connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1698056/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1698056] [NEW] package libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attemp

2017-06-14 Thread Amit Ashok
Public bug reported:

i was trying to install a software dia from
https://sourceforge.net/projects/dia-installer/?source=typ_redirect when
i came across this issue

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1
ProcVersionSignature: Ubuntu 4.4.0-78.99-generic 4.4.62
Uname: Linux 4.4.0-78-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
Date: Thu Jun 15 09:43:23 2017
DuplicateSignature:
 package:libnm-glib-vpn1:amd64:1.2.6-0ubuntu0.16.04.1
 Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
 dpkg: error processing package libnm-glib-vpn1:amd64 (--configure):
  package is in a very bad inconsistent state; you should
ErrorMessage: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2016-06-17 (362 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
IpRoute:
 default via 192.168.1.1 dev wlan0  proto static  metric 600 
 169.254.0.0/16 dev wlan0  scope link  metric 1000 
 192.168.1.0/24 dev wlan0  proto kernel  scope link  src 192.168.1.7  metric 600
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt  1.2.20
SourcePackage: network-manager
Title: package libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1 failed to 
install/upgrade: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
UpgradeStatus: Upgraded to xenial on 2016-08-01 (317 days ago)
nmcli-dev:
 DEVICE  TYPE  STATEDBUS-PATH  
CONNECTION  CON-UUID  CON-PATH  
 
 wlan0   wifi  connected/org/freedesktop/NetworkManager/Devices/0  
DNA-A2136036aba9-f380-4b67-9382-b8ebbb6ecd8e  
/org/freedesktop/NetworkManager/ActiveConnection/2 
 eth0ethernet  unavailable  /org/freedesktop/NetworkManager/Devices/1  --   
   ---- 

 lo  loopback  unmanaged/org/freedesktop/NetworkManager/Devices/2  --   
   ----
nmcli-nm:
 RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  WIFI  
   WWAN-HW  WWAN
 running  1.2.6connected  started  full  enabled enabled  
enabled  enabled  enabled

** Affects: network-manager (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1698056

Title:
  package libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1 failed to
  install/upgrade: package is in a very bad inconsistent state; you
  should  reinstall it before attempting configuration

Status in network-manager package in Ubuntu:
  New

Bug description:
  i was trying to install a software dia from
  https://sourceforge.net/projects/dia-installer/?source=typ_redirect
  when i came across this issue

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1
  ProcVersionSignature: Ubuntu 4.4.0-78.99-generic 4.4.62
  Uname: Linux 4.4.0-78-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  Date: Thu Jun 15 09:43:23 2017
  DuplicateSignature:
   package:libnm-glib-vpn1:amd64:1.2.6-0ubuntu0.16.04.1
   Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
   dpkg: error processing package libnm-glib-vpn1:amd64 (--configure):
package is in a very bad inconsistent state; you should
  ErrorMessage: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2016-06-17 (362 days ago)
  InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 
(20150218.1)
  IpRoute:
   default via 192.168.1.1 dev wlan0  proto static  metric 600 
   169.254.0.0/16 dev wlan0  scope link  metric 1000 
   192.168.1.0/24 dev wlan0  proto kernel  scope link  src 192.168.1.7  metric 
600
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
   WimaxEnabled=true
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: network-manager
  Title: package libnm-glib-vpn1:amd64 1.2.6-0ubuntu0.16.04.1 failed to 
install/upgrade: package is in a very bad inconsistent state; you should  
reinstall it before attempting configuration
  UpgradeStatus: Upgraded to xenial on 2016-08-01 (317 days ago)
  nmcli-dev:
   DEVICE  

[Touch-packages] [Bug 1698053] [NEW] package libqt5widgets5:amd64 5.5.1+dfsg-16ubuntu7.5 failed to install/upgrade: El paquete está en un estado grave de inconsistencia - debe reinstalarlo antes de i

2017-06-14 Thread Lautaro Torrico
Public bug reported:

I just logged into my computer and then appeared this buj

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libqt5widgets5:amd64 5.5.1+dfsg-16ubuntu7.5
ProcVersionSignature: Ubuntu 4.8.0-54.57~16.04.1-generic 4.8.17
Uname: Linux 4.8.0-54-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
Date: Thu Jun 15 00:30:28 2017
ErrorMessage: El paquete está en un estado grave de inconsistencia - debe 
reinstalarlo  antes de intentar su configuración.
InstallationDate: Installed on 2017-05-12 (33 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 
(20170215.2)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt  1.2.20
SourcePackage: qtbase-opensource-src
Title: package libqt5widgets5:amd64 5.5.1+dfsg-16ubuntu7.5 failed to 
install/upgrade: El paquete está en un estado grave de inconsistencia - debe 
reinstalarlo  antes de intentar su configuración.
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: qtbase-opensource-src (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1698053

Title:
  package libqt5widgets5:amd64 5.5.1+dfsg-16ubuntu7.5 failed to
  install/upgrade: El paquete está en un estado grave de inconsistencia
  - debe reinstalarlo  antes de intentar su configuración.

Status in qtbase-opensource-src package in Ubuntu:
  New

Bug description:
  I just logged into my computer and then appeared this buj

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libqt5widgets5:amd64 5.5.1+dfsg-16ubuntu7.5
  ProcVersionSignature: Ubuntu 4.8.0-54.57~16.04.1-generic 4.8.17
  Uname: Linux 4.8.0-54-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.1-0ubuntu2.6
  Architecture: amd64
  Date: Thu Jun 15 00:30:28 2017
  ErrorMessage: El paquete está en un estado grave de inconsistencia - debe 
reinstalarlo  antes de intentar su configuración.
  InstallationDate: Installed on 2017-05-12 (33 days ago)
  InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 
(20170215.2)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: qtbase-opensource-src
  Title: package libqt5widgets5:amd64 5.5.1+dfsg-16ubuntu7.5 failed to 
install/upgrade: El paquete está en un estado grave de inconsistencia - debe 
reinstalarlo  antes de intentar su configuración.
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1698053/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1698050] [NEW] Disabled arrow buttons in Nautilus header bar are too dark

2017-06-14 Thread Daniel van Vugt
Public bug reported:

Disabled arrow buttons in Nautilus header bar are too dark, under Gnome
Shell.

They don't look disabled as much as they look like a rendering bug.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: light-themes 16.10+17.10.20170518-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
Uname: Linux 4.10.0-22-generic x86_64
ApportVersion: 2.20.5-0ubuntu4
Architecture: amd64
Date: Thu Jun 15 11:41:54 2017
InstallationDate: Installed on 2017-05-03 (42 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170502)
PackageArchitecture: all
SourcePackage: ubuntu-themes
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: ubuntu-themes (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug artful visual-quality

** Tags added: visual-quality

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-themes in Ubuntu.
https://bugs.launchpad.net/bugs/1698050

Title:
  Disabled arrow buttons in Nautilus header bar are too dark

Status in ubuntu-themes package in Ubuntu:
  New

Bug description:
  Disabled arrow buttons in Nautilus header bar are too dark, under
  Gnome Shell.

  They don't look disabled as much as they look like a rendering bug.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: light-themes 16.10+17.10.20170518-0ubuntu1
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Thu Jun 15 11:41:54 2017
  InstallationDate: Installed on 2017-05-03 (42 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170502)
  PackageArchitecture: all
  SourcePackage: ubuntu-themes
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-themes/+bug/1698050/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1574120] Re: Notebook doesn't suspend when lid is closed after update to 16.04

2017-06-14 Thread Kai-Heng Feng
I think there are two ongoing patches are going to address this, maybe
worth a try:

One is from Benjamin Tissoires:
https://patchwork.kernel.org/patch/9760869/

Another one is from Lv Zheng:
https://patchwork.kernel.org/patch/9771121/

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1574120

Title:
  Notebook doesn't suspend when lid is closed after update to 16.04

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  My notebook does not suspend after upgrading from 15.10 to 16.04.

  According to system settings the notebook should suspend when lid is
  closed but actually this does not happen. Instead it continues to run
  as if nothing had happened.

  With the previous versions of ubuntu (14.04-15.10) everything worked
  fine.

  My System: HP Pavilion dv7.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: acpi (not installed)
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sat Apr 23 23:11:15 2016
  InstallationDate: Installed on 2015-10-29 (176 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  SourcePackage: acpi
  UpgradeStatus: Upgraded to xenial on 2016-04-22 (1 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1574120/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1686189] Re: External monitor connecting problem on Intel graphics card

2017-06-14 Thread Kai-Heng Feng
Hi, please try Linux kernel version 4.4.71, 4.8, 4.9 at [1] so I can
know the what exact patch series fixed the issue.

My guess is that backported lspcon feature broke some machine. But since
4.10 works, we need to backport more patches to ours 4.4 Linux.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1686189

Title:
  External monitor connecting problem on Intel graphics card

Status in linux package in Ubuntu:
  Confirmed
Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  I am facing a problem with Intel Graphics driver. I have external
  monitor and in display settings the second monitor is detecting but
  it's not working, so could you email me a solution.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  Uname: Linux 4.4.25-040425-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Tue Apr 25 21:45:16 2017
  DistUpgraded: 2017-04-25 21:07:40,819 DEBUG icon theme changed, re-reading
  DistroCodename: xenial
  DistroVariant: ubuntu
  DkmsStatus: i915-4.6.3-4.4.0, 1, 4.4.0-75-generic, x86_64: installed
  GraphicsCard:
   Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] 
(rev 09) (prog-if 00 [VGA controller])
 Subsystem: Dell Haswell-ULT Integrated Graphics Controller [1028:05e9]
  InstallationDate: Installed on 2017-04-25 (0 days ago)
  InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
  MachineType: Dell Inc. Inspiron 3537
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.25-040425-generic 
root=UUID=3914e6d5-5c87-4816-8043-776ef4184d29 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to xenial on 2017-04-25 (0 days ago)
  dmi.bios.date: 04/30/2014
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A08
  dmi.board.name: 03JPPR
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: A08
  dmi.modalias: 
dmi:bvnDellInc.:bvrA08:bd04/30/2014:svnDellInc.:pnInspiron3537:pvrA08:rvnDellInc.:rn03JPPR:rvrA00:cvnDellInc.:ct8:cvrA08:
  dmi.product.name: Inspiron 3537
  dmi.product.version: A08
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.70-1~ubuntu16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.6-0ubuntu0.16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.6-0ubuntu0.16.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1.2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2
  xserver.bootTime: Tue Apr 25 21:37:24 2017
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id   17900 
   vendor AUO
  xserver.version: 2:1.18.4-0ubuntu0.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1686189/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1574120] Re: Notebook doesn't suspend when lid is closed after update to 16.04

2017-06-14 Thread caltinay
I have the same issue on a HP ZBook G3 running Debian with the 4.11 kernel from 
experimental and after reading comment #103 I tried
rmmod hp_wmi
and this fixed it!

So hopefully an updated kernel will fix it properly with that driver
loaded.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1574120

Title:
  Notebook doesn't suspend when lid is closed after update to 16.04

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  My notebook does not suspend after upgrading from 15.10 to 16.04.

  According to system settings the notebook should suspend when lid is
  closed but actually this does not happen. Instead it continues to run
  as if nothing had happened.

  With the previous versions of ubuntu (14.04-15.10) everything worked
  fine.

  My System: HP Pavilion dv7.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: acpi (not installed)
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sat Apr 23 23:11:15 2016
  InstallationDate: Installed on 2015-10-29 (176 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  SourcePackage: acpi
  UpgradeStatus: Upgraded to xenial on 2016-04-22 (1 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1574120/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1698038] [NEW] package libjpeg-turbo8:i386 1.4.2-0ubuntu3 failed to install/upgrade: pacote libjpeg-turbo8:i386 não está pronto para configuração não posso configurar (estado at

2017-06-14 Thread Flávio Alberto dos Santos Costa
Public bug reported:

I boot the computer and this happened.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libjpeg-turbo8:i386 1.4.2-0ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
Uname: Linux 4.4.0-79-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.6
AptOrdering:
 ttf-mscorefonts-installer: Install
 libjpeg-turbo8: Configure
 ttf-mscorefonts-installer: Configure
 NULL: ConfigurePending
Architecture: amd64
Date: Wed Jun 14 14:34:05 2017
Dependencies:
 gcc-6-base 6.0.1-0ubuntu1
 libc6 2.23-0ubuntu7
 libgcc1 1:6.0.1-0ubuntu1
 multiarch-support 2.23-0ubuntu7
ErrorMessage: pacote libjpeg-turbo8:i386 não está pronto para configuração  não 
posso configurar (estado atual 'half-installed')
InstallationDate: Installed on 2017-06-10 (4 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: i386
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt  1.2.20
SourcePackage: libjpeg-turbo
Title: package libjpeg-turbo8:i386 1.4.2-0ubuntu3 failed to install/upgrade: 
pacote libjpeg-turbo8:i386 não está pronto para configuração  não posso 
configurar (estado atual 'half-installed')
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: libjpeg-turbo (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-package i386 xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libjpeg-turbo in Ubuntu.
https://bugs.launchpad.net/bugs/1698038

Title:
  package libjpeg-turbo8:i386 1.4.2-0ubuntu3 failed to install/upgrade:
  pacote libjpeg-turbo8:i386 não está pronto para configuração  não
  posso configurar (estado atual 'half-installed')

Status in libjpeg-turbo package in Ubuntu:
  New

Bug description:
  I boot the computer and this happened.

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libjpeg-turbo8:i386 1.4.2-0ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2.6
  AptOrdering:
   ttf-mscorefonts-installer: Install
   libjpeg-turbo8: Configure
   ttf-mscorefonts-installer: Configure
   NULL: ConfigurePending
  Architecture: amd64
  Date: Wed Jun 14 14:34:05 2017
  Dependencies:
   gcc-6-base 6.0.1-0ubuntu1
   libc6 2.23-0ubuntu7
   libgcc1 1:6.0.1-0ubuntu1
   multiarch-support 2.23-0ubuntu7
  ErrorMessage: pacote libjpeg-turbo8:i386 não está pronto para configuração  
não posso configurar (estado atual 'half-installed')
  InstallationDate: Installed on 2017-06-10 (4 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  PackageArchitecture: i386
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: libjpeg-turbo
  Title: package libjpeg-turbo8:i386 1.4.2-0ubuntu3 failed to install/upgrade: 
pacote libjpeg-turbo8:i386 não está pronto para configuração  não posso 
configurar (estado atual 'half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libjpeg-turbo/+bug/1698038/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1667113] Re: System users appears in Ligthdm and user switcher (Accountsservice has no filter for shell types)

2017-06-14 Thread Gabriel Cotnoir
Note to lightdm users
You can manually tweak /etc/lightdm/users.conf
Add libvirt-qemu to the hidden-users

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1667113

Title:
  System users appears in Ligthdm and user switcher (Accountsservice has
  no filter for shell types)

Status in accountsservice package in Ubuntu:
  Confirmed
Status in base-passwd package in Ubuntu:
  Invalid
Status in ceph package in Ubuntu:
  Confirmed
Status in ifmail package in Ubuntu:
  Confirmed
Status in libvirt package in Ubuntu:
  Confirmed
Status in lightdm package in Ubuntu:
  Confirmed
Status in netqmail package in Ubuntu:
  Confirmed
Status in sddm package in Ubuntu:
  Fix Released

Bug description:
  "Technical" user libvirt Qemu appears in the list of user in Ligthdm,
  among the real regular users. It probably shouldn't

  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: libvirt-bin 2.5.0-3ubuntu2
  ProcVersionSignature: Ubuntu 4.9.0-15.16-generic 4.9.5
  Uname: Linux 4.9.0-15-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
  ApportVersion: 2.20.4-0ubuntu2
  Architecture: amd64
  CurrentDesktop: Unity:Unity7
  Date: Wed Feb 22 22:09:24 2017
  InstallationDate: Installed on 2017-02-01 (21 days ago)
  InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170201)
  KernLog:
   
  SourcePackage: libvirt
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/accountsservice/+bug/1667113/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697165] Re: no tengo centro de sotfware en obuntu 17.04

2017-06-14 Thread Seth Arnold
Thanks for taking the time to report this bug and helping to make Ubuntu
better. We appreciate the difficulties you are facing, but this appears
to be a "regular" (non-security) bug.  I have unmarked it as a security
issue since this bug does not show evidence of allowing attackers to
cross privilege boundaries nor directly cause loss of data/privacy.
Please feel free to report any other bugs you may find.

** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1697165

Title:
  no tengo centro de sotfware en obuntu 17.04

Status in xorg package in Ubuntu:
  New

Bug description:
  no tengo centro de software en obuntu 17.04

  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: xorg 1:7.7+16ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.4-0ubuntu4.1
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  Date: Sat Jun 10 13:52:07 2017
  DistUpgraded: 2017-06-10 12:16:26,276 ERROR got error from PostInstallScript 
./xorg_fix_proprietary.py (g-exec-error-quark: Falló al ejecutar el proceso 
hijo «./xorg_fix_proprietary.py» (No such file or directory) (8))
  DistroCodename: zesty
  DistroVariant: ubuntu
  GraphicsCard:
   Intel Corporation 4th Generation Core Processor Family Integrated Graphics 
Controller [8086:041e] (rev 06) (prog-if 00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. 4th Generation Core Processor Family 
Integrated Graphics Controller [1043:8534]
  InstallationDate: Installed on 2017-03-02 (100 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.2)
  MachineType: ASUS All Series
  ProcEnviron:
   LANGUAGE=es_ES
   PATH=(custom, no user)
   LANG=es_ES.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=UUID=7c5fca2d-61df-4650-9436-ca8bf2a4b816 ro splash quiet
  SourcePackage: xorg
  UpgradeStatus: Upgraded to zesty on 2017-06-10 (0 days ago)
  dmi.bios.date: 04/29/2016
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0501
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: H81M-P PLUS
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr0501:bd04/29/2016:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnH81M-PPLUS:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: All Series
  dmi.product.version: System Version
  dmi.sys.vendor: ASUS
  version.compiz: compiz 1:0.9.13.1+17.04.20170109-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.76-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.3-1ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.3-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.3-1ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.9.0-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20170309-0ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.14-0ubuntu1
  xserver.bootTime: Sat Jun 10 13:44:03 2017
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.19.3-1ubuntu1
  xserver.video_driver: modeset

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1697165/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1696930] Re: package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 [modified: lib/x86_64-linux-gnu/libcrypto.so.1.0.0 lib/x86_64-linux-gnu/libssl.so.1.0.0 usr/lib/x86_64-linux-gnu/openssl-

2017-06-14 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: openssl (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1696930

Title:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 [modified: lib/x86_64
  -linux-gnu/libcrypto.so.1.0.0 lib/x86_64-linux-gnu/libssl.so.1.0.0
  usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libaep.so
  usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libatalla.so
  usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libcapi.so
  usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libchil.so
  usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libcswift.so
  usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libgmp.so
  usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libpadlock.so
  usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libsureware.so] failed
  to install/upgrade: package libssl1.0.0:amd64 is not ready for
  configuration  cannot configure (current status 'half-installed')

Status in openssl package in Ubuntu:
  Confirmed

Bug description:
  debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by 
another process: Resource temporarily unavailable
  dpkg: error processing package libssl1.0.0:amd64 (--configure):
   package libssl1.0.0:amd64 is not ready for configuration
   cannot configure (current status 'half-installed')
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 [modified: 
lib/x86_64-linux-gnu/libcrypto.so.1.0.0 lib/x86_64-linux-gnu/libssl.so.1.0.0 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libaep.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libatalla.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libcapi.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libchil.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libcswift.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libgmp.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libpadlock.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libsureware.so]
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.1-0ubuntu2.6
  AptOrdering:
   libssl1.0.0: Configure
   NULL: ConfigurePending
  Architecture: amd64
  Date: Fri Jun  9 12:29:49 2017
  DpkgTerminalLog:
   dpkg: error processing package libssl1.0.0:amd64 (--configure):
package libssl1.0.0:amd64 is not ready for configuration
cannot configure (current status 'half-installed')
  ErrorMessage: package libssl1.0.0:amd64 is not ready for configuration  
cannot configure (current status 'half-installed')
  InstallationDate: Installed on 2017-06-05 (3 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: openssl
  Title: package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 [modified: 
lib/x86_64-linux-gnu/libcrypto.so.1.0.0 lib/x86_64-linux-gnu/libssl.so.1.0.0 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libaep.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libatalla.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libcapi.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libchil.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libcswift.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libgmp.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libpadlock.so 
usr/lib/x86_64-linux-gnu/openssl-1.0.0/engines/libsureware.so] failed to 
install/upgrade: package libssl1.0.0:amd64 is not ready for configuration  
cannot configure (current status 'half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1696930/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1647638] Re: W: APT had planned for dpkg to do more than it reported back

2017-06-14 Thread Tiago Stürmer Daitx
Small correction to get the right zz-fail file (needs to escape $),
please run:

$ sudo tee /etc/kernel/postinst.d/zz-fail 

[Touch-packages] [Bug 1647638] Re: W: APT had planned for dpkg to do more than it reported back

2017-06-14 Thread Tiago Stürmer Daitx
I could replicate it on my system, I got the following message on the
tests:

W: APT had planned for dpkg to do more than it reported back (0 vs 4).
   Affected packages: linux-image-4.10.0-22-generic:amd64


== Reproducer ==

$ sudo tee /etc/kernel/postinst.d/zz-fail 

[Touch-packages] [Bug 1667825] Re: Requesting Cherry Pick: dns/resolved: consider configuration from unmanaged devices

2017-06-14 Thread gpothier
The problem persists in 17.10 as of today.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1667825

Title:
  Requesting Cherry Pick: dns/resolved: consider configuration from
  unmanaged devices

Status in network-manager package in Ubuntu:
  Confirmed

Bug description:
  Please forgive me if this is not the proper channel to request a
  cherry-pick. I'm currently experiencing this issue on Ubuntu 17.04
  using the network-manager-l2tp plugin.

  The Network Manager team recently patched an issue that breaks DNS
  resolution for certain VPN connections due to the PPP/TUN interface
  being unmanaged.

  The patch that corrects this is
  913896721d7c7c65f7e4a24e8c0d9d275a9dfbaa.

  For more information, please see the upstream bug report:
  https://bugzilla.gnome.org/show_bug.cgi?id=779087

  Please let me know if I need to submit additional information or if
  this is the incorrect channel to request this.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1667825/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1696970] Re: softlockup DoS causes systemd-journald.service to abort with SIGABORT

2017-06-14 Thread Steve Langasek
The watchdogs are by design.  The unclean journal may not be.  OTOH if
this only happens with the ephemeral journal in /run, the impact is
minor.  We should check whether the unclean journal problem is
reproducible with /var/log/journal.

** Also affects: systemd (Ubuntu Artful)
   Importance: High
   Status: New

** Tags removed: rls-aa-incoming

** Changed in: systemd (Ubuntu Artful)
 Assignee: (unassigned) => Canonical Foundations Team 
(canonical-foundations)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1696970

Title:
  softlockup DoS causes systemd-journald.service to abort with SIGABORT

Status in systemd package in Ubuntu:
  New
Status in systemd source package in Artful:
  New

Bug description:
  I was running the new stress-ng softlockup stressor and observed that
  systemd-journald gets killed with an abort and this corrupts the
  systemd journal.

  How to reproduce:

  git clone git://kernel.ubuntu.com/cking/stress-ng
  cd stress-ng
  make clean; make

  sudo ./stress-ng --softlockup 0 -t 360 -v

  ..and wait for 360 seconds.  dmesg shows the following, 100%
  reproduceable:

  
  [  875.310331] systemd[1]: systemd-timesyncd.service: Watchdog timeout (limit 
3min)!
  [  875.310740] systemd[1]: systemd-timesyncd.service: Killing process 574 
(systemd-timesyn) with signal SIGABRT.
  [  875.327289] systemd[1]: systemd-timesyncd.service: Main process exited, 
code=killed, status=6/ABRT
  [  875.327666] systemd[1]: systemd-timesyncd.service: Unit entered failed 
state.
  [  875.327686] systemd[1]: systemd-timesyncd.service: Failed with result 
'watchdog'.
  [  875.327917] systemd[1]: systemd-timesyncd.service: Service has no hold-off 
time, scheduling restart.
  [  875.327954] systemd[1]: Stopped Network Time Synchronization.
  [  875.328845] systemd[1]: Starting Network Time Synchronization...
  [  875.525071] systemd[1]: Started Network Time Synchronization.
  [  875.539619] systemd[1]: systemd-journald.service: Main process exited, 
code=dumped, status=6/ABRT
  [  875.544257] systemd-journald[5214]: File 
/run/log/journal/440e485e550040e3b93b66b2faae8525/system.journal corrupted or 
uncleanly shut down, renaming and replacing.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1696970/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 264691] Re: Please add NM option for connecting to L2TP IPSEC VPN

2017-06-14 Thread Douglas Kosovic
network-manager-l2tp 1.2.6-2 was accepted into Debian sid :

   https://tracker.debian.org/pkg/network-manager-l2tp

The Debian package was automatically added to Ubuntu artful (17.10).

I've requested an Ubuntu backport of network-manager-l2tp from artful to
xenial (16.04) which includes intermediate zesty (17.04) and yakkety
(16:10) releases :

   https://bugs.launchpad.net/xenial-backports/+bug/1697934

Please vote for the backport by clicking the "this bug affects me" link
in the backport request.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/264691

Title:
  Please add NM option for connecting to L2TP IPSEC VPN

Status in NetworkManager:
  Unknown
Status in network-manager package in Ubuntu:
  Confirmed
Status in network-manager package in Debian:
  Invalid

Bug description:
  Binary package hint: network-manager

  Missing feature:

  You cannot connect to a (Microsoft) L2TP IPSEC VPN with Network
  Manager.

  The server I want to connect to expects a login / password and a PSK.

  When you do a connection in XP you can see the following details on a
  connection:

  Device name: L2TP
  Server type: PPP
  Authentication: MS CHAP v2
  IPSEC Encryption: IPSEC ESP 3DES
  Compression: MPPC

To manage notifications about this bug go to:
https://bugs.launchpad.net/network-manager/+bug/264691/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 759394] Re: can not umount rbind mounts

2017-06-14 Thread Ivan Zakharyaschev
This worked for me correctly --
https://unix.stackexchange.com/a/264488/4319 :

mount --rbind /dev /mnt/test
mount --make-rslave /mnt/test
umount -R /mnt/test

It was important to have the two first commands as two separate
commands: do not combine --rbind and --make-rslave in one invocation of
mount.

Without --make-rslave , the behavior was unwanted (and not successful):

* umount -l would affect the original old mountpoints, too,
* and umount -R would be affected by the busy (open) files under the original 
old mountpoints. (Very unexpected...)

** Changed in: util-linux (Ubuntu)
   Status: Confirmed => Opinion

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to util-linux in Ubuntu.
https://bugs.launchpad.net/bugs/759394

Title:
  can not umount rbind mounts

Status in util-linux package in Ubuntu:
  Opinion

Bug description:
  Binary package hint: util-linux

  mkdir /mnt/dev
  mount --rbind /dev /mnt/dev
  umount /mnt/dev

  The umount fails because of the sub mounts that the recursive bind
  also bind mounted under /mnt/dev, which you have to remove manually
  first.  When you mount with --rbind, umount should be able to reverse
  the process, unmounting all recursively bound mounts.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/759394/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1695928] Re: Please remove obsolete UOA packages

2017-06-14 Thread Jeremy Bicha
** Description changed:

  Ubuntu Online Accounts is no longer maintained. There is an alternative,
  GNOME Online Accounts for the GNOME desktop.
  
  Also, Unity's Online Accounts settings panel does not currently work
  without oxide-qt but oxide-qt will be removed from Ubuntu 17.10.
  
  Please remove these source packages and their binaries:
- -
+ =
+ 
+ Phase 1
+ ---
  gnome-control-center-signon
  account-plugins
  account-plugin-fitbit
  account-polld
  pay-service
- qt-purchasing-opensource-src
+ qtpurchasing-opensource-src
  storage-provider-webdav
  sync-monitor
  ubuntuone-credentials
  ubuntu-push
  unity-china-photo-scope
  unity-scope-gdrive
  
+ Phase 2
+ ---
  ubuntu-system-settings-online-accounts
  online-accounts-api
  storage-framework
  keeper
  mcloud
- 
  address-book-app
  address-book-service
  dialer-app
  messaging-app
  telephony-service
  tone-generator
  ubuntu-system-settings
  buteo-sync-plugins-contacts-google
  camera-app
  indicator-transfer
  indicator-transfer-buteo
  libertine
  ubuntu-experience-tests
  unity-scopes-shell
  unity8
  
  Other Notes
  ---
  The Shotwell suggests have been dropped in artful-proposed. Shotwell is 
temporarily stuck in -proposed because of an autopkgtest issue 
https://bugzilla.gnome.org/781802
  
  Kubuntu still uses signon-ui.
  
  See also https://code.launchpad.net/~xnox/ubuntu-
  seeds/unity8-removals/+merge/323615

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gnome-control-center-
signon in Ubuntu.
https://bugs.launchpad.net/bugs/1695928

Title:
  Please remove obsolete UOA packages

Status in gnome-control-center-signon package in Ubuntu:
  New

Bug description:
  Ubuntu Online Accounts is no longer maintained. There is an
  alternative, GNOME Online Accounts for the GNOME desktop.

  Also, Unity's Online Accounts settings panel does not currently work
  without oxide-qt but oxide-qt will be removed from Ubuntu 17.10.

  Please remove these source packages and their binaries:
  =

  Phase 1
  ---
  gnome-control-center-signon
  account-plugins
  account-plugin-fitbit
  account-polld
  pay-service
  qtpurchasing-opensource-src
  storage-provider-webdav
  sync-monitor
  ubuntuone-credentials
  ubuntu-push
  unity-china-photo-scope
  unity-scope-gdrive

  Phase 2
  ---
  ubuntu-system-settings-online-accounts
  online-accounts-api
  storage-framework
  keeper
  mcloud
  address-book-app
  address-book-service
  dialer-app
  messaging-app
  telephony-service
  tone-generator
  ubuntu-system-settings
  buteo-sync-plugins-contacts-google
  camera-app
  indicator-transfer
  indicator-transfer-buteo
  libertine
  ubuntu-experience-tests
  unity-scopes-shell
  unity8

  Other Notes
  ---
  The Shotwell suggests have been dropped in artful-proposed. Shotwell is 
temporarily stuck in -proposed because of an autopkgtest issue 
https://bugzilla.gnome.org/781802

  Kubuntu still uses signon-ui.

  See also https://code.launchpad.net/~xnox/ubuntu-
  seeds/unity8-removals/+merge/323615

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center-signon/+bug/1695928/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1698017] [NEW] package linux-image-extra-4.10.0-22-generic 4.10.0-22.24 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1

2017-06-14 Thread ravi
Public bug reported:

crash on startup

ProblemType: Package
DistroRelease: Ubuntu 17.04
Package: linux-image-extra-4.10.0-22-generic 4.10.0-22.24
ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
Uname: Linux 4.10.0-22-generic x86_64
ApportVersion: 2.20.4-0ubuntu4.1
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  ravi   1848 F pulseaudio
 /dev/snd/controlC1:  ravi   1848 F pulseaudio
Date: Tue Jun 13 19:13:12 2017
ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
InstallationDate: Installed on 2016-11-11 (215 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
IwConfig:
 lono wireless extensions.
 
 enp2s0no wireless extensions.
MachineType: Gigabyte Technology Co., Ltd. GA-MA785GM-US2H
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=UUID=7ad6d36b-9514-4922-990a-04505a500d65 ro acpi=off quiet splash 
vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 2.02~beta3-4ubuntu2
RfKill:
 
SourcePackage: initramfs-tools
Title: package linux-image-extra-4.10.0-22-generic 4.10.0-22.24 failed to 
install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
UpgradeStatus: Upgraded to zesty on 2017-04-14 (61 days ago)
dmi.bios.date: 05/17/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F11
dmi.board.name: GA-MA785GM-US2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrF11:bd05/17/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GM-US2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GM-US2H:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA785GM-US2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package zesty

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1698017

Title:
  package linux-image-extra-4.10.0-22-generic 4.10.0-22.24 failed to
  install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools
  exited with return code 1

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  crash on startup

  ProblemType: Package
  DistroRelease: Ubuntu 17.04
  Package: linux-image-extra-4.10.0-22-generic 4.10.0-22.24
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.4-0ubuntu4.1
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ravi   1848 F pulseaudio
   /dev/snd/controlC1:  ravi   1848 F pulseaudio
  Date: Tue Jun 13 19:13:12 2017
  ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
  InstallationDate: Installed on 2016-11-11 (215 days ago)
  InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
  IwConfig:
   lono wireless extensions.
   
   enp2s0no wireless extensions.
  MachineType: Gigabyte Technology Co., Ltd. GA-MA785GM-US2H
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=UUID=7ad6d36b-9514-4922-990a-04505a500d65 ro acpi=off quiet splash 
vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc 2.02~beta3-4ubuntu2
  RfKill:
   
  SourcePackage: initramfs-tools
  Title: package linux-image-extra-4.10.0-22-generic 4.10.0-22.24 failed to 
install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
  UpgradeStatus: Upgraded to zesty on 2017-04-14 (61 days ago)
  dmi.bios.date: 05/17/2010
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F11
  dmi.board.name: GA-MA785GM-US2H
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrF11:bd05/17/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GM-US2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GM-US2H:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: GA-MA785GM-US2H
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1698017/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : 

[Touch-packages] [Bug 1698017] Re: package linux-image-extra-4.10.0-22-generic 4.10.0-22.24 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1

2017-06-14 Thread Apport retracing service
** Tags removed: need-duplicate-check

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1698017

Title:
  package linux-image-extra-4.10.0-22-generic 4.10.0-22.24 failed to
  install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools
  exited with return code 1

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  crash on startup

  ProblemType: Package
  DistroRelease: Ubuntu 17.04
  Package: linux-image-extra-4.10.0-22-generic 4.10.0-22.24
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.4-0ubuntu4.1
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ravi   1848 F pulseaudio
   /dev/snd/controlC1:  ravi   1848 F pulseaudio
  Date: Tue Jun 13 19:13:12 2017
  ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
  InstallationDate: Installed on 2016-11-11 (215 days ago)
  InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
  IwConfig:
   lono wireless extensions.
   
   enp2s0no wireless extensions.
  MachineType: Gigabyte Technology Co., Ltd. GA-MA785GM-US2H
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=UUID=7ad6d36b-9514-4922-990a-04505a500d65 ro acpi=off quiet splash 
vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc 2.02~beta3-4ubuntu2
  RfKill:
   
  SourcePackage: initramfs-tools
  Title: package linux-image-extra-4.10.0-22-generic 4.10.0-22.24 failed to 
install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with 
return code 1
  UpgradeStatus: Upgraded to zesty on 2017-04-14 (61 days ago)
  dmi.bios.date: 05/17/2010
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F11
  dmi.board.name: GA-MA785GM-US2H
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: 
dmi:bvnAwardSoftwareInternational,Inc.:bvrF11:bd05/17/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GM-US2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GM-US2H:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: GA-MA785GM-US2H
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1698017/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1574667] Re: Mouse pointer occasionally jumps to the bottom-left corner

2017-06-14 Thread Michael Verrilli
I figured out the issue with my right-click. Just documenting in case
anyone else does the libinput swap. It defaulted my settings with Two-
finger emulation enabled. Just disabled it an all is good. Thanks
@juanhm.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1574667

Title:
  Mouse pointer occasionally jumps to the bottom-left corner

Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  Sometimes the mouse pointer jumps directly to the bottom-left corner
  of the screen, which results in opening the trash window when
  clicking.

  This seems to be related: https://ubuntu-mate.community/t/mouse-
  pointer-jumps-on-clicking-touchpad/2932.

  Thanks,
  MZ

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  BootLog: /dev/sda6: clean, 276587/40779776 files, 15261626/163117056 blocks
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Mon Apr 25 15:55:54 2016
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation Sky Lake Integrated Graphics [8086:1916] (rev 07) (prog-if 
00 [VGA controller])
 Subsystem: Dell Skylake Integrated Graphics [1028:06b2]
  InstallationDate: Installed on 2016-04-23 (2 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 8087:07dc Intel Corp. 
   Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card 
Reader Controller
   Bus 001 Device 002: ID 064e:920b Suyin Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. Inspiron 5559
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic.efi.signed 
root=UUID=c5bc0a1d-3fe9-4ae5-81e9-de7d141b419c ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/21/2015
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.1.5
  dmi.board.name: 06CMH7
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.1.5:bd12/21/2015:svnDellInc.:pnInspiron5559:pvr:rvnDellInc.:rn06CMH7:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: Inspiron 5559
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.67-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2
  xserver.bootTime: Mon Apr 25 13:43:44 2016
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id1156 
   vendor LGD
  xserver.version: 2:1.18.3-1ubuntu2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1574667/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697287] Re: package isc-dhcp-client 4.3.3-5ubuntu12 [modified: usr/share/doc/isc-dhcp-client/changelog.Debian.gz] failed to install/upgrade: el paquete isc-dhcp-client no está l

2017-06-14 Thread Ubuntu Foundations Team Bug Bot
** Attachment removed: "DuplicateSignature.txt"
   
https://bugs.launchpad.net/bugs/1697287/+attachment/4894084/+files/DuplicateSignature.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1697287

Title:
  package isc-dhcp-client 4.3.3-5ubuntu12 [modified: usr/share/doc/isc-
  dhcp-client/changelog.Debian.gz] failed to install/upgrade: el paquete
  isc-dhcp-client no está listo para configurarse  no se puede
  configurar (estado actual `half-installed')

Status in isc-dhcp package in Ubuntu:
  New

Bug description:
  rr

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: isc-dhcp-client 4.3.3-5ubuntu12 [modified: 
usr/share/doc/isc-dhcp-client/changelog.Debian.gz]
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2.6
  AptOrdering:
   linux-image-extra-4.4.0-77-generic: Remove
   linux-image-4.4.0-77-generic: Remove
   isc-dhcp-client: Configure
   NULL: ConfigurePending
  Architecture: amd64
  Date: Sun Jun 11 09:10:44 2017
  DhclientLeases:
   
  ErrorMessage: el paquete isc-dhcp-client no está listo para configurarse  no 
se puede configurar (estado actual `half-installed')
  InstallationDate: Installed on 2016-09-23 (260 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-79-generic 
root=UUID=cee3f129-716d-46c7-9ab8-016c71f29972 ro quiet splash
  SourcePackage: isc-dhcp
  Title: package isc-dhcp-client 4.3.3-5ubuntu12 [modified: 
usr/share/doc/isc-dhcp-client/changelog.Debian.gz] failed to install/upgrade: 
el paquete isc-dhcp-client no está listo para configurarse  no se puede 
configurar (estado actual `half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1697287/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697287] DuplicateSignature.txt

2017-06-14 Thread Brian Murray
Due to a bug in apport's method for creating a duplicate signature, the
DuplicateSignature in this report was incorrect. We are fixing that now,
sorry for the noise!

** Attachment added: "DuplicateSignature.txt"
   
https://bugs.launchpad.net/bugs/1697287/+attachment/4896069/+files/DuplicateSignature.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1697287

Title:
  package isc-dhcp-client 4.3.3-5ubuntu12 [modified: usr/share/doc/isc-
  dhcp-client/changelog.Debian.gz] failed to install/upgrade: el paquete
  isc-dhcp-client no está listo para configurarse  no se puede
  configurar (estado actual `half-installed')

Status in isc-dhcp package in Ubuntu:
  New

Bug description:
  rr

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: isc-dhcp-client 4.3.3-5ubuntu12 [modified: 
usr/share/doc/isc-dhcp-client/changelog.Debian.gz]
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2.6
  AptOrdering:
   linux-image-extra-4.4.0-77-generic: Remove
   linux-image-4.4.0-77-generic: Remove
   isc-dhcp-client: Configure
   NULL: ConfigurePending
  Architecture: amd64
  Date: Sun Jun 11 09:10:44 2017
  DhclientLeases:
   
  ErrorMessage: el paquete isc-dhcp-client no está listo para configurarse  no 
se puede configurar (estado actual `half-installed')
  InstallationDate: Installed on 2016-09-23 (260 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-79-generic 
root=UUID=cee3f129-716d-46c7-9ab8-016c71f29972 ro quiet splash
  SourcePackage: isc-dhcp
  Title: package isc-dhcp-client 4.3.3-5ubuntu12 [modified: 
usr/share/doc/isc-dhcp-client/changelog.Debian.gz] failed to install/upgrade: 
el paquete isc-dhcp-client no está listo para configurarse  no se puede 
configurar (estado actual `half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1697287/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1674258] Re: lscpu crashs when /dev/mem is not stable to read

2017-06-14 Thread Chris J Arges
Hello Ike, or anyone else affected,

Accepted util-linux into xenial-proposed. The package will build now and
be available at https://launchpad.net/ubuntu/+source/util-
linux/2.27.1-6ubuntu3.3 in a few hours, and then in the -proposed
repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed.  Your feedback will aid us getting this update
out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-needed to verification-done. If it does not fix the
bug for you, please add a comment stating that, and change the tag to
verification-failed.  In either case, details of your testing will help
us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance!

** Changed in: util-linux (Ubuntu Xenial)
   Status: In Progress => Fix Committed

** Changed in: util-linux (Ubuntu Yakkety)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to util-linux in Ubuntu.
https://bugs.launchpad.net/bugs/1674258

Title:
  lscpu crashs when /dev/mem is not stable to read

Status in util-linux package in Ubuntu:
  Fix Released
Status in util-linux source package in Xenial:
  Fix Committed
Status in util-linux source package in Yakkety:
  Fix Committed
Status in util-linux source package in Zesty:
  Fix Committed

Bug description:
  [Impact]

   * Read from /dev/mem and scan DMI tables is dangerous, if /dev/mem is
  not stable to read, it will cause lscpu crash.

  [Test Case]

   * `sudo lscpu` shall not cause Segmentation fault (core dumped)

  [Regression Potential]

   * Reading from DMI tables is sysfs is more stable then reading from
  /dev/mem and if DMI tables is not available lscpu will use the old way
  to search in /dev/mem. I believe its low regression risk

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1674258/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1674258] Please test proposed package

2017-06-14 Thread Chris J Arges
Hello Ike, or anyone else affected,

Accepted util-linux into zesty-proposed. The package will build now and
be available at https://launchpad.net/ubuntu/+source/util-
linux/2.29-1ubuntu2.1 in a few hours, and then in the -proposed
repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed.  Your feedback will aid us getting this update
out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-needed to verification-done. If it does not fix the
bug for you, please add a comment stating that, and change the tag to
verification-failed.  In either case, details of your testing will help
us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to util-linux in Ubuntu.
https://bugs.launchpad.net/bugs/1674258

Title:
  lscpu crashs when /dev/mem is not stable to read

Status in util-linux package in Ubuntu:
  Fix Released
Status in util-linux source package in Xenial:
  Fix Committed
Status in util-linux source package in Yakkety:
  Fix Committed
Status in util-linux source package in Zesty:
  Fix Committed

Bug description:
  [Impact]

   * Read from /dev/mem and scan DMI tables is dangerous, if /dev/mem is
  not stable to read, it will cause lscpu crash.

  [Test Case]

   * `sudo lscpu` shall not cause Segmentation fault (core dumped)

  [Regression Potential]

   * Reading from DMI tables is sysfs is more stable then reading from
  /dev/mem and if DMI tables is not available lscpu will use the old way
  to search in /dev/mem. I believe its low regression risk

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1674258/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1674258] Please test proposed package

2017-06-14 Thread Chris J Arges
Hello Ike, or anyone else affected,

Accepted util-linux into yakkety-proposed. The package will build now
and be available at https://launchpad.net/ubuntu/+source/util-
linux/2.28.2-1ubuntu1.2 in a few hours, and then in the -proposed
repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed.  Your feedback will aid us getting this update
out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-needed to verification-done. If it does not fix the
bug for you, please add a comment stating that, and change the tag to
verification-failed.  In either case, details of your testing will help
us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance!

** Changed in: util-linux (Ubuntu Zesty)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to util-linux in Ubuntu.
https://bugs.launchpad.net/bugs/1674258

Title:
  lscpu crashs when /dev/mem is not stable to read

Status in util-linux package in Ubuntu:
  Fix Released
Status in util-linux source package in Xenial:
  Fix Committed
Status in util-linux source package in Yakkety:
  Fix Committed
Status in util-linux source package in Zesty:
  Fix Committed

Bug description:
  [Impact]

   * Read from /dev/mem and scan DMI tables is dangerous, if /dev/mem is
  not stable to read, it will cause lscpu crash.

  [Test Case]

   * `sudo lscpu` shall not cause Segmentation fault (core dumped)

  [Regression Potential]

   * Reading from DMI tables is sysfs is more stable then reading from
  /dev/mem and if DMI tables is not available lscpu will use the old way
  to search in /dev/mem. I believe its low regression risk

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1674258/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1574667] Re: Mouse pointer occasionally jumps to the bottom-left corner

2017-06-14 Thread Michael Verrilli
I have this exact issue on a Dell Precision 5510. I tried the libinput
workaround along with modifying the settings as discussed above... and
it mostly works except now I cannot use right click.  On this touchpad,
the click is by pushing the touchpad itself, not separate buttons.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1574667

Title:
  Mouse pointer occasionally jumps to the bottom-left corner

Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  Sometimes the mouse pointer jumps directly to the bottom-left corner
  of the screen, which results in opening the trash window when
  clicking.

  This seems to be related: https://ubuntu-mate.community/t/mouse-
  pointer-jumps-on-clicking-touchpad/2932.

  Thanks,
  MZ

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  BootLog: /dev/sda6: clean, 276587/40779776 files, 15261626/163117056 blocks
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Mon Apr 25 15:55:54 2016
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation Sky Lake Integrated Graphics [8086:1916] (rev 07) (prog-if 
00 [VGA controller])
 Subsystem: Dell Skylake Integrated Graphics [1028:06b2]
  InstallationDate: Installed on 2016-04-23 (2 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 8087:07dc Intel Corp. 
   Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card 
Reader Controller
   Bus 001 Device 002: ID 064e:920b Suyin Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. Inspiron 5559
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic.efi.signed 
root=UUID=c5bc0a1d-3fe9-4ae5-81e9-de7d141b419c ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/21/2015
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.1.5
  dmi.board.name: 06CMH7
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.1.5:bd12/21/2015:svnDellInc.:pnInspiron5559:pvr:rvnDellInc.:rn06CMH7:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: Inspiron 5559
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.67-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2
  xserver.bootTime: Mon Apr 25 13:43:44 2016
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id1156 
   vendor LGD
  xserver.version: 2:1.18.3-1ubuntu2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1574667/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1630516] Re: Logrotate doesn't clean old system logs, allowing them to fill the disk

2017-06-14 Thread Launchpad Bug Tracker
This bug was fixed in the package logrotate - 3.8.7-2ubuntu2.16.10.1

---
logrotate (3.8.7-2ubuntu2.16.10.1) yakkety; urgency=medium

  * createOutputFile: rename already existing file (LP: #1630516)
- d/p/ubuntu/createOutputFile-eliminate-stat-open-TOCTOU-race.patch
- d/p/ubuntu/createOutputFile-rename-already-existing-file.patch

 -- Christian Ehrhardt   Wed, 22 Mar
2017 11:47:34 +0100

** Changed in: logrotate (Ubuntu Yakkety)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to logrotate in Ubuntu.
https://bugs.launchpad.net/bugs/1630516

Title:
  Logrotate doesn't clean old system logs, allowing them to fill the
  disk

Status in One Hundred Papercuts:
  Triaged
Status in logrotate package in Ubuntu:
  Fix Released
Status in logrotate source package in Trusty:
  Fix Released
Status in logrotate source package in Xenial:
  Fix Released
Status in logrotate source package in Yakkety:
  Fix Released
Status in logrotate source package in Zesty:
  Fix Released
Status in logrotate package in Debian:
  Fix Released

Bug description:
  [Impact]

  Logrotate fails to rotate a log and then will continue to fail to
  rotate it until manual intervention takes place. If messaging has not
  been configured on the system there will be no warning issued to the
  user. The log will grow day by day until a user intervenes or the
  drive that the log is stored on is full.

  Very large log files can make it more difficult to find useful data.
  Full drives make the rest of the system fail to operate. Backporting a
  fix would prevent drives filling up on stable releases.

  [Test Case]

  Go to your logs area (/var/logs) and create a file with a name ending
  .2, as would be created part way through the logrotate process. So if
  you have /var/log/syslog, /var/log/syslog.1, /var/log/syslog.2.gz,
  /var/log/syslog.3.gz; create a new file named /var/log/syslog.2. Your
  subsequent log rotate runs will fail.

  [Regression Potential]

  - I'd hope the potential is low as it only triggers under certain conditions 
that are special (target filename in the way).
  - So far in those conditions it failed to rotate
  - Yet If despite my hope there still manifests an issue I'd expect it could 
be renaming files it should not, so people would end up "missing" their logs - 
the good thing is that this is a rename, so they should find it at different 
names.
  - Another thing I consider possible is that some unexpected conditions cause 
e.g. a crash in the changed code, in that case the logs are not rotated, but 
since there is no unlink the logs will still exist.
  - Therefore I consider the Potential low enough to consider the fix.

  [Other Info]
  n/a

  ---

  Good afternoon.
  I have started seeing something very similar to Debian Dug 734688 "Logs are 
not rotated for a month" but in the latest Ubuntu LTS (16.04).  I seem to have
  $ logrotate --version
  logrotate 3.8.7
  bundled in it.  A few weeks ago I started getting root emails such as this:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && 
run-parts --report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/munin/munin-node.log.1: File 
exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  When I inspected the area of concern I was able to see that there was an 
existing .1 file.
  manager@warden:/var/log/munin$ ll
  total 580
  drwxr-xr-x  2 munin adm  4096 Sep 27 06:31 ./
  drwxr-xr-x 13 root  syslog   4096 Oct  5 06:26 ../
  -rw-r--r--  1 root  root 3440 Sep 26 13:39 munin-node-configure.log
  -rw-r--r--  1 root  root   490251 Oct  5 10:25 munin-node.log
  -rw-r--r--  1 root  root56598 Sep 21 02:01 munin-node.log.1
  -rw-r--r--  1 root  root24576 Aug 31 02:01 munin-node.log.2
  -rw-r--r--  1 root  root 1906 Sep 19 06:25 munin-node.log.8.gz
  The contents of the munin-node.log file seem to run from the 19th September 
until today.  Unlike other parts of this bug the .1 and .2 files do not seem to 
be already compressed.

  I deleted all but the munin-node.log file to see if it would resolve the 
problem and was going to leave it at that.  Then I noticed that I have had 
another Ubuntu machine which has been sending similar emails for the past week:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && run-parts 
--report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/syslog.1.gz: File exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  Different file, different machine but a very similar error message.

  Checking on the syslog file I can see that it better fits with other reports 
on this bug as my duplicated .1 files has a corresponding .1.gz file.
  manager@trac:/var/log$ ll syslog*
  -rw-r- 1 

[Touch-packages] [Bug 1630516] Update Released

2017-06-14 Thread Chris J Arges
The verification of the Stable Release Update for logrotate has
completed successfully and the package has now been released to
-updates.  Subsequently, the Ubuntu Stable Release Updates Team is being
unsubscribed and will not receive messages about this bug report.  In
the event that you encounter a regression using the package from
-updates please report a new bug using ubuntu-bug and tag the bug report
regression-update so we can easily find any regressions.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to logrotate in Ubuntu.
https://bugs.launchpad.net/bugs/1630516

Title:
  Logrotate doesn't clean old system logs, allowing them to fill the
  disk

Status in One Hundred Papercuts:
  Triaged
Status in logrotate package in Ubuntu:
  Fix Released
Status in logrotate source package in Trusty:
  Fix Released
Status in logrotate source package in Xenial:
  Fix Released
Status in logrotate source package in Yakkety:
  Fix Released
Status in logrotate source package in Zesty:
  Fix Released
Status in logrotate package in Debian:
  Fix Released

Bug description:
  [Impact]

  Logrotate fails to rotate a log and then will continue to fail to
  rotate it until manual intervention takes place. If messaging has not
  been configured on the system there will be no warning issued to the
  user. The log will grow day by day until a user intervenes or the
  drive that the log is stored on is full.

  Very large log files can make it more difficult to find useful data.
  Full drives make the rest of the system fail to operate. Backporting a
  fix would prevent drives filling up on stable releases.

  [Test Case]

  Go to your logs area (/var/logs) and create a file with a name ending
  .2, as would be created part way through the logrotate process. So if
  you have /var/log/syslog, /var/log/syslog.1, /var/log/syslog.2.gz,
  /var/log/syslog.3.gz; create a new file named /var/log/syslog.2. Your
  subsequent log rotate runs will fail.

  [Regression Potential]

  - I'd hope the potential is low as it only triggers under certain conditions 
that are special (target filename in the way).
  - So far in those conditions it failed to rotate
  - Yet If despite my hope there still manifests an issue I'd expect it could 
be renaming files it should not, so people would end up "missing" their logs - 
the good thing is that this is a rename, so they should find it at different 
names.
  - Another thing I consider possible is that some unexpected conditions cause 
e.g. a crash in the changed code, in that case the logs are not rotated, but 
since there is no unlink the logs will still exist.
  - Therefore I consider the Potential low enough to consider the fix.

  [Other Info]
  n/a

  ---

  Good afternoon.
  I have started seeing something very similar to Debian Dug 734688 "Logs are 
not rotated for a month" but in the latest Ubuntu LTS (16.04).  I seem to have
  $ logrotate --version
  logrotate 3.8.7
  bundled in it.  A few weeks ago I started getting root emails such as this:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && 
run-parts --report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/munin/munin-node.log.1: File 
exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  When I inspected the area of concern I was able to see that there was an 
existing .1 file.
  manager@warden:/var/log/munin$ ll
  total 580
  drwxr-xr-x  2 munin adm  4096 Sep 27 06:31 ./
  drwxr-xr-x 13 root  syslog   4096 Oct  5 06:26 ../
  -rw-r--r--  1 root  root 3440 Sep 26 13:39 munin-node-configure.log
  -rw-r--r--  1 root  root   490251 Oct  5 10:25 munin-node.log
  -rw-r--r--  1 root  root56598 Sep 21 02:01 munin-node.log.1
  -rw-r--r--  1 root  root24576 Aug 31 02:01 munin-node.log.2
  -rw-r--r--  1 root  root 1906 Sep 19 06:25 munin-node.log.8.gz
  The contents of the munin-node.log file seem to run from the 19th September 
until today.  Unlike other parts of this bug the .1 and .2 files do not seem to 
be already compressed.

  I deleted all but the munin-node.log file to see if it would resolve the 
problem and was going to leave it at that.  Then I noticed that I have had 
another Ubuntu machine which has been sending similar emails for the past week:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && run-parts 
--report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/syslog.1.gz: File exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  Different file, different machine but a very similar error message.

  Checking on the syslog file I can see that it better fits with other reports 
on this bug as my duplicated .1 files has a corresponding .1.gz file.
  manager@trac:/var/log$ ll syslog*
  -rw-r- 1 syslog adm 918492 Oct  5 10:30 syslog
  -rw-r- 1 syslog adm 

[Touch-packages] [Bug 1630516] Re: Logrotate doesn't clean old system logs, allowing them to fill the disk

2017-06-14 Thread Launchpad Bug Tracker
This bug was fixed in the package logrotate - 3.8.7-1ubuntu1.1

---
logrotate (3.8.7-1ubuntu1.1) trusty; urgency=medium

  * createOutputFile: rename already existing file (LP: #1630516)
- d/p/ubuntu/createOutputFile-eliminate-stat-open-TOCTOU-race.patch
- d/p/ubuntu/createOutputFile-rename-already-existing-file.patch

 -- Christian Ehrhardt   Wed, 22 Mar
2017 12:43:10 +0100

** Changed in: logrotate (Ubuntu Trusty)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to logrotate in Ubuntu.
https://bugs.launchpad.net/bugs/1630516

Title:
  Logrotate doesn't clean old system logs, allowing them to fill the
  disk

Status in One Hundred Papercuts:
  Triaged
Status in logrotate package in Ubuntu:
  Fix Released
Status in logrotate source package in Trusty:
  Fix Released
Status in logrotate source package in Xenial:
  Fix Released
Status in logrotate source package in Yakkety:
  Fix Released
Status in logrotate source package in Zesty:
  Fix Released
Status in logrotate package in Debian:
  Fix Released

Bug description:
  [Impact]

  Logrotate fails to rotate a log and then will continue to fail to
  rotate it until manual intervention takes place. If messaging has not
  been configured on the system there will be no warning issued to the
  user. The log will grow day by day until a user intervenes or the
  drive that the log is stored on is full.

  Very large log files can make it more difficult to find useful data.
  Full drives make the rest of the system fail to operate. Backporting a
  fix would prevent drives filling up on stable releases.

  [Test Case]

  Go to your logs area (/var/logs) and create a file with a name ending
  .2, as would be created part way through the logrotate process. So if
  you have /var/log/syslog, /var/log/syslog.1, /var/log/syslog.2.gz,
  /var/log/syslog.3.gz; create a new file named /var/log/syslog.2. Your
  subsequent log rotate runs will fail.

  [Regression Potential]

  - I'd hope the potential is low as it only triggers under certain conditions 
that are special (target filename in the way).
  - So far in those conditions it failed to rotate
  - Yet If despite my hope there still manifests an issue I'd expect it could 
be renaming files it should not, so people would end up "missing" their logs - 
the good thing is that this is a rename, so they should find it at different 
names.
  - Another thing I consider possible is that some unexpected conditions cause 
e.g. a crash in the changed code, in that case the logs are not rotated, but 
since there is no unlink the logs will still exist.
  - Therefore I consider the Potential low enough to consider the fix.

  [Other Info]
  n/a

  ---

  Good afternoon.
  I have started seeing something very similar to Debian Dug 734688 "Logs are 
not rotated for a month" but in the latest Ubuntu LTS (16.04).  I seem to have
  $ logrotate --version
  logrotate 3.8.7
  bundled in it.  A few weeks ago I started getting root emails such as this:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && 
run-parts --report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/munin/munin-node.log.1: File 
exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  When I inspected the area of concern I was able to see that there was an 
existing .1 file.
  manager@warden:/var/log/munin$ ll
  total 580
  drwxr-xr-x  2 munin adm  4096 Sep 27 06:31 ./
  drwxr-xr-x 13 root  syslog   4096 Oct  5 06:26 ../
  -rw-r--r--  1 root  root 3440 Sep 26 13:39 munin-node-configure.log
  -rw-r--r--  1 root  root   490251 Oct  5 10:25 munin-node.log
  -rw-r--r--  1 root  root56598 Sep 21 02:01 munin-node.log.1
  -rw-r--r--  1 root  root24576 Aug 31 02:01 munin-node.log.2
  -rw-r--r--  1 root  root 1906 Sep 19 06:25 munin-node.log.8.gz
  The contents of the munin-node.log file seem to run from the 19th September 
until today.  Unlike other parts of this bug the .1 and .2 files do not seem to 
be already compressed.

  I deleted all but the munin-node.log file to see if it would resolve the 
problem and was going to leave it at that.  Then I noticed that I have had 
another Ubuntu machine which has been sending similar emails for the past week:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && run-parts 
--report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/syslog.1.gz: File exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  Different file, different machine but a very similar error message.

  Checking on the syslog file I can see that it better fits with other reports 
on this bug as my duplicated .1 files has a corresponding .1.gz file.
  manager@trac:/var/log$ ll syslog*
  -rw-r- 1 syslog adm 

[Touch-packages] [Bug 1611363] Re: vim.gtk3 crashes frequently with SIGSEGV in ffi_call_unix64()

2017-06-14 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: unity-gtk-module (Ubuntu Xenial)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to vim in Ubuntu.
https://bugs.launchpad.net/bugs/1611363

Title:
  vim.gtk3 crashes frequently with SIGSEGV in ffi_call_unix64()

Status in vim:
  Confirmed
Status in unity-gtk-module package in Ubuntu:
  Confirmed
Status in vim package in Ubuntu:
  Confirmed
Status in unity-gtk-module source package in Xenial:
  Confirmed
Status in vim source package in Xenial:
  Confirmed

Bug description:
  Hi, vim-gtk3 crashes so often on my system that it's borderline unusable.
  My system is a clean install of Ubuntu 16.04. I also (temporarily) renamed my 
customized ~/.vimrc and ~/.vim. My system is up-to-date as of today 
(2016-08-09); installed vim-gtk3 is 2:7.4.1689-3ubuntu1.1.

  The crash happens only (but very frequently, not always) when I launch
  gvim, either by calling it from a shell or by double-clicking a file
  in Nautilus. Note that the crash is independent of whether I'm opening
  a file or not. (At least I tried both variations from the terminal.)

  There's also a report on vim's bugtracker, but since unity appears in
  the backtrace, the consensus is that it's probably Ubuntu-specific.

  ProblemType: Crash
  DistroRelease: Ubuntu 16.04
  Package: vim-gtk3 2:7.4.1689-3ubuntu1.1
  ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
  Uname: Linux 4.4.0-31-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Tue Aug  9 14:34:31 2016
  ExecutablePath: /usr/bin/vim.gtk3
  InstallationDate: Installed on 2016-07-10 (29 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  ProcCmdline: gvim -f 
/home/username/Documents/schoul/2016/1G-TODO/01-systemes-equations-TODO/chap01_systemes-equations-NOTES.tex
  Signal: 11
  SourcePackage: vim
  StacktraceTop:
   ?? () from /usr/lib/x86_64-linux-gnu/libunity-gtk3-parser.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
   ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
  Title: vim.gtk3 crashed with SIGSEGV in ffi_call_unix64()
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

To manage notifications about this bug go to:
https://bugs.launchpad.net/vim/+bug/1611363/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1611363] Re: vim.gtk3 crashes frequently with SIGSEGV in ffi_call_unix64()

2017-06-14 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: unity-gtk-module (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to vim in Ubuntu.
https://bugs.launchpad.net/bugs/1611363

Title:
  vim.gtk3 crashes frequently with SIGSEGV in ffi_call_unix64()

Status in vim:
  Confirmed
Status in unity-gtk-module package in Ubuntu:
  Confirmed
Status in vim package in Ubuntu:
  Confirmed
Status in unity-gtk-module source package in Xenial:
  Confirmed
Status in vim source package in Xenial:
  Confirmed

Bug description:
  Hi, vim-gtk3 crashes so often on my system that it's borderline unusable.
  My system is a clean install of Ubuntu 16.04. I also (temporarily) renamed my 
customized ~/.vimrc and ~/.vim. My system is up-to-date as of today 
(2016-08-09); installed vim-gtk3 is 2:7.4.1689-3ubuntu1.1.

  The crash happens only (but very frequently, not always) when I launch
  gvim, either by calling it from a shell or by double-clicking a file
  in Nautilus. Note that the crash is independent of whether I'm opening
  a file or not. (At least I tried both variations from the terminal.)

  There's also a report on vim's bugtracker, but since unity appears in
  the backtrace, the consensus is that it's probably Ubuntu-specific.

  ProblemType: Crash
  DistroRelease: Ubuntu 16.04
  Package: vim-gtk3 2:7.4.1689-3ubuntu1.1
  ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
  Uname: Linux 4.4.0-31-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Tue Aug  9 14:34:31 2016
  ExecutablePath: /usr/bin/vim.gtk3
  InstallationDate: Installed on 2016-07-10 (29 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  ProcCmdline: gvim -f 
/home/username/Documents/schoul/2016/1G-TODO/01-systemes-equations-TODO/chap01_systemes-equations-NOTES.tex
  Signal: 11
  SourcePackage: vim
  StacktraceTop:
   ?? () from /usr/lib/x86_64-linux-gnu/libunity-gtk3-parser.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
   ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
  Title: vim.gtk3 crashed with SIGSEGV in ffi_call_unix64()
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

To manage notifications about this bug go to:
https://bugs.launchpad.net/vim/+bug/1611363/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1685683] Re: Update evolution to 3.24.1

2017-06-14 Thread Launchpad Bug Tracker
This bug was fixed in the package evolution-data-server -
3.24.2-0ubuntu2

---
evolution-data-server (3.24.2-0ubuntu2) artful; urgency=medium

  * Disable Ubuntu Online Accounts integration
  * Convert evolution-data-server-online-accounts into a transitional
package depending on evolution-data-server which now provides
the remaining GNOME Online Accounts support.

 -- Jeremy Bicha   Mon, 05 Jun 2017 08:34:44 -0400

** Changed in: evolution-data-server (Ubuntu)
   Status: Fix Committed => Fix Released

** Changed in: evolution (Ubuntu)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to evolution-data-server in
Ubuntu.
https://bugs.launchpad.net/bugs/1685683

Title:
  Update evolution to 3.24.1

Status in evolution package in Ubuntu:
  Fix Released
Status in evolution-data-server package in Ubuntu:
  Fix Released

Bug description:
  We should update the Evolution stack to 3.24 for Ubuntu 17.10. The big
  change here is that it now uses cmake instead of autotools.

  The update is staged in this PPA and rebuilds of all rdepends have been done:
  https://launchpad.net/~ubuntu-desktop/+archive/ubuntu/transitions/+packages

  Here's some Evolution remaining questions/issues:

  1. I disabled
  
https://sources.debian.net/src/evolution/unstable/debian/patches/02_nss_paths.patch/
  since it didn't seem to be needed.

  2. Lintian is complaining about rpaths. The rpath fix I used with
  e-d-s did not work for Evolution.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/1685683/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1685683] Re: Update evolution to 3.24.1

2017-06-14 Thread Launchpad Bug Tracker
This bug was fixed in the package evolution - 3.24.2-0ubuntu2

---
evolution (3.24.2-0ubuntu2) artful; urgency=medium

  * debian/patches/02_nss_paths.patch: update for cmake; reinstate the
path fix for finding NSS's certificate database library; otherwise you
don't start with any of the trusted certificates from NSS.

 -- Mathieu Trudel-Lapierre   Tue, 13 Jun 2017
14:30:23 -0400

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to evolution-data-server in
Ubuntu.
https://bugs.launchpad.net/bugs/1685683

Title:
  Update evolution to 3.24.1

Status in evolution package in Ubuntu:
  Fix Released
Status in evolution-data-server package in Ubuntu:
  Fix Released

Bug description:
  We should update the Evolution stack to 3.24 for Ubuntu 17.10. The big
  change here is that it now uses cmake instead of autotools.

  The update is staged in this PPA and rebuilds of all rdepends have been done:
  https://launchpad.net/~ubuntu-desktop/+archive/ubuntu/transitions/+packages

  Here's some Evolution remaining questions/issues:

  1. I disabled
  
https://sources.debian.net/src/evolution/unstable/debian/patches/02_nss_paths.patch/
  since it didn't seem to be needed.

  2. Lintian is complaining about rpaths. The rpath fix I used with
  e-d-s did not work for Evolution.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/1685683/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697822] DuplicateSignature.txt

2017-06-14 Thread Brian Murray
Due to a bug in apport's method for creating a duplicate signature, the
DuplicateSignature in this report was incorrect. We are fixing that now,
sorry for the noise!

** Attachment added: "DuplicateSignature.txt"
   
https://bugs.launchpad.net/bugs/1697822/+attachment/4896014/+files/DuplicateSignature.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1697822

Title:
  package bluez-cups 5.37-0ubuntu5 failed to install/upgrade: package
  bluez-cups is not ready for configuration  cannot configure (current
  status 'half-installed')

Status in bluez package in Ubuntu:
  New

Bug description:
  chrashed during upgrade

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: bluez-cups 5.37-0ubuntu5
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.6
  Architecture: amd64
  Date: Wed Jun 14 09:07:29 2017
  DpkgHistoryLog:
   Start-Date: 2017-06-14  09:07:15
   Requested-By: prabhakaran (1000)
   Upgrade: libgnutls-openssl27:amd64 (3.4.10-4ubuntu1.2, 3.4.10-4ubuntu1.3), 
flashplugin-installer:amd64 (25.0.0.171ubuntu0.16.04.1, 
26.0.0.126ubuntu0.16.04.1), libgnutls30:amd64 (3.4.10-4ubuntu1.2, 
3.4.10-4ubuntu1.3), libgnutls30:i386 (3.4.10-4ubuntu1.2, 3.4.10-4ubuntu1.3)
  DuplicateSignature:
   package:bluez-cups:5.37-0ubuntu5
   Installing from local file 
/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170613.2.orig.tar.gz
   Flash Plugin installed.
   dpkg: error processing package bluez-cups (--configure):
package bluez-cups is not ready for configuration
  ErrorMessage: package bluez-cups is not ready for configuration  cannot 
configure (current status 'half-installed')
  InstallationDate: Installed on 2016-08-02 (315 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  InterestingModules: bluetooth
  Lsusb:
   Bus 002 Device 003: ID 5986:0190 Acer, Inc 
   Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
   Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 0914
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-79-generic 
root=UUID=987671d2-2e03-4acd-9a32-cc0bc8f57b64 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: bluez
  Title: package bluez-cups 5.37-0ubuntu5 failed to install/upgrade: package 
bluez-cups is not ready for configuration  cannot configure (current status 
'half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/28/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 29CN38WW(V2.15)
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: Base Board Product Name
  dmi.board.vendor: LENOVO
  dmi.board.version: Base Board Version
  dmi.chassis.asset.tag: Chassis Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Chassis Manufacturer
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnLENOVO:bvr29CN38WW(V2.15):bd01/28/2011:svnLENOVO:pn0914:pvrIdeapadZ560:rvnLENOVO:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
  dmi.product.name: 0914
  dmi.product.version: Ideapad Z560
  dmi.sys.vendor: LENOVO
  hciconfig:
   
  syslog: Jun 14 08:54:17 prabhakaran-Ideapad-Z560 NetworkManager[900]:   
[1497410657.4577] Loaded device plugin: NMBluezManager 
(/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-device-plugin-bluetooth.so)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1697822/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697822] Due to a bug in apport's method for creating a duplicate signature, the DuplicateSignature in this report was incorrect. We are fixing that now, sorry for the noise!

2017-06-14 Thread Brian Murray
-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1697822

Title:
  package bluez-cups 5.37-0ubuntu5 failed to install/upgrade: package
  bluez-cups is not ready for configuration  cannot configure (current
  status 'half-installed')

Status in bluez package in Ubuntu:
  New

Bug description:
  chrashed during upgrade

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: bluez-cups 5.37-0ubuntu5
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.6
  Architecture: amd64
  Date: Wed Jun 14 09:07:29 2017
  DpkgHistoryLog:
   Start-Date: 2017-06-14  09:07:15
   Requested-By: prabhakaran (1000)
   Upgrade: libgnutls-openssl27:amd64 (3.4.10-4ubuntu1.2, 3.4.10-4ubuntu1.3), 
flashplugin-installer:amd64 (25.0.0.171ubuntu0.16.04.1, 
26.0.0.126ubuntu0.16.04.1), libgnutls30:amd64 (3.4.10-4ubuntu1.2, 
3.4.10-4ubuntu1.3), libgnutls30:i386 (3.4.10-4ubuntu1.2, 3.4.10-4ubuntu1.3)
  DuplicateSignature:
   package:bluez-cups:5.37-0ubuntu5
   Installing from local file 
/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170613.2.orig.tar.gz
   Flash Plugin installed.
   dpkg: error processing package bluez-cups (--configure):
package bluez-cups is not ready for configuration
  ErrorMessage: package bluez-cups is not ready for configuration  cannot 
configure (current status 'half-installed')
  InstallationDate: Installed on 2016-08-02 (315 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  InterestingModules: bluetooth
  Lsusb:
   Bus 002 Device 003: ID 5986:0190 Acer, Inc 
   Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
   Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 0914
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-79-generic 
root=UUID=987671d2-2e03-4acd-9a32-cc0bc8f57b64 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: bluez
  Title: package bluez-cups 5.37-0ubuntu5 failed to install/upgrade: package 
bluez-cups is not ready for configuration  cannot configure (current status 
'half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/28/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 29CN38WW(V2.15)
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: Base Board Product Name
  dmi.board.vendor: LENOVO
  dmi.board.version: Base Board Version
  dmi.chassis.asset.tag: Chassis Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Chassis Manufacturer
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnLENOVO:bvr29CN38WW(V2.15):bd01/28/2011:svnLENOVO:pn0914:pvrIdeapadZ560:rvnLENOVO:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
  dmi.product.name: 0914
  dmi.product.version: Ideapad Z560
  dmi.sys.vendor: LENOVO
  hciconfig:
   
  syslog: Jun 14 08:54:17 prabhakaran-Ideapad-Z560 NetworkManager[900]:   
[1497410657.4577] Loaded device plugin: NMBluezManager 
(/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-device-plugin-bluetooth.so)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1697822/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1673350] Re: dm-queue-length module is not included in installer/initramfs

2017-06-14 Thread Mathieu Trudel-Lapierre
Verification done for yakkety's multipath-tools SRU:

multipath-tools 0.5.0+git1.656f8865-5ubuntu7.3

I verified that multipath-tools correctly ships its new hook to include
dm-service-time and dm-queue-length, and the system with that update
boots successfully.

** Tags removed: verification-needed-yakkety
** Tags added: verification-done-yakkety

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1673350

Title:
  dm-queue-length module is not included in installer/initramfs

Status in hw-detect package in Ubuntu:
  Fix Released
Status in initramfs-tools package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in multipath-tools package in Ubuntu:
  Fix Released
Status in hw-detect source package in Xenial:
  In Progress
Status in initramfs-tools source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Released
Status in multipath-tools source package in Xenial:
  Fix Committed
Status in hw-detect source package in Yakkety:
  In Progress
Status in initramfs-tools source package in Yakkety:
  Invalid
Status in linux source package in Yakkety:
  Fix Released
Status in multipath-tools source package in Yakkety:
  Fix Committed

Bug description:
  [Impact]
  Multipath users using EMC XtremIO storage as boot device or at install time 
may run into this issue. With the module unavailable the device is more often 
than not unavailable. Any users changing path selector to 'queue-length' with 
other storage devices may also be affected.

  [Test case]
  1) Install on multipath system using EMC XtremIO storage / OR:
   a) Start d-i install on qemu with multipath enabled
   b) exit to d-i menu
   c) modify /etc/multipath.conf to define path selector as 'queue-length' for 
the local qemu device.
   d) restart multipathd if necessary.
  2) Try to complete the install, setting up storage as multipath and using the 
multipath device as boot disk.
  3) Reboot to disk.

  In a success case, the install should complete successfully without
  requiring manual configuration from the user to support the multipath
  storage past the normal detection of multipath and partitioning.

  In a failure case, the install may not complete, or rebooting may fail
  or lead to a system booted on a single path of the multipath device
  (ie. / on /dev/sda2 rather than /dev/mpatha2).

  [Regression Potential]
  The inclusion of a new multipath path selector driver should not cause any 
regressions, but any failure to detect, configure or boot on multipath devices 
following this change on XtremIO hardware or otherwise would constitute a 
regression potentially caused by this change.

  ---

  ---Problem Description---
  dm-queue-length module is not included in installer/initramfs

  On Ubuntu, multipath devices using the 'queue-length' path selector
  are non-functional on both the installer and initramfs environments;
  because the 'dm-queue-length' kernel module is not included in them.

  The multipath-modules.udeb (src:linux) does not include it in the installer,
  nor multipath-tools-boot (src:multipath-tools) installs it in the initramfs.

  One example is the EMC XtremIO storage, which has 'queue-length' defined as
  its path selector in the default multipath configuration, at least on 16.04.

  Other products may be affected if they are manually configured to use that
  path selector (e.g., via /etc/multipath.conf), and the mere switch of that
  might render the system _unbootable_ if booting from multipath, since the
  initramfs is affected.

  More recently this and another storage changed default path selectors out
  of 'queue-length', however, it's virtually possible for any storage system
  to be affected, with the described manual configuration change.  So, this
  change is also desired on for the next stable release, 17.04, and later.

  Patches are provided for 16.04 and 17.04.

  Error logs in LP comment #6.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hw-detect/+bug/1673350/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697998] Re: package ureadahead 0.100.0-16 failed to install/upgrade: problemas com dependências - a deixar triggers por processar

2017-06-14 Thread Apport retracing service
** Tags removed: need-duplicate-check

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ureadahead in Ubuntu.
https://bugs.launchpad.net/bugs/1697998

Title:
  package ureadahead 0.100.0-16 failed to install/upgrade: problemas com
  dependências - a deixar triggers por processar

Status in ureadahead package in Ubuntu:
  New

Bug description:
  The issue came after downloading and installing dist upgrade via do-
  release-upgrade command.

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: ureadahead 0.100.0-16
  ProcVersionSignature: Ubuntu 3.16.0-77.99~14.04.1-generic 3.16.7-ckt27
  Uname: Linux 3.16.0-77-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.24
  Architecture: amd64
  Date: Wed Jun 14 16:58:59 2017
  DuplicateSignature: package:ureadahead:0.100.0-16:problemas com dependências 
- a deixar triggers por processar
  ErrorMessage: problemas com dependências - a deixar triggers por processar
  InstallationDate: Installed on 2015-03-03 (834 days ago)
  InstallationMedia: Ubuntu-Server 14.04.2 LTS "Trusty Tahr" - Release amd64 
(20150218.1)
  RelatedPackageVersions:
   dpkg 1.18.23kali1
   apt  1.4~rc2
  SourcePackage: ureadahead
  Title: package ureadahead 0.100.0-16 failed to install/upgrade: problemas com 
dependências - a deixar triggers por processar
  UpgradeStatus: Upgraded to xenial on 2017-06-14 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ureadahead/+bug/1697998/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697998] [NEW] package ureadahead 0.100.0-16 failed to install/upgrade: problemas com dependências - a deixar triggers por processar

2017-06-14 Thread glauber_md
Public bug reported:

The issue came after downloading and installing dist upgrade via do-
release-upgrade command.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: ureadahead 0.100.0-16
ProcVersionSignature: Ubuntu 3.16.0-77.99~14.04.1-generic 3.16.7-ckt27
Uname: Linux 3.16.0-77-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.24
Architecture: amd64
Date: Wed Jun 14 16:58:59 2017
DuplicateSignature: package:ureadahead:0.100.0-16:problemas com dependências - 
a deixar triggers por processar
ErrorMessage: problemas com dependências - a deixar triggers por processar
InstallationDate: Installed on 2015-03-03 (834 days ago)
InstallationMedia: Ubuntu-Server 14.04.2 LTS "Trusty Tahr" - Release amd64 
(20150218.1)
RelatedPackageVersions:
 dpkg 1.18.23kali1
 apt  1.4~rc2
SourcePackage: ureadahead
Title: package ureadahead 0.100.0-16 failed to install/upgrade: problemas com 
dependências - a deixar triggers por processar
UpgradeStatus: Upgraded to xenial on 2017-06-14 (0 days ago)

** Affects: ureadahead (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package third-party-packages xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ureadahead in Ubuntu.
https://bugs.launchpad.net/bugs/1697998

Title:
  package ureadahead 0.100.0-16 failed to install/upgrade: problemas com
  dependências - a deixar triggers por processar

Status in ureadahead package in Ubuntu:
  New

Bug description:
  The issue came after downloading and installing dist upgrade via do-
  release-upgrade command.

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: ureadahead 0.100.0-16
  ProcVersionSignature: Ubuntu 3.16.0-77.99~14.04.1-generic 3.16.7-ckt27
  Uname: Linux 3.16.0-77-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.24
  Architecture: amd64
  Date: Wed Jun 14 16:58:59 2017
  DuplicateSignature: package:ureadahead:0.100.0-16:problemas com dependências 
- a deixar triggers por processar
  ErrorMessage: problemas com dependências - a deixar triggers por processar
  InstallationDate: Installed on 2015-03-03 (834 days ago)
  InstallationMedia: Ubuntu-Server 14.04.2 LTS "Trusty Tahr" - Release amd64 
(20150218.1)
  RelatedPackageVersions:
   dpkg 1.18.23kali1
   apt  1.4~rc2
  SourcePackage: ureadahead
  Title: package ureadahead 0.100.0-16 failed to install/upgrade: problemas com 
dependências - a deixar triggers por processar
  UpgradeStatus: Upgraded to xenial on 2017-06-14 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ureadahead/+bug/1697998/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697911] DuplicateSignature.txt

2017-06-14 Thread Brian Murray
Due to a bug in apport's method for creating a duplicate signature, the
DuplicateSignature in this report was incorrect. We are fixing that now,
sorry for any noise!"

** Attachment added: "DuplicateSignature.txt"
   
https://bugs.launchpad.net/bugs/1697911/+attachment/4895976/+files/DuplicateSignature.txt

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1697911

Title:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
  package libssl1.0.0:amd64 cannot be configured because
  libssl1.0.0:i386 is not ready (current status 'half-installed')

Status in openssl package in Ubuntu:
  New

Bug description:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
  package libssl1.0.0:amd64 cannot be configured because
  libssl1.0.0:i386 is not ready (current status 'half-installed')

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libssl1.0.0:amd64 1.0.2g-1ubuntu4.6
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.6
  Architecture: amd64
  Date: Wed Jun 14 13:06:50 2017
  DuplicateSignature:
   package:libssl1.0.0:amd64:1.0.2g-1ubuntu4.6
   Installing from local file 
/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170613.2.orig.tar.gz
   Flash Plugin installed.
   dpkg: error processing package libssl1.0.0:amd64 (--configure):
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is 
not ready (current status 'half-installed')
  ErrorMessage: package libssl1.0.0:amd64 cannot be configured because 
libssl1.0.0:i386 is not ready (current status 'half-installed')
  InstallationDate: Installed on 2017-01-07 (157 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: openssl
  Title: package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade: 
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is not 
ready (current status 'half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1697911/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697911] Due to a bug in apport's method for creating a duplicate signature, the DuplicateSignature in this report was incorrect. We are fixing that now, sorry for any noise!"

2017-06-14 Thread Brian Murray
-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1697911

Title:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
  package libssl1.0.0:amd64 cannot be configured because
  libssl1.0.0:i386 is not ready (current status 'half-installed')

Status in openssl package in Ubuntu:
  New

Bug description:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
  package libssl1.0.0:amd64 cannot be configured because
  libssl1.0.0:i386 is not ready (current status 'half-installed')

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libssl1.0.0:amd64 1.0.2g-1ubuntu4.6
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.6
  Architecture: amd64
  Date: Wed Jun 14 13:06:50 2017
  DuplicateSignature:
   package:libssl1.0.0:amd64:1.0.2g-1ubuntu4.6
   Installing from local file 
/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170613.2.orig.tar.gz
   Flash Plugin installed.
   dpkg: error processing package libssl1.0.0:amd64 (--configure):
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is 
not ready (current status 'half-installed')
  ErrorMessage: package libssl1.0.0:amd64 cannot be configured because 
libssl1.0.0:i386 is not ready (current status 'half-installed')
  InstallationDate: Installed on 2017-01-07 (157 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: openssl
  Title: package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade: 
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is not 
ready (current status 'half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1697911/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697789] Re: Xorg: page allocation failure: order:0, mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE), nodemask=(null)

2017-06-14 Thread Bug Watch Updater
** Changed in: xorg-server
   Status: Unknown => Confirmed

** Changed in: xorg-server
   Importance: Unknown => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1697789

Title:
  Xorg: page allocation failure: order:0,
  mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE),
  nodemask=(null)

Status in X.Org X server:
  Confirmed
Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  dmesg:
  [23559.058500] Xorg: page allocation failure: order:0, 
mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE), nodemask=(null)
  [23559.058509] Xorg cpuset=/ mems_allowed=0
  [23559.058516] CPU: 1 PID: 1797 Comm: Xorg Not tainted 
4.12.0-041200rc5-generic #201706112031
  [23559.058517] Hardware name: SAMSUNG ELECTRONICS CO., LTD. 
530U3C/530U4C/SAMSUNG_NP1234567890, BIOS P14AAJ 04/15/2013
  [23559.058519] Call Trace:
  [23559.058528]  dump_stack+0x63/0x8d
  [23559.058532]  warn_alloc+0x114/0x1c0
  [23559.058535]  __alloc_pages_slowpath+0xe07/0xe10
  [23559.058539]  __alloc_pages_nodemask+0x233/0x250
  [23559.058543]  alloc_pages_vma+0xab/0x250
  [23559.058547]  shmem_alloc_page+0x70/0xc0
  [23559.058550]  ? __radix_tree_insert+0x45/0x220
  [23559.058553]  ? __vm_enough_memory+0x29/0x130
  [23559.058555]  shmem_alloc_and_acct_page+0x72/0x1b0
  [23559.058558]  ? find_get_entry+0x1e/0xc0
  [23559.058561]  shmem_getpage_gfp+0x195/0xbd0
  [23559.058564]  shmem_read_mapping_page_gfp+0x44/0x80
  [23559.058611]  i915_gem_object_get_pages_gtt+0x204/0x5a0 [i915]
  [23559.058643]  i915_gem_object_get_pages+0x20/0x60 [i915]
  [23559.058673]  __i915_gem_object_get_pages+0x5c/0x70 [i915]
  [23559.058706]  __i915_vma_do_pin+0x1c6/0x3a0 [i915]
  [23559.058737]  i915_gem_execbuffer_reserve_vma.isra.29+0x14d/0x1b0 [i915]
  [23559.058765]  i915_gem_execbuffer_reserve.isra.30+0x3b7/0x3e0 [i915]
  [23559.058794]  i915_gem_do_execbuffer.isra.36+0x577/0x16c0 [i915]
  [23559.058799]  ? unix_stream_recvmsg+0x54/0x70
  [23559.058801]  ? unix_state_double_lock+0x70/0x70
  [23559.058830]  i915_gem_execbuffer2+0x96/0x1b0 [i915]
  [23559.058849]  drm_ioctl+0x216/0x4c0 [drm]
  [23559.058877]  ? i915_gem_execbuffer+0x2f0/0x2f0 [i915]
  [23559.058881]  ? __remove_hrtimer+0x3c/0x70
  [23559.058885]  do_vfs_ioctl+0xa3/0x600
  [23559.05]  ? do_setitimer+0xe0/0x240
  [23559.058891]  ? SyS_setitimer+0xf1/0x120
  [23559.058894]  SyS_ioctl+0x79/0x90
  [23559.058897]  entry_SYSCALL_64_fastpath+0x1e/0xa9
  [23559.058900] RIP: 0033:0x7fd8c5c7e987
  [23559.058901] RSP: 002b:7ffd494ac738 EFLAGS: 0246 ORIG_RAX: 
0010
  [23559.058904] RAX: ffda RBX: 0006 RCX: 
7fd8c5c7e987
  [23559.058905] RDX: 7ffd494ac790 RSI: 40406469 RDI: 
000c
  [23559.058907] RBP: 0028 R08: 0001 R09: 
000c
  [23559.058908] R10: 0001 R11: 0246 R12: 
0040
  [23559.058909] R13: 0008 R14: 5581c086a6c0 R15: 

  [23559.058912] Mem-Info:
  [23559.058918] active_anon:1016643 inactive_anon:298858 isolated_anon:0
  active_file:395940 inactive_file:1147459 isolated_file:0
  unevictable:129 dirty:124022 writeback:21146 unstable:0
  slab_reclaimable:57926 slab_unreclaimable:23062
  mapped:283483 shmem:248113 pagetables:23247 bounce:0
  free:29069 free_pcp:245 free_cma:0
  [23559.058923] Node 0 active_anon:4066572kB inactive_anon:1195432kB 
active_file:1583760kB inactive_file:4589836kB unevictable:516kB 
isolated(anon):0kB isolated(file):0kB mapped:1133932kB dirty:496088kB 
writeback:84584kB shmem:992452kB shmem_thp: 0kB shmem_pmdmapped: 0kB anon_thp: 
976896kB writeback_tmp:0kB unstable:0kB all_unreclaimable? no
  [23559.058924] Node 0 DMA free:15360kB min:84kB low:104kB high:124kB 
active_anon:0kB inactive_anon:0kB active_file:0kB inactive_file:0kB 
unevictable:0kB writepending:0kB present:15984kB managed:15360kB mlocked:0kB 
slab_reclaimable:0kB slab_unreclaimable:0kB kernel_stack:0kB pagetables:0kB 
bounce:0kB free_pcp:0kB local_pcp:0kB free_cma:0kB
  [23559.058930] lowmem_reserve[]: 0 3226 11726 11726 11726
  [23559.058935] Node 0 DMA32 free:52176kB min:18568kB low:23208kB high:27848kB 
active_anon:718716kB inactive_anon:177564kB active_file:228516kB 
inactive_file:2067540kB unevictable:0kB writepending:203112kB present:3438520kB 
managed:3354852kB mlocked:0kB slab_reclaimable:98764kB 
slab_unreclaimable:3004kB kernel_stack:576kB pagetables:4384kB bounce:0kB 
free_pcp:0kB local_pcp:0kB free_cma:0kB
  [23559.058941] lowmem_reserve[]: 0 0 8500 8500 8500
  [23559.058945] Node 0 Normal free:48740kB min:48924kB low:61152kB 
high:73380kB active_anon:3347648kB inactive_anon:1017448kB 
active_file:1354180kB inactive_file:2521736kB unevictable:516kB 
writepending:377444kB present:8902656kB 

Re: [Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Steve Langasek
On Wed, Jun 14, 2017 at 05:58:06PM -, Ryan Harper wrote:
> This is a known issue w.r.t waiting for IPV6 LL, on Xenial KVM, qemu -net
> user does not provide IPV6 LL response (yakkety and newer do), so there's a
> delay;  it does sound like the IPV6 LL timeout is longer than it used to be
> as I've seen a 5 to 10 second delay in VMs launched on KVM on xenial, but
> not a full 120 seconds which breaks the wait-online.

If it were just a delay, networkd should still eventually recognize the
device as configured.  Maybe some packets are going missing?  We probably
need a network trace from within the guest.

Also probably interesting to know if 'sudo service networkd-resolved
restart' changes the state of things, or if the device remains
'configuring'.

-- 
Steve Langasek   Give me a lever long enough and a Free OS
Debian Developer   to set it on, and I can move the world.
Ubuntu Developerhttp://www.debian.org/
slanga...@ubuntu.com vor...@debian.org

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697789] Re: Xorg: page allocation failure: order:0, mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE), nodemask=(null)

2017-06-14 Thread Cristian Aravena Romero
https://bugzilla.kernel.org/show_bug.cgi?id=196075

** Bug watch added: freedesktop.org Bugzilla #101426
   https://bugs.freedesktop.org/show_bug.cgi?id=101426

** Also affects: xorg-server via
   https://bugs.freedesktop.org/show_bug.cgi?id=101426
   Importance: Unknown
   Status: Unknown

** Bug watch added: Linux Kernel Bug Tracker #196075
   https://bugzilla.kernel.org/show_bug.cgi?id=196075

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1697789

Title:
  Xorg: page allocation failure: order:0,
  mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE),
  nodemask=(null)

Status in X.Org X server:
  Unknown
Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  dmesg:
  [23559.058500] Xorg: page allocation failure: order:0, 
mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE), nodemask=(null)
  [23559.058509] Xorg cpuset=/ mems_allowed=0
  [23559.058516] CPU: 1 PID: 1797 Comm: Xorg Not tainted 
4.12.0-041200rc5-generic #201706112031
  [23559.058517] Hardware name: SAMSUNG ELECTRONICS CO., LTD. 
530U3C/530U4C/SAMSUNG_NP1234567890, BIOS P14AAJ 04/15/2013
  [23559.058519] Call Trace:
  [23559.058528]  dump_stack+0x63/0x8d
  [23559.058532]  warn_alloc+0x114/0x1c0
  [23559.058535]  __alloc_pages_slowpath+0xe07/0xe10
  [23559.058539]  __alloc_pages_nodemask+0x233/0x250
  [23559.058543]  alloc_pages_vma+0xab/0x250
  [23559.058547]  shmem_alloc_page+0x70/0xc0
  [23559.058550]  ? __radix_tree_insert+0x45/0x220
  [23559.058553]  ? __vm_enough_memory+0x29/0x130
  [23559.058555]  shmem_alloc_and_acct_page+0x72/0x1b0
  [23559.058558]  ? find_get_entry+0x1e/0xc0
  [23559.058561]  shmem_getpage_gfp+0x195/0xbd0
  [23559.058564]  shmem_read_mapping_page_gfp+0x44/0x80
  [23559.058611]  i915_gem_object_get_pages_gtt+0x204/0x5a0 [i915]
  [23559.058643]  i915_gem_object_get_pages+0x20/0x60 [i915]
  [23559.058673]  __i915_gem_object_get_pages+0x5c/0x70 [i915]
  [23559.058706]  __i915_vma_do_pin+0x1c6/0x3a0 [i915]
  [23559.058737]  i915_gem_execbuffer_reserve_vma.isra.29+0x14d/0x1b0 [i915]
  [23559.058765]  i915_gem_execbuffer_reserve.isra.30+0x3b7/0x3e0 [i915]
  [23559.058794]  i915_gem_do_execbuffer.isra.36+0x577/0x16c0 [i915]
  [23559.058799]  ? unix_stream_recvmsg+0x54/0x70
  [23559.058801]  ? unix_state_double_lock+0x70/0x70
  [23559.058830]  i915_gem_execbuffer2+0x96/0x1b0 [i915]
  [23559.058849]  drm_ioctl+0x216/0x4c0 [drm]
  [23559.058877]  ? i915_gem_execbuffer+0x2f0/0x2f0 [i915]
  [23559.058881]  ? __remove_hrtimer+0x3c/0x70
  [23559.058885]  do_vfs_ioctl+0xa3/0x600
  [23559.05]  ? do_setitimer+0xe0/0x240
  [23559.058891]  ? SyS_setitimer+0xf1/0x120
  [23559.058894]  SyS_ioctl+0x79/0x90
  [23559.058897]  entry_SYSCALL_64_fastpath+0x1e/0xa9
  [23559.058900] RIP: 0033:0x7fd8c5c7e987
  [23559.058901] RSP: 002b:7ffd494ac738 EFLAGS: 0246 ORIG_RAX: 
0010
  [23559.058904] RAX: ffda RBX: 0006 RCX: 
7fd8c5c7e987
  [23559.058905] RDX: 7ffd494ac790 RSI: 40406469 RDI: 
000c
  [23559.058907] RBP: 0028 R08: 0001 R09: 
000c
  [23559.058908] R10: 0001 R11: 0246 R12: 
0040
  [23559.058909] R13: 0008 R14: 5581c086a6c0 R15: 

  [23559.058912] Mem-Info:
  [23559.058918] active_anon:1016643 inactive_anon:298858 isolated_anon:0
  active_file:395940 inactive_file:1147459 isolated_file:0
  unevictable:129 dirty:124022 writeback:21146 unstable:0
  slab_reclaimable:57926 slab_unreclaimable:23062
  mapped:283483 shmem:248113 pagetables:23247 bounce:0
  free:29069 free_pcp:245 free_cma:0
  [23559.058923] Node 0 active_anon:4066572kB inactive_anon:1195432kB 
active_file:1583760kB inactive_file:4589836kB unevictable:516kB 
isolated(anon):0kB isolated(file):0kB mapped:1133932kB dirty:496088kB 
writeback:84584kB shmem:992452kB shmem_thp: 0kB shmem_pmdmapped: 0kB anon_thp: 
976896kB writeback_tmp:0kB unstable:0kB all_unreclaimable? no
  [23559.058924] Node 0 DMA free:15360kB min:84kB low:104kB high:124kB 
active_anon:0kB inactive_anon:0kB active_file:0kB inactive_file:0kB 
unevictable:0kB writepending:0kB present:15984kB managed:15360kB mlocked:0kB 
slab_reclaimable:0kB slab_unreclaimable:0kB kernel_stack:0kB pagetables:0kB 
bounce:0kB free_pcp:0kB local_pcp:0kB free_cma:0kB
  [23559.058930] lowmem_reserve[]: 0 3226 11726 11726 11726
  [23559.058935] Node 0 DMA32 free:52176kB min:18568kB low:23208kB high:27848kB 
active_anon:718716kB inactive_anon:177564kB active_file:228516kB 
inactive_file:2067540kB unevictable:0kB writepending:203112kB present:3438520kB 
managed:3354852kB mlocked:0kB slab_reclaimable:98764kB 
slab_unreclaimable:3004kB kernel_stack:576kB pagetables:4384kB bounce:0kB 
free_pcp:0kB local_pcp:0kB free_cma:0kB
  

[Touch-packages] [Bug 1569925] Re: Shutdown hang on 16.04 with iscsi targets

2017-06-14 Thread Kai Holthaus
@nacc: Yes.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1569925

Title:
  Shutdown hang on 16.04 with iscsi targets

Status in systemd package in Ubuntu:
  Confirmed
Status in systemd source package in Xenial:
  New

Bug description:
  I have 4 servers running the latest 16.04 updates from the development
  branch (as of right now).

  Each server is connected to NetApp storage using iscsi software
  initiator.  There are a total of 56 volumes spread across two NetApp
  arrays.  Each volume has 4 paths available to it which are being
  managed by device mapper.

  While logged into the iscsi sessions all I have to do is reboot the
  server and I get a hang.

  I see a message that says:

    "Reached target Shutdown"

  followed by

    "systemd-shutdown[1]: Failed to finalize DM devices, ignoring"

  and then I see 8 lines that say:

    "connection1:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection2:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection3:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection4:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection5:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection6:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection7:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection8:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    NOTE: the actual values of the *'s differ for each line above.

  This seems like a bug somewhere but I am unaware of any additional
  logging that I could turn on to pinpoint the problem.

  Note I also have similar setups that are not doing iscsi and they
  don't have this problem.

  Here is a screenshot of what I see on the shell when I try to reboot:

  (https://launchpadlibrarian.net/291303059/Screenshot.jpg)

  This is being tracked in NetApp bug tracker CQ number 860251.

  If I log out of all iscsi sessions before rebooting then I do not
  experience the hang:

  iscsiadm -m node -U all

  We are wondering if this could be some kind of shutdown ordering
  problem.  Like the network devices have already disappeared and then
  iscsi tries to perform some operation (hence the ping timeouts).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1569925/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Ryan Harper
This is a known issue w.r.t waiting for IPV6 LL, on Xenial KVM, qemu -net
user does not provide IPV6 LL response (yakkety and newer do), so there's a
delay;  it does sound like the IPV6 LL timeout is longer than it used to be
as I've seen a 5 to 10 second delay in VMs launched on KVM on xenial, but
not a full 120 seconds which breaks the wait-online.

On Wed, Jun 14, 2017 at 12:31 PM, Stefan Bader 
wrote:

> So from what Steve wrote and what I see. the missing part is moving from
> "Gained IPv6LL" to "Configured".
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1697730
>
> Title:
>   Long boot time due to systemd-networkd-wait-online.service failure
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/
> 1697730/+subscriptions
>

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Stefan Bader
So from what Steve wrote and what I see. the missing part is moving from
"Gained IPv6LL" to "Configured".

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Stefan Bader
@Ryan:

2: eth0
   Link File: /lib/systemd/network/99-default.link
Network File: /run/systemd/network/10-netplan-eth0.network
Type: ether
   State: routable (configuring)
Path: xen-vif-0
  Driver: vif
  HW Address: 00:16:3e:71:31:57 (Xensource, Inc.)
 Address: 192.168.2.159
  fe80::216:3eff:fe71:3157
 Gateway: 192.168.2.1 (PC Engines GmbH)
 DNS: 192.168.2.1
  fe80::c66e:1fff:fe3b:bdcd

Similar on the KVM guest, just being ens3 then.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1569925] Re: Shutdown hang on 16.04 with iscsi targets

2017-06-14 Thread Nish Aravamudan
@kai-holthaus: after editing the service file, did you issue a `sudo
systemctl daemon-reload` ?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1569925

Title:
  Shutdown hang on 16.04 with iscsi targets

Status in systemd package in Ubuntu:
  Confirmed
Status in systemd source package in Xenial:
  New

Bug description:
  I have 4 servers running the latest 16.04 updates from the development
  branch (as of right now).

  Each server is connected to NetApp storage using iscsi software
  initiator.  There are a total of 56 volumes spread across two NetApp
  arrays.  Each volume has 4 paths available to it which are being
  managed by device mapper.

  While logged into the iscsi sessions all I have to do is reboot the
  server and I get a hang.

  I see a message that says:

    "Reached target Shutdown"

  followed by

    "systemd-shutdown[1]: Failed to finalize DM devices, ignoring"

  and then I see 8 lines that say:

    "connection1:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection2:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection3:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection4:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection5:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection6:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection7:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    "connection8:0: ping timeout of 5 secs expired, recv timeout 5, last rx 
4311815***, last ping 43118164**, now 4311817***"
    NOTE: the actual values of the *'s differ for each line above.

  This seems like a bug somewhere but I am unaware of any additional
  logging that I could turn on to pinpoint the problem.

  Note I also have similar setups that are not doing iscsi and they
  don't have this problem.

  Here is a screenshot of what I see on the shell when I try to reboot:

  (https://launchpadlibrarian.net/291303059/Screenshot.jpg)

  This is being tracked in NetApp bug tracker CQ number 860251.

  If I log out of all iscsi sessions before rebooting then I do not
  experience the hang:

  iscsiadm -m node -U all

  We are wondering if this could be some kind of shutdown ordering
  problem.  Like the network devices have already disappeared and then
  iscsi tries to perform some operation (hence the ping timeouts).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1569925/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Steve Langasek
I noticed one difference between our configs was that you did not have
public ipv6 set up.  I shut down radvd on my router and rebooted as a
test; this seems to cause a slight delay at boot (long enough for
systemd to send a message warning that it's waiting for the network to
be configured), but this takes about 15s before it gives up on ipv6, not
2 minutes.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Ryan Harper
What does your networkctl status eth0 show?

On Wed, Jun 14, 2017 at 11:34 AM, Ryan Harper 
wrote:

> It looks a lot like this issue:
>
> https://github.com/systemd/systemd/issues/1645
>
> Where DHCP works, it has an ip and can sync time and other items, but the
> wait service isn't happy.
>
> On Wed, Jun 14, 2017 at 10:46 AM, Steve Langasek <
> steve.langa...@canonical.com> wrote:
>
>> The journal shows, two minutes after the start of the wait-online job:
>>
>> Jun 14 00:11:42 bar-artful6401 systemd-networkd-wait-online[618]: Event
>> loop failed: Connection timed out
>> Jun 14 00:11:42 bar-artful6401 systemd[1]: 
>> systemd-networkd-wait-online.service:
>> Main process exited, code=exited, status=1/FAILURE
>> Jun 14 00:11:42 bar-artful6401 systemd[1]: Failed to start Wait for
>> Network to be Configured.
>> Jun 14 00:11:42 bar-artful6401 systemd[1]: 
>> systemd-networkd-wait-online.service:
>> Unit entered failed state.
>> Jun 14 00:11:42 bar-artful6401 systemd[1]: 
>> systemd-networkd-wait-online.service:
>> Failed with result 'exit-code'.
>> Jun 14 00:11:43 bar-artful6401 systemd[1]: Reached target Network is
>> Online.
>>
>> So this sounds like a protocol/socket issue, rather than an issue with
>> networkd reporting wrong state of the network devices.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1697730
>>
>> Title:
>>   Long boot time due to systemd-networkd-wait-online.service failure
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/16977
>> 30/+subscriptions
>>
>
>

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: 

[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Ryan Harper
It looks a lot like this issue:

https://github.com/systemd/systemd/issues/1645

Where DHCP works, it has an ip and can sync time and other items, but the
wait service isn't happy.

On Wed, Jun 14, 2017 at 10:46 AM, Steve Langasek <
steve.langa...@canonical.com> wrote:

> The journal shows, two minutes after the start of the wait-online job:
>
> Jun 14 00:11:42 bar-artful6401 systemd-networkd-wait-online[618]: Event
> loop failed: Connection timed out
> Jun 14 00:11:42 bar-artful6401 systemd[1]: 
> systemd-networkd-wait-online.service:
> Main process exited, code=exited, status=1/FAILURE
> Jun 14 00:11:42 bar-artful6401 systemd[1]: Failed to start Wait for
> Network to be Configured.
> Jun 14 00:11:42 bar-artful6401 systemd[1]: 
> systemd-networkd-wait-online.service:
> Unit entered failed state.
> Jun 14 00:11:42 bar-artful6401 systemd[1]: 
> systemd-networkd-wait-online.service:
> Failed with result 'exit-code'.
> Jun 14 00:11:43 bar-artful6401 systemd[1]: Reached target Network is
> Online.
>
> So this sounds like a protocol/socket issue, rather than an issue with
> networkd reporting wrong state of the network devices.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1697730
>
> Title:
>   Long boot time due to systemd-networkd-wait-online.service failure
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/
> 1697730/+subscriptions
>


** Bug watch added: github.com/systemd/systemd/issues #1645
   https://github.com/systemd/systemd/issues/1645

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : 

[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Steve Langasek
Fresh install of an artful-server image in a VM, and I can't reproduce
this problem.  For some reason, on your system networkd never logs that
the network interface has been 'configured'.  So in fact, systemd-
networkd-wait-online is behaving correctly; you're somehow just never
getting the OK from systemd-networkd.

ubuntu@artful-server:~$ time sudo /lib/systemd/systemd-networkd-wait-online
ignoring: lo

real0m0.018s
user0m0.012s
sys 0m0.000s
ubuntu@artful-server:~$ echo $?
0
ubuntu@artful-server:~$ ip link
1: lo:  mtu 65536 qdisc noqueue state UNKNOWN mode 
DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: ens3:  mtu 1500 qdisc pfifo_fast state UP 
mode DEFAULT group default qlen 1000
link/ether 52:54:00:68:21:e2 brd ff:ff:ff:ff:ff:ff
ubuntu@artful-server:~$ ip addr
1: lo:  mtu 65536 qdisc noqueue state UNKNOWN group 
default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: ens3:  mtu 1500 qdisc pfifo_fast state UP 
group default qlen 1000
link/ether 52:54:00:68:21:e2 brd ff:ff:ff:ff:ff:ff
inet 192.168.15.68/24 brd 192.168.15.255 scope global dynamic ens3
   valid_lft 3269sec preferred_lft 3269sec
inet6 2001:470:e980:0:5054:ff:fe68:21e2/64 scope global mngtmpaddr 
noprefixroute dynamic 
   valid_lft 86295sec preferred_lft 14295sec
inet6 fe80::5054:ff:fe68:21e2/64 scope link 
   valid_lft forever preferred_lft forever
ubuntu@artful-server:~$ cat /etc/netplan/01-netcfg.yaml 
# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: networkd
  ethernets:
ens3:
  dhcp4: yes
  dhcp6: yes
ubuntu@artful-server:~$ cat /run/systemd/network/10-netplan-ens3.network 
[Match]
Name=ens3

[Network]
DHCP=yes

[DHCP]
RouteMetric=100
ubuntu@artful-server:~$ dpkg -l systemd|grep ^ii
ii  systemd233-6ubuntu3 amd64system and service manager
ubuntu@artful-server:~$ 

And, perhaps most crucially:

ubuntu@artful-server:~$ sudo journalctl -u systemd-networkd --no-pager
-- Logs begin at Wed 2017-06-14 09:20:15 PDT, end at Wed 2017-06-14 09:27:38 
PDT. --
Jun 14 09:20:17 artful-server systemd[1]: Starting Network Service...
Jun 14 09:20:17 artful-server systemd-networkd[451]: Enumeration completed
Jun 14 09:20:17 artful-server systemd[1]: Started Network Service.
Jun 14 09:20:17 artful-server systemd-networkd[451]: ens3: IPv6 successfully 
enabled
Jun 14 09:20:17 artful-server systemd-networkd[451]: ens3: Gained carrier
Jun 14 09:20:18 artful-server systemd-networkd[451]: ens3: DHCPv4 address 
192.168.15.68/24 via 192.168.15.1
Jun 14 09:20:18 artful-server systemd-networkd[451]: ens3: Gained IPv6LL
Jun 14 09:20:20 artful-server systemd-networkd[451]: ens3: Configured
ubuntu@artful-server:~$

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 

[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Stefan Bader
Hm, maybe that helps. This is the contents of /run/systemd/netif/links/2
(which is my eth0):

# This is private data. Do not parse.
ADMIN_STATE=configuring
OPER_STATE=routable
NETWORK_FILE=/run/systemd/network/10-netplan-eth0.network
DNS=192.168.2.1 fe80::c66e:1fff:fe3b:bdcd
NTP=
DOMAINS=
ROUTE_DOMAINS=
LLMNR=yes
MDNS=no
ADDRESSES=192.168.2.159/24
ROUTES=192.168.2.1/32/0/100/254/18446744073709551615 
0.0.0.0/0/0/100/254/18446744073709551615
DHCP4_ADDRESS=192.168.2.159
DHCP_LEASE=/run/systemd/netif/leases/2

ADMIN_STATE sounds suspicious.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Stefan Bader
@Steve, eth0 is normal when you use Xen HVM guests. What I see when I
strace the wait command is that is is in some epoll most of the time.
That was the reason I was thinking that maybe it is waiting on some
status change. But then I also believe it did find two entries in
/run/systemd/netif/links which seem to be lo and eth0. So it should be
aware of both. Just not sure what it is waiting for.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1507247] Re: avahi-daemon dies after about a minute

2017-06-14 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: avahi (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to avahi in Ubuntu.
https://bugs.launchpad.net/bugs/1507247

Title:
  avahi-daemon dies after about a minute

Status in avahi package in Ubuntu:
  Confirmed

Bug description:
  So I thought I'd try running Vagrant inside of an Ubuntu VM to do some
  development work as detailed here:
  http://taoofmac.com/space/HOWTO/Vagrant

  When the box starts up, there is a short delay before broadcasting
  begins, and I'm able to ping the guest (in this case registered as
  "hobo-container.local").

  Then, after a minute or two, it stops responding.  The logs look like
  this:

  -- Logs begin at Thu 2015-10-15 14:36:55 EDT, end at Thu 2015-10-15 14:40:00 
EDT. --
  Oct 15 14:36:58 hobo-container systemd[1]: Starting Avahi mDNS/DNS-SD Stack...
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Found user 'avahi' (UID 
110) and group 'avahi' (GID 119).
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Successfully dropped root 
privileges.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: avahi-daemon 0.6.31 
starting up.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Successfully called 
chroot().
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Successfully dropped 
remaining capabilities.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Loading service file 
/services/ssh.service.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Joining mDNS multicast 
group on interface eth1.IPv6 with address fe80::a0
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: New relevant interface 
eth1.IPv6 for mDNS.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Joining mDNS multicast 
group on interface eth1.IPv4 with address 203.0.11
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: New relevant interface 
eth1.IPv4 for mDNS.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Network interface 
enumeration completed.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Registering new address 
record for fe80::a00:27ff:fef9:e38c on eth1.*.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Registering new address 
record for 203.0.113.2 on eth1.IPv4.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Registering HINFO record 
with values 'X86_64'/'LINUX'.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Joining mDNS multicast 
group on interface lxcbr0.IPv4 with address 10.0.3
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: New relevant interface 
lxcbr0.IPv4 for mDNS.
  Oct 15 14:36:58 hobo-container avahi-daemon[507]: Registering new address 
record for 10.0.3.1 on lxcbr0.IPv4.
  Oct 15 14:36:59 hobo-container avahi-daemon[507]: Server startup complete. 
Host name is hobo-container.local. Local service
  Oct 15 14:37:00 hobo-container avahi-daemon[507]: Joining mDNS multicast 
group on interface lxcbr0.IPv6 with address fe80::
  Oct 15 14:37:00 hobo-container avahi-daemon[507]: New relevant interface 
lxcbr0.IPv6 for mDNS.
  Oct 15 14:37:00 hobo-container avahi-daemon[507]: Registering new address 
record for fe80::704a:9bff:fe76:a607 on lxcbr0.*.
  Oct 15 14:37:01 hobo-container avahi-daemon[507]: Service "hobo-container" 
(/services/ssh.service) successfully established
  Oct 15 14:38:28 hobo-container systemd[1]: avahi-daemon.service start 
operation timed out. Terminating.
  Oct 15 14:38:28 hobo-container avahi-daemon[507]: Got SIGTERM, quitting.
  Oct 15 14:38:28 hobo-container avahi-daemon[507]: Leaving mDNS multicast 
group on interface lxcbr0.IPv6 with address fe80::
  Oct 15 14:38:28 hobo-container avahi-daemon[507]: Leaving mDNS multicast 
group on interface lxcbr0.IPv4 with address 10.0.3
  Oct 15 14:38:28 hobo-container avahi-daemon[507]: Leaving mDNS multicast 
group on interface eth1.IPv6 with address fe80::a0
  Oct 15 14:38:28 hobo-container avahi-daemon[507]: Leaving mDNS multicast 
group on interface eth1.IPv4 with address 203.0.11
  Oct 15 14:38:28 hobo-container systemd[1]: Failed to start Avahi mDNS/DNS-SD 
Stack.
  Oct 15 14:38:28 hobo-container systemd[1]: Unit avahi-daemon.service entered 
failed state.
  Oct 15 14:38:28 hobo-container systemd[1]: avahi-daemon.service failed.

  Further attempts to restart the service fail:

  $ sudo service avahi-daemon start
  Job for avahi-daemon.service failed. See "systemctl status 
avahi-daemon.service" and "journalctl -xe" for details.

  With similar logs:

  Oct 15 14:41:16 hobo-container systemd[1]: Starting Avahi mDNS/DNS-SD Stack...
  Oct 15 14:41:16 hobo-container avahi-daemon[1099]: Found user 'avahi' (UID 
110) and group 'avahi' (GID 119).
  Oct 15 14:41:16 hobo-container avahi-daemon[1099]: Successfully dropped root 
privileges.
  Oct 15 14:41:16 hobo-container avahi-daemon[1099]: avahi-daemon 0.6.31 
starting up.
  Oct 15 14:41:16 hobo-container avahi-daemon[1099]: 

[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Steve Langasek
The journal shows, two minutes after the start of the wait-online job:

Jun 14 00:11:42 bar-artful6401 systemd-networkd-wait-online[618]: Event loop 
failed: Connection timed out
Jun 14 00:11:42 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, 
status=1/FAILURE
Jun 14 00:11:42 bar-artful6401 systemd[1]: Failed to start Wait for Network to 
be Configured.
Jun 14 00:11:42 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
Jun 14 00:11:42 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.
Jun 14 00:11:43 bar-artful6401 systemd[1]: Reached target Network is Online.

So this sounds like a protocol/socket issue, rather than an issue with
networkd reporting wrong state of the network devices.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1695876] Re: German Documentation file displays incorrect CUPS version

2017-06-14 Thread Ivy Alexander
** Patch removed: "lp1695876_xenial.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1695876/+attachment/4895904/+files/lp1695876_xenial.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1695876

Title:
  German Documentation file displays incorrect CUPS version

Status in CUPS:
  Fix Released
Status in cups package in Ubuntu:
  New

Bug description:
  The /doc/de/index.html.in file in the package source has an incorrect
  version number written into a header instead of using '@CUPS_VERSION@'
  to populate this file as in the other languages' version of the same
  file, seemingly resulting in /usr/share/cups/doc-root/de/index.html
  having the wrong version once CUPS is installed:

  ...
  

  CUPS 2.0.2
  ...

  instead of:

  ...
  

  CUPS @CUPS_VERSION@
  ...

  resulting in 'CUPS 2.0.2' instead of 2.1.3 being shown.

To manage notifications about this bug go to:
https://bugs.launchpad.net/cups/+bug/1695876/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1696415] Re: NetworkManager does not update IPv4 address lifetime even though DHCP lease was successfully renewed

2017-06-14 Thread Sjors Gielen
** Summary changed:

- NetworkManager seems to drop IPv4 DHCP lease even though it was successfully 
renewed
+ NetworkManager does not update IPv4 address lifetime even though DHCP lease 
was successfully renewed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1696415

Title:
  NetworkManager does not update IPv4 address lifetime even though DHCP
  lease was successfully renewed

Status in network-manager package in Ubuntu:
  New

Bug description:
  I've found an issue on some of our Xenial office machines, causing
  NetworkManager to drop its IP address lease in some cases when it
  shouldn't. I'm not sure if the actual bug is in NetworkManager or
  perhaps dbus or dhclient, but I'll do my best to help to figure out
  where it is.

  What appears to happen:
  * NetworkManager is informed of a new IPv4 lease.
  * During the lease, dhclient keeps it fresh by renewing it using DHCPREQUESTs 
regularly.
  * In spite of this, NetworkManager drops the IP address from the interface 
when the last reported lease time expires.

  This happens on various machines, once every few days. We are using a
  failover DHCP configuration using two machines (192.168.0.3 'bonaire'
  and 192.168.0.4 'curacao').



  The machine where I've done the debugging is called 'pampus'
  (192.168.0.166). As you can see in the logs, at 01:21:06
  NetworkManager reports a new lease with lease time 7200.

  jun 07 01:21:06 pampus dhclient[1532]: DHCPREQUEST of 192.168.0.166 on eth0 
to 192.168.0.4 port 67 (xid=0x3295b440)
  jun 07 01:21:06 pampus dhclient[1532]: DHCPACK of 192.168.0.166 from 
192.168.0.4
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
address 192.168.0.166
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   plen 
24 (255.255.255.0)
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
gateway 192.168.0.5
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
server identifier 192.168.0.4
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
lease time 7200
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
nameserver '192.168.0.3'
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
nameserver '192.168.0.4'
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
domain name 'office.screenpointmed.com'
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9531] dhcp4 
(eth0): state changed bound -> bound

  After this, dhclient is supposed to keep the lease fresh, which it
  does. E.g. at 03:13:19 you can see a DHCPREQUEST and DHCPACK; I've
  seen this DHCPACK in a tcpdump and it contains a new lease time of
  7200 seconds.

  jun 07 03:13:19 pampus dhclient[1532]: DHCPREQUEST of 192.168.0.166 on eth0 
to 192.168.0.4 port 67 (xid=0x3295b440)
  jun 07 03:13:19 pampus dhclient[1532]: DHCPACK of 192.168.0.166 from 
192.168.0.4
  jun 07 03:13:19 pampus dhclient[1532]: bound to 192.168.0.166 -- renewal in 
2708 seconds.

  However, at 03:21:07 (exactly 2 hours and 1 second after the last
  lease reported by NetworkManager) Avahi and NTP report that the IP
  address is gone:

  jun 07 03:21:07 pampus avahi-daemon[1167]: Withdrawing address record for 
192.168.0.166 on eth0.
  jun 07 03:21:07 pampus avahi-daemon[1167]: Leaving mDNS multicast group on 
interface eth0.IPv4 with address 192.168.0.166.
  jun 07 03:21:07 pampus avahi-daemon[1167]: Interface eth0.IPv4 no longer 
relevant for mDNS.
  jun 07 03:21:08 pampus ntpd[18832]: Deleting interface #3 eth0, 
192.168.0.166#123, interface stats: received=2512, sent=2549, dropped=0, 
active_time=111819 secs

  So I suspect NetworkManager dropped the IP address from the interface,
  because it wasn't informed by dhclient that the lease was renewed. The
  logs don't explicitly say this, so I may have to turn on more verbose
  debugging logs in NetworkManager or dhclient to verify this.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: network-manager 1.2.6-0ubuntu0.16.04.1
  ProcVersionSignature: Ubuntu 4.4.0-66.87-generic 4.4.44
  Uname: Linux 4.4.0-66-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2.6
  Architecture: amd64
  Date: Wed Jun  7 14:48:59 2017
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2016-11-04 (214 days ago)
  InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
  IpRoute:
   default via 192.168.0.5 dev eth0  proto static  metric 100 
   192.168.0.0/24 dev eth0  proto kernel  scope link  src 192.168.0.166 
   192.168.0.0/24 dev eth0  proto kernel  scope link  src 192.168.0.166  metric 
100
  IwConfig:
   lono wireless extensions.
   
   eth1  no wireless extensions.
   
   eth0  no 

[Touch-packages] [Bug 1697959] [NEW] late package version collection can cause confusion

2017-06-14 Thread Brian Murray
Public bug reported:

The following OOPS contains some misinformation:

https://errors.ubuntu.com/oops/3680877e-5046-11e7-89b7-fa163e54c21f

The Date field is from before the package version in the report was
accepted into -proposed. This likely happened because the .crash file
was created and data collection, including adding the Package key, was
done after systemd had been upgraded. This is alluded to in the
UnreportableReason of the OOPS.

UnreportableReason:
Неполадка произошла с программой /lib/systemd/systemd-resolved, в которую были 
внесены изменения с момента её аварийного завершения работы.

It says that systemd-resolved was modified since the error occurred.

As we can see in bug 1621396 this ended up confusing the developer and
they were concerned about their fix not working. It seems like apport or
whoopsie should do something better here.

Ideas include not putting a package version in the Package field if the
binary has been modified, or not uploading the crash to the Error
Tracker if the binary has changed.  The latter would require some
additional work because the UnreportableReason is translated.

** Affects: apport (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1697959

Title:
  late package version collection can cause confusion

Status in apport package in Ubuntu:
  New

Bug description:
  The following OOPS contains some misinformation:

  https://errors.ubuntu.com/oops/3680877e-5046-11e7-89b7-fa163e54c21f

  The Date field is from before the package version in the report was
  accepted into -proposed. This likely happened because the .crash file
  was created and data collection, including adding the Package key, was
  done after systemd had been upgraded. This is alluded to in the
  UnreportableReason of the OOPS.

  UnreportableReason:
  Неполадка произошла с программой /lib/systemd/systemd-resolved, в которую 
были внесены изменения с момента её аварийного завершения работы.

  It says that systemd-resolved was modified since the error occurred.

  As we can see in bug 1621396 this ended up confusing the developer and
  they were concerned about their fix not working. It seems like apport
  or whoopsie should do something better here.

  Ideas include not putting a package version in the Package field if
  the binary has been modified, or not uploading the crash to the Error
  Tracker if the binary has changed.  The latter would require some
  additional work because the UnreportableReason is translated.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1697959/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1695876] Re: German Documentation file displays incorrect CUPS version

2017-06-14 Thread Ivy Alexander
** Patch removed: "debdiff fixes typo"
   
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1695876/+attachment/4895881/+files/lp1695876_xenial.debdiff

** Patch added: "lp1695876_xenial.debdiff"
   
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1695876/+attachment/4895904/+files/lp1695876_xenial.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1695876

Title:
  German Documentation file displays incorrect CUPS version

Status in CUPS:
  Fix Released
Status in cups package in Ubuntu:
  New

Bug description:
  The /doc/de/index.html.in file in the package source has an incorrect
  version number written into a header instead of using '@CUPS_VERSION@'
  to populate this file as in the other languages' version of the same
  file, seemingly resulting in /usr/share/cups/doc-root/de/index.html
  having the wrong version once CUPS is installed:

  ...
  

  CUPS 2.0.2
  ...

  instead of:

  ...
  

  CUPS @CUPS_VERSION@
  ...

  resulting in 'CUPS 2.0.2' instead of 2.1.3 being shown.

To manage notifications about this bug go to:
https://bugs.launchpad.net/cups/+bug/1695876/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1696415] Re: NetworkManager seems to drop IPv4 DHCP lease even though it was successfully renewed

2017-06-14 Thread Sjors Gielen
By setting log_level to DEBUG, I could confirm from the logs that there
is a miscommunication between dhclient and NetworkManager causing this
issue.

It looks like it is not NetworkManager that removes the IPv4 address
from the interface; the address is removed from the interface
automatically by the kernel because its lifetime expired:

jun 13 19:26:21 cuba NetworkManager[28642]:  [1497374781.0763] platform: 
address: adding or updating IPv4 address: 192.168.0.55/24 lft 7200sec pref 
7200sec lifetime 99735-0[7200,7200] dev 3 src unknown
jun 13 19:26:21 cuba NetworkManager[28642]:  [1497374781.0763] platform: 
signal: address 4 changed: 192.168.0.55/24 lft 7200sec pref 7200sec lifetime 
99735-99735[7200,7200] dev 3 src kernel
jun 13 21:26:21 cuba NetworkManager[28642]:  [1497381981.3191] platform: 
signal: address 4 removed: 192.168.0.55/24 lft 0sec pref 0sec lifetime 
106935-99735[7200,7200] dev 3 src kernel

The "address: adding or updating IPv4 address" message comes right after
receiving a message from dhclient, because it sent a DHCPREQUEST and
received a DHCPACK:

jun 13 19:26:21 cuba dhclient[13154]: DHCPREQUEST of 192.168.0.55 on eth1 to 
192.168.0.3 port 67 (xid=0xfd7483b)
jun 13 19:26:21 cuba dhclient[13154]: DHCPACK of 192.168.0.55 from 192.168.0.3
jun 13 19:26:21 cuba NetworkManager[28642]:  [1497374781.0748] 
bus-manager: (dhcp) accepted connection 0x7f9ae000fc60 on private socket
jun 13 19:26:21 cuba NetworkManager[28642]:  [1497374781.0759] dhcp4 
(eth1): DHCP reason 'RENEW' -> state 'bound'

Within the 2 hours lifetime of the IP address, another DHCPREQUEST &
DHCPACK occurs, and some communication is attempted between dhclient and
NetworkManager, but this doesn't result in the state change as seen
above:

jun 13 20:20:11 cuba dhclient[13154]: DHCPREQUEST of 192.168.0.55 on eth1 to 
192.168.0.3 port 67 (xid=0xfd7483b)
jun 13 20:20:11 cuba dhclient[13154]: DHCPACK of 192.168.0.55 from 192.168.0.3
jun 13 20:20:11 cuba NetworkManager[28642]:  [1497378011.6527] 
bus-manager: (dhcp) accepted connection 0x7f9ae0019060 on private socket
jun 13 20:20:11 cuba NetworkManager[28642]:  [1497378011.6527] 
bus-manager: (dhcp) closed connection 0x7f9ae0019060 on private socket
jun 13 20:20:11 cuba dhclient[13154]: bound to 192.168.0.55 -- renewal in 2731 
seconds.

So, crucially, there is an attempted communication between dhclient and
NetworkManager, but this doesn't result in an update to the lifetime of
the IPv4 address. I'll focus my investigation on this. I would
appreciate a reply from maintainers or upstream that they are aware of
this issue.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1696415

Title:
  NetworkManager does not update IPv4 address lifetime even though DHCP
  lease was successfully renewed

Status in network-manager package in Ubuntu:
  New

Bug description:
  I've found an issue on some of our Xenial office machines, causing
  NetworkManager to drop its IP address lease in some cases when it
  shouldn't. I'm not sure if the actual bug is in NetworkManager or
  perhaps dbus or dhclient, but I'll do my best to help to figure out
  where it is.

  What appears to happen:
  * NetworkManager is informed of a new IPv4 lease.
  * During the lease, dhclient keeps it fresh by renewing it using DHCPREQUESTs 
regularly.
  * In spite of this, NetworkManager drops the IP address from the interface 
when the last reported lease time expires.

  This happens on various machines, once every few days. We are using a
  failover DHCP configuration using two machines (192.168.0.3 'bonaire'
  and 192.168.0.4 'curacao').



  The machine where I've done the debugging is called 'pampus'
  (192.168.0.166). As you can see in the logs, at 01:21:06
  NetworkManager reports a new lease with lease time 7200.

  jun 07 01:21:06 pampus dhclient[1532]: DHCPREQUEST of 192.168.0.166 on eth0 
to 192.168.0.4 port 67 (xid=0x3295b440)
  jun 07 01:21:06 pampus dhclient[1532]: DHCPACK of 192.168.0.166 from 
192.168.0.4
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
address 192.168.0.166
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   plen 
24 (255.255.255.0)
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
gateway 192.168.0.5
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
server identifier 192.168.0.4
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
lease time 7200
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
nameserver '192.168.0.3'
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
nameserver '192.168.0.4'
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9530]   
domain name 'office.screenpointmed.com'
  jun 07 01:21:06 pampus NetworkManager[1161]:   [1496791266.9531] dhcp4 
(eth0): state changed bound -> bound

  After 

[Touch-packages] [Bug 1686189] Re: External monitor connecting problem on Intel graphics card

2017-06-14 Thread Robert David
@Kai-Heng

Sorry for delay - been off work due to injury :(

lsmod | grep i915:

rodavid@rodavid-Latitude-E7250:~$ lsmod | grep i915
i915 1208320  5
i2c_algo_bit   16384  1 i915
drm_kms_helper155648  1 i915
drm   364544  6 i915,drm_kms_helper
video  40960  3 i915,dell_wmi,dell_laptop


Drivers 4.4.0-73 ~ 4.4.0-77 all seem to have the monitor issues.  72 has been 
the only one I can reliably use.  Some of them "seem to work" after messing 
with the settings, but any time the screen goes to sleep, it almost never comes 
back and sometimes the machine will actually lock up forcing me to power off.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1686189

Title:
  External monitor connecting problem on Intel graphics card

Status in linux package in Ubuntu:
  Confirmed
Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  I am facing a problem with Intel Graphics driver. I have external
  monitor and in display settings the second monitor is detecting but
  it's not working, so could you email me a solution.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  Uname: Linux 4.4.25-040425-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Tue Apr 25 21:45:16 2017
  DistUpgraded: 2017-04-25 21:07:40,819 DEBUG icon theme changed, re-reading
  DistroCodename: xenial
  DistroVariant: ubuntu
  DkmsStatus: i915-4.6.3-4.4.0, 1, 4.4.0-75-generic, x86_64: installed
  GraphicsCard:
   Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] 
(rev 09) (prog-if 00 [VGA controller])
 Subsystem: Dell Haswell-ULT Integrated Graphics Controller [1028:05e9]
  InstallationDate: Installed on 2017-04-25 (0 days ago)
  InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
  MachineType: Dell Inc. Inspiron 3537
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.25-040425-generic 
root=UUID=3914e6d5-5c87-4816-8043-776ef4184d29 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to xenial on 2017-04-25 (0 days ago)
  dmi.bios.date: 04/30/2014
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A08
  dmi.board.name: 03JPPR
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: A08
  dmi.modalias: 
dmi:bvnDellInc.:bvrA08:bd04/30/2014:svnDellInc.:pnInspiron3537:pvrA08:rvnDellInc.:rn03JPPR:rvrA00:cvnDellInc.:ct8:cvrA08:
  dmi.product.name: Inspiron 3537
  dmi.product.version: A08
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.70-1~ubuntu16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.6-0ubuntu0.16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.6-0ubuntu0.16.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1.2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2
  xserver.bootTime: Tue Apr 25 21:37:24 2017
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id   17900 
   vendor AUO
  xserver.version: 2:1.18.4-0ubuntu0.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1686189/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Steve Langasek
On Wed, Jun 14, 2017 at 10:04:28AM -, Stefan Bader wrote:
> Sorry, forgot above:

> #> cat /run/systemd/network/10-netplan-eth0.network 
> [Match]
> Name=eth0

> [Network]
> DHCP=ipv4

> [DHCP]
> RouteMetric=100

I know you say this is also reproducible for you when using ensX names, but
for completeness, why do you have eth0 here?  That's not a name that should
be appearing anywhere on an artful system, unless you've set net.ifnames=0,
which is strongly discouraged.


On Wed, Jun 14, 2017 at 07:37:50AM -, Stefan Bader wrote:
> @Steve, yes it does. And if the wait is related to the list of NICs from
> ifquery, it does make sense (in some way) as that list only contains
> "lo", not "eth0". Also "ifquery --state eth0" does not return anything
> while it does return "lo=lo" for "lo".

networkd doesn't care at all about ifquery.  systemd-networkd-wait-online(8)
documents that this should return as soon as "all links it is aware of and
which are managed by systemd-network [are] fully configured or failed, and
[...] at least one link [gains] a carrier."

So this is definitely not working as designed, if you have only a single
interface configured in systemd-network and its link is up, but -wait-online
is not returning success.

-- 
Steve Langasek   Give me a lever long enough and a Free OS
Debian Developer   to set it on, and I can move the world.
Ubuntu Developerhttp://www.debian.org/
slanga...@ubuntu.com vor...@debian.org

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : 

[Touch-packages] [Bug 1557157] Re: apparmor profile denied for saslauthd: /run/saslauthd/mux

2017-06-14 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: openldap (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1557157

Title:
  apparmor profile denied for saslauthd: /run/saslauthd/mux

Status in openldap package in Ubuntu:
  Confirmed

Bug description:
  When using slapd with saslauthd the processes communicate via the
  {,/var}/run/saslauthd/mux socket (this is the default location for the
  saslauthd server from the sasl2-bin package in the
  /etc/default/saslauthd config), but the apparmor profile for
  usr.sbin.slapd does not allow access to this socket/file.

  Syslog message:
  apparmor="DENIED" operation="connect" profile="/usr/sbin/slapd" 
name="/run/saslauthd/mux" pid=1880
  4 comm="slapd" requested_mask="r" denied_mask="r" fsuid=108 ouid=0

  
  Please add the following line to  /etc/apparmor.d/usr.sbin.slapd:
  /{,var/}run/saslauthd/mux rw,

  
  Ubuntu version: Ubuntu 14.04.4 LTS
  slapd version: 2.4.31-1+nmu2ubu

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1557157/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1630516] Re: Logrotate doesn't clean old system logs, allowing them to fill the disk

2017-06-14 Thread Chris J Arges
Also validated on Yakkety.

** Tags added: verification-done-yakkety

** Tags removed: verification-needed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to logrotate in Ubuntu.
https://bugs.launchpad.net/bugs/1630516

Title:
  Logrotate doesn't clean old system logs, allowing them to fill the
  disk

Status in One Hundred Papercuts:
  Triaged
Status in logrotate package in Ubuntu:
  Fix Released
Status in logrotate source package in Trusty:
  Fix Committed
Status in logrotate source package in Xenial:
  Fix Released
Status in logrotate source package in Yakkety:
  Fix Committed
Status in logrotate source package in Zesty:
  Fix Released
Status in logrotate package in Debian:
  Fix Released

Bug description:
  [Impact]

  Logrotate fails to rotate a log and then will continue to fail to
  rotate it until manual intervention takes place. If messaging has not
  been configured on the system there will be no warning issued to the
  user. The log will grow day by day until a user intervenes or the
  drive that the log is stored on is full.

  Very large log files can make it more difficult to find useful data.
  Full drives make the rest of the system fail to operate. Backporting a
  fix would prevent drives filling up on stable releases.

  [Test Case]

  Go to your logs area (/var/logs) and create a file with a name ending
  .2, as would be created part way through the logrotate process. So if
  you have /var/log/syslog, /var/log/syslog.1, /var/log/syslog.2.gz,
  /var/log/syslog.3.gz; create a new file named /var/log/syslog.2. Your
  subsequent log rotate runs will fail.

  [Regression Potential]

  - I'd hope the potential is low as it only triggers under certain conditions 
that are special (target filename in the way).
  - So far in those conditions it failed to rotate
  - Yet If despite my hope there still manifests an issue I'd expect it could 
be renaming files it should not, so people would end up "missing" their logs - 
the good thing is that this is a rename, so they should find it at different 
names.
  - Another thing I consider possible is that some unexpected conditions cause 
e.g. a crash in the changed code, in that case the logs are not rotated, but 
since there is no unlink the logs will still exist.
  - Therefore I consider the Potential low enough to consider the fix.

  [Other Info]
  n/a

  ---

  Good afternoon.
  I have started seeing something very similar to Debian Dug 734688 "Logs are 
not rotated for a month" but in the latest Ubuntu LTS (16.04).  I seem to have
  $ logrotate --version
  logrotate 3.8.7
  bundled in it.  A few weeks ago I started getting root emails such as this:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && 
run-parts --report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/munin/munin-node.log.1: File 
exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  When I inspected the area of concern I was able to see that there was an 
existing .1 file.
  manager@warden:/var/log/munin$ ll
  total 580
  drwxr-xr-x  2 munin adm  4096 Sep 27 06:31 ./
  drwxr-xr-x 13 root  syslog   4096 Oct  5 06:26 ../
  -rw-r--r--  1 root  root 3440 Sep 26 13:39 munin-node-configure.log
  -rw-r--r--  1 root  root   490251 Oct  5 10:25 munin-node.log
  -rw-r--r--  1 root  root56598 Sep 21 02:01 munin-node.log.1
  -rw-r--r--  1 root  root24576 Aug 31 02:01 munin-node.log.2
  -rw-r--r--  1 root  root 1906 Sep 19 06:25 munin-node.log.8.gz
  The contents of the munin-node.log file seem to run from the 19th September 
until today.  Unlike other parts of this bug the .1 and .2 files do not seem to 
be already compressed.

  I deleted all but the munin-node.log file to see if it would resolve the 
problem and was going to leave it at that.  Then I noticed that I have had 
another Ubuntu machine which has been sending similar emails for the past week:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && run-parts 
--report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/syslog.1.gz: File exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  Different file, different machine but a very similar error message.

  Checking on the syslog file I can see that it better fits with other reports 
on this bug as my duplicated .1 files has a corresponding .1.gz file.
  manager@trac:/var/log$ ll syslog*
  -rw-r- 1 syslog adm 918492 Oct  5 10:30 syslog
  -rw-r- 1 syslog adm 125819 Sep 30 06:25 syslog.1
  -rw-r- 1 syslog adm  20638 Oct  2 02:01 syslog.1.gz
  -rw-r- 1 syslog adm  41989 Sep 30 02:00 syslog.2.gz
  -rw-r- 1 syslog adm  18654 Sep 28 02:01 syslog.3.gz
  -rw-r- 1 syslog adm  31720 Sep 26 06:40 syslog.4.gz
  -rw-r- 1 syslog adm  33151 Sep 25 02:01 syslog.5.gz
  -rw-r- 1 syslog adm  17290 Sep 23 

[Touch-packages] [Bug 1621396] Re: systemd-resolved crashed with SIGSEGV in dns_packet_is_reply_for()

2017-06-14 Thread Brian Murray
Its worth noting that apport creates an initial .crash file without much
information in it, after the user chooses to send the crash to the Error
Tracker then some information gathering is performed. This information
gathering stage includes adding the version of the package. Looking at
the particular instance,
https://errors.ubuntu.com/oops/3680877e-5046-11e7-89b7-fa163e54c21f,
with the version of the package from -proposed a couple of things stand
out.

Date: Thu Jun 8 12:35:23 2017

This is before the package was accepted into -proposed.  Additionally
there is this:

UnreportableReason: 
Неполадка произошла с программой /lib/systemd/systemd-resolved, в которую были 
внесены изменения с момента её аварийного завершения работы.

So this is not a genuine crash with the version of the package from
-proposed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1621396

Title:
  systemd-resolved crashed with SIGSEGV in dns_packet_is_reply_for()

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Xenial:
  Confirmed
Status in systemd source package in Yakkety:
  Confirmed
Status in systemd source package in Zesty:
  Fix Committed

Bug description:
  [Impact]

   * Null-pointer dereference in resolved, results in resolved crash and
  reports on launchpad and errors.

  [Test Case]

   * Unknown steps to reproduce
   * Monitor the drop off in crashes on errors.ubuntu.com:
  https://errors.ubuntu.com/problem/ea90aefe098653f44b46e56d72e2cc05ff980465

  [Regression Potential]

   * The behavior is similar, instead of crashing resolved it returns an
  error in the relevant function. Whilst this may not result in correct
  dns resolution for the affected dns packets, it should not result in
  resolved crashes.

  [Original Bug Report]

  This is one of background errors that happens without any active app being 
involved.
  For the records, I had open: Firefox, Slack, Franz and the Terminal

  The Ubuntu Error Tracker has been receiving reports about a problem regarding 
systemd. This problem was most recently seen with package version 233-6ubuntu2, 
the problem page at 
https://errors.ubuntu.com/problem/ea90aefe098653f44b46e56d72e2cc05ff980465 
contains more details, including versions of packages affected, stacktrace or 
traceback, and individual crash reports.
  If you do not have access to the Ubuntu Error Tracker you can request it at 
http://forms.canonical.com/reports/.

  ProblemType: Crash
  DistroRelease: Ubuntu 16.10
  Package: systemd 231-5
  ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
  Uname: Linux 4.4.0-9136-generic x86_64
  ApportVersion: 2.20.3-0ubuntu7
  Architecture: amd64
  CrashCounter: 1
  Date: Thu Sep  8 09:33:55 2016
  ExecutablePath: /lib/systemd/systemd-resolved
  InstallationDate: Installed on 2013-06-06 (1189 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
  MachineType: Dell Inc. Dell System XPS L322X
  ProcCmdline: /lib/systemd/systemd-resolved
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-9136-generic 
root=UUID=2850be62-a05e-4ab9-af2b-5f1fd159ce5d ro quiet splash vt.handoff=7
  Signal: 11
  SourcePackage: systemd
  StacktraceTop:
   ?? ()
   ?? ()
   ?? () from /lib/systemd/libsystemd-shared-231.so
   sd_event_dispatch () from /lib/systemd/libsystemd-shared-231.so
   sd_event_run () from /lib/systemd/libsystemd-shared-231.so
  Title: systemd-resolved crashed with SIGSEGV in sd_event_dispatch()
  UpgradeStatus: Upgraded to yakkety on 2016-09-03 (4 days ago)
  UserGroups:

  dmi.bios.date: 04/18/2013
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A08
  dmi.board.name: 0PJHXN
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: 0.1
  dmi.modalias: 
dmi:bvnDellInc.:bvrA08:bd04/18/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn0PJHXN:rvrA00:cvnDellInc.:ct8:cvr0.1:
  dmi.product.name: Dell System XPS L322X
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1621396/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1695876] Re: German Documentation file displays incorrect CUPS version

2017-06-14 Thread Ivy Alexander
Patch with the fix.

** Patch added: "debdiff fixes typo"
   
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1695876/+attachment/4895881/+files/lp1695876_xenial.debdiff

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1695876

Title:
  German Documentation file displays incorrect CUPS version

Status in CUPS:
  Fix Released
Status in cups package in Ubuntu:
  New

Bug description:
  The /doc/de/index.html.in file in the package source has an incorrect
  version number written into a header instead of using '@CUPS_VERSION@'
  to populate this file as in the other languages' version of the same
  file, seemingly resulting in /usr/share/cups/doc-root/de/index.html
  having the wrong version once CUPS is installed:

  ...
  

  CUPS 2.0.2
  ...

  instead of:

  ...
  

  CUPS @CUPS_VERSION@
  ...

  resulting in 'CUPS 2.0.2' instead of 2.1.3 being shown.

To manage notifications about this bug go to:
https://bugs.launchpad.net/cups/+bug/1695876/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1630516] Re: Logrotate doesn't clean old system logs, allowing them to fill the disk

2017-06-14 Thread Chris J Arges
I have validated the trusty version works as expected! Thanks

** Tags added: verification-done-trusty

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to logrotate in Ubuntu.
https://bugs.launchpad.net/bugs/1630516

Title:
  Logrotate doesn't clean old system logs, allowing them to fill the
  disk

Status in One Hundred Papercuts:
  Triaged
Status in logrotate package in Ubuntu:
  Fix Released
Status in logrotate source package in Trusty:
  Fix Committed
Status in logrotate source package in Xenial:
  Fix Released
Status in logrotate source package in Yakkety:
  Fix Committed
Status in logrotate source package in Zesty:
  Fix Released
Status in logrotate package in Debian:
  Fix Released

Bug description:
  [Impact]

  Logrotate fails to rotate a log and then will continue to fail to
  rotate it until manual intervention takes place. If messaging has not
  been configured on the system there will be no warning issued to the
  user. The log will grow day by day until a user intervenes or the
  drive that the log is stored on is full.

  Very large log files can make it more difficult to find useful data.
  Full drives make the rest of the system fail to operate. Backporting a
  fix would prevent drives filling up on stable releases.

  [Test Case]

  Go to your logs area (/var/logs) and create a file with a name ending
  .2, as would be created part way through the logrotate process. So if
  you have /var/log/syslog, /var/log/syslog.1, /var/log/syslog.2.gz,
  /var/log/syslog.3.gz; create a new file named /var/log/syslog.2. Your
  subsequent log rotate runs will fail.

  [Regression Potential]

  - I'd hope the potential is low as it only triggers under certain conditions 
that are special (target filename in the way).
  - So far in those conditions it failed to rotate
  - Yet If despite my hope there still manifests an issue I'd expect it could 
be renaming files it should not, so people would end up "missing" their logs - 
the good thing is that this is a rename, so they should find it at different 
names.
  - Another thing I consider possible is that some unexpected conditions cause 
e.g. a crash in the changed code, in that case the logs are not rotated, but 
since there is no unlink the logs will still exist.
  - Therefore I consider the Potential low enough to consider the fix.

  [Other Info]
  n/a

  ---

  Good afternoon.
  I have started seeing something very similar to Debian Dug 734688 "Logs are 
not rotated for a month" but in the latest Ubuntu LTS (16.04).  I seem to have
  $ logrotate --version
  logrotate 3.8.7
  bundled in it.  A few weeks ago I started getting root emails such as this:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && 
run-parts --report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/munin/munin-node.log.1: File 
exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  When I inspected the area of concern I was able to see that there was an 
existing .1 file.
  manager@warden:/var/log/munin$ ll
  total 580
  drwxr-xr-x  2 munin adm  4096 Sep 27 06:31 ./
  drwxr-xr-x 13 root  syslog   4096 Oct  5 06:26 ../
  -rw-r--r--  1 root  root 3440 Sep 26 13:39 munin-node-configure.log
  -rw-r--r--  1 root  root   490251 Oct  5 10:25 munin-node.log
  -rw-r--r--  1 root  root56598 Sep 21 02:01 munin-node.log.1
  -rw-r--r--  1 root  root24576 Aug 31 02:01 munin-node.log.2
  -rw-r--r--  1 root  root 1906 Sep 19 06:25 munin-node.log.8.gz
  The contents of the munin-node.log file seem to run from the 19th September 
until today.  Unlike other parts of this bug the .1 and .2 files do not seem to 
be already compressed.

  I deleted all but the munin-node.log file to see if it would resolve the 
problem and was going to leave it at that.  Then I noticed that I have had 
another Ubuntu machine which has been sending similar emails for the past week:
  > Subject: Cron  test -x /usr/sbin/anacron || ( cd / && run-parts 
--report /etc/cron.daily )
  >
  > /etc/cron.daily/logrotate:
  > error: error creating output file /var/log/syslog.1.gz: File exists
  > run-parts: /etc/cron.daily/logrotate exited with return code 1
  Different file, different machine but a very similar error message.

  Checking on the syslog file I can see that it better fits with other reports 
on this bug as my duplicated .1 files has a corresponding .1.gz file.
  manager@trac:/var/log$ ll syslog*
  -rw-r- 1 syslog adm 918492 Oct  5 10:30 syslog
  -rw-r- 1 syslog adm 125819 Sep 30 06:25 syslog.1
  -rw-r- 1 syslog adm  20638 Oct  2 02:01 syslog.1.gz
  -rw-r- 1 syslog adm  41989 Sep 30 02:00 syslog.2.gz
  -rw-r- 1 syslog adm  18654 Sep 28 02:01 syslog.3.gz
  -rw-r- 1 syslog adm  31720 Sep 26 06:40 syslog.4.gz
  -rw-r- 1 syslog adm  33151 Sep 25 02:01 syslog.5.gz
  -rw-r- 1 syslog adm  17290 Sep 23 02:01 

[Touch-packages] [Bug 1697789] Re: Xorg: page allocation failure: order:0, mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE), nodemask=(null)

2017-06-14 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: xorg (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1697789

Title:
  Xorg: page allocation failure: order:0,
  mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE),
  nodemask=(null)

Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  dmesg:
  [23559.058500] Xorg: page allocation failure: order:0, 
mode:0x14210d2(GFP_HIGHUSER|__GFP_NORETRY|__GFP_RECLAIMABLE), nodemask=(null)
  [23559.058509] Xorg cpuset=/ mems_allowed=0
  [23559.058516] CPU: 1 PID: 1797 Comm: Xorg Not tainted 
4.12.0-041200rc5-generic #201706112031
  [23559.058517] Hardware name: SAMSUNG ELECTRONICS CO., LTD. 
530U3C/530U4C/SAMSUNG_NP1234567890, BIOS P14AAJ 04/15/2013
  [23559.058519] Call Trace:
  [23559.058528]  dump_stack+0x63/0x8d
  [23559.058532]  warn_alloc+0x114/0x1c0
  [23559.058535]  __alloc_pages_slowpath+0xe07/0xe10
  [23559.058539]  __alloc_pages_nodemask+0x233/0x250
  [23559.058543]  alloc_pages_vma+0xab/0x250
  [23559.058547]  shmem_alloc_page+0x70/0xc0
  [23559.058550]  ? __radix_tree_insert+0x45/0x220
  [23559.058553]  ? __vm_enough_memory+0x29/0x130
  [23559.058555]  shmem_alloc_and_acct_page+0x72/0x1b0
  [23559.058558]  ? find_get_entry+0x1e/0xc0
  [23559.058561]  shmem_getpage_gfp+0x195/0xbd0
  [23559.058564]  shmem_read_mapping_page_gfp+0x44/0x80
  [23559.058611]  i915_gem_object_get_pages_gtt+0x204/0x5a0 [i915]
  [23559.058643]  i915_gem_object_get_pages+0x20/0x60 [i915]
  [23559.058673]  __i915_gem_object_get_pages+0x5c/0x70 [i915]
  [23559.058706]  __i915_vma_do_pin+0x1c6/0x3a0 [i915]
  [23559.058737]  i915_gem_execbuffer_reserve_vma.isra.29+0x14d/0x1b0 [i915]
  [23559.058765]  i915_gem_execbuffer_reserve.isra.30+0x3b7/0x3e0 [i915]
  [23559.058794]  i915_gem_do_execbuffer.isra.36+0x577/0x16c0 [i915]
  [23559.058799]  ? unix_stream_recvmsg+0x54/0x70
  [23559.058801]  ? unix_state_double_lock+0x70/0x70
  [23559.058830]  i915_gem_execbuffer2+0x96/0x1b0 [i915]
  [23559.058849]  drm_ioctl+0x216/0x4c0 [drm]
  [23559.058877]  ? i915_gem_execbuffer+0x2f0/0x2f0 [i915]
  [23559.058881]  ? __remove_hrtimer+0x3c/0x70
  [23559.058885]  do_vfs_ioctl+0xa3/0x600
  [23559.05]  ? do_setitimer+0xe0/0x240
  [23559.058891]  ? SyS_setitimer+0xf1/0x120
  [23559.058894]  SyS_ioctl+0x79/0x90
  [23559.058897]  entry_SYSCALL_64_fastpath+0x1e/0xa9
  [23559.058900] RIP: 0033:0x7fd8c5c7e987
  [23559.058901] RSP: 002b:7ffd494ac738 EFLAGS: 0246 ORIG_RAX: 
0010
  [23559.058904] RAX: ffda RBX: 0006 RCX: 
7fd8c5c7e987
  [23559.058905] RDX: 7ffd494ac790 RSI: 40406469 RDI: 
000c
  [23559.058907] RBP: 0028 R08: 0001 R09: 
000c
  [23559.058908] R10: 0001 R11: 0246 R12: 
0040
  [23559.058909] R13: 0008 R14: 5581c086a6c0 R15: 

  [23559.058912] Mem-Info:
  [23559.058918] active_anon:1016643 inactive_anon:298858 isolated_anon:0
  active_file:395940 inactive_file:1147459 isolated_file:0
  unevictable:129 dirty:124022 writeback:21146 unstable:0
  slab_reclaimable:57926 slab_unreclaimable:23062
  mapped:283483 shmem:248113 pagetables:23247 bounce:0
  free:29069 free_pcp:245 free_cma:0
  [23559.058923] Node 0 active_anon:4066572kB inactive_anon:1195432kB 
active_file:1583760kB inactive_file:4589836kB unevictable:516kB 
isolated(anon):0kB isolated(file):0kB mapped:1133932kB dirty:496088kB 
writeback:84584kB shmem:992452kB shmem_thp: 0kB shmem_pmdmapped: 0kB anon_thp: 
976896kB writeback_tmp:0kB unstable:0kB all_unreclaimable? no
  [23559.058924] Node 0 DMA free:15360kB min:84kB low:104kB high:124kB 
active_anon:0kB inactive_anon:0kB active_file:0kB inactive_file:0kB 
unevictable:0kB writepending:0kB present:15984kB managed:15360kB mlocked:0kB 
slab_reclaimable:0kB slab_unreclaimable:0kB kernel_stack:0kB pagetables:0kB 
bounce:0kB free_pcp:0kB local_pcp:0kB free_cma:0kB
  [23559.058930] lowmem_reserve[]: 0 3226 11726 11726 11726
  [23559.058935] Node 0 DMA32 free:52176kB min:18568kB low:23208kB high:27848kB 
active_anon:718716kB inactive_anon:177564kB active_file:228516kB 
inactive_file:2067540kB unevictable:0kB writepending:203112kB present:3438520kB 
managed:3354852kB mlocked:0kB slab_reclaimable:98764kB 
slab_unreclaimable:3004kB kernel_stack:576kB pagetables:4384kB bounce:0kB 
free_pcp:0kB local_pcp:0kB free_cma:0kB
  [23559.058941] lowmem_reserve[]: 0 0 8500 8500 8500
  [23559.058945] Node 0 Normal free:48740kB min:48924kB low:61152kB 
high:73380kB active_anon:3347648kB inactive_anon:1017448kB 
active_file:1354180kB inactive_file:2521736kB unevictable:516kB 
writepending:377444kB present:8902656kB managed:8704148kB mlocked:516kB 

[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Ryan Harper
This is annoying:

% journalctl -D var/log/journal -o short-precise Journal file
var/log/journal/1fe5c5ed88c14c81bd52acb9f96f3a18/system.journal uses an
unsupported feature, ignoring file.
-- No entries --

Why can't xenial systemd journalctl read an artful one?  That seems like a
terrible idea w.r.t features here;  are we enabling new features that we
can't read outside of the same distro release?

https://bugzilla.redhat.com/show_bug.cgi?id=1413388

We should get this fixed when it;s available.  Or disable the LZ4 for
compat until it's done


On Wed, Jun 14, 2017 at 5:04 AM, Stefan Bader 
wrote:

> Sorry, forgot above:
>
> #> cat /run/systemd/network/10-netplan-eth0.network
> [Match]
> Name=eth0
>
> [Network]
> DHCP=ipv4
>
> [DHCP]
> RouteMetric=100
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1697730
>
> Title:
>   Long boot time due to systemd-networkd-wait-online.service failure
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/
> 1697730/+subscriptions
>


** Bug watch added: Red Hat Bugzilla #1413388
   https://bugzilla.redhat.com/show_bug.cgi?id=1413388

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697397] Re: libldap-2.4.42+dfsg-2ubuntu3.2 crashes libreoffice

2017-06-14 Thread jack
Output of "dpkg-query -l libreoffice-calc libreoffice-core"

** Attachment added: "dpkq-query"
   
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1697397/+attachment/4895847/+files/dpkq-query

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1697397

Title:
  libldap-2.4.42+dfsg-2ubuntu3.2 crashes libreoffice

Status in libreoffice package in Ubuntu:
  Incomplete
Status in openldap package in Ubuntu:
  Incomplete

Bug description:
  Running xubuntu xenial, and after a recent upgrade w/ the following:
  libldap-2.4-2:i386 (2.4.42+dfsg-2ubuntu3.2) over (2.4.42+dfsg-2ubuntu3.1)

  all libreoffice applications (calc, writer, etc) crash on start, with
  the following error:

  /usr/lib/libreoffice/program/soffice.bin: symbol lookup error:
  /usr/lib/libreoffice/program/../program/libsclo.so: undefined symbol:
  _ZN9ScrollBar8SetRangeERK5Range

  
  after investigating, i figured out it seems to be linked to the libldap 
upgrade, and indeed as a temporary workaround downgrading to 
2.4.42+dfsg-2ubuntu3 allows libreoffice to work again.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1697397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697397] Re: libldap-2.4.42+dfsg-2ubuntu3.2 crashes libreoffice

2017-06-14 Thread jack
Last transactions from /var/log/apt/history.log

** Attachment added: "history.log"
   
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1697397/+attachment/4895846/+files/history.log

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1697397

Title:
  libldap-2.4.42+dfsg-2ubuntu3.2 crashes libreoffice

Status in libreoffice package in Ubuntu:
  Incomplete
Status in openldap package in Ubuntu:
  Incomplete

Bug description:
  Running xubuntu xenial, and after a recent upgrade w/ the following:
  libldap-2.4-2:i386 (2.4.42+dfsg-2ubuntu3.2) over (2.4.42+dfsg-2ubuntu3.1)

  all libreoffice applications (calc, writer, etc) crash on start, with
  the following error:

  /usr/lib/libreoffice/program/soffice.bin: symbol lookup error:
  /usr/lib/libreoffice/program/../program/libsclo.so: undefined symbol:
  _ZN9ScrollBar8SetRangeERK5Range

  
  after investigating, i figured out it seems to be linked to the libldap 
upgrade, and indeed as a temporary workaround downgrading to 
2.4.42+dfsg-2ubuntu3 allows libreoffice to work again.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1697397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697397] Re: libldap-2.4.42+dfsg-2ubuntu3.2 crashes libreoffice

2017-06-14 Thread jack
Output of "ldd /usr/lib/libreoffice/program/soffice.bin"

** Attachment added: "ldd"
   
https://bugs.launchpad.net/ubuntu/+source/openldap/+bug/1697397/+attachment/4895848/+files/ldd

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1697397

Title:
  libldap-2.4.42+dfsg-2ubuntu3.2 crashes libreoffice

Status in libreoffice package in Ubuntu:
  Incomplete
Status in openldap package in Ubuntu:
  Incomplete

Bug description:
  Running xubuntu xenial, and after a recent upgrade w/ the following:
  libldap-2.4-2:i386 (2.4.42+dfsg-2ubuntu3.2) over (2.4.42+dfsg-2ubuntu3.1)

  all libreoffice applications (calc, writer, etc) crash on start, with
  the following error:

  /usr/lib/libreoffice/program/soffice.bin: symbol lookup error:
  /usr/lib/libreoffice/program/../program/libsclo.so: undefined symbol:
  _ZN9ScrollBar8SetRangeERK5Range

  
  after investigating, i figured out it seems to be linked to the libldap 
upgrade, and indeed as a temporary workaround downgrading to 
2.4.42+dfsg-2ubuntu3 allows libreoffice to work again.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1697397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697397] Re: libldap-2.4.42+dfsg-2ubuntu3.2 crashes libreoffice

2017-06-14 Thread jack
Alright, attached the different info as requested.

As previously said, only downgrading libldap allowed for libreoffice to
work again... despite how odd it may seem/be. Not sure why, or how
amazed you are, but there we are ;)

Thanks for looking into this, let me know if I can help some more.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1697397

Title:
  libldap-2.4.42+dfsg-2ubuntu3.2 crashes libreoffice

Status in libreoffice package in Ubuntu:
  Incomplete
Status in openldap package in Ubuntu:
  Incomplete

Bug description:
  Running xubuntu xenial, and after a recent upgrade w/ the following:
  libldap-2.4-2:i386 (2.4.42+dfsg-2ubuntu3.2) over (2.4.42+dfsg-2ubuntu3.1)

  all libreoffice applications (calc, writer, etc) crash on start, with
  the following error:

  /usr/lib/libreoffice/program/soffice.bin: symbol lookup error:
  /usr/lib/libreoffice/program/../program/libsclo.so: undefined symbol:
  _ZN9ScrollBar8SetRangeERK5Range

  
  after investigating, i figured out it seems to be linked to the libldap 
upgrade, and indeed as a temporary workaround downgrading to 
2.4.42+dfsg-2ubuntu3 allows libreoffice to work again.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1697397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1575614] Re: [SRU]Can't select p12 secret key for TLS auth for 802.1X authentication

2017-06-14 Thread Martin Dünkelmann
Network-Manager Version 1.2.2-0ubuntu0.16.04.4
Linux Mint 18.1 based on Ubuntu 16.04

Same Problem.

*.key File is invisible in the gui

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1575614

Title:
  [SRU]Can't select p12 secret key for TLS auth for 802.1X
  authentication

Status in NetworkManager:
  Fix Released
Status in network-manager package in Ubuntu:
  Fix Released
Status in network-manager-applet package in Ubuntu:
  Fix Released
Status in network-manager source package in Xenial:
  Fix Released
Status in network-manager-applet source package in Xenial:
  Fix Released

Bug description:
  [Impact]

  Users cannot select TLS certificate when connecting to a network that
  requires TLS type 802.1X authentication

  [Test case]
  STR:
  1. Click on Connections icon in status panel
  2. Click on Edit connections
  3. Select Wired connection
  4. Go to 802.1x tab
  5. Check the Use 802.1X checkbox
  6. Choose TLS
  7. Click on Secret key button
  8. In file chooser navigate to the folder where key is located and try to 
select key file - the list is empty

  For wifi connection:
  1. Click on Connections icon in status panel
  2. Click on Edit connections
  3. Select Wi-Fi connection
  4. Go to Wi-Fi Security tab
  5. Select WPA & WPA2 Enterprise in the drop-down list
  6. Choose TLS
  7. Click on (None) next to Private key
  8. In file chooser navigate to the folder where key is located and try to 
select key file - the list is empty

  [Regression Potential]
  The fix is quite straight forward and the possibility of causing regression 
is limited.

To manage notifications about this bug go to:
https://bugs.launchpad.net/network-manager/+bug/1575614/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1109029] Re: Depend on linux-initramfs-tool

2017-06-14 Thread ChristianEhrhardt
I discussed the multipath-tools dependency in the context of Debian.
But for multipath it really is a dependency.
The bug will soon switch to closed (wont'fix)

Yet OTOH it only is that for multiapth-tools-boot and kpartx-boot.
These are optional installs - even multipath-tools only suggests that.
But these packages don't work correctly anymore if you switch to dracut.
Due to that it is "correct" to have a hard dependency.

Yet your need to be able to install dracut is fulfilled.
Only users who explicitly picked multipath-tools-boot will have to decide what 
they want.
The other packages are fixed.

** Changed in: multipath-tools (Ubuntu)
   Status: Confirmed => Won't Fix

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to kbd in Ubuntu.
https://bugs.launchpad.net/bugs/1109029

Title:
  Depend on linux-initramfs-tool

Status in apparmor package in Ubuntu:
  Fix Released
Status in console-setup package in Ubuntu:
  Fix Released
Status in kbd package in Ubuntu:
  Fix Released
Status in linux package in Ubuntu:
  Fix Released
Status in lvm2 package in Ubuntu:
  Invalid
Status in multipath-tools package in Ubuntu:
  Won't Fix
Status in plymouth package in Ubuntu:
  Fix Released
Status in ubuntu-meta package in Ubuntu:
  Invalid
Status in udev package in Ubuntu:
  Invalid
Status in watershed package in Ubuntu:
  Fix Released
Status in multipath-tools package in Debian:
  New

Bug description:
  Many core packages depend on initramfs-tools when they should actually
  depend on linux-initramfs-tool (virtual package provided by initramfs-
  tools and dracut).

  Debian seems to be using "Depends: initramfs-tools | linux-initramfs-
  tool" for almost every relevant package.

  See also bug #1108987, which is about the fact that dracut shouldn't
  conflict with initramfs-tools.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1109029/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697929] WifiSyslog.txt

2017-06-14 Thread Volodymyr Babchuk
apport information

** Attachment added: "WifiSyslog.txt"
   
https://bugs.launchpad.net/bugs/1697929/+attachment/4895843/+files/WifiSyslog.txt

** Package changed: linux (Ubuntu) => xorg (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1697929

Title:
  Memory leak in xorg.

Status in xorg package in Ubuntu:
  New

Bug description:
  Seems that xorg has a memory leak. On 28th day of uptime it consumes
  13G of virtualy memory on my PC:

  
   PID USER  PR  NIVIRTRESSHR S  %CPU %MEM TIME+ COMMAND
 
  21516 root  20   0 13,340g 8,351g  49036 S   7,3 53,7   3387:19 Xorg  
  

  xrestop does not show anything suspicious:

  xrestop - Display: localhost
Monitoring 23 clients. XErrors: 0
Pixmaps:  171661K total, Other: 138K total, All:  171800K total

  res-base Wins  GCs Fnts Pxms Misc   Pxm mem  Other   Total   PID Identifier   
 
  1e0 110   23  34581170K  8K  81178K   ?   xcompmgr
  08031   171   17  26845896K  8K  45904K   ?   i3
  000 1020  15720111K  5K  20116K   ?   i3
  20033   181   19  15718527K  5K  18533K 23441 Thunderbird
  0c027   1414  117 3826K  4K   3830K 21872 emacs
  1204131   12 3452 1560K 82K   1642K 21822 Terminal
  0e0 34039  570K384B570K   ?   i3bar for 
output DP2
  1c0 2130  1730B  7K  7K   ?   screensaver
  240 2200  1524B  3K  3K 25174 notify-osd
  180 3100  1300B  3K  3K   ?   
  280 0100  1060B  2K  2K   ?   
  140 8   3111   114B  2K  2K 31068 
chromium-browser
  160 4110   450B  2K  2K 31068 Report a 
bug : Bugs : linux package :
  260 4300   498B  1K  1K 25553 Network
  2c0 3100   120B384B384B 21027 
gnome-screensaver
  100 010020B 72B 72B   ?   
  2a0 110000B 48B 48B   ?   xrestop
  1a0 110000B 48B 48B   ?   
  040 110000B 48B 48B   ?   
  220 010000B 24B 24B   ?   
  060 010000B 24B 24B   ?   
  0a0 000000B  0B  0B   ?   

  
  Description:  Ubuntu 16.04.2 LTS
  Release:  16.04

  xorg:
Installed: 1:7.7+13ubuntu3
Candidate: 1:7.7+13ubuntu3
Version table:
   *** 1:7.7+13ubuntu3 500
  500 http://ua.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
  100 /var/lib/dpkg/status
  --- 
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  lorc   1736 F pulseaudio
  CurrentDesktop: i3
  DistroRelease: Ubuntu 16.04
  HibernationDevice: RESUME=UUID=6071d270-1c91-42c9-a5e5-fb2326b04098
  InstallationDate: Installed on 2016-10-04 (253 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  MachineType: HP HP ProDesk 600 G2 SFF
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-75-generic.efi.signed 
root=UUID=60ffd1b6-b4b8-4a93-a697-cb95f923a535 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.4.0-75.96-generic 4.4.59
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-75-generic N/A
   linux-backports-modules-4.4.0-75-generic  N/A
   linux-firmware1.157.8
  RfKill:
   0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
  Tags:  xenial
  Uname: Linux 4.4.0-75-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo uucp
  _MarkForUpload: True
  dmi.bios.date: 11/01/2016
  dmi.bios.vendor: HP
  dmi.bios.version: N02 Ver. 02.17
  dmi.board.name: 805D
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.22
  dmi.chassis.asset.tag: CZC5520SDC
  dmi.chassis.type: 4
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrN02Ver.02.17:bd11/01/2016:svnHP:pnHPProDesk600G2SFF:pvr:rvnHP:rn805D:rvrKBCVersion05.22:cvnHP:ct4:cvr:
  dmi.product.name: HP ProDesk 600 G2 SFF
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1697929/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : 

[Touch-packages] [Bug 1697891] Re: SSH X11 forwarding broken on Zesty

2017-06-14 Thread Colin Watson
If you use the -v option then you should be able to find out the reason.
It might be as simple as the server not having xauth installed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1697891

Title:
  SSH X11 forwarding broken on Zesty

Status in openssh package in Ubuntu:
  Invalid

Bug description:
  ouroumov@Edge:~$ ssh -X ouroumov@10.42.0.1 pluma
  ouroumov@10.42.0.1's password:
  X11 forwarding request failed on channel 0

  (pluma:30718): Gtk-WARNING **: cannot open display:
  ouroumov@Edge:~$

  This used to work in 16.04.
  This is problematic because among other things, it prevents one from using 
x2x.

  Note: in this experiment, the ssh command is executed on a Zesty
  client, and the target is a Xenial Server

  
  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: ssh 1:7.4p1-10
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.4-0ubuntu4.1
  Architecture: amd64
  Date: Wed Jun 14 10:39:17 2017
  InstallationDate: Installed on 2017-04-05 (70 days ago)
  InstallationMedia: Ubuntu-MATE 17.04 "Zesty Zapus" - Beta amd64 (20170321.1)
  PackageArchitecture: all
  SourcePackage: openssh
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1697891/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697929] Re: Memory leak in xorg.

2017-06-14 Thread Volodymyr Babchuk
Hm. I have selected "xorg" as affected package, but tracker created bug
for "linux" anyways. Sorry for that. Unfortunately, I can't change
affected package for some reason.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1697929

Title:
  Memory leak in xorg.

Status in xorg package in Ubuntu:
  New

Bug description:
  Seems that xorg has a memory leak. On 28th day of uptime it consumes
  13G of virtualy memory on my PC:

  
   PID USER  PR  NIVIRTRESSHR S  %CPU %MEM TIME+ COMMAND
 
  21516 root  20   0 13,340g 8,351g  49036 S   7,3 53,7   3387:19 Xorg  
  

  xrestop does not show anything suspicious:

  xrestop - Display: localhost
Monitoring 23 clients. XErrors: 0
Pixmaps:  171661K total, Other: 138K total, All:  171800K total

  res-base Wins  GCs Fnts Pxms Misc   Pxm mem  Other   Total   PID Identifier   
 
  1e0 110   23  34581170K  8K  81178K   ?   xcompmgr
  08031   171   17  26845896K  8K  45904K   ?   i3
  000 1020  15720111K  5K  20116K   ?   i3
  20033   181   19  15718527K  5K  18533K 23441 Thunderbird
  0c027   1414  117 3826K  4K   3830K 21872 emacs
  1204131   12 3452 1560K 82K   1642K 21822 Terminal
  0e0 34039  570K384B570K   ?   i3bar for 
output DP2
  1c0 2130  1730B  7K  7K   ?   screensaver
  240 2200  1524B  3K  3K 25174 notify-osd
  180 3100  1300B  3K  3K   ?   
  280 0100  1060B  2K  2K   ?   
  140 8   3111   114B  2K  2K 31068 
chromium-browser
  160 4110   450B  2K  2K 31068 Report a 
bug : Bugs : linux package :
  260 4300   498B  1K  1K 25553 Network
  2c0 3100   120B384B384B 21027 
gnome-screensaver
  100 010020B 72B 72B   ?   
  2a0 110000B 48B 48B   ?   xrestop
  1a0 110000B 48B 48B   ?   
  040 110000B 48B 48B   ?   
  220 010000B 24B 24B   ?   
  060 010000B 24B 24B   ?   
  0a0 000000B  0B  0B   ?   

  
  Description:  Ubuntu 16.04.2 LTS
  Release:  16.04

  xorg:
Installed: 1:7.7+13ubuntu3
Candidate: 1:7.7+13ubuntu3
Version table:
   *** 1:7.7+13ubuntu3 500
  500 http://ua.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
  100 /var/lib/dpkg/status
  --- 
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  lorc   1736 F pulseaudio
  CurrentDesktop: i3
  DistroRelease: Ubuntu 16.04
  HibernationDevice: RESUME=UUID=6071d270-1c91-42c9-a5e5-fb2326b04098
  InstallationDate: Installed on 2016-10-04 (253 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  MachineType: HP HP ProDesk 600 G2 SFF
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-75-generic.efi.signed 
root=UUID=60ffd1b6-b4b8-4a93-a697-cb95f923a535 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.4.0-75.96-generic 4.4.59
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-75-generic N/A
   linux-backports-modules-4.4.0-75-generic  N/A
   linux-firmware1.157.8
  RfKill:
   0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
  Tags:  xenial
  Uname: Linux 4.4.0-75-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo uucp
  _MarkForUpload: True
  dmi.bios.date: 11/01/2016
  dmi.bios.vendor: HP
  dmi.bios.version: N02 Ver. 02.17
  dmi.board.name: 805D
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.22
  dmi.chassis.asset.tag: CZC5520SDC
  dmi.chassis.type: 4
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrN02Ver.02.17:bd11/01/2016:svnHP:pnHPProDesk600G2SFF:pvr:rvnHP:rn805D:rvrKBCVersion05.22:cvnHP:ct4:cvr:
  dmi.product.name: HP ProDesk 600 G2 SFF
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1697929/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : 

[Touch-packages] [Bug 1697929] [NEW] Memory leak in xorg.

2017-06-14 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Seems that xorg has a memory leak. On 28th day of uptime it consumes 13G
of virtualy memory on my PC:


 PID USER  PR  NIVIRTRESSHR S  %CPU %MEM TIME+ COMMAND  
   
21516 root  20   0 13,340g 8,351g  49036 S   7,3 53,7   3387:19 Xorg


xrestop does not show anything suspicious:

xrestop - Display: localhost
  Monitoring 23 clients. XErrors: 0
  Pixmaps:  171661K total, Other: 138K total, All:  171800K total

res-base Wins  GCs Fnts Pxms Misc   Pxm mem  Other   Total   PID Identifier
1e0 110   23  34581170K  8K  81178K   ?   xcompmgr
08031   171   17  26845896K  8K  45904K   ?   i3
000 1020  15720111K  5K  20116K   ?   i3
20033   181   19  15718527K  5K  18533K 23441 Thunderbird
0c027   1414  117 3826K  4K   3830K 21872 emacs
1204131   12 3452 1560K 82K   1642K 21822 Terminal
0e0 34039  570K384B570K   ?   i3bar for 
output DP2
1c0 2130  1730B  7K  7K   ?   screensaver
240 2200  1524B  3K  3K 25174 notify-osd
180 3100  1300B  3K  3K   ?   
280 0100  1060B  2K  2K   ?   
140 8   3111   114B  2K  2K 31068 
chromium-browser
160 4110   450B  2K  2K 31068 Report a bug 
: Bugs : linux package :
260 4300   498B  1K  1K 25553 Network
2c0 3100   120B384B384B 21027 
gnome-screensaver
100 010020B 72B 72B   ?   
2a0 110000B 48B 48B   ?   xrestop
1a0 110000B 48B 48B   ?   
040 110000B 48B 48B   ?   
220 010000B 24B 24B   ?   
060 010000B 24B 24B   ?   
0a0 000000B  0B  0B   ?   


Description:Ubuntu 16.04.2 LTS
Release:16.04

xorg:
  Installed: 1:7.7+13ubuntu3
  Candidate: 1:7.7+13ubuntu3
  Version table:
 *** 1:7.7+13ubuntu3 500
500 http://ua.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
100 /var/lib/dpkg/status
--- 
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  lorc   1736 F pulseaudio
CurrentDesktop: i3
DistroRelease: Ubuntu 16.04
HibernationDevice: RESUME=UUID=6071d270-1c91-42c9-a5e5-fb2326b04098
InstallationDate: Installed on 2016-10-04 (253 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: HP HP ProDesk 600 G2 SFF
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-75-generic.efi.signed 
root=UUID=60ffd1b6-b4b8-4a93-a697-cb95f923a535 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.4.0-75.96-generic 4.4.59
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-75-generic N/A
 linux-backports-modules-4.4.0-75-generic  N/A
 linux-firmware1.157.8
RfKill:
 0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
Tags:  xenial
Uname: Linux 4.4.0-75-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo uucp
_MarkForUpload: True
dmi.bios.date: 11/01/2016
dmi.bios.vendor: HP
dmi.bios.version: N02 Ver. 02.17
dmi.board.name: 805D
dmi.board.vendor: HP
dmi.board.version: KBC Version 05.22
dmi.chassis.asset.tag: CZC5520SDC
dmi.chassis.type: 4
dmi.chassis.vendor: HP
dmi.modalias: 
dmi:bvnHP:bvrN02Ver.02.17:bd11/01/2016:svnHP:pnHPProDesk600G2SFF:pvr:rvnHP:rn805D:rvrKBCVersion05.22:cvnHP:ct4:cvr:
dmi.product.name: HP ProDesk 600 G2 SFF
dmi.sys.vendor: HP

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-collected xenial
-- 
Memory leak in xorg.
https://bugs.launchpad.net/bugs/1697929
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to xorg in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1686189] Re: External monitor connecting problem on Intel graphics card

2017-06-14 Thread Tharrrk
E7470 on Dell dock 0PDXXF here as well. LCD(eDP-1)+DVI(DP-1-1)+VGA(DP-1-3).
Intel graphics only.

I'm running 4.4.0-79-lowlatency now.

DISTRIB_ID=neon
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="KDE neon User Edition 5.10"

I've found out that graphics come up after I switch to vt1 (Ctrl-Alt-F1)
for a while and then back (Alt-F7). I didn't try more than once,
displays just came up.

I've also noticed that -78 worked fine if I rebooted from -72 without
powering the machine off.

Does this trick work for anybody else?

Cheers
Tharrrk

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1686189

Title:
  External monitor connecting problem on Intel graphics card

Status in linux package in Ubuntu:
  Confirmed
Status in xorg package in Ubuntu:
  Confirmed

Bug description:
  I am facing a problem with Intel Graphics driver. I have external
  monitor and in display settings the second monitor is detecting but
  it's not working, so could you email me a solution.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  Uname: Linux 4.4.25-040425-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Tue Apr 25 21:45:16 2017
  DistUpgraded: 2017-04-25 21:07:40,819 DEBUG icon theme changed, re-reading
  DistroCodename: xenial
  DistroVariant: ubuntu
  DkmsStatus: i915-4.6.3-4.4.0, 1, 4.4.0-75-generic, x86_64: installed
  GraphicsCard:
   Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] 
(rev 09) (prog-if 00 [VGA controller])
 Subsystem: Dell Haswell-ULT Integrated Graphics Controller [1028:05e9]
  InstallationDate: Installed on 2017-04-25 (0 days ago)
  InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
  MachineType: Dell Inc. Inspiron 3537
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.25-040425-generic 
root=UUID=3914e6d5-5c87-4816-8043-776ef4184d29 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to xenial on 2017-04-25 (0 days ago)
  dmi.bios.date: 04/30/2014
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A08
  dmi.board.name: 03JPPR
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: A08
  dmi.modalias: 
dmi:bvnDellInc.:bvrA08:bd04/30/2014:svnDellInc.:pnInspiron3537:pvrA08:rvnDellInc.:rn03JPPR:rvrA00:cvnDellInc.:ct8:cvrA08:
  dmi.product.name: Inspiron 3537
  dmi.product.version: A08
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.70-1~ubuntu16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.6-0ubuntu0.16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.6-0ubuntu0.16.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1.2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2
  xserver.bootTime: Tue Apr 25 21:37:24 2017
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id   17900 
   vendor AUO
  xserver.version: 2:1.18.4-0ubuntu0.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1686189/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697918] [NEW] ubuntu resolution

2017-06-14 Thread Ahmed Amr
Public bug reported:

there is no resolution list available just 800*600 and my screen up tp
1920*1080 , and there was desktop login loop when i installed any nvidia
drivers version .

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.8.0-54.57~16.04.1-generic 4.8.17
Uname: Linux 4.8.0-54-generic x86_64
.tmp.unity_support_test.1:
 
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Wed Jun 14 13:11:09 2017
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus: bbswitch, 0.8, 4.8.0-54-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Skylake Integrated Graphics [8086:191b] (rev 06) (prog-if 00 
[VGA controller])
   Subsystem: ASUSTeK Computer Inc. Skylake Integrated Graphics [1043:1c5d]
   Subsystem: ASUSTeK Computer Inc. GM107M [GeForce GTX 960M] [1043:1c5d]
InstallationDate: Installed on 2017-06-12 (1 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 
(20170215.2)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 002: ID 04f2:b424 Chicony Electronics Co., Ltd 
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. GL552VW
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-54-generic.efi.signed 
root=UUID=e53ad924-76e5-4007-b242-c39ae16ebcc7 ro quiet splash nomodeset 
vt.handoff=7
Renderer: Software
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/26/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: GL552VW.217
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: GL552VW
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrGL552VW.217:bd01/26/2016:svnASUSTeKCOMPUTERINC.:pnGL552VW:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnGL552VW:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: GL552VW
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1~ubuntu16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.6-0ubuntu0.16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.6-0ubuntu0.16.04.1
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Wed Jun 14 15:06:01 2017
xserver.configfile: default
xserver.errors:
 open /dev/dri/card0: No such file or directory
 open /dev/dri/card0: No such file or directory
 Screen 0 deleted because of no matching config section.
 AIGLX: reverting to software rendering
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 
xserver.version: 2:1.18.4-1ubuntu6.1~16.04.1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug compiz-0.9 ubuntu xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1697918

Title:
  ubuntu resolution

Status in xorg package in Ubuntu:
  New

Bug description:
  there is no resolution list available just 800*600 and my screen up tp
  1920*1080 , and there was desktop login loop when i installed any
  nvidia drivers version .

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.8.0-54.57~16.04.1-generic 4.8.17
  Uname: Linux 4.8.0-54-generic x86_64
  .tmp.unity_support_test.1:
   
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Wed Jun 14 13:11:09 2017
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
  DkmsStatus: bbswitch, 0.8, 4.8.0-54-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Skylake Integrated Graphics [8086:191b] (rev 06) (prog-if 
00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. Skylake Integrated Graphics [1043:1c5d]
 Subsystem: ASUSTeK Computer Inc. GM107M [GeForce GTX 960M] [1043:1c5d]
  

[Touch-packages] [Bug 1490349] Re: 15:10 and 16.04: bluetoothd reports "Not enough free handles to register service" at start

2017-06-14 Thread Daniel van Vugt
Actually, it sounds like this one:

https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/?id=f558fca8d64e3795b0654a90d343af1dd1d8b33c

** Changed in: bluez (Ubuntu)
 Assignee: (unassigned) => Daniel van Vugt (vanvugt)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1490349

Title:
  15:10 and 16.04: bluetoothd reports "Not enough free handles to
  register service" at start

Status in bluez package in Ubuntu:
  Confirmed

Bug description:
  On 15:10 after the bluetooth service has been stopped and restarted it
  is not possible to scan or connect to devices:

  $ sudo systemctl start bluetooth
  $ journalctl --unit=bluetooth | tail -n 19 | awk '{$1="";$2="";$4="";print 
$0}'
23:31:53  systemd[1]: Starting Bluetooth service...
23:31:53  bluetoothd[16647]: Bluetooth daemon 5.33
23:31:53  systemd[1]: Started Bluetooth service.
23:31:53  bluetoothd[16647]: Starting SDP server
23:31:53  bluetoothd[16647]: Bluetooth management interface 1.9 initialized
23:31:53  bluetoothd[16647]: Failed to obtain handles for "Service Changed" 
characteristic
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Error adding Link Loss service
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Current Time Service could not be registered
23:31:53  bluetoothd[16647]: gatt-time-server: Input/output error (5)
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Sap driver initialization failed.
23:31:53  bluetoothd[16647]: sap-server: Operation not permitted (1)
23:31:53  bluetoothd[16647]: Endpoint registered: sender=:1.440 
path=/MediaEndpoint/A2DPSource
23:31:53  bluetoothd[16647]: Endpoint registered: sender=:1.440 
path=/MediaEndpoint/A2DPSink

  And

  $ bluetoothctl
  [NEW] Controller 00:1F:3A:E0:0A:AF hephaestion.lan.iam.tj [default]
  [NEW] Device 00:0A:95:4B:BD:C2 Apple Wireless Keyboard
  [NEW] Device 00:07:61:3B:86:98 Bluetooth Travel Mouse
  [bluetooth]# scan on
  Failed to start discovery: org.bluez.Error.NotReady

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1490349/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697474] Re: Map of India is incorrect

2017-06-14 Thread Will Cooke
Narendra confirms that UTC+5:30 is all of India, but that he's never had
a problem with it in the past.  This is probably fine then, but let's
test it once we know we're OK to proceed.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libtimezonemap in Ubuntu.
https://bugs.launchpad.net/bugs/1697474

Title:
  Map of India is incorrect

Status in libtimezonemap package in Ubuntu:
  Confirmed

Bug description:
  A correct map of India is shown here:

  https://www.mapsofworld.com/india/

  The map used in libtimezonemap needs to be updated to match.

  I'm reaching out to Prakash to get some exact details on what should
  be changed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libtimezonemap/+bug/1697474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1490349] Re: 15:10 and 16.04: bluetoothd reports "Not enough free handles to register service" at start

2017-06-14 Thread Daniel van Vugt
That sounds like an excellent workaround. It's probably not a fix
though. A fix would involve finding out why the config has confused
bluez.

Actually this sounds like an "old" bug that was fixed after 16.04 since newer 
releases aren't being reported. If we could figure out what fixed it then we 
could backport that fix to 16.04. You can search the code here:
   https://git.kernel.org/pub/scm/bluetooth/bluez.git

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1490349

Title:
  15:10 and 16.04: bluetoothd reports "Not enough free handles to
  register service" at start

Status in bluez package in Ubuntu:
  Confirmed

Bug description:
  On 15:10 after the bluetooth service has been stopped and restarted it
  is not possible to scan or connect to devices:

  $ sudo systemctl start bluetooth
  $ journalctl --unit=bluetooth | tail -n 19 | awk '{$1="";$2="";$4="";print 
$0}'
23:31:53  systemd[1]: Starting Bluetooth service...
23:31:53  bluetoothd[16647]: Bluetooth daemon 5.33
23:31:53  systemd[1]: Started Bluetooth service.
23:31:53  bluetoothd[16647]: Starting SDP server
23:31:53  bluetoothd[16647]: Bluetooth management interface 1.9 initialized
23:31:53  bluetoothd[16647]: Failed to obtain handles for "Service Changed" 
characteristic
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Error adding Link Loss service
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Current Time Service could not be registered
23:31:53  bluetoothd[16647]: gatt-time-server: Input/output error (5)
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Not enough free handles to register service
23:31:53  bluetoothd[16647]: Sap driver initialization failed.
23:31:53  bluetoothd[16647]: sap-server: Operation not permitted (1)
23:31:53  bluetoothd[16647]: Endpoint registered: sender=:1.440 
path=/MediaEndpoint/A2DPSource
23:31:53  bluetoothd[16647]: Endpoint registered: sender=:1.440 
path=/MediaEndpoint/A2DPSink

  And

  $ bluetoothctl
  [NEW] Controller 00:1F:3A:E0:0A:AF hephaestion.lan.iam.tj [default]
  [NEW] Device 00:0A:95:4B:BD:C2 Apple Wireless Keyboard
  [NEW] Device 00:07:61:3B:86:98 Bluetooth Travel Mouse
  [bluetooth]# scan on
  Failed to start discovery: org.bluez.Error.NotReady

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1490349/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1621396] Re: systemd-resolved crashed with SIGSEGV in dns_packet_is_reply_for()

2017-06-14 Thread Dimitri John Ledkov
There is now one crash report in proposed. I'm not sure if this is
because resolved was running, and has not been restarted yet. Or there
is still this genuine crash present in the proposed package.

_systemctl try-restart systemd-resolved.service || true

is called in the postinst, so the daemon should have been restarted.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1621396

Title:
  systemd-resolved crashed with SIGSEGV in dns_packet_is_reply_for()

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Xenial:
  Confirmed
Status in systemd source package in Yakkety:
  Confirmed
Status in systemd source package in Zesty:
  Fix Committed

Bug description:
  [Impact]

   * Null-pointer dereference in resolved, results in resolved crash and
  reports on launchpad and errors.

  [Test Case]

   * Unknown steps to reproduce
   * Monitor the drop off in crashes on errors.ubuntu.com:
  https://errors.ubuntu.com/problem/ea90aefe098653f44b46e56d72e2cc05ff980465

  [Regression Potential]

   * The behavior is similar, instead of crashing resolved it returns an
  error in the relevant function. Whilst this may not result in correct
  dns resolution for the affected dns packets, it should not result in
  resolved crashes.

  [Original Bug Report]

  This is one of background errors that happens without any active app being 
involved.
  For the records, I had open: Firefox, Slack, Franz and the Terminal

  The Ubuntu Error Tracker has been receiving reports about a problem regarding 
systemd. This problem was most recently seen with package version 233-6ubuntu2, 
the problem page at 
https://errors.ubuntu.com/problem/ea90aefe098653f44b46e56d72e2cc05ff980465 
contains more details, including versions of packages affected, stacktrace or 
traceback, and individual crash reports.
  If you do not have access to the Ubuntu Error Tracker you can request it at 
http://forms.canonical.com/reports/.

  ProblemType: Crash
  DistroRelease: Ubuntu 16.10
  Package: systemd 231-5
  ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
  Uname: Linux 4.4.0-9136-generic x86_64
  ApportVersion: 2.20.3-0ubuntu7
  Architecture: amd64
  CrashCounter: 1
  Date: Thu Sep  8 09:33:55 2016
  ExecutablePath: /lib/systemd/systemd-resolved
  InstallationDate: Installed on 2013-06-06 (1189 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
  MachineType: Dell Inc. Dell System XPS L322X
  ProcCmdline: /lib/systemd/systemd-resolved
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-9136-generic 
root=UUID=2850be62-a05e-4ab9-af2b-5f1fd159ce5d ro quiet splash vt.handoff=7
  Signal: 11
  SourcePackage: systemd
  StacktraceTop:
   ?? ()
   ?? ()
   ?? () from /lib/systemd/libsystemd-shared-231.so
   sd_event_dispatch () from /lib/systemd/libsystemd-shared-231.so
   sd_event_run () from /lib/systemd/libsystemd-shared-231.so
  Title: systemd-resolved crashed with SIGSEGV in sd_event_dispatch()
  UpgradeStatus: Upgraded to yakkety on 2016-09-03 (4 days ago)
  UserGroups:

  dmi.bios.date: 04/18/2013
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A08
  dmi.board.name: 0PJHXN
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: 0.1
  dmi.modalias: 
dmi:bvnDellInc.:bvrA08:bd04/18/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn0PJHXN:rvrA00:cvnDellInc.:ct8:cvr0.1:
  dmi.product.name: Dell System XPS L322X
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1621396/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697898] Re: Small graphical glitch when using GNOME Software

2017-06-14 Thread Daniel van Vugt
*** This bug is a duplicate of bug 1693613 ***
https://bugs.launchpad.net/bugs/1693613

Thank you for taking the time to report this bug and helping to make
Ubuntu better. This particular bug has already been reported and is a
duplicate of bug 1693613, so it is being marked as such. Please look at
the other bug report to see if there is any missing information that you
can provide, or to see if there is a workaround for the bug.
Additionally, any further discussion regarding the bug should occur in
the other report. Feel free to continue to report any other bugs you may
find.


** This bug has been marked a duplicate of bug 1693613
   Ambiance/Radiance headerbar has more padding on top than on bottom

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-themes in Ubuntu.
https://bugs.launchpad.net/bugs/1697898

Title:
  Small graphical glitch when using GNOME Software

Status in ubuntu-themes package in Ubuntu:
  New

Bug description:
  Different title bar size (see the attached screenshots).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-themes/+bug/1697898/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697900] Re: Small graphical glitch in Nautilus "Delete" button border

2017-06-14 Thread Daniel van Vugt
** Summary changed:

- Small graphical glitch when using Nautilus
+ Small graphical glitch in Nautilus "Delete" button border

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-themes in Ubuntu.
https://bugs.launchpad.net/bugs/1697900

Title:
  Small graphical glitch in Nautilus "Delete" button border

Status in ubuntu-themes package in Ubuntu:
  New

Bug description:
  Glitch in the "Delete" button (see the attached screenshots).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-themes/+bug/1697900/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697587] Re: Please merge sudo (main) 1.8.20p2-1 from Debian unstable (main)

2017-06-14 Thread Amr Ibrahim
** Description changed:

- It fixes #LP: 1686803 and contains new upstream releases.
+ It fixes LP: #1686803 and contains new upstream releases.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to sudo in Ubuntu.
https://bugs.launchpad.net/bugs/1697587

Title:
   Please merge sudo (main) 1.8.20p2-1 from Debian unstable (main)

Status in sudo package in Ubuntu:
  Confirmed

Bug description:
  It fixes LP: #1686803 and contains new upstream releases.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/sudo/+bug/1697587/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1686784] Re: no predictable names for platform (non-PCI) NICs

2017-06-14 Thread Dimitri John Ledkov
https://bugs.launchpad.net/ubuntu/+source/netcfg/+bug/1697914

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1686784

Title:
  no predictable names for platform (non-PCI) NICs

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Xenial:
  Confirmed
Status in systemd source package in Yakkety:
  New
Status in systemd source package in Zesty:
  Fix Committed

Bug description:
  [Impact]
  Systems may have NICs attached to the "platform" bus. These are NICs that are 
onboard, but not attached to a PCI(-like) bus. Rather, they are described by 
firmware directly. None of the naming policies enabled by Ubuntu by default 
matches these NICs, so they end up having unpredictable names. In the case 
where other NICs are attached (e.g. PCIe cards), the ethN enumeration race 
occurs, making it impossible to have an interface name that is persistent 
across reboots. That is, if you do a network install over "eth0", on reboot 
that NIC now maybe "eth3", which causes it to fail to start the network on boot.

  The HiSilicon D05 boards are an example of this. It has 4 onboard NICs
  that are described by ACPI directly, and may also have other PCIe NICs
  plugged in.

  [Test Case]
  Boot a system with the characteristics described above, and check to see if 
any "ethN" interfaces exist.

  [Regression Risk]
  Unless one fixed the names locally with .netlink / .rules files the interface 
names will change for the ACPI/platform bus network interfaces, from random 
ethX names to stable names named like enaVENDORMODELiX. Thus we should check 
that this update doesn't negatively break certified ARM64 platforms with: ARM, 
NVIDIA, HISILICON platform bus ethernet devices.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1686784/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1686784] Re: no predictable names for platform (non-PCI) NICs

2017-06-14 Thread Dimitri John Ledkov
Thank you for verifying this, also opening a bug report against
netconfig to not call those interface names as "unknown" but call them
platform interfaces, or some such.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1686784

Title:
  no predictable names for platform (non-PCI) NICs

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Xenial:
  Confirmed
Status in systemd source package in Yakkety:
  New
Status in systemd source package in Zesty:
  Fix Committed

Bug description:
  [Impact]
  Systems may have NICs attached to the "platform" bus. These are NICs that are 
onboard, but not attached to a PCI(-like) bus. Rather, they are described by 
firmware directly. None of the naming policies enabled by Ubuntu by default 
matches these NICs, so they end up having unpredictable names. In the case 
where other NICs are attached (e.g. PCIe cards), the ethN enumeration race 
occurs, making it impossible to have an interface name that is persistent 
across reboots. That is, if you do a network install over "eth0", on reboot 
that NIC now maybe "eth3", which causes it to fail to start the network on boot.

  The HiSilicon D05 boards are an example of this. It has 4 onboard NICs
  that are described by ACPI directly, and may also have other PCIe NICs
  plugged in.

  [Test Case]
  Boot a system with the characteristics described above, and check to see if 
any "ethN" interfaces exist.

  [Regression Risk]
  Unless one fixed the names locally with .netlink / .rules files the interface 
names will change for the ACPI/platform bus network interfaces, from random 
ethX names to stable names named like enaVENDORMODELiX. Thus we should check 
that this update doesn't negatively break certified ARM64 platforms with: ARM, 
NVIDIA, HISILICON platform bus ethernet devices.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1686784/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697911] Re: package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade: package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is not ready (current

2017-06-14 Thread Apport retracing service
** Tags removed: need-duplicate-check

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1697911

Title:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
  package libssl1.0.0:amd64 cannot be configured because
  libssl1.0.0:i386 is not ready (current status 'half-installed')

Status in openssl package in Ubuntu:
  New

Bug description:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
  package libssl1.0.0:amd64 cannot be configured because
  libssl1.0.0:i386 is not ready (current status 'half-installed')

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libssl1.0.0:amd64 1.0.2g-1ubuntu4.6
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.6
  Architecture: amd64
  Date: Wed Jun 14 13:06:50 2017
  DuplicateSignature:
   package:libssl1.0.0:amd64:1.0.2g-1ubuntu4.6
   Installing from local file 
/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170613.2.orig.tar.gz
   Flash Plugin installed.
   dpkg: error processing package libssl1.0.0:amd64 (--configure):
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is 
not ready (current status 'half-installed')
  ErrorMessage: package libssl1.0.0:amd64 cannot be configured because 
libssl1.0.0:i386 is not ready (current status 'half-installed')
  InstallationDate: Installed on 2017-01-07 (157 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: openssl
  Title: package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade: 
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is not 
ready (current status 'half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1697911/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697911] [NEW] package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade: package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is not ready (curren

2017-06-14 Thread hlempas hlemponiaris
Public bug reported:

package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386
is not ready (current status 'half-installed')

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libssl1.0.0:amd64 1.0.2g-1ubuntu4.6
ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
Uname: Linux 4.4.0-79-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
Date: Wed Jun 14 13:06:50 2017
DuplicateSignature:
 package:libssl1.0.0:amd64:1.0.2g-1ubuntu4.6
 Installing from local file 
/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170613.2.orig.tar.gz
 Flash Plugin installed.
 dpkg: error processing package libssl1.0.0:amd64 (--configure):
  package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is 
not ready (current status 'half-installed')
ErrorMessage: package libssl1.0.0:amd64 cannot be configured because 
libssl1.0.0:i386 is not ready (current status 'half-installed')
InstallationDate: Installed on 2017-01-07 (157 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt  1.2.20
SourcePackage: openssl
Title: package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade: 
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is not 
ready (current status 'half-installed')
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: openssl (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-package xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1697911

Title:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
  package libssl1.0.0:amd64 cannot be configured because
  libssl1.0.0:i386 is not ready (current status 'half-installed')

Status in openssl package in Ubuntu:
  New

Bug description:
  package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade:
  package libssl1.0.0:amd64 cannot be configured because
  libssl1.0.0:i386 is not ready (current status 'half-installed')

  ProblemType: Package
  DistroRelease: Ubuntu 16.04
  Package: libssl1.0.0:amd64 1.0.2g-1ubuntu4.6
  ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
  Uname: Linux 4.4.0-79-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.6
  Architecture: amd64
  Date: Wed Jun 14 13:06:50 2017
  DuplicateSignature:
   package:libssl1.0.0:amd64:1.0.2g-1ubuntu4.6
   Installing from local file 
/var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20170613.2.orig.tar.gz
   Flash Plugin installed.
   dpkg: error processing package libssl1.0.0:amd64 (--configure):
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is 
not ready (current status 'half-installed')
  ErrorMessage: package libssl1.0.0:amd64 cannot be configured because 
libssl1.0.0:i386 is not ready (current status 'half-installed')
  InstallationDate: Installed on 2017-01-07 (157 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  RelatedPackageVersions:
   dpkg 1.18.4ubuntu1.2
   apt  1.2.20
  SourcePackage: openssl
  Title: package libssl1.0.0:amd64 1.0.2g-1ubuntu4.6 failed to install/upgrade: 
package libssl1.0.0:amd64 cannot be configured because libssl1.0.0:i386 is not 
ready (current status 'half-installed')
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1697911/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697474] Re: Map of India is incorrect

2017-06-14 Thread Will Cooke
Internet suggests that all of India is UTC+5:30, and that Jammu and
Kashmir are on India Standard Time.

https://www.timeanddate.com/worldclock/india/srinagar

So, yes, it appears that the installer is setting the wrong timezone for
India if it's setting it to +5 and not +5:30.  I've reached out to some
folk who know more about this and will report back.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libtimezonemap in Ubuntu.
https://bugs.launchpad.net/bugs/1697474

Title:
  Map of India is incorrect

Status in libtimezonemap package in Ubuntu:
  Confirmed

Bug description:
  A correct map of India is shown here:

  https://www.mapsofworld.com/india/

  The map used in libtimezonemap needs to be updated to match.

  I'm reaching out to Prakash to get some exact details on what should
  be changed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libtimezonemap/+bug/1697474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697474] Re: Map of India is incorrect

2017-06-14 Thread Will Cooke
A view of the whole world with the changes added.

** Attachment added: "bg (1).png"
   
https://bugs.launchpad.net/ubuntu/+source/libtimezonemap/+bug/1697474/+attachment/4895768/+files/bg%20%281%29.png

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libtimezonemap in Ubuntu.
https://bugs.launchpad.net/bugs/1697474

Title:
  Map of India is incorrect

Status in libtimezonemap package in Ubuntu:
  Confirmed

Bug description:
  A correct map of India is shown here:

  https://www.mapsofworld.com/india/

  The map used in libtimezonemap needs to be updated to match.

  I'm reaching out to Prakash to get some exact details on what should
  be changed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libtimezonemap/+bug/1697474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697730] Re: Long boot time due to systemd-networkd-wait-online.service failure

2017-06-14 Thread Stefan Bader
Sorry, forgot above:

#> cat /run/systemd/network/10-netplan-eth0.network 
[Match]
Name=eth0

[Network]
DHCP=ipv4

[DHCP]
RouteMetric=100

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1697730

Title:
  Long boot time due to systemd-networkd-wait-online.service failure

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Fresh VM installation from the Artful daily server ISO. Installation
  finishes without issues but booting the installed system takes a long
  time (until systemd-networkd-wait-online.service times out). The VM
  can already be pinged at that stage, so network has been configured at
  that stage. It just seems that the waiting command does not notice the
  interface being up.

  From the installed system (after timeout) it looks like the lo device
  is set up via /etc/network/interfaces but the NIC is set in
  /etc/netplan/01-netcfg.yaml.

  systemd-networkd.service:
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Network Service...
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: Enumeration completed
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: IPv6 successfully 
enabled
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Started Network Service.
  Jun 13 17:07:08 bar-artful6401 systemd-networkd[587]: eth0: Gained carrier
  Jun 13 17:07:09 bar-artful6401 systemd-networkd[587]: eth0: DHCPv4 address 
192.168.2.159/24 via 192.168.2.1
  Jun 13 17:07:10 bar-artful6401 systemd-networkd[587]: eth0: Gained IPv6LL

  systemd-networkd-wait-online.service (failed):
  Jun 13 17:07:08 bar-artful6401 systemd[1]: Starting Wait for Network to be 
Configured...
  Jun 13 17:09:09 bar-artful6401 systemd-networkd-wait-online[593]: Event loop 
failed: Connection timed out
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Main process exited, code=exited, sta
  Jun 13 17:09:09 bar-artful6401 systemd[1]: Failed to start Wait for Network 
to be Configured.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Unit entered failed state.
  Jun 13 17:09:09 bar-artful6401 systemd[1]: 
systemd-networkd-wait-online.service: Failed with result 'exit-code'.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: systemd 233-6ubuntu3
  ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
  Uname: Linux 4.10.0-22-generic x86_64
  ApportVersion: 2.20.5-0ubuntu4
  Architecture: amd64
  Date: Tue Jun 13 18:11:47 2017
  InstallationDate: Installed on 2017-06-13 (0 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Alpha amd64 
(20170611)
  Lsusb: Error: command ['lsusb'] failed with exit code 1:
  MachineType: Xen HVM domU
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-22-generic 
root=/dev/mapper/bar--artful6401--vg-root ro video=640x480
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/15/2017
  dmi.bios.vendor: Xen
  dmi.bios.version: 4.8.0
  dmi.chassis.type: 1
  dmi.chassis.vendor: Xen
  dmi.modalias: 
dmi:bvnXen:bvr4.8.0:bd03/15/2017:svnXen:pnHVMdomU:pvr4.8.0:cvnXen:ct1:cvr:
  dmi.product.name: HVM domU
  dmi.product.version: 4.8.0
  dmi.sys.vendor: Xen

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1697730/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697474] Re: Map of India is incorrect

2017-06-14 Thread Will Cooke
Image showing just India.

** Attachment added: "timezone_5.5.png"
   
https://bugs.launchpad.net/ubuntu/+source/libtimezonemap/+bug/1697474/+attachment/4895769/+files/timezone_5.5.png

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libtimezonemap in Ubuntu.
https://bugs.launchpad.net/bugs/1697474

Title:
  Map of India is incorrect

Status in libtimezonemap package in Ubuntu:
  Confirmed

Bug description:
  A correct map of India is shown here:

  https://www.mapsofworld.com/india/

  The map used in libtimezonemap needs to be updated to match.

  I'm reaching out to Prakash to get some exact details on what should
  be changed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libtimezonemap/+bug/1697474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1697474] Re: Map of India is incorrect

2017-06-14 Thread Iain Lane
As far as I can see, according to that first link I gave, the area that
is about to be changed to be a part of India in Ubuntu's installer is
UTC+5.

Are we saying that's wrong?

The legal advice is helpful. Can we find a copy of the definitive map
that we're updating to be in line with?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libtimezonemap in Ubuntu.
https://bugs.launchpad.net/bugs/1697474

Title:
  Map of India is incorrect

Status in libtimezonemap package in Ubuntu:
  Confirmed

Bug description:
  A correct map of India is shown here:

  https://www.mapsofworld.com/india/

  The map used in libtimezonemap needs to be updated to match.

  I'm reaching out to Prakash to get some exact details on what should
  be changed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libtimezonemap/+bug/1697474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


  1   2   >