[Touch-packages] [Bug 873975] Re: lacks consolekit integration

2018-11-07 Thread Bug Watch Updater
** Changed in: consolekit (Debian)
   Status: Incomplete => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to consolekit in Ubuntu.
https://bugs.launchpad.net/bugs/873975

Title:
  lacks consolekit integration

Status in consolekit package in Ubuntu:
  Confirmed
Status in nodm package in Ubuntu:
  Fix Released
Status in consolekit package in Debian:
  Fix Released
Status in nodm package in Debian:
  Fix Released
Status in consolekit package in Fedora:
  Won't Fix

Bug description:
  Symptoms: users that login via nodm cannot mount usb sticks

  cause: 
consolekit expects the display maanger (nodm in our case) to register   
  
the session as local, but it doesn't current.   
  
  references:
 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=597937#71 

 https://bugzilla.redhat.com/show_bug.cgi?id=657979

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/consolekit/+bug/873975/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 793361] Re: [avidemux?] Pre-rolling problem with specific (broken?) movie

2018-11-07 Thread Bug Watch Updater
** Changed in: gstreamer
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gstreamer0.10 in Ubuntu.
https://bugs.launchpad.net/bugs/793361

Title:
  [avidemux?] Pre-rolling problem with specific (broken?) movie

Status in GStreamer:
  Expired
Status in gstreamer0.10 package in Ubuntu:
  New

Bug description:
  Totem and Banshee not work. VLC play movie. Attach movie

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: libgstreamer0.10-0 0.10.32-3ubuntu3
  Uname: Linux 2.6.39-02063901-generic x86_64
  Architecture: amd64
  Date: Mon Jun  6 00:54:48 2011
  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
  ProcEnviron:
   LANGUAGE=es_CL:en
   LANG=es_CL.UTF-8
   SHELL=/bin/bash
  SourcePackage: gstreamer0.10
  UpgradeStatus: Upgraded to natty on 2011-06-03 (3 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/gstreamer/+bug/793361/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1556457] Re: [FFe] Demilight (OS/2 weight=350) confuses fontconfig

2018-11-07 Thread Bug Watch Updater
** Changed in: fontconfig (Debian)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to fontconfig in Ubuntu.
https://bugs.launchpad.net/bugs/1556457

Title:
  [FFe] Demilight (OS/2 weight=350) confuses fontconfig

Status in Fontconfig:
  Fix Released
Status in fontconfig package in Ubuntu:
  Fix Released
Status in fontconfig package in Debian:
  Fix Released

Bug description:
  [FFe request comment]

  Upgrading to fontconfig 2.11.94 is proposed as a fix of this bug,
  including a fix of certain font weight issues due to the switch from
  fonts-droid to fonts-noto-cjk for Chinese (discussed at bug #1468027)
  where we haven't found any way to work around the problem.

  The proposed upload is available in this PPA:
  https://launchpad.net/~gunnarhj/+archive/ubuntu/fontconfig-test2

  Changes are listed in the attachment upstream_git-log.txt

  [Original description including updates]

  See https://bugs.freedesktop.org/show_bug.cgi?id=81453 and bug
  1468027.

  Fontconfig lacks support for many OpenType/TrueType OS/2 font weight
  values. This causes a bunch of problems, like mixing up Demilight
  (weight=350) and Regular (weight=400).

  Although it's possible to write (dirty?) hacks for deb-packed fonts,
  this still causes problems for otherwise sourced fonts.

  Archlinux: https://bugs.archlinux.org/task/48550 (fix released,
  upgraded to 2.11.94)

To manage notifications about this bug go to:
https://bugs.launchpad.net/fontconfig/+bug/1556457/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 368846] Re: audo/x-mod files play locally but not over http

2018-11-07 Thread Bug Watch Updater
** Changed in: gstreamer
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gstreamer0.10 in Ubuntu.
https://bugs.launchpad.net/bugs/368846

Title:
  audo/x-mod files play locally but not over http

Status in GStreamer:
  Expired
Status in gstreamer0.10 package in Ubuntu:
  Triaged

Bug description:
  Binary package hint: totem

  On Hardy, playing a .m3u playlist full of .xm files results in Totem
  prompting to "Search for a suitable codec", which it can't find ("no
  matching application available"; "playback of this movie requires a
  Module Music Format (MOD) decoder plugin which is not installed"). But
  if I download the individual .xm files and open them, Totem plays them
  just great. Playing a .m3u with an mp3 in it works great, too.

  ProblemType: Bug
  Architecture: i386
  Date: Tue Apr 28 16:15:58 2009
  DistroRelease: Ubuntu 8.04
  ExecutablePath: /usr/bin/totem-gstreamer
  NonfreeKernelModules: fglrx
  Package: totem-gstreamer 2.22.1-0ubuntu3
  PackageArchitecture: i386
  ProcEnviron:
   
PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: totem
  Uname: Linux 2.6.24-23-generic i686

To manage notifications about this bug go to:
https://bugs.launchpad.net/gstreamer/+bug/368846/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 611835] Re: Incorrect detect size of surface for subtitle rendering when playback anamorph video

2018-11-07 Thread Bug Watch Updater
** Changed in: gstreamer
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gstreamer0.10 in Ubuntu.
https://bugs.launchpad.net/bugs/611835

Title:
  Incorrect detect size of surface for subtitle rendering when playback
  anamorph video

Status in GStreamer:
  Expired
Status in gstreamer0.10 package in Ubuntu:
  Triaged

Bug description:
  Look at attached screenshots. I get incorrect rendering in Totem player. 
Correct rendering - it's mplayer.
  Sample: http://sharebee.com/65fa39aa
  When aspect ratio of video stream not equal with aspect ratio in properties 
of this video stream in media contatiner (anamorph video) rendering ass 
subtitles always incorrect. For example real size of video in this sample file 
is 1440x1080, but it's playback like 1920x1080.

  ProblemType: Bug
  DistroRelease: Ubuntu 10.10
  Package: libgstreamer0.10-0 0.10.30-1
  ProcVersionSignature: Ubuntu 2.6.35-11.16-generic 2.6.35-rc5
  Uname: Linux 2.6.35-11-generic x86_64
  Architecture: amd64
  Date: Sat Jul 31 04:47:55 2010
  InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
  ProcEnviron:
   LANG=ru_RU.UTF-8
   SHELL=/bin/bash
  SourcePackage: gstreamer0.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/gstreamer/+bug/611835/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1792745] Re: NetworkManager crashed with SIGSEGV in _int_malloc()

2018-11-07 Thread Bug Watch Updater
** Changed in: network-manager
   Status: Unknown => Fix Released

** Changed in: network-manager
   Importance: Unknown => Critical

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1792745

Title:
  NetworkManager crashed with SIGSEGV in _int_malloc()

Status in NetworkManager:
  Fix Released
Status in network-manager package in Ubuntu:
  Fix Released

Bug description:
  I’m seeing NetworkManager crash several times on startup and on resume
  from suspend. Apport doesn’t catch those for some reason, but this
  happened when I tried to reproduce by manually running NetworkManager
  --debug.

  (Different crash from bug 1792743?  Also apport-retrace didn’t seem to
  like that one.)

  ProblemType: Crash
  DistroRelease: Ubuntu 18.10
  Package: network-manager 1.12.2-0ubuntu4
  ProcVersionSignature: Ubuntu 4.18.0-7.8-generic 4.18.5
  Uname: Linux 4.18.0-7-generic x86_64
  NonfreeKernelModules: openafs
  ApportVersion: 2.20.10-0ubuntu9
  Architecture: amd64
  Date: Sat Sep 15 14:04:50 2018
  EcryptfsInUse: Yes
  ExecutablePath: /usr/sbin/NetworkManager
  IfupdownConfig: # ifupdown has been replaced by netplan(5) on this system.  
Do not edit.
  InstallationDate: Installed on 2016-02-19 (939 days ago)
  InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64 
(20160218)
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=false
  ProcCmdline: NetworkManager --debug
  SegvAnalysis:
   Segfault happened at: 0x7f79966ea378 <_int_malloc+3352>: cmp
%rcx,0x18(%rdx)
   PC (0x7f79966ea378) ok
   source "%rcx" ok
   destination "0x18(%rdx)" (0x0018) not located in a known VMA region 
(needed writable region)!
  SegvReason: writing NULL VMA
  Signal: 11
  SourcePackage: network-manager
  StacktraceTop:
   _int_malloc (av=av@entry=0x7f799683ac40 , 
bytes=bytes@entry=4096) at malloc.c:4014
   __libc_calloc (n=, elem_size=) at malloc.c:3420
   g_malloc0 () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
   nlmsg_alloc_size (len=4096) at src/platform/nm-netlink.c:314
   _nl80211_alloc_msg (id=28, ifindex=2, phy=0, cmd=cmd@entry=32, 
flags=flags@entry=768) at src/platform/wifi/wifi-utils-nl80211.c:88
  Title: NetworkManager crashed with SIGSEGV in _int_malloc()
  UpgradeStatus: Upgraded to cosmic on 2018-08-17 (29 days ago)
  UserGroups:
   
  nmcli-con: Error: command ['nmcli', '-f', 'all', 'con'] failed with exit code 
8: Error: NetworkManager is not running.
  nmcli-dev: Error: command ['nmcli', '-f', 'all', 'dev'] failed with exit code 
8: Error: NetworkManager is not running.
  nmcli-nm: Error: command ['nmcli', '-f', 'all', 'gen'] failed with exit code 
8: Error: NetworkManager is not running.

To manage notifications about this bug go to:
https://bugs.launchpad.net/network-manager/+bug/1792745/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1783298] Re: AuthInfoRequired negotiate in cups 2.2.7 in Bionic does not work

2018-11-07 Thread josephpei
I found the solution:

https://www.dedoimedo.com/computers/ubuntu-beaver-samba-shares.html

Quote: The reason is, they changed the default protocol version and
whatnot, and actually, who cares. People just want to be able to share
things with their Windows boxes easily!

Edit

/etc/samba/smb.conf

Add a line

client max protocol = NT1

Restart smb

sudo systemctl restart smbd.service

Now we can see the windows neighbours and the share printers.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1783298

Title:
  AuthInfoRequired negotiate in cups 2.2.7 in Bionic does not work

Status in cups package in Ubuntu:
  Confirmed

Bug description:
  
  Hi,

  We have our printers configured to print to a Windows print server. In
  Ubuntu 14.04 and 16.04 our setup works fine but in 18.04 our setup
  seems to be acting more like AuthInfoRequired username,password i.e.
  it prompts for a password when printing rather than using the
  available Kerberos credentials.

  We are using an unaltered cupsd.conf file and are adding printers with
  the following command:

  lpadmin -p "printer" -D "Printer" -L "room" -v
  "smb://printers.cis.strath.ac.uk/printers" -o Media=A4 -o PageSize=A4
  -o printer-error-policy=abort-job -o auth-info-required=negotiate -m
  "CIS/hp-officejet_pro_476_576_series-ps.ppd"

  the smb backend has been linked to /usr/lib/x86_64-linux-
  gnu/samba/smbspool_krb5_wrapper (I've added this the apparmor profile
  as it's blocked by default) and the permissions on this file changed
  to 700 (owner root) as per manpage instructions.

  When using lp -d printer /tmp/test.txt I get the following response:

  Password for myuid on localhost?

  Typing my password gets the job accepted to the queue but it does
  spool to the Windows Print Server and in the error_log file I can see

  D [24/Jul/2018:10:33:00 +0100] [Job 45] SMBSPOOL_KRB5 - 
AUTH_INFO_REQUIRED=negotiate
  D [24/Jul/2018:10:33:00 +0100] [Job 45] SMBSPOOL_KRB5 - Started with uid=0
  D [24/Jul/2018:10:33:00 +0100] [Job 45] SMBSPOOL_KRB5 - AUTH_UID is not set

  As I said earlier this all works perfectly on Xenial and Trusty.
  (A similar AuthInfoRequired negotiate setup also works in cups 2.2.5 on MacOS 
10.13)

  Any ideas how to fix this?

  Thanks,

  Ian.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: cups 2.2.7-1ubuntu2.1
  ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
  Uname: Linux 4.15.0-29-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.2
  Architecture: amd64
  Date: Tue Jul 24 10:03:57 2018
  InstallationDate: Installed on 2018-06-22 (31 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  Lsusb:
   Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
   Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 001 Device 003: ID 0461:4d81 Primax Electronics, Ltd Dell N889 Optical 
Mouse
   Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. OptiPlex 790
  Papersize: a4
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz root=/dev/mapper/pd--ig--vg-root ro 
quiet splash
  SourcePackage: cups
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/28/2011
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A05
  dmi.board.name: 0HY9JP
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 6
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA05:bd05/28/2011:svnDellInc.:pnOptiPlex790:pvr01:rvnDellInc.:rn0HY9JP:rvrA00:cvnDellInc.:ct6:cvr:
  dmi.product.name: OptiPlex 790
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1783298/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1053207] Re: HTTPS connections fail when GNOME HTTP/HTTPS proxy config differ

2018-11-07 Thread Bug Watch Updater
** Changed in: libsoup
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libsoup2.4 in Ubuntu.
https://bugs.launchpad.net/bugs/1053207

Title:
  HTTPS connections fail when GNOME HTTP/HTTPS proxy config differ

Status in libsoup:
  Expired
Status in epiphany-browser package in Ubuntu:
  Confirmed
Status in libsoup2.4 package in Ubuntu:
  Confirmed

Bug description:
  [From upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=684418]

  Using the Soup GNOME features, when a HTTPS proxy is set to something that 
does
  not match the HTTP proxy, all HTTPS connections result in a
  SoupMessage.response_body.data being null.

  To reproduce:

  1. "apt-get install polipo" (or find a proxy supporting both HTTP and HTTPS)
  2. In gnome-control-center, set both HTTP and HTTPS proxy to localhost:8123 
(or
  your proxy address)
  3. Fetch https://duckduckgo.com/?q=foo using Soup w/ the GNOME feature type
  (Ephy 3.5.4 works here)
  4. Observe the page load succeeds

  5. Change the _HTTP_ proxy to be something other than the HTTPS proxy
  6. Fetch https://duckduckgo.com/?q=bar
  7. Observe the page load fails (in Ephy, results in a download of an empty
  file)

  Note that GProxy is returning the correct proxy address in both cases, so I
  assume Soup's GNOME proxy resolver is at issue here.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: libsoup-gnome2.4-1 2.39.92-0ubuntu1
  ProcVersionSignature: Ubuntu 3.5.0-15.21-generic 3.5.4
  Uname: Linux 3.5.0-15-generic x86_64
  ApportVersion: 2.5.2-0ubuntu3
  Architecture: amd64
  Date: Thu Sep 20 13:34:07 2012
  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
  SourcePackage: libsoup2.4
  UpgradeStatus: Upgraded to quantal on 2012-09-18 (1 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/libsoup/+bug/1053207/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1767162] Re: Random stripes and dots

2018-11-07 Thread Randy Tang
$ sudo lshw -c video
  *-display 
   description: VGA compatible controller
   product: Richland [Radeon HD 8570D]
   vendor: Advanced Micro Devices, Inc. [AMD/ATI]
   physical id: 1
   bus info: pci@:00:01.0
   version: 00
   width: 32 bits
   clock: 33MHz
   capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
   configuration: driver=radeon latency=0
   resources: irq:26 memory:c000-cfff ioport:f000(size=256) 
memory:fef0-fef3 memory:c-d


Output of journalctl is also attached.


** Attachment added: "journalctl"
   
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1767162/+attachment/5210175/+files/journalctl

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1767162

Title:
  Random stripes and dots

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  Ubuntu 18.04 LTS.

  Random stripes and dots appear on some texts. It happens on various
  applications. See the attached (an example of Rhythmbox).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1767162/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1799032] Re: Update to libcap 2.26

2018-11-07 Thread Bug Watch Updater
** Changed in: libcap2 (Debian)
   Status: Unknown => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libcap2 in Ubuntu.
https://bugs.launchpad.net/bugs/1799032

Title:
  Update to libcap 2.26

Status in libcap2 package in Ubuntu:
  New
Status in libcap2 package in Debian:
  New

Bug description:
  Hey everyone,

  We recently pushed support for ambient capabilities and namespaces filesystem 
capabilities
  to libcap2 [1]. Together with Andrew Morgan, Serge Hallyn and I have released 
a version 2.26
  of libcap2. Note that libcap2 has moved to a new location [2]

  The 2.26 release can be downloaded from [3].

  Please update to the new version!

  [1]: 
https://sites.google.com/site/fullycapable/release-notes-for-libcap/pre-releasenotesfor226
  [2]: https://git.kernel.org/pub/scm/libs/libcap/libcap.git/
  [3]: 
https://git.kernel.org/pub/scm/libs/libcap/libcap.git/snapshot/libcap-2.26.tar.gz

  Thanks!
  Christian

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libcap2/+bug/1799032/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802225] [NEW] LightDM login doesn't display after screen lock

2018-11-07 Thread NJ
Public bug reported:

When locking the screen via the xfce menu or light-locker tool the
screen sits at a blank/black screen. Moving the mouse or pressing a
button on the keyboard does nothing. After searching I found I could
just enter my password blindly and it would unlock the screen. Also
going to a console tty and back to the graphical login would then show a
login screen.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: lightdm 1.28.0-0ubuntu1
Uname: Linux 4.19.0-041900-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Nov  8 13:29:14 2018
InstallationDate: Installed on 2017-11-06 (366 days ago)
InstallationMedia: Xubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017.1)
LightdmConfig:
 [LightDM]
 logind-check-graphical=true
 display-setup-script=xrandr --output eDP-1 --primary
SourcePackage: lightdm
UpgradeStatus: Upgraded to cosmic on 2018-10-22 (17 days ago)

** Affects: lightdm (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug cosmic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1802225

Title:
  LightDM login doesn't display after screen lock

Status in lightdm package in Ubuntu:
  New

Bug description:
  When locking the screen via the xfce menu or light-locker tool the
  screen sits at a blank/black screen. Moving the mouse or pressing a
  button on the keyboard does nothing. After searching I found I could
  just enter my password blindly and it would unlock the screen. Also
  going to a console tty and back to the graphical login would then show
  a login screen.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: lightdm 1.28.0-0ubuntu1
  Uname: Linux 4.19.0-041900-generic x86_64
  ApportVersion: 2.20.10-0ubuntu13
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Thu Nov  8 13:29:14 2018
  InstallationDate: Installed on 2017-11-06 (366 days ago)
  InstallationMedia: Xubuntu 17.10 "Artful Aardvark" - Release amd64 
(20171017.1)
  LightdmConfig:
   [LightDM]
   logind-check-graphical=true
   display-setup-script=xrandr --output eDP-1 --primary
  SourcePackage: lightdm
  UpgradeStatus: Upgraded to cosmic on 2018-10-22 (17 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1802225/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1759836] Re: systemd-udevd consumes 100% of CPU

2018-11-07 Thread Kai-Heng Feng
Sounds like a kernel bug instead? Please boot with kernel parameter
`usbcore.dyndbg=+p` and attach dmesg.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1759836

Title:
  systemd-udevd consumes 100% of CPU

Status in linux:
  Confirmed
Status in The Ubuntu Power Consumption Project:
  New
Status in bluez package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Incomplete
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  The systemd-udevd proccess consumes 100% of a thread everytime, but
  i'm not noticing any difference in my computer.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: systemd 237-3ubuntu6
  ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
  Uname: Linux 4.15.0-13-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.9-0ubuntu2
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Mar 29 08:52:54 2018
  InstallationDate: Installed on 2018-03-05 (23 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180304)
  MachineType: Dell Inc. Inspiron N5010
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-13-generic 
root=UUID=3c29e292-f1ae-45e1-a0ed-a82524278ce1 ro quiet splash vt.handoff=1
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /lib/systemd/system/rc-local.service → 
/lib/systemd/system/rc-local.service.d/debian.conf
   [EXTENDED]   /lib/systemd/system/user@.service → 
/lib/systemd/system/user@.service.d/timeout.conf

   2 overridden configuration files found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/25/2011
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A12
  dmi.board.name: 08R0GW
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A12
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: A12
  dmi.modalias: 
dmi:bvnDellInc.:bvrA12:bd01/25/2011:svnDellInc.:pnInspironN5010:pvrA12:rvnDellInc.:rn08R0GW:rvrA12:cvnDellInc.:ct8:cvrA12:
  dmi.product.name: Inspiron N5010
  dmi.product.version: A12
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/kernel/+bug/1759836/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 310295] Re: Totem cannot play second audio stream

2018-11-07 Thread Bug Watch Updater
** Changed in: gstreamer
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gstreamer0.10 in Ubuntu.
https://bugs.launchpad.net/bugs/310295

Title:
  Totem cannot play second audio stream

Status in GStreamer:
  Expired
Status in gstreamer0.10 package in Ubuntu:
  Triaged
Status in gstreamer0.10 package in Arch Linux:
  New

Bug description:
  Binary package hint: totem-gstreamer

  Description:  Ubuntu jaunty (development branch)
  Release:  9.04

  I've  just installed Jaunty Alpha 2 and when I try to play a mkv file
  which happens to have a secondary audio vorbis (comments) Totem fails
  to decode stream.

  here is the output:

  (totem:12303): GStreamer-WARNING **: Failed to load plugin
  '/usr/lib/gstreamer-0.10/libgstice.so': libjinglep2pbase-0.3.so.0:
  cannot open shared object file: No such file or directory

  (totem:12302): GStreamer-WARNING **: Failed to load plugin 
'/usr/lib/gstreamer-0.10/libgstice.so': libjinglep2pbase-0.3.so.0: cannot open 
shared object file: No such file or directory
  ** (totem:12302): DEBUG: Init of Python module
  ** (totem:12302): DEBUG: Registering Python plugin instance: 
YouTube+TotemPythonPlugin
  ** (totem:12302): DEBUG: Creating object of type YouTube+TotemPythonPlugin
  ** (totem:12302): DEBUG: Creating Python plugin instance
  ** (totem:12302): DEBUG: Init of Python module
  ** (totem:12302): DEBUG: Registering Python plugin instance: 
BBCViewer+TotemPythonPlugin
  ** (totem:12302): DEBUG: Creating object of type BBCViewer+TotemPythonPlugin
  ** (totem:12302): DEBUG: Creating Python plugin instance
  Stream with high frequencies VQ coding
  ** Message: Error: Could not decode stream.
  vorbisdec.c(815): vorbis_handle_header_packet (): 
/GstPlayBin:play/GstDecodeBin:decodebin1/GstVorbisDec:vorbisdec0:
  couldn't read header packet

  ** (totem:12302): DEBUG: Finalizing Python plugin instance
  ** (totem:12302): DEBUG: Finalizing Python plugin instance

  
  The very same file used to work with Jaunty alpha 1.

  Installed packages:

  totem-gstreamer:
Instalado: 2.24.3-0ubuntu1
Candidato: 2.24.3-0ubuntu1
Tabela de versão:
   *** 2.24.3-0ubuntu1 0
  500 http://ftp.ubuntu.com jaunty/main Packages
  500 http://archive.ubuntu.com jaunty/main Packages
  100 /var/lib/dpkg/status

To manage notifications about this bug go to:
https://bugs.launchpad.net/gstreamer/+bug/310295/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1666432] Re: Internet drops every few minutes on wired and wireless connection

2018-11-07 Thread Michael Morisette
This started happening for me within the last week or so.  A recent
update may have triggered it?

I'm on a wired connection.  The connection randomly drops within a half
hour of system startup.  I can disconnect and reconnect and it seems to
fix it.

I dual-boot occasionally to Windows 7 (same machine), and it doesn't
appear to be an issue there.Definitely an Ubuntu specific bug

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1666432

Title:
  Internet drops every few minutes on wired and wireless connection

Status in network-manager package in Ubuntu:
  Confirmed

Bug description:
  Internet drops every 1-30 minutes when connected via wired or wireless
  (i.e., this is a problem on both wired and wireless) even though
  connection icon indicates the computer is still connected.

  Disconnecting and reconnecting via the connection icon resets internet
  temporarily until the next time.

  Dropped internet is discovered with "The site can't be reached"
  screens in Chromium, or error messages when downloading/updating in
  Terminal, or missing connection in Ubuntu Software app, or stalled
  syncing in Insync application (occurred even without Insync).

  Internet drops more frequently on wireless than on wired.

  It seems to disconnect more frequently with heavier internet use
  (e.g., downloading multiple files, opening several webpages in quick
  succession).

  This is a fresh install (yesterday) of Ubuntu 16.04 on a Dell Inspiron
  15 5567 (dual boot). It occurs when running Live CD as well though.

  Ethernet and wifi both work without randomly disconnecting in Windows
  10 on the same machine, and ethernet and wifi work on other machines
  running Ubuntu and Windows with the same router, so it is not a
  hardware or router issue.

  Output from sudo lshw -class network

  *-network
     description: Wireless interface
     product: Wireless 3165
     vendor: Intel Corporation
     physical id: 0
     bus info: pci@:02:00.0
     logical name: wlp2s0
     version: 79
     serial: 58:fb:84:55:21:52
     width: 64 bits
     clock: 33MHz
     capabilities: pm msi pciexpress bus_master cap_list ethernet physical 
wireless
     configuration: broadcast=yes driver=iwlwifi 
driverversion=4.4.0-62-generic firmware=17.352738.0 ip=192.168.1.15 latency=0 
link=yes multicast=yes wireless=IEEE 802.11abgn
     resources: irq:283 memory:df10-df101fff
    *-network
     description: Ethernet interface
     product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
     vendor: Realtek Semiconductor Co., Ltd.
     physical id: 0
     bus info: pci@:03:00.0
     logical name: enp3s0
     version: 07
     serial: 18:db:f2:3c:d5:37
     size: 10Mbit/s
     capacity: 100Mbit/s
     width: 64 bits
     clock: 33MHz
     capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet 
physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
     configuration: autonegotiation=on broadcast=yes driver=r8169 
driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 
latency=0 link=no multicast=yes port=MII speed=10Mbit/s
     resources: irq:279 ioport:d000(size=256) memory:df00-df000fff 
memory:d030-d0303fff

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: network-manager 1.2.2-0ubuntu0.16.04.3
  ProcVersionSignature: Ubuntu 4.4.0-62.83-generic 4.4.40
  Uname: Linux 4.4.0-62-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.5
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Tue Feb 21 16:36:55 2017
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2017-02-20 (1 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  IpRoute:
   default via 192.168.1.1 dev wlp2s0  proto static  metric 600
   169.254.0.0/16 dev wlp2s0  scope link  metric 1000
   192.168.1.0/24 dev wlp2s0  proto kernel  scope link  src 192.168.1.15  
metric 600
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-dev:
   DEVICE  TYPE  STATEDBUS-PATH  
CONNECTION   CON-UUID  CON-PATH
   wlp2s0  wifi  connected/org/freedesktop/NetworkManager/Devices/0  
pr500k-9912ec-1  36301ded-0ac5-4a86-9621-87290ef159af  
/org/freedesktop/NetworkManager/ActiveConnection/5
   enp3s0  ethernet  unavailable  /org/freedesktop/NetworkManager/Devices/1  -- 
  ----
   lo  loopback  unmanaged/org/freedesktop/NetworkManager/Devices/2  -- 
  --   

[Touch-packages] [Bug 1784023] Re: Update profiles for usrmerge

2018-11-07 Thread Bug Watch Updater
** Changed in: strongswan (Debian)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1784023

Title:
  Update profiles for usrmerge

Status in apparmor package in Ubuntu:
  Fix Released
Status in apparmor-profiles-extra package in Ubuntu:
  New
Status in dhcpcanon package in Ubuntu:
  New
Status in ejabberd package in Ubuntu:
  New
Status in firefox package in Ubuntu:
  In Progress
Status in fwknop package in Ubuntu:
  New
Status in i2p package in Ubuntu:
  New
Status in isc-dhcp package in Ubuntu:
  Fix Released
Status in kopanocore package in Ubuntu:
  New
Status in libvirt package in Ubuntu:
  Fix Released
Status in lightdm package in Ubuntu:
  Fix Released
Status in lightdm-remote-session-freerdp2 package in Ubuntu:
  Fix Released
Status in lightdm-remote-session-x2go package in Ubuntu:
  Fix Released
Status in man-db package in Ubuntu:
  Fix Released
Status in strongswan package in Ubuntu:
  Fix Released
Status in surf package in Ubuntu:
  New
Status in telepathy-mission-control-5 package in Ubuntu:
  Fix Released
Status in strongswan package in Debian:
  Fix Released

Bug description:
  this is about / and /usr merge.

  /bin & /sbin merge is out of scope. Anything that was in /sbin/  will
  remain in /{,usr/}sbin/.

  = src:apparmor =
  usr.bin.chromium-browser appears to be out of date w.r.t. apparmor-profiles 
upstream git tree

  /usr/share/apparmor/extra-profiles/usr.sbin.useradd needs update
  upstream https://gitlab.com/apparmor/apparmor/merge_requests/152/diffs

  = other packages =

  Slightly more complete list: https://paste.ubuntu.com/p/4zDJ8mTc5Z/

  $ sudo grep '[[:space:]]/bin' -r .
  ./usr.bin.man:  /bin/bzip2 rmCx -> _filter,
  ./usr.bin.man:  /bin/gzip rmCx -> _filter,
  ./usr.bin.man:  /bin/bzip2 rm,
  ./usr.bin.man:  /bin/gzip rm,
  ./usr.sbin.libvirtd:  /bin/* PUx,
  ./abstractions/lightdm:  /bin/ rmix,
  ./abstractions/lightdm:  /bin/fusermount Px,
  ./abstractions/lightdm:  /bin/** rmix,
  ./abstractions/libvirt-qemu:  /bin/uname rmix,
  ./abstractions/libvirt-qemu:  /bin/grep rmix,
  ./usr.bin.chromium-browser:  /bin/ps Uxr,
  ./usr.bin.chromium-browser:/bin/dash ixr,
  ./usr.bin.chromium-browser:/bin/grep ixr,
  ./usr.bin.chromium-browser:/bin/readlink ixr,
  ./usr.bin.chromium-browser:/bin/sed ixr,
  ./usr.bin.chromium-browser:/bin/which ixr,
  ./usr.bin.chromium-browser:/bin/mkdir ixr,
  ./usr.bin.chromium-browser:/bin/mv ixr,
  ./usr.bin.chromium-browser:/bin/touch ixr,
  ./usr.bin.chromium-browser:/bin/dash ixr,
  ./usr.bin.firefox:  /bin/which ixr,
  ./usr.bin.firefox:  /bin/ps Uxr,
  ./usr.bin.firefox:  /bin/uname Uxr,
  ./usr.bin.firefox:/bin/dash ixr,
  ./sbin.dhclient:  /bin/bash mr,

  $ sudo grep '[[:space:]]/sbin' -r .
  ./usr.lib.telepathy:deny /sbin/ldconfig x,
  ./usr.sbin.libvirtd:  /sbin/* PUx,
  ./abstractions/lightdm:  /sbin/ r,
  ./abstractions/lightdm:  /sbin/** rmixk,
  ./usr.bin.firefox:  /sbin/killall5 ixr,
  ./sbin.dhclient:  /sbin/dhclient mr,
  ./sbin.dhclient:  # daemon to run arbitrary code via /sbin/dhclient-script, 
it would need to be
  ./sbin.dhclient:  /sbin/dhclient-script   Uxr,

  $ sudo grep '[[:space:]]/lib' -r .
  ./snap.core.4917.usr.lib.snapd.snap-confine:/lib/udev/snappy-app-dev ixr, 
# drop
  ./usr.lib.snapd.snap-confine.real:/lib/udev/snappy-app-dev ixr, # drop
  ./abstractions/lightdm:  /lib/ r,
  ./abstractions/lightdm:  /lib/** rmixk,
  ./abstractions/lightdm:  /lib32/ r,
  ./abstractions/lightdm:  /lib32/** rmixk,
  ./abstractions/lightdm:  /lib64/ r,
  ./abstractions/lightdm:  /lib64/** rmixk,
  ./usr.bin.chromium-browser:/lib/libgcc_s.so* mr,
  ./usr.bin.chromium-browser:/lib/@{multiarch}/libgcc_s.so* mr,
  ./usr.bin.chromium-browser:/lib{,32,64}/libm-*.so* mr,
  ./usr.bin.chromium-browser:/lib/@{multiarch}/libm-*.so* mr,
  ./usr.bin.chromium-browser:/lib{,32,64}/libpthread-*.so* mr,
  ./usr.bin.chromium-browser:/lib/@{multiarch}/libpthread-*.so* mr,
  ./usr.bin.chromium-browser:/lib{,32,64}/libc-*.so* mr,
  ./usr.bin.chromium-browser:/lib/@{multiarch}/libc-*.so* mr,
  ./usr.bin.chromium-browser:/lib{,32,64}/libld-*.so* mr,
  ./usr.bin.chromium-browser:/lib/@{multiarch}/libld-*.so* mr,
  ./usr.bin.chromium-browser:/lib{,32,64}/ld-*.so* mr,
  ./usr.bin.chromium-browser:/lib/@{multiarch}/ld-*.so* mr,
  ./usr.bin.chromium-browser:/lib/tls/*/{cmov,nosegneg}/libm-*.so* mr,
  ./usr.bin.chromium-browser:/lib/tls/*/{cmov,nosegneg}/libpthread-*.so* mr,
  ./usr.bin.chromium-browser:/lib/tls/*/{cmov,nosegneg}/libc-*.so* mr,

  above list might be incomplete

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1784023/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to 

[Touch-packages] [Bug 1799111] Re: lots of Classes missing from docs (e.g. QFileInfo)

2018-11-07 Thread Bug Watch Updater
** Changed in: qtbase-opensource-src (Debian)
   Status: Unknown => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1799111

Title:
  lots of Classes missing from docs (e.g. QFileInfo)

Status in qtbase-opensource-src package in Ubuntu:
  New
Status in qtbase-opensource-src package in Debian:
  Fix Released

Bug description:
  [Impact]
  The packaged Qt documentation, which can be viewed in browser (qt*-doc-html 
packages) or in Qt Assistant (qt*-doc packages) is missing all documentation 
generated from C++ files. Only the static text is present.

  Qt is split by many modules (qtbase, qtdeclarative, qtwebengine,
  etc.). I am now fixing it for qtbase, the largest module, but I may
  fix it for other modules if someone requests it.

  [Test Case]
  1. Install qtbase5-doc-html package.
  2. Make sure /usr/share/qt5/doc/qtcore/qobject.html is present.

  [Regression Potential]
  The proposed fix only adds a new build-dependency. There is absolutely no 
regression potential.

  [Other Info]
  Description of the fix:

  qdoc is a tool that parses C++ source files and generates
  documentation from them. Recently, qdoc began using clang instead of
  its own C++ parser. Clang needs the C++ standard library to work. qdoc
  build system uses a build-time macro (CLANG_RESOURCE_DIR) that hard-
  codes the path to standard library in the executable:
  https://code.qt.io/cgit/qt/qttools.git/tree/src/qdoc/qdoc.pro?h=5.11#n19.

  From qttools-opensource-src 5.11.1-5 build log in Cosmic amd64, one
  can see that qdoc was compiled with
  -D'CLANG_RESOURCE_DIR="/usr/lib/llvm-6.0/lib/clang/6.0.1/include"'. So
  this directory needs to be present when qdoc is used. This directory
  is provided by libclang-common-6.0-dev package. So adding it to build-
  dependencies makes the documentation build correctly.

  This is the minimal fix for Cosmic. For Ubuntu 19.04, I will try to
  use a better solution like moving the clang standard library detection
  from build time to run time, or making qttools5-dev-tools depend on
  the needed -dev packages.

  [Original Description]
  The Qt offline documentation for cosmic is incomplete. In fact there's 
virtually no content what so ever. It would be easier I think to list what 
actually got picked up that what was missed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1799111/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1801642] Re: Bluetooth mouse sleeps after 5 seconds of inactivity

2018-11-07 Thread Wajuz Donny
Day 3: No issue after wake from suspend.
Day 4: Issue comes back again (after suspend). Resolved after toggling 
"Autosuspend on" for two unknown USB devices to "Bad".

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1801642

Title:
  Bluetooth mouse sleeps after 5 seconds of inactivity

Status in bluez package in Ubuntu:
  Invalid

Bug description:
  I'm having bluetooth mouse lag issue. After leaving it stationary for
  5 seconds, I have to move it for 2 seconds before the pointer starts
  moving.

  I recently upgraded to Cosmic 3 days ago (from Bionic). There was no
  issue in the first 3 days, including after suspend/restart/shutdown.
  This issue only appears starting today.

  I tried:
  1. Running 'bluetoothctl' and then 'scan off'. The command failed to run with 
'Failed to stop discovery: org.bluez.Error.Failed'.
  2. modprobe -r btusb, then modprobe it again.
  3. sudo sh -c 'echo N > /sys/module/drm_kms_helper/parameters/poll'
  4. Disabling wifi.

  $ apt-cache policy bluez
  5.50-0ubuntu1

  $uname -a; lspci -nnk | grep -iA2 net; lsusb; dmesg | grep -i bluetooth; 
dmesg | grep -i firmware; lsmod | grep bluetooth
  4.18.0-10-generic #11
  02:00.0 Network controller [0280]: Intel Corporation Wireless 7260 
[8086:08b1] (rev 73)
Subsystem: Intel Corporation Dual Band Wireless-N 7260 [8086:4460]
Kernel driver in use: iwlwifi
  03:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. 
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)
Subsystem: Dell RTL8111/8168/8411 PCI Express Gigabit Ethernet 
Controller [1028:05f9]
Kernel driver in use: r8169
Kernel modules: r8169
  Bus 001 Device 002: ID 8087:8000 Intel Corp. 
  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 003 Device 003: ID 17e9:4301 DisplayLink 
  Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
  Bus 002 Device 047: ID 04f3:0206 Elan Microelectronics Corp. 
  Bus 002 Device 006: ID 8087:07dc Intel Corp. 
  Bus 002 Device 034: ID 0461:4d51 Primax Electronics, Ltd 0Y357C PMX-MMOCZUL 
(B) [Dell Laser Mouse]
  Bus 002 Device 118: ID 0853:0132 Topre Corporation 
  Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  [  287.361153] hid-generic 0005:046D:B012.0005: input,hidraw2: BLUETOOTH HID 
v0.14 Keyboard [MX Master] on FC:F8:AE:33:C7:31
  bluetooth 548864  33 btrtl,btintel,btbcm,bnep,btusb,rfcomm
  ecdh_generic   24576  2 bluetooth

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: bluez 5.50-0ubuntu1
  ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
  Uname: Linux 4.18.0-10-generic x86_64
  ApportVersion: 2.20.10-0ubuntu13
  Architecture: amd64
  CurrentDesktop: MATE
  Date: Mon Nov  5 13:40:01 2018
  InstallationDate: Installed on 2018-07-08 (119 days ago)
  InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: Dell Inc. Inspiron 7537
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.18.0-10-generic 
root=/dev/mapper/ubuntu--mate--vg-root ro ipv6.disable=1 quiet splash 
i915.enable_psr=0
  SourcePackage: bluez
  UpgradeStatus: Upgraded to cosmic on 2018-11-02 (3 days ago)
  dmi.bios.date: 10/31/2013
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A05
  dmi.board.name: 07PF9F
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: 0.1
  dmi.modalias: 
dmi:bvnDellInc.:bvrA05:bd10/31/2013:svnDellInc.:pnInspiron7537:pvr:rvnDellInc.:rn07PF9F:rvrA00:cvnDellInc.:ct8:cvr0.1:
  dmi.product.family: Shark Bay ULT
  dmi.product.name: Inspiron 7537
  dmi.product.sku: Inspiron 7537
  dmi.sys.vendor: Dell Inc.
  hciconfig:
   hci0:Type: Primary  Bus: USB
BD Address: FC:F8:AE:33:C7:31  ACL MTU: 1021:5  SCO MTU: 96:5
UP RUNNING 
RX bytes:2380 acl:32 sco:0 events:208 errors:0
TX bytes:28560 acl:29 sco:0 commands:170 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1801642/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 630185] Re: Totem doesn't display SSA/ASS subtitles correctly

2018-11-07 Thread Bug Watch Updater
** Changed in: gst-plugins-base
   Status: In Progress => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-base0.10 in
Ubuntu.
https://bugs.launchpad.net/bugs/630185

Title:
  Totem doesn't display SSA/ASS subtitles correctly

Status in gst-plugins-base:
  Expired
Status in gst-plugins-base0.10 package in Ubuntu:
  Triaged

Bug description:
  In Maverick beta Totem cannot handle properly SSA/ASS subtitles.
  Actually they are rendered as .srt subtitles. Regression from Lucid.

  ProblemType: Bug
  DistroRelease: Ubuntu 10.10
  Package: libgstreamer0.10-0 0.10.30-1build2
  ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
  Uname: Linux 2.6.35-19-generic x86_64
  NonfreeKernelModules: nvidia
  Architecture: amd64
  Date: Sat Sep  4 14:32:46 2010
  ExecutablePath: /usr/bin/totem
  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
  ProcEnviron:
   SHELL=/bin/bash
   LANG=it_IT.utf8
  SourcePackage: gstreamer0.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/gst-plugins-base/+bug/630185/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1734967] Re: tzdata info for WGT/WGST broken

2018-11-07 Thread Bug Watch Updater
** Changed in: php7.0 (Debian)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to tzdata in Ubuntu.
https://bugs.launchpad.net/bugs/1734967

Title:
  tzdata info for WGT/WGST broken

Status in php5 package in Ubuntu:
  New
Status in php7.0 package in Ubuntu:
  New
Status in php7.1 package in Ubuntu:
  New
Status in tzdata package in Ubuntu:
  Invalid
Status in php7.0 package in Debian:
  Fix Released

Bug description:
  Using "America/Godthab" timezone, "WGT/WGST" is no longer displayed
  from date command but instead just "-03". Problem is evident in PHP
  applications too, which now think we're in Sao Paolo.

  This appears to have changed with latest tzdata update or perhaps in
  combination with change from DST.

  Same problem on 16.04, 17.10 and Debian 9.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/1734967/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1740894] Re: KEY_RFKILL is not passed to userspace

2018-11-07 Thread Mario Vukelic
As an additional check I once more installed the SRU version (and
rebooted):

$ apt-cache policy xkb-data
xkb-data:
  Installed: 2.23.1-1ubuntu1.18.10.1
  Candidate: 2.23.1-1ubuntu1.18.10.1
  Version table:
 *** 2.23.1-1ubuntu1.18.10.1 500
500 http://de.archive.ubuntu.com/ubuntu cosmic-proposed/main amd64 
Packages
500 http://de.archive.ubuntu.com/ubuntu cosmic-proposed/main i386 
Packages
100 /var/lib/dpkg/status
 2.23.1-1ubuntu1 500
500 http://de.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
500 http://de.archive.ubuntu.com/ubuntu cosmic/main i386 Packages



Now the problem occurs again. I.e. the first key press still enables the
airplane mode just like with the non-SRU version, but the second key
press fails to disable the mode:

1.Press key (STILL OK)

-> Airplane mode enables. The airplane mode icon appears in the Gnome
panel. Wifi turns off. BT turns off.

2. Press key again (THIS IS NOW BROKEN)

-> Airplane mode appears to disable momentarily: For a short moment the
airplane mode icon disappears from the Gnome panel. HOWEVER, then the
airplane mode immediately and automatically re-enables. The airplane
mode icon reappears in the panel, Wifi and BT remain off.


- does that command works to get out of airplane mode? (Command: gdbus call 
etc.)

Yes, this still works

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libxkbcommon in Ubuntu.
https://bugs.launchpad.net/bugs/1740894

Title:
  KEY_RFKILL is not passed to userspace

Status in libxkbcommon package in Ubuntu:
  Fix Released
Status in xkeyboard-config package in Ubuntu:
  Fix Released
Status in xorgproto package in Ubuntu:
  Fix Released
Status in xkeyboard-config source package in Bionic:
  Fix Committed
Status in xkeyboard-config source package in Cosmic:
  Fix Committed

Bug description:
  * Impact
  the airplane mode key doesn't work in GNOME

  * Test case
  Use a laptop with a key to activate airplane mode, it should toggle the 
corresponding mode on/off when used

  * Regression potential
  The change adds a new key definition but doesn't touch any existing one, 
nothing specific to test out of the new key working

  -

  There are a couple things going on, that could be fixed by a Debian or
  Ubuntu maintainer:

  - libxkbdcommon needs to be updated from 0.7.1 to 0.7.2. This
  introduces the RFKill key: https://lists.freedesktop.org/archives
  /wayland-devel/2017-August/034721.html

  - x11-proto needs a new release. This commit added RFKill, but it is
  not in a release:
  
https://cgit.freedesktop.org/xorg/proto/xproto/commit/?id=98a32d328e7195e12c38baa877917335bceffbaf

  - Likely other X11 packages need to be rebuilt.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libxkbcommon/+bug/1740894/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1740894] Re: KEY_RFKILL is not passed to userspace

2018-11-07 Thread Mario Vukelic
@Sebastian:

I reinstalled the non-SRU version:

$ apt-cache policy xkb-data
xkb-data:
  Installed: 2.23.1-1ubuntu1
  Candidate: 2.23.1-1ubuntu1.18.10.1
  Version table:
 2.23.1-1ubuntu1.18.10.1 500
500 http://de.archive.ubuntu.com/ubuntu cosmic-proposed/main amd64 
Packages
500 http://de.archive.ubuntu.com/ubuntu cosmic-proposed/main i386 
Packages
 *** 2.23.1-1ubuntu1 500
500 http://de.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
500 http://de.archive.ubuntu.com/ubuntu cosmic/main i386 Packages
100 /var/lib/dpkg/status


- on a stock XPS with the non-SRU version, what keycode do you get in xev

I press Fn+Pos1 and I get:

FocusIn event, serial 39, synthetic NO, window 0x201,
mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 39, synthetic NO, window 0x0,
keys:  4294967246 0   0   0   0   0   0   0   0   0   0   0   0   0   0   0 
  
   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

MappingNotify event, serial 39, synthetic NO, window 0x0,
request MappingKeyboard, first_keycode 8, count 248

KeyPress event, serial 39, synthetic NO, window 0x201,
root 0x1ce, subw 0x0, time 272898, (-557,525), root:(1274,1553),
state 0x0, keycode 255 (keysym 0x0, NoSymbol), same_screen YES,
XLookupString gives 0 bytes: 
XmbLookupString gives 0 bytes: 
XFilterEvent returns: False

KeyRelease event, serial 39, synthetic NO, window 0x201,
root 0x1ce, subw 0x0, time 272898, (-557,525), root:(1274,1553),
state 0x0, keycode 255 (keysym 0x0, NoSymbol), same_screen YES,
XLookupString gives 0 bytes: 
XFilterEvent returns: False


- on a stock cosmic what happens when you use the key

1.Press key

-> Airplane mode enables. The airplane mode icon appear in the Gnome
panel. Wifi turns off. BT turns off

2. Press key again

-> Airplane mode disables. The airplane mode icon disappears from the
Gnome panel. Wifi turns on. BT turns on.


I.e., it works perfectly. Every time I press the key, the airplane mode changes 
into the other state (on or off)


- does that command works to get out of airplane mode? (Command: gdbus call 
etc.)

Yes

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libxkbcommon in Ubuntu.
https://bugs.launchpad.net/bugs/1740894

Title:
  KEY_RFKILL is not passed to userspace

Status in libxkbcommon package in Ubuntu:
  Fix Released
Status in xkeyboard-config package in Ubuntu:
  Fix Released
Status in xorgproto package in Ubuntu:
  Fix Released
Status in xkeyboard-config source package in Bionic:
  Fix Committed
Status in xkeyboard-config source package in Cosmic:
  Fix Committed

Bug description:
  * Impact
  the airplane mode key doesn't work in GNOME

  * Test case
  Use a laptop with a key to activate airplane mode, it should toggle the 
corresponding mode on/off when used

  * Regression potential
  The change adds a new key definition but doesn't touch any existing one, 
nothing specific to test out of the new key working

  -

  There are a couple things going on, that could be fixed by a Debian or
  Ubuntu maintainer:

  - libxkbdcommon needs to be updated from 0.7.1 to 0.7.2. This
  introduces the RFKill key: https://lists.freedesktop.org/archives
  /wayland-devel/2017-August/034721.html

  - x11-proto needs a new release. This commit added RFKill, but it is
  not in a release:
  
https://cgit.freedesktop.org/xorg/proto/xproto/commit/?id=98a32d328e7195e12c38baa877917335bceffbaf

  - Likely other X11 packages need to be rebuilt.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libxkbcommon/+bug/1740894/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 40189] Re: [SRU] [xenial] [bionic] autofs needs to be restarted to pick up some shares

2018-11-07 Thread Kevin
I'm running into this bug as well on 16.04.5

I've tried the autofs.service (SystemD) solution. I've tried the startup
scripts in the rc.local and it "seems" to work most of the time, but not
really ideal.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to upstart in Ubuntu.
https://bugs.launchpad.net/bugs/40189

Title:
  [SRU] [xenial] [bionic] autofs needs to be restarted to pick up some
  shares

Status in autofs package in Ubuntu:
  Fix Released
Status in autofs5 package in Ubuntu:
  Invalid
Status in upstart package in Ubuntu:
  Invalid
Status in autofs source package in Xenial:
  Incomplete

Bug description:
  I am using autofs to access shares on a Windows XP machine from a
  Kubuntu AMD64 machine.  The problems applies in both Breezy and
  Dapper.

  EDIT:  confirmed with similar configuration on Intrepid with a NetApp
  filer hosting NFS.  Server OS removed from summary.

  When I first try to access the mount point via cd or in Konqueror it
  does not exist.  However,  if I then restart autofs
  (/etc/init.d/autofs restart) everythin then works OK.  My config files
  are:

  auto.master

  #
  # $Id: auto.master,v 1.3 2003/09/29 08:22:35 raven Exp $
  #
  # Sample auto.master file
  # This is an automounter map and it has the following format
  # key [ -mount-options-separated-by-comma ] location
  # For details of the format look at autofs(5).
  #/misc/etc/auto.misc --timeout=60
  #/misc/etc/auto.misc
  #/net /etc/auto.net

  /petunia /etc/petunia.misc --timeout=60

  
  petunia.misc

  #
  # $Id: auto.misc,v 1.2 2003/09/29 08:22:35 raven Exp $
  #
  # This is an automounter map and it has the following format
  # key [ -mount-options-separated-by-comma ] location
  # Details may be found in the autofs(5) manpage

  cd  -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom

  tony  -fstype=smbfs,defaults,password=xxx,fmask=777,dmask=777 
://192.168.1.2/tony
  chris -fstype=smbfs,defaults,password=xxx,fmask=777,dmask=777 
://192.168.1.2/chris
  shared-fstype=smbfs,defaults,password=xxx,fmask=777,dmask=777 
://192.168.1.2/SharedDocs
  linuxbackups  -fstype=smbfs,defaults,password=xxx,fmask=777,dmask=777 
://192.168.1.2/linuxbackups

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/autofs/+bug/40189/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 413620] Re: Totem / GStreamer can't read .idx-subtitles

2018-11-07 Thread Bug Watch Updater
** Changed in: gstreamer
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gstreamer0.10 in Ubuntu.
https://bugs.launchpad.net/bugs/413620

Title:
  Totem / GStreamer can't read .idx-subtitles

Status in GStreamer:
  Expired
Status in gstreamer0.10 package in Ubuntu:
  Triaged
Status in gstreamer1.0 package in Ubuntu:
  New

Bug description:
  Im facing a a minor problem in the Totem / GStreamer player:

  It seams to be unable to read .idx subtitle files. A bit strange,
  since it identify .idx as a subtitle format (along with for example
  .sub and .srt) when I choose subtiles.

  
  This bug is similar to the #159678 which concerns .smi files. 

  And for the record, Im using ubuntu 9.04 and Totem 2.25.1 / GStreamer
  0.10.22

To manage notifications about this bug go to:
https://bugs.launchpad.net/gstreamer/+bug/413620/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1639531] Re: GCC compiles programs to shared object instead of executable, preventing GUI file managers from executing programs

2018-11-07 Thread Bug Watch Updater
Launchpad has imported 8 comments from the remote bug at
https://bugs.freedesktop.org/show_bug.cgi?id=97226.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2016-08-06T13:12:36+00:00 David Faure wrote:

/usr/bin/ls: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV),
dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for
GNU/Linux 3.0.0, BuildID[sha1]=339279bdac0d1a8c98b6bbb92afc8d8edb185d9f,
stripped

This file is detected as application/x-sharedlib instead of
application/x-executable, by the s-m-i test suite, if I add it there.

Patch for the test suite: http://www.davidfaure.fr/kde/smi.diff
+ downloading http://www.davidfaure.fr/kde/ls into tests/.

Result:
ls, 'data' test: expected application/x-executable, got application/x-sharedlib
ls, 'file' test: expected application/x-executable, got application/x-sharedlib

There must be a bug in the ELF magic for application/x-sharedlib and/or
application/x-executable.

Reply at: https://bugs.launchpad.net/ubuntu/+source/shared-mime-
info/+bug/1639531/comments/0


On 2016-08-06T13:17:24+00:00 Bugzilla-x wrote:

Or you could just dump the file into the staging-tests/ directory, and
run "make local-test". Patch welcome, but I wonder how useful that magic
(or lack of accuracy) actually is.

Reply at: https://bugs.launchpad.net/ubuntu/+source/shared-mime-
info/+bug/1639531/comments/1


On 2016-08-06T18:05:51+00:00 David Faure wrote:

Well we need a way to find out that /bin/ls is an executable, and
there's no extension, so working magic would be useful ;)

However I don't know anything about the ELF file format, so I don't know
what the problem actually is (and whether it offers reliable magic).

Admittedly the magic for x-sharedlib is the one that's much less useful, shared 
libs are typically called *.so or *.so.[0-9\.]* :-)
But I wouldn't dare just removing all magic from x-sharedlib... unless someone 
can prove that the ELF file format makes no actual difference between shared 
libs and executables?

Reply at: https://bugs.launchpad.net/ubuntu/+source/shared-mime-
info/+bug/1639531/comments/2


On 2017-01-05T01:25:47+00:00 Alan Coopersmith wrote:

The ELF file format distinguishes between traditional executables and shared
objects, but unfortunately PIE executables are treated as ELF shared objects

Reply at: https://bugs.launchpad.net/ubuntu/+source/shared-mime-
info/+bug/1639531/comments/9


On 2017-01-14T16:16:09+00:00 Yann Droneaud wrote:

AFAIK, a shared object could be a PIE program if it has a (valid)
interpretor header (PT_INTERP).

It should be noted that glibc's ELF loader (ld-linux.so, exact name
depending on architecture) is a shared object and a valid program, but
doesn't have an interpretor header, but that's the only exception I
aware of.

IOTH, glibc's libc.so is a shared object with a valid interpretor,
making it a valid program (try it !). Reporting such library as a
program might be misleading for end user.

Anyway, PT_INTERP header not at a fixed location in the ELF file, so it
cannot be described in shared-mime-info database.

(It's a pity PIE ELF files were not describe with a new ELF type or at
least a flag :(

Reply at: https://bugs.launchpad.net/ubuntu/+source/shared-mime-
info/+bug/1639531/comments/10


On 2017-09-06T21:34:59+00:00 dkg wrote:

This has been open for over a year, and is related to even older bugs in
tools that depend on shared-mime-info (e.g.
https://bugzilla.gnome.org/show_bug.cgi?id=737849 ).  This is also an
issue in libmagic, and there is more discussion about ELF over there:
https://bugzilla.redhat.com/show_bug.cgi?id=1296868

It'd be great to have some sort of resolution here.

Reply at: https://bugs.launchpad.net/ubuntu/+source/shared-mime-
info/+bug/1639531/comments/11


On 2017-09-06T21:39:53+00:00 Bugzilla-x wrote:

(In reply to Daniel Kahn Gillmor from comment #5)
> It'd be great to have some sort of resolution here.

That's not going to happen unless somebody has a patch. Reading comment
4, that seems unlikely. If you have applications that require this deep
level of knowledge of the different formats, you'll probably want to use
something more precise than the shared-mime spec.

Reply at: https://bugs.launchpad.net/ubuntu/+source/shared-mime-
info/+bug/1639531/comments/12


[Touch-packages] [Bug 1714178]

2018-11-07 Thread Martin-peres-n
I posted a patch series for -modesetting that fixes this issue, and also
adds TearFree support:
https://gitlab.freedesktop.org/xorg/xserver/merge_requests/24

The patch series from Ville
(https://patchwork.freedesktop.org/series/49663/) will however be what
you are looking for, as it will not reduce the performance at all.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1714178

Title:
  Triple 4K monitor display failed (modesetting driver limited to
  8192x8192)

Status in X.Org X server:
  Confirmed
Status in linux package in Ubuntu:
  Triaged
Status in mesa package in Ubuntu:
  Fix Released
Status in xorg-server package in Ubuntu:
  Triaged
Status in linux source package in Bionic:
  Confirmed
Status in mesa source package in Bionic:
  Confirmed
Status in xorg-server source package in Bionic:
  Confirmed

Bug description:
  Title: Triple monitor display failed with Dell Dock (HiDPI)
  (modesetting)

  Summary: Triple monitor display failed with Dell Dock (HiDPI)
  (modesetting)

  Steps:
  1. a laptop with Built-in 4K LCD
  2. Cold boot system with Dell Dock connected
  3. Connect a 4K monitor to Dock
  4. Connect 2nd 4K monitor to Dock
  5. Go to [All Settings]=>[Displays] to have the following configuration.
  Resolution: 4kx2k@60Hz (one Built-in LCD + two external monitors)
  Mirror displays: disable

  Expected results: Triple monitor display should works without issues
  Actual results: Triple monitor display failed with Dell Dock

  Additional information:
  1. Linux distribution: Ubuntu 16.04+modesetting, 16.04.3, and 17.04
  2. Laptop: Dell Precision 5520
  3. Dell Business Thunderbolt Dock - TB16
  https://goo.gl/vFDjpi

  WORKAROUND (UBUNTU 18.04+):
  Log in to "Ubuntu on Wayland" instead of "Ubuntu".

  ---
  .tmp.unity_support_test.0:

  ApportVersion: 2.20.1-0ubuntu2.10
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is a distribution channel descriptor
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-xenial-amd64-20160624-2
  DistroCodename: xenial
  DistroRelease: Ubuntu 16.04
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:591d] (rev 04) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:07bf]
     Subsystem: Dell Device [1028:07bf]
  InstallationDate: Installed on 2017-08-29 (2 days ago)
  InstallationMedia: Ubuntu 16.04 "Xenial" - Build amd64 LIVE Binary 
20160624-10:47
  MachineType: Dell Inc. Precision 5520
  Package: xorg-server (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.11.0-14-generic.efi.signed 
root=UUID=b79ae801-0652-4785-beaf-e8387d798948 ro acpi_rev_override quiet 
splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.11.0-14.20~16.04.1-generic 4.11.12
  Tags:  xenial ubuntu compiz-0.9
  Uname: Linux 4.11.0-14-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 05/08/2017
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.3.3
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.3.3:bd05/08/2017:svnDellInc.:pnPrecision5520:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
  dmi.product.name: Precision 5520
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.76-1~ubuntu16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.7-0ubuntu0.16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.7-0ubuntu0.16.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.3
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1.2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2

To manage notifications about this bug go to:
https://bugs.launchpad.net/xorg-server/+bug/1714178/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1796324] Re: symbol export missing: pa_encoding_from_string

2018-11-07 Thread Bug Watch Updater
Launchpad has imported 3 comments from the remote bug at
https://bugs.freedesktop.org/show_bug.cgi?id=103806.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2017-11-17T22:58:40+00:00 Felipe Sateler wrote:

Forwarded from #882029. This function is found in format.h but it not
exported in map-file and thus unavailable on most (all?) linux systems.
I don't know if the function is supposed to be exported, or maybe it
should be private instead.


#882029: https://bugs.debian.org/882029

Reply at:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1796324/comments/0


On 2017-12-12T04:16:52+00:00 Tanu Kaskinen wrote:

I'm 99.3% certain that it's supposed to be exported. It's documented,
and internally it's only used in format.c, so if it isn't meant to be
exported, then the declaration should be removed from format.h since
it's not needed.

Patch submitted:
https://patchwork.freedesktop.org/patch/192885/

Reply at:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1796324/comments/1


On 2017-12-12T05:03:09+00:00 Tanu Kaskinen wrote:

The patch is now in master.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1796324/comments/2


** Changed in: pulseaudio
   Status: Unknown => Fix Released

** Changed in: pulseaudio
   Importance: Unknown => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1796324

Title:
  symbol export missing: pa_encoding_from_string

Status in PulseAudio:
  Fix Released
Status in pulseaudio package in Ubuntu:
  Fix Released
Status in pulseaudio package in Debian:
  Confirmed

Bug description:
  This specific release of libpulsecommon-11.1 is missing the symbol
  `pa_encoding_from_string`.

  This was fixed upstream: https://bugs.freedesktop.org/show_bug.cgi?id=103806
  This has a Debian bug open, but I suspect it's been fixed by bumping major 
version: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=882029

  This results in unexpected:

   = note: /usr/bin/ld: 
/home/faux/code/rust-tone/target/debug/deps/liblibpulse_binding-f64ba2ce37bb3bc6.rlib(libpulse_binding-f64ba2ce37bb3bc6.libpulse_binding.3msoaviz-cgu.13.rcgu.o):
 undefined reference to symbol 'pa_encoding_from_string'
//usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-11.1.so: error 
adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: libpulse-dev 1:11.1-1ubuntu7.1
  ProcVersionSignature: Ubuntu 4.15.0-36.39-generic 4.15.18
  Uname: Linux 4.15.0-36-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.9-0ubuntu7.4
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  faux   2964 F pulseaudio
   /dev/snd/controlC2:  faux   2964 F pulseaudio
   /dev/snd/pcmC0D0p:   faux   2964 F...m pulseaudio
   /dev/snd/controlC0:  faux   2964 F pulseaudio
  Date: Fri Oct  5 15:37:38 2018
  InstallationDate: Installed on 2018-04-25 (162 days ago)
  InstallationMedia: Ubuntu-Server 18.04 LTS "Bionic Beaver" - Release amd64 
(20180425)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/22/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1402
  dmi.board.asset.tag: Default string
  dmi.board.name: TUF Z370-PRO GAMING
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr1402:bd05/22/2018:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnTUFZ370-PROGAMING:rvrRev1.xx:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to:
https://bugs.launchpad.net/pulseaudio/+bug/1796324/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1499858] Re: bluetoothd[650]: Failed to obtain handles for "Service Changed" characteristic

2018-11-07 Thread Singtoh
Hello again,

I compiled bluez-5.46 & installed it on ubuntu 16.04 and this has taken
care of all of the "Not enough free handles to register service" errors
and also "Failed to obtain handles for "Service Changed" characteristic"
errors and bluetooth is working better than it ever has, for me anyway.
So for me this is solved, I suppose.

Don't know if this will help anyone?? But I hope so!

Cheers,

Singtoh

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1499858

Title:
  bluetoothd[650]: Failed to obtain handles for "Service Changed"
  characteristic

Status in bluez package in Ubuntu:
  Confirmed

Bug description:
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Failed to obtain 
handles for "Service Changed" characteristic
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Not enough free 
handles to register service
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Error adding Link 
Loss service
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Not enough free 
handles to register service
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Not enough free 
handles to register service
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Not enough free 
handles to register service
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Current Time Service 
could not be registered
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: gatt-time-server: 
Input/output error (5)
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Not enough free 
handles to register service
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Not enough free 
handles to register service
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: Sap driver 
initialization failed.
  sep 25 11:03:01 username-530U3C-530U4C bluetoothd[650]: sap-server: Operation 
not permitted (1)

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: bluez 5.34-0ubuntu1
  ProcVersionSignature: Ubuntu 4.2.0-11.13-generic 4.2.1
  Uname: Linux 4.2.0-11-generic x86_64
  ApportVersion: 2.19-0ubuntu1
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Fri Sep 25 16:37:42 2015
  InstallationDate: Installed on 2015-07-26 (61 days ago)
  InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150723)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 530U3C/530U4C
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-11-generic 
root=UUID=4f4435ca-b877-47a5-9065-3dd624c0514e ro rootflags=subvol=@ quiet 
splash vt.handoff=7
  SourcePackage: bluez
  UdevLog: Error: [Errno 2] No existe el archivo o el directorio: 
'/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/15/2013
  dmi.bios.vendor: Phoenix Technologies Ltd.
  dmi.bios.version: P14AAJ
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: SAMSUNG_NP1234567890
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: FAB1
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: 0.1
  dmi.modalias: 
dmi:bvnPhoenixTechnologiesLtd.:bvrP14AAJ:bd04/15/2013:svnSAMSUNGELECTRONICSCO.,LTD.:pn530U3C/530U4C:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rnSAMSUNG_NP1234567890:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
  dmi.product.name: 530U3C/530U4C
  dmi.product.version: 0.1
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
  hciconfig:
   hci0:Type: BR/EDR  Bus: USB
BD Address: C4:85:08:6C:01:0A  ACL MTU: 310:10  SCO MTU: 64:8
UP RUNNING PSCAN 
RX bytes:12620731 acl:54193 sco:0 events:799035 errors:0
TX bytes:447934374 acl:1637190 sco:0 commands:1459 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1499858/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 367334] Re: console-kit-daemon[2951]: WARNING: Couldn't read /proc/2950/environ: Failed to open file '/proc/2950/environ': No such file or directory

2018-11-07 Thread Bug Watch Updater
** Changed in: consolekit
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to consolekit in Ubuntu.
https://bugs.launchpad.net/bugs/367334

Title:
  console-kit-daemon[2951]: WARNING: Couldn't read /proc/2950/environ:
  Failed to open file '/proc/2950/environ': No such file or directory

Status in ConsoleKit:
  Fix Released
Status in consolekit package in Ubuntu:
  Confirmed

Bug description:
  Binary package hint: consolekit

  This line appears in my syslog. I don't know what its importance is:

  console-kit-daemon[2951]: WARNING: Couldn't read /proc/2950/environ:
  Failed to open file '/proc/2950/environ': No such file or directory

  The folder 2950 itself also doesn't exist. 2951 however does. Just a
  guess then: shouldn't it be trying to read /proc/2951/environ instead?

  Ubuntu 9.04, consolekit 0.3.0-2ubuntu4 (jaunty proposed)

To manage notifications about this bug go to:
https://bugs.launchpad.net/consolekit/+bug/367334/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802181] [NEW] GnuCash Reports don't show charts

2018-11-07 Thread benste
Public bug reported:

Reports don't show charts after recent upgrades (maybe also since the ubuntu 
version upgrade)
The IRC community suspects a similar issue to 
https://blogs.gnome.org/mcatanzaro/2018/11/06/mesa-update-breaks-webkitgtk-in-fedora-29/

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: gnucash 1:3.3-2
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
NonfreeKernelModules: wl nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Nov  7 22:38:23 2018
InstallationDate: Installed on 2018-09-15 (53 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: gnucash
UpgradeStatus: Upgraded to cosmic on 2018-10-19 (19 days ago)

** Affects: gnucash (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: mesa (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug cosmic

** Also affects: mesa (Ubuntu)
   Importance: Undecided
   Status: New

** Summary changed:

- Reports don't show charts
+ GnuCash Reports don't show charts

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1802181

Title:
  GnuCash Reports don't show charts

Status in gnucash package in Ubuntu:
  New
Status in mesa package in Ubuntu:
  New

Bug description:
  Reports don't show charts after recent upgrades (maybe also since the ubuntu 
version upgrade)
  The IRC community suspects a similar issue to 
  
https://blogs.gnome.org/mcatanzaro/2018/11/06/mesa-update-breaks-webkitgtk-in-fedora-29/

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: gnucash 1:3.3-2
  ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
  Uname: Linux 4.18.0-10-generic x86_64
  NonfreeKernelModules: wl nvidia_modeset nvidia
  ApportVersion: 2.20.10-0ubuntu13
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Nov  7 22:38:23 2018
  InstallationDate: Installed on 2018-09-15 (53 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  SourcePackage: gnucash
  UpgradeStatus: Upgraded to cosmic on 2018-10-19 (19 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnucash/+bug/1802181/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1575078] Re: [XPS 15 9550, Realtek ALC3266] Headphone jack stops working after a while

2018-11-07 Thread David Rosenstrauch
FYI, upstream kernel bug is at:
https://bugzilla.kernel.org/show_bug.cgi?id=109841

** Bug watch added: Linux Kernel Bug Tracker #109841
   https://bugzilla.kernel.org/show_bug.cgi?id=109841

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1575078

Title:
  [XPS 15 9550, Realtek ALC3266] Headphone jack stops working after a
  while

Status in alsa-driver package in Ubuntu:
  Confirmed

Bug description:
  I'm experiencing a strange behavior with a headphone jack on my
  laptop.

  I have an external audio speaker connected to it. When I disconnect the 
speaker and reconnect it again it stops working.
  Even more, laptop audio stops working too. And after the reboot, I don't even 
see any of the audio devices.

  I've googled a lot and tried different fixes from forums with no luck.
  After a while, I've accidentally discovered that putting the laptop to
  the sleep mode and rebooting system after brings audio back to live.
  Even more, if speakers were attached during this sleep-reboot
  procedure, they are starting to work as well.

  However, after the next reboot speakers are not working again. And if
  I will plug them out and in - problem with completely missing audio
  returns.

  P.S. I'm using laptop-mode-tools package on my laptop. Recovery after
  hibernation made me believe that it's somehow related. But after
  uninstalling this package nothing really changed.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/pcmC0D0p:   kop3224 F...m pulseaudio
   /dev/snd/controlC0:  kop3224 F pulseaudio
  CurrentDesktop: Unity
  Date: Tue Apr 26 12:17:03 2016
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-04-22 (3 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_Card: Встроенное аудио - HDA Intel PCH
  Symptom_Jack: Black Headphone Out, Left
  Symptom_Type: Sound works for a while, then breaks
  Title: [XPS 15 9550, Realtek ALC3266, Black Headphone Out, Left] fails after 
a while
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/07/2016
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 01.02.00
  dmi.board.name: 0N7TVV
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr01.02.00:bd04/07/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: XPS 15 9550
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1575078/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1119781] Re: Test suite should be enabled during build

2018-11-07 Thread Bug Watch Updater
** Changed in: grilo
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to grilo in Ubuntu.
https://bugs.launchpad.net/bugs/1119781

Title:
  Test suite should be enabled during build

Status in Grilo:
  Expired
Status in grilo package in Ubuntu:
  Confirmed

Bug description:
  The test suite in grilo is currently not run.

  There are several reasons:
   * The check in configure.ac for "enable_tests" is broken and never runs the 
tests, even when --enable-tests is passed.
   * The test source files themselves are out of date and need some fixing to 
run with latest grilo.
   * Some tests, like the registry one, seems to require that the package be 
installed first (which isn't a deal breaker, we can run as a dep8)

To manage notifications about this bug go to:
https://bugs.launchpad.net/grilo/+bug/1119781/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 592434] Re: ssh -X user@machine hangs when using exit to terminate

2018-11-07 Thread Bug Watch Updater
** Changed in: dbus
   Status: Confirmed => Unknown

** Changed in: dbus
   Importance: Medium => Wishlist

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dbus in Ubuntu.
https://bugs.launchpad.net/bugs/592434

Title:
  ssh -X user@machine hangs when using exit to terminate

Status in D-Bus:
  Unknown
Status in dbus package in Ubuntu:
  Fix Released
Status in dbus package in Debian:
  New

Bug description:
  ssh -X user@server hangs when using exit to terminate

  Steps to reproduce:
  user@client:~$ ssh -X user@server
  user@server:~$ gedit

  At this point gedit from server will run locally. Closing the program
  and returning to the terminal you run:

  user@server:~$ exit
  logout

  At this point the terminal hangs on the echo logout, but does not return to 
the client prompt. The action has been consistent when connecting to a server 
running opensolaris or ubuntu 8.04.
  The client is using Ubuntu 10.04 and the server is using 8.04, and using 
default password authentication. As you will see in the video attached I can 
confirm the issue when using a clean Ubuntu 10.04 as a client and Ubuntu 8.04 
as the server, using default password authentication.

  Workaround
  --
  -When logging out with "exit" and it hangs, press Ctrl-C
  -If you would like to simply use gedit on another computer use the following 
command:
    $ dbus-launch gedit

  Date: Thu Jun 10 17:34:26 2010

To manage notifications about this bug go to:
https://bugs.launchpad.net/dbus/+bug/592434/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1663528] Re: pulseaudio assert failure: pulseaudio: mixer.c:929: snd_mixer_elem_get_callback_private: Assertion `mixer' failed.

2018-11-07 Thread Bug Watch Updater
Launchpad has imported 4 comments from the remote bug at
https://bugs.freedesktop.org/show_bug.cgi?id=104385.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2017-12-26T09:37:23+00:00 Paulepanter wrote:

Created attachment 136388
(gdb) t a a bt; t a a bt f; info registers

Looking through the core dump files of one system with Debian 9
(Stretch), I noticed some of PulseAudio 10.0, where it terminates with
SIGABRT.

```
Thread 3 (Thread 0x7f60175f1700 (LWP 9319)):
#0  0x7f6028922771 in __GI_ppoll (fds=0x56233965ece0, nfds=4, 
timeout=, sigmask=sigmask@entry=0x0) at 
../sysdeps/unix/sysv/linux/ppoll.c:39
#1  0x7f602a098df8 in ppoll (__ss=0x0, __timeout=, 
__nfds=, __fds=) at 
/usr/include/x86_64-linux-gnu/bits/poll2.h:77
#2  pa_rtpoll_run (p=0x56233978bbe0) at pulsecore/rtpoll.c:314
#3  0x7f6022189a73 in thread_func (userdata=0x56233978b9c0) at 
modules/alsa/alsa-source.c:1516
#4  0x7f6029e302c8 in internal_thread_func (userdata=0x56233964bf50) at 
pulsecore/thread-posix.c:81
#5  0x7f6029302494 in start_thread (arg=0x7f60175f1700) at 
pthread_create.c:333
#6  0x7f602892baff in clone () at 
../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 2 (Thread 0x7f6017df2700 (LWP 9318)):
#0  0x7f6028922771 in __GI_ppoll (fds=0x5623396d0b80, nfds=5, 
timeout=, sigmask=sigmask@entry=0x0) at 
../sysdeps/unix/sysv/linux/ppoll.c:39
#1  0x7f602a098df8 in ppoll (__ss=0x0, __timeout=, 
__nfds=, __fds=) at 
/usr/include/x86_64-linux-gnu/bits/poll2.h:77
#2  pa_rtpoll_run (p=0x562339750c60) at pulsecore/rtpoll.c:314
#3  0x7f6022183575 in thread_func (userdata=0x562339750a10) at 
modules/alsa/alsa-sink.c:1799
#4  0x7f6029e302c8 in internal_thread_func (userdata=0x562339668390) at 
pulsecore/thread-posix.c:81
#5  0x7f6029302494 in start_thread (arg=0x7f6017df2700) at 
pthread_create.c:333
#6  0x7f602892baff in clone () at 
../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 1 (Thread 0x7f602a4684c0 (LWP 2624)):
#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#1  0x7f60288773fa in __GI_abort () at abort.c:89
#2  0x7f602886ee37 in __assert_fail_base (fmt=, 
assertion=assertion@entry=0x7f60224748e8 "mixer", 
file=file@entry=0x7f6022474b79 "mixer.c", line=line@entry=929, 
function=function@entry=0x7f6022474e00 <__PRETTY_FUNCTION__.9666> 
"snd_mixer_elem_get_callback_private") at assert.c:92
#3  0x7f602886eee2 in __GI___assert_fail 
(assertion=assertion@entry=0x7f60224748e8 "mixer", 
file=file@entry=0x7f6022474b79 "mixer.c", line=line@entry=929, 
function=function@entry=0x7f6022474e00 <__PRETTY_FUNCTION__.9666> 
"snd_mixer_elem_get_callback_private") at assert.c:101
#4  0x7f60223f503d in snd_mixer_elem_get_callback_private 
(mixer=mixer@entry=0x0) at mixer.c:929
#5  0x7f60226be60b in report_jack_state (melem=0x0, mask=mask@entry=0) at 
modules/alsa/module-alsa-card.c:362
#6  0x7f60226beb1b in card_suspend_changed (c=, 
card=, u=0x5623395de220) at modules/alsa/module-alsa-card.c:628
#7  0x7f602a08d60c in pa_hook_fire (hook=0x562339555948, 
data=data@entry=0x5623395d0a40) at pulsecore/hook-list.c:104
#8  0x7f602a089d8a in pa_card_suspend (c=c@entry=0x5623395d0a40, 
suspend=suspend@entry=false, cause=cause@entry=PA_SUSPEND_SESSION) at 
pulsecore/card.c:390
#9  0x7f60228c500c in verify_access (u=u@entry=0x5623395be700, 
d=0x5623395d30d0) at modules/module-udev-detect.c:362
#10 0x7f60228c63e5 in inotify_cb (a=0x5623395545e8, e=, 
fd=14, events=, userdata=0x5623395be700) at 
modules/module-udev-detect.c:624
#11 0x7f6029ba774c in dispatch_pollfds (m=0x562339554590) at 
pulse/mainloop.c:655
#12 pa_mainloop_dispatch (m=m@entry=0x562339554590) at pulse/mainloop.c:898
#13 0x7f6029ba7b4c in pa_mainloop_iterate (m=0x562339554590, 
block=, retval=0x7ffc8077f948) at pulse/mainloop.c:929
#14 0x7f6029ba7bf0 in pa_mainloop_run (m=0x562339554590, 
retval=0x7ffc8077f948) at pulse/mainloop.c:944
#15 0x56233875bd8c in main (argc=, argv=) at 
daemon/main.c:1140
```

Please find the full backtraces attached.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1663528/comments/15


On 2018-05-24T16:51:36+00:00 Tanu Kaskinen wrote:

Sorry, I didn't notice this bug report until now. I think I have a fix
for it, I'll submit it shortly.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1663528/comments/16


On 2018-05-24T17:42:00+00:00 Tanu Kaskinen wrote:

Here's the patch: https://patchwork.freedesktop.org/patch/225242/

If this is a reproducible problem and you're able to apply the patch,
testing would be 

[Touch-packages] [Bug 592434]

2018-11-07 Thread Gitlab-migration
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has
been closed from further activity.

You can subscribe and participate further through the new bug through
this link to our GitLab instance:
https://gitlab.freedesktop.org/dbus/dbus/issues/34.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dbus in Ubuntu.
https://bugs.launchpad.net/bugs/592434

Title:
  ssh -X user@machine hangs when using exit to terminate

Status in D-Bus:
  Unknown
Status in dbus package in Ubuntu:
  Fix Released
Status in dbus package in Debian:
  New

Bug description:
  ssh -X user@server hangs when using exit to terminate

  Steps to reproduce:
  user@client:~$ ssh -X user@server
  user@server:~$ gedit

  At this point gedit from server will run locally. Closing the program
  and returning to the terminal you run:

  user@server:~$ exit
  logout

  At this point the terminal hangs on the echo logout, but does not return to 
the client prompt. The action has been consistent when connecting to a server 
running opensolaris or ubuntu 8.04.
  The client is using Ubuntu 10.04 and the server is using 8.04, and using 
default password authentication. As you will see in the video attached I can 
confirm the issue when using a clean Ubuntu 10.04 as a client and Ubuntu 8.04 
as the server, using default password authentication.

  Workaround
  --
  -When logging out with "exit" and it hangs, press Ctrl-C
  -If you would like to simply use gedit on another computer use the following 
command:
    $ dbus-launch gedit

  Date: Thu Jun 10 17:34:26 2010

To manage notifications about this bug go to:
https://bugs.launchpad.net/dbus/+bug/592434/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 592434]

2018-11-07 Thread Gquigs+bugs
This is fixed Ubuntu 16.10, haven't investigated where the fix came
from.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dbus in Ubuntu.
https://bugs.launchpad.net/bugs/592434

Title:
  ssh -X user@machine hangs when using exit to terminate

Status in D-Bus:
  Unknown
Status in dbus package in Ubuntu:
  Fix Released
Status in dbus package in Debian:
  New

Bug description:
  ssh -X user@server hangs when using exit to terminate

  Steps to reproduce:
  user@client:~$ ssh -X user@server
  user@server:~$ gedit

  At this point gedit from server will run locally. Closing the program
  and returning to the terminal you run:

  user@server:~$ exit
  logout

  At this point the terminal hangs on the echo logout, but does not return to 
the client prompt. The action has been consistent when connecting to a server 
running opensolaris or ubuntu 8.04.
  The client is using Ubuntu 10.04 and the server is using 8.04, and using 
default password authentication. As you will see in the video attached I can 
confirm the issue when using a clean Ubuntu 10.04 as a client and Ubuntu 8.04 
as the server, using default password authentication.

  Workaround
  --
  -When logging out with "exit" and it hangs, press Ctrl-C
  -If you would like to simply use gedit on another computer use the following 
command:
    $ dbus-launch gedit

  Date: Thu Jun 10 17:34:26 2010

To manage notifications about this bug go to:
https://bugs.launchpad.net/dbus/+bug/592434/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1781746] Re: [SRU] Slow startup with zram-config installed (/dev/zram0) or encrypted swap

2018-11-07 Thread Bug Watch Updater
** Changed in: initramfs-tools (Debian)
   Status: Unknown => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1781746

Title:
  [SRU] Slow startup with zram-config installed (/dev/zram0) or
  encrypted swap

Status in Default settings and artwork for Baltix OS:
  New
Status in initramfs-tools package in Ubuntu:
  Confirmed
Status in zram-config package in Ubuntu:
  Confirmed
Status in initramfs-tools package in Debian:
  Fix Released

Bug description:
  [Impact]

  Ubuntu 18.04 startup slowdowns for 30-120 seconds when zram swap is enabled 
(for example zram-config installed) or swap is encrypted.
  Today lots of users have SSD instead of HDD disk drives and use zram swap 
instead of swap partition or swap file, but if initrd is generated when zram 
swap is enabled then system can become "unbootable" from the user's perspective 
(Users with SSD storage doesn't wait 2 or more minutes...)

  This bug is already fixed in Debian initramfs-tools ver 0.132, please accept 
this simple 3 lines patch from Debian into Ubuntu 18.04 LTS
  
https://salsa.debian.org/kernel-team/initramfs-tools/commit/312393b0cf1231125eeff3d1a2b6b778a935c21d

  [Test Case]
  Install zram-config package and regenerate and initrd, for example with 
  sudo update-initramfs -u

  When generating initrd I get this message in terminal:

  I: The initramfs will attempt to resume from /dev/zram0
  I: (UUID=e380356c-767e-4265-98da-8be62ad28569)
  I: Set the RESUME variable to override 
this.###.]

  So the local-premount script in initramfs was waiting for a swap
  device that was not available, until it timed out. The relevant
  message was gave up waiting for suspend/resume device.

  [Regression Potential]

  None, patch simply adds case for /dev/zram*:

  60case "$resume_auto" in
  61/dev/zram*)
  62ephemeral=true
  63;;
  64esac

  
  [Other Info]
  Manual method to disable this (as resuming from swap is not possible with an 
encrypted or zram swap): modify file /etc/initramfs-tools/conf.d/resume - add 
(or change) line
  RESUME=none
  (instead of the UUID that was here) will disable waiting for a resume device.
  and run sudo update-initramfs -u to apply the changes.

To manage notifications about this bug go to:
https://bugs.launchpad.net/baltix-default-settings/+bug/1781746/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1794033] Re: i965: Failed to submit batchbuffer: Bad address

2018-11-07 Thread Bug Watch Updater
Launchpad has imported 13 comments from the remote bug at
https://bugs.freedesktop.org/show_bug.cgi?id=104778.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2018-01-24T22:47:15+00:00 Mark-a-janes wrote:

Mesa CI reports a low error rate (2/700k), however the number of
intermittent failures is consistently nonzero.  This is worse than our
historical results.

The rarity of the failures makes it difficult to pinpoint the
regression, however there are several repeating errors:

i965: Failed to submit batchbuffer: Bad address
piglit.spec.!opengl 1_1.copypixels-draw-sync  ivb
piglit.spec.!opengl 1_3.gl-1_3-texture-env   snb


intel_batchbuffer.c:937: submit_batch: Assertion `entry->handle == 
batch->batch.bo->gem_handle' failed.
piglit.spec.!opengl 1_3.gl-1_3-texture-env.bdwm64
piglit.shaders.glsl-fs-raytrace-bug27060 skl

HSW tesselation failures

deqp-gles31': corrupted double-linked list: 0x561e9518be50 ***
dEQP-GLES31.functional.debug.error_filters.case_0.bdwm64

Reply at:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1794033/comments/0


On 2018-01-31T14:59:20+00:00 Kenxeth wrote:

Do we know what kernel version is running on the machines with failures?
We do slightly different things on v4.13 and later.  Wondering if it's
only happening on machines with older kernels, or newer ones, or both.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1794033/comments/1


On 2018-01-31T16:42:44+00:00 Mark-a-janes wrote:

Unfortunately I saw this recently on 4.14 and 4.11

http://otc-mesa-ci.jf.intel.com/job/Leeroy/1934476/ - ivbgt2-01 4.14
http://otc-mesa-ci.jf.intel.com/job/Leeroy/1934454/ - sklgt2-04 4.11

Reply at:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1794033/comments/2


On 2018-03-23T10:51:40+00:00 Lionel-g-landwerlin wrote:

Running piglit.shaders.glsl-fs-raytrace-bug27060, I found this valgrind
warning : https://patchwork.freedesktop.org/patch/212413/

Reply at:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1794033/comments/3


On 2018-03-23T13:42:29+00:00 Lionel-g-landwerlin wrote:

The Broadwell failure is interesting as it's clearly a memory corruption issue.
Running the dEQP-GLES31.functional.debug.* tests under valgrind, I can see a 
few errors from the CTS suite :

Test case 'dEQP-
GLES31.functional.debug.negative_coverage.callbacks.state.get_nuniformfv'..

==12081== Use of uninitialised value of size 8
==12081==at 0x59B505E: ??? (in 
/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.25)
==12081==by 0x59B55A8: std::ostreambuf_iterator > std::num_put > >::_M_insert_int(std::ostreambuf_iterator >, std::ios_base&, char, long) const (in 
/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.25)
==12081==by 0x59C1178: std::ostream& std::ostream::_M_insert(long) 
(in /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.25)
==12081==by 0x71CAF1: std::ostream& tcu::Format::operator<< (std::ostream&, tcu::Format::Array const&) (in 
/home/djdeath/src/mesa-src/VK-GL-CTS/build-es31/modules/gles31/deqp-gles31)
==12081==by 0xD9F922: std::ostream& tcu::Format::operator<< 
(std::ostream&, tcu::Format::ArrayPointer const&) (in 
/home/djdeath/src/mesa-src/VK-GL-CTS/build-es31/modules/gles31/deqp-gles31)
==12081==by 0xEE0160: tcu::MessageBuilder& tcu::MessageBuilder::operator<< 
 >(tcu::Format::ArrayPointer const&) (in 
/home/djdeath/src/mesa-src/VK-GL-CTS/build-es31/modules/gles31/deqp-gles31)
==12081==by 0xE9E45F: glu::CallLogWrapper::glGetIntegerv(unsigned int, 
int*) (in 
/home/djdeath/src/mesa-src/VK-GL-CTS/build-es31/modules/gles31/deqp-gles31)
==12081==by 0xA611D2: 
deqp::gles31::Functional::NegativeTestShared::get_nuniformfv(deqp::gles31::Functional::NegativeTestShared::NegativeTestContext&)
 (in /home/djdeath/src/mesa-src/VK-GL-CTS/build-es31/modules/gles31/deqp-gles31)
==12081==by 0x7230DF: deqp::gles31::Functional::(anonymous 
namespace)::TestFunctionWrapper::call(deqp::gles31::Functional::(anonymous 
namespace)::DebugMessageTestContext&) const (in 
/home/djdeath/src/mesa-src/VK-GL-CTS/build-es31/modules/gles31/deqp-gles31)
==12081==by 0x725DA1: deqp::gles31::Functional::(anonymous 
namespace)::CallbackErrorCase::iterate() (in 
/home/djdeath/src/mesa-src/VK-GL-CTS/build-es31/modules/gles31/deqp-gles31)
==12081==by 0x6DCAD3: 
deqp::gles31::TestCaseWrapper::iterate(tcu::TestCase*) (in 
/home/djdeath/src/mesa-src/VK-GL-CTS/build-es31/modules/gles31/deqp-gles31)
==12081==by 0xF9E157: 

[Touch-packages] [Bug 1768625] Re: Bluetooth headset HSP/HFP mode not working in Bionic

2018-11-07 Thread Gustavo Niemeyer
The issue is most probably that your headset implements the HFP profile,
but not the HSP profile, and pulseaudio does not yet support the HFP
profile despite what that line says (HSP/HFP). To confirm, run
bluetoothctl, and type something like:

> devices
(...)
> info 11:22:33:44:55:66

Where the address is the one for your headset. It will likely display
something like this:

UUID: Audio Sink(110b--1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (110c--1000-8000-00805f9b34fb)
UUID: A/V Remote Control(110e--1000-8000-00805f9b34fb)
UUID: Handsfree (111e--1000-8000-00805f9b34fb)

If so, the "Headset" (HSP) profile is missing.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1768625

Title:
  Bluetooth headset HSP/HFP mode not working in Bionic

Status in pulseaudio package in Ubuntu:
  Confirmed

Bug description:
  There is a previous bug with almost the same title, but for Xenial
  (https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1549163). I
  have had this issue in Artful, and when commented on the old bug, I
  was asked to raise a new one instead. I waited to see if Bionic fixed
  it for me, but it does not seem to work still. So!

  Steps to reproduce:
  1. enable bluetooth on computer and switch on the headset.
  2. pair and connect the headset
  3. go to settings to switch headset to HSP/HFP mode to enable mic
  4. save and close window.

  Expected behaviour:
  1. mic should be enabled and headset should be usable to attend calls on 
laptop.

  Behaviour in error:
  1. Headset profile switches back to A2DP and mic is not enabled.

  I am using a generic bluetooth headset on a fresh updated Kubuntu
  18.04 bionic with plasma DE.

  Software versions:
  Kernel: 4.15.0-20-generic
  Bluez version: 5.48-0ubuntu3
  pulseaudio: 1:11.1-1ubuntu7
  pulseaudio-module-bluetooth: 1:11.1-1ubuntu7

  
  Additional information:
  Running "pacmd list-cards" says that HSF/HFP is 'not available' on the 
headset:

  Output from Headset section:
  profiles:
  a2dp_sink: High Fidelity Playback (A2DP Sink) (priority 40, 
available: unknown)
  headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, 
available: no)
  off: Off (priority 0, available: yes)
  active profile: 

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1768625/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1790963] Re: Unable to connect with openssh 7.8 client and certificates

2018-11-07 Thread Bug Watch Updater
Launchpad has imported 8 comments from the remote bug at
https://bugzilla.redhat.com/show_bug.cgi?id=1623929.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2018-08-30T13:22:47+00:00 Jakub wrote:

Description of problem:
The OpenSSH server in RHEL7.6 does not send complete list of signature 
algorithms in SHA2 extension.

debug1: kex_input_ext_info: server-sig-algs=

This causes failures if the client is on OpenSSH 7.8p1+ (Fedora 28+) and
for some reason disabled the rsa-sha2-* public key algorithms with
PubkeyAcceptedKeyTypes configuration option.

The correct list should look like this:

debug1: kex_input_ext_info: server-sig-algs=

This does not affect any other key types at this moment.

Version-Release number of selected component (if applicable):
openssh-7.4p1-16

How reproducible:
specific configuration

Steps to Reproduce:
1. Install OpenSSH 7.8p1 (Fedora 28+)
2. Configure pubkey authentication using RSA key with remote server example.com
3. ssh -vvv -o PubkeyAcceptedKeyTypes=ssh-rsa example.com

Actual results:

debug1: Next authentication method: publickey
debug1: Offering public key: RSA 
SHA256:I1XXiJ/wkXC6Vn8ohZVHcJTCCKoPKm4mL8qtjtyNMhw /home/lslebodn/.ssh/id_rsa
debug1: send_pubkey_test: no mutual signature algorithm

Expected results:

The authentication should proceed using ssh-rsa algorithm.

Additional info:
This is a change in OpenSSH 7.8 that it is getting more strict about handling 
this extension. Unfortunately we carry broken version in RHEL7, which is not 
sending complete list of algorithms.

Workaround:
In client, list also the SHA2 extension algorithms:

PubkeyAcceptedKeyTypes rsa-sha2-256,rsa-sha2-512

If you need to adjust this list, rather use the + sign.


Thanks lslebodn for reporting this issue to me.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1790963/comments/0


On 2018-09-04T16:46:16+00:00 Christoph wrote:

Hi,

client fedora 28 with openssh-7.8p1-2.fc28.x86_64

using a ssh-rsa-cert-...@openssh.com client certificate

> debug1: Offering public key: RSA-CERT > SHA256:xxx 
> /home/c/.ssh/id_rsa-cert.pub
> debug1: send_pubkey_test: no mutual signature algorithm

The proposed workaround does not seem to work (Even if adding the cert
type)

> PubkeyAcceptedKeyTypes rsa-sha2-256,rsa-sha2-512,ssh-rsa,ssh-rsa-
cert-...@openssh.com

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1790963/comments/1


On 2018-09-04T17:33:06+00:00 Jakub wrote:

If you want to use certificates, you need to list also the SHA2 variants
of certificates:

rsa-sha2-256-cert-...@openssh.com,rsa-sha2-512-cert-...@openssh.com

Not sure if this is somewhere documented, but is should do the job.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1790963/comments/2


On 2018-09-05T11:07:44+00:00 Christoph wrote:

Hi,

i tried

PubkeyAcceptedKeyTypes rsa-sha2-256,rsa-sha2-512,rsa-
sha2-256-cert-...@openssh.com,rsa-sha2-512-cert-...@openssh.com,ssh-rsa-
cert-...@openssh.com

but still

debug1: send_pubkey_test: no mutual signature algorithm

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1790963/comments/3


On 2018-09-05T11:36:43+00:00 Jakub wrote:

Please, open a customer case if you have this issue with your RHEL
installation.

https://access.redhat.com/

This will really need a fix in RHEL7 since the new OpenSSH checks the
signature algorithms against the hardcoded list there, which is wrong.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1790963/comments/4


On 2018-09-06T17:21:31+00:00 Etienne wrote:

Hi all,

Even if the CA is an RSA key, you can sign ECDSA or ED25519 keys so you
get ECDSA/ED25519 certs which allow you to work around the issue without
changing anything server-side

Exemple cert:
$ ssh-keygen -Lf ~/.ssh/id_ed25519-cert.pub
~/.ssh/id_ed25519-cert.pub:
Type: ssh-ed25519-cert-...@openssh.com user certificate
Public key: ED25519-CERT SHA256:<...>
Signing CA: RSA SHA256:<...>
Key ID: "..."

Reply at:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1790963/comments/8


On 2018-10-31T12:17:01+00:00 Christoph wrote:

I think something happend within openssh 7.9 if my interpretation of
this is correct: https://www.spinics.net/lists/openssh-unix-
dev/msg05371.html

Reply at:

[Touch-packages] [Bug 516832] Re: [avidemux] Doesn't handle files with large gaps between audio/video streams properly

2018-11-07 Thread Bug Watch Updater
** Changed in: gstreamer
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-good0.10 in
Ubuntu.
https://bugs.launchpad.net/bugs/516832

Title:
  [avidemux] Doesn't handle files with large gaps between audio/video
  streams properly

Status in GStreamer:
  Expired
Status in gst-plugins-good0.10 package in Ubuntu:
  Triaged

Bug description:
  $ LANGUAGE=C GST_DEBUG_NO_COLOR=1 GST_DEBUG=*:2 totem 2> log
  0:00:00.091962270  4404  0x99e0080 WARNpyplugin 
gstpythonplugin.c:343:plugin_init: Couldn't g_module_open libpython. Reason: 
/usr/lib/libpython2.6.so: cannot open shared object file: No such file or 
directory
  0:00:00.092094409  4404  0x99e0080 WARN  GST_PLUGIN_LOADING 
gstplugin.c:422:gst_plugin_register_func: plugin 
"/usr/lib/gstreamer-0.10/libgstpython.so" failed to initialise
  0:00:00.093664162  4404  0x99e0080 WARN  GST_PLUGIN_LOADING 
gstplugin.c:422:gst_plugin_register_func: plugin 
"/usr/lib/gstreamer-0.10/libgstladspa.so" failed to initialise

  (totem:4403): GLib-GObject-WARNING **: value "10752000" of type `guint' is 
invalid or out of range for property `connection-speed' of type `guint'
  0:00:05.426087788  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426199813  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.426238924  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426270213  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.426303737  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426333629  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.426366874  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426396766  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.426429731  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426473591  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.426507115  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426537007  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.426570251  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426600702  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.426633667  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426663839  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.426697083  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.426726975  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected
  0:00:05.430748437  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4603:gst_pad_get_range: getrange failed unexpected
  0:00:05.430823028  4403  0x99e0080 WARN  GST_SCHEDULING 
gstpad.c:4715:gst_pad_pull_range: pullrange failed unexpected

  $ ls /usr/lib/libpython2.6.s*
  /usr/lib/libpython2.6.so.1  /usr/lib/libpython2.6.so.1.0

  $ totem film.avi

  (totem:4386): GLib-GObject-WARNING **: value "10752000" of type
  `guint' is invalid or out of range for property `connection-speed' of
  type `guint

  $ LANGUAGE=C gst-launch-0.10 playbin2 uri=film.avi

  (gst-launch-0.10:4230): GLib-WARNING **: g_set_prgname() called multiple times
  Setting pipeline to PAUSED ...
  ERROR: Pipeline doesn't want to pause.
  ERROR: from element /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0: 
Invalid URI "Avatar(2009)TS SHQ 720p-[Spanish+Sub)-[ESDGAS].avi".
  Additional debug info:
  gsturidecodebin.c(889): gen_source_element (): 
/GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0
  Setting pipeline to NULL ...
  Freeing pipeline ...

  ProblemType: Bug
  Architecture: i386
  Date: Wed Feb  3 20:47:46 2010
  DistroRelease: Ubuntu 9.10
  ExecutablePath: /usr/bin/totem
  NonfreeKernelModules: nvidia
  Package: libgstreamer0.10-0 0.10.25-2
  ProcEnviron:
   SHELL=/bin/bash
   LANG=es_CL.UTF-8
  ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
  SourcePackage: gstreamer0.10
  Uname: Linux 

[Touch-packages] [Bug 1633520] Re: Support dbus runtime relocation

2018-11-07 Thread Bug Watch Updater
Launchpad has imported 9 comments from the remote bug at
https://bugs.freedesktop.org/show_bug.cgi?id=98260.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2016-10-14T15:13:50+00:00 Michael Terry wrote:

Created attachment 127303
proposed patch

It would be nice if DBus added support for a runtime relocatable root in
Unix.  i.e. at runtime, be able to be run from /opt/dbus/ or some such,
without having that be a compile-time prefix.

I notice the Windows version has some basic support for this.  Detecting
its installation directory and treating paths as relative to that.

My specific use case is testing a snap [1] of a full desktop
environment.  This bundled in dbus and session services and all sorts of
things.  The session DBus was trying to activate services with their
compile-time hardcoded paths and not finding them.

And I bet similar use cases exist.

The plumbing already exists to fix those paths up, thanks to the Windows
support.

So I threw together a patch for the Unix side of things, to listen to
the new variable DBUS_ROOT.  If you prefer a different env name, let me
know.

[1] http://snapcraft.io/

Reply at:
https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/1633520/comments/0


On 2016-10-14T18:02:43+00:00 Simon McVittie wrote:

(In reply to Michael Terry from comment #0)
> So I threw together a patch for the Unix side of things, to listen to the
> new variable DBUS_ROOT.

libdbus and dbus-daemon are security-sensitive code, and in some
configurations the environment is attacker-controlled. Please don't rush
into this.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/1633520/comments/3


On 2016-10-14T18:10:50+00:00 Simon McVittie wrote:

Comment on attachment 127303
proposed patch

Review of attachment 127303:
-

For the session bus, it would seem reasonable to search XDG_DATA_DIRS
according to the basedir spec (). I'd rather do that than invent
a new environment variable.

I'm somewhat sceptical about the correctness of a Snap app-container
running its own dbus-daemon - a contained app doesn't sound a lot like a
login session to me (), and this is pretty much the
opposite of the direction that the "user-session" work has gone in
().

However, relocating a dbus-daemon with XDG_DATA_DIRS seems potentially
useful for regression testing or whatever (which is also the intended
purpose of most of the environment variables that Snap app-containers
(ab)use to pretend to be a namespace, AIUI).

---

What is your use case for relocating the system bus?

The system bus is a bus for the system. Running a separate system bus in
a container seems deeply inappropriate, unless the container is as close
to whole-system as things like lxc and Docker, in which case the chroot-
like environment will do the right thing anyway.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/1633520/comments/4


On 2016-10-14T18:16:53+00:00 Simon McVittie wrote:

(In reply to Simon McVittie from comment #2)
> For the session bus, it would seem reasonable to search XDG_DATA_DIRS
> according to the basedir spec
> ( html>). I'd rather do that than invent a new environment variable.

What I mean here is: take the logic we use for
, which I assume you're basically happy
with because you don't seem to have patched it, and apply it to finding
${datadir}/dbus-1/session.conf (taking the first one and ignoring any
that it "shadows" seems reasonable).

We implement  by behaving as though our
compile-time @DATADIR@ had been appended to XDG_DATA_DIRS; the same
would make sense for ${datadir}/dbus-1/session.conf.

Reply at:
https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/1633520/comments/5


On 2016-10-14T18:53:57+00:00 Michael Terry wrote:

Thank you for looking at this!

> Please don't rush into this.

Agreed.  I wanted to check with you folks before I actually did anything
on the Ubuntu side.

> What is your use case for relocating the system bus?

I don't have one.  I was just trying to be consistent with the other
changes.  I'm happy to drop those bits.

> I'm somewhat sceptical about the correctness of a 

[Touch-packages] [Bug 293832]

2018-11-07 Thread Orzel
Spam alert ...

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/293832

Title:
  printer prints page at wrong position, page cut

Status in Poppler:
  Unknown
Status in brother-cups-wrapper-extra package in Ubuntu:
  Invalid
Status in brother-lpr-drivers-extra package in Ubuntu:
  Invalid
Status in cups package in Ubuntu:
  Invalid
Status in poppler package in Ubuntu:
  Fix Released
Status in brother-cups-wrapper-extra source package in Karmic:
  Invalid
Status in brother-lpr-drivers-extra source package in Karmic:
  Invalid
Status in cups source package in Karmic:
  Invalid
Status in poppler source package in Karmic:
  Won't Fix

Bug description:
  After updating to intrepid, my Brother DCP-7025 printed every page
  about 2 cm above the usual position. This leads to pages cut as if
  printing with wrong paper configuration though A4 paper is set
  everywhere (Cups settings, program settings). For example when
  printing a test page with the printer configuration tool I cannot see
  the upper part of the Ubuntu logo.

  I have used both a hardy and an intrepid live cd to test and found out
  that the problem only occurs using intrepid, so I think it's a problem
  with the intrepid driver packages.

  However I found out, that in the printer configuration tool a wrong
  driver "DCP-7025 BR-Script" is loaded. The correct (and working!)
  driver is "DCP-7025 for CUPS". So to manually solve the problem simply
  choose the correct driver in the tool.

  I think that during the installation process of the package "brother-
  cups-wrapper-laser" the correct driver is not set to be used as
  default driver and the system continues to use the wrong driver
  instead.

To manage notifications about this bug go to:
https://bugs.launchpad.net/poppler/+bug/293832/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 293832]

2018-11-07 Thread elaniean
In many incidents, the printer configuration tool has a wrong driver
(like DCP-7025 BR-Script) is loaded. then you must have to identify
which driver tools are unnecessary. So to manually or ask to Brother
Printer Support for solving the problem simply choose the correct driver
in the tool. Know more by visiting the website
https://www.printererrorrepair.com/brother-printer-support-phone-number

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/293832

Title:
  printer prints page at wrong position, page cut

Status in Poppler:
  Unknown
Status in brother-cups-wrapper-extra package in Ubuntu:
  Invalid
Status in brother-lpr-drivers-extra package in Ubuntu:
  Invalid
Status in cups package in Ubuntu:
  Invalid
Status in poppler package in Ubuntu:
  Fix Released
Status in brother-cups-wrapper-extra source package in Karmic:
  Invalid
Status in brother-lpr-drivers-extra source package in Karmic:
  Invalid
Status in cups source package in Karmic:
  Invalid
Status in poppler source package in Karmic:
  Won't Fix

Bug description:
  After updating to intrepid, my Brother DCP-7025 printed every page
  about 2 cm above the usual position. This leads to pages cut as if
  printing with wrong paper configuration though A4 paper is set
  everywhere (Cups settings, program settings). For example when
  printing a test page with the printer configuration tool I cannot see
  the upper part of the Ubuntu logo.

  I have used both a hardy and an intrepid live cd to test and found out
  that the problem only occurs using intrepid, so I think it's a problem
  with the intrepid driver packages.

  However I found out, that in the printer configuration tool a wrong
  driver "DCP-7025 BR-Script" is loaded. The correct (and working!)
  driver is "DCP-7025 for CUPS". So to manually solve the problem simply
  choose the correct driver in the tool.

  I think that during the installation process of the package "brother-
  cups-wrapper-laser" the correct driver is not set to be used as
  default driver and the system continues to use the wrong driver
  instead.

To manage notifications about this bug go to:
https://bugs.launchpad.net/poppler/+bug/293832/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802149] [NEW] redir to an empty variable

2018-11-07 Thread Pavel Boldin
Public bug reported:

Redirection to an empty variable causes `dash` to exit abnormally via
SIGSEGV.


1) $ lsb_release -rd
Description:Ubuntu 16.04.5 LTS
Release:16.04
2) $ apt-cache policy dash
dash:
  Installed: 0.5.8-2.1ubuntu2
  Candidate: 0.5.8-2.1ubuntu2
  Version table:
 *** 0.5.8-2.1ubuntu2 500
500 http://ua.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
100 /var/lib/dpkg/status
3) Script to reproduce:
$ cat test.sh 

foobar() {
local a=$1
echo abc >&$a
}
foobar

4) Result:
$ dash ~/cloudlinux/kernelcare/test.sh 
Segmentation fault (core dumped)

** Affects: dash (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dash in Ubuntu.
https://bugs.launchpad.net/bugs/1802149

Title:
  redir to an empty variable

Status in dash package in Ubuntu:
  New

Bug description:
  Redirection to an empty variable causes `dash` to exit abnormally via
  SIGSEGV.

  
  1) $ lsb_release -rd
  Description:  Ubuntu 16.04.5 LTS
  Release:  16.04
  2) $ apt-cache policy dash
  dash:
Installed: 0.5.8-2.1ubuntu2
Candidate: 0.5.8-2.1ubuntu2
Version table:
   *** 0.5.8-2.1ubuntu2 500
  500 http://ua.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
  100 /var/lib/dpkg/status
  3) Script to reproduce:
  $ cat test.sh 

  foobar() {
local a=$1
echo abc >&$a
  }
  foobar

  4) Result:
  $ dash ~/cloudlinux/kernelcare/test.sh 
  Segmentation fault (core dumped)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dash/+bug/1802149/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 492363] Re: Nautilus often can't recognize mp3 without extension

2018-11-07 Thread Bug Watch Updater
** Changed in: shared-mime-info
   Status: Confirmed => Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/492363

Title:
  Nautilus often can't recognize mp3 without extension

Status in Nautilus:
  Won't Fix
Status in shared-mime-info:
  Unknown
Status in nautilus package in Ubuntu:
  Triaged
Status in shared-mime-info package in Ubuntu:
  New

Bug description:
  Binary package hint: nautilus

  MP3 files are often not recognized in Karmic. I took all mp3s from my music 
archive, removed extensions, and only a half of files were recognized. It was 
OK in Jaunty.
  You can get a sample file which is not recognized at 
http://launchpadlibrarian.net/36237701/Come.mp3
  It was erroneously reported as bug in File, see bug 490087.

To manage notifications about this bug go to:
https://bugs.launchpad.net/nautilus/+bug/492363/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1762152] Re: Network Manager is unable to connect to Wifi. Ask password and then loop forever

2018-11-07 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: network-manager (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1762152

Title:
  Network Manager is unable to connect to Wifi. Ask password and then
  loop forever

Status in network-manager package in Ubuntu:
  Confirmed

Bug description:
  On Live session or after installation, the wifi adapter is recognized,
  the password phrase is accepted but it never connect and loop forever.

  Thinkpad T430 with Intel Centrino 6205
  03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 
[Taylor Peak] (rev 34)

  It is not a Passphrase issue. Same PC with Debian 9 or 10 works very well.
  Really strange, considering Ubuntu 18.04 is based on Debian 10 !!!

  After comparing many files, it appears that the 2 last lines of
  /etc/NetworkManager/NetworkManager.conf have been added on Ubuntu !

  Debian 10:
  $ cat /NetworkManager/NetworkManager.conf
  [main]
  plugins=ifupdown,keyfile

  [ifupdown]
  managed=false

  Ubuntu 18.04:
  $ cat /etc/NetworkManager/NetworkManager.conf
  [main]
  plugins=ifupdown,keyfile

  [ifupdown]
  managed=false

  [device]
  wifi.scan-rand-mac-address=no

  I removed the last 2 files in Ubuntu 18.04, and now Wifi works
  perfectly. The wifi passphrase is accepted, and even going to sleep
  mode and back is fine.

  --
  I would strongly recommend to modify /etc/NetworkManager/NetworkManager.conf 
in package network-manager to remove the 2 last lines.
  In fact this file should not be modified by Ubuntu and kept as in Debian.
  Is it possible to do it in Ubuntu before 18.04 LTS to be launched ???
  --

  It seems this 2 lines have been added due to bug 1681513:
  https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1681513
  As reported here:
  https://askubuntu.com/questions/905283/wifi-issue-with-ubuntu-17-04

  By the way, file NetworkManager.conf is empty in Fedora...

  Cheers
  Fred

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1762152/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1754671] Re: Full-tunnel VPN DNS leakage regression

2018-11-07 Thread Olivier Tilloy
This is fixed in the 1.12 series of network-manager (1.12.0 release), so
cosmic and dingo are not affected.

** Changed in: network-manager (Ubuntu)
   Status: Confirmed => Fix Released

** Changed in: network-manager (Ubuntu)
 Assignee: Olivier Tilloy (osomon) => (unassigned)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1754671

Title:
  Full-tunnel VPN DNS leakage regression

Status in NetworkManager:
  Fix Released
Status in network-manager package in Ubuntu:
  Fix Released
Status in network-manager source package in Bionic:
  Confirmed

Bug description:
  In 16.04 the NetworkManager package used to carry this patch:
  
http://bazaar.launchpad.net/~network-manager/network-manager/ubuntu/view/head:/debian/patches/Filter-DNS-servers-to-add-to-dnsmasq-based-on-availa.patch

  It fixed the DNS setup so that when I'm on the VPN, I am not sending
  unencrypted DNS queries to the (potentially hostile) local
  nameservers.

  This patch disappeared in an update. I think it was present in
  1.2.2-0ubuntu0.16.04.4 but was dropped some time later.

  This security bug exists upstream too: 
https://bugzilla.gnome.org/show_bug.cgi?id=746422
  It's not a *regression* there though, as they didn't fix it yet 
(unfortunately!)

To manage notifications about this bug go to:
https://bugs.launchpad.net/network-manager/+bug/1754671/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1742997] Re: Newly installed applications are not showing in "Installed"

2018-11-07 Thread Ken VanDine
** Changed in: gnome-software (Ubuntu Bionic)
 Assignee: Olivier Tilloy (osomon) => Robert Ancell (robert-ancell)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to packagekit in Ubuntu.
https://bugs.launchpad.net/bugs/1742997

Title:
  Newly installed applications are not showing in "Installed"

Status in GNOME Software:
  Expired
Status in gnome-software package in Ubuntu:
  Fix Released
Status in packagekit package in Ubuntu:
  Invalid
Status in gnome-software source package in Bionic:
  Confirmed
Status in packagekit source package in Bionic:
  Invalid

Bug description:
  If you install any application using GNOME Software (Ubuntu Software),
  the newly installed application is not displayed on the "Installed"
  tab. It starts showing after the next system reboot.

  Steps to Reproduce:
  1. Find any application that is not installed and install it.
  2. Switch to the "Installed" tab and try to find the newly installed 
application.

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnome-software/+bug/1742997/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 492363]

2018-11-07 Thread Gitlab-migration
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has
been closed from further activity.

You can subscribe and participate further through the new bug through
this link to our GitLab instance: https://gitlab.freedesktop.org/xdg
/shared-mime-info/issues/46.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to shared-mime-info in
Ubuntu.
https://bugs.launchpad.net/bugs/492363

Title:
  Nautilus often can't recognize mp3 without extension

Status in Nautilus:
  Won't Fix
Status in shared-mime-info:
  Unknown
Status in nautilus package in Ubuntu:
  Triaged
Status in shared-mime-info package in Ubuntu:
  New

Bug description:
  Binary package hint: nautilus

  MP3 files are often not recognized in Karmic. I took all mp3s from my music 
archive, removed extensions, and only a half of files were recognized. It was 
OK in Jaunty.
  You can get a sample file which is not recognized at 
http://launchpadlibrarian.net/36237701/Come.mp3
  It was erroneously reported as bug in File, see bug 490087.

To manage notifications about this bug go to:
https://bugs.launchpad.net/nautilus/+bug/492363/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1368411] Re: Cannot insert IPV6 rule before IPV4 rules

2018-11-07 Thread Bug Watch Updater
** Changed in: ufw (Debian)
   Status: Unknown => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ufw in Ubuntu.
https://bugs.launchpad.net/bugs/1368411

Title:
  Cannot insert IPV6 rule before IPV4 rules

Status in ufw:
  New
Status in ufw package in Ubuntu:
  Confirmed
Status in ufw package in Debian:
  New

Bug description:
  I am unable to insert any rules concerning IPV6 before IPV4 rules. Thus, when 
IPV4 rules are numbered 1 to 5 and IPV6 rules are numbered  6 to 10,  the 
following command:
  [code]
  ufw insert 1 deny from 2a02:2210:12:a:b820:fff:fea2:25d1
  [/code]
  errors with "ERROR: Invalid position '1'".

  However, the command
  [code]
  ufw insert 6 deny from 2a02:2210:12:a:b820:fff:fea2:25d1
  [/code]
  succeeds.

  In my case, this poses a problem, since I am trying to insert rules
  from a script against brute force attacks. The script needs to insert
  blocking rules before a number of other rules that open up some ports
  (since the order of rules is important in ufw). However since the
  number of IPV4 rules will be changing all the time, the position of
  the first available number for an IPV6 address is hard to determine.

  Proposed solution: either allow IPV6 rules to precede IPV4 rules, or
  implement a keyword defining the first available position; e.g. "ufw
  insert first deny from 2a02:2210:12:a:b820:fff:fea2:25d1".

  BTW: this was all figured out with ufw version 0.31.1-1, Ubuntu
  12.04.5 LTS,

To manage notifications about this bug go to:
https://bugs.launchpad.net/ufw/+bug/1368411/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1781699] Re: DHCPv6 server crashes regularly (bionic)

2018-11-07 Thread Bug Watch Updater
** Changed in: isc-dhcp (Debian)
   Status: Unknown => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to isc-dhcp in Ubuntu.
https://bugs.launchpad.net/bugs/1781699

Title:
  DHCPv6 server crashes regularly (bionic)

Status in isc-dhcp package in Ubuntu:
  Confirmed
Status in isc-dhcp package in Debian:
  New
Status in isc-dhcp package in Fedora:
  Unknown

Bug description:
  The isc-dhcp-server crashes regularly on bionic, sometimes directly after 
boot, sometimes later.
  The version installed is 4.3.5-3ubuntu7.

  journalctl shows:
  Jul 14 09:35:11  dhcpd[1543]: Solicit message from 
fe80::18eb:dfc7:17e5:c8d7 port 546, transaction ID 0x7E8EC00
  Jul 14 09:35:11  dhcpd[1543]: Advertise NA: address ::1998 
to client with duid 00:01:00:01:21:9f:3a:02:d4:a3:3d:bf:17:e9 iaid = 0 valid 
for 8
  Jul 14 09:35:11  dhcpd[1543]: Sending Advertise to 
fe80::18eb:dfc7:17e5:c8d7 port 546
  Jul 14 09:35:12  dhcpd[1543]: Request message from 
fe80::18eb:dfc7:17e5:c8d7 port 546, transaction ID 0x65FADB00
  Jul 14 09:35:12  dhcpd[1543]: Reply NA: address ::1998 to 
client with duid 00:01:00:01:21:9f:3a:02:d4:a3:3d:bf:17:e9 iaid = 0 valid for 
86400
  Jul 14 09:35:12  dhcpd[1543]: Sending Reply to 
fe80::18eb:dfc7:17e5:c8d7 port 546
  Jul 14 09:35:53  dhcpd[1543]: Confirm message from 
fe80::725a:b6ff:fea2:6120 port 546, transaction ID 0x5105F400
  Jul 14 09:35:53  dhcpd[1543]: Sending Reply to 
fe80::725a:b6ff:fea2:6120 port 546
  Jul 14 09:35:53  dhcpd[1543]: Rebind message from 
fe80::725a:b6ff:fea2:6120 port 546, transaction ID 0x1FEA7E00
  Jul 14 09:35:53  dhcpd[1543]: Reply NA: address ::1992 to 
client with duid 00:04:c2:47:10:e8:8b:dc:d4:a1:0a:1d:21:f2:be:20:e8:a0 iaid = 
-1230
  Jul 14 09:35:53  sh[1543]: ../../../lib/isc/heap.c:251: REQUIRE(idx 
>= 1 && idx <= heap->last) failed, back trace
  Jul 14 09:35:53  sh[1543]: #0 0x7efc458a6417 in ??
  Jul 14 09:35:53  sh[1543]: #1 0x7efc458a636a in ??
  Jul 14 09:35:53  sh[1543]: #2 0x7efc458ad4ea in ??
  Jul 14 09:35:53  sh[1543]: #3 0x55d9ee65d571 in ??
  Jul 14 09:35:53  sh[1543]: #4 0x55d9ee658701 in ??
  Jul 14 09:35:53  sh[1543]: #5 0x55d9ee65ab05 in ??
  Jul 14 09:35:53  sh[1543]: #6 0x55d9ee65bff3 in ??
  Jul 14 09:35:53  sh[1543]: #7 0x55d9ee65cafc in ??
  Jul 14 09:35:53  sh[1543]: #8 0x55d9ee678402 in ??
  Jul 14 09:35:53  sh[1543]: #9 0x55d9ee667463 in ??
  Jul 14 09:35:53  sh[1543]: #10 0x55d9ee696476 in ??
  Jul 14 09:35:53  sh[1543]: #11 0x7efc458dd73b in ??
  Jul 14 09:35:53  sh[1543]: #12 0x7efc458ccf9e in ??
  Jul 14 09:35:53  sh[1543]: #13 0x7efc458d1e60 in ??
  Jul 14 09:35:53  sh[1543]: #14 0x7efc458d2325 in ??
  Jul 14 09:35:53  sh[1543]: #15 0x55d9ee6696b0 in ??
  Jul 14 09:35:53  sh[1543]: #16 0x55d9ee61d519 in ??
  Jul 14 09:35:53  sh[1543]: #17 0x7efc454c6b97 in ??
  Jul 14 09:35:53  sh[1543]: #18 0x55d9ee61de0a in ??
  Jul 14 09:35:54  systemd[1]: isc-dhcp-server6.service: Main process 
exited, code=dumped, status=6/ABRT
  Jul 14 09:35:54  systemd[1]: isc-dhcp-server6.service: Failed with 
result 'core-dump'.

  The bug was reported to Debian independently, https://bugs.debian.org
  /cgi-bin/bugreport.cgi?bug=896122.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1781699/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1799625] Re: Enable journald support

2018-11-07 Thread Bug Watch Updater
** Changed in: qtbase-opensource-src (Debian)
   Status: Unknown => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1799625

Title:
  Enable journald support

Status in qtbase-opensource-src package in Ubuntu:
  New
Status in qtbase-opensource-src package in Debian:
  New
Status in Fedora:
  Unknown

Bug description:
  ...

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1799625/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1787729] Re: [FAILED] Failed to start Process error reports when automatic reporting is enabled.

2018-11-07 Thread Keith Myers
No, I have never changed problem reporting from the default Automatic in
the initial installation.

If I remember correctly, this all started when for some reason when I
had a failed problem report upload notification on the screen and I
acknowledged it.

The very next reboot showed me the Failed to start Process Error
reporting message in the boot screen and in the log.  I don't use 'no
splash' so I watch for errors and notice them at every boot.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1787729

Title:
  [FAILED] Failed to start Process error reports when automatic
  reporting is enabled.

Status in apport package in Ubuntu:
  Incomplete

Bug description:
  Hello,

  Attached image.

  Regards,
  --
  Cristian Aravena Romero (caravena)

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: apport 2.20.10-0ubuntu7
  Uname: Linux 4.18.3-041803-generic x86_64
  ApportLog:
   
  ApportVersion: 2.20.10-0ubuntu7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Aug 18 11:48:00 2018
  InstallationDate: Installed on 2017-10-13 (308 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
  PackageArchitecture: all
  SourcePackage: apport
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1787729/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802135] [NEW] broken touchpad after i2c-i801 blacklist change

2018-11-07 Thread chad billman
Public bug reported:

After upgrading to kmod (24-1ubuntu3.1) the trackpads stop working on
Lenovo 11e 2nd gen machines.

We have a fleet of approximetly 1000 of them in production running
ubuntu 18.04. Prior to this update the trackpads worked out of box in
18.04.

We are currently working around the issue by deploying our own blacklist
files.

Here is a link to the SRU justification: https://bugs.launchpad.net/hwe-
next/+bug/1786574

** Affects: kmod (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: regression-update

** Description changed:

  After upgrading to kmod (24-1ubuntu3.1) the trackpads stop working on
  Lenovo 11e 2nd gen machines.
  
  We have a fleet of approximetly 1000 of them in production running
  ubuntu 18.04. Prior to this update the trackpads worked out of box in
  18.04.
  
  We are currently working around the issue by deploying our own blacklist
  files.
+ 
+ Here is a link to the SRU justification: https://bugs.launchpad.net/hwe-
+ next/+bug/1786574

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to kmod in Ubuntu.
https://bugs.launchpad.net/bugs/1802135

Title:
  broken touchpad after i2c-i801 blacklist change

Status in kmod package in Ubuntu:
  New

Bug description:
  After upgrading to kmod (24-1ubuntu3.1) the trackpads stop working on
  Lenovo 11e 2nd gen machines.

  We have a fleet of approximetly 1000 of them in production running
  ubuntu 18.04. Prior to this update the trackpads worked out of box in
  18.04.

  We are currently working around the issue by deploying our own
  blacklist files.

  Here is a link to the SRU justification: https://bugs.launchpad.net
  /hwe-next/+bug/1786574

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kmod/+bug/1802135/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1458322] Re: NetworkManager doesn't hide virtual interfaces (e.g. Docker, VMWare)

2018-11-07 Thread Steven Maddox
I'd much rather have something similar to that cinnamon fix as it
actually seems to check if the device is listed as unmanaged.  The patch
I've supplied above (based on the earlier patch by Campbell Vertesi)
doesn't seem to do that.  Doesn't matter if my vmnet8 (or similar
interface) is in the keyfile unmanaged-devices list or not.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1458322

Title:
  NetworkManager doesn't hide virtual interfaces (e.g. Docker, VMWare)

Status in One Hundred Papercuts:
  Confirmed
Status in network-manager package in Ubuntu:
  Confirmed

Bug description:
  Previously in Ubuntu 14.04 NetworkManager hid the veth interfaces that were 
created by Docker.
  Now since I've updated to 15.04 the veth interfaces are listed as Unmanaged 
under the gnome system tray icon which is kind of annoying.
  I'm using docker 1.6.2 and network-manager 0.9.10.0-4ubuntu15.1

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: network-manager 0.9.10.0-4ubuntu15.1
  ProcVersionSignature: Ubuntu 3.19.0-18.18-generic 3.19.6
  Uname: Linux 3.19.0-18-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1.1
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Sun May 24 14:22:44 2015
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2013-08-29 (632 days ago)
  InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 
(20130214)
  IpRoute:
   default via 192.168.178.1 dev wlan0  proto static  metric 1024 
   169.254.0.0/16 dev wlan0  scope link  metric 1000 
   172.17.0.0/16 dev docker0  proto kernel  scope link  src 172.17.42.1 
   192.168.178.0/24 dev wlan0  proto kernel  scope link  src 192.168.178.40
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
   WimaxEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: Upgraded to vivid on 2015-05-24 (0 days ago)
  mtime.conffile..etc.NetworkManager.NetworkManager.conf: 
2014-08-19T11:46:06.705439
  nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 
2: Error: Object 'nm' is unknown, try 'nmcli help'.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hundredpapercuts/+bug/1458322/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1754671] Re: Full-tunnel VPN DNS leakage regression

2018-11-07 Thread Olivier Tilloy
See the discussion in the upstream bug report. The fix is in the master
branch and needs to be backported to the 1.10 series so that we can pick
it up in bionic.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1754671

Title:
  Full-tunnel VPN DNS leakage regression

Status in NetworkManager:
  Fix Released
Status in network-manager package in Ubuntu:
  Fix Released
Status in network-manager source package in Bionic:
  Confirmed

Bug description:
  In 16.04 the NetworkManager package used to carry this patch:
  
http://bazaar.launchpad.net/~network-manager/network-manager/ubuntu/view/head:/debian/patches/Filter-DNS-servers-to-add-to-dnsmasq-based-on-availa.patch

  It fixed the DNS setup so that when I'm on the VPN, I am not sending
  unencrypted DNS queries to the (potentially hostile) local
  nameservers.

  This patch disappeared in an update. I think it was present in
  1.2.2-0ubuntu0.16.04.4 but was dropped some time later.

  This security bug exists upstream too: 
https://bugzilla.gnome.org/show_bug.cgi?id=746422
  It's not a *regression* there though, as they didn't fix it yet 
(unfortunately!)

To manage notifications about this bug go to:
https://bugs.launchpad.net/network-manager/+bug/1754671/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802125] Re: openssl 1.1.0 incorrectly verifies certificates with permitted name constraints

2018-11-07 Thread madbiologist
** Tags added: bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1802125

Title:
  openssl 1.1.0 incorrectly verifies certificates with permitted name
  constraints

Status in openssl package in Ubuntu:
  New

Bug description:
  Seen on 18.04.1 with openssl/libssl 1.1.0g-2ubuntu4.1

  As per the issue on the openssl github at
  https://github.com/openssl/openssl/issues/5521 - 1.1.0 is overzealous
  about parsing common names as hostnames and this can lead to
  incorrectly rejecting client certificates from CAs with DNS name
  constraints. This is reportedly fixed in 1.1.1.

  Specifically this is an issue in my case because I run an apache2
  server that verifies client certificates on https connections and have
  discovered that some certificates are being rejected because an
  intermediate CA has DNS name constraints which are being unexpectedly
  applied to the CN of client certificates.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1802125/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1742997] Re: Newly installed applications are not showing in "Installed"

2018-11-07 Thread Olivier Tilloy
Can still reproduce on bionic, not on cosmic. Killing gnome-software and
running it again is enough to "fix" the issue (because the list of
installed applications is being refreshed at startup).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to packagekit in Ubuntu.
https://bugs.launchpad.net/bugs/1742997

Title:
  Newly installed applications are not showing in "Installed"

Status in GNOME Software:
  Expired
Status in gnome-software package in Ubuntu:
  Fix Released
Status in packagekit package in Ubuntu:
  Invalid
Status in gnome-software source package in Bionic:
  Confirmed
Status in packagekit source package in Bionic:
  Invalid

Bug description:
  If you install any application using GNOME Software (Ubuntu Software),
  the newly installed application is not displayed on the "Installed"
  tab. It starts showing after the next system reboot.

  Steps to Reproduce:
  1. Find any application that is not installed and install it.
  2. Switch to the "Installed" tab and try to find the newly installed 
application.

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnome-software/+bug/1742997/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802125] [NEW] openssl 1.1.0 incorrectly verifies certificates with permitted name constraints

2018-11-07 Thread Richard Hesketh
Public bug reported:

Seen on 18.04.1 with openssl/libssl 1.1.0g-2ubuntu4.1

As per the issue on the openssl github at
https://github.com/openssl/openssl/issues/5521 - 1.1.0 is overzealous
about parsing common names as hostnames and this can lead to incorrectly
rejecting client certificates from CAs with DNS name constraints. This
is reportedly fixed in 1.1.1.

Specifically this is an issue in my case because I run an apache2 server
that verifies client certificates on https connections and have
discovered that some certificates are being rejected because an
intermediate CA has DNS name constraints which are being unexpectedly
applied to the CN of client certificates.

** Affects: openssl (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1802125

Title:
  openssl 1.1.0 incorrectly verifies certificates with permitted name
  constraints

Status in openssl package in Ubuntu:
  New

Bug description:
  Seen on 18.04.1 with openssl/libssl 1.1.0g-2ubuntu4.1

  As per the issue on the openssl github at
  https://github.com/openssl/openssl/issues/5521 - 1.1.0 is overzealous
  about parsing common names as hostnames and this can lead to
  incorrectly rejecting client certificates from CAs with DNS name
  constraints. This is reportedly fixed in 1.1.1.

  Specifically this is an issue in my case because I run an apache2
  server that verifies client certificates on https connections and have
  discovered that some certificates are being rejected because an
  intermediate CA has DNS name constraints which are being unexpectedly
  applied to the CN of client certificates.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1802125/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 192629] Re: "Cannot move file to trash, do you want to delete immediately?" on NTFS / VFAT partitions

2018-11-07 Thread Bug Watch Updater
** Changed in: glib
   Status: New => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to glib2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/192629

Title:
  "Cannot move file to trash, do you want to delete immediately?" on
  NTFS / VFAT partitions

Status in GLib:
  Expired
Status in glib2.0 package in Ubuntu:
  Triaged

Bug description:
  Trying to delete files with nautilus from a vfat partition "fails".
  Well, the file can be deleted OK, but it seems gvfs can't send the
  file to the trashcan, so only permanent delete is available.
  Furthermore, the name of the file appears in little boxes, similar to
  viewing a chinese site using Latin-1 encoding (will attach
  screenshot).

  Distro: Hardy up to date (17-february 2008)

  Steps to reproduce: Copy a file to an vfat partition. Select it and delete 
using nautilus. A message error will appear: 
"Can't move file to trashcan. Do you want to delete it inmediately?"
"File <>cannot be moved to trashcan"

  Versions:
  Nautilus 1:2.21.91-0ubuntu2
  gvfs 0.1.7-0ubuntu4

  /etc/fstab for the vfat partition:
  UUID=9445-A956  /fat32  vfatdefaults,utf8,umask=007,gid=46 0  
 1

To manage notifications about this bug go to:
https://bugs.launchpad.net/glib/+bug/192629/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1458322] Re: NetworkManager doesn't hide virtual interfaces (e.g. Docker, VMWare)

2018-11-07 Thread José Pedro Saraiva
Fix for cinnamon in case someone is interested:
https://github.com/linuxmint/Cinnamon/commit/3e366ce3f5cfe118ae1ab594bf2ce8c7872d8b4d

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1458322

Title:
  NetworkManager doesn't hide virtual interfaces (e.g. Docker, VMWare)

Status in One Hundred Papercuts:
  Confirmed
Status in network-manager package in Ubuntu:
  Confirmed

Bug description:
  Previously in Ubuntu 14.04 NetworkManager hid the veth interfaces that were 
created by Docker.
  Now since I've updated to 15.04 the veth interfaces are listed as Unmanaged 
under the gnome system tray icon which is kind of annoying.
  I'm using docker 1.6.2 and network-manager 0.9.10.0-4ubuntu15.1

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: network-manager 0.9.10.0-4ubuntu15.1
  ProcVersionSignature: Ubuntu 3.19.0-18.18-generic 3.19.6
  Uname: Linux 3.19.0-18-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1.1
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Sun May 24 14:22:44 2015
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2013-08-29 (632 days ago)
  InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 
(20130214)
  IpRoute:
   default via 192.168.178.1 dev wlan0  proto static  metric 1024 
   169.254.0.0/16 dev wlan0  scope link  metric 1000 
   172.17.0.0/16 dev docker0  proto kernel  scope link  src 172.17.42.1 
   192.168.178.0/24 dev wlan0  proto kernel  scope link  src 192.168.178.40
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
   WimaxEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: Upgraded to vivid on 2015-05-24 (0 days ago)
  mtime.conffile..etc.NetworkManager.NetworkManager.conf: 
2014-08-19T11:46:06.705439
  nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 
2: Error: Object 'nm' is unknown, try 'nmcli help'.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hundredpapercuts/+bug/1458322/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1793550] Re: tracker 2.1.4+ library needs ontology files from tracker binary package

2018-11-07 Thread Bug Watch Updater
** Changed in: tracker (Debian)
   Status: Unknown => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to tracker in Ubuntu.
https://bugs.launchpad.net/bugs/1793550

Title:
  tracker 2.1.4+ library needs ontology files from tracker binary
  package

Status in nautilus package in Ubuntu:
  Invalid
Status in tracker package in Ubuntu:
  Triaged
Status in tracker package in Debian:
  Fix Committed

Bug description:
  See the Debian bug for more details.

  The tracker 2.1.4 libraries will exit with an error, basically
  crashing the app if they can't find /usr/share/tracker/domain-
  ontologies/default.rule which is currently provided by the tracker
  binary package.

  The most obvious consequence is this means that nautilus won't run if
  tracker is not installed. But the tracker binary package isn't yet in
  main. The MIR is LP: #1770877

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1793550/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1767162] Re: Random stripes and dots

2018-11-07 Thread Sebastien Bacher
It's not specific to rhythmbox, reassigning to gtk but it might be freetype or 
something else in the stack. Could you add your journalctl log just after 
seeing the issue? 
What videocard/driver do you use? Do you get the problem at random time or 
maybe sometime after suspend/resume for example?

** Package changed: rhythmbox (Ubuntu) => gtk+3.0 (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+3.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1767162

Title:
  Random stripes and dots

Status in gtk+3.0 package in Ubuntu:
  New

Bug description:
  Ubuntu 18.04 LTS.

  Random stripes and dots appear on some texts. It happens on various
  applications. See the attached (an example of Rhythmbox).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1767162/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1801832] Re: Input method toggled when using the numeric pad

2018-11-07 Thread Sebastien Bacher
Thank you for your bug report. What key did you configure to switch
input method in the control-center region settings?

** Changed in: ibus (Ubuntu)
   Importance: Undecided => Low

** Changed in: ibus (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ibus in Ubuntu.
https://bugs.launchpad.net/bugs/1801832

Title:
  Input method toggled when using the numeric pad

Status in ibus package in Ubuntu:
  Incomplete

Bug description:
  Ubuntu 18.04 LTS

  During the Chinese character input mode, when I enter numbers using
  the numeric pad, the input method will be switched to English
  automatically, which is very annoying. Any suggestions?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1801832/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 420609] Re: wrong LC_TIME in Italian

2018-11-07 Thread Bug Watch Updater
** Changed in: glibc
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to eglibc in Ubuntu.
https://bugs.launchpad.net/bugs/420609

Title:
  wrong LC_TIME in Italian

Status in GLibC:
  Fix Released
Status in eglibc package in Ubuntu:
  Fix Released
Status in glibc package in Ubuntu:
  Invalid

Bug description:
  Accordingly to this file [1], this newspaper [2], and also because I'm 
Italian, there is an error in the way the date is displayed in linux.
  The correct format for Italian speakers is:
  day_name day_number month_name year, HH:MM:SS, time_zone

  in the LC_TIME date_fmt things are really mixed up and should be changed to:
  %a %e %b %Y, %H:%M:%S, %Z

  the file localedata/locales/it_IT needs to be changed, but I can't
  understand how, since there are only strange codes

  [1]: 
ftp://ftp.software.ibm.com/software/globalization/locales/Italy-Italian_Date.pdf
  [2]: http://www.corriere.it/

To manage notifications about this bug go to:
https://bugs.launchpad.net/glibc/+bug/420609/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1724919] Re: Bluetooth headphones only use A2DP when connected manually

2018-11-07 Thread paul hopgood
Bug still present in 18.10. 
To get A2DP audio working you have to manually disconnect and reconnect.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1724919

Title:
  Bluetooth headphones only use A2DP when connected manually

Status in alsa-driver package in Ubuntu:
  Won't Fix

Bug description:
  Issue with Sony MDR-1ABT Bluetooth headphones:
  Once paired, the headphones will be connected automatically whenever they are 
switched on. However when connected this way, only the HSP/HFP profile will 
work and trying to change to A2DP in sound settings does nothing.
  If the headphones are then manually disconnected and reconnected from 
Bluetooth settings, they will initially use HSP/HFP but then selecting A2DP in 
sound settings will successfully make them use A2DP.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
  Uname: Linux 4.13.0-16-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.7-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  neil   1443 F pulseaudio
   /dev/snd/pcmC0D0c:   neil   1443 F...m pulseaudio
   /dev/snd/controlC0:  neil   1443 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Oct 19 19:12:59 2017
  InstallationDate: Installed on 2017-10-19 (0 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
  PackageArchitecture: all
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_Card: MDR-1ABT
  Symptom_Type: None of the above
  Title: [MDR-1ABT, playback] Playback problem
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/06/2017
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F5
  dmi.board.asset.tag: Default string
  dmi.board.name: Z270N-WIFI-CF
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrF5:bd07/06/2017:svnGigabyteTechnologyCo.,Ltd.:pnZ270N-WIFI:pvrDefaultstring:rvnGigabyteTechnologyCo.,Ltd.:rnZ270N-WIFI-CF:rvrx.x:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: Default string
  dmi.product.name: Z270N-WIFI
  dmi.product.version: Default string
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1724919/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1787729] Re: [FAILED] Failed to start Process error reports when automatic reporting is enabled.

2018-11-07 Thread Brian Murray
My only thought is that problem reporting was disabled in gnome-control-
center and this disabled the whoopsie service and because whoopsie
wasn't running apport-autoreport would not work. Have you modified that
setting since you originally encountered the issue?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1787729

Title:
  [FAILED] Failed to start Process error reports when automatic
  reporting is enabled.

Status in apport package in Ubuntu:
  Incomplete

Bug description:
  Hello,

  Attached image.

  Regards,
  --
  Cristian Aravena Romero (caravena)

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: apport 2.20.10-0ubuntu7
  Uname: Linux 4.18.3-041803-generic x86_64
  ApportLog:
   
  ApportVersion: 2.20.10-0ubuntu7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Aug 18 11:48:00 2018
  InstallationDate: Installed on 2017-10-13 (308 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
  PackageArchitecture: all
  SourcePackage: apport
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1787729/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1767162] [NEW] Random stripes and dots

2018-11-07 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Ubuntu 18.04 LTS.

Random stripes and dots appear on some texts. It happens on various
applications. See the attached (an example of Rhythmbox).

** Affects: gtk+3.0 (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bionic bot-comment
-- 
Random stripes and dots
https://bugs.launchpad.net/bugs/1767162
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to gtk+3.0 in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802109] [NEW] cheese

2018-11-07 Thread sjaak peters
Public bug reported:

 do not work in ubuntu 18.04

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.15.0-39.42-generic 4.15.18
Uname: Linux 4.15.0-39-generic i686
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: i386
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Wed Nov  7 14:56:22 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics 
Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. [MSI] 2nd Generation Core 
Processor Family Integrated Graphics Controller [1462:1094]
 NVIDIA Corporation GF108M [GeForce GT 520M] [10de:0df7] (rev a1) (prog-if 00 
[VGA controller])
   Subsystem: Micro-Star International Co., Ltd. [MSI] GF108M [GeForce GT 520M] 
[1462:1094]
InstallationDate: Installed on 2016-02-08 (1002 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release i386 (20150422)
MachineType: wortmann MS-1754
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-39-generic 
root=UUID=e21ffc21-d27c-4706-83fa-f2637d3d05cb ro quiet splash vt.handoff=1
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/03/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E1754IMT.10D
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MS-1754
dmi.board.vendor: Wortmann AG
dmi.board.version: REV:1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: MS-1754
dmi.chassis.version: N/A
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrE1754IMT.10D:bd03/03/2011:svnwortmann:pnMS-1754:pvrREV1.0:rvnWortmannAG:rnMS-1754:rvrREV1.0:cvnMS-1754:ct10:cvrN/A:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: MS-1754
dmi.product.version: REV:1.0
dmi.sys.vendor: wortmann
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Wed Nov  7 09:28:02 2018
xserver.configfile: default
xserver.errors: NOUVEAU(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.6-1ubuntu4.2
xserver.video_driver: modeset

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-bug bionic i386 ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1802109

Title:
  cheese

Status in xorg package in Ubuntu:
  New

Bug description:
   do not work in ubuntu 18.04

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 4.15.0-39.42-generic 4.15.18
  Uname: Linux 4.15.0-39-generic i686
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: i386
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  Date: Wed Nov  7 14:56:22 2018
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  GraphicsCard:
   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics 
Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Micro-Star International Co., Ltd. [MSI] 2nd Generation Core 
Processor Family Integrated Graphics Controller [1462:1094]
   NVIDIA Corporation GF108M [GeForce GT 520M] [10de:0df7] (rev a1) (prog-if 00 
[VGA controller])
 Subsystem: Micro-Star International Co., Ltd. [MSI] GF108M [GeForce GT 
520M] [1462:1094]
  InstallationDate: Installed on 2016-02-08 (1002 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release i386 (20150422)
  MachineType: wortmann MS-1754
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-39-generic 
root=UUID=e21ffc21-d27c-4706-83fa-f2637d3d05cb ro quiet splash vt.handoff=1
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/03/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: E1754IMT.10D
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: MS-1754
  dmi.board.vendor: Wortmann AG
  dmi.board.version: REV:1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: MS-1754
  dmi.chassis.version: N/A
  dmi.modalias: 

[Touch-packages] [Bug 1458322] Re: NetworkManager doesn't hide virtual interfaces (e.g. Docker, VMWare)

2018-11-07 Thread José Pedro Saraiva
Unreal, 3 years later and this is still a thing.
It's not even an issue exclusive to ubuntu, it's present in most, if not all, 
linux distros and then we wonder why people have switched to OSX.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1458322

Title:
  NetworkManager doesn't hide virtual interfaces (e.g. Docker, VMWare)

Status in One Hundred Papercuts:
  Confirmed
Status in network-manager package in Ubuntu:
  Confirmed

Bug description:
  Previously in Ubuntu 14.04 NetworkManager hid the veth interfaces that were 
created by Docker.
  Now since I've updated to 15.04 the veth interfaces are listed as Unmanaged 
under the gnome system tray icon which is kind of annoying.
  I'm using docker 1.6.2 and network-manager 0.9.10.0-4ubuntu15.1

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: network-manager 0.9.10.0-4ubuntu15.1
  ProcVersionSignature: Ubuntu 3.19.0-18.18-generic 3.19.6
  Uname: Linux 3.19.0-18-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1.1
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Sun May 24 14:22:44 2015
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2013-08-29 (632 days ago)
  InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 
(20130214)
  IpRoute:
   default via 192.168.178.1 dev wlan0  proto static  metric 1024 
   169.254.0.0/16 dev wlan0  scope link  metric 1000 
   172.17.0.0/16 dev docker0  proto kernel  scope link  src 172.17.42.1 
   192.168.178.0/24 dev wlan0  proto kernel  scope link  src 192.168.178.40
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
   WimaxEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: Upgraded to vivid on 2015-05-24 (0 days ago)
  mtime.conffile..etc.NetworkManager.NetworkManager.conf: 
2014-08-19T11:46:06.705439
  nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 
2: Error: Object 'nm' is unknown, try 'nmcli help'.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hundredpapercuts/+bug/1458322/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802090] Re: update overwrites sshd_config

2018-11-07 Thread Marc Deslauriers
>From the new log:

Preparing to unpack .../openssh-sftp-server_1%3a7.6p1-4ubuntu0.1_amd64.deb ...
Unpacking openssh-sftp-server (1:7.6p1-4ubuntu0.1) over (1:7.6p1-4) ...
Preparing to unpack .../openssh-server_1%3a7.6p1-4ubuntu0.1_amd64.deb ...
Unpacking openssh-server (1:7.6p1-4ubuntu0.1) over (1:7.6p1-4) ...
Preparing to unpack .../openssh-client_1%3a7.6p1-4ubuntu0.1_amd64.deb ...
Unpacking openssh-client (1:7.6p1-4ubuntu0.1) over (1:7.6p1-4) ...
Setting up openssh-client (1:7.6p1-4ubuntu0.1) ...
Setting up openssh-sftp-server (1:7.6p1-4ubuntu0.1) ...
Setting up openssh-server (1:7.6p1-4ubuntu0.1) ...
Replacing config file /etc/ssh/sshd_config with new version
Log ended: 2018-11-07  06:53:53

That's quite odd, since it didn't prompt, that implies it was using an
unmodified /etc/ssh/sshd_config from the previous package...

Colin, any ideas?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1506544]

2018-11-07 Thread Tietze-heiko
Elementary is implemented but not used (if not used on the system). So
the question is whether or not we make it the default for Gnome
(proposal was done in patch 3/5 at
https://gerrit.libreoffice.org/#/c/51959/3)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1506544

Title:
  Change default Theme for LibreOffice to Breeze for Ubuntu 16.04

Status in LibreOffice:
  Fix Released
Status in libreoffice package in Ubuntu:
  Fix Released
Status in ubuntu-meta package in Ubuntu:
  Fix Released

Bug description:
  Breeze has a much more pleasing appearance and is better maintained
  than the human theme.

To manage notifications about this bug go to:
https://bugs.launchpad.net/df-libreoffice/+bug/1506544/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 420609]

2018-11-07 Thread Digitalfreak
Created attachment 11247
Proposed final solution

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to eglibc in Ubuntu.
https://bugs.launchpad.net/bugs/420609

Title:
  wrong LC_TIME in Italian

Status in GLibC:
  Fix Released
Status in eglibc package in Ubuntu:
  Fix Released
Status in glibc package in Ubuntu:
  Invalid

Bug description:
  Accordingly to this file [1], this newspaper [2], and also because I'm 
Italian, there is an error in the way the date is displayed in linux.
  The correct format for Italian speakers is:
  day_name day_number month_name year, HH:MM:SS, time_zone

  in the LC_TIME date_fmt things are really mixed up and should be changed to:
  %a %e %b %Y, %H:%M:%S, %Z

  the file localedata/locales/it_IT needs to be changed, but I can't
  understand how, since there are only strange codes

  [1]: 
ftp://ftp.software.ibm.com/software/globalization/locales/Italy-Italian_Date.pdf
  [2]: http://www.corriere.it/

To manage notifications about this bug go to:
https://bugs.launchpad.net/glibc/+bug/420609/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 420609]

2018-11-07 Thread Cvs-commit
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "GNU C Library master sources".

The branch, master has been updated
   via  434d45fd70ac1a137d01b715ea99c03ce3c21b14 (commit)
  from  7abf97bed9c24464a8a68fb9f9fe8d1e55c6b54c (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=434d45fd70ac1a137d01b715ea99c03ce3c21b14

commit 434d45fd70ac1a137d01b715ea99c03ce3c21b14
Author: Rafal Luzynski 
Date:   Fri Sep 14 22:43:02 2018 +0200

it_CH/it_IT locales: Correct some LC_TIME formats (bug 10425).

Synchronize some values with CLDR and apply some suggestions from Bugzilla.

[BZ #10425]
* localedata/locales/it_IT (d_t_fmt): Use "%a %-d %b %Y, %T".
(date_fmt): Use "%a %-d %b %Y, %T, %Z".
* localedata/locales/it_CH (d_t_fmt): Use "%a %-d %b %Y, %T"
which is the same as in it_IT.
(d_fmt): Use "%d.%m.%Y" which is the same as in de_CH.
(date_fmt): Use "%a %-d %b %Y, %T, %Z" which is the same as in it_IT.

---

Summary of changes:
 ChangeLog|   10 ++
 localedata/locales/it_CH |6 +++---
 localedata/locales/it_IT |4 ++--
 3 files changed, 15 insertions(+), 5 deletions(-)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to eglibc in Ubuntu.
https://bugs.launchpad.net/bugs/420609

Title:
  wrong LC_TIME in Italian

Status in GLibC:
  Fix Released
Status in eglibc package in Ubuntu:
  Fix Released
Status in glibc package in Ubuntu:
  Invalid

Bug description:
  Accordingly to this file [1], this newspaper [2], and also because I'm 
Italian, there is an error in the way the date is displayed in linux.
  The correct format for Italian speakers is:
  day_name day_number month_name year, HH:MM:SS, time_zone

  in the LC_TIME date_fmt things are really mixed up and should be changed to:
  %a %e %b %Y, %H:%M:%S, %Z

  the file localedata/locales/it_IT needs to be changed, but I can't
  understand how, since there are only strange codes

  [1]: 
ftp://ftp.software.ibm.com/software/globalization/locales/Italy-Italian_Date.pdf
  [2]: http://www.corriere.it/

To manage notifications about this bug go to:
https://bugs.launchpad.net/glibc/+bug/420609/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 420609]

2018-11-07 Thread Digitalfreak
Commit 434d45f fixes the issue.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to eglibc in Ubuntu.
https://bugs.launchpad.net/bugs/420609

Title:
  wrong LC_TIME in Italian

Status in GLibC:
  Fix Released
Status in eglibc package in Ubuntu:
  Fix Released
Status in glibc package in Ubuntu:
  Invalid

Bug description:
  Accordingly to this file [1], this newspaper [2], and also because I'm 
Italian, there is an error in the way the date is displayed in linux.
  The correct format for Italian speakers is:
  day_name day_number month_name year, HH:MM:SS, time_zone

  in the LC_TIME date_fmt things are really mixed up and should be changed to:
  %a %e %b %Y, %H:%M:%S, %Z

  the file localedata/locales/it_IT needs to be changed, but I can't
  understand how, since there are only strange codes

  [1]: 
ftp://ftp.software.ibm.com/software/globalization/locales/Italy-Italian_Date.pdf
  [2]: http://www.corriere.it/

To manage notifications about this bug go to:
https://bugs.launchpad.net/glibc/+bug/420609/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 420609]

2018-11-07 Thread Digitalfreak
Much has changed since the last patch has been attached therefore it
does not apply cleanly now.

For Italian [1] CLDR says that the correct medium date format is "d MMM
y" (5 set 1999), correct medium time format is "HH:mm:ss" (13:25:59),
correct medium date and time format is "d MMM y, HH:mm:ss" (5 set 1999,
13:25:59).

For Italian in Switzerland [2] it provides the same data although marks
them as "unconfirmed".

(In reply to Nicolo' Chieffo from comment #18)
> Ok, so I will change date_fmt to not contain abbreviations.

I've checked some locales and they all contain abbreviations in date_fmt
so I think it is perfectly OK to contain abbreviations.

> What about the timezone? Should it be present for both date_fmt and
d_fmt?

Most (but not all) of the locales contain the timezone in d_t_fmt but
the default C locale does not.  Therefore I think it is correct not to
include the timezone in d_t_fmt but include it in date_fmt.

Now about the patch:

> * d_t_fmt: "%a %e %b %Y, %T, %Z"
> - remove the leading zero in the day of month using '%e' instead of '%b'

Good idea but I think you'd rather use "%-d" which means "do not pad
with zero". "%e" means "pad with space", "%-e" means "do not pad with
space" and therefore has the same effect as "%-d".  Also, I think that
the timezone should be removed.

I will write a new patch and replace it with "%-d" and remove ", %Z".

> - add ',' to separate date, time and timezone

Good, CLDR says that date and time should be separated with a comma.

> * t_fmt: "%H.%M.%S"
> - express the time in the expanded way instead of using '%T', to be sure to
> use the correct values

CLDR says there should be colons rather than dots therefore I will
reject this change.  Also I will restore the format with colons in
date_fmt. "%T" means that "%H:%M:%S" is used literally therefore it is
correct.

> * date_fmt: "%c"
> - make date_fmt and d_t_fmt the same

As said above, date_fmt should contain the timezone while d_t_fmt (which
is used by "%c") should not.  Therefore I think that the correct
date_fmt should be "%a %-d %b %Y, %T, %Z" (ven 14 set 2018, 22:07:41,
CEST)

Also, I will change d_fmt in it_CH from "%d. %m. %y" (which looks bad)
to "%d.%m.%Y" (which is the same as de_CH and is almost the same as CLDR
suggests).  I will not change d_fmt in it_IT because it looks almost the
same as CLDR.  (In both cases CLDR suggests two-digit year while we have
four digits.)

[1] http://st.unicode.org/cldr-apps/v#/it/Gregorian/
[2] http://st.unicode.org/cldr-apps/v#/it_CH/Gregorian/

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to eglibc in Ubuntu.
https://bugs.launchpad.net/bugs/420609

Title:
  wrong LC_TIME in Italian

Status in GLibC:
  Fix Released
Status in eglibc package in Ubuntu:
  Fix Released
Status in glibc package in Ubuntu:
  Invalid

Bug description:
  Accordingly to this file [1], this newspaper [2], and also because I'm 
Italian, there is an error in the way the date is displayed in linux.
  The correct format for Italian speakers is:
  day_name day_number month_name year, HH:MM:SS, time_zone

  in the LC_TIME date_fmt things are really mixed up and should be changed to:
  %a %e %b %Y, %H:%M:%S, %Z

  the file localedata/locales/it_IT needs to be changed, but I can't
  understand how, since there are only strange codes

  [1]: 
ftp://ftp.software.ibm.com/software/globalization/locales/Italy-Italian_Date.pdf
  [2]: http://www.corriere.it/

To manage notifications about this bug go to:
https://bugs.launchpad.net/glibc/+bug/420609/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1759836]

2018-11-07 Thread brunofcosouza
(In reply to Y S Gupta from comment #8)


Same here. I used the commands from Szymon to find out what was going on and 
got the Synaptics Touchpad, too.

The workaround by Y S Gupta works like a charm. Put it in a startup
script and everything is ok. THANK YOU!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1759836

Title:
  systemd-udevd consumes 100% of CPU

Status in linux:
  Confirmed
Status in The Ubuntu Power Consumption Project:
  New
Status in bluez package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Incomplete
Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  The systemd-udevd proccess consumes 100% of a thread everytime, but
  i'm not noticing any difference in my computer.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: systemd 237-3ubuntu6
  ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
  Uname: Linux 4.15.0-13-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.9-0ubuntu2
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Mar 29 08:52:54 2018
  InstallationDate: Installed on 2018-03-05 (23 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180304)
  MachineType: Dell Inc. Inspiron N5010
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-13-generic 
root=UUID=3c29e292-f1ae-45e1-a0ed-a82524278ce1 ro quiet splash vt.handoff=1
  SourcePackage: systemd
  SystemdDelta:
   [EXTENDED]   /lib/systemd/system/rc-local.service → 
/lib/systemd/system/rc-local.service.d/debian.conf
   [EXTENDED]   /lib/systemd/system/user@.service → 
/lib/systemd/system/user@.service.d/timeout.conf

   2 overridden configuration files found.
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/25/2011
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A12
  dmi.board.name: 08R0GW
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A12
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: A12
  dmi.modalias: 
dmi:bvnDellInc.:bvrA12:bd01/25/2011:svnDellInc.:pnInspironN5010:pvrA12:rvnDellInc.:rn08R0GW:rvrA12:cvnDellInc.:ct8:cvrA12:
  dmi.product.name: Inspiron N5010
  dmi.product.version: A12
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/kernel/+bug/1759836/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802090] Re: update overwrites sshd_config

2018-11-07 Thread Marc Deslauriers
Oh, sorry about that, I didn't notice the date...and also requested the
wrong log file.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 342219] Re: subtitles disappear on seek

2018-11-07 Thread Bug Watch Updater
** Changed in: gst-plugins-base
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gst-plugins-base0.10 in
Ubuntu.
https://bugs.launchpad.net/bugs/342219

Title:
  subtitles disappear on seek

Status in gst-plugins-base:
  Expired
Status in Totem:
  Invalid
Status in gst-plugins-base0.10 package in Ubuntu:
  Triaged

Bug description:
  Binary package hint: totem

  Hi,

  i have some problem with subtitles in Totem.

  The problem is, that when i'm changing time using timeline, for some
  time subtitles dissapear, a start displaing in next 20 seconds.

  This not a problem with subtitles, because when i play movie without
  changing time, subtitles are display correctly.

  Maybe it's not critical bug, but it's very annoing.

To manage notifications about this bug go to:
https://bugs.launchpad.net/gst-plugins-base/+bug/342219/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 697756] Re: iPod and iPhone movies are played with incorrect orientation

2018-11-07 Thread Bug Watch Updater
** Changed in: gstreamer
   Status: Confirmed => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gstreamer0.10 in Ubuntu.
https://bugs.launchpad.net/bugs/697756

Title:
  iPod and iPhone movies are played with incorrect orientation

Status in GStreamer:
  Expired
Status in Totem:
  Invalid
Status in gstreamer0.10 package in Ubuntu:
  Confirmed

Bug description:
  Movies made with iPods and iPhones are encoded with orientation
  information, because users hold them in arbitrary positions when
  recording movies (they are meant to, there is no right way to hold an
  iDevice, apparently.  Unless you are making a call on an iPhone 4).
  At the moment I see upside-down and sideways movies sent from iPhones
  and iPods.

  If you hold the device on its side while recording a movie, playback
  should recognise this and have gravity in the recording represented in
  the most sensible representation on the display device (in most fixed
  monitors I guess this is positive on the Y axis, if (0,0) is on the
  top left).  I.e. match gravity in the recording to gravity on
  playback.

  ProblemType: Bug
  DistroRelease: Ubuntu 10.10
  Package: libgstreamer0.10-0 0.10.30-1build2
  Uname: Linux 2.6.37-rc8-linus x86_64
  Architecture: amd64
  Date: Wed Jan  5 17:08:02 2011
  ExecutablePath: /usr/bin/totem
  InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100412)
  ProcEnviron:
   LANG=en_GB.utf8
   SHELL=/bin/bash
  SourcePackage: gstreamer0.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/gstreamer/+bug/697756/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 984962] Re: Uses wrong pkg-config for dbus test when cross-building [SRU]

2018-11-07 Thread Bug Watch Updater
** Changed in: consolekit (Debian)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to consolekit in Ubuntu.
https://bugs.launchpad.net/bugs/984962

Title:
  Uses wrong pkg-config for dbus test when cross-building [SRU]

Status in consolekit package in Ubuntu:
  Incomplete
Status in consolekit source package in Precise:
  Incomplete
Status in consolekit source package in Quantal:
  Won't Fix
Status in consolekit package in Debian:
  Fix Released

Bug description:
  [Problem]
  consolekit fails to cross-build due to trying use wrong-arch 'pkg-config' 
during configure.

  [Impact]
  The impact is only on those cross-building, but one target for the precise 
release was to have as much of the base system cross-buildable as possible. 
consolekit is a base system package so it's important to be able to cross-build 
it.

  [Development Fix]
  Upstream git has fixed this problem by removing the check in question 
entirely. See 
http://cgit.freedesktop.org/ConsoleKit/commit/?id=f42cafcce978c402bdbc9c6e03a0c90bb0924b89

  But that version has not yet been released. I don't know if other
  changes are needed first before simply getting rid of it.

  [Stable Fix]
  The minimal fix is simply to use $PKG_CONFIG as set-up by autoconf instead of 
hard-coded 'pkg-config', then tha correct version is used for both native and 
cross builds. 

  [Test Case]
  1. apt-get source consolekit
  2. apt-get -a armel build-dep consolekit
  3. cd consolekit-0.4.5
  4. CONFIG_SITE=/etc/dpkg-cross/cross-config.armel DEB_BUILD_OPTIONS=nocheck 
dpkg-buildpackage -aarmel -uc -us

  Broken Behavior: build will stop after a while saying: 
Package dbus-1 was not found in the pkg-config search path.
  Perhaps you should add the directory containing `dbus-1.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'dbus-1' found
  Error: Couldn't determine the version of your DBUS package.
This is probably an error in this script, please report it
along with the following information:
Base DBUS version =''
DBUS_VERSION_MAJOR='0'
DBUS_VERSION_MINOR='0'
DBUS_VERSION_MICRO='0'
(and then print out the whole of config.log)

  Fixed Behavior: build will get past this point, saying:
   Your dbus version is 1,4,18.
  It will stop a bit further on with "/bin/bash: /usr/bin/dbus-binding-tool: No 
such file or directory", unless you have qemu installed, but that's a different 
bug in a different package.

  [Regression Potential]
  The only thing that could go wrong is breaking the native build. I've tested 
that this works fine. You can confirm it with
  1. apt-get build-dep consolekit
  2. cd consolekit-0.4.5
  3. dpkg-buildpackage -uc -us
  that build should complete as normal.

  [Original Report]

  consolekit can't find dbus-1 when cross-building:

  From the build log: 
http://people.linaro.org/~wookey/buildd/precise/sbuild-ma/consolekit_0.4.5-2-precise-ma-cross-armel-20120417-025041.38177.log
  Package dbus-1 was not found in the pkg-config search path.
  Perhaps you should add the directory containing `dbus-1.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'dbus-1' found
  Error: Couldn't determine the version of your DBUS package.

  This turns out to be because a local test in configure.ac used hard-
  coded 'pkg-config' instead of $PKG_CONFIG which autoconf has set to
  the correct path (/usr/bin/-pkg-config)

  (This patch is not sufficient to cross-build this package which has
  other issues).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/consolekit/+bug/984962/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1770082] Re: systemd-networkd not renaming devices on boot

2018-11-07 Thread Launchpad Bug Tracker
This bug was fixed in the package netplan.io - 0.40.2.1

---
netplan.io (0.40.2.1) cosmic; urgency=medium

  * Fix typo breaking rename on 'netplan apply'. (LP: #1770082)

 -- Mathieu Trudel-Lapierre   Mon, 22 Oct 2018
14:58:40 -0400

** Changed in: netplan.io (Ubuntu Cosmic)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1770082

Title:
  systemd-networkd not renaming devices on boot

Status in netplan:
  Fix Released
Status in cloud-init package in Ubuntu:
  Confirmed
Status in netplan.io package in Ubuntu:
  Fix Released
Status in nplan package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Confirmed
Status in nplan source package in Xenial:
  Fix Released
Status in netplan.io source package in Bionic:
  Fix Released
Status in netplan.io source package in Cosmic:
  Fix Released

Bug description:
  [Impact]
  Systems relying on renaming network interfaces at boot and when 'netplan 
apply' is run.

  [Test case]
  - Write a new netplan YAML (adjusting for current system as necessary):
  network:
  version: 2
  ethernets:
  ens3:
  dhcp4: true
  match:
  macaddress: 52:54:00:de:bd:f6
  set-name: myif0
  - Bring down interface : 'ip link set dev ens3 down'
  - Run 'netplan apply'
  - Verify that the device is correctly renamed to 'myif0'.
  - Reboot.
  - Make sure the device is correctly renamed to 'myif0'.

  [Regression potential]
  Changes in rename logic to add udev rules may otherwise impact applying 
different settings to the network interfaces. Changes in settings on network 
interfaces, missing parameters (especially on bonds, bridges) should be 
investigated as potential regressions. Other failures to apply network settings 
might also happen if there's a race between applying renames via the udev 
rules, and using the new names to apply configuration changes to the interfaces.

  === systemd issue ===

  Renaming devices doesn't seem to work.

  If I disable all other network configuration and create
  /etc/systemd/network/10-network.link with:

  [Match]
  MACAddress=52:54:00:c1:c9:bb

  [Link]
  Name=myiface3

  I expect this to cause the device with that MAC address to be renamed
  to  myiface3. However, when I reboot, I instead see:

  $ ip l
  1: lo:  mtu 65536 qdisc noqueue state UNKNOWN mode 
DEFAULT group default qlen 1000
  link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
  2: ens3:  mtu 1500 qdisc noop state DOWN mode DEFAULT 
group default qlen 1000
  link/ether 52:54:00:c1:c9:bb brd ff:ff:ff:ff:ff:ff

  The device is not renamed.

  This link file is pretty much identical to Example 2 in
  https://www.freedesktop.org/software/systemd/man/systemd.link.html.

  The renaming does work if I boot with net.ifnames=0, and oddly, it
  also works if I unbind the device and rebind it as netplan apply does.
  No setting of NamePolicy seems to help.

  === Original Bug ==

  'set-name:' doesn't change the name of a network interface on boot, it
  only works when you do netplan apply.

  Say I take this 50-cloud-init.yaml file:

  # This file is generated from information provided by
  # the datasource.  Changes to it will not persist across an instance.
  # To disable cloud-init's network configuration capabilities, write a file
  # /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
  # network: {config: disabled}
  network:
  version: 2
  ethernets:
  ens3:
  dhcp4: true
  match:
  macaddress: 52:54:00:de:bd:f6
  set-name: ens3

  Say I change set-name to 'myiface3' and reboot. I expect that the
  device will be called myiface3 and brought up fine with dhcp. However,
  instead I see:

  $ ip a
  1: lo:  mtu 65536 qdisc noqueue state UNKNOWN group 
default qlen 1000
  link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
  inet 127.0.0.1/8 scope host lo
     valid_lft forever preferred_lft forever
  inet6 ::1/128 scope host
     valid_lft forever preferred_lft forever
  2: ens3:  mtu 1500 qdisc noop state DOWN group default 
qlen 1000
  link/ether 52:54:00:de:bd:f6 brd ff:ff:ff:ff:ff:ff

  The name has not been changed, and the device has not been brought up.

  If I run netplan apply however, I see the following:

  1: lo:  mtu 65536 qdisc noqueue state UNKNOWN group 
default qlen 1000
  link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
  inet 127.0.0.1/8 scope host lo
     valid_lft forever preferred_lft forever
  inet6 ::1/128 scope host
     valid_lft forever preferred_lft forever
  3: myiface3:  mtu 1500 qdisc fq_codel state 
UP group default qlen 1000
  link/ether 52:54:00:de:bd:f6 brd ff:ff:ff:ff:ff:ff
  inet 192.168.122.151/24 brd 192.168.122.255 scope global dynamic 

[Touch-packages] [Bug 1796324] Re: symbol export missing: pa_encoding_from_string

2018-11-07 Thread Bug Watch Updater
** Changed in: pulseaudio (Debian)
   Status: Unknown => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1796324

Title:
  symbol export missing: pa_encoding_from_string

Status in PulseAudio:
  Unknown
Status in pulseaudio package in Ubuntu:
  Fix Released
Status in pulseaudio package in Debian:
  Confirmed

Bug description:
  This specific release of libpulsecommon-11.1 is missing the symbol
  `pa_encoding_from_string`.

  This was fixed upstream: https://bugs.freedesktop.org/show_bug.cgi?id=103806
  This has a Debian bug open, but I suspect it's been fixed by bumping major 
version: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=882029

  This results in unexpected:

   = note: /usr/bin/ld: 
/home/faux/code/rust-tone/target/debug/deps/liblibpulse_binding-f64ba2ce37bb3bc6.rlib(libpulse_binding-f64ba2ce37bb3bc6.libpulse_binding.3msoaviz-cgu.13.rcgu.o):
 undefined reference to symbol 'pa_encoding_from_string'
//usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-11.1.so: error 
adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: libpulse-dev 1:11.1-1ubuntu7.1
  ProcVersionSignature: Ubuntu 4.15.0-36.39-generic 4.15.18
  Uname: Linux 4.15.0-36-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.9-0ubuntu7.4
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  faux   2964 F pulseaudio
   /dev/snd/controlC2:  faux   2964 F pulseaudio
   /dev/snd/pcmC0D0p:   faux   2964 F...m pulseaudio
   /dev/snd/controlC0:  faux   2964 F pulseaudio
  Date: Fri Oct  5 15:37:38 2018
  InstallationDate: Installed on 2018-04-25 (162 days ago)
  InstallationMedia: Ubuntu-Server 18.04 LTS "Bionic Beaver" - Release amd64 
(20180425)
  SourcePackage: pulseaudio
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/22/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1402
  dmi.board.asset.tag: Default string
  dmi.board.name: TUF Z370-PRO GAMING
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr1402:bd05/22/2018:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnTUFZ370-PROGAMING:rvrRev1.xx:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to:
https://bugs.launchpad.net/pulseaudio/+bug/1796324/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802090] Re: update overwrites sshd_config

2018-11-07 Thread Dominic Raferd
attached: /var/log/apt/term.log

** Attachment added: "term.log.gz"
   
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+attachment/5210010/+files/term.log.gz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1802090] Re: update overwrites sshd_config

2018-11-07 Thread Dominic Raferd
The update to 18.04 was a long time ago, the problem occurred this
morning...

On Wed, 7 Nov 2018 at 13:01, Marc Deslauriers <
marc.deslauri...@canonical.com> wrote:

> It looks like you upgraded from Ubuntu 16.04 to Ubuntu 18.04.
> >From the log file:
>
> Unpacking openssh-server (1:7.6p1-4) over (1:7.2p2-4ubuntu2.4) ...
>
> Then the upgrade asked you what to do with the modified conffile, again,
> from the log:
>
> Configuring openssh-server
> sshd_config: A new version (/tmp/filerMG8sJ) of configuration file
> /etc/ssh/sshd_config is available, but the
> version installed currently has been locally modified.
> What do you want to do about modified configuration file sshd_config?
>  install the package maintainer's
> version
> keep the local version currently installed
> show the differences between the versions
> show a side-by-side difference between the versions
> start a new shell to examine the situation
> 
> # nano /tmp/filerMG8sJ
> 
> Replacing config file /etc/ssh/sshd_config with new version
>
> At which point you edited the file and instructed the upgrade process to
> use the new package version.
>
> I'm not quite sure what you expect this bug to resolve, the package
> seems to be acting as it should.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1802090
>
> Title:
>   update overwrites sshd_config
>
> Status in openssh package in Ubuntu:
>   Incomplete
>
> Bug description:
>   The latest update for Bionic (18.04.1) either overwrote or modified my
>   /etc/ssh/sshd_config with the result that I could no longer access my
>   machine using ssh.
>
>   A specific
>   Port [x]
>   line was removed and replaced by:
>   #Port 22
>
>   This was the only change. It happened as part of an automated process
>   this morning  - presumably a security update.
>
>   Was this behaviour intended?!
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions
>

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802090] Re: update overwrites sshd_config

2018-11-07 Thread Colin Watson
This log was from 2018-06-27, not from this morning.

I think we need to see /var/log/apt/term.log instead.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802090] Re: update overwrites sshd_config

2018-11-07 Thread Marc Deslauriers
It looks like you upgraded from Ubuntu 16.04 to Ubuntu 18.04.
>From the log file:

Unpacking openssh-server (1:7.6p1-4) over (1:7.2p2-4ubuntu2.4) ...

Then the upgrade asked you what to do with the modified conffile, again,
from the log:

Configuring openssh-server
sshd_config: A new version (/tmp/filerMG8sJ) of configuration file 
/etc/ssh/sshd_config is available, but the
version installed currently has been locally modified.
What do you want to do about modified configuration file sshd_config?   
install the package maintainer's version
keep the local version currently installed
show the differences between the versions
show a side-by-side difference between the versions
start a new shell to examine the situation

# nano /tmp/filerMG8sJ

Replacing config file /etc/ssh/sshd_config with new version

At which point you edited the file and instructed the upgrade process to
use the new package version.

I'm not quite sure what you expect this bug to resolve, the package
seems to be acting as it should.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802090] Re: update overwrites sshd_config

2018-11-07 Thread Dominic Raferd
It was an automatic update, file attached

** Attachment added: "apt-term.log"
   
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+attachment/5209992/+files/apt-term.log.gz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1800877] Re: iproute2/xenial: Add support for the VF Trust setting (fix IPv6 multicast under SR-IOV on Mellanox adapters)

2018-11-07 Thread Mauricio Faria de Oliveira
Verification successful on xenial-proposed. 
Updated verification tags.

Steps
=

Setup 1) Enable xenial-proposed and install the iproute2 package:
---

$ echo 'deb http://archive.ubuntu.com/ubuntu xenial-proposed main restricted' | 
sudo tee /etc/apt/sources.list.d/xenial-proposed.list
deb http://archive.ubuntu.com/ubuntu xenial-proposed main restricted

$ sudo apt-get update

$ apt-cache madison iproute2 | grep xenial-proposed
  iproute2 | 4.3.0-1ubuntu3.16.04.4 | http://archive.ubuntu.com/ubuntu 
xenial-proposed/main amd64 Packages

$ sudo apt-get install -y iproute2

$  dpkg -s iproute2 | grep Version
Version: 4.3.0-1ubuntu3.16.04.4


Setup 2) Configure 2 VFs in the ixgbe driver:
---

# lspci -s 08:00
08:00.0 Ethernet controller: Intel Corporation 82599 10 Gigabit TN Network 
Connection (rev 01)
08:00.1 Ethernet controller: Intel Corporation 82599 10 Gigabit TN Network 
Connection (rev 01)

# echo 2 > /sys/bus/pci/devices/\:08\:00.0/sriov_numvfs

# dmesg | grep Virtual
[  817.815245] ixgbevf: Intel(R) 10 Gigabit PCI Express Virtual Function 
Network Driver - version 2.12.1-k
[  818.825923] ixgbevf :08:10.0: Intel(R) 82599 Virtual Function
[  818.837931] ixgbevf :08:10.2: Intel(R) 82599 Virtual Function

# lspci -s 08:10
08:10.0 Ethernet controller: Intel Corporation 82599 Ethernet Controller 
Virtual Function (rev 01)
08:10.2 Ethernet controller: Intel Corporation 82599 Ethernet Controller 
Virtual Function (rev 01)


Verification 1) Check for 'trust' in 'ip link help':
---

# ip link help 2>&1 | grep trust
   [ trust { on | off} ] ]


Verification 2) Check for 'trust' in 'ip link show'
---

# ip link show dev eth0
6: eth0:  mtu 9000 qdisc mq state UP mode 
DEFAULT group default qlen 1000
link/ether 68:05:ca:28:ff:9a brd ff:ff:ff:ff:ff:ff
vf 0 MAC 00:00:00:00:00:00, spoof checking on, link-state auto, trust off
vf 1 MAC aa:fd:21:3f:93:1b, spoof checking on, link-state auto, trust off


Verification 3) Set 'trust' on/off in the VFs
---

Trust setting is off by default:

# ip link show dev eth0 | grep trust
vf 0 MAC 00:00:00:00:00:00, spoof checking on, link-state auto, trust off
vf 1 MAC aa:fd:21:3f:93:1b, spoof checking on, link-state auto, trust off

Enable trust setting on vf0:

# ip link set eth0 vf 0 trust on
# ip link show dev eth0 | grep trust
vf 0 MAC 00:00:00:00:00:00, spoof checking on, link-state auto, trust on
vf 1 MAC aa:fd:21:3f:93:1b, spoof checking on, link-state auto, trust off

Enable trust setting on vf1:

# ip link set eth0 vf 1 trust on
# ip link show dev eth0 | grep trust
vf 0 MAC 00:00:00:00:00:00, spoof checking on, link-state auto, trust on
vf 1 MAC aa:fd:21:3f:93:1b, spoof checking on, link-state auto, trust on

Disable trust setting on vf0:

# ip link set eth0 vf 0 trust off
# ip link show dev eth0 | grep trust
vf 0 MAC 00:00:00:00:00:00, spoof checking on, link-state auto, trust off
vf 1 MAC aa:fd:21:3f:93:1b, spoof checking on, link-state auto, trust on

Disable trust setting on vf1:

# ip link set eth0 vf 1 trust off
# ip link show dev eth0 | grep trust
vf 0 MAC 00:00:00:00:00:00, spoof checking on, link-state auto, trust off
vf 1 MAC aa:fd:21:3f:93:1b, spoof checking on, link-state auto, trust off

** Tags removed: verification-needed verification-needed-xenial
** Tags added: verification-done verification-done-xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iproute2 in Ubuntu.
https://bugs.launchpad.net/bugs/1800877

Title:
  iproute2/xenial: Add support for the VF Trust setting (fix IPv6
  multicast under SR-IOV on Mellanox adapters)

Status in iproute2 package in Ubuntu:
  Fix Released
Status in iproute2 source package in Xenial:
  Fix Committed

Bug description:
  [Impact]

   * An VM's VF cannot receive IPv6 multicast traffic
     from other VMs' VFs in the same Mellanox adapter
     _if_ its VF trust setting is not enabled, and on
     Xenial currently iproute2 _cannot_ enable it.

   * This breaks IPv6 NDP (Neighbor Discovery Protocol)
     in that scenario.

   * This upload adds three iproute2 upstream commits
     to enable/disable the VF setting, which resolves
     that problem/limitation.

  [Test Case]

   * Check 'ip link help' for the 'trust' option:

     Before:

   # ip link help 2>&1 | grep trust
   

     After:

   # ip link help 2>&1 | grep trust
   [ trust { on | off} ] ]

   * Check 'ip link show dev PF' for 'trust on|off' field in VFs.

     Before: (trust field _is not_ present)

   # ip link show dev ens1f0
   ...
   vf 0 MAC 00:00:00:00:00:00, spoof checking on, link-state auto
   vf 1 MAC 00:00:00:00:00:00, spoof checking on, link-state auto

     After: (trust field _is_ present)

   # ip link show dev ens1f0
   ...
   vf 0 MAC 00:00:00:00:00:00, spoof checking on, link-state auto, trust off
   vf 1 MAC 

[Touch-packages] [Bug 1801128] Re: OpenSSH 7.7 -w tunnel bug

2018-11-07 Thread Karl Stenerud
** Changed in: openssh (Ubuntu)
 Assignee: (unassigned) => Karl Stenerud (kstenerud)

** Changed in: openssh (Ubuntu Cosmic)
 Assignee: (unassigned) => Karl Stenerud (kstenerud)

** Changed in: openssh (Ubuntu Cosmic)
   Status: New => In Progress

** Description changed:

+ [Impact]
+ 
+ A regression in OpenSSH 7.7 breaks tunnelling via the -w switch in the
+ ssh command.
+ 
+ [Test Case]
+ 
+ # lxc launch ubuntu:cosmic tester && lxc exec tester bash
+ 
+ # apt update && \
+ apt dist-upgrade -y && \
+ sed -i 's/PasswordAuthentication no/PasswordAuthentication yes/g' 
/etc/ssh/sshd_config && \
+ service sshd restart && \
+ echo ubuntu:ubuntu | chpasswd
+ 
+ # ssh -w any ubuntu@localhost
+ ubuntu@localhost's password: 
+ Tunnel device open failed.
+ Could not request tunnel forwarding.
+ 
+ [Regression Potential]
+ 
+ This is already fixed and tested upstream, and thus has little
+ regression potential.
+ 
+ [Original Description]
+ 
  Just upgraded to cosmic, which picks up OpenSSH 7.7.
  
  OpenSSH 7.7 has known bug
  https://bugzilla.mindrot.org/show_bug.cgi?id=2855 which is fixed in
- OpenSSH 7.8.  It's a regression that completely breaks -w tunneling.
+ OpenSSH 7.8. It's a regression that completely breaks -w tunneling.
  
- The OpenSSH bug contains a trivial two-line patch to fix the bug.  I
+ The OpenSSH bug contains a trivial two-line patch to fix the bug. I
  downloaded the Ubuntu openssh package source, applied the patch and
  rebuilt, and can confirm that is does fix the problem.
  
  Any chance we could get this patch backported to Cosmic?
  
  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: openssh-client 1:7.7p1-4
  ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
  Uname: Linux 4.18.0-10-generic x86_64
  ApportVersion: 2.20.10-0ubuntu13
  Architecture: amd64
- Date: Thu Nov  1 09:36:16 2018
+ Date: Thu Nov 1 09:36:16 2018
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  RelatedPackageVersions:
-  ssh-askpass   N/A
-  libpam-sshN/A
-  keychain  N/A
+  ssh-askpass N/A
+  libpam-ssh N/A
+  keychain N/A
   ssh-askpass-gnome N/A
- SSHClientVersion: OpenSSH_7.7p1 Ubuntu-4, OpenSSL 1.0.2n  7 Dec 2017
+ SSHClientVersion: OpenSSH_7.7p1 Ubuntu-4, OpenSSL 1.0.2n 7 Dec 2017
  SourcePackage: openssh
  UpgradeStatus: Upgraded to cosmic on 2018-11-01 (0 days ago)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1801128

Title:
  OpenSSH 7.7 -w tunnel bug

Status in openssh package in Ubuntu:
  New
Status in openssh source package in Cosmic:
  In Progress

Bug description:
  [Impact]

  A regression in OpenSSH 7.7 breaks tunnelling via the -w switch in the
  ssh command.

  [Test Case]

  # lxc launch ubuntu:cosmic tester && lxc exec tester bash

  # apt update && \
  apt dist-upgrade -y && \
  sed -i 's/PasswordAuthentication no/PasswordAuthentication yes/g' 
/etc/ssh/sshd_config && \
  service sshd restart && \
  echo ubuntu:ubuntu | chpasswd

  # ssh -w any ubuntu@localhost
  ubuntu@localhost's password: 
  Tunnel device open failed.
  Could not request tunnel forwarding.

  [Regression Potential]

  This is already fixed and tested upstream, and thus has little
  regression potential.

  [Original Description]

  Just upgraded to cosmic, which picks up OpenSSH 7.7.

  OpenSSH 7.7 has known bug
  https://bugzilla.mindrot.org/show_bug.cgi?id=2855 which is fixed in
  OpenSSH 7.8. It's a regression that completely breaks -w tunneling.

  The OpenSSH bug contains a trivial two-line patch to fix the bug. I
  downloaded the Ubuntu openssh package source, applied the patch and
  rebuilt, and can confirm that is does fix the problem.

  Any chance we could get this patch backported to Cosmic?

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: openssh-client 1:7.7p1-4
  ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
  Uname: Linux 4.18.0-10-generic x86_64
  ApportVersion: 2.20.10-0ubuntu13
  Architecture: amd64
  Date: Thu Nov 1 09:36:16 2018
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  RelatedPackageVersions:
   ssh-askpass N/A
   libpam-ssh N/A
   keychain N/A
   ssh-askpass-gnome N/A
  SSHClientVersion: OpenSSH_7.7p1 Ubuntu-4, OpenSSL 1.0.2n 7 Dec 2017
  SourcePackage: openssh
  UpgradeStatus: Upgraded to cosmic on 2018-11-01 (0 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1801128/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802090] Re: update overwrites sshd_config

2018-11-07 Thread Marc Deslauriers
That's not supposed to happen. Could you please attach your /var/log
/dist-upgrade/apt-term.log file?

Did you update manually, or was this done automatically?

Thanks.

** Changed in: openssh (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 856776] Re: Cannot declare itself as another username with CUPS server

2018-11-07 Thread gf
Hi Jonathan. Thanks for the update on your life! (chuckle!)
Congratulations on graduating university. :)
I hope you still have time for Ubuntu or some form of Linux in your life. I am 
just clearing up these old bug reports that are still open from years ago.

I will close the report now.
Have a great day!
:)
G
Oshawa, Ontario (hello, fellow Canadian!)

Closed per reporter’s feedback.

** Changed in: cups (Ubuntu)
   Status: Incomplete => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/856776

Title:
  Cannot declare itself as another username with CUPS server

Status in Common Print Dialog:
  New
Status in cups package in Ubuntu:
  Invalid

Bug description:
  Originally posted on http://askubuntu.com/questions/61095/use-
  different-username-on-cups-remote-printing :

  > I'm using CUPS to print on an enterprise network. The job gets submitted 
fine, but I need to submit it as another username. Now  I'm `jon` but I need to 
send it as say `jonallard`.
  > 
  > On the command line, one could print as such
  > 
  > lp -U jonallard -d printer1 file.ext
  > 
  > How do I customize the *username* part when using the GUI printing dialogs 
and the Printing system settings?
  > 
  > It is possible that it isn't, in fact, possible to add this username to the 
Ubuntu print config. If so, where should I ask for an improvement?"

  Martin Owens -doctormo-@AskUbuntu suggested I add the username in the
  IPP URI directly. The printer address dialog won't let me do that.

  Is this a bug or is there some hidden place to put this username or
  should it be improved?

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: system-config-printer-gnome 1.3.1+20110222-0ubuntu16.3
  ProcVersionSignature: Ubuntu 2.6.38-11.48-generic 2.6.38.8
  Uname: Linux 2.6.38-11-generic x86_64
  NonfreeKernelModules: nvidia
  Architecture: amd64
  CupsErrorLog:
   
  Date: Thu Sep 22 16:17:38 2011
  ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
  InterpreterPath: /usr/bin/python2.7
  Lpstat: device for uprint-mono: 
ipp://cups.ncs.mcgill.ca:631/printers/mcgill_mono
  MachineType: LENOVO 427637U
  PackageArchitecture: all
  Papersize: letter
  PpdFiles: uprint-mono: Generic PCL Laser Printer
  ProcEnviron:
   LANGUAGE=en_CA:en
   LANG=en_CA.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic 
root=UUID=264a98b8-d582-4814-bb46-81adf856e638 ro splash vga=795 quiet splash 
vt.handoff=7
  SourcePackage: system-config-printer
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/13/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 8BET44WW (1.24 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 427637U
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr8BET44WW(1.24):bd05/13/2011:svnLENOVO:pn427637U:pvrThinkPadW520:rvnLENOVO:rn427637U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 427637U
  dmi.product.version: ThinkPad W520
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/common-print-dialog-gtk/+bug/856776/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 322210] Re: [needs-packaging] PPD for Dymo LabelWriter 400 not complete

2018-11-07 Thread gf
Thanks for the update, Ben. I will close the report now.
Have a great day!
:)
G

Closed per reporter’s feedback.

** Changed in: cups (Ubuntu)
   Status: Incomplete => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/322210

Title:
  [needs-packaging] PPD for Dymo LabelWriter 400 not complete

Status in cups package in Ubuntu:
  Invalid

Bug description:
  Binary package hint: cups

  Release: 8.10
  Cups package version: 1.3.9-2ubuntu6.1

  I installed Dymo LabelWriter 400 with the Multi-Purpose labels 11354.
  I chose the only available driver: Dymo Label Printer, 1.3

  Problem: I could not set the correct label size as the Multi-Purpose
  labels are missing from the ppd-file. The result is that I get
  printouts which do not fit the labels.

  Solution:
  I downloaded the driver from the manufacturer and extracted the lines for the 
Multi-Purpose labels from their ppd-file.
  drivers page: 
https://global.dymo.com/enUS/RNW/RNW.html?pg=std_adp.php_faqid=101
  driver file: http://www.dymo.com/media/Software/dymo-cups-drivers-1.0.3.tar.gz

  What should be done is that the ppd-file in cups should be updated
  with all the labels in the manufacturers ppd. Depending on their
  license.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/322210/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1802090] [NEW] update overwrites sshd_config

2018-11-07 Thread Dominic Raferd
Public bug reported:

The latest update for Bionic (18.04.1) either overwrote or modified my
/etc/ssh/sshd_config with the result that I could no longer access my
machine using ssh.

A specific
Port [x]
line was removed and replaced by:
#Port 22

This was the only change. It happened as part of an automated process
this morning  - presumably a security update.

Was this behaviour intended?!

** Affects: openssh (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1802090

Title:
  update overwrites sshd_config

Status in openssh package in Ubuntu:
  New

Bug description:
  The latest update for Bionic (18.04.1) either overwrote or modified my
  /etc/ssh/sshd_config with the result that I could no longer access my
  machine using ssh.

  A specific
  Port [x]
  line was removed and replaced by:
  #Port 22

  This was the only change. It happened as part of an automated process
  this morning  - presumably a security update.

  Was this behaviour intended?!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1802090/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1777010] Re: ip token set, results in: Invalid argument

2018-11-07 Thread Lisa Jessin
@Thomas: sorry, took me some days to find the time and check with
freshly installed versions:

16.04.5 LTS (Xenial Xerus):
~#ip token list
token :: dev eth0 
~# ip token set ::12 dev eth0
~# ip token list
token ::12 dev eth0 
~# ip token set ::ab dev eth0
~# ip token list
token ::ab dev eth0 

Debian GNU/Linux 9 (stretch):
:~# ip token list
token :: dev eth0
~# ip token set ::12 dev eth0
~# ip token list
token ::12 dev eth0
~# ip token set ::ab dev eth0
~# ip token list
token ::ab dev eth0

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iproute2 in Ubuntu.
https://bugs.launchpad.net/bugs/1777010

Title:
  ip token set, results in: Invalid argument

Status in iproute2 package in Ubuntu:
  Confirmed

Bug description:
  Hi,

  I can't set any ipv6 token with ip command. It seems that it has a bug.
  Also it is not possible to set it with netplan (see bug #1737976)

  ~# ip token list
  token :: dev enp1s0
  token :: dev enp2s0
  token :: dev ovpn0
  token :: dev br0

  ~# ip token set ::2a:2a:2a:2a/64 dev br0
  RTNETLINK answers: Invalid argument

  ~# ip token set ::2a/64 dev br0
  RTNETLINK answers: Invalid argument

  ~# ip token set ::beef dev br0
  RTNETLINK answers: Invalid argument

  It seems, that this Bug is really old?!
  https://bbs.archlinux.org/viewtopic.php?id=202757

  This is really fatal, because I cant set a static ip. My prefix get
  mixed from my provider every x days.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: iproute2 4.15.0-2ubuntu1
  ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
  Uname: Linux 4.15.0-23-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.2
  Architecture: amd64
  Date: Fri Jun 15 01:26:04 2018
  InstallationDate: Installed on 2018-06-12 (2 days ago)
  InstallationMedia: Ubuntu-Server 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  ProcEnviron:
   TERM=xterm
   PATH=(custom, no user)
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: iproute2
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iproute2/+bug/1777010/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1777010] Re: ip token set, results in: Invalid argument

2018-11-07 Thread Lisa Jessin
Also checked removing of tokens:
~# ip token set :: dev eth0
~# ip token list
token :: dev eth0 

This works in Xenial and Stretch without any errors.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iproute2 in Ubuntu.
https://bugs.launchpad.net/bugs/1777010

Title:
  ip token set, results in: Invalid argument

Status in iproute2 package in Ubuntu:
  Confirmed

Bug description:
  Hi,

  I can't set any ipv6 token with ip command. It seems that it has a bug.
  Also it is not possible to set it with netplan (see bug #1737976)

  ~# ip token list
  token :: dev enp1s0
  token :: dev enp2s0
  token :: dev ovpn0
  token :: dev br0

  ~# ip token set ::2a:2a:2a:2a/64 dev br0
  RTNETLINK answers: Invalid argument

  ~# ip token set ::2a/64 dev br0
  RTNETLINK answers: Invalid argument

  ~# ip token set ::beef dev br0
  RTNETLINK answers: Invalid argument

  It seems, that this Bug is really old?!
  https://bbs.archlinux.org/viewtopic.php?id=202757

  This is really fatal, because I cant set a static ip. My prefix get
  mixed from my provider every x days.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: iproute2 4.15.0-2ubuntu1
  ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
  Uname: Linux 4.15.0-23-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.2
  Architecture: amd64
  Date: Fri Jun 15 01:26:04 2018
  InstallationDate: Installed on 2018-06-12 (2 days ago)
  InstallationMedia: Ubuntu-Server 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  ProcEnviron:
   TERM=xterm
   PATH=(custom, no user)
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  SourcePackage: iproute2
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iproute2/+bug/1777010/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1801496] Re: Printing job in 16.04 is slower than in 14.04

2018-11-07 Thread William.Yeung
We are reported that users(who are affect by this problem ) can't do
their job normally. Such as, doctors' consulting speed are seriously
delay by the medical diagnostic document printing speed.

We(RICOH printer driver developer) are still working hard to looking for an 
workaround to make sure our printer user can do their job normally before your 
official release.
We appreciate that you can private it to us if you have one.

By the way, more and more our printer driver users are affect by this
problem.

So, we are eagerly want to know that if Ubuntu is on the process of dealing 
with this problem?
Can you offer us the approximate time that Ubuntu fixed this problem?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1801496

Title:
  Printing job in 16.04 is slower than in 14.04

Status in cups package in Ubuntu:
  New

Bug description:
  Ubuntu 16.04LTS
  OS Version:   16.04.5
  CUPS Version: 2.1.3
  Ghostscript Version:  9.25 (2018-09-13)

  Printing job in 16.04 is slower than in 14.04

  We(RICOH printer driver developer) are report a problem from our printer 
users:
  I print file Ubuntu 14.04.5, CUPS 2.1.3,Ghostscript 9.25 is fast(12 Seconds).

  But, after I update to Ubuntu 16.04, CUPS 2.1.3, Ghostscript 9.25, I
  print the same file with the same driver is slow(326 Seconds).

  I figure out that all the print jobs is much slower on Ubuntu 16.04.

  I view the "CUPS Error Log",   it shows that there are three points
  which maybe the reasons that makes the print job slowly.

  
  FIRST:
  
  By counting the time from "Starting renderer" to "renderer exited with status 
0", we figure out that 16.04 spend more time than 14.04 on "renderer" process.
  So we assuming that:"renderer" is one of the key process that makes the print 
job slowly.

  "Starting renderer with command: \"printf \'\\033%%-12345X@PJL 
JOB\\012\';printf \'@PJL SET DATAMODE=TWIN\\  @PJL 
EOJ\\012\\033%%-12345X\'\""
  .
  renderer exited with status 0"
  


  SECOND:
  
  On 16.04, a print job outputs lots of logs as below:
  "[Job xxx] Removing document files."

  This step(“Removing document files”)does not exsit on 14.04.
  

  
  The phenomenon that print jobs slower in 16.04 is more obvious when printing 
many jobs in the same time.

  THIRD
  We tried drivers form other company(HP,Brother…), the printings also slow 
down in Ubuntu 16.04 than 14.04.

  Our question is:
  1. Do you have any plan to improve the performance of printing on Ubuntu 
16.04?
  2. Do you have any workaround before this problems fixed?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1801496/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1740894] Re: KEY_RFKILL is not passed to userspace

2018-11-07 Thread Sebastien Bacher
Sorry but it's still a bit confusing to me so taking a step back
- on a stock XPS with the non-SRU version, what keycode do you get in xev 
- on a stock cosmic what happens when you use the key
- does that command works to get out of airplane mode?

gdbus call --session --dest org.gnome.SettingsDaemon.Rfkill \
   --object-path /org/gnome/SettingsDaemon/Rfkill \
   --method org.freedesktop.DBus.Properties.Set \
org.gnome.SettingsDaemon.Rfkill AirplaneMode ''

(https://bugzilla.gnome.org/show_bug.cgi?id=760517 is the upstream bug
which discussed the current handling of that key in g-s-d)

** Bug watch added: GNOME Bug Tracker #760517
   https://bugzilla.gnome.org/show_bug.cgi?id=760517

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libxkbcommon in Ubuntu.
https://bugs.launchpad.net/bugs/1740894

Title:
  KEY_RFKILL is not passed to userspace

Status in libxkbcommon package in Ubuntu:
  Fix Released
Status in xkeyboard-config package in Ubuntu:
  Fix Released
Status in xorgproto package in Ubuntu:
  Fix Released
Status in xkeyboard-config source package in Bionic:
  Fix Committed
Status in xkeyboard-config source package in Cosmic:
  Fix Committed

Bug description:
  * Impact
  the airplane mode key doesn't work in GNOME

  * Test case
  Use a laptop with a key to activate airplane mode, it should toggle the 
corresponding mode on/off when used

  * Regression potential
  The change adds a new key definition but doesn't touch any existing one, 
nothing specific to test out of the new key working

  -

  There are a couple things going on, that could be fixed by a Debian or
  Ubuntu maintainer:

  - libxkbdcommon needs to be updated from 0.7.1 to 0.7.2. This
  introduces the RFKill key: https://lists.freedesktop.org/archives
  /wayland-devel/2017-August/034721.html

  - x11-proto needs a new release. This commit added RFKill, but it is
  not in a release:
  
https://cgit.freedesktop.org/xorg/proto/xproto/commit/?id=98a32d328e7195e12c38baa877917335bceffbaf

  - Likely other X11 packages need to be rebuilt.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libxkbcommon/+bug/1740894/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1801832] Re: Input method toggled when using the numeric pad

2018-11-07 Thread Randy Tang
** Tags added: ibus

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ibus in Ubuntu.
https://bugs.launchpad.net/bugs/1801832

Title:
  Input method toggled when using the numeric pad

Status in ibus package in Ubuntu:
  New

Bug description:
  Ubuntu 18.04 LTS

  During the Chinese character input mode, when I enter numbers using
  the numeric pad, the input method will be switched to English
  automatically, which is very annoying. Any suggestions?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1801832/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1801496] Re: Printing job in 16.04 is slower than in 14.04

2018-11-07 Thread William.Yeung
** Package changed: ubuntu => cups (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1801496

Title:
  Printing job in 16.04 is slower than in 14.04

Status in cups package in Ubuntu:
  New

Bug description:
  Ubuntu 16.04LTS
  OS Version:   16.04.5
  CUPS Version: 2.1.3
  Ghostscript Version:  9.25 (2018-09-13)

  Printing job in 16.04 is slower than in 14.04

  We(RICOH printer driver developer) are report a problem from our printer 
users:
  I print file Ubuntu 14.04.5, CUPS 2.1.3,Ghostscript 9.25 is fast(12 Seconds).

  But, after I update to Ubuntu 16.04, CUPS 2.1.3, Ghostscript 9.25, I
  print the same file with the same driver is slow(326 Seconds).

  I figure out that all the print jobs is much slower on Ubuntu 16.04.

  I view the "CUPS Error Log",   it shows that there are three points
  which maybe the reasons that makes the print job slowly.

  
  FIRST:
  
  By counting the time from "Starting renderer" to "renderer exited with status 
0", we figure out that 16.04 spend more time than 14.04 on "renderer" process.
  So we assuming that:"renderer" is one of the key process that makes the print 
job slowly.

  "Starting renderer with command: \"printf \'\\033%%-12345X@PJL 
JOB\\012\';printf \'@PJL SET DATAMODE=TWIN\\  @PJL 
EOJ\\012\\033%%-12345X\'\""
  .
  renderer exited with status 0"
  


  SECOND:
  
  On 16.04, a print job outputs lots of logs as below:
  "[Job xxx] Removing document files."

  This step(“Removing document files”)does not exsit on 14.04.
  

  
  The phenomenon that print jobs slower in 16.04 is more obvious when printing 
many jobs in the same time.

  THIRD
  We tried drivers form other company(HP,Brother…), the printings also slow 
down in Ubuntu 16.04 than 14.04.

  Our question is:
  1. Do you have any plan to improve the performance of printing on Ubuntu 
16.04?
  2. Do you have any workaround before this problems fixed?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1801496/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


  1   2   >