[Touch-packages] [Bug 1839123] Re: [19.10 FEAT] gzip compression improvements addl. patch required

2019-08-12 Thread Frank Heimes
** Changed in: ubuntu-z-systems
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gzip in Ubuntu.
https://bugs.launchpad.net/bugs/1839123

Title:
  [19.10 FEAT] gzip compression improvements addl. patch required

Status in Ubuntu on IBM z Systems:
  Fix Released
Status in gzip package in Ubuntu:
  Fix Released

Bug description:
  This patch (unfortunately not yet upstream acepted) is needed on top
  of LP 1825350
  (https://bugs.launchpad.net/ubuntu/+source/gzip/+bug/1825350), and
  fixes a serious bug.

  It was already developed and published a while ago:
  https://lists.gnu.org/archive/html/bug-gzip/2019-07/msg0.html

  This patch fixes data corruption issues, and thus is very important.
  Unfortunately, so far it has been ignored (there is not much going on
  on gzip mailing list in general). I would like to ask you to pick it
  up for the distro.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1839123/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832397] Re: dbus errors and running older version

2019-08-12 Thread Launchpad Bug Tracker
[Expired for dbus (Ubuntu) because there has been no activity for 60
days.]

** Changed in: dbus (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to dbus in Ubuntu.
https://bugs.launchpad.net/bugs/1832397

Title:
  dbus errors and running older version

Status in dbus package in Ubuntu:
  Expired

Bug description:
  Hello,

  
  I am running this older version :

  Traitement des actions différées (« triggers ») pour dbus
  (1.12.2-1ubuntu1) ...

  
  I have errors as following :

  Failed to open connection to "system" message bus: Did not receive a
  reply. Possible causes include: the remote application did not send a
  reply, the message bus security policy blocked the reply, the reply
  timeout expired, or the network connection was broken.

  
  Thank you in advance to help me debugg dbus then update It,

  Regards.

  
  Dorian ROSSE.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/1832397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839231] Re: updating bionic to 237-3ubuntu10.25 restarts systemd-networkd

2019-08-12 Thread Dan Streetman
upgrading systemd does restart networkd, but it should not remove any
existing managed configuration while restarting (or stopping).  For
example:

ubuntu@lp1839231:~$ sudo systemctl start systemd-networkd
ubuntu@lp1839231:~$ ip a show ens3
2: ens3:  mtu 1500 qdisc fq_codel state UP 
group default qlen 1000
link/ether 52:54:00:e8:e2:3f brd ff:ff:ff:ff:ff:ff
inet 192.168.122.25/24 brd 192.168.122.255 scope global dynamic ens3
   valid_lft 3537sec preferred_lft 3537sec
inet6 fe80::5054:ff:fee8:e23f/64 scope link 
   valid_lft forever preferred_lft forever
ubuntu@lp1839231:~$ sudo systemctl stop systemd-networkd
Warning: Stopping systemd-networkd.service, but it can still be activated by:
  systemd-networkd.socket
ubuntu@lp1839231:~$ ip a show ens3
2: ens3:  mtu 1500 qdisc fq_codel state UP 
group default qlen 1000
link/ether 52:54:00:e8:e2:3f brd ff:ff:ff:ff:ff:ff
inet 192.168.122.25/24 brd 192.168.122.255 scope global dynamic ens3
   valid_lft 3529sec preferred_lft 3529sec
inet6 fe80::5054:ff:fee8:e23f/64 scope link 
   valid_lft forever preferred_lft forever
ubuntu@lp1839231:~$ sudo systemctl start systemd-networkd
ubuntu@lp1839231:~$ ip a show ens3
2: ens3:  mtu 1500 qdisc fq_codel state UP 
group default qlen 1000
link/ether 52:54:00:e8:e2:3f brd ff:ff:ff:ff:ff:ff
inet 192.168.122.25/24 brd 192.168.122.255 scope global dynamic ens3
   valid_lft 3599sec preferred_lft 3599sec
inet6 fe80::5054:ff:fee8:e23f/64 scope link 
   valid_lft forever preferred_lft forever


What specific config is in your networkd config files?  What specific 
interface(s) or address(es) are you having trouble with?

** Changed in: systemd (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1839231

Title:
  updating bionic to 237-3ubuntu10.25 restarts systemd-networkd

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  I updated my Ubuntu 18.04.2 server from systemd 237-3ubuntu10.24 to
  237-3ubuntu10.25. This caused a restart of systemd-networkd, breaking
  all TCP-over-IPv6 connections.

  apt history entry:

  Start-Date: 2019-08-06  19:46:21
  Commandline: apt-get dist-upgrade -y
  Requested-By: shivaram (1000)
  Upgrade: libsystemd0:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), udev:amd64 
(237-3ubuntu10.24, 237-3ubuntu10.25), libudev1:amd64 (237-3ubuntu10.24, 
237-3ubuntu10.25), systemd-sysv:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), 
libpam-systemd:amd64 (237-3ubuntu10.24, 237-3ubuntu10.25), systemd:amd64 
(237-3ubuntu10.24, 237-3ubuntu10.25), libnss-systemd:amd64 (237-3ubuntu10.24, 
237-3ubuntu10.25), base-files:amd64 (10.1ubuntu2.5, 10.1ubuntu2.6)
  End-Date: 2019-08-06  19:54:17

  systemd journal output:

  Aug 06 19:47:40 pentos systemd[1]: Reloading.
  Aug 06 19:47:57 pentos systemd[1]: Reexecuting.
  Aug 06 19:47:58 pentos systemd[1]: systemd 237 running in system mode. (+PAM 
+AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT 
+GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 
default-hie
  Aug 06 19:47:58 pentos systemd[1]: Detected architecture x86-64.
  Aug 06 19:47:58 pentos systemd[1]: Stopping Network Service...
  Aug 06 19:47:58 pentos systemd[1]: Stopped Network Service.
  Aug 06 19:47:58 pentos systemd[1]: Starting Network Service...
  Aug 06 19:47:59 pentos systemd-networkd[11513]: ens5: Gained IPv6LL
  Aug 06 19:47:59 pentos systemd-networkd[11513]: Enumeration completed
  Aug 06 19:47:59 pentos systemd[1]: Started Network Service.
  Aug 06 19:47:59 pentos systemd-networkd[11513]: lo: Link is not managed by us
  Aug 06 19:47:59 pentos systemd-networkd[11513]: ens5: DHCPv4 address 
192.168.1.103/24 via 192.168.1.1
  Aug 06 19:47:59 pentos dbus-daemon[947]: [system] Activating via systemd: 
service name='org.freedesktop.hostname1' 
unit='dbus-org.freedesktop.hostname1.service' requested by ':1.2341' (uid=100 
pid=11513 comm="/lib/systemd/systemd-network
  Aug 06 19:47:59 pentos systemd-networkd[11513]: ens5: Configured

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1839231/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839856] Re: Screen resolution on external monitor won't go above 2560 x 1080

2019-08-12 Thread Daniel van Vugt
** Package changed: xorg (Ubuntu) => xorg-server (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1839856

Title:
  Screen resolution on external monitor won't go above 2560 x 1080

Status in linux package in Ubuntu:
  Confirmed
Status in xorg-server package in Ubuntu:
  New

Bug description:
  I have an external monitor capable of 3440 x 1440. I am using a
  Thinkpad T480s. Up until about 2 weeks ago, I could set the resolution
  of the monitor to 3440 x 1440 just fine. Now when I try, the screen
  goes black and I have to revert to a lower resolution. The highest it
  will go now is 2560 x 1080. Lower resolutions work fine as well.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
  Uname: Linux 5.0.0-23-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Aug 12 08:56:25 2019
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus:
   acpi-call, 1.1.0, 4.18.0-25-generic, x86_64: installed
   acpi-call, 1.1.0, 5.0.0-23-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GraphicsCard:
   Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA 
controller])
 Subsystem: Lenovo UHD Graphics 620 [17aa:2258]
  InstallationDate: Installed on 2019-02-19 (173 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: LENOVO 20L7S01200
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-23-generic 
root=UUID=471b6634-e334-44c7-b898-080ab93327e0 ro quiet splash vt.handoff=1
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/19/2019
  dmi.bios.vendor: LENOVO
  dmi.bios.version: N22ET53W (1.30 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20L7S01200
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40709 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrN22ET53W(1.30):bd02/19/2019:svnLENOVO:pn20L7S01200:pvrThinkPadT480s:rvnLENOVO:rn20L7S01200:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad T480s
  dmi.product.name: 20L7S01200
  dmi.product.sku: LENOVO_MT_20L7_BU_Think_FM_ThinkPad T480s
  dmi.product.version: ThinkPad T480s
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
  version.libdrm2: libdrm2 2.4.97-1ubuntu1~18.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.2-1ubuntu1.1~18.04.2
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.0.2-1ubuntu1.1~18.04.2
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1839856/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839900] [NEW] Power button action not working

2019-08-12 Thread Douglas Silva
Public bug reported:

I've configured it so that the system would suspend after pressing the
power button. This does not happen.

How is it reproducible?
It started after updating from Ubuntu 18.04.2 to 18.04.3. New packages, new 
kernel, new bug. On Ubuntu 19.04, this has been reproducible since its release. 
This is also reproducible on other distributions with the GNOME desktop.

This is exclusive to the GNOME desktop. No other desktop I've tried has
issues with the power button action.

Ubuntu 18.04.3
Kernel 5.0.0-23-generic
GNOME 3.28.2

See attached logs. Near the end of it I attempted to make the system
suspend by repeatedly pressing the power button, as configured in GNOME
Settings > Power > When the power button is pressed.

** Affects: gnome-settings-daemon (Ubuntu)
 Importance: Undecided
 Status: New

** Attachment added: "journalctl output"
   
https://bugs.launchpad.net/bugs/1839900/+attachment/5282269/+files/journalctl.txt

** Package changed: systemd (Ubuntu) => gnome-settings-daemon (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1839900

Title:
  Power button action not working

Status in gnome-settings-daemon package in Ubuntu:
  New

Bug description:
  I've configured it so that the system would suspend after pressing the
  power button. This does not happen.

  How is it reproducible?
  It started after updating from Ubuntu 18.04.2 to 18.04.3. New packages, new 
kernel, new bug. On Ubuntu 19.04, this has been reproducible since its release. 
This is also reproducible on other distributions with the GNOME desktop.

  This is exclusive to the GNOME desktop. No other desktop I've tried
  has issues with the power button action.

  Ubuntu 18.04.3
  Kernel 5.0.0-23-generic
  GNOME 3.28.2

  See attached logs. Near the end of it I attempted to make the system
  suspend by repeatedly pressing the power button, as configured in
  GNOME Settings > Power > When the power button is pressed.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1839900/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1838464] Re: NFS volume not mounting with systemd

2019-08-12 Thread Dan Streetman
> After=network.target

you want to use network-online.target, not (only) network.target.

you also may want to use
Before=umount.target
Before=remote-fs.target


systemd will create an automatic mount unit for all mounts, so you can see what 
params it uses if you mount the NFS share manually (i.e. remove your mount unit 
file and mount from cmdline) and run systemctl show, e.g.:
$ systemctl show mnt-nas-music.mount

it also will dynamically create mount files for everything you have in
/etc/fstab, at /run/systemd/generator/.

Is there a reason you want to replace the fstab entry with a systemd
mount unit file?

** Changed in: systemd (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1838464

Title:
  NFS volume not mounting with systemd

Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Hello,

  I'm unable to mount NFS volume at boot time with systemd. Using Ubuntu 
18.04.2 LTS.
  I commented out /etc/fstab entry:
  #192.168.1.103:/Multimedia/Music  /mnt/nas/music/ nfs 
_netdev,auto,user,vers=30   0

  I created "/etc/systemd/system/mnt-nas-music.mount":
  [Unit]
  Description=NAS volume - Music
  After=network.target

  [Mount]
  What=192.168.1.103:/Multimedia/Music
  Where=/mnt/nas/music/
  Type=nfs
  Options=_netdev,auto,user,nfsvers=3
  TimeoutSec=10

  [Install]
  WantedBy=multi-user.target

  I enabled it with "systemctl enable mnt-nas-music.mount" so that when I run 
"systemctl is-enabled mnt-nas-music.mount" I obtain:
  enable

  But I keep obtaining this error ("systemctl status mnt-nas-
  music.mount"):

   mnt-nas-music.mount - NAS volume - Music
 Loaded: loaded (/etc/systemd/system/mnt-nas-music.mount; enabled; vendor 
preset: enabled)
 Active: failed (Result: exit-code) since Tue 2019-07-30 21:23:42 CEST; 
29min ago
  Where: /mnt/nas/music
   What: 192.168.1.103:/Multimedia/Music
Process: 1530 ExecMount=/bin/mount 192.168.1.103:/Multimedia/Music 
/mnt/nas/music -t nfs -o _netdev,user,nfsvers=3 (code=exited, status=32)

  lug 30 21:23:42 ubuntu-desktop systemd[1]: Mounting NAS volume - Music...
  lug 30 21:23:42 ubuntu-desktop mount[1530]: mount.nfs: Network is unreachable
  lug 30 21:23:42 ubuntu-desktop systemd[1]: mnt-nas-music.mount: Mount process 
exited, code=exited status=32
  lug 30 21:23:42 ubuntu-desktop systemd[1]: mnt-nas-music.mount: Failed with 
result 'exit-code'.
  lug 30 21:23:42 ubuntu-desktop systemd[1]: Failed to mount NAS volume - Music.

  If I run "journalctl -b" I notice that the attempt to mount NFS volume 
happens before network is ready:
  lug 30 21:23:42 ubuntu-desktop systemd[1]: Failed to mount NAS volume - Music.
  lug 30 21:23:48 ubuntu-desktop NetworkManager[978]:   [1564514628.2750] 
device (enp2s0): Activation: successful, device activated.

  I think this is a bug.
  Thanks in advance
  Michele

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1838464/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1838329] Re: Cryptswap periodically fails to mount at boot due to missing a udev notification

2019-08-12 Thread Dan Streetman
> This patch has already been submitted upstream to systemd

What is the upstream systemd issue number?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1838329

Title:
  Cryptswap periodically fails to mount at boot due to missing a udev
  notification

Status in systemd package in Ubuntu:
  New

Bug description:
  On some systems, cryptsetup-based encrypted swap partitions cause
  systemd to get stuck at boot. This is a timing-sensitive Heisenbug, so
  the rate of occurrence varies from one system to another. Some
  hardware will not experience the issue at all, others will only
  occasionally experience the issue, and then there are the unlucky who
  are unable to boot at all, no matter how many times they restart.

  The workaround is for the cryptsetup-generator to generate cryptswap
  service entries that call `udevadm trigger` after `mkswap`. This will
  ensure that the udev event is triggered, so that systemd is notified
  that the encrypt swap partition is ready to activate. This patch has
  already been submitted upstream to systemd, but it was not accepted
  because it is a workaround for the side effect of systemd not seeing
  the udev event upon creating the swap partition.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1838329/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839589] Re: pulseaudio FTBFS on eoan 12.2-2ubuntu4 [FAIL: cpu-volume-test]

2019-08-12 Thread Dave Chiluk
** Changed in: pulseaudio (Ubuntu)
 Assignee: (unassigned) => Dave Chiluk (chiluk)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1839589

Title:
  pulseaudio FTBFS on eoan 12.2-2ubuntu4 [FAIL: cpu-volume-test]

Status in pulseaudio package in Ubuntu:
  Confirmed

Bug description:
  pulseaudio fails to build from source on Eoan

  I was attempting to put together a patchset for LP#1839580, but it
  appears as if the packages are currently failing to build from source.
  Not sure how they built the first time around.

  Here's my ppa's buildlog, for a source package with my patch commented out of 
the series file.
  
https://launchpadlibrarian.net/436626918/buildlog_ubuntu-eoan-amd64.pulseaudio_1%3A12.2-2ubuntu4+lp1839580b2_BUILDING.txt.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1839589/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839123] Re: [19.10 FEAT] gzip compression improvements addl. patch required

2019-08-12 Thread Launchpad Bug Tracker
This bug was fixed in the package gzip - 1.10-0ubuntu2

---
gzip (1.10-0ubuntu2) eoan; urgency=medium

  * Cherrypick gnu debbugs fixes for optimizied s390x zlib
compression. LP: #1839123

 -- Dimitri John Ledkov   Mon, 12 Aug 2019 12:08:24
+0100

** Changed in: gzip (Ubuntu)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gzip in Ubuntu.
https://bugs.launchpad.net/bugs/1839123

Title:
  [19.10 FEAT] gzip compression improvements addl. patch required

Status in Ubuntu on IBM z Systems:
  Fix Committed
Status in gzip package in Ubuntu:
  Fix Released

Bug description:
  This patch (unfortunately not yet upstream acepted) is needed on top
  of LP 1825350
  (https://bugs.launchpad.net/ubuntu/+source/gzip/+bug/1825350), and
  fixes a serious bug.

  It was already developed and published a while ago:
  https://lists.gnu.org/archive/html/bug-gzip/2019-07/msg0.html

  This patch fixes data corruption issues, and thus is very important.
  Unfortunately, so far it has been ignored (there is not much going on
  on gzip mailing list in general). I would like to ask you to pick it
  up for the distro.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1839123/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1838370] Re: slapd segfault on filter parse error

2019-08-12 Thread Lucas Kanashiro
** Description changed:

  Impact
  --
  
  Users willing to use the slapd rwm overlay will face a slapd
  segmentation fault when trying to rewrite some rules. Backporting this
  fix will allow users using stable releases to take advantage of this
  feature without crashing slapd. This issue was fixed by upstream not
  freeing the rwm overlay filter memory without prior checking.
  
  Test Case
  -
  
  In this test case, the rwm overlay will be used and a rule will be
  created to deny any search request for uid=root, then the 'ldapsearch'
  will be invoked to trigger the failure. It is important to mention that
  the 'ldapsearch' command should fail regardless the presence of the bug
  in the package, the target here is the slapd crash. To reproduce this
  bug one can follow the procedure below in Ubuntu xenial, bionic or
  disco:
  
  $ sudo apt-get update
+ 
+ 
+ Use debconf to pre-seed slapd questions before install it:
+ 
+ $ debconf-set-selections << EOF
+ slapd slapd/no_configuration boolean false
+ slapd slapd/domain string example.com
+ slapd shared/organization string example.com
+ slapd slapd/password1 password test
+ slapd slapd/password2 password test
+ slapd slapd/backend select MDB
+ slapd slapd/move_old_database boolean false
+ EOF
  $ sudo apt-get install slapd ldap-utils -y
  
- Reconfigure the slapd package. When asked about a domain, use "example.com".
- Choose a password you want (or just leave it blank), and accept defaults for
- everything else:
- 
- $ sudo dpkg-reconfigure slapd
  
  Create a file called 'add-rwm.ldif' with the following content:
  
  $ cat add-rwm.ldif
  dn: cn=module{0},cn=config
  changetype: modify
  add: olcModuleLoad
  olcModuleLoad: rwm
  
  dn: olcOverlay=rwm,olcDatabase={1}mdb,cn=config
  changetype: add
  objectClass: olcOverlayConfig
  objectClass: olcRwmConfig
  olcOverlay: rwm
  olcRwmRewrite: {0} rwm-rewriteEngine "on"
  olcRwmRewrite: {1} rwm-rewriteContext "searchFilter"
  olcRwmRewrite: {2} rwm-rewriteRule "(.*)(uid=root)(.*)" "$1$2$3" "#"
  
  With this file in place, run:
  
  $ sudo ldapadd -Q -Y EXTERNAL -H ldapi:/// -f add-rwm.ldif
  
  Now, to trigger the crash:
  
  $ ldapsearch -x -h localhost -b dc=example,dc=com -LLL uid=root
  Server is unwilling to perform (53)
  Additional information: searchFilter/searchFilterAttrDN massage error
  
- slapd process will die, and /var/crash will have a crash file for slapd. You
- can run the following command to confirm the error:
+ 
+ slapd process will die, and /var/crash will have a crash file for slapd. You 
can run the following command to confirm the error:
  
  $ cat /var/log/syslog | grep filter_free
  Aug  9 19:51:05 popular-gorilla slapd[1479]: filter_free: unknown filter 
type=28530
+ 
+ -> Expected behavior
+ 
+ In this test case, as mentioned before, the 'ldapsearch' command should
+ fail but the 'slapd' process should not die. As result, we don't expect
+ a slapd crash report in /var/crash directory.
+ 
  
  Regression Potential
  
  
  Since the fix is a patch provided by upstream (reviewed by maintainers
  and us) simple mistakes like typos are not expected. The patch impacts
  only the rwm module which is not loaded by default. So any regression
  would affect only the users that make use of this overlay. If an user is
  not using rwm overlay and is facing any issue, it should be related to
  other problems related to LDAP directory services.
+ 
  
  [Original message]
  
  Hello!
  We have faced slapd crash, seems an attacker was trying to brute force one
  of our services and uid parsing failures caused slapd crash:
  
  Jul 26 18:59:47 slapd[1252]: conn=1466 op=13 SRCH
  base="ou=test,dc=test,dc=com" scope=2 deref=0
  
filter="(&(uid=aistar123<>!n)(objectClass=posixAccount)(uid=*)(&(uidNumber=*)(!(uidNumber=0"
  Jul 26 18:59:47 slapd[1252]: conn=1466 op=13 SRCH attr=objectClass uid
  userPassword uidNumber gidNumber gecos homeDirectory loginShell
  krbPrincipalName cn memberOf modifyTimestamp modifyTimestamp
  shadowLastChange shadowMin shadow
  Max shadowWarning shadowInactive shadowExpire shadowFlag krbLastPwdChange
  krbPasswordExpiration pwdAttribute authorizedService accountExpires
  userAccountControl nsAccountLock host loginDisabled loginExpirationTime
  loginAllowedTimeMap sshPublic
  Key
  Jul 26 18:59:47 slapd[1252]: conn=1466 op=13 SEARCH RESULT tag=101 err=0
  nentries=0 text=massaged filter parse error
  Jul 26 18:59:47 kernel: [ 9441.554161] slapd[2367]: segfault at 18 ip
  7fc8d18ec512 sp 7fc8889e2810 error 4 in libc-2.23.so
  [7fc8d1868000+1c]
  
  Another faulty filter example:
  
filter="(&(uid=sql<>?)(objectClass=posixAccount)(&(uidNumber=*)(!(uidNumber=0"
  
filter="(&(uid=fugeone<>?123)(objectClass=posixAccount)(uid=*)(&(uidNumber=*)(!(uidNumber=0"
  
  $ lsb_release -rd
  Description: Ubuntu 16.04.5 LTS
  Release: 16.04
  
  $ slapd -VVV
  @(#) $OpenLDAP: slapd  (Ubuntu) (May 22 2018 13:54:12) $
  

[Touch-packages] [Bug 1574582] Re: HP lt4120 Snapdragon X5 LTE USB modem not recognized by network-manager

2019-08-12 Thread Andreas Martitsch
In 18.04 I was able to configure the modem properly using following
steps:

XXX@XXX-HP-EliteBook-840-G3:~$ uname -a
Linux XXX-HP-EliteBook-840-G3 5.0.0-23-generic #24~18.04.1-Ubuntu SMP Mon Jul 
29 16:12:28 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux


Step 1: Check if the LTE module is properly detected by the NetworkManager

XXX@XXX-HP-EliteBook-840-G3:~$ mmcli -L
/org/freedesktop/ModemManager1/Modem/0 [HP] HP lt4120 Snapdragon X5 LTE

XXX@XXX-HP-EliteBook-840-G3:~$ mmcli -m 0

  --
  General  |  dbus path: /org/freedesktop/ModemManager1/Modem/0
   |  device id: 
  --
  Hardware |   manufacturer: HP
   |  model: HP lt4120 Snapdragon X5 LTE
   |   revision: T77W595.F0.0.0.3.4.GC.020  1  [Jul 01 2015 
06:00:00]
   |   h/w revision: V055
   |  supported: gsm-umts, lte
   | cdma-evdo, lte
   | lte
   | cdma-evdo, gsm-umts, lte
   |current: cdma-evdo, gsm-umts, lte
   |   equipment id: XXX
  --
  System   | device: /sys/devices/pci:00/:00:14.0/usb1/1-3
   |drivers: qmi_wwan
   | plugin: Generic
   |   primary port: cdc-wdm0
   |  ports: cdc-wdm0 (qmi), wwp0s20f0u3i1 (net)
  --
  Numbers  |own: X
  --
  Status   |   lock: sim-pin2
   | unlock retries: sim-pin (3), sim-pin2 (3), sim-puk (10), sim-puk2 
(10)
   |  state: connected
   |power state: on
   |access tech: lte
   | signal quality: 49% (recent)
  --
  Modes|  supported: allowed: 2g; preferred: none
   | allowed: 3g; preferred: none
   | allowed: 2g, 3g; preferred: 3g
   | allowed: 2g, 3g; preferred: 2g
   | allowed: 2g, 4g; preferred: 4g
   | allowed: 2g, 4g; preferred: 2g
   | allowed: 3g, 4g; preferred: 3g
   | allowed: 3g, 4g; preferred: 4g
   | allowed: 2g, 3g, 4g; preferred: 4g
   | allowed: 2g, 3g, 4g; preferred: 3g
   | allowed: 2g, 3g, 4g; preferred: 2g
   |current: allowed: 2g, 3g, 4g; preferred: 4g
  --
  Bands|  supported: egsm, dcs, pcs, g850, utran-1, utran-4, utran-5, 
utran-8, 
   | utran-2, eutran-1, eutran-2, eutran-3, eutran-4, 
eutran-5, eutran-7, 
   | eutran-8, eutran-12, eutran-13, eutran-17, 
eutran-20, cdma-bc0, 
   | cdma-bc1
   |current: egsm, dcs, pcs, g850, utran-1, utran-4, utran-5, 
utran-8, 
   | utran-2, eutran-1, eutran-2, eutran-3, eutran-4, 
eutran-5, eutran-7, 
   | eutran-8, eutran-12, eutran-13, eutran-17, 
eutran-20, cdma-bc0, 
   | cdma-bc1
  --
  IP   |  supported: ipv4, ipv6, ipv4v6
  --
  3GPP |   imei: XXX
   |operator id: 23203
   |  operator name: HoT
   |   registration: home
  --
  CDMA |   meid: XX
   |esn: 
   | activation: not-activated
  --
  SIM  |  dbus path: /org/freedesktop/ModemManager1/SIM/0
  --
  Bearer   |  dbus path: /org/freedesktop/ModemManager1/Bearer/0


Step 2: (only necessary, if no LTE module is detected under Step 1) Get the the 
vendor and product ID of the LTE module

XXX@XXX-HP-EliteBook-840-G3:~$ lsusb
Bus 002 Device 001: ID : ZZ
Bus 001 Device 006: ID : ZZ
Bus 001 Device 005: ID : ZZ
Bus 001 Device 007: ID : ZZ
Bus 001 Device 003: ID 03f0:9d1d Hewlett-Packard 
Bus 001 Device 001: ID : ZZ


Step 3: (only necessary, if no LTE module is detected under Step 1) Create a 
specific udev rules file (e.g., 99-hp-lt4120.rules) under /etc/udev/rules.d/

ACTION!="add|change", GOTO="mbim_to_qmi_rules_end"
SUBSYSTEM!="usb|drivers", GOTO="mbim_to_qmi_rules_end"

# force HP lt4120 to configuration #1
SUBSYSTEM=="usb", \
ATTR{idVendor}=="03f0", ATTR{idProduct}=="9d1d", \
ATTR{bConfigurationValue}="1"

# load qmi_wwan module
SUBSYSTEM=="usb", \
ATTR{idVendor}=="03f0", ATTR{idProduct}=="9d1d", \
RUN+="/sbin/modprobe -b qmi_wwan"

# add the new id in the qmi_wwan driver
SUBSYSTEM=="drivers", \
ENV{DEVPATH}=="/sys/bus/usb/drivers/qmi_wwan", \
ATTR{new_id}="03f0 9d1d"

# load qcserial module
SUBSYSTEM=="usb", \
ATTR{idVendor}=="03f0", 

[Touch-packages] [Bug 1838151] Re: Poor quality audio with modern Bluetooth headsets in HSP/HFP. Missing wide band speech support.

2019-08-12 Thread Michael
Just noticed this with my new Bluetooth headset. With the same headset,
the microphone and audio quality is a lot better when paired with an
Android device than when paired with my desktop (4.15.0-55-generic
Ubuntu 18.04.03 LTS).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1838151

Title:
  Poor quality audio with modern Bluetooth headsets in HSP/HFP.  Missing
  wide band speech support.

Status in linux package in Ubuntu:
  Confirmed
Status in pulseaudio package in Ubuntu:
  Triaged

Bug description:
  Bluetooth HSP/HFP audio quality is poor on Ubuntu comparative to all
  other major platforms (Windows, MacOS, ChromeOS, Android, iOS).

  Modern Bluetooth headsets (such as the Bose QC series headphones, many
  others) are capable of using HFP 1.6 with mSBC 16kHz audio encoding.
  As it currently stands, Ubuntu defaults to only supporting HSP
  headsets using 8kHz CVSD, and is incapable of supporting HFP 1.6 at
  this time.

  The ChromiumOS team recently tackled this issue -
  https://bugs.chromium.org/p/chromium/issues/detail?id=843048

  Their efforts may assist in bringing this to Ubuntu, however it
  appears that there are quite a lot of differences considering they
  have developed their own audio server solution etc.

  The Bluetooth Telephony Working Group published the HFP 1.6 spec in
  May 2011 -
  https://www.bluetooth.org/docman/handlers/downloaddoc.ashx?doc_id=238193

  Patches have been proposed in the past for this issue to the kernel
  and PulseAudio:

  PulseAudio: https://patchwork.freedesktop.org/patch/245272/
  Kernel: https://www.spinics.net/lists/linux-bluetooth/msg76982.html

  It appears that the Chromium OS team applied the same kernel patch:
  
https://chromium.googlesource.com/chromiumos/third_party/kernel/+/77dd0cb94c1713a8a12f6e392955dfa64c430e54

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: pulseaudio 1:12.2-2ubuntu3
  ProcVersionSignature: Ubuntu 5.0.0-20.21-generic 5.0.8
  Uname: Linux 5.0.0-20-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  jnappi 2777 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Jul 27 11:08:29 2019
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2017-11-04 (629 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: pulseaudio
  UpgradeStatus: Upgraded to disco on 2019-07-18 (9 days ago)
  dmi.bios.date: 06/07/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R07ET67W (2.07 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20FW000TUS
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40705 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrR07ET67W(2.07):bd06/07/2016:svnLENOVO:pn20FW000TUS:pvrThinkPadT460p:rvnLENOVO:rn20FW000TUS:rvrSDK0J40705WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad T460p
  dmi.product.name: 20FW000TUS
  dmi.product.sku: LENOVO_MT_20FW_BU_Think_FM_ThinkPad T460p
  dmi.product.version: ThinkPad T460p
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1838151/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837170] Re: Kodi package crash after the update of libdrm-amdgpu1

2019-08-12 Thread Tom Lake
Please Timo, there's really a problem with AMD APUs

We are running our systems without HW Acceleration support

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1837170

Title:
  Kodi package crash after the update of libdrm-amdgpu1

Status in mesa package in Ubuntu:
  Incomplete

Bug description:
  Greetings,

  The last update of libdrm-amdgpu1 caused a bug on Kodi package, making
  it to crash after loading any video or reproduce a black image.

  Version: 2.4.97-1ubuntu1~18.04.12019-07-03 15:07:54 UTC

libdrm (2.4.97-1ubuntu1~18.04.1) bionic; urgency=medium

* Backport to bionic for 18.04.3 HWE stack update. (LP: #1824111)

   -- Timo Aaltonen  Wed, 10 Apr 2019 13:54:06
  +0300

  
  Kodi gives this error:

  #3  0x7f47676c60aa in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
  #4  0x7f47676c5dd7 in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

  Repeated several times

  #3  0x7f475ce2c5a6 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1
  #4  0x7f475ce2c425 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1

  Team-Kodi stated these errors are in relation to 'Not supported GPU
  drivers', when Kodi can't find these files.

  
  I've found the cause, and a temporary solution:

  This bug was caused after an update for the latest version of libdrm-
  amdgpu1 2.4.97-1ubuntu1~18.04.1

  So I grabbed the previous version from 
  https://mirror.transip.net/ubuntu/ubuntu/pool/main/libd/libdrm/

  installed libdrm-amdgpu1_2.4.95-1~18.04.1_amd64.deb

  and now Kodi returns.

  
  I created a bug report, the problem affects multiple users.

  https://bugs.launchpad.net/ubuntu/+source/kodi/+bug/1836828

  
  We have a PointRelease coming soon, would we have time to fix this package?

  Thank you for your assistance.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1837170/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1822773] Re: Volume resets to 0 on startup

2019-08-12 Thread Efthimios Chaskaris
Tried startup without steam and chromium, issue still occurs.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-utils in Ubuntu.
https://bugs.launchpad.net/bugs/1822773

Title:
  Volume resets to 0 on startup

Status in alsa-utils package in Ubuntu:
  New

Bug description:
  Steps to reproduce the problem
  1. Set the volume to some value like 100 or 80%
  2. Shutdown and start the system
  3. Volume is set to 0%.

  Ubuntu 18.10, 19.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-utils/+bug/1822773/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839856] [NEW] Screen resolution on external monitor won't go above 2560 x 1080

2019-08-12 Thread Matt White
Public bug reported:

I have an external monitor capable of 3440 x 1440. I am using a Thinkpad
T480s. Up until about 2 weeks ago, I could set the resolution of the
monitor to 3440 x 1440 just fine. Now when I try, the screen goes black
and I have to revert to a lower resolution. The highest it will go now
is 2560 x 1080. Lower resolutions work fine as well.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
Uname: Linux 5.0.0-23-generic x86_64
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Mon Aug 12 08:56:25 2019
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
DkmsStatus:
 acpi-call, 1.1.0, 4.18.0-25-generic, x86_64: installed
 acpi-call, 1.1.0, 5.0.0-23-generic, x86_64: installed
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA 
controller])
   Subsystem: Lenovo UHD Graphics 620 [17aa:2258]
InstallationDate: Installed on 2019-02-19 (173 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
MachineType: LENOVO 20L7S01200
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-23-generic 
root=UUID=471b6634-e334-44c7-b898-080ab93327e0 ro quiet splash vt.handoff=1
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/19/2019
dmi.bios.vendor: LENOVO
dmi.bios.version: N22ET53W (1.30 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20L7S01200
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: 
dmi:bvnLENOVO:bvrN22ET53W(1.30):bd02/19/2019:svnLENOVO:pn20L7S01200:pvrThinkPadT480s:rvnLENOVO:rn20L7S01200:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T480s
dmi.product.name: 20L7S01200
dmi.product.sku: LENOVO_MT_20L7_BU_Think_FM_ThinkPad T480s
dmi.product.version: ThinkPad T480s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.97-1ubuntu1~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.2-1ubuntu1.1~18.04.2
version.libgl1-mesa-glx: libgl1-mesa-glx 19.0.2-1ubuntu1.1~18.04.2
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic resolution ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1839856

Title:
  Screen resolution on external monitor won't go above 2560 x 1080

Status in xorg package in Ubuntu:
  New

Bug description:
  I have an external monitor capable of 3440 x 1440. I am using a
  Thinkpad T480s. Up until about 2 weeks ago, I could set the resolution
  of the monitor to 3440 x 1440 just fine. Now when I try, the screen
  goes black and I have to revert to a lower resolution. The highest it
  will go now is 2560 x 1080. Lower resolutions work fine as well.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
  Uname: Linux 5.0.0-23-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Aug 12 08:56:25 2019
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus:
   acpi-call, 1.1.0, 4.18.0-25-generic, x86_64: installed
   acpi-call, 1.1.0, 5.0.0-23-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GraphicsCard:
   Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA 
controller])
 Subsystem: Lenovo UHD Graphics 620 [17aa:2258]
  InstallationDate: Installed on 2019-02-19 (173 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: LENOVO 20L7S01200
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no 

[Touch-packages] [Bug 1822773] Re: Volume resets to 0 on startup

2019-08-12 Thread Efthimios Chaskaris
What happens is, the sound in the login screen appears as 0, then in the
desktop it goes to 100, then after a few seconds goes to 0. I have
chromium and steam starting up on boot. Applies to Ubuntu 19.04.

** Description changed:

  Steps to reproduce the problem
  1. Set the volume to some value like 100 or 80%
  2. Shutdown and start the system
  3. Volume is set to 0%.
  
- Ubuntu 18.10
+ Ubuntu 18.10, 19.04

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-utils in Ubuntu.
https://bugs.launchpad.net/bugs/1822773

Title:
  Volume resets to 0 on startup

Status in alsa-utils package in Ubuntu:
  New

Bug description:
  Steps to reproduce the problem
  1. Set the volume to some value like 100 or 80%
  2. Shutdown and start the system
  3. Volume is set to 0%.

  Ubuntu 18.10, 19.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-utils/+bug/1822773/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837821] Re: [HP Spectre x360 Convertible 15-df0xxx, Realtek ALC285, Black Mic, Left] Recording problem

2019-08-12 Thread Jim
Looks like the same issue I'm having on Thinkpad X1 Carbon 7th Gen
running Ubuntu 19.04.

Debug output here:
http://alsa-project.org/db/?f=5c09dfb7b0fc0ff5ad32c0576893316f5613d3a1

As well as the Mic not being detected, and therefore not available for
use in any applications, there is an issue with the master audio volume
being either full-on or muted.  individual mixer controls still work,
but the main volume control does nothing other than mute the audio.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1837821

Title:
  [HP Spectre x360 Convertible 15-df0xxx, Realtek ALC285, Black Mic,
  Left] Recording problem

Status in alsa-driver package in Ubuntu:
  Confirmed

Bug description:
  Running Ubuntu 18.04.2 LTS. The built in microphone is not displayed
  and not available to select. The webcam, touchscreen, and speakers all
  work fine. Plugging in a headset with a microphone does allow audio to
  be heard through the external microphone.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 4.18.0-25.26~18.04.1-generic 4.18.20
  Uname: Linux 4.18.0-25-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  carwyn 2521 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  Date: Wed Jul 24 20:57:51 2019
  InstallationDate: Installed on 2019-07-22 (3 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  PackageArchitecture: all
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: alsa-driver
  Symptom: audio
  Symptom_AlsaRecordingTest: ALSA recording test through plughw:PCH failed
  Symptom_Card: Built-in Audio - HDA Intel PCH
  Symptom_Jack: Black Mic, Left
  Symptom_Type: None of the above
  Title: [HP Spectre x360 Convertible 15-df0xxx, Realtek ALC285, Black Mic, 
Left] Recording problem
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/22/2019
  dmi.bios.vendor: AMI
  dmi.bios.version: F.29
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: 8518
  dmi.board.vendor: HP
  dmi.board.version: 10.47
  dmi.chassis.type: 31
  dmi.chassis.vendor: HP
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAMI:bvrF.29:bd04/22/2019:svnHP:pnHPSpectrex360Convertible15-df0xxx:pvr:rvnHP:rn8518:rvr10.47:cvnHP:ct31:cvrChassisVersion:
  dmi.product.family: 103C_5335KV HP Spectre
  dmi.product.name: HP Spectre x360 Convertible 15-df0xxx
  dmi.product.sku: 6JY95UA#ABA
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1837821/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 201786] Re: ssh Agent admitted failure to sign using the key on big endian machines

2019-08-12 Thread Andreas Hasenack
Hi Petrida,

could you please elaborate on why you changed the bug status from
incomplete to confirmed without providing the requested information from
comment #95?

** Changed in: openssh (Ubuntu)
   Status: Confirmed => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/201786

Title:
  ssh Agent admitted failure to sign using the key on big endian
  machines

Status in seahorse:
  Fix Released
Status in gnome-keyring package in Ubuntu:
  Fix Released
Status in openssh package in Ubuntu:
  Incomplete

Bug description:
  on hardy (preserved home folder from feisty) i get the following when
  i try to ssh

  Agent admitted failure to sign using the key.
  Permission denied (publickey).

  or with verbose on

  sam@titania:~$ ssh -v oberon
  OpenSSH_4.7p1 Debian-4ubuntu1, OpenSSL 0.9.8g 19 Oct 2007
  debug1: Reading configuration data /home/sam/.ssh/config
  debug1: Applying options for oberon
  debug1: Reading configuration data /etc/ssh/ssh_config
  debug1: Applying options for *
  debug1: Connecting to ## [##] port ##.
  debug1: Connection established.
  debug1: identity file /home/sam/.ssh/identity type -1
  debug1: identity file /home/sam/.ssh/id_rsa type 1
  debug1: identity file /home/sam/.ssh/id_dsa type -1
  debug1: Remote protocol version 2.0, remote software version OpenSSH_4.6p1 
Debian-5ubuntu0.1
  debug1: match: OpenSSH_4.6p1 Debian-5ubuntu0.1 pat OpenSSH*
  debug1: Enabling compatibility mode for protocol 2.0
  debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-4ubuntu1
  debug1: SSH2_MSG_KEXINIT sent
  debug1: SSH2_MSG_KEXINIT received
  debug1: kex: server->client aes128-cbc hmac-md5 none
  debug1: kex: client->server aes128-cbc hmac-md5 none
  debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
  debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
  debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
  debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
  debug1: using hostkeyalias: oberon
  debug1: Host 'oberon' is known and matches the RSA host key.
  debug1: Found key in /home/sam/.ssh/known_hosts:1
  debug1: ssh_rsa_verify: signature correct
  debug1: SSH2_MSG_NEWKEYS sent
  debug1: expecting SSH2_MSG_NEWKEYS
  debug1: SSH2_MSG_NEWKEYS received
  debug1: SSH2_MSG_SERVICE_REQUEST sent
  debug1: SSH2_MSG_SERVICE_ACCEPT received
  debug1: Authentications that can continue: publickey
  debug1: Next authentication method: publickey
  debug1: Offering public key: /home/sam/.ssh/id_rsa
  debug1: Server accepts key: pkalg ssh-rsa blen 277
  Agent admitted failure to sign using the key.
  debug1: Trying private key: /home/sam/.ssh/identity
  debug1: Trying private key: /home/sam/.ssh/id_dsa
  debug1: No more authentication methods to try.
  Permission denied (publickey).

  I tried generating a new key. this worked for a few logons, but then i
  get back to this error.

  I think it is to do with the local key agent. i found that
   SSH_AUTH_SOCK=0 ssh oberon
  works fine.

To manage notifications about this bug go to:
https://bugs.launchpad.net/seahorse/+bug/201786/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1821625] Re: systemd 237-3ubuntu10.14 ADT test failure on Bionic ppc64el (test-seccomp)

2019-08-12 Thread Dan Streetman
to close this out, the latest systemd build, version 237-3ubuntu10.25,
picked up the correct pkey_mprotect value from the updated kernel and
now does not fail the test.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1821625

Title:
  systemd 237-3ubuntu10.14 ADT test failure on Bionic ppc64el (test-
  seccomp)

Status in libseccomp package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Invalid
Status in libseccomp source package in Bionic:
  Invalid
Status in linux source package in Bionic:
  Fix Released
Status in systemd source package in Bionic:
  Invalid

Bug description:
  Starting with systemd 237-3ubuntu10.14, the testcase test-seccomp is
  failing on Bionic on ppc64el with the error messages:

  Operating on architecture: ppc
  Failed to add n/a() rule for architecture ppc, skipping: Bad address
  Operating on architecture: ppc64
  Failed to add n/a() rule for architecture ppc64, skipping: Bad address
  Operating on architecture: ppc64-le
  Failed to add n/a() rule for architecture ppc64-le, skipping: Numerical 
argument out of domain
  Assertion 'p == MAP_FAILED' failed at ../src/test/test-seccomp.c:413, 
function test_memory_deny_write_execute_mmap(). Aborting.
  memoryseccomp-mmap terminated by signal ABRT.
  Assertion 'wait_for_terminate_and_check("memoryseccomp-mmap", pid, WAIT_LOG) 
== EXIT_SUCCESS' failed at ../src/test/test-seccomp.c:427, function 
test_memory_deny_write_execute_mmap(). Aborting.
  Aborted (core dumped)
  FAIL: test-seccomp (code: 134)

  Full logs at:
  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/ppc64el/s/systemd/20190302_025135_d0e38@/log.gz

  The testcase passed with systemd version 237-3ubuntu10.13 running on the same 
4.15.0-45 kernel on ppc64el:
  
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/ppc64el/s/systemd/20190228_154406_6b12f@/log.gz

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libseccomp/+bug/1821625/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839756] Re: Nvidia driver options are not easy to understand

2019-08-12 Thread Matthew Paul Thomas
** Changed in: software-properties (Ubuntu)
 Assignee: (unassigned) => Olivier Tilloy (osomon)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1839756

Title:
  Nvidia driver options are not easy to understand

Status in software-properties package in Ubuntu:
  Triaged

Bug description:
  I have just upgraded to Ubuntu 18.04.3LTS, and the options I have for
  my nvidia driver are shown in the screenshot.

  I dont understand why I have the option for an older, untested version
  of the driver as well as the latest version. Also, the wording of
  these options is highly technical and not very meaningful to someone
  who just wants the latest driver.

  I would be better to have just 2 options, with labels more meaningful to the 
end user like:
  * Latest official Nvidia driver (proprietary)
  * Latest Nouveau driver (open source)

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: software-properties-gtk 0.96.24.32.9
  ProcVersionSignature: Ubuntu 4.15.0-55.60-generic 4.15.18
  Uname: Linux 4.15.0-55-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: XFCE
  Date: Sun Aug 11 13:32:43 2019
  InstallationDate: Installed on 2016-11-11 (1002 days ago)
  InstallationMedia: Xubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  PackageArchitecture: all
  SourcePackage: software-properties
  UpgradeStatus: Upgraded to bionic on 2018-08-24 (351 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1839756/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839123] Re: [19.10 FEAT] gzip compression improvements addl. patch required

2019-08-12 Thread Dimitri John Ledkov
** Changed in: ubuntu-z-systems
   Status: In Progress => Fix Committed

** Changed in: gzip (Ubuntu)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gzip in Ubuntu.
https://bugs.launchpad.net/bugs/1839123

Title:
  [19.10 FEAT] gzip compression improvements addl. patch required

Status in Ubuntu on IBM z Systems:
  Fix Committed
Status in gzip package in Ubuntu:
  Fix Committed

Bug description:
  This patch (unfortunately not yet upstream acepted) is needed on top
  of LP 1825350
  (https://bugs.launchpad.net/ubuntu/+source/gzip/+bug/1825350), and
  fixes a serious bug.

  It was already developed and published a while ago:
  https://lists.gnu.org/archive/html/bug-gzip/2019-07/msg0.html

  This patch fixes data corruption issues, and thus is very important.
  Unfortunately, so far it has been ignored (there is not much going on
  on gzip mailing list in general). I would like to ask you to pick it
  up for the distro.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1839123/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839826] Re: Newly added Google accounts don't work: The specified session has been invalidated for some reason.

2019-08-12 Thread Iain Lane
Yeah OK, upgrading glib-networking fixes this.

** Package changed: evolution-data-server (Ubuntu) => glib-networking
(Ubuntu)

** Changed in: glib-networking (Ubuntu)
   Status: New => In Progress

** Changed in: glib-networking (Ubuntu)
 Assignee: (unassigned) => Iain Lane (laney)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to glib-networking in Ubuntu.
https://bugs.launchpad.net/bugs/1839826

Title:
  Newly added Google accounts don't work: The specified session has been
  invalidated for some reason.

Status in glib-networking package in Ubuntu:
  In Progress

Bug description:
  This is my GOA/EDS version but it's likely to have been broken by
  something else I think:

  gnome-online-accounts:
    Installed: 3.32.0-1ubuntu1
    Candidate: 3.32.0-1ubuntu1
    Version table:
   *** 3.32.0-1ubuntu1 500
  500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
  100 /var/lib/dpkg/status

  evolution-data-server:
    Installed: 3.32.2-2
    Candidate: 3.32.2-2
    Version table:
   *** 3.32.2-2 500
  500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
  100 /var/lib/dpkg/status

  Existing accounts work fine, but if I add a new account using gnome-
  control-center or gnome-calendar, then it doesn't work. Calendars
  don't sync and Evolution can't retrieve mail/contacts, etc. In the
  journal there is:

  Aug 12 12:00:37 raleigh.home.orangesquash.org.uk gnome-calendar[8276]:
  source_credentials_required_cb: Failed to authenticate
  'i...@orangesquash.org.uk': Error reading data from TLS socket: The
  specified session has been invalidated for some reason.

  I think that's an error from glib-networking.

  I tried on eoan only, so far (a clean system and my real one). As
  first steps maybe we need to try disco, and maybe also downgrading
  glib-networking. Or upgrading it: there is a new release waiting to be
  packaged.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/glib-networking/+bug/1839826/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839123] Re: [19.10 FEAT] gzip compression improvements addl. patch required

2019-08-12 Thread Frank Heimes
** Changed in: ubuntu-z-systems
   Status: Triaged => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gzip in Ubuntu.
https://bugs.launchpad.net/bugs/1839123

Title:
  [19.10 FEAT] gzip compression improvements addl. patch required

Status in Ubuntu on IBM z Systems:
  In Progress
Status in gzip package in Ubuntu:
  In Progress

Bug description:
  This patch (unfortunately not yet upstream acepted) is needed on top
  of LP 1825350
  (https://bugs.launchpad.net/ubuntu/+source/gzip/+bug/1825350), and
  fixes a serious bug.

  It was already developed and published a while ago:
  https://lists.gnu.org/archive/html/bug-gzip/2019-07/msg0.html

  This patch fixes data corruption issues, and thus is very important.
  Unfortunately, so far it has been ignored (there is not much going on
  on gzip mailing list in general). I would like to ask you to pick it
  up for the distro.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1839123/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839826] [NEW] Newly added Google accounts don't work: The specified session has been invalidated for some reason.

2019-08-12 Thread Iain Lane
Public bug reported:

This is my GOA/EDS version but it's likely to have been broken by
something else I think:

gnome-online-accounts:
  Installed: 3.32.0-1ubuntu1
  Candidate: 3.32.0-1ubuntu1
  Version table:
 *** 3.32.0-1ubuntu1 500
500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
100 /var/lib/dpkg/status

evolution-data-server:
  Installed: 3.32.2-2
  Candidate: 3.32.2-2
  Version table:
 *** 3.32.2-2 500
500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
100 /var/lib/dpkg/status

Existing accounts work fine, but if I add a new account using gnome-
control-center or gnome-calendar, then it doesn't work. Calendars don't
sync and Evolution can't retrieve mail/contacts, etc. In the journal
there is:

Aug 12 12:00:37 raleigh.home.orangesquash.org.uk gnome-calendar[8276]:
source_credentials_required_cb: Failed to authenticate
'i...@orangesquash.org.uk': Error reading data from TLS socket: The
specified session has been invalidated for some reason.

I think that's an error from glib-networking.

I tried on eoan only, so far (a clean system and my real one). As first
steps maybe we need to try disco, and maybe also downgrading glib-
networking. Or upgrading it: there is a new release waiting to be
packaged.

** Affects: evolution-data-server (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: rls-ee-incoming

** Package changed: gnome-control-center (Ubuntu) => gnome-online-
accounts (Ubuntu)

** Package changed: gnome-online-accounts (Ubuntu) => evolution-data-
server (Ubuntu)

** Description changed:

- This is my GOA version but it's likely to have been broken by something
- else I think:
+ This is my GOA/EDS version but it's likely to have been broken by
+ something else I think:
  
  gnome-online-accounts:
-   Installed: 3.32.0-1ubuntu1
-   Candidate: 3.32.0-1ubuntu1
+   Installed: 3.32.0-1ubuntu1
+   Candidate: 3.32.0-1ubuntu1
+   Version table:
+  *** 3.32.0-1ubuntu1 500
+ 500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
+ 100 /var/lib/dpkg/status
+ 
+ evolution-data-server:
+   Installed: 3.32.2-2
+   Candidate: 3.32.2-2
Version table:
-  *** 3.32.0-1ubuntu1 500
+  *** 3.32.2-2 500
  500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
  100 /var/lib/dpkg/status
  
- Existing accounts work fine, but if I add a new account using gnome-
- control-center or gnome-calendar, then it doesn't work. Calendars don't
- sync and Evolution can't retrieve mail/contacts, etc. In the journal
- there is:
+ 
+ Existing accounts work fine, but if I add a new account using 
gnome-control-center or gnome-calendar, then it doesn't work. Calendars don't 
sync and Evolution can't retrieve mail/contacts, etc. In the journal there is:
  
  Aug 12 12:00:37 raleigh.home.orangesquash.org.uk gnome-calendar[8276]:
  source_credentials_required_cb: Failed to authenticate
  'i...@orangesquash.org.uk': Error reading data from TLS socket: The
  specified session has been invalidated for some reason.
  
  I think that's an error from glib-networking.
  
  I tried on eoan only, so far (a clean system and my real one). As first
  steps maybe we need to try disco, and maybe also downgrading glib-
  networking.

** Tags added: rls-ee-incoming

** Description changed:

  This is my GOA/EDS version but it's likely to have been broken by
  something else I think:
  
  gnome-online-accounts:
    Installed: 3.32.0-1ubuntu1
    Candidate: 3.32.0-1ubuntu1
    Version table:
   *** 3.32.0-1ubuntu1 500
  500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
  100 /var/lib/dpkg/status
  
  evolution-data-server:
-   Installed: 3.32.2-2
-   Candidate: 3.32.2-2
-   Version table:
-  *** 3.32.2-2 500
- 500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
- 100 /var/lib/dpkg/status
+   Installed: 3.32.2-2
+   Candidate: 3.32.2-2
+   Version table:
+  *** 3.32.2-2 500
+ 500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
+ 100 /var/lib/dpkg/status
  
- 
- Existing accounts work fine, but if I add a new account using 
gnome-control-center or gnome-calendar, then it doesn't work. Calendars don't 
sync and Evolution can't retrieve mail/contacts, etc. In the journal there is:
+ Existing accounts work fine, but if I add a new account using gnome-
+ control-center or gnome-calendar, then it doesn't work. Calendars don't
+ sync and Evolution can't retrieve mail/contacts, etc. In the journal
+ there is:
  
  Aug 12 12:00:37 raleigh.home.orangesquash.org.uk gnome-calendar[8276]:
  source_credentials_required_cb: Failed to authenticate
  'i...@orangesquash.org.uk': Error reading data from TLS socket: The
  specified session has been invalidated for some reason.
  
  I think that's an error from glib-networking.
  
  I tried on eoan only, so far (a clean system and my real one). As first
  steps maybe we need to try disco, and maybe also downgrading glib-
- networking.
+ networking. Or upgrading it: there is a new 

[Touch-packages] [Bug 1839123] Re: [19.10 FEAT] gzip compression improvements addl. patch required

2019-08-12 Thread Dimitri John Ledkov
** Information type changed from Private to Public

** Changed in: gzip (Ubuntu)
   Status: New => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gzip in Ubuntu.
https://bugs.launchpad.net/bugs/1839123

Title:
  [19.10 FEAT] gzip compression improvements addl. patch required

Status in Ubuntu on IBM z Systems:
  Triaged
Status in gzip package in Ubuntu:
  In Progress

Bug description:
  This patch (unfortunately not yet upstream acepted) is needed on top
  of LP 1825350
  (https://bugs.launchpad.net/ubuntu/+source/gzip/+bug/1825350), and
  fixes a serious bug.

  It was already developed and published a while ago:
  https://lists.gnu.org/archive/html/bug-gzip/2019-07/msg0.html

  This patch fixes data corruption issues, and thus is very important.
  Unfortunately, so far it has been ignored (there is not much going on
  on gzip mailing list in general). I would like to ask you to pick it
  up for the distro.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-z-systems/+bug/1839123/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839826] [NEW] Newly added Google accounts don't work: The specified session has been invalidated for some reason.

2019-08-12 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

This is my GOA version but it's likely to have been broken by something
else I think:

gnome-online-accounts:
  Installed: 3.32.0-1ubuntu1
  Candidate: 3.32.0-1ubuntu1
  Version table:
 *** 3.32.0-1ubuntu1 500
500 file:/srv/mirrors/ubuntu eoan/main amd64 Packages
100 /var/lib/dpkg/status

Existing accounts work fine, but if I add a new account using gnome-
control-center or gnome-calendar, then it doesn't work. Calendars don't
sync and Evolution can't retrieve mail/contacts, etc. In the journal
there is:

Aug 12 12:00:37 raleigh.home.orangesquash.org.uk gnome-calendar[8276]:
source_credentials_required_cb: Failed to authenticate
'i...@orangesquash.org.uk': Error reading data from TLS socket: The
specified session has been invalidated for some reason.

I think that's an error from glib-networking.

I tried on eoan only, so far (a clean system and my real one). As first
steps maybe we need to try disco, and maybe also downgrading glib-
networking.

** Affects: gnome-online-accounts (Ubuntu)
 Importance: Undecided
 Status: New

-- 
Newly added Google accounts don't work: The specified session has been 
invalidated for some reason.
https://bugs.launchpad.net/bugs/1839826
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to gnome-online-accounts in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1838370] Re: slapd segfault on filter parse error

2019-08-12 Thread Christian Ehrhardt 
** Bug watch added: Debian Bug tracker #934277
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=934277

** Also affects: openldap (Debian) via
   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=934277
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openldap in Ubuntu.
https://bugs.launchpad.net/bugs/1838370

Title:
  slapd segfault on filter parse error

Status in openldap:
  Fix Released
Status in openldap package in Ubuntu:
  Fix Released
Status in openldap source package in Xenial:
  Confirmed
Status in openldap source package in Bionic:
  Confirmed
Status in openldap source package in Disco:
  Confirmed
Status in openldap package in Debian:
  Unknown

Bug description:
  Impact
  --

  Users willing to use the slapd rwm overlay will face a slapd
  segmentation fault when trying to rewrite some rules. Backporting this
  fix will allow users using stable releases to take advantage of this
  feature without crashing slapd. This issue was fixed by upstream not
  freeing the rwm overlay filter memory without prior checking.

  Test Case
  -

  In this test case, the rwm overlay will be used and a rule will be
  created to deny any search request for uid=root, then the 'ldapsearch'
  will be invoked to trigger the failure. It is important to mention
  that the 'ldapsearch' command should fail regardless the presence of
  the bug in the package, the target here is the slapd crash. To
  reproduce this bug one can follow the procedure below in Ubuntu
  xenial, bionic or disco:

  $ sudo apt-get update
  $ sudo apt-get install slapd ldap-utils -y

  Reconfigure the slapd package. When asked about a domain, use "example.com".
  Choose a password you want (or just leave it blank), and accept defaults for
  everything else:

  $ sudo dpkg-reconfigure slapd

  Create a file called 'add-rwm.ldif' with the following content:

  $ cat add-rwm.ldif
  dn: cn=module{0},cn=config
  changetype: modify
  add: olcModuleLoad
  olcModuleLoad: rwm

  dn: olcOverlay=rwm,olcDatabase={1}mdb,cn=config
  changetype: add
  objectClass: olcOverlayConfig
  objectClass: olcRwmConfig
  olcOverlay: rwm
  olcRwmRewrite: {0} rwm-rewriteEngine "on"
  olcRwmRewrite: {1} rwm-rewriteContext "searchFilter"
  olcRwmRewrite: {2} rwm-rewriteRule "(.*)(uid=root)(.*)" "$1$2$3" "#"

  With this file in place, run:

  $ sudo ldapadd -Q -Y EXTERNAL -H ldapi:/// -f add-rwm.ldif

  Now, to trigger the crash:

  $ ldapsearch -x -h localhost -b dc=example,dc=com -LLL uid=root
  Server is unwilling to perform (53)
  Additional information: searchFilter/searchFilterAttrDN massage error

  slapd process will die, and /var/crash will have a crash file for slapd. You
  can run the following command to confirm the error:

  $ cat /var/log/syslog | grep filter_free
  Aug  9 19:51:05 popular-gorilla slapd[1479]: filter_free: unknown filter 
type=28530

  Regression Potential
  

  Since the fix is a patch provided by upstream (reviewed by maintainers
  and us) simple mistakes like typos are not expected. The patch impacts
  only the rwm module which is not loaded by default. So any regression
  would affect only the users that make use of this overlay. If an user
  is not using rwm overlay and is facing any issue, it should be related
  to other problems related to LDAP directory services.

  [Original message]

  Hello!
  We have faced slapd crash, seems an attacker was trying to brute force one
  of our services and uid parsing failures caused slapd crash:

  Jul 26 18:59:47 slapd[1252]: conn=1466 op=13 SRCH
  base="ou=test,dc=test,dc=com" scope=2 deref=0
  
filter="(&(uid=aistar123<>!n)(objectClass=posixAccount)(uid=*)(&(uidNumber=*)(!(uidNumber=0"
  Jul 26 18:59:47 slapd[1252]: conn=1466 op=13 SRCH attr=objectClass uid
  userPassword uidNumber gidNumber gecos homeDirectory loginShell
  krbPrincipalName cn memberOf modifyTimestamp modifyTimestamp
  shadowLastChange shadowMin shadow
  Max shadowWarning shadowInactive shadowExpire shadowFlag krbLastPwdChange
  krbPasswordExpiration pwdAttribute authorizedService accountExpires
  userAccountControl nsAccountLock host loginDisabled loginExpirationTime
  loginAllowedTimeMap sshPublic
  Key
  Jul 26 18:59:47 slapd[1252]: conn=1466 op=13 SEARCH RESULT tag=101 err=0
  nentries=0 text=massaged filter parse error
  Jul 26 18:59:47 kernel: [ 9441.554161] slapd[2367]: segfault at 18 ip
  7fc8d18ec512 sp 7fc8889e2810 error 4 in libc-2.23.so
  [7fc8d1868000+1c]

  Another faulty filter example:
  
filter="(&(uid=sql<>?)(objectClass=posixAccount)(&(uidNumber=*)(!(uidNumber=0"
  
filter="(&(uid=fugeone<>?123)(objectClass=posixAccount)(uid=*)(&(uidNumber=*)(!(uidNumber=0"

  $ lsb_release -rd
  Description: Ubuntu 16.04.5 LTS
  Release: 16.04

  $ slapd -VVV
  @(#) $OpenLDAP: slapd  (Ubuntu) (May 22 2018 13:54:12) $
  buildd@lcy01-amd64-019
  

[Touch-packages] [Bug 1813581] Re: gpgme1.0 ftbfs in 18.04 LTS

2019-08-12 Thread Julian Andres Klode
Uploaded. Wondering if it makes sense to actually release that fix and
have users install a pointless rebuild, or just keep it stuck in
proposed for whoever needs to do an SRU later?

** Description changed:

+ [Impact]
  according to
  
http://people.canonical.com/~doko/ftbfs-report/test-rebuild-20181222-bionic.html
  
  gpgme1.0 ftbfs.
  
  * Start testing of TofuInfoTest *
  Config: Using QtTest library 5.9.5, Qt 5.9.5 (x86_64-little_endian-lp64 
shared (dynamic) release build; by GCC 7.3.0)
  PASS   : TofuInfoTest::initTestCase()
  PASS   : TofuInfoTest::testTofuNull()
  PASS   : TofuInfoTest::testTofuInfo()
  PASS   : TofuInfoTest::testTofuSignCount()
  PASS   : TofuInfoTest::testTofuKeyList()
  PASS   : TofuInfoTest::testTofuPolicy()
  FAIL!  : TofuInfoTest::testTofuConflict() 'sig.validity() == 
Signature::Marginal' returned FALSE. ()
-Loc: [t-tofuinfo.cpp(458)]
+    Loc: [t-tofuinfo.cpp(458)]
  PASS   : TofuInfoTest::cleanupTestCase()
  Totals: 7 passed, 1 failed, 0 skipped, 0 blacklisted, 2386ms
  * Finished testing of TofuInfoTest *
  FAIL: t-tofuinfo
+ 
+ [Test case]
+ build it
+ 
+ [Regression potential]
+ This only changes the test suite run during build, and that one currently 
fails, so it can't cause any regression.

** Changed in: gpgme1.0 (Ubuntu Bionic)
   Status: Confirmed => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gpgme1.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1813581

Title:
  gpgme1.0 ftbfs in 18.04 LTS

Status in gpgme1.0 package in Ubuntu:
  Won't Fix
Status in gpgme1.0 source package in Bionic:
  In Progress

Bug description:
  [Impact]
  according to
  
http://people.canonical.com/~doko/ftbfs-report/test-rebuild-20181222-bionic.html

  gpgme1.0 ftbfs.

  * Start testing of TofuInfoTest *
  Config: Using QtTest library 5.9.5, Qt 5.9.5 (x86_64-little_endian-lp64 
shared (dynamic) release build; by GCC 7.3.0)
  PASS   : TofuInfoTest::initTestCase()
  PASS   : TofuInfoTest::testTofuNull()
  PASS   : TofuInfoTest::testTofuInfo()
  PASS   : TofuInfoTest::testTofuSignCount()
  PASS   : TofuInfoTest::testTofuKeyList()
  PASS   : TofuInfoTest::testTofuPolicy()
  FAIL!  : TofuInfoTest::testTofuConflict() 'sig.validity() == 
Signature::Marginal' returned FALSE. ()
     Loc: [t-tofuinfo.cpp(458)]
  PASS   : TofuInfoTest::cleanupTestCase()
  Totals: 7 passed, 1 failed, 0 skipped, 0 blacklisted, 2386ms
  * Finished testing of TofuInfoTest *
  FAIL: t-tofuinfo

  [Test case]
  build it

  [Regression potential]
  This only changes the test suite run during build, and that one currently 
fails, so it can't cause any regression.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gpgme1.0/+bug/1813581/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp