[Touch-packages] [Bug 1751144] Re: xorg

2019-08-16 Thread Launchpad Bug Tracker
[Expired for xorg (Ubuntu) because there has been no activity for 60
days.]

** Changed in: xorg (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1751144

Title:
  xorg

Status in xorg package in Ubuntu:
  Expired

Bug description:
  xorg

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.13.0-35.39~16.04.1-generic 4.13.13
  Uname: Linux 4.13.0-35-generic x86_64
  .tmp.unity_support_test.1:
   
  ApportVersion: 2.20.1-0ubuntu2.15
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  Date: Thu Feb 22 15:33:01 2018
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 
230 OEM] [1002:6779] (prog-if 00 [VGA controller])
 Subsystem: Dell Radeon HD 6450 [1028:2120]
   Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 
230 OEM] [1002:6779] (prog-if 00 [VGA controller])
 Subsystem: Dell Radeon HD 6450 [1028:2120]
  MachineType: Dell Inc. OptiPlex 990
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-35-generic 
root=/dev/mapper/ubuntu--gnome--vg-root ro recovery nomodeset
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/28/2011
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A05
  dmi.board.name: 06D7TR
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 6
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA05:bd05/28/2011:svnDellInc.:pnOptiPlex990:pvr01:rvnDellInc.:rn06D7TR:rvrA00:cvnDellInc.:ct6:cvr:
  dmi.product.name: OptiPlex 990
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.3+16.04.20171116-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.89+git20180214.e75e0ea2-0ubuntu0ricotz~16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 
18.0.0~git20180214+18.0.1e173463-0ubuntu0ricotz~16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 
18.0.0~git20180214+18.0.1e173463-0ubuntu0ricotz~16.04.1
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1751144/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832689] Re: TPM certification tests now failing after update to 1.1.1 (test_output_formats)

2019-08-16 Thread Launchpad Bug Tracker
[Expired for openssl (Ubuntu) because there has been no activity for 60
days.]

** Changed in: openssl (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1832689

Title:
  TPM certification tests now failing after update to 1.1.1
  (test_output_formats)

Status in Provider for Plainbox - TPM2:
  Incomplete
Status in openssl package in Ubuntu:
  Expired

Bug description:
  The certification team is running automated tests for every supported
  ubuntu-core device for every new core18 snap update. The recent core18
  includes the openssl 1.1.1 update and seems to have caused regressions
  in the TPM test suite (for the dawson-i device). I was able to dig out
  the test suite itself, with the failing test code located here:

  https://git.launchpad.net/plainbox-provider-
  tpm2/tree/data/tpm2-tools-3.0.4/test/system/test_output_formats.sh

  Test failure log seems to be this:

  openssl rsa -pubin -inform "$fmt" -text -in "$this_key" &> /dev/null
  on line 95 failed: 1

  The certification team will follow up with more information. This is
  currently causing core18 promotions to be blocked (and there has been
  over a month without a new core18 stable snap). Setting to critical.

  I noticed a follow-up SRU for openssl with fix for LP: #1828215 and
  was wondering if it might be related?

To manage notifications about this bug go to:
https://bugs.launchpad.net/plainbox-provider-tpm2/+bug/1832689/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832967] Re: /etc/resolv.conf does not include the local domain name

2019-08-16 Thread Launchpad Bug Tracker
[Expired for resolvconf (Ubuntu) because there has been no activity for
60 days.]

** Changed in: resolvconf (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to resolvconf in Ubuntu.
https://bugs.launchpad.net/bugs/1832967

Title:
  /etc/resolv.conf does not include the local domain name

Status in resolvconf package in Ubuntu:
  Expired

Bug description:
  When I rebooted my system after an update, `/etc/resolv.conf` was
  symlinked to `/run/resolvconf/resolv.conf`.  That file did not have my
  local domain name in the search even though it is supplied by the dhcp
  server.  The systemd resolv.conf file (in
  `/run/systemd/resolve/resolv.conf`) had the correct search
  information.

  Please ensure that the search is correctly added.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: resolvconf 1.79ubuntu10.18.04.3
  ProcVersionSignature: Ubuntu 4.15.0-51.55-generic 4.15.18
  Uname: Linux 4.15.0-51-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.6
  Architecture: amd64
  Date: Sat Jun 15 22:18:05 2019
  PackageArchitecture: all
  ProcEnviron:
   TERM=xterm
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: resolvconf
  UpgradeStatus: Upgraded to bionic on 2018-08-21 (299 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/resolvconf/+bug/1832967/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840510] [NEW] Please enable PGO and LTO for arm64

2019-08-16 Thread Ali Saidi
Public bug reported:

The rules file conditionally enables PGO and LTO in the python3 build
and while it's enabled for many platforms it's not enabled for arm64.
This is worth about 30% performance. Please enable it.

A patch is available here with the original debian bug report:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=934812

** Affects: python3-defaults (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python3-defaults in
Ubuntu.
https://bugs.launchpad.net/bugs/1840510

Title:
  Please enable PGO and LTO for arm64

Status in python3-defaults package in Ubuntu:
  New

Bug description:
  The rules file conditionally enables PGO and LTO in the python3 build
  and while it's enabled for many platforms it's not enabled for arm64.
  This is worth about 30% performance. Please enable it.

  A patch is available here with the original debian bug report:
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=934812

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python3-defaults/+bug/1840510/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837580] Re: memlock is not set

2019-08-16 Thread Kain
Actually, its just systemd 240. Looks fixed in 241 and newer.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1837580

Title:
  memlock is not set

Status in systemd package in Ubuntu:
  New
Status in systemd package in Debian:
  Unknown

Bug description:
  I discovered this in relation to jack, which installs
  /etc/security/limits.d/audio.conf, containing:

  @audio   -  rtprio 95
  @audio   -  memlockunlimited

  For a user in the audio group:

  $ulimit -l -r
  max locked memory   (kbytes, -l) 65536
  real-time priority  (-r) 95

  So jack (run as user via qjackctl) reports:

  ERROR: Cannot lock down 82280346 byte memory area (Cannot allocate
  memory)

  but does not report that it cannot set real-time priority, which it
  does if run by a user not in the audio group.

  I also tried putting the line in /etc/security/limits.conf, and trying
  a number rather than "unlimited", but it didn't help.

  Also reported independently here:
  https://askubuntu.com/questions/1142943/ulimit-unlimited-cannot-set

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: libpam-modules:amd64 1.3.1-5ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-20.21-lowlatency 5.0.8
  Uname: Linux 5.0.0-20-lowlatency x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Jul 23 15:07:52 2019
  InstallationDate: Installed on 2016-10-25 (1000 days ago)
  InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
  SourcePackage: pam
  UpgradeStatus: Upgraded to disco on 2019-07-19 (3 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1837580/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840435] Re: Systemd >=240 sets a clamp of 64MB for RLIMIT_MEMLOCK, too low for some applications.

2019-08-16 Thread Kain
Upon further inspection, this is actually fixed in systemd 241.   To
reproduce, try setting a LimitMEMLOCK higher than 64mb for the system
unit user@.service, OR for any unit executed by a systemd --user
process. You will see that the RLIMIT_MEMLOCK is actually clamped to
64MB.  This can be observed by using prlimit -p <>.

You can reproduce by trying to give a user session (via user@.service OR
/etc/systemd/user.conf) a LimitMEMLOCK of greater than 64MB and then
inside a systemd unit or inside a gnome-terminal (since gnome terminals
in at least disco and newer are run under a systemd user-service) try to
execute `jackd -d hw:0 -r 48000 -p 256 -n 3 -S`. You may need to
suspend/stop pulseadio.

On my system at least (USB audio only), jackd wants to memlock 82280346
bytes (82MBish) of RAM for audio buffers and the like.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840435

Title:
  Systemd >=240 sets a clamp of 64MB for RLIMIT_MEMLOCK, too low for
  some applications.

Status in systemd:
  Unknown
Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Systemd >= 240 sets a clamp for RLIMIT_MEMLOCK, which is too low for
  some realistic applications.  This clamp should probably be increased.
  This breaks a number of current jackd setups, for example.

  See upstream bug: https://github.com/systemd/systemd/issues/13331.

  This occurs on at Ubuntu Disco and newer, Disco being the first
  release to ship with systemd >= 240.

To manage notifications about this bug go to:
https://bugs.launchpad.net/systemd/+bug/1840435/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1799977] Re: [MIR] gssdp

2019-08-16 Thread Chris Coulson
** Changed in: gssdp (Ubuntu)
 Assignee: Ubuntu Security Team (ubuntu-security) => (unassigned)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gssdp in Ubuntu.
https://bugs.launchpad.net/bugs/1799977

Title:
  [MIR] gssdp

Status in gssdp package in Ubuntu:
  New

Bug description:
  * Availability

  Builds on all supported architectures in Ubuntu and on sync from
  Debian, the package was in main in the past and needs to be re-
  promoted

  * Rationale

  We would like to enable dlna sharing of media files, which is a GNOME
  upstream feature and relying on gssdp

  * Security

  No CVE/known security issue

  * Quality assurance

  - the desktop-packages team is subscribed to the package
  - the bug lists in upstream, the Debian PTS and launchpad are empty
  - upstream has a testsuit which is being used during build

  * Dependendies

  The package dependencies are in main

  * Standards compliance

  the package is using standard packaging (dh11), the standards-version
  is 4.1.1, the package is in sync from Debian

  * Maintainance

  Upstream is active and the desktop team is going to look after the
  package in ubuntu

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gssdp/+bug/1799977/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1799279] Re: kernel update hangs inside update-secureboot-policy

2019-08-16 Thread Julian Andres Klode
*** This bug is a duplicate of bug 1827697 ***
https://bugs.launchpad.net/bugs/1827697

@Radoslaw This bug is a duplicate of bug #1827697, and has been fixed in
all releases.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1799279

Title:
  kernel update hangs inside update-secureboot-policy

Status in apt package in Ubuntu:
  Invalid

Bug description:
  I just ran `apt-get --auto-remove dist-upgrade` on 18.04.

  It is hung on update-secureboot-policy waiting for confirmation from
  whiptail.

  apt-get --auto-remove dist-upgrade
  |
  -/usr/bin/dpkg --status-fd 80 --configure --pending
   |
   -/bin/sh /var/lib/dpkg/info/linux-headers-4.15.0-38-generic.postinst 
configure
    |
    -run-parts --report --exit-on-error --arg=4.15.0-38-generic 
/etc/kernel/header_postinst.d
     |
     -/bin/sh /usr/lib/dkms/dkms_autoinstaller start 4.15.0-38-generic
  |
  -/bin/bash /usr/sbin/dkms autoinstall --kernelver 4.15.0-38-generic
   |
   -/bin/bash /usr/sbin/dkms autoinstall --kernelver 4.15.0-38-generic
    |
    -/usr/bin/perl -w /usr/share/debconf/frontend 
/usr/sbin/update-secureboot-policy --enroll-key
     |
     -/bin/sh /usr/sbin/update-secureboot-policy --enroll-key
     -whiptail --backtitle Package configuration --title Configuring Secure 
Boot --output-fd 12 --nocancel --msgbox Your system has UEFI Secure Boot 
enabled.  UEFI Secure Boot requires additional configuration to work with  
third-party drivers.  The system will assist you in configuring UEFI Secure 
Boot. To permit  the use of third-party drivers, a new Machine-Owner Key (MOK) 
has been  generated. This key now needs to be enrolled in your system's 
firmware.  To ensure that this change is being made by you as an authorized 
user,  and not by an attacker, you must choose a password now and then confirm  
the change after reboot using the same password, in both the "Enroll  MOK" and 
"Change Secure Boot state" menus that will be presented to you  when this 
system reboots.  If you proceed but do not confirm the password upon reboot, 
Ubuntu will  still be able to boot on your system but any hardware that 
requires  third-party drivers to work correctly may not be usable. --scrolltext 
20 77

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: apt 1.6.3ubuntu0.1
  ProcVersionSignature: Ubuntu 4.15.0-36.39-generic 4.15.18
  Uname: Linux 4.15.0-36-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.4
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Oct 22 15:15:56 2018
  InstallationDate: Installed on 2018-09-27 (25 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  SourcePackage: apt
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1799279/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1375405] Re: Impossible download speed

2019-08-16 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: apt (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1375405

Title:
  Impossible download speed

Status in apt package in Ubuntu:
  Confirmed

Bug description:
  Here's my problem:
  Sometimes the download speed is something impossible like 3000 PB/s (3 
thousand petabytes a second). And it kind of annoys me because I don't how long 
the download's actually going to take.
  I'm in Ubuntu 14.04.1 LTS
  I'm using apt version 1.0.1ubuntu2.4.1
  I'm sorry if the details aren't detailed enough. Just let me know

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1375405/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1375405] Re: Impossible download speed

2019-08-16 Thread Ian Johnson
I've seen this inside an Ubuntu 18.04 lxd container with a poor internet
connection as well. apt is version 1.6.11.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1375405

Title:
  Impossible download speed

Status in apt package in Ubuntu:
  Confirmed

Bug description:
  Here's my problem:
  Sometimes the download speed is something impossible like 3000 PB/s (3 
thousand petabytes a second). And it kind of annoys me because I don't how long 
the download's actually going to take.
  I'm in Ubuntu 14.04.1 LTS
  I'm using apt version 1.0.1ubuntu2.4.1
  I'm sorry if the details aren't detailed enough. Just let me know

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1375405/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1799279] Re: kernel update hangs inside update-secureboot-policy

2019-08-16 Thread Radoslaw Biernacki
*** This bug is a duplicate of bug 1827697 ***
https://bugs.launchpad.net/bugs/1827697

This affects me as well.
Cannot install display link drivers because of that issue.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1799279

Title:
  kernel update hangs inside update-secureboot-policy

Status in apt package in Ubuntu:
  Invalid

Bug description:
  I just ran `apt-get --auto-remove dist-upgrade` on 18.04.

  It is hung on update-secureboot-policy waiting for confirmation from
  whiptail.

  apt-get --auto-remove dist-upgrade
  |
  -/usr/bin/dpkg --status-fd 80 --configure --pending
   |
   -/bin/sh /var/lib/dpkg/info/linux-headers-4.15.0-38-generic.postinst 
configure
    |
    -run-parts --report --exit-on-error --arg=4.15.0-38-generic 
/etc/kernel/header_postinst.d
     |
     -/bin/sh /usr/lib/dkms/dkms_autoinstaller start 4.15.0-38-generic
  |
  -/bin/bash /usr/sbin/dkms autoinstall --kernelver 4.15.0-38-generic
   |
   -/bin/bash /usr/sbin/dkms autoinstall --kernelver 4.15.0-38-generic
    |
    -/usr/bin/perl -w /usr/share/debconf/frontend 
/usr/sbin/update-secureboot-policy --enroll-key
     |
     -/bin/sh /usr/sbin/update-secureboot-policy --enroll-key
     -whiptail --backtitle Package configuration --title Configuring Secure 
Boot --output-fd 12 --nocancel --msgbox Your system has UEFI Secure Boot 
enabled.  UEFI Secure Boot requires additional configuration to work with  
third-party drivers.  The system will assist you in configuring UEFI Secure 
Boot. To permit  the use of third-party drivers, a new Machine-Owner Key (MOK) 
has been  generated. This key now needs to be enrolled in your system's 
firmware.  To ensure that this change is being made by you as an authorized 
user,  and not by an attacker, you must choose a password now and then confirm  
the change after reboot using the same password, in both the "Enroll  MOK" and 
"Change Secure Boot state" menus that will be presented to you  when this 
system reboots.  If you proceed but do not confirm the password upon reboot, 
Ubuntu will  still be able to boot on your system but any hardware that 
requires  third-party drivers to work correctly may not be usable. --scrolltext 
20 77

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: apt 1.6.3ubuntu0.1
  ProcVersionSignature: Ubuntu 4.15.0-36.39-generic 4.15.18
  Uname: Linux 4.15.0-36-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.4
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Oct 22 15:15:56 2018
  InstallationDate: Installed on 2018-09-27 (25 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  SourcePackage: apt
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1799279/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1799977] Re: [MIR] gssdp

2019-08-16 Thread Chris Coulson
I reviewed gssdp 1.2.0-1 as checked in to eoan. This isn't a full
security audit, but rather a quick gauge of maintainability.

- gsspd is a gobject based library for using SSDP (Simple Service Discovery 
Protocol), and is required by rygel.
- gssdp is part of the GNOME project.
- It doesn't see a lot of git activity, but it's quite a small project so 
that's not really unexpected.
- No CVEs in our database.
- Build dependencies in main except for gnome-pkg-tools, meson and valac - none 
of which create binary dependencies.

- Doesn't spawn any subprocesses.
- Looks like it's careful with memory management.
- No logging other than a few g_debugs (which are off by default).
- Doesn't use the environment
- No privileged code.
- Does some networking:
  - Consumers of the gssdp API create a GSSDPClient for each network interface.
  - GSSDPClient sets up 3 sockets - IIUC, the first one receives SSDP (NOTIFY 
and M-SEARCH) multicast packets. The second one is for sending SSDP NOTIFY 
multicast packets and sending responses to SSDP M-SEARCH multicast queries. The 
third one is for sending SSDP M-SEARCH multicast queries and receiving 
responses to those.
  - The first socket is bound to the SSDP multicast address and port.
  - The second socket is bound to the interface address and SSDP port.
  - The third socket is bound to the interface address and a random port.
  - Unless I've misunderstood something, the way that the sockets are 
configured seems a bit weird and I think there might be a bug. The 
IP_MULTICAST_IF sockopt is set (via gssdp_socket_mcast_interface_set) and 
IP_ADD_MEMBERSHIP is set (via g_socket_join_multicast_group) on the same socket 
- the one that receives multicast packets. Shouldn't the IP_MULTICAST_IF 
sockopt be set on the other 2 sockets (the ones sending multicast packets) 
instead?
- It's using AF_NETLINK for looking up MAC addresses, which it uses for keying 
a hashtable of cached user agent strings from other devices.
- The max-age in alive announcements is set to 1800s. Re-announcements are sent 
3 times during this period.
- It responds to unicast M-SEARCH queries, which is called out in 
https://blog.cloudflare.com/ssdp-100gbps/. Devices that respond to unicast 
M-SEARCH queries and are directly connected to the internet can be used in DDoS 
attacks in scenarios where an attacker is able to generate packets with a 
spoofed source IP. It does employ some rate limiting though - it delays the 
response by a random time of between 0 and 3 seconds. This was tested with 
netcat.
- No crypto.
- No sql.
- No privileged commands.
- Doesn't use any environment variables.
- No webkit.
- Lintian clean, other than a warning about there being no manpage for 
/usr/bin/gssdp-device-sniffer
- A single binary - /usr/bin/gssdp-device-sniffer in gssdp-tools, which 
provides a UI for monitoring SSDP announcements.
- Build logs look clean other than some doc warnings.
- No configuration files.
- No systemd services.
- No dbus services.
- No setuid binaries.
- No fs capabilities.
- No sudo fragments.
- No udev rules.
- No cron jobs.

Security team ACK for promoting gssdp to main.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gssdp in Ubuntu.
https://bugs.launchpad.net/bugs/1799977

Title:
  [MIR] gssdp

Status in gssdp package in Ubuntu:
  New

Bug description:
  * Availability

  Builds on all supported architectures in Ubuntu and on sync from
  Debian, the package was in main in the past and needs to be re-
  promoted

  * Rationale

  We would like to enable dlna sharing of media files, which is a GNOME
  upstream feature and relying on gssdp

  * Security

  No CVE/known security issue

  * Quality assurance

  - the desktop-packages team is subscribed to the package
  - the bug lists in upstream, the Debian PTS and launchpad are empty
  - upstream has a testsuit which is being used during build

  * Dependendies

  The package dependencies are in main

  * Standards compliance

  the package is using standard packaging (dh11), the standards-version
  is 4.1.1, the package is in sync from Debian

  * Maintainance

  Upstream is active and the desktop team is going to look after the
  package in ubuntu

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gssdp/+bug/1799977/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1385245] Re: Beats Studio wireless bluetooth headphones wont pair w/ ubuntu 14.04

2019-08-16 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: blueman (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1385245

Title:
  Beats Studio wireless bluetooth headphones wont pair w/ ubuntu 14.04

Status in blueman package in Ubuntu:
  Confirmed
Status in bluez package in Ubuntu:
  Confirmed

Bug description:
  I have Beats Studio wireless bluetooth headphones and when adding
  device (pair bluetooth device) it wont pair w/ ubuntu 14.04 system.

  Closest thing I've found is this:
  https://code.google.com/p/chromium/issues/detail?id=379126

  It looks like it's working on ChromeOS so I'm hoping it's possible it
  will work w/ ubuntu.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/blueman/+bug/1385245/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1385245] Re: Beats Studio wireless bluetooth headphones wont pair w/ ubuntu 14.04

2019-08-16 Thread Alex Madurowicz
** Also affects: blueman (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1385245

Title:
  Beats Studio wireless bluetooth headphones wont pair w/ ubuntu 14.04

Status in blueman package in Ubuntu:
  Confirmed
Status in bluez package in Ubuntu:
  Confirmed

Bug description:
  I have Beats Studio wireless bluetooth headphones and when adding
  device (pair bluetooth device) it wont pair w/ ubuntu 14.04 system.

  Closest thing I've found is this:
  https://code.google.com/p/chromium/issues/detail?id=379126

  It looks like it's working on ChromeOS so I'm hoping it's possible it
  will work w/ ubuntu.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/blueman/+bug/1385245/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840396] Re: do not display two screen

2019-08-16 Thread Leonidas S. Barbosa
** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1840396

Title:
  do not display two screen

Status in xorg package in Ubuntu:
  New

Bug description:
  maybe error drivers graphics for del

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
  Uname: Linux 5.0.0-25-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 08:50:25 2019
  DistUpgraded: 2019-06-26 14:49:28,001 ERROR Cache can not be locked (Can not 
lock '/var/lib/apt/lists/lock' )
  DistroCodename: disco
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation HD Graphics 620 [8086:5916] (rev 02) (prog-if 00 [VGA 
controller])
 Subsystem: Dell HD Graphics 620 [1028:078b]
 Subsystem: Dell Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 
M520] [1028:078b]
  InstallationDate: Installed on 2019-06-25 (51 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: Dell Inc. Inspiron 15-3567
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-25-generic 
root=UUID=981f9e6c-b414-4dbc-8a43-1e260574e929 ro quiet splash vt.handoff=1
  SourcePackage: xorg
  UpgradeStatus: Upgraded to disco on 2019-06-26 (50 days ago)
  dmi.bios.date: 08/25/2017
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 2.0.3
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr2.0.3:bd08/25/2017:svnDellInc.:pnInspiron15-3567:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
  dmi.product.family: Inspiron
  dmi.product.name: Inspiron 15-3567
  dmi.product.sku: 078B
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.97-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.8-0ubuntu0~19.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.0.8-0ubuntu0~19.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.4-1ubuntu3
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20180925-2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1840396/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840397] Re: do not display two screen

2019-08-16 Thread Leonidas S. Barbosa
** Information type changed from Private Security to Public

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1840397

Title:
  do not display two screen

Status in xorg package in Ubuntu:
  New

Bug description:
  maybe error drivers graphics for del

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
  Uname: Linux 5.0.0-25-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 08:50:25 2019
  DistUpgraded: 2019-06-26 14:49:28,001 ERROR Cache can not be locked (Can not 
lock '/var/lib/apt/lists/lock' )
  DistroCodename: disco
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation HD Graphics 620 [8086:5916] (rev 02) (prog-if 00 [VGA 
controller])
 Subsystem: Dell HD Graphics 620 [1028:078b]
 Subsystem: Dell Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 
M520] [1028:078b]
  InstallationDate: Installed on 2019-06-25 (51 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: Dell Inc. Inspiron 15-3567
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-25-generic 
root=UUID=981f9e6c-b414-4dbc-8a43-1e260574e929 ro quiet splash vt.handoff=1
  SourcePackage: xorg
  UpgradeStatus: Upgraded to disco on 2019-06-26 (50 days ago)
  dmi.bios.date: 08/25/2017
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 2.0.3
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr2.0.3:bd08/25/2017:svnDellInc.:pnInspiron15-3567:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
  dmi.product.family: Inspiron
  dmi.product.name: Inspiron 15-3567
  dmi.product.sku: 078B
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.97-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.8-0ubuntu0~19.04.1
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.0.8-0ubuntu0~19.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.4-1ubuntu3
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20180925-2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1840397/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1829399] Re: Lid switch triggered suspend takes much longer than UI triggered suspend

2019-08-16 Thread Terry Rudd
** Also affects: systemd (Ubuntu)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu)
   Status: Expired => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1829399

Title:
  Lid switch triggered suspend takes much longer than UI triggered
  suspend

Status in linux package in Ubuntu:
  Invalid
Status in systemd package in Ubuntu:
  New

Bug description:
  IBM T460
  5.0.0-13-generic #14-Ubuntu SMP Mon Apr 15 14:59:14 UTC 2019 x86_64 x86_64 
x86_64 GNU/Linux

  
  When triggering a suspend even from the lid switch of my Lenovo T460 it takes 
30 seconds to reach suspend state. Several others with different models of 
Lenovo laptops have also reproduced this issue. 

  It seems this is isolated to the lid switch as UI triggered suspend
  (alt+power icon) is far faster.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1829399/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1806012] Re: set-cpufreq: 'powersave' governor configuration sanity on ubuntu server

2019-08-16 Thread Dan Streetman
** Tags removed: sts sts-sponsor-ddstreet

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1806012

Title:
  set-cpufreq: 'powersave' governor configuration sanity on ubuntu
  server

Status in systemd package in Ubuntu:
  In Progress
Status in systemd source package in Xenial:
  In Progress
Status in systemd source package in Bionic:
  In Progress
Status in systemd source package in Cosmic:
  In Progress
Status in systemd source package in Disco:
  In Progress

Bug description:
  Whilst debugging 'slow instance performance' on a Ubuntu Bionic based
  cloud, I observed that the default cpu governor configuration was set
  to 'powersave'; toggling this to 'performance' (while in not anyway a
  particularly green thing todo) resulted in the instance slowness
  disappearing and the cloud performance being as expected (based on a
  prior version of the deploy on Ubuntu Xenial).

  AFAICT Xenial does the same thing albeit in a slight different way,
  but we definitely did not see the same performance laggy-ness under a
  Xenial based cloud.

  Raising against systemd (as this package sets the governor to
  'powersave') - I feel that the switch to 'performance' although
  appropriate then obscures what might be a performance/behavioural
  difference in the underlying kernel when a machine is under load.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: systemd 237-3ubuntu10.9
  ProcVersionSignature: Ubuntu 4.15.0-39.42-generic 4.15.18
  Uname: Linux 4.15.0-39-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
  Date: Fri Nov 30 10:05:46 2018
  Lsusb:
   Bus 002 Device 002: ID 8087:8002 Intel Corp. 
   Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 001 Device 003: ID 413c:a001 Dell Computer Corp. Hub
   Bus 001 Device 002: ID 8087:800a Intel Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. PowerEdge R630
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=C.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.15.0-39-generic 
root=UUID=a361a524-47eb-46c3-8a04-e5eaa65188c9 ro hugepages=103117 iommu=pt 
intel_iommu=on
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/08/2016
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 2.3.4
  dmi.board.name: 02C2CP
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A03
  dmi.chassis.type: 23
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr2.3.4:bd11/08/2016:svnDellInc.:pnPowerEdgeR630:pvr:rvnDellInc.:rn02C2CP:rvrA03:cvnDellInc.:ct23:cvr:
  dmi.product.name: PowerEdge R630
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1806012/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840359] Re: systemd-networkd-wait-online & two ethernet on board

2019-08-16 Thread Radek Secka
In syslog was just:
systemd-networkd-wait-online[4903]: Event loop failed: Connection timed out
apt-helper[4892]: E: Sub-process /lib/systemd/systemd-networkd-wait-online 
returned an error code (1)

In /etc/netplan/  just   01-netcfg.yaml (Attachment)
/etc/systemd/network is empty
In /run/systemd/network/  just 10-netplatn-enp3s0.network (Attachment)

** Attachment added: "01-netcfg.yaml and 10-netplan-enp3s0.network"
   
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1840359/+attachment/5282866/+files/network.7z

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840359

Title:
  systemd-networkd-wait-online & two ethernet on board

Status in systemd package in Ubuntu:
  New

Bug description:
  Since I've upgraded to 19.04 my boot was 3 minutes longer due to wait for 
network. I've tried many tricks, but today I have finally found the source = 
the bug.
  My PC has motherboard AsRock Z370M-ITX/ac which has 2 Ethernet ports. When I 
connect Ethernet cable just to the "first" device "enp3s0" boot is quick, when 
I connect Ethernet cable just to the "second" device "enp0s31f6" boot is about 
3 minutes longer.

  It simply waits for the "enp3s0" device.

  Since there is no mark on the board or on the rear panel which port is
  "first" and which is "second" it's clear that the failure is on Ubuntu
  19.04 side. Ubuntu 18.04 LTS has no such problem.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: systemd 240-6ubuntu5.3
  ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
  Uname: Linux 5.0.0-25-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Thu Aug 15 21:55:12 2019
  InstallationDate: Installed on 2017-12-22 (600 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Release amd64 
(20171017.1)
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-25-generic 
root=UUID=d383d414-f179-4df7-a8f3-890dacf8ca33 ro modprobe.blacklist=nouveau 
intel_iommu=on
  SourcePackage: systemd
  UpgradeStatus: Upgraded to disco on 2019-06-22 (54 days ago)
  dmi.bios.date: 03/21/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P2.10
  dmi.board.name: Z370M-ITX/ac
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP2.10:bd03/21/2018:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ370M-ITX/ac:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.family: To Be Filled By O.E.M.
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.sku: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1840359/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840474] Re: The "Add to Favorites" is not shown for some Qt(?) applications in dash/dock

2019-08-16 Thread Launchpad Bug Tracker
*** This bug is a duplicate of bug 1768609 ***
https://bugs.launchpad.net/bugs/1768609

Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: ubuntu-meta (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1840474

Title:
  The "Add to Favorites" is not shown for some Qt(?) applications in
  dash/dock

Status in gnome-shell package in Ubuntu:
  Confirmed
Status in ubuntu-meta package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Install Ubuntu 18.04 LTS
  2. Install Kate (or Gwenview, Dolphin)
  3. Launch Kate (or Gwenview, Dolphin) from 9-dots-menu
  4. Try to pin the application to the dash/dock with "Add to Favorites" option

  Expected results:
  * the "Add to Favorites" is shown in the menu for all applications

  Actual results:
  * the "Add to Favorites" is not shown in the menu for all applications

  Notes:

  1. first seen on AskUbuntu ( https://askubuntu.com/q/1166171/66509 ).
  2. pinning to dock works as expected in Unity and MATE (using Mutiny panel 
layout).

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-shell 3.28.4-0ubuntu18.04.1
  ProcVersionSignature: Ubuntu 4.15.0-58.64-generic 4.15.18
  Uname: Linux 4.15.0-58-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 17:20:39 2019
  DisplayManager: lightdm
  GsettingsChanges:
   b'org.gnome.shell' b'command-history' redacted by apport
   b'org.gnome.shell' b'favorite-apps' redacted by apport
   b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
  InstallationDate: Installed on 2018-04-26 (476 days ago)
  InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  SourcePackage: gnome-shell
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1840474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840474] Re: The "Add to Favorites" is not shown for some Qt(?) applications in dash/dock

2019-08-16 Thread Launchpad Bug Tracker
*** This bug is a duplicate of bug 1768609 ***
https://bugs.launchpad.net/bugs/1768609

Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: gnome-shell (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1840474

Title:
  The "Add to Favorites" is not shown for some Qt(?) applications in
  dash/dock

Status in gnome-shell package in Ubuntu:
  Confirmed
Status in ubuntu-meta package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Install Ubuntu 18.04 LTS
  2. Install Kate (or Gwenview, Dolphin)
  3. Launch Kate (or Gwenview, Dolphin) from 9-dots-menu
  4. Try to pin the application to the dash/dock with "Add to Favorites" option

  Expected results:
  * the "Add to Favorites" is shown in the menu for all applications

  Actual results:
  * the "Add to Favorites" is not shown in the menu for all applications

  Notes:

  1. first seen on AskUbuntu ( https://askubuntu.com/q/1166171/66509 ).
  2. pinning to dock works as expected in Unity and MATE (using Mutiny panel 
layout).

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-shell 3.28.4-0ubuntu18.04.1
  ProcVersionSignature: Ubuntu 4.15.0-58.64-generic 4.15.18
  Uname: Linux 4.15.0-58-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 17:20:39 2019
  DisplayManager: lightdm
  GsettingsChanges:
   b'org.gnome.shell' b'command-history' redacted by apport
   b'org.gnome.shell' b'favorite-apps' redacted by apport
   b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
  InstallationDate: Installed on 2018-04-26 (476 days ago)
  InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  SourcePackage: gnome-shell
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1840474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1768609] Re: can't add KDE apps to GNOME dock

2019-08-16 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: gnome-shell (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1768609

Title:
  can't add KDE apps to GNOME dock

Status in gnome-shell package in Ubuntu:
  Confirmed
Status in gnome-shell-extension-ubuntu-dock package in Ubuntu:
  Confirmed
Status in ubuntu-meta package in Ubuntu:
  Confirmed

Bug description:
  Hi,

  I clean installed Ubuntu 18.04 yesterday and noticed I couldn't add
  KDE apps to the GNOME dock. Basically, the "Add to Favorites" option
  is missing from the right-click menu of dock icons of currently-
  running KDE apps.

  If I search for a KDE app using the "Show Applications" button, and
  right-click on an app in the search results before running it, that
  menu does contain "Add to Favorites". However, if this is used, the
  added app behaves incorrectly, in that clicking on its icon in the
  dock always launches a new instance rather than bringing any existing
  instance to the front.

  Previously I used Ubuntu 14.04 (with Unity) and KDE apps could be
  added to the dock and managed as expected (i.e. clicking app icon when
  app is running brought it to the front).

  Some searching around suggests this might be related to missing
  StartWMClass fields in the .desktop files of the KDE apps. I added
  StartWMClass=kate to /usr/share/applications/org.kde.kate.desktop and
  that seemed to fix the problem. However this didn't work for Konsole,
  so there might be more to fixing this in general.

  I think this is probably either a KDE bug (they need to correct all
  their .desktop files?), a GNOME bug, or at the very least an Ubuntu-
  level regression in the Unity->GNOME transition that may justify
  taking action somewhere.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1768609/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1768609] Re: can't add KDE apps to GNOME dock

2019-08-16 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: ubuntu-meta (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1768609

Title:
  can't add KDE apps to GNOME dock

Status in gnome-shell package in Ubuntu:
  Confirmed
Status in gnome-shell-extension-ubuntu-dock package in Ubuntu:
  Confirmed
Status in ubuntu-meta package in Ubuntu:
  Confirmed

Bug description:
  Hi,

  I clean installed Ubuntu 18.04 yesterday and noticed I couldn't add
  KDE apps to the GNOME dock. Basically, the "Add to Favorites" option
  is missing from the right-click menu of dock icons of currently-
  running KDE apps.

  If I search for a KDE app using the "Show Applications" button, and
  right-click on an app in the search results before running it, that
  menu does contain "Add to Favorites". However, if this is used, the
  added app behaves incorrectly, in that clicking on its icon in the
  dock always launches a new instance rather than bringing any existing
  instance to the front.

  Previously I used Ubuntu 14.04 (with Unity) and KDE apps could be
  added to the dock and managed as expected (i.e. clicking app icon when
  app is running brought it to the front).

  Some searching around suggests this might be related to missing
  StartWMClass fields in the .desktop files of the KDE apps. I added
  StartWMClass=kate to /usr/share/applications/org.kde.kate.desktop and
  that seemed to fix the problem. However this didn't work for Konsole,
  so there might be more to fixing this in general.

  I think this is probably either a KDE bug (they need to correct all
  their .desktop files?), a GNOME bug, or at the very least an Ubuntu-
  level regression in the Unity->GNOME transition that may justify
  taking action somewhere.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1768609/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1768609] Re: can't add KDE apps to GNOME dock

2019-08-16 Thread Norbert
@seb128
>The issue looks similar to e.g 
>https://bugzilla.gnome.org/show_bug.cgi?id=738672 and those applications 
>probably need to be fixed

GNOMEs Hell should be fixed, not the applications.

In all other desktops with dock - Unity, MATE (with Mutiny panel layout)
- it works as expected.

** Also affects: gnome-shell (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: ubuntu-meta (Ubuntu)
   Importance: Undecided
   Status: New

** Tags added: disco eoan

** Bug watch added: bugzilla.gnome.org/ #738672
   https://bugzilla.gnome.org/show_bug.cgi?id=738672

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1768609

Title:
  can't add KDE apps to GNOME dock

Status in gnome-shell package in Ubuntu:
  Confirmed
Status in gnome-shell-extension-ubuntu-dock package in Ubuntu:
  Confirmed
Status in ubuntu-meta package in Ubuntu:
  Confirmed

Bug description:
  Hi,

  I clean installed Ubuntu 18.04 yesterday and noticed I couldn't add
  KDE apps to the GNOME dock. Basically, the "Add to Favorites" option
  is missing from the right-click menu of dock icons of currently-
  running KDE apps.

  If I search for a KDE app using the "Show Applications" button, and
  right-click on an app in the search results before running it, that
  menu does contain "Add to Favorites". However, if this is used, the
  added app behaves incorrectly, in that clicking on its icon in the
  dock always launches a new instance rather than bringing any existing
  instance to the front.

  Previously I used Ubuntu 14.04 (with Unity) and KDE apps could be
  added to the dock and managed as expected (i.e. clicking app icon when
  app is running brought it to the front).

  Some searching around suggests this might be related to missing
  StartWMClass fields in the .desktop files of the KDE apps. I added
  StartWMClass=kate to /usr/share/applications/org.kde.kate.desktop and
  that seemed to fix the problem. However this didn't work for Konsole,
  so there might be more to fixing this in general.

  I think this is probably either a KDE bug (they need to correct all
  their .desktop files?), a GNOME bug, or at the very least an Ubuntu-
  level regression in the Unity->GNOME transition that may justify
  taking action somewhere.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1768609/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840474] Re: The "Add to Favorites" is not shown for some Qt(?) applications in dash/dock

2019-08-16 Thread Norbert
*** This bug is a duplicate of bug 1768609 ***
https://bugs.launchpad.net/bugs/1768609

** Tags added: eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1840474

Title:
  The "Add to Favorites" is not shown for some Qt(?) applications in
  dash/dock

Status in gnome-shell package in Ubuntu:
  Confirmed
Status in ubuntu-meta package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Install Ubuntu 18.04 LTS
  2. Install Kate (or Gwenview, Dolphin)
  3. Launch Kate (or Gwenview, Dolphin) from 9-dots-menu
  4. Try to pin the application to the dash/dock with "Add to Favorites" option

  Expected results:
  * the "Add to Favorites" is shown in the menu for all applications

  Actual results:
  * the "Add to Favorites" is not shown in the menu for all applications

  Notes:

  1. first seen on AskUbuntu ( https://askubuntu.com/q/1166171/66509 ).
  2. pinning to dock works as expected in Unity and MATE (using Mutiny panel 
layout).

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-shell 3.28.4-0ubuntu18.04.1
  ProcVersionSignature: Ubuntu 4.15.0-58.64-generic 4.15.18
  Uname: Linux 4.15.0-58-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 17:20:39 2019
  DisplayManager: lightdm
  GsettingsChanges:
   b'org.gnome.shell' b'command-history' redacted by apport
   b'org.gnome.shell' b'favorite-apps' redacted by apport
   b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
  InstallationDate: Installed on 2018-04-26 (476 days ago)
  InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  SourcePackage: gnome-shell
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1840474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840474] Re: The "Add to Favorites" is not shown for some Qt(?) applications in dash/dock

2019-08-16 Thread Paul White
*** This bug is a duplicate of bug 1768609 ***
https://bugs.launchpad.net/bugs/1768609

** This bug has been marked a duplicate of bug 1768609
   can't add KDE apps to GNOME dock

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1840474

Title:
  The "Add to Favorites" is not shown for some Qt(?) applications in
  dash/dock

Status in gnome-shell package in Ubuntu:
  New
Status in ubuntu-meta package in Ubuntu:
  New

Bug description:
  Steps to reproduce:
  1. Install Ubuntu 18.04 LTS
  2. Install Kate (or Gwenview, Dolphin)
  3. Launch Kate (or Gwenview, Dolphin) from 9-dots-menu
  4. Try to pin the application to the dash/dock with "Add to Favorites" option

  Expected results:
  * the "Add to Favorites" is shown in the menu for all applications

  Actual results:
  * the "Add to Favorites" is not shown in the menu for all applications

  Notes:

  1. first seen on AskUbuntu ( https://askubuntu.com/q/1166171/66509 ).
  2. pinning to dock works as expected in Unity and MATE (using Mutiny panel 
layout).

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-shell 3.28.4-0ubuntu18.04.1
  ProcVersionSignature: Ubuntu 4.15.0-58.64-generic 4.15.18
  Uname: Linux 4.15.0-58-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 17:20:39 2019
  DisplayManager: lightdm
  GsettingsChanges:
   b'org.gnome.shell' b'command-history' redacted by apport
   b'org.gnome.shell' b'favorite-apps' redacted by apport
   b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
  InstallationDate: Installed on 2018-04-26 (476 days ago)
  InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  SourcePackage: gnome-shell
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1840474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840474] [NEW] The "Add to Favorites" is not shown for some Qt(?) applications in dash/dock

2019-08-16 Thread Norbert
Public bug reported:

Steps to reproduce:
1. Install Ubuntu 18.04 LTS
2. Install Kate (or Gwenview, Dolphin)
3. Launch Kate (or Gwenview, Dolphin) from 9-dots-menu
4. Try to pin the application to the dash/dock with "Add to Favorites" option

Expected results:
* the "Add to Favorites" is shown in the menu for all applications

Actual results:
* the "Add to Favorites" is not shown in the menu for all applications

Notes:

1. first seen on AskUbuntu ( https://askubuntu.com/q/1166171/66509 ).
2. pinning to dock works as expected in Unity and MATE (using Mutiny panel 
layout).

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-shell 3.28.4-0ubuntu18.04.1
ProcVersionSignature: Ubuntu 4.15.0-58.64-generic 4.15.18
Uname: Linux 4.15.0-58-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Aug 16 17:20:39 2019
DisplayManager: lightdm
GsettingsChanges:
 b'org.gnome.shell' b'command-history' redacted by apport
 b'org.gnome.shell' b'favorite-apps' redacted by apport
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2018-04-26 (476 days ago)
InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: gnome-shell (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: ubuntu-meta (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: apport-bug bionic disco

** Also affects: ubuntu-meta (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ubuntu-meta in Ubuntu.
https://bugs.launchpad.net/bugs/1840474

Title:
  The "Add to Favorites" is not shown for some Qt(?) applications in
  dash/dock

Status in gnome-shell package in Ubuntu:
  New
Status in ubuntu-meta package in Ubuntu:
  New

Bug description:
  Steps to reproduce:
  1. Install Ubuntu 18.04 LTS
  2. Install Kate (or Gwenview, Dolphin)
  3. Launch Kate (or Gwenview, Dolphin) from 9-dots-menu
  4. Try to pin the application to the dash/dock with "Add to Favorites" option

  Expected results:
  * the "Add to Favorites" is shown in the menu for all applications

  Actual results:
  * the "Add to Favorites" is not shown in the menu for all applications

  Notes:

  1. first seen on AskUbuntu ( https://askubuntu.com/q/1166171/66509 ).
  2. pinning to dock works as expected in Unity and MATE (using Mutiny panel 
layout).

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: gnome-shell 3.28.4-0ubuntu18.04.1
  ProcVersionSignature: Ubuntu 4.15.0-58.64-generic 4.15.18
  Uname: Linux 4.15.0-58-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 17:20:39 2019
  DisplayManager: lightdm
  GsettingsChanges:
   b'org.gnome.shell' b'command-history' redacted by apport
   b'org.gnome.shell' b'favorite-apps' redacted by apport
   b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
  InstallationDate: Installed on 2018-04-26 (476 days ago)
  InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  SourcePackage: gnome-shell
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1840474/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840359] Re: systemd-networkd-wait-online & two ethernet on board

2019-08-16 Thread Dan Streetman
can you attach your syslog?  As well as any files you find in:
/etc/netplan/
/etc/systemd/network/
/run/systemd/network/

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840359

Title:
  systemd-networkd-wait-online & two ethernet on board

Status in systemd package in Ubuntu:
  New

Bug description:
  Since I've upgraded to 19.04 my boot was 3 minutes longer due to wait for 
network. I've tried many tricks, but today I have finally found the source = 
the bug.
  My PC has motherboard AsRock Z370M-ITX/ac which has 2 Ethernet ports. When I 
connect Ethernet cable just to the "first" device "enp3s0" boot is quick, when 
I connect Ethernet cable just to the "second" device "enp0s31f6" boot is about 
3 minutes longer.

  It simply waits for the "enp3s0" device.

  Since there is no mark on the board or on the rear panel which port is
  "first" and which is "second" it's clear that the failure is on Ubuntu
  19.04 side. Ubuntu 18.04 LTS has no such problem.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: systemd 240-6ubuntu5.3
  ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
  Uname: Linux 5.0.0-25-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Thu Aug 15 21:55:12 2019
  InstallationDate: Installed on 2017-12-22 (600 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Release amd64 
(20171017.1)
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-25-generic 
root=UUID=d383d414-f179-4df7-a8f3-890dacf8ca33 ro modprobe.blacklist=nouveau 
intel_iommu=on
  SourcePackage: systemd
  UpgradeStatus: Upgraded to disco on 2019-06-22 (54 days ago)
  dmi.bios.date: 03/21/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P2.10
  dmi.board.name: Z370M-ITX/ac
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP2.10:bd03/21/2018:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ370M-ITX/ac:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.family: To Be Filled By O.E.M.
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.sku: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1840359/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1714178] Re: Triple 4K monitor display failed (modesetting driver limited to 8192x8192)

2019-08-16 Thread Timo Aaltonen
** Changed in: linux-oem-osp1 (Ubuntu Bionic)
   Status: New => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1714178

Title:
  Triple 4K monitor display failed (modesetting driver limited to
  8192x8192)

Status in DRI:
  Fix Released
Status in HWE Next:
  New
Status in X.Org X server:
  Unknown
Status in linux package in Ubuntu:
  Triaged
Status in linux-oem-osp1 package in Ubuntu:
  New
Status in mesa package in Ubuntu:
  Fix Released
Status in xorg-server package in Ubuntu:
  Invalid
Status in linux source package in Bionic:
  Confirmed
Status in linux-oem-osp1 source package in Bionic:
  Fix Committed
Status in mesa source package in Bionic:
  Fix Released
Status in xorg-server source package in Bionic:
  Invalid

Bug description:
  Title: Triple monitor display failed with Dell Dock (HiDPI)
  (modesetting)

  Summary: Triple monitor display failed with Dell Dock (HiDPI)
  (modesetting)

  Steps:
  1. a laptop with Built-in 4K LCD
  2. Cold boot system with Dell Dock connected
  3. Connect a 4K monitor to Dock
  4. Connect 2nd 4K monitor to Dock
  5. Go to [All Settings]=>[Displays] to have the following configuration.
  Resolution: 4kx2k@60Hz (one Built-in LCD + two external monitors)
  Mirror displays: disable

  Expected results: Triple monitor display should works without issues
  Actual results: Triple monitor display failed with Dell Dock

  Additional information:
  1. Linux distribution: Ubuntu 16.04+modesetting, 16.04.3, and 17.04
  2. Laptop: Dell Precision 5520
  3. Dell Business Thunderbolt Dock - TB16
  https://goo.gl/vFDjpi

  WORKAROUND (UBUNTU 18.04+):
  Log in to "Ubuntu on Wayland" instead of "Ubuntu".

  ---
  .tmp.unity_support_test.0:

  ApportVersion: 2.20.1-0ubuntu2.10
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  DistUpgraded: Fresh install
  DistributionChannelDescriptor:
   # This is a distribution channel descriptor
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-xenial-amd64-20160624-2
  DistroCodename: xenial
  DistroRelease: Ubuntu 16.04
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation Device [8086:591d] (rev 04) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:07bf]
     Subsystem: Dell Device [1028:07bf]
  InstallationDate: Installed on 2017-08-29 (2 days ago)
  InstallationMedia: Ubuntu 16.04 "Xenial" - Build amd64 LIVE Binary 
20160624-10:47
  MachineType: Dell Inc. Precision 5520
  Package: xorg-server (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.11.0-14-generic.efi.signed 
root=UUID=b79ae801-0652-4785-beaf-e8387d798948 ro acpi_rev_override quiet 
splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.11.0-14.20~16.04.1-generic 4.11.12
  Tags:  xenial ubuntu compiz-0.9
  Uname: Linux 4.11.0-14-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 05/08/2017
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.3.3
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvr1.3.3:bd05/08/2017:svnDellInc.:pnPrecision5520:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
  dmi.product.name: Precision 5520
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.76-1~ubuntu16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.7-0ubuntu0.16.04.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.7-0ubuntu0.16.04.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.3
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1.2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2

To manage notifications about this bug go to:
https://bugs.launchpad.net/dri/+bug/1714178/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1813581] Re: gpgme1.0 ftbfs in 18.04 LTS

2019-08-16 Thread Julian Andres Klode
Package built successfully, so marking it as verified.

** Tags removed: verification-needed verification-needed-bionic
** Tags added: verification-done verification-done-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gpgme1.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1813581

Title:
  gpgme1.0 ftbfs in 18.04 LTS

Status in gpgme1.0 package in Ubuntu:
  Won't Fix
Status in gpgme1.0 source package in Bionic:
  Fix Committed

Bug description:
  [Impact]
  according to
  
http://people.canonical.com/~doko/ftbfs-report/test-rebuild-20181222-bionic.html

  gpgme1.0 ftbfs.

  * Start testing of TofuInfoTest *
  Config: Using QtTest library 5.9.5, Qt 5.9.5 (x86_64-little_endian-lp64 
shared (dynamic) release build; by GCC 7.3.0)
  PASS   : TofuInfoTest::initTestCase()
  PASS   : TofuInfoTest::testTofuNull()
  PASS   : TofuInfoTest::testTofuInfo()
  PASS   : TofuInfoTest::testTofuSignCount()
  PASS   : TofuInfoTest::testTofuKeyList()
  PASS   : TofuInfoTest::testTofuPolicy()
  FAIL!  : TofuInfoTest::testTofuConflict() 'sig.validity() == 
Signature::Marginal' returned FALSE. ()
     Loc: [t-tofuinfo.cpp(458)]
  PASS   : TofuInfoTest::cleanupTestCase()
  Totals: 7 passed, 1 failed, 0 skipped, 0 blacklisted, 2386ms
  * Finished testing of TofuInfoTest *
  FAIL: t-tofuinfo

  [Test case]
  build it

  [Regression potential]
  This only changes the test suite run during build, and that one currently 
fails, so it can't cause any regression.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gpgme1.0/+bug/1813581/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840359] Re: systemd-networkd-wait-online & two ethernet on board

2019-08-16 Thread Radek Secka
No they don't have same MAC but the difference is just one bit.

I'm using network-manager and I didn't changed systemd-networkd configuration 
manually. 
May be it was changed during Upgrade LTS 18.04 -> 19.04

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840359

Title:
  systemd-networkd-wait-online & two ethernet on board

Status in systemd package in Ubuntu:
  New

Bug description:
  Since I've upgraded to 19.04 my boot was 3 minutes longer due to wait for 
network. I've tried many tricks, but today I have finally found the source = 
the bug.
  My PC has motherboard AsRock Z370M-ITX/ac which has 2 Ethernet ports. When I 
connect Ethernet cable just to the "first" device "enp3s0" boot is quick, when 
I connect Ethernet cable just to the "second" device "enp0s31f6" boot is about 
3 minutes longer.

  It simply waits for the "enp3s0" device.

  Since there is no mark on the board or on the rear panel which port is
  "first" and which is "second" it's clear that the failure is on Ubuntu
  19.04 side. Ubuntu 18.04 LTS has no such problem.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: systemd 240-6ubuntu5.3
  ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
  Uname: Linux 5.0.0-25-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Thu Aug 15 21:55:12 2019
  InstallationDate: Installed on 2017-12-22 (600 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Release amd64 
(20171017.1)
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-25-generic 
root=UUID=d383d414-f179-4df7-a8f3-890dacf8ca33 ro modprobe.blacklist=nouveau 
intel_iommu=on
  SourcePackage: systemd
  UpgradeStatus: Upgraded to disco on 2019-06-22 (54 days ago)
  dmi.bios.date: 03/21/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P2.10
  dmi.board.name: Z370M-ITX/ac
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP2.10:bd03/21/2018:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ370M-ITX/ac:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.family: To Be Filled By O.E.M.
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.sku: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1840359/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1832919] Re: installed libssl1.1:amd64 package post-installation script subprocess returned error exit status 10

2019-08-16 Thread Dimitri John Ledkov
Using bionic as a base, and upgrading all the way to disco:
(bionic-amd64)root@ottawa:~# echo PURGE | debconf-communicate libpam0g:amd64
0
(bionic-amd64)root@ottawa:~# echo PURGE | debconf-communicate libpam0g
0
(bionic-amd64)root@ottawa:~# echo PURGE | debconf-communicate libc6:amd64
0
(bionic-amd64)root@ottawa:~# echo PURGE | debconf-communicate libc6
0
(bionic-amd64)root@ottawa:~# echo PURGE | debconf-communicate libssl1.1
0
(bionic-amd64)root@ottawa:~# echo PURGE | debconf-communicate libssl1.1:amd64
0
(bionic-amd64)root@ottawa:~# dpkg-query -W libssl1.1
libssl1.1:amd64 1.1.0g-2ubuntu4

(upgrade)
(got promted for restarting services, meaning template got initiated correctly)

Services restarted successfully.

Setting up openssl (1.1.1b-1ubuntu2.4) ...


** Tags removed: verification-needed verification-needed-cosmic 
verification-needed-disco
** Tags added: verification-done verification-done-cosmic 
verification-done-disco

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssl in Ubuntu.
https://bugs.launchpad.net/bugs/1832919

Title:
  installed libssl1.1:amd64 package post-installation script subprocess
  returned error exit status 10

Status in openssl package in Ubuntu:
  Fix Released
Status in openssl source package in Bionic:
  Fix Released
Status in openssl source package in Cosmic:
  Fix Committed
Status in openssl source package in Disco:
  Fix Committed
Status in openssl source package in Eoan:
  Fix Released

Bug description:
  [Impact]

   * Systems that have in error removed debconf database fail to upgrade
  libssl1.1 (as e.g. is known to be done in some vagrant boxes)

   * libssl1.1 tries to use debconf template from libc6 package, but
  doesn't ship one by itself as it should for shared templates. As it is
  not guaranteed that template will be available.

  [TestCase]

  # DO NOT DO THIS ON PRODUCTION MACHINES #
  # echo PURGE | debconf-communicate libpam0g:amd64
  0
  # echo PURGE | debconf-communicate libpam0g
  0
  # echo PURGE | debconf-communicate libc6:amd64
  0
  # echo PURGE | debconf-communicate libc6
  0

  Then upgrade from bionic-release to the -proposed package and it
  should work.

  It should not fail with exit code 10.

  [Regression Potential]

   * A new template is added, an identical import from glibc without any
  further changes. This registers the template in debconf, for this
  package, preventing the above describe error. This has no codechanges,
  only metadata.

  [Other Info]
   
   * Original bug report 

  The error happens when trying to configure libssl1.1:amd64 (dpkg
  --configure -D 2  libssl1.1)

  dpkg: error processing package libssl1.1:amd64 (--configure):
   installed libssl1.1:amd64 package post-installation script subprocess 
returned error exit status 10
  D02: post_script_tasks - ensure_diversions
  D02: post_script_tasks - trig_incorporate
  D02: check_triggers_cycle pnow=libc-bin:amd64 first
  Processing triggers for libc-bin (2.27-3ubuntu1) ...
  D02: post_postinst_tasks - trig_incorporate
  Errors were encountered while processing:
   libssl1.1:amd64

  [ WORKAROUND TO RECOVER YOUR SYSTEM ]

  $ sudo dpkg-reconfigure libc6
  $ sudo dpkg --configure libssl1.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1832919/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840359] Re: systemd-networkd-wait-online & two ethernet on board

2019-08-16 Thread Dan Streetman
what's your network configuration?  are you using netplan?  or network-
manager?  or have you configured systemd-networkd manually?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840359

Title:
  systemd-networkd-wait-online & two ethernet on board

Status in systemd package in Ubuntu:
  New

Bug description:
  Since I've upgraded to 19.04 my boot was 3 minutes longer due to wait for 
network. I've tried many tricks, but today I have finally found the source = 
the bug.
  My PC has motherboard AsRock Z370M-ITX/ac which has 2 Ethernet ports. When I 
connect Ethernet cable just to the "first" device "enp3s0" boot is quick, when 
I connect Ethernet cable just to the "second" device "enp0s31f6" boot is about 
3 minutes longer.

  It simply waits for the "enp3s0" device.

  Since there is no mark on the board or on the rear panel which port is
  "first" and which is "second" it's clear that the failure is on Ubuntu
  19.04 side. Ubuntu 18.04 LTS has no such problem.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: systemd 240-6ubuntu5.3
  ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
  Uname: Linux 5.0.0-25-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Thu Aug 15 21:55:12 2019
  InstallationDate: Installed on 2017-12-22 (600 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Release amd64 
(20171017.1)
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-25-generic 
root=UUID=d383d414-f179-4df7-a8f3-890dacf8ca33 ro modprobe.blacklist=nouveau 
intel_iommu=on
  SourcePackage: systemd
  UpgradeStatus: Upgraded to disco on 2019-06-22 (54 days ago)
  dmi.bios.date: 03/21/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P2.10
  dmi.board.name: Z370M-ITX/ac
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP2.10:bd03/21/2018:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ370M-ITX/ac:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.family: To Be Filled By O.E.M.
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.sku: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1840359/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840435] Re: Systemd >=240 sets a clamp of 64MB for RLIMIT_MEMLOCK, too low for some applications.

2019-08-16 Thread Dan Streetman
> This breaks a number of current jackd setups, for example.

please provide steps to reproduce the problem.

** Changed in: systemd (Ubuntu)
   Status: New => Incomplete

** Bug watch added: github.com/systemd/systemd/issues #13331
   https://github.com/systemd/systemd/issues/13331

** Also affects: systemd via
   https://github.com/systemd/systemd/issues/13331
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840435

Title:
  Systemd >=240 sets a clamp of 64MB for RLIMIT_MEMLOCK, too low for
  some applications.

Status in systemd:
  Unknown
Status in systemd package in Ubuntu:
  Incomplete

Bug description:
  Systemd >= 240 sets a clamp for RLIMIT_MEMLOCK, which is too low for
  some realistic applications.  This clamp should probably be increased.
  This breaks a number of current jackd setups, for example.

  See upstream bug: https://github.com/systemd/systemd/issues/13331.

  This occurs on at Ubuntu Disco and newer, Disco being the first
  release to ship with systemd >= 240.

To manage notifications about this bug go to:
https://bugs.launchpad.net/systemd/+bug/1840435/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840359] Re: systemd-networkd-wait-online & two ethernet on board

2019-08-16 Thread Kai-Heng Feng
Do they have same MAC address?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840359

Title:
  systemd-networkd-wait-online & two ethernet on board

Status in systemd package in Ubuntu:
  New

Bug description:
  Since I've upgraded to 19.04 my boot was 3 minutes longer due to wait for 
network. I've tried many tricks, but today I have finally found the source = 
the bug.
  My PC has motherboard AsRock Z370M-ITX/ac which has 2 Ethernet ports. When I 
connect Ethernet cable just to the "first" device "enp3s0" boot is quick, when 
I connect Ethernet cable just to the "second" device "enp0s31f6" boot is about 
3 minutes longer.

  It simply waits for the "enp3s0" device.

  Since there is no mark on the board or on the rear panel which port is
  "first" and which is "second" it's clear that the failure is on Ubuntu
  19.04 side. Ubuntu 18.04 LTS has no such problem.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: systemd 240-6ubuntu5.3
  ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
  Uname: Linux 5.0.0-25-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Thu Aug 15 21:55:12 2019
  InstallationDate: Installed on 2017-12-22 (600 days ago)
  InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Release amd64 
(20171017.1)
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-25-generic 
root=UUID=d383d414-f179-4df7-a8f3-890dacf8ca33 ro modprobe.blacklist=nouveau 
intel_iommu=on
  SourcePackage: systemd
  UpgradeStatus: Upgraded to disco on 2019-06-22 (54 days ago)
  dmi.bios.date: 03/21/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P2.10
  dmi.board.name: Z370M-ITX/ac
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP2.10:bd03/21/2018:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ370M-ITX/ac:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.family: To Be Filled By O.E.M.
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.sku: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1840359/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 185165] Re: Ubuntu does not open MS Windows internet shortcuts with 'url' extension

2019-08-16 Thread Amr Ibrahim
** Tags added: bionic disco eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mime-support in Ubuntu.
https://bugs.launchpad.net/bugs/185165

Title:
  Ubuntu does not open MS Windows internet shortcuts with 'url'
  extension

Status in Ayatana Design:
  Fix Committed
Status in Gnome Mime-Data:
  Fix Released
Status in One Hundred Papercuts:
  Invalid
Status in gnome-mime-data package in Ubuntu:
  Fix Released
Status in mime-support package in Ubuntu:
  Triaged
Status in shared-mime-info package in Ubuntu:
  Triaged

Bug description:
  Ubuntu will not open standard internet shortcuts created in Microsoft
  Windows.  This makes interoperability very poor, and will prevent many
  people from migrating to Ubuntu.

  Copy any 'filename.url' from a Microsoft Windows machine, or create a
  file with the following contents:

  [DEFAULT]
  BASEURL=http://www.ubuntu.com
  [InternetShortcut]
  URL=http://www.ubuntu.com

  and name it 'ubuntu.url'.

  Double click in Nautilus to launch.  Nothing happens.  It should
  launch in the same manner as a 'desktop' internet shortcut.

  Note: a workaround has been developed -
  http://ubuntuforums.org/showthread.php?p=3281092.  This should be
  provided by default Ubuntu installation.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ayatana-design/+bug/185165/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840435] [NEW] Systemd >=240 sets a clamp of 64MB for RLIMIT_MEMLOCK, too low for some applications.

2019-08-16 Thread Kain
Public bug reported:

Systemd >= 240 sets a clamp for RLIMIT_MEMLOCK, which is too low for
some realistic applications.  This clamp should probably be increased.
This breaks a number of current jackd setups, for example.

See upstream bug: https://github.com/systemd/systemd/issues/13331.

This occurs on at Ubuntu Disco and newer, Disco being the first release
to ship with systemd >= 240.

** Affects: systemd (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1840435

Title:
  Systemd >=240 sets a clamp of 64MB for RLIMIT_MEMLOCK, too low for
  some applications.

Status in systemd package in Ubuntu:
  New

Bug description:
  Systemd >= 240 sets a clamp for RLIMIT_MEMLOCK, which is too low for
  some realistic applications.  This clamp should probably be increased.
  This breaks a number of current jackd setups, for example.

  See upstream bug: https://github.com/systemd/systemd/issues/13331.

  This occurs on at Ubuntu Disco and newer, Disco being the first
  release to ship with systemd >= 240.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1840435/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 555380] Re: cautious-launcher untranslated and untranslatable

2019-08-16 Thread Amr Ibrahim
** Tags added: bionic disco eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mime-support in Ubuntu.
https://bugs.launchpad.net/bugs/555380

Title:
  cautious-launcher untranslated and untranslatable

Status in Ubuntu Translations:
  Triaged
Status in mime-support package in Ubuntu:
  Triaged

Bug description:
  Binary package hint: mime-support

  The dialog box displayed by cautious-launcher shows untranslated in my
  Spanish desktop, and can't be translated because mime-support doesn't
  have a template in Launchpad Translations:

https://translations.launchpad.net/ubuntu/lucid/+source/mime-support

  ProblemType: Bug
  DistroRelease: Ubuntu 10.04
  Package: mime-support 3.48-1ubuntu1
  ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
  Uname: Linux 2.6.32-19-generic i686
  NonfreeKernelModules: nvidia
  Architecture: i386
  Date: Mon Apr  5 00:04:20 2010
  Dependencies:
   
  PackageArchitecture: all
  ProcEnviron:
   LANGUAGE=es_ES:es:en_GB:en
   PATH=(custom, user)
   LANG=es_ES.utf8
   SHELL=/bin/bash
  SourcePackage: mime-support

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-translations/+bug/555380/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837580] Re: memlock is not set

2019-08-16 Thread Kain
Systemd 240 and newer introduced a clamp to RLIMIT_MEMLOCK in
c8884aceefc85245b9bdfb626e2daf27521259bd.  See
https://github.com/systemd/systemd/issues/13331.

** Bug watch added: github.com/systemd/systemd/issues #13331
   https://github.com/systemd/systemd/issues/13331

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1837580

Title:
  memlock is not set

Status in systemd package in Ubuntu:
  New
Status in systemd package in Debian:
  Unknown

Bug description:
  I discovered this in relation to jack, which installs
  /etc/security/limits.d/audio.conf, containing:

  @audio   -  rtprio 95
  @audio   -  memlockunlimited

  For a user in the audio group:

  $ulimit -l -r
  max locked memory   (kbytes, -l) 65536
  real-time priority  (-r) 95

  So jack (run as user via qjackctl) reports:

  ERROR: Cannot lock down 82280346 byte memory area (Cannot allocate
  memory)

  but does not report that it cannot set real-time priority, which it
  does if run by a user not in the audio group.

  I also tried putting the line in /etc/security/limits.conf, and trying
  a number rather than "unlimited", but it didn't help.

  Also reported independently here:
  https://askubuntu.com/questions/1142943/ulimit-unlimited-cannot-set

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: libpam-modules:amd64 1.3.1-5ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-20.21-lowlatency 5.0.8
  Uname: Linux 5.0.0-20-lowlatency x86_64
  ApportVersion: 2.20.10-0ubuntu27.1
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Jul 23 15:07:52 2019
  InstallationDate: Installed on 2016-10-25 (1000 days ago)
  InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
  SourcePackage: pam
  UpgradeStatus: Upgraded to disco on 2019-07-19 (3 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1837580/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1839764] Re: Video cuts out after 3 seconds

2019-08-16 Thread bwallum
The fault returned and I swapped out monitor/pc with other units to
narrow down the fault to the monitor. A new monitor has fixed the
problem of losing the screen after 3 seconds or so.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd-shim in Ubuntu.
https://bugs.launchpad.net/bugs/1839764

Title:
  Video cuts out after 3 seconds

Status in systemd-shim package in Ubuntu:
  New

Bug description:
  Using Desktop 19.04

  When I start the computer the video is fine until it boots up Ubuntu.
  Then, after 3 seconds approximately the monitor is blanked. I can turn
  the monitor off and on again and it shows Ubuntu, again for 3 seconds
  then the same black screen. Ubuntu is running and I can log in, click
  report error button in pop up and log out, during multiple 3 second
  intervals between switching on the screen and Ubuntu blanking it.

  I am currently using another computer to send this report.

  Anybody else with the problem? Anybody worked out a fix?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd-shim/+bug/1839764/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1792294] Re: Generates unbootable initrd: Out of Memory Error

2019-08-16 Thread Mengyao Xie
Add: this problem only happens in new kernel version. I can boot system
with the old kernel version.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1792294

Title:
  Generates unbootable initrd: Out of Memory Error

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  I am currently using Cosmic (which is not released yet) and version
  0.131ubuntu10 of "initramfs-tools" always generates unbootable initrd.
  After I select the kernel to boot during GRUB it says: "Loading
  initial ramdisk... Error: Out of memory". And then it halts forever.

  This issue appears on all kernel versions.

  The system is on UEFI + GPT.

  Note that I don't have a swap partition on my system, but I don't
  think it's the cause.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: initramfs-tools 0.131ubuntu10
  ProcVersionSignature: Ubuntu 4.15.0-34.37-generic 4.15.18
  Uname: Linux 4.15.0-34-generic x86_64
  ApportVersion: 2.20.10-0ubuntu9
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Sep 13 13:36:35 2018
  InstallationDate: Installed on 2018-09-12 (0 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  PackageArchitecture: all
  SourcePackage: initramfs-tools
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1792294/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840422] Re: Boot fail: Loading initial ramdisk... Error: Out of memory

2019-08-16 Thread Chris Guiver
Thank you for taking the time to report this issue and helping to make
Ubuntu better.

Examining the information you have given us, this does not appear to be
a bug report so we are closing it and converting it to a question in the
support tracker. We understand the difficulties you are facing, but it
is better to raise problems you are having in the support tracker at
https://answers.launchpad.net/ubuntu if you are uncertain if they are
bugs.

You can also find help with your problem in the support forum of your
local Ubuntu community http://loco.ubuntu.com/ or asking at
https://askubuntu.com or https://ubuntuforums.org. For help on reporting
bugs, see https://help.ubuntu.com/community/ReportingBugs.

** Changed in: initramfs-tools (Ubuntu)
   Status: New => Invalid

** Converted to question:
   https://answers.launchpad.net/ubuntu/+source/initramfs-tools/+question/682927

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1840422

Title:
  Boot fail: Loading initial ramdisk... Error: Out of memory

Status in initramfs-tools package in Ubuntu:
  Invalid

Bug description:
  Hi all,

  I want to upgrade the system's kernel version to 4.20.

  After compiling the Kernel 4.20, I update-grub and reboot. However,
  boot failed, it says: "Loading initial ramdisk... Error: Out of
  memory".

  I can successfully boot the system by using the old kernel version.

  So, how to fix this problem?

  SYSTEM INFORMATION:
  Linux ubuntu-PowerEdge-R440 4.18.0-15-generic #16~18.04.1-Ubuntu SMP Thu Feb 
7 14:06:04 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1840422/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840422] [NEW] Boot fail: Loading initial ramdisk... Error: Out of memory

2019-08-16 Thread Mengyao Xie
Public bug reported:

Hi all,

I want to upgrade the system's kernel version to 4.20.

After compiling the Kernel 4.20, I update-grub and reboot. However, boot
failed, it says: "Loading initial ramdisk... Error: Out of memory".

I can successfully boot the system by using the old kernel version.

So, how to fix this problem?

SYSTEM INFORMATION:
Linux ubuntu-PowerEdge-R440 4.18.0-15-generic #16~18.04.1-Ubuntu SMP Thu Feb 7 
14:06:04 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

** Affects: initramfs-tools (Ubuntu)
 Importance: Undecided
 Status: Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1840422

Title:
  Boot fail: Loading initial ramdisk... Error: Out of memory

Status in initramfs-tools package in Ubuntu:
  Invalid

Bug description:
  Hi all,

  I want to upgrade the system's kernel version to 4.20.

  After compiling the Kernel 4.20, I update-grub and reboot. However,
  boot failed, it says: "Loading initial ramdisk... Error: Out of
  memory".

  I can successfully boot the system by using the old kernel version.

  So, how to fix this problem?

  SYSTEM INFORMATION:
  Linux ubuntu-PowerEdge-R440 4.18.0-15-generic #16~18.04.1-Ubuntu SMP Thu Feb 
7 14:06:04 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1840422/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1792294] Re: Generates unbootable initrd: Out of Memory Error

2019-08-16 Thread Mengyao Xie
Hi Kai-Chuang Yan,

I have the same problem when I want to change the system's kernel
version.

After compiling the Kernel 4.20, I update-grub and reboot. However, it
says: "Loading initial ramdisk... Error: Out of memory".

What did you mean that this bug is fixed in the 0.131ubuntu15?

Thanks!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1792294

Title:
  Generates unbootable initrd: Out of Memory Error

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  I am currently using Cosmic (which is not released yet) and version
  0.131ubuntu10 of "initramfs-tools" always generates unbootable initrd.
  After I select the kernel to boot during GRUB it says: "Loading
  initial ramdisk... Error: Out of memory". And then it halts forever.

  This issue appears on all kernel versions.

  The system is on UEFI + GPT.

  Note that I don't have a swap partition on my system, but I don't
  think it's the cause.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: initramfs-tools 0.131ubuntu10
  ProcVersionSignature: Ubuntu 4.15.0-34.37-generic 4.15.18
  Uname: Linux 4.15.0-34-generic x86_64
  ApportVersion: 2.20.10-0ubuntu9
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Sep 13 13:36:35 2018
  InstallationDate: Installed on 2018-09-12 (0 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 
(20180725)
  PackageArchitecture: all
  SourcePackage: initramfs-tools
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1792294/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840416] Re: 2.4g wifi connection failed randomly during wpa re-key

2019-08-16 Thread Betty Lin
The problem is really hard to reproduce.
The test scenario is:
1. Connect wi-fi
2. Play 4k video on Youtube

Monitor the scenario for more than one week, and discover this problem
once.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1840416

Title:
  2.4g wifi connection failed randomly during wpa re-key

Status in OEM Priority Project:
  New
Status in network-manager package in Ubuntu:
  New

Bug description:
  I'm not sure this issue caused by WIFI AP or WIFI module.
  From log, it looks the tested machine can not get new key from WIFI AP 
randomly.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: network-manager 1.10.6-2ubuntu1.1
  ProcVersionSignature: Ubuntu 4.15.0-1030.35-oem 4.15.18
  Uname: Linux 4.15.0-1030-oem x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 14:51:12 2019
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-bionic-amd64-20180608-47+italia-whl+X37
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2019-08-14 (2 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
20180608-09:38
  IpRoute:
   default via 10.101.46.1 dev wlp2s0 proto dhcp metric 600 
   10.101.46.0/24 dev wlp2s0 proto kernel scope link src 10.101.46.198 metric 
600 
   169.254.0.0/16 dev wlp2s0 scope link metric 1000
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-con:
   NAMEUUID  TYPE  TIMESTAMP   
TIMESTAMP-REALAUTOCONNECT  AUTOCONNECT-PRIORITY  
READONLY  DBUS-PATH   ACTIVE  DEVICE  STATE 
 ACTIVE-PATH SLAVE 
   Canonical-2.4GHz-g  f0a4469e-23e9-4899-a498-49a50b3a8e21  wifi  1565938016  
廿十九年八月十六日 (週五) 十四時46分56秒  yes  0 no
/org/freedesktop/NetworkManager/Settings/1  yes wlp2s0  activated  
/org/freedesktop/NetworkManager/ActiveConnection/5  --
  nmcli-dev:
   DEVICE  TYPE  STATE  DBUS-PATH  
CONNECTION  CON-UUID  CON-PATH  
 
   wlp2s0  wifi  connected  /org/freedesktop/NetworkManager/Devices/2  
Canonical-2.4GHz-g  f0a4469e-23e9-4899-a498-49a50b3a8e21  
/org/freedesktop/NetworkManager/ActiveConnection/5 
   lo  loopback  unmanaged  /org/freedesktop/NetworkManager/Devices/1  --   
   ----
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.10.6   connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1840416/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840416] Re: 2.4g wifi connection failed randomly during wpa re-key

2019-08-16 Thread Alex Tu
compare the failed case and passed case , it seems the clue is 2nd kernel 
trigging 
wlp2s0: deauthenticated from 3c:ce:73:48:04:60

# from journalctl.log:
 八  16 13:13:38 u-XPS-13-9380 kernel: wlp2s0: deauthenticated from 
3c:ce:73:48:0e:40 (Reason: 1=UNSPECIFIED)
 八  16 13:13:39 u-XPS-13-9380 wpa_supplicant[11018]: wlp2s0: 
CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
 八  16 13:13:43 u-XPS-13-9380 wpa_supplicant[11018]: wlp2s0: SME: Trying to 
authenticate with 3c:ce:73:48:04:60 (SSID='Canonical-2.4GHz-g' freq=2412 MHz)
 八  16 13:13:43 u-XPS-13-9380 kernel: wlp2s0: associated
 八  16 13:13:43 u-XPS-13-9380 kernel: wlp2s0: deauthenticated from 
3c:ce:73:48:04:60 (Reason: 2=PREV_AUTH_NOT_VALID)
 八  16 13:13:43 u-XPS-13-9380 wpa_supplicant[11018]: wlp2s0: 
CTRL-EVENT-DISCONNECTED bssid=3c:ce:73:48:04:60 reason=2
 八  16 13:13:43 u-XPS-13-9380 wpa_supplicant[11018]: wlp2s0: WPA: 4-Way 
Handshake failed - pre-shared key may be incorrect
 八  16 13:13:43 u-XPS-13-9380 wpa_supplicant[11018]: wlp2s0: 
CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Canonical-2.4GHz-g" auth_failures=1 
duration=10 reason=WRONG_KEY


# compare to the latest successful rekey in journalctl.log:
 八  14 11:07:33 u-XPS-13-9380 kernel: wlp2s0: deauthenticated from 
a4:56:30:cc:0f:30 (Reason: 2=PREV_AUTH_NOT_VALID)
 八  14 11:07:33 u-XPS-13-9380 wpa_supplicant[907]: wlp2s0: SME: Trying to 
authenticate with 3c:ce:73:48:0e:40 (SSID='Canonical-2.4GHz-g' freq=2437 MHz)   
   
 八  14 11:07:33 u-XPS-13-9380 kernel: wlp2s0: associated
 八  14 11:07:33 u-XPS-13-9380 NetworkManager[906]:   [1565752053.7303] 
device (wlp2s0): supplicant interface state: associating -> 4-way handshake


** Attachment added: "journalctl.log"
   
https://bugs.launchpad.net/oem-priority/+bug/1840416/+attachment/5282829/+files/journalctl.log

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1840416

Title:
  2.4g wifi connection failed randomly during wpa re-key

Status in OEM Priority Project:
  New
Status in network-manager package in Ubuntu:
  New

Bug description:
  I'm not sure this issue caused by WIFI AP or WIFI module.
  From log, it looks the tested machine can not get new key from WIFI AP 
randomly.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: network-manager 1.10.6-2ubuntu1.1
  ProcVersionSignature: Ubuntu 4.15.0-1030.35-oem 4.15.18
  Uname: Linux 4.15.0-1030-oem x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 14:51:12 2019
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-bionic-amd64-20180608-47+italia-whl+X37
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2019-08-14 (2 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
20180608-09:38
  IpRoute:
   default via 10.101.46.1 dev wlp2s0 proto dhcp metric 600 
   10.101.46.0/24 dev wlp2s0 proto kernel scope link src 10.101.46.198 metric 
600 
   169.254.0.0/16 dev wlp2s0 scope link metric 1000
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-con:
   NAMEUUID  TYPE  TIMESTAMP   
TIMESTAMP-REALAUTOCONNECT  AUTOCONNECT-PRIORITY  
READONLY  DBUS-PATH   ACTIVE  DEVICE  STATE 
 ACTIVE-PATH SLAVE 
   Canonical-2.4GHz-g  f0a4469e-23e9-4899-a498-49a50b3a8e21  wifi  1565938016  
廿十九年八月十六日 (週五) 十四時46分56秒  yes  0 no
/org/freedesktop/NetworkManager/Settings/1  yes wlp2s0  activated  
/org/freedesktop/NetworkManager/ActiveConnection/5  --
  nmcli-dev:
   DEVICE  TYPE  STATE  DBUS-PATH  
CONNECTION  CON-UUID  CON-PATH  
 
   wlp2s0  wifi  connected  /org/freedesktop/NetworkManager/Devices/2  
Canonical-2.4GHz-g  f0a4469e-23e9-4899-a498-49a50b3a8e21  
/org/freedesktop/NetworkManager/ActiveConnection/5 
   lo  loopback  unmanaged  /org/freedesktop/NetworkManager/Devices/1  --   
   ----
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.10.6   connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1840416/+subscriptions

-- 
Mailing 

[Touch-packages] [Bug 1840416] Re: 2.4g wifi connection failed randomly during wpa re-key

2019-08-16 Thread Alex Tu
** Attachment added: "sosreport-wi-fi-lost-20190816135009.tar.xz"
   
https://bugs.launchpad.net/oem-priority/+bug/1840416/+attachment/5282828/+files/sosreport-wi-fi-lost-20190816135009.tar.xz

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1840416

Title:
  2.4g wifi connection failed randomly during wpa re-key

Status in OEM Priority Project:
  New
Status in network-manager package in Ubuntu:
  New

Bug description:
  I'm not sure this issue caused by WIFI AP or WIFI module.
  From log, it looks the tested machine can not get new key from WIFI AP 
randomly.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: network-manager 1.10.6-2ubuntu1.1
  ProcVersionSignature: Ubuntu 4.15.0-1030.35-oem 4.15.18
  Uname: Linux 4.15.0-1030-oem x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 14:51:12 2019
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-bionic-amd64-20180608-47+italia-whl+X37
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2019-08-14 (2 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
20180608-09:38
  IpRoute:
   default via 10.101.46.1 dev wlp2s0 proto dhcp metric 600 
   10.101.46.0/24 dev wlp2s0 proto kernel scope link src 10.101.46.198 metric 
600 
   169.254.0.0/16 dev wlp2s0 scope link metric 1000
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-con:
   NAMEUUID  TYPE  TIMESTAMP   
TIMESTAMP-REALAUTOCONNECT  AUTOCONNECT-PRIORITY  
READONLY  DBUS-PATH   ACTIVE  DEVICE  STATE 
 ACTIVE-PATH SLAVE 
   Canonical-2.4GHz-g  f0a4469e-23e9-4899-a498-49a50b3a8e21  wifi  1565938016  
廿十九年八月十六日 (週五) 十四時46分56秒  yes  0 no
/org/freedesktop/NetworkManager/Settings/1  yes wlp2s0  activated  
/org/freedesktop/NetworkManager/ActiveConnection/5  --
  nmcli-dev:
   DEVICE  TYPE  STATE  DBUS-PATH  
CONNECTION  CON-UUID  CON-PATH  
 
   wlp2s0  wifi  connected  /org/freedesktop/NetworkManager/Devices/2  
Canonical-2.4GHz-g  f0a4469e-23e9-4899-a498-49a50b3a8e21  
/org/freedesktop/NetworkManager/ActiveConnection/5 
   lo  loopback  unmanaged  /org/freedesktop/NetworkManager/Devices/1  --   
   ----
  nmcli-nm:
   RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI WWAN-HW  WWAN
   running  1.10.6   connected  started  full  enabled enabled  
enabled  enabled  enabled

To manage notifications about this bug go to:
https://bugs.launchpad.net/oem-priority/+bug/1840416/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1840416] [NEW] 2.4g wifi connection failed randomly during wpa re-key

2019-08-16 Thread Alex Tu
Public bug reported:

I'm not sure this issue caused by WIFI AP or WIFI module.
>From log, it looks the tested machine can not get new key from WIFI AP 
>randomly.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: network-manager 1.10.6-2ubuntu1.1
ProcVersionSignature: Ubuntu 4.15.0-1030.35-oem 4.15.18
Uname: Linux 4.15.0-1030-oem x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Aug 16 14:51:12 2019
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-bionic-amd64-20180608-47+italia-whl+X37
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2019-08-14 (2 days ago)
InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
20180608-09:38
IpRoute:
 default via 10.101.46.1 dev wlp2s0 proto dhcp metric 600 
 10.101.46.0/24 dev wlp2s0 proto kernel scope link src 10.101.46.198 metric 600 
 169.254.0.0/16 dev wlp2s0 scope link metric 1000
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAMEUUID  TYPE  TIMESTAMP   
TIMESTAMP-REALAUTOCONNECT  AUTOCONNECT-PRIORITY  
READONLY  DBUS-PATH   ACTIVE  DEVICE  STATE 
 ACTIVE-PATH SLAVE 
 Canonical-2.4GHz-g  f0a4469e-23e9-4899-a498-49a50b3a8e21  wifi  1565938016  
廿十九年八月十六日 (週五) 十四時46分56秒  yes  0 no
/org/freedesktop/NetworkManager/Settings/1  yes wlp2s0  activated  
/org/freedesktop/NetworkManager/ActiveConnection/5  --
nmcli-dev:
 DEVICE  TYPE  STATE  DBUS-PATH  
CONNECTION  CON-UUID  CON-PATH  
 
 wlp2s0  wifi  connected  /org/freedesktop/NetworkManager/Devices/2  
Canonical-2.4GHz-g  f0a4469e-23e9-4899-a498-49a50b3a8e21  
/org/freedesktop/NetworkManager/ActiveConnection/5 
 lo  loopback  unmanaged  /org/freedesktop/NetworkManager/Devices/1  -- 
 ----
nmcli-nm:
 RUNNING  VERSION  STATE  STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  WIFI  
   WWAN-HW  WWAN
 running  1.10.6   connected  started  full  enabled enabled  
enabled  enabled  enabled

** Affects: oem-priority
 Importance: Undecided
 Status: New

** Affects: network-manager (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic

** Also affects: oem-priority
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1840416

Title:
  2.4g wifi connection failed randomly during wpa re-key

Status in OEM Priority Project:
  New
Status in network-manager package in Ubuntu:
  New

Bug description:
  I'm not sure this issue caused by WIFI AP or WIFI module.
  From log, it looks the tested machine can not get new key from WIFI AP 
randomly.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: network-manager 1.10.6-2ubuntu1.1
  ProcVersionSignature: Ubuntu 4.15.0-1030.35-oem 4.15.18
  Uname: Linux 4.15.0-1030-oem x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Aug 16 14:51:12 2019
  DistributionChannelDescriptor:
   # This is the distribution channel descriptor for the OEM CDs
   # For more information see 
http://wiki.ubuntu.com/DistributionChannelDescriptor
   canonical-oem-somerville-bionic-amd64-20180608-47+italia-whl+X37
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2019-08-14 (2 days ago)
  InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 
20180608-09:38
  IpRoute:
   default via 10.101.46.1 dev wlp2s0 proto dhcp metric 600 
   10.101.46.0/24 dev wlp2s0 proto kernel scope link src 10.101.46.198 metric 
600 
   169.254.0.0/16 dev wlp2s0 scope link metric 1000
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-con:
   NAMEUUID  TYPE  TIMESTAMP   
TIMESTAMP-REALAUTOCONNECT  AUTOCONNECT-PRIORITY  
READONLY  DBUS-PATH   ACTIVE  DEVICE  STATE 
 ACTIVE-PATH SLAVE 
   Canonical-2.4GHz-g