[Touch-packages] [Bug 1849919] [NEW] Xorg crash

2019-10-25 Thread pleabargain
Public bug reported:

I was using chrome
deluge was running in the background

I got 3 quick error messages that other apps were shutting down but I
didn't get the names

Then, all applications disappeared from screen 
running desktop UI but NO apps

All running apps just stopped.

No error message on screen so I ran ubuntu-bug

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
Uname: Linux 5.3.0-19-generic x86_64
.tmp.unity_support_test.0:
 
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sat Oct 26 08:38:22 2019
DistUpgraded: 2019-10-23 09:33:56,809 ERROR got error from PostInstallScript 
./xorg_fix_proprietary.py (g-exec-error-quark: Failed to execute child process 
“./xorg_fix_proprietary.py” (No such file or directory) (8))
DistroCodename: eoan
DistroVariant: ubuntu
DkmsStatus: anbox, 1, 5.0.0-32-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics 
Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. 2nd Generation Core Processor Family 
Integrated Graphics Controller [1043:84ca]
InstallationDate: Installed on 2015-08-23 (1524 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-19-generic 
root=UUID=155c3c3c-daa6-414c-ac3d-0f8c492592c0 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: Upgraded to eoan on 2019-10-23 (2 days ago)
dmi.bios.date: 07/21/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2501
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z77-V LX
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2501:bd07/21/2014:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8Z77-VLX:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.14.0+19.10.20190918-0ubuntu1
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.1-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
xserver.bootTime: Mon Aug 20 17:24:57 2018
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 
xserver.version: 2:1.18.4-0ubuntu0.7

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug crash eoan ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1849919

Title:
  Xorg crash

Status in xorg package in Ubuntu:
  New

Bug description:
  I was using chrome
  deluge was running in the background

  I got 3 quick error messages that other apps were shutting down but I
  didn't get the names

  Then, all applications disappeared from screen 
  running desktop UI but NO apps

  All running apps just stopped.

  No error message on screen so I ran ubuntu-bug

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
  Uname: Linux 5.3.0-19-generic x86_64
  .tmp.unity_support_test.0:
   
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Oct 26 08:38:22 2019
  DistUpgraded: 2019-10-23 09:33:56,809 ERROR got error from PostInstallScript 
./xorg_fix_proprietary.py (g-exec-error-quark: Failed to execute child process 
“./xorg_fix_proprietary.py” (No such file or directory) (8))
  DistroCodename: eoan
  DistroVariant: ubuntu
  DkmsStatus: anbox, 1, 5.0.0-32-generic, x86_64: installed
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics 
Controller [8086:0102] (rev 

[Touch-packages] [Bug 1846539] Re: [broadwell-rt286, playback] Since Linux 5.2rc2 audio playback no longer works on Dell Venue 11 Pro 7140

2019-10-25 Thread Bug Watch Updater
Launchpad has imported 19 comments from the remote bug at
https://bugzilla.kernel.org/show_bug.cgi?id=204237.

If you reply to an imported comment from within Launchpad, your comment
will be sent to the remote bug automatically. Read more about
Launchpad's inter-bugtracker facilities at
https://help.launchpad.net/InterBugTracking.


On 2019-07-19T19:36:02+00:00 drraug wrote:

Created attachment 283853
dmesg output

Since kernel 5.2 there is no sound on my Broadwell-based laptop with
bdw-rt5677 driver. The laptop is a Chromebook Pixel 2015 (Samus)
converted to Linux with UEFI firmware by MrChromebox. There was no
problem with this component with 4.19.*, 5.0.* and 5.1.* kernels up
until 5.1.16.


> uname -a
Linux pixie 5.2.1-arch1-1-ARCH #1 SMP PREEMPT Sun Jul 14 14:52:52 UTC 2019 
x86_64 GNU/Linux

> cat /proc/version
Linux version 5.2.1-arch1-1-ARCH (builduser@heftig-55221) (gcc version 9.1.0 
(GCC)) #1 SMP PREEMPT Sun Jul 14 14:52:52 UTC 2019

> cat /proc/cpuinfo | grep -i name
model name  : Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz

Reply at: https://bugs.launchpad.net/ubuntu/+source/alsa-
driver/+bug/1846539/comments/0


On 2019-07-19T19:38:58+00:00 drraug wrote:

awk -f scripts/ver_linux
If some fields are empty or look unusual you may have an old version.
Compare to the current minimal requirements in Documentation/Changes.

Linux pixie 5.2.1-arch1-1-ARCH #1 SMP PREEMPT Sun Jul 14 14:52:52 UTC
2019 x86_64 GNU/Linux

GNU C   9.1.0
GNU Make4.2.1
Binutils2.32
Util-linux  2.34
Mount   2.34
Module-init-tools   26
E2fsprogs   1.45.3
Jfsutils1.1.15
Reiserfsprogs   3.6.27
Xfsprogs4.20.0
Linux C Library 2.29
Dynamic linker (ldd)2.29
Linux C++ Library   6.0.26
Procps  3.3.15
Kbd 2.0.4
Console-tools   2.0.4
Sh-utils8.31
Udev242
Modules Loaded  8021q ac ac97_bus aesni_intel aes_x86_64 agpgart ahci 
arc4 atkbd atmel_mxt_ts battery ccm cfg80211 chromeos_laptop cmdlinepart 
coretemp crc16 crc32c_generic crc32c_intel crc32_pclmul crct10dif_pclmul 
cros_ec_core cros_ec_lpcs cros_kbd_led_backlight cryptd crypto_simd drm 
drm_kms_helper evdev ext4 fat fb_sys_fops garp ghash_clmulni_intel glue_helper 
gpio_lynxpoint i2c_algo_bit i8042 i915 input_leds intel_cstate intel_gtt 
intel_pch_thermal intel_powerclamp intel_rapl intel_rapl_perf intel_spi 
intel_spi_platform intel_uncore ip_tables irqbypass iTCO_vendor_support 
iTCO_wdt iwlmvm iwlwifi jbd2 joydev kvm kvm_intel libahci libata libps2 llc 
lpc_ich lz4 lz4_compress mac80211 mac_hid mbcache media mei mei_me mousedev mrp 
msr mtd nls_cp437 nls_iso8859_1 ofpart pcc_cpufreq pcspkr rfkill rng_core 
scsi_mod sd_mod serio serio_raw snd snd_compress snd_hda_codec 
snd_hda_codec_hdmi snd_hda_core snd_hda_intel snd_hwdep snd_pcm 
snd_pcm_dmaengine snd_soc_acpi snd_soc_acpi_intel_match snd_soc_core 
snd_soc_rl6231 snd_soc_rt5677 snd_soc_rt5677_spi snd_soc_sst_acpi 
snd_soc_sst_bdw_rt5677_mach snd_soc_sst_dsp snd_soc_sst_firmware 
snd_soc_sst_haswell_pcm snd_soc_sst_ipc snd_sof snd_sof_intel_bdw 
snd_sof_intel_byt snd_sof_intel_ipc snd_sof_xtensa_dsp snd_timer sof_acpi_dev 
soundcore spi_nor spi_pxa2xx_platform stp syscopyarea sysfillrect sysimgblt tpm 
tpm_tis tpm_tis_core uvcvideo vfat videobuf2_common videobuf2_memops 
videobuf2_v4l2 videobuf2_vmalloc videodev x86_pkg_temp_thermal xhci_hcd 
xhci_pci x_tables

Reply at: https://bugs.launchpad.net/ubuntu/+source/alsa-
driver/+bug/1846539/comments/1


On 2019-07-19T19:40:54+00:00 drraug wrote:

Created attachment 283855
/proc/modules

Reply at: https://bugs.launchpad.net/ubuntu/+source/alsa-
driver/+bug/1846539/comments/2


On 2019-07-19T19:41:12+00:00 drraug wrote:

Created attachment 283857
/proc/iomem

Reply at: https://bugs.launchpad.net/ubuntu/+source/alsa-
driver/+bug/1846539/comments/3


On 2019-07-19T19:42:37+00:00 drraug wrote:

Created attachment 283859
lspci -vvv

Reply at: https://bugs.launchpad.net/ubuntu/+source/alsa-
driver/+bug/1846539/comments/4


On 2019-07-19T19:44:16+00:00 drraug wrote:

> cat /etc/modprobe.d/modprobe.conf
blacklist btintel
blacklist btusb
blacklist bluetooth

options snd slots=snd_soc_sst_bdw_rt5677_mach,snd-hda-intel

Reply at: https://bugs.launchpad.net/ubuntu/+source/alsa-
driver/+bug/1846539/comments/5


On 2019-07-21T23:57:37+00:00 bubbathevtog wrote:

I can 

[Touch-packages] [Bug 1846539] Re: [broadwell-rt286, playback] Since Linux 5.2rc2 audio playback no longer works on Dell Venue 11 Pro 7140

2019-10-25 Thread RussianNeuroMancer
** Bug watch added: Linux Kernel Bug Tracker #204237
   https://bugzilla.kernel.org/show_bug.cgi?id=204237

** Changed in: linux
   Importance: Medium => Unknown

** Changed in: linux
   Status: Invalid => Unknown

** Changed in: linux
 Remote watch: Linux Kernel Bug Tracker #205083 => Linux Kernel Bug Tracker 
#204237

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1846539

Title:
  [broadwell-rt286, playback] Since Linux 5.2rc2 audio playback no
  longer works on Dell Venue 11 Pro 7140

Status in Linux:
  Unknown
Status in alsa-driver package in Ubuntu:
  New
Status in linux package in Ubuntu:
  New

Bug description:
  Hello!

  I noticed that since Linux 5.2rc2 audio playback no longer works on
  Dell Venue 11 Pro 7140 (Intel Core M-5Y71; rt286). Turns out that
  happened because SND_SOC_SOF_BROADWELL_SUPPORT was enabled in kernel
  binary builds since 5.2rc2: https://kernel.ubuntu.com/~kernel-
  ppa/mainline/v5.2-rc2/

  To verify this assumption I tested two builds of Linux 5.3.1.
  1. Build with enabled SND_SOC_SOF_BROADWELL_SUPPORT from 
https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.3.1/

  Audio playback doesn't work, dmesg:
  [4.072800] snd_hda_intel :00:03.0: bound :00:02.0 (ops 
i915_audio_component_bind_ops [i915])
  [4.212606] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.238009] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.294920] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.407351] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.428922] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.458926] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.472113] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for 
intel/IntcPP01.bin failed with error -2
  [4.472118] haswell-pcm-audio haswell-pcm-audio: fw image 
intel/IntcPP01.bin not available(-2)
  [4.472735] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox 
readback FW info: type 01, - version: 00.00, build 77, source commit id: 
876ac6906f31a43b6772b23c7c983ce9dcb18a19
  [4.474607] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System 
Pin mapping ok
  [4.474676] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload0 Pin mapping ok
  [4.474741] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload1 Pin mapping ok
  [4.474807] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Loopback Pin mapping ok
  [4.476377] broadwell-audio broadwell-audio: rt286-aif1 <-> 
snd-soc-dummy-dai mapping ok
  [4.480344] input: broadwell-rt286 Headset as 
/devices/pci:00/INT3438:00/broadwell-audio/sound/card1/input14
  [7.892659] haswell-pcm-audio haswell-pcm-audio: error: message type 7 
header 0x8700
  [   13.015379] haswell-pcm-audio haswell-pcm-audio: error: reset stream 2 
still running
  [   13.127262] haswell-pcm-audio haswell-pcm-audio: error: reset stream 0 
still running
  [   19.623436] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- 
ipcx 0x8612 isr 0x ipcd 0x4700 imrx 0x7fff
  [   19.623446] haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 
faile

  2. Build with disabled SND_SOC_SOF_BROADWELL_SUPPORT.

  Audio playback works, dmesg:
  [4.839028] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for 
intel/IntcPP01.bin failed with error -2
  [4.839034] haswell-pcm-audio haswell-pcm-audio: fw image 
intel/IntcPP01.bin not available(-2)
  [4.839644] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox 
readback FW info: type 01, - version: 00.00, build 77, source commit id: 
876ac6906f31a43b6772b23c7c983ce9dcb18a19
  [4.851204] snd_hda_intel :00:03.0: bound :00:02.0 (ops 
i915_audio_component_bind_ops [i915])
  [4.907386] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System 
Pin mapping ok
  [4.907475] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload0 Pin mapping ok
  [4.909831] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload1 Pin mapping ok
  [4.909931] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Loopback Pin mapping ok
  [4.912149] broadwell-audio broadwell-audio: rt286-aif1 <-> 
snd-soc-dummy-dai mapping ok
  [4.929629] input: broadwell-rt286 Headset as 
/devices/pci:00/INT3438:00/broadwell-audio/sound/card1/input14

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
  Uname: Linux 5.3.0-13-generic x86_64
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   

[Touch-packages] [Bug 1410544] Re: Upgrade to Python 2.7.9 (backporting features from PEP 466)

2019-10-25 Thread Jeremy Bicha
** Summary changed:

- Upgrade to Python 2.7.9 (backporting features from PEP 466)
+ Upgrade to Python 2.7.17 (backporting features from PEP 466)

** Tags removed: precise trusty utopic
** Tags added: bionic xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-defaults in Ubuntu.
https://bugs.launchpad.net/bugs/1410544

Title:
  Upgrade to Python 2.7.17 (backporting features from PEP 466)

Status in python-defaults package in Ubuntu:
  New

Bug description:
  Following @actionparsnip's suggestion, re-filing
  https://answers.launchpad.net/ubuntu/+source/python-
  defaults/+question/260428 as a bug. Quoted from the original question:

  "What are the official plans for Python 2.7.9 (and further 2.7 patch
  releases) in supported releases? As per PEP 466
  (https://www.python.org/dev/peps/pep-0466/), these will receive
  handpicked security-related feature additions from the Python 3
  series. Will these new releases be included in released-and-still-
  supported Ubuntu versions? (I realise Ubuntu releases don't generally
  get new upstream software versions, but I feel this case might warrant
  an exception.)

  Note that I'm specifically asking about the *features* mentioned in
  PEP 466 (and any future additions), i.e. the new functions in the hmac
  and hashlib modules and the backported ssl module, not any security
  issues in existing functionality."

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python-defaults/+bug/1410544/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1844992] Re: Update to 1.18.0 not this cycle

2019-10-25 Thread Jeremy Bicha
autosynced for 20.04 LTS

** Changed in: v4l-utils (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to v4l-utils in Ubuntu.
https://bugs.launchpad.net/bugs/1844992

Title:
  Update to 1.18.0 not this cycle

Status in v4l-utils package in Ubuntu:
  Fix Released

Bug description:
  The new version has new features and it's late for this cycle

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/v4l-utils/+bug/1844992/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849907] Re: Add Online Account Nextcloud no Apply button

2019-10-25 Thread Gunnar Hjalmarsson
Thanks for report. ubuntu-docs is for bugs in the desktop documentation,
though, and this is apparently not about that. Changing affected
package.

The window on my 19.10 (attached) does not look exactly as the one in
your screenshot. I have a "Connect" button at the top right which
probably would be clickable if I filled the fields.

Which desktop environment are you on?

If you are on Ubuntu GNOME, did you possibly change the appearance
settings somehow, maybe in Tweaks? (I imagine that a possible
explanation is that you enabled something which is not compatible with
the design of that Nextcloud window.)

** Attachment added: "nextcloud-window.png"
   
https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/1849907/+attachment/5300199/+files/nextcloud-window.png

** Package changed: ubuntu-docs (Ubuntu) => gnome-online-accounts
(Ubuntu)

** Changed in: gnome-online-accounts (Ubuntu)
   Status: New => Incomplete

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gnome-online-accounts in
Ubuntu.
https://bugs.launchpad.net/bugs/1849907

Title:
  Add Online Account Nextcloud no Apply button

Status in gnome-online-accounts package in Ubuntu:
  Incomplete

Bug description:
  I am trying to add an online account, nextcloud

  three fields show, server, username and password.

  There is no Apply or OK button.

  I cannot add the account.

  Resizing the window does not help. Fields just get longer, still no
  buttons.

  Ubuntu 19.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-online-accounts/+bug/1849907/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849907] [NEW] Add Online Account Nextcloud no Apply button

2019-10-25 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

I am trying to add an online account, nextcloud

three fields show, server, username and password.

There is no Apply or OK button.

I cannot add the account.

Resizing the window does not help. Fields just get longer, still no
buttons.

Ubuntu 19.10

** Affects: gnome-online-accounts (Ubuntu)
 Importance: Undecided
 Status: Incomplete

-- 
Add Online Account Nextcloud no Apply button
https://bugs.launchpad.net/bugs/1849907
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to gnome-online-accounts in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1813400] Re: systemctl doesn't respect --dry-run

2019-10-25 Thread Doug Gale
Still happens on 237-3ubuntu10.31

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1813400

Title:
  systemctl doesn't respect --dry-run

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  [Expected behaviour]

  When I use the --dry-run flag with systemctl, I would expect it not to
  take any action, but instead print what it is going to do.

  [Actual behaviour]

  Passing --dry-run doesn't affect the behaviour of systemctl.

  [Test case]

  $ systemctl --dry-run reboot

  Ubuntu version: 18.04.1
  systemd version: 237-3ubuntu10.11

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1813400/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1813400] Re: systemctl doesn't respect --dry-run

2019-10-25 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: systemd (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1813400

Title:
  systemctl doesn't respect --dry-run

Status in systemd package in Ubuntu:
  Confirmed

Bug description:
  [Expected behaviour]

  When I use the --dry-run flag with systemctl, I would expect it not to
  take any action, but instead print what it is going to do.

  [Actual behaviour]

  Passing --dry-run doesn't affect the behaviour of systemctl.

  [Test case]

  $ systemctl --dry-run reboot

  Ubuntu version: 18.04.1
  systemd version: 237-3ubuntu10.11

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1813400/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1734167] Re: DNS doesn't work in no-cloud as launched by ubuntu

2019-10-25 Thread Joshua Powers
** Changed in: cloud-init
   Status: Confirmed => Fix Released

** Changed in: cloud-init (Ubuntu Artful)
   Status: Confirmed => Won't Fix

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1734167

Title:
  DNS doesn't work in no-cloud as launched by ubuntu

Status in cloud-init:
  Fix Released
Status in cloud-init package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Fix Released
Status in cloud-init source package in Zesty:
  Fix Released
Status in systemd source package in Zesty:
  Fix Released
Status in cloud-init source package in Artful:
  Won't Fix
Status in systemd source package in Artful:
  Fix Released
Status in systemd source package in Bionic:
  Fix Released

Bug description:
  [Impact]

   * resolved does not start early enough in the boot-process preventing
  DNS resolution to be operational during early boot, for example as
  required by special early stages of cloud-init, resulting in failure
  to boot / provision the instance fully.

  [Test Case]

   * Boot container or a VM with a nocloud-net data source, and a URL pointing 
to the datasource as explained below
   * Observe that boot completes and provisioning is successful
   * Check that there are no dns-resolution errors in the cloud-init log / boot 
log

  [Regression Potential]

   * starting resolved earlier may prevent it from connecting to dbus,
  and may require a restart later on when re-triggered over dbus. This
  is on artful only, as in bionic resolved has gained ability to
  reconnected to dbus post-start. Backporting that, however, is too
  large for an SRU as it requires sd-bus changes.

  [Other Info]
   
   * Original bug report.

  I use no-cloud to test the kernel in CI (I am maintainer of the bcache
  subsystem), and have been running it successfully under 16.04 cloud
  images from qemu, using a qemu command that includes:

  -smbios "type=1,serial=ds=nocloud-
  net;s=https://raw.githubusercontent.com/mlyle/mlyle/master/cloud-
  metadata/linuxtst/"

  As documented here:

  http://cloudinit.readthedocs.io/en/latest/topics/datasources/nocloud.html

  Under the new 17.10 cloud images, this doesn't work: the network comes
  up, but name resolution doesn't work-- /etc/resolv.conf is a symlink
  to a nonexistent file at this point of the boot and systemd-resolved
  is not running.  When I manually hack /etc/resolv.conf in the cloud
  image to point to 4.2.2.1 it works fine.

  I don't know if nameservice not working is by design, but it seems
  like it should work.  The documentation states:

  "With ds=nocloud-net, the seedfrom value must start with http://,
  https:// or ftp://;

  And https is not going to work for a raw IP address.

  Related bugs:
   * bug 1734939: #include fails silently.

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-init/+bug/1734167/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837170] Re: Kodi package crash after the update of libdrm-amdgpu1

2019-10-25 Thread Tom Lake
Kodi devs-team were very conservative they would not help and asked me
to wait Ubuntu fix the bug.

Kodi is a reference to a bug that affects every graphical software
installed.

I'm observing every new mesa and kernels upgrades, I'll keep informing.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1837170

Title:
  Kodi package crash after the update of libdrm-amdgpu1

Status in mesa package in Ubuntu:
  Incomplete

Bug description:
  Greetings,

  The last update of libdrm-amdgpu1 caused a bug on Kodi package, making
  it to crash after loading any video or reproduce a black image.

  Version: 2.4.97-1ubuntu1~18.04.12019-07-03 15:07:54 UTC

libdrm (2.4.97-1ubuntu1~18.04.1) bionic; urgency=medium

* Backport to bionic for 18.04.3 HWE stack update. (LP: #1824111)

   -- Timo Aaltonen  Wed, 10 Apr 2019 13:54:06
  +0300

  
  Kodi gives this error:

  #3  0x7f47676c60aa in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
  #4  0x7f47676c5dd7 in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

  Repeated several times

  #3  0x7f475ce2c5a6 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1
  #4  0x7f475ce2c425 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1

  Team-Kodi stated these errors are in relation to 'Not supported GPU
  drivers', when Kodi can't find these files.

  
  I've found the cause, and a temporary solution:

  This bug was caused after an update for the latest version of libdrm-
  amdgpu1 2.4.97-1ubuntu1~18.04.1

  So I grabbed the previous version from 
  https://mirror.transip.net/ubuntu/ubuntu/pool/main/libd/libdrm/

  installed libdrm-amdgpu1_2.4.95-1~18.04.1_amd64.deb

  and now Kodi returns.

  
  I created a bug report, the problem affects multiple users.

  https://bugs.launchpad.net/ubuntu/+source/kodi/+bug/1836828

  
  We have a PointRelease coming soon, would we have time to fix this package?

  Thank you for your assistance.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1837170/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1647638] Re: W: APT had planned for dpkg to do more than it reported back

2019-10-25 Thread arturo
bueno pero en conclusión que se puede hacer con ese error

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1647638

Title:
  W: APT had planned for dpkg to do more than it reported back

Status in apt package in Ubuntu:
  Confirmed

Bug description:
  I noticed that base-files was not completely installed and meant to
  fix it with "sudo apt-get install --reinstall base-files". This
  resulted in the following output.

  $ LANG=C sudo apt-get install --reinstall base-files
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  The following packages were automatically installed and are no longer 
required:
linux-headers-4.9.0-4 linux-headers-4.9.0-4-generic 
linux-image-4.9.0-4-generic linux-image-extra-4.9.0-4-generic
  Use 'sudo apt autoremove' to remove them.
  0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 13 not upgraded.
  Need to get 0 B/56,9 kB of archives.
  After this operation, 0 B of additional disk space will be used.
  (Reading database ... 598721 files and directories currently installed.)
  Preparing to unpack .../base-files_9.6ubuntu8_amd64.deb ...
  Unpacking base-files (9.6ubuntu8) over (9.6ubuntu8) ...
  Setting up base-files (9.6ubuntu8) ...
  Processing triggers for install-info (6.3.0.dfsg.1-1) ...
  Processing triggers for cracklib-runtime (2.9.2-3) ...
  Processing triggers for plymouth-theme-ubuntu-gnome-text (16.10.5) ...
  update-initramfs: deferring update (trigger activated)
  Processing triggers for man-db (2.7.5-2) ...
  Processing triggers for initramfs-tools (0.125ubuntu8) ...
  update-initramfs: Generating /boot/initrd.img-4.9.0-8-generic
  W: APT had planned for dpkg to do more than it reported back (4 vs 6).
 Affected packages: base-files:amd64

  
  $ lsb_release -a
  No LSB modules are available.
  Distributor ID:   Ubuntu
  Description:  Ubuntu Zesty Zapus (development branch)
  Release:  17.04
  Codename: zesty

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1647638/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837170] Re: Kodi package crash after the update of libdrm-amdgpu1

2019-10-25 Thread Tom Lake
No, Kodi does not crash anymore with x-swat and since official mesa
19.0.8-0ubuntu0~18.04.2

But it's followed by another problem, it's not 100% solved.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1837170

Title:
  Kodi package crash after the update of libdrm-amdgpu1

Status in mesa package in Ubuntu:
  Incomplete

Bug description:
  Greetings,

  The last update of libdrm-amdgpu1 caused a bug on Kodi package, making
  it to crash after loading any video or reproduce a black image.

  Version: 2.4.97-1ubuntu1~18.04.12019-07-03 15:07:54 UTC

libdrm (2.4.97-1ubuntu1~18.04.1) bionic; urgency=medium

* Backport to bionic for 18.04.3 HWE stack update. (LP: #1824111)

   -- Timo Aaltonen  Wed, 10 Apr 2019 13:54:06
  +0300

  
  Kodi gives this error:

  #3  0x7f47676c60aa in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
  #4  0x7f47676c5dd7 in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

  Repeated several times

  #3  0x7f475ce2c5a6 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1
  #4  0x7f475ce2c425 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1

  Team-Kodi stated these errors are in relation to 'Not supported GPU
  drivers', when Kodi can't find these files.

  
  I've found the cause, and a temporary solution:

  This bug was caused after an update for the latest version of libdrm-
  amdgpu1 2.4.97-1ubuntu1~18.04.1

  So I grabbed the previous version from 
  https://mirror.transip.net/ubuntu/ubuntu/pool/main/libd/libdrm/

  installed libdrm-amdgpu1_2.4.95-1~18.04.1_amd64.deb

  and now Kodi returns.

  
  I created a bug report, the problem affects multiple users.

  https://bugs.launchpad.net/ubuntu/+source/kodi/+bug/1836828

  
  We have a PointRelease coming soon, would we have time to fix this package?

  Thank you for your assistance.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1837170/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849873] Re: Cannot compile programs that use gtk.h and -Werror

2019-10-25 Thread Sebastien Bacher
** Changed in: gtk+2.0 (Ubuntu)
   Importance: Undecided => Low

** Changed in: gtk+2.0 (Ubuntu)
   Status: New => Triaged

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1849873

Title:
  Cannot compile programs that use gtk.h and -Werror

Status in gtk+2.0 package in Ubuntu:
  Triaged

Bug description:
  To reproduce:

  sudo apt install libgtk2.0-dev && echo "#include " > foo.c
  && gcc -Werror -c foo.c $(pkg-config --cflags gtk+-2.0) || echo FAIL

  Should complete silently and produce foo.o, but instead, fails as
  follows:

  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  libgtk2.0-dev is already the newest version (2.24.32-4ubuntu1).
  libgtk2.0-dev set to manually installed.
  0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
  In file included from /usr/include/gtk-2.0/gtk/gtkobject.h:37,
   from /usr/include/gtk-2.0/gtk/gtkwidget.h:36,
   from /usr/include/gtk-2.0/gtk/gtkcontainer.h:35,
   from /usr/include/gtk-2.0/gtk/gtkbin.h:35,
   from /usr/include/gtk-2.0/gtk/gtkwindow.h:36,
   from /usr/include/gtk-2.0/gtk/gtkdialog.h:35,
   from /usr/include/gtk-2.0/gtk/gtkaboutdialog.h:32,
   from /usr/include/gtk-2.0/gtk/gtk.h:33,
   from foo.c:1:
  /usr/include/gtk-2.0/gtk/gtktypeutils.h:236:1: error: ‘GTypeDebugFlags’ is 
deprecated [-Werror=deprecated-declarations]
236 | voidgtk_type_init   (GTypeDebugFlagsdebug_flags);
| ^~~~
  In file included from /usr/include/glib-2.0/gobject/gobject.h:24,
   from /usr/include/glib-2.0/gobject/gbinding.h:29,
   from /usr/include/glib-2.0/glib-object.h:23,
   from /usr/include/glib-2.0/gio/gioenums.h:28,
   from /usr/include/glib-2.0/gio/giotypes.h:28,
   from /usr/include/glib-2.0/gio/gio.h:26,
   from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
   from /usr/include/gtk-2.0/gdk/gdk.h:32,
   from /usr/include/gtk-2.0/gtk/gtk.h:32,
   from foo.c:1:
  /usr/include/glib-2.0/gobject/gtype.h:679:1: note: declared here
679 | {
| ^
  In file included from /usr/include/gtk-2.0/gtk/gtktoolitem.h:31,
   from /usr/include/gtk-2.0/gtk/gtktoolbutton.h:30,
   from /usr/include/gtk-2.0/gtk/gtkmenutoolbutton.h:30,
   from /usr/include/gtk-2.0/gtk/gtk.h:126,
   from foo.c:1:
  /usr/include/gtk-2.0/gtk/gtktooltips.h:73:3: error: ‘GTimeVal’ is deprecated: 
Use 'GDateTime' instead [-Werror=deprecated-declarations]
 73 |   GTimeVal last_popdown;
|   ^~~~
  In file included from /usr/include/glib-2.0/glib/galloca.h:32,
   from /usr/include/glib-2.0/glib.h:30,
   from /usr/include/glib-2.0/gobject/gbinding.h:28,
   from /usr/include/glib-2.0/glib-object.h:23,
   from /usr/include/glib-2.0/gio/gioenums.h:28,
   from /usr/include/glib-2.0/gio/giotypes.h:28,
   from /usr/include/glib-2.0/gio/gio.h:26,
   from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
   from /usr/include/gtk-2.0/gdk/gdk.h:32,
   from /usr/include/gtk-2.0/gtk/gtk.h:32,
   from foo.c:1:
  /usr/include/glib-2.0/glib/gtypes.h:551:8: note: declared here
551 | struct _GTimeVal
|^
  cc1: all warnings being treated as errors
  FAIL

  This is a regression since ubuntu 19.04.

  Noticed while building cef.

  Workaround: -DGTK_DISABLE_DEPRECATED

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: libgtk2.0-dev 2.24.32-4ubuntu1
  ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
  Uname: Linux 5.3.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  Date: Fri Oct 25 09:48:14 2019
  InstallationDate: Installed on 2019-10-18 (7 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  SourcePackage: gtk+2.0
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/1849873/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1816657] Re: Auditd Segfaults When Starting after Reboot

2019-10-25 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: audit (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to audit in Ubuntu.
https://bugs.launchpad.net/bugs/1816657

Title:
  Auditd Segfaults When Starting after Reboot

Status in audit package in Ubuntu:
  Confirmed

Bug description:
  In Bionic with auditd 1:2.8.2-1ubuntu1 and an /etc/audit/auditd.conf
  present, auditd segfaults after every reboot.  If I manually install
  auditd 1:2.8.3-1ubuntu2 from Cosmic, the issue is corrected. It seems
  the bugfix wasn't backported to Bionic.  It seems to be related to
  this issue reported with RHEL
  https://bugzilla.redhat.com/show_bug.cgi?id=1587995.

  Version
  Description:  Ubuntu 18.04.1 LTS
  Release:  18.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/audit/+bug/1816657/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849714] Re: failure to install repos for raspberry pi

2019-10-25 Thread Kenneth Zadeck
This is not unreasonable given that I have not been able to find a
simple way to reproduce the first failure.   I will focus on the long
list of easily repeatable problems with this port.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1849714

Title:
  failure to install repos for raspberry pi

Status in software-properties package in Ubuntu:
  Invalid

Bug description:
  following the directions about 1/5 down the page of
  https://wiki.ubuntu.com/ARM/RaspberryPi

  sudo add-apt-repository ppa:ubuntu-raspi2/ppa
  Cannot add PPA: 'ppa:~ubuntu-raspi2/ubuntu/ppa'.
  ERROR: '~ubuntu-raspi2' user or team does not exist.

  This seems like a failure to me.

  shire:~(13) lsb_release -rd
  Description:  Ubuntu 19.10
  Release:  19.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1849714/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849886] Re: lightdm does not work on eoan on raspberry pi 4

2019-10-25 Thread Kenneth Zadeck
change the term "blank screen" to "unresponsive blank screen" in the
above.   Sorry

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1849886

Title:
  lightdm does not work on eoan on raspberry pi 4

Status in software-properties package in Ubuntu:
  New

Bug description:
  if you follow the directions on
  https://wiki.ubuntu.com/ARM/RaspberryPi

  sudo apt-get install xubuntu-desktop

  about 20% thru the installation it will ask which window manager you want 
(using dpkg-reconfigure).
  if you select lightdm, you will only get a blank greeter screen after you 
reboot.

  using sudo dpkg-reconfigure gdm3

  resets this to gdm3 and after a reboot, everything is fine.

  this was done on a clean armhf eoan install on a 4gb raspberry pi 4B.

  I have done the install several times.   This bug is repeatable.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1849886/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849886] [NEW] lightdm does not work on eoan on raspberry pi 4

2019-10-25 Thread Kenneth Zadeck
Public bug reported:

if you follow the directions on https://wiki.ubuntu.com/ARM/RaspberryPi

sudo apt-get install xubuntu-desktop

about 20% thru the installation it will ask which window manager you want 
(using dpkg-reconfigure).
if you select lightdm, you will only get a blank greeter screen after you 
reboot.

using sudo dpkg-reconfigure gdm3

resets this to gdm3 and after a reboot, everything is fine.

this was done on a clean armhf eoan install on a 4gb raspberry pi 4B.

I have done the install several times.   This bug is repeatable.

** Affects: software-properties (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1849886

Title:
  lightdm does not work on eoan on raspberry pi 4

Status in software-properties package in Ubuntu:
  New

Bug description:
  if you follow the directions on
  https://wiki.ubuntu.com/ARM/RaspberryPi

  sudo apt-get install xubuntu-desktop

  about 20% thru the installation it will ask which window manager you want 
(using dpkg-reconfigure).
  if you select lightdm, you will only get a blank greeter screen after you 
reboot.

  using sudo dpkg-reconfigure gdm3

  resets this to gdm3 and after a reboot, everything is fine.

  this was done on a clean armhf eoan install on a 4gb raspberry pi 4B.

  I have done the install several times.   This bug is repeatable.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1849886/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1846539]

2019-10-25 Thread david.ward
This is a duplicate of bug 204237.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1846539

Title:
  [broadwell-rt286, playback] Since Linux 5.2rc2 audio playback no
  longer works on Dell Venue 11 Pro 7140

Status in Linux:
  Invalid
Status in alsa-driver package in Ubuntu:
  New
Status in linux package in Ubuntu:
  New

Bug description:
  Hello!

  I noticed that since Linux 5.2rc2 audio playback no longer works on
  Dell Venue 11 Pro 7140 (Intel Core M-5Y71; rt286). Turns out that
  happened because SND_SOC_SOF_BROADWELL_SUPPORT was enabled in kernel
  binary builds since 5.2rc2: https://kernel.ubuntu.com/~kernel-
  ppa/mainline/v5.2-rc2/

  To verify this assumption I tested two builds of Linux 5.3.1.
  1. Build with enabled SND_SOC_SOF_BROADWELL_SUPPORT from 
https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.3.1/

  Audio playback doesn't work, dmesg:
  [4.072800] snd_hda_intel :00:03.0: bound :00:02.0 (ops 
i915_audio_component_bind_ops [i915])
  [4.212606] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.238009] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.294920] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.407351] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.428922] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.458926] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.472113] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for 
intel/IntcPP01.bin failed with error -2
  [4.472118] haswell-pcm-audio haswell-pcm-audio: fw image 
intel/IntcPP01.bin not available(-2)
  [4.472735] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox 
readback FW info: type 01, - version: 00.00, build 77, source commit id: 
876ac6906f31a43b6772b23c7c983ce9dcb18a19
  [4.474607] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System 
Pin mapping ok
  [4.474676] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload0 Pin mapping ok
  [4.474741] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload1 Pin mapping ok
  [4.474807] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Loopback Pin mapping ok
  [4.476377] broadwell-audio broadwell-audio: rt286-aif1 <-> 
snd-soc-dummy-dai mapping ok
  [4.480344] input: broadwell-rt286 Headset as 
/devices/pci:00/INT3438:00/broadwell-audio/sound/card1/input14
  [7.892659] haswell-pcm-audio haswell-pcm-audio: error: message type 7 
header 0x8700
  [   13.015379] haswell-pcm-audio haswell-pcm-audio: error: reset stream 2 
still running
  [   13.127262] haswell-pcm-audio haswell-pcm-audio: error: reset stream 0 
still running
  [   19.623436] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- 
ipcx 0x8612 isr 0x ipcd 0x4700 imrx 0x7fff
  [   19.623446] haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 
faile

  2. Build with disabled SND_SOC_SOF_BROADWELL_SUPPORT.

  Audio playback works, dmesg:
  [4.839028] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for 
intel/IntcPP01.bin failed with error -2
  [4.839034] haswell-pcm-audio haswell-pcm-audio: fw image 
intel/IntcPP01.bin not available(-2)
  [4.839644] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox 
readback FW info: type 01, - version: 00.00, build 77, source commit id: 
876ac6906f31a43b6772b23c7c983ce9dcb18a19
  [4.851204] snd_hda_intel :00:03.0: bound :00:02.0 (ops 
i915_audio_component_bind_ops [i915])
  [4.907386] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System 
Pin mapping ok
  [4.907475] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload0 Pin mapping ok
  [4.909831] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload1 Pin mapping ok
  [4.909931] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Loopback Pin mapping ok
  [4.912149] broadwell-audio broadwell-audio: rt286-aif1 <-> 
snd-soc-dummy-dai mapping ok
  [4.929629] input: broadwell-rt286 Headset as 
/devices/pci:00/INT3438:00/broadwell-audio/sound/card1/input14

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
  Uname: Linux 5.3.0-13-generic x86_64
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  irina   818 F pulseaudio
   /dev/snd/controlC0:  irina   818 F pulseaudio
  CurrentDesktop: GNOME
  Date: Fri Oct  4 01:22:54 2019
  InstallationDate: Installed on 2019-02-12 (233 days ago)
  InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 

[Touch-packages] [Bug 1846539]

2019-10-25 Thread russianneuromancer
*** This bug has been marked as a duplicate of bug 204237 ***

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1846539

Title:
  [broadwell-rt286, playback] Since Linux 5.2rc2 audio playback no
  longer works on Dell Venue 11 Pro 7140

Status in Linux:
  Invalid
Status in alsa-driver package in Ubuntu:
  New
Status in linux package in Ubuntu:
  New

Bug description:
  Hello!

  I noticed that since Linux 5.2rc2 audio playback no longer works on
  Dell Venue 11 Pro 7140 (Intel Core M-5Y71; rt286). Turns out that
  happened because SND_SOC_SOF_BROADWELL_SUPPORT was enabled in kernel
  binary builds since 5.2rc2: https://kernel.ubuntu.com/~kernel-
  ppa/mainline/v5.2-rc2/

  To verify this assumption I tested two builds of Linux 5.3.1.
  1. Build with enabled SND_SOC_SOF_BROADWELL_SUPPORT from 
https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.3.1/

  Audio playback doesn't work, dmesg:
  [4.072800] snd_hda_intel :00:03.0: bound :00:02.0 (ops 
i915_audio_component_bind_ops [i915])
  [4.212606] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.238009] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.294920] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.407351] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.428922] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.458926] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.472113] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for 
intel/IntcPP01.bin failed with error -2
  [4.472118] haswell-pcm-audio haswell-pcm-audio: fw image 
intel/IntcPP01.bin not available(-2)
  [4.472735] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox 
readback FW info: type 01, - version: 00.00, build 77, source commit id: 
876ac6906f31a43b6772b23c7c983ce9dcb18a19
  [4.474607] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System 
Pin mapping ok
  [4.474676] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload0 Pin mapping ok
  [4.474741] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload1 Pin mapping ok
  [4.474807] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Loopback Pin mapping ok
  [4.476377] broadwell-audio broadwell-audio: rt286-aif1 <-> 
snd-soc-dummy-dai mapping ok
  [4.480344] input: broadwell-rt286 Headset as 
/devices/pci:00/INT3438:00/broadwell-audio/sound/card1/input14
  [7.892659] haswell-pcm-audio haswell-pcm-audio: error: message type 7 
header 0x8700
  [   13.015379] haswell-pcm-audio haswell-pcm-audio: error: reset stream 2 
still running
  [   13.127262] haswell-pcm-audio haswell-pcm-audio: error: reset stream 0 
still running
  [   19.623436] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- 
ipcx 0x8612 isr 0x ipcd 0x4700 imrx 0x7fff
  [   19.623446] haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 
faile

  2. Build with disabled SND_SOC_SOF_BROADWELL_SUPPORT.

  Audio playback works, dmesg:
  [4.839028] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for 
intel/IntcPP01.bin failed with error -2
  [4.839034] haswell-pcm-audio haswell-pcm-audio: fw image 
intel/IntcPP01.bin not available(-2)
  [4.839644] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox 
readback FW info: type 01, - version: 00.00, build 77, source commit id: 
876ac6906f31a43b6772b23c7c983ce9dcb18a19
  [4.851204] snd_hda_intel :00:03.0: bound :00:02.0 (ops 
i915_audio_component_bind_ops [i915])
  [4.907386] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System 
Pin mapping ok
  [4.907475] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload0 Pin mapping ok
  [4.909831] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload1 Pin mapping ok
  [4.909931] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Loopback Pin mapping ok
  [4.912149] broadwell-audio broadwell-audio: rt286-aif1 <-> 
snd-soc-dummy-dai mapping ok
  [4.929629] input: broadwell-rt286 Headset as 
/devices/pci:00/INT3438:00/broadwell-audio/sound/card1/input14

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
  Uname: Linux 5.3.0-13-generic x86_64
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  irina   818 F pulseaudio
   /dev/snd/controlC0:  irina   818 F pulseaudio
  CurrentDesktop: GNOME
  Date: Fri Oct  4 01:22:54 2019
  InstallationDate: Installed on 2019-02-12 (233 days ago)
  InstallationMedia: Ubuntu 18.10 "Cosmic 

[Touch-packages] [Bug 1846539] Re: [broadwell-rt286, playback] Since Linux 5.2rc2 audio playback no longer works on Dell Venue 11 Pro 7140

2019-10-25 Thread Bug Watch Updater
** Changed in: linux
   Status: Confirmed => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1846539

Title:
  [broadwell-rt286, playback] Since Linux 5.2rc2 audio playback no
  longer works on Dell Venue 11 Pro 7140

Status in Linux:
  Invalid
Status in alsa-driver package in Ubuntu:
  New
Status in linux package in Ubuntu:
  New

Bug description:
  Hello!

  I noticed that since Linux 5.2rc2 audio playback no longer works on
  Dell Venue 11 Pro 7140 (Intel Core M-5Y71; rt286). Turns out that
  happened because SND_SOC_SOF_BROADWELL_SUPPORT was enabled in kernel
  binary builds since 5.2rc2: https://kernel.ubuntu.com/~kernel-
  ppa/mainline/v5.2-rc2/

  To verify this assumption I tested two builds of Linux 5.3.1.
  1. Build with enabled SND_SOC_SOF_BROADWELL_SUPPORT from 
https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.3.1/

  Audio playback doesn't work, dmesg:
  [4.072800] snd_hda_intel :00:03.0: bound :00:02.0 (ops 
i915_audio_component_bind_ops [i915])
  [4.212606] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.238009] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.294920] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.407351] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.428922] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.458926] broadwell-audio broadwell-audio: ASoC: failed to init link 
System PCM: -517
  [4.472113] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for 
intel/IntcPP01.bin failed with error -2
  [4.472118] haswell-pcm-audio haswell-pcm-audio: fw image 
intel/IntcPP01.bin not available(-2)
  [4.472735] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox 
readback FW info: type 01, - version: 00.00, build 77, source commit id: 
876ac6906f31a43b6772b23c7c983ce9dcb18a19
  [4.474607] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System 
Pin mapping ok
  [4.474676] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload0 Pin mapping ok
  [4.474741] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload1 Pin mapping ok
  [4.474807] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Loopback Pin mapping ok
  [4.476377] broadwell-audio broadwell-audio: rt286-aif1 <-> 
snd-soc-dummy-dai mapping ok
  [4.480344] input: broadwell-rt286 Headset as 
/devices/pci:00/INT3438:00/broadwell-audio/sound/card1/input14
  [7.892659] haswell-pcm-audio haswell-pcm-audio: error: message type 7 
header 0x8700
  [   13.015379] haswell-pcm-audio haswell-pcm-audio: error: reset stream 2 
still running
  [   13.127262] haswell-pcm-audio haswell-pcm-audio: error: reset stream 0 
still running
  [   19.623436] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- 
ipcx 0x8612 isr 0x ipcd 0x4700 imrx 0x7fff
  [   19.623446] haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 
faile

  2. Build with disabled SND_SOC_SOF_BROADWELL_SUPPORT.

  Audio playback works, dmesg:
  [4.839028] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for 
intel/IntcPP01.bin failed with error -2
  [4.839034] haswell-pcm-audio haswell-pcm-audio: fw image 
intel/IntcPP01.bin not available(-2)
  [4.839644] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox 
readback FW info: type 01, - version: 00.00, build 77, source commit id: 
876ac6906f31a43b6772b23c7c983ce9dcb18a19
  [4.851204] snd_hda_intel :00:03.0: bound :00:02.0 (ops 
i915_audio_component_bind_ops [i915])
  [4.907386] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System 
Pin mapping ok
  [4.907475] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload0 Pin mapping ok
  [4.909831] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Offload1 Pin mapping ok
  [4.909931] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> 
Loopback Pin mapping ok
  [4.912149] broadwell-audio broadwell-audio: rt286-aif1 <-> 
snd-soc-dummy-dai mapping ok
  [4.929629] input: broadwell-rt286 Headset as 
/devices/pci:00/INT3438:00/broadwell-audio/sound/card1/input14

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: alsa-base 1.0.25+dfsg-0ubuntu5
  ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
  Uname: Linux 5.3.0-13-generic x86_64
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  irina   818 F pulseaudio
   /dev/snd/controlC0:  irina   818 F pulseaudio
  CurrentDesktop: GNOME
  Date: Fri Oct  4 01:22:54 2019
  InstallationDate: Installed on 2019-02-12 (233 days ago)
  InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" 

[Touch-packages] [Bug 1848036] Re: Inconsistent use of spaces

2019-10-25 Thread Launchpad Bug Tracker
This bug was fixed in the package unattended-upgrades - 1.15

---
unattended-upgrades (1.15) unstable; urgency=medium

  [ Tobias Bannert ]
  * update german translation.
Improved some formulations and punctuation.

  [ Maarten ]
  * Update Dutch translation (Closes: #941672)

  [ Balint Reczey ]
  * autopkgtest: Retry failing downloads a few times
  * test/autopkgtest_kernel_patterns.py: Add debug statements
  * test/autopkgtest_kernel_patterns.py: Use stricter pattern for
packages to check
  * debian/tests/control: Mark upgrade-between-snapshots as flaky
(Closes: #941752)
  * Fix whitespace (LP: #1848036)
  * Explain sanity check failures better
  * Adjust only direct dependencies when falling back to adjusting more
packages.
Adjusting all transitive dependencies is found to slow down upgrades too
much when many packages were upgradable but not with adjustments taking
place. If a package upgrade to be installed by unattended-upgrades requires
adjusting a transitive but not direct dependency, please add this
dependency as a direct dependency of the package to unlock the upgrade.
(Closes: #935653) (LP: #1848357)
  * debian/tests/common-functions: Don't sleep after successful u-u run

 -- Balint Reczey   Tue, 22 Oct 2019 18:48:33 +0200

** Changed in: unattended-upgrades (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unattended-upgrades in
Ubuntu.
https://bugs.launchpad.net/bugs/1848036

Title:
  Inconsistent use of spaces

Status in unattended-upgrades package in Ubuntu:
  Fix Released

Bug description:
  # pkgs that are (for some reason) not safe to install
  blacklist = get_blacklist()
  logging.info(_("Initial blacklist : %s"),
   " ".join(blacklist))

  # install only these packages regardless of other upgrades available
  whitelist = get_whitelist()
  logging.info(_("Initial whitelist: %s"),
   " ".join(whitelist))

  This looks particularly odd when installing with subiquity as some of
  the last messages displayed are:

  Initial blacklist :
  Initial whitelist:

  See the attached screenshot if you want more proof.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1848036/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848357] Re: Adjusting transitive dependencies of packages slows down unattended-upgrades a lot

2019-10-25 Thread Launchpad Bug Tracker
This bug was fixed in the package unattended-upgrades - 1.15

---
unattended-upgrades (1.15) unstable; urgency=medium

  [ Tobias Bannert ]
  * update german translation.
Improved some formulations and punctuation.

  [ Maarten ]
  * Update Dutch translation (Closes: #941672)

  [ Balint Reczey ]
  * autopkgtest: Retry failing downloads a few times
  * test/autopkgtest_kernel_patterns.py: Add debug statements
  * test/autopkgtest_kernel_patterns.py: Use stricter pattern for
packages to check
  * debian/tests/control: Mark upgrade-between-snapshots as flaky
(Closes: #941752)
  * Fix whitespace (LP: #1848036)
  * Explain sanity check failures better
  * Adjust only direct dependencies when falling back to adjusting more
packages.
Adjusting all transitive dependencies is found to slow down upgrades too
much when many packages were upgradable but not with adjustments taking
place. If a package upgrade to be installed by unattended-upgrades requires
adjusting a transitive but not direct dependency, please add this
dependency as a direct dependency of the package to unlock the upgrade.
(Closes: #935653) (LP: #1848357)
  * debian/tests/common-functions: Don't sleep after successful u-u run

 -- Balint Reczey   Tue, 22 Oct 2019 18:48:33 +0200

** Changed in: unattended-upgrades (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unattended-upgrades in
Ubuntu.
https://bugs.launchpad.net/bugs/1848357

Title:
  Adjusting transitive dependencies of packages slows down unattended-
  upgrades a lot

Status in unattended-upgrades package in Ubuntu:
  Fix Released

Bug description:
  [Impact]

   * Unattended-upgrades tries to mark packages for upgrade and when it
  fails to do so and falls back to mark adjusting packages to use
  candidates from allowed origins it can spend a lot of CPU time on
  packages which are not installable in the end.

  [Test Case]

   * Mark an upgradable package from the security pocket as held.
   * Observe u-u adjusting only direct dependencies, instead of doing it 
recursively.

  [Regression Potential]

   * U-u may fail to install updates due to APT not finding a solution
  without having transitive dependences adjusted. In those cases the
  update should mark the transitive dependencies which enable the update
  as direct dependencies.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1848357/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837170] Re: Kodi package crash after the update of libdrm-amdgpu1

2019-10-25 Thread Timo Aaltonen
This bug is about kodi crashing, so does it crash with 19.2.1 or not?

If you have other issues, test with 19.10 and then file them upstream.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1837170

Title:
  Kodi package crash after the update of libdrm-amdgpu1

Status in mesa package in Ubuntu:
  Incomplete

Bug description:
  Greetings,

  The last update of libdrm-amdgpu1 caused a bug on Kodi package, making
  it to crash after loading any video or reproduce a black image.

  Version: 2.4.97-1ubuntu1~18.04.12019-07-03 15:07:54 UTC

libdrm (2.4.97-1ubuntu1~18.04.1) bionic; urgency=medium

* Backport to bionic for 18.04.3 HWE stack update. (LP: #1824111)

   -- Timo Aaltonen  Wed, 10 Apr 2019 13:54:06
  +0300

  
  Kodi gives this error:

  #3  0x7f47676c60aa in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
  #4  0x7f47676c5dd7 in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

  Repeated several times

  #3  0x7f475ce2c5a6 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1
  #4  0x7f475ce2c425 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1

  Team-Kodi stated these errors are in relation to 'Not supported GPU
  drivers', when Kodi can't find these files.

  
  I've found the cause, and a temporary solution:

  This bug was caused after an update for the latest version of libdrm-
  amdgpu1 2.4.97-1ubuntu1~18.04.1

  So I grabbed the previous version from 
  https://mirror.transip.net/ubuntu/ubuntu/pool/main/libd/libdrm/

  installed libdrm-amdgpu1_2.4.95-1~18.04.1_amd64.deb

  and now Kodi returns.

  
  I created a bug report, the problem affects multiple users.

  https://bugs.launchpad.net/ubuntu/+source/kodi/+bug/1836828

  
  We have a PointRelease coming soon, would we have time to fix this package?

  Thank you for your assistance.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1837170/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837170] Re: Kodi package crash after the update of libdrm-amdgpu1

2019-10-25 Thread Timo Aaltonen
as for testing more AMD hw, (accelerated) media decoding is not within
the scope of hw enablement as required by the OEM's (on any GPU)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1837170

Title:
  Kodi package crash after the update of libdrm-amdgpu1

Status in mesa package in Ubuntu:
  Incomplete

Bug description:
  Greetings,

  The last update of libdrm-amdgpu1 caused a bug on Kodi package, making
  it to crash after loading any video or reproduce a black image.

  Version: 2.4.97-1ubuntu1~18.04.12019-07-03 15:07:54 UTC

libdrm (2.4.97-1ubuntu1~18.04.1) bionic; urgency=medium

* Backport to bionic for 18.04.3 HWE stack update. (LP: #1824111)

   -- Timo Aaltonen  Wed, 10 Apr 2019 13:54:06
  +0300

  
  Kodi gives this error:

  #3  0x7f47676c60aa in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
  #4  0x7f47676c5dd7 in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

  Repeated several times

  #3  0x7f475ce2c5a6 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1
  #4  0x7f475ce2c425 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1

  Team-Kodi stated these errors are in relation to 'Not supported GPU
  drivers', when Kodi can't find these files.

  
  I've found the cause, and a temporary solution:

  This bug was caused after an update for the latest version of libdrm-
  amdgpu1 2.4.97-1ubuntu1~18.04.1

  So I grabbed the previous version from 
  https://mirror.transip.net/ubuntu/ubuntu/pool/main/libd/libdrm/

  installed libdrm-amdgpu1_2.4.95-1~18.04.1_amd64.deb

  and now Kodi returns.

  
  I created a bug report, the problem affects multiple users.

  https://bugs.launchpad.net/ubuntu/+source/kodi/+bug/1836828

  
  We have a PointRelease coming soon, would we have time to fix this package?

  Thank you for your assistance.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1837170/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Touch-packages] [Bug 1671951] Re: networkd should allow configuring IPV6 MTU

2019-10-25 Thread Ryan Harper
On Fri, Oct 25, 2019 at 1:31 PM Dan Streetman 
wrote:

> I looked at this for a few minutes, and it seems strange that it works
> at all (at boot) since networkd sets the ipv6 mtu before bringing the
> link up, but the kernel resets the ipv6 mtu to the device mtu on link
> up.  I must be missing something.
>

I'm glad you saw that.  I'm seeing this as well on my curtin vmtest
(automated deployment and data collection during first boot).

I have to restart networkd for it to work on the first boot.
Subsequent boots it seems to work fine without a restart of networkd.


> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1671951
>
> Title:
>   networkd should allow configuring IPV6 MTU
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1671951/+subscriptions
>

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1671951

Title:
  networkd should allow configuring IPV6 MTU

Status in cloud-init package in Ubuntu:
  Confirmed
Status in netplan.io package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Fix Released
Status in cloud-init source package in Bionic:
  Confirmed
Status in netplan.io source package in Bionic:
  Fix Released
Status in systemd source package in Bionic:
  Triaged
Status in cloud-init source package in Disco:
  New
Status in netplan.io source package in Disco:
  Fix Released
Status in systemd source package in Disco:
  Triaged

Bug description:
  = netplan.io =

  [Impact]

   * IPv6 traffic failing to send/receive due to incompatible/low MTU
  setting. Specifically, IPv6 traffic may have higher MTU requirements
  than IPv4 traffic and thus may need to be overridden and/or set to a
  higher value than IPv6 traffic.

  [Test Case]
   * Apply a netplan configuration that specifices ipv6-mtu:

  network:
version: 2
ethernets:
  eth0:
dhcp4: true
dhcp6: true
ipv6-mtu: 6000

   * Check that MTU bytes, is at least IPv6MTUBytes on the interface:

  $ sysctl net.ipv6.conf.eth0.mtu
  net.ipv6.conf.eth0.mtu = 6000

  [Regression Potential]

   * This is a future compatible backport of an additional keyword not
  used by default. It may result in MTU change to a higher value, which
  should not cause loss of connectivity.

  [Other Info]

   * Original bug report below

  = end of netplan.io =

  = systemd =

  [Impact]

   * IPv6 traffic failing to send/receive due to incompatible/low MTU
  setting. Specifically, IPv6 traffic may have higher MTU requirements
  than IPv4 traffic and thus may need to be overridden and/or set to a
  higher value than IPv6 traffic.

  [Test Case]

   * Use IPv6MTUBytes= setting in a .network unit
   * Restart systemd-network
   * Check that there no error messages / warnings about not-recognizing this 
option
   * Check that MTU bytes, is at least IPv6MTUBytes on the interface

  [Regression Potential]

   * This is a future compatible backport of an additional keyword not
  used by default. It may result in MTU change to a higher value, which
  should not cause loss of connectivity.

  [Other Info]

   * Original bug report below

  = end of systemd =

  1) Zesty
  2) systemd-232-19
  3) I need to configure the IPV6 MTU for tunneling by adding an 
IPv6MTUBytes=1480 value in the .network file for an interface with an IPV6 
static address in the [Network] section
  4) networkd does not parse or read the value and does not apply this 
configuration to the interface.

  Upstream has discussed this issue here:

  https://github.com/systemd/systemd/pull/1533

  But it's been closed in favor of only setting via RA.

  However, we know of multiple use-case which are currently supported in
  ifdupdown where we want to retain control over IPV6 MTU values outside
  of PMTU Discovery configurations.

  Some context from those discussions

  >> Client systems that route their ipv6 packets to a 6in4 router also
  >> have to have their ipv6 mtu lowered.  They could lower their link mtu,
  >> so their ipv6 packets are small enough, but that reduces performance
  >> of their ipv4 network.

  Yes.  Anything that creates a PMTUD black hole can result in
  situations where the higher header overhead of IPv6 will cause IPv4 to
  pass but IPv6 traffic to be dropped.

  One example here is egress from an ipsec tunnel wherein the next
  hop MTU is too low for IPv6 datagrams to pass.  Another is VM ->
  whatever -> host bridge -> tunnel ingress.  If the datagram cannot enter
  the tunnel due to size, it is dropped, and an ICMP response uses the
  tunnel address as a source, which may not be routable back to the
  origin.  This one is an issue with IPv4 as well, and is one case where
  manually setting the IPv6 MTU lower than the (also manually set) device
  MTU is of benefit.


[Touch-packages] [Bug 1849873] Re: Cannot compile programs that use gtk.h and -Werror

2019-10-25 Thread Dan Kegel
Filed https://gitlab.gnome.org/GNOME/gtk/issues/2221 in case it's an upstream 
bug.
I'll probably regret that.

** Bug watch added: gitlab.gnome.org/GNOME/gtk/issues #2221
   https://gitlab.gnome.org/GNOME/gtk/issues/2221

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1849873

Title:
  Cannot compile programs that use gtk.h and -Werror

Status in gtk+2.0 package in Ubuntu:
  New

Bug description:
  To reproduce:

  sudo apt install libgtk2.0-dev && echo "#include " > foo.c
  && gcc -Werror -c foo.c $(pkg-config --cflags gtk+-2.0) || echo FAIL

  Should complete silently and produce foo.o, but instead, fails as
  follows:

  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  libgtk2.0-dev is already the newest version (2.24.32-4ubuntu1).
  libgtk2.0-dev set to manually installed.
  0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
  In file included from /usr/include/gtk-2.0/gtk/gtkobject.h:37,
   from /usr/include/gtk-2.0/gtk/gtkwidget.h:36,
   from /usr/include/gtk-2.0/gtk/gtkcontainer.h:35,
   from /usr/include/gtk-2.0/gtk/gtkbin.h:35,
   from /usr/include/gtk-2.0/gtk/gtkwindow.h:36,
   from /usr/include/gtk-2.0/gtk/gtkdialog.h:35,
   from /usr/include/gtk-2.0/gtk/gtkaboutdialog.h:32,
   from /usr/include/gtk-2.0/gtk/gtk.h:33,
   from foo.c:1:
  /usr/include/gtk-2.0/gtk/gtktypeutils.h:236:1: error: ‘GTypeDebugFlags’ is 
deprecated [-Werror=deprecated-declarations]
236 | voidgtk_type_init   (GTypeDebugFlagsdebug_flags);
| ^~~~
  In file included from /usr/include/glib-2.0/gobject/gobject.h:24,
   from /usr/include/glib-2.0/gobject/gbinding.h:29,
   from /usr/include/glib-2.0/glib-object.h:23,
   from /usr/include/glib-2.0/gio/gioenums.h:28,
   from /usr/include/glib-2.0/gio/giotypes.h:28,
   from /usr/include/glib-2.0/gio/gio.h:26,
   from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
   from /usr/include/gtk-2.0/gdk/gdk.h:32,
   from /usr/include/gtk-2.0/gtk/gtk.h:32,
   from foo.c:1:
  /usr/include/glib-2.0/gobject/gtype.h:679:1: note: declared here
679 | {
| ^
  In file included from /usr/include/gtk-2.0/gtk/gtktoolitem.h:31,
   from /usr/include/gtk-2.0/gtk/gtktoolbutton.h:30,
   from /usr/include/gtk-2.0/gtk/gtkmenutoolbutton.h:30,
   from /usr/include/gtk-2.0/gtk/gtk.h:126,
   from foo.c:1:
  /usr/include/gtk-2.0/gtk/gtktooltips.h:73:3: error: ‘GTimeVal’ is deprecated: 
Use 'GDateTime' instead [-Werror=deprecated-declarations]
 73 |   GTimeVal last_popdown;
|   ^~~~
  In file included from /usr/include/glib-2.0/glib/galloca.h:32,
   from /usr/include/glib-2.0/glib.h:30,
   from /usr/include/glib-2.0/gobject/gbinding.h:28,
   from /usr/include/glib-2.0/glib-object.h:23,
   from /usr/include/glib-2.0/gio/gioenums.h:28,
   from /usr/include/glib-2.0/gio/giotypes.h:28,
   from /usr/include/glib-2.0/gio/gio.h:26,
   from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
   from /usr/include/gtk-2.0/gdk/gdk.h:32,
   from /usr/include/gtk-2.0/gtk/gtk.h:32,
   from foo.c:1:
  /usr/include/glib-2.0/glib/gtypes.h:551:8: note: declared here
551 | struct _GTimeVal
|^
  cc1: all warnings being treated as errors
  FAIL

  This is a regression since ubuntu 19.04.

  Noticed while building cef.

  Workaround: -DGTK_DISABLE_DEPRECATED

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: libgtk2.0-dev 2.24.32-4ubuntu1
  ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
  Uname: Linux 5.3.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  Date: Fri Oct 25 09:48:14 2019
  InstallationDate: Installed on 2019-10-18 (7 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  SourcePackage: gtk+2.0
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/1849873/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849883] [NEW] Xorg freeze, rapid flickering, unresponsive

2019-10-25 Thread Karl Lindheimer
Public bug reported:

This problem occurs when accessing the systems "setting" menu only after
you try to select "devices" such as printers.  The display goes haywire
and refuses to respond to users selections.  The only way to recover is
to right-click the gnome menu icon on the left side of screen and
selecting "force quit"

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
Uname: Linux 5.3.0-19-generic x86_64
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Fri Oct 25 14:08:37 2019
DistUpgraded: Fresh install
DistroCodename: eoan
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GpuHangFrequency: Several times a day
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter 
[80ee:beef] (prog-if 00 [VGA controller])
InstallationDate: Installed on 2019-10-18 (7 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 008: ID 80ee:0021 VirtualBox USB Tablet
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-19-generic 
root=UUID=cca44654-6594-409b-a6ac-6e15ad57bf83 ro quiet splash
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: 
dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.family: Virtual Machine
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

** Affects: xorg (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug eoan freeze ubuntu

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1849883

Title:
  Xorg freeze, rapid flickering, unresponsive

Status in xorg package in Ubuntu:
  New

Bug description:
  This problem occurs when accessing the systems "setting" menu only
  after you try to select "devices" such as printers.  The display goes
  haywire and refuses to respond to users selections.  The only way to
  recover is to right-click the gnome menu icon on the left side of
  screen and selecting "force quit"

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
  Uname: Linux 5.3.0-19-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Fri Oct 25 14:08:37 2019
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
  GpuHangFrequency: Several times a day
  GpuHangReproducibility: Yes, I can easily reproduce it
  GpuHangStarted: Immediately after installing this version of Ubuntu
  GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter 
[80ee:beef] (prog-if 00 [VGA controller])
  InstallationDate: Installed on 2019-10-18 (7 days ago)
  InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 008: ID 80ee:0021 VirtualBox USB Tablet
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: innotek GmbH VirtualBox
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-19-generic 
root=UUID=cca44654-6594-409b-a6ac-6e15ad57bf83 ro quiet splash
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  

[Touch-packages] [Bug 1849835] Re: add-apt-repository does not work in focal

2019-10-25 Thread sudodus
That was really fast response, or I think a bugfix independent of my bug
report. Anyway, in the recently zsynced new daily iso file

add-apt-repository

works in Lubuntu focal :-)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1849835

Title:
  add-apt-repository does not work in focal

Status in software-properties package in Ubuntu:
  New

Bug description:
  I tested to use a ppa because I wanted to test if mkusb will work in
  focal. But

  add-apt-repository

  does not work.

  ---
  lubuntu@lubuntu:~$ sudo add-apt-repository ppa:mkusb/ppa  # existing ppa
  Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 107, in 
  sp = SoftwareProperties(options=options)
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
118, in __init__
  self.reload_sourceslist()
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
613, in reload_sourceslist
  self.distro.get_sources(self.sourceslist)
File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in 
get_sources
  (self.id, self.codename))
  aptsources.distro.NoDistroTemplateException: Error: could not find a 
distribution template for Ubuntu/focal
  lubuntu@lubuntu:~$ sudo add-apt-repository ppa:qwerty/asdf  # not existing 
ppa: same output
  Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 107, in 
  sp = SoftwareProperties(options=options)
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
118, in __init__
  self.reload_sourceslist()
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
613, in reload_sourceslist
  self.distro.get_sources(self.sourceslist)
File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in 
get_sources
  (self.id, self.codename))
  aptsources.distro.NoDistroTemplateException: Error: could not find a 
distribution template for Ubuntu/focal
  lubuntu@lubuntu:~$ lsb_release -a
  No LSB modules are available.
  Distributor ID: Ubuntu
  Description:Ubuntu Focal Fossa (development branch)
  Release:20.04
  Codename:   focal
  lubuntu@lubuntu:~$ 
  ---

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: software-properties-common 0.98.5
  ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
  Uname: Linux 5.3.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CasperVersion: 1.427
  CurrentDesktop: LXQt
  Date: Fri Oct 25 13:10:33 2019
  LiveMediaBuild: Lubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20191024)
  PackageArchitecture: all
  SourcePackage: software-properties
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1849835/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1671951] Re: networkd should allow configuring IPV6 MTU

2019-10-25 Thread Dan Streetman
I looked at this for a few minutes, and it seems strange that it works
at all (at boot) since networkd sets the ipv6 mtu before bringing the
link up, but the kernel resets the ipv6 mtu to the device mtu on link
up.  I must be missing something.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1671951

Title:
  networkd should allow configuring IPV6 MTU

Status in cloud-init package in Ubuntu:
  Confirmed
Status in netplan.io package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Fix Released
Status in cloud-init source package in Bionic:
  Confirmed
Status in netplan.io source package in Bionic:
  Fix Released
Status in systemd source package in Bionic:
  Triaged
Status in cloud-init source package in Disco:
  New
Status in netplan.io source package in Disco:
  Fix Released
Status in systemd source package in Disco:
  Triaged

Bug description:
  = netplan.io =

  [Impact]

   * IPv6 traffic failing to send/receive due to incompatible/low MTU
  setting. Specifically, IPv6 traffic may have higher MTU requirements
  than IPv4 traffic and thus may need to be overridden and/or set to a
  higher value than IPv6 traffic.

  [Test Case]
   * Apply a netplan configuration that specifices ipv6-mtu:

  network:
version: 2
ethernets:
  eth0:
dhcp4: true
dhcp6: true
ipv6-mtu: 6000

   * Check that MTU bytes, is at least IPv6MTUBytes on the interface:

  $ sysctl net.ipv6.conf.eth0.mtu
  net.ipv6.conf.eth0.mtu = 6000

  [Regression Potential]

   * This is a future compatible backport of an additional keyword not
  used by default. It may result in MTU change to a higher value, which
  should not cause loss of connectivity.

  [Other Info]

   * Original bug report below

  = end of netplan.io =

  = systemd =

  [Impact]

   * IPv6 traffic failing to send/receive due to incompatible/low MTU
  setting. Specifically, IPv6 traffic may have higher MTU requirements
  than IPv4 traffic and thus may need to be overridden and/or set to a
  higher value than IPv6 traffic.

  [Test Case]

   * Use IPv6MTUBytes= setting in a .network unit
   * Restart systemd-network
   * Check that there no error messages / warnings about not-recognizing this 
option
   * Check that MTU bytes, is at least IPv6MTUBytes on the interface

  [Regression Potential]

   * This is a future compatible backport of an additional keyword not
  used by default. It may result in MTU change to a higher value, which
  should not cause loss of connectivity.

  [Other Info]

   * Original bug report below

  = end of systemd =

  1) Zesty
  2) systemd-232-19
  3) I need to configure the IPV6 MTU for tunneling by adding an 
IPv6MTUBytes=1480 value in the .network file for an interface with an IPV6 
static address in the [Network] section
  4) networkd does not parse or read the value and does not apply this 
configuration to the interface.

  Upstream has discussed this issue here:

  https://github.com/systemd/systemd/pull/1533

  But it's been closed in favor of only setting via RA.

  However, we know of multiple use-case which are currently supported in
  ifdupdown where we want to retain control over IPV6 MTU values outside
  of PMTU Discovery configurations.

  Some context from those discussions

  >> Client systems that route their ipv6 packets to a 6in4 router also
  >> have to have their ipv6 mtu lowered.  They could lower their link mtu,
  >> so their ipv6 packets are small enough, but that reduces performance
  >> of their ipv4 network.

  Yes.  Anything that creates a PMTUD black hole can result in
  situations where the higher header overhead of IPv6 will cause IPv4 to
  pass but IPv6 traffic to be dropped.

  One example here is egress from an ipsec tunnel wherein the next
  hop MTU is too low for IPv6 datagrams to pass.  Another is VM ->
  whatever -> host bridge -> tunnel ingress.  If the datagram cannot enter
  the tunnel due to size, it is dropped, and an ICMP response uses the
  tunnel address as a source, which may not be routable back to the
  origin.  This one is an issue with IPv4 as well, and is one case where
  manually setting the IPv6 MTU lower than the (also manually set) device
  MTU is of benefit.

  In essence, any of these sort of cases that require an explicit
  setting of the device MTU will likely require a setting of the IPv6 mtu
  as well to account for its larger header overhead.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1671951/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849878] [NEW] Debu1: SSH2_MSG_KEXINIT sent

2019-10-25 Thread ivannamp
Public bug reported:

I try to make the connection with an NSA that lives on the same network
of my Ubuntu 1804 server, however performing authentication via SSH
hangs in Debu1: SSH2_MSG_KEXINIT sent. Tracked error: Conection closed

** Affects: openssh (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1849878

Title:
  Debu1: SSH2_MSG_KEXINIT sent

Status in openssh package in Ubuntu:
  New

Bug description:
  I try to make the connection with an NSA that lives on the same
  network of my Ubuntu 1804 server, however performing authentication
  via SSH hangs in Debu1: SSH2_MSG_KEXINIT sent. Tracked error:
  Conection closed

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1849878/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849714] Re: failure to install repos for raspberry pi

2019-10-25 Thread Brian Murray
The are no packages for Ubuntu 19.10 (Eoan) in that PPA. I'll contact
someone who can update the wiki page, but I'm setting this bug to
Invalid.

** Changed in: software-properties (Ubuntu)
   Status: Incomplete => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1849714

Title:
  failure to install repos for raspberry pi

Status in software-properties package in Ubuntu:
  Invalid

Bug description:
  following the directions about 1/5 down the page of
  https://wiki.ubuntu.com/ARM/RaspberryPi

  sudo add-apt-repository ppa:ubuntu-raspi2/ppa
  Cannot add PPA: 'ppa:~ubuntu-raspi2/ubuntu/ppa'.
  ERROR: '~ubuntu-raspi2' user or team does not exist.

  This seems like a failure to me.

  shire:~(13) lsb_release -rd
  Description:  Ubuntu 19.10
  Release:  19.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1849714/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1671951] Re: networkd should allow configuring IPV6 MTU

2019-10-25 Thread Mathieu Trudel-Lapierre
Thanks. Let's put both tasks as Triaged again then, since it's obviously
not fixed in disco and bionic.

I don't think this qualifies as a regression though, since the feature
was never available before. It's just not finished since the systemd
side of this isn't complete.

** Changed in: systemd (Ubuntu Bionic)
   Status: Fix Released => Triaged

** Changed in: systemd (Ubuntu Disco)
   Status: New => Triaged

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1671951

Title:
  networkd should allow configuring IPV6 MTU

Status in cloud-init package in Ubuntu:
  Confirmed
Status in netplan.io package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Fix Released
Status in cloud-init source package in Bionic:
  Confirmed
Status in netplan.io source package in Bionic:
  Fix Released
Status in systemd source package in Bionic:
  Triaged
Status in cloud-init source package in Disco:
  New
Status in netplan.io source package in Disco:
  Fix Released
Status in systemd source package in Disco:
  Triaged

Bug description:
  = netplan.io =

  [Impact]

   * IPv6 traffic failing to send/receive due to incompatible/low MTU
  setting. Specifically, IPv6 traffic may have higher MTU requirements
  than IPv4 traffic and thus may need to be overridden and/or set to a
  higher value than IPv6 traffic.

  [Test Case]
   * Apply a netplan configuration that specifices ipv6-mtu:

  network:
version: 2
ethernets:
  eth0:
dhcp4: true
dhcp6: true
ipv6-mtu: 6000

   * Check that MTU bytes, is at least IPv6MTUBytes on the interface:

  $ sysctl net.ipv6.conf.eth0.mtu
  net.ipv6.conf.eth0.mtu = 6000

  [Regression Potential]

   * This is a future compatible backport of an additional keyword not
  used by default. It may result in MTU change to a higher value, which
  should not cause loss of connectivity.

  [Other Info]

   * Original bug report below

  = end of netplan.io =

  = systemd =

  [Impact]

   * IPv6 traffic failing to send/receive due to incompatible/low MTU
  setting. Specifically, IPv6 traffic may have higher MTU requirements
  than IPv4 traffic and thus may need to be overridden and/or set to a
  higher value than IPv6 traffic.

  [Test Case]

   * Use IPv6MTUBytes= setting in a .network unit
   * Restart systemd-network
   * Check that there no error messages / warnings about not-recognizing this 
option
   * Check that MTU bytes, is at least IPv6MTUBytes on the interface

  [Regression Potential]

   * This is a future compatible backport of an additional keyword not
  used by default. It may result in MTU change to a higher value, which
  should not cause loss of connectivity.

  [Other Info]

   * Original bug report below

  = end of systemd =

  1) Zesty
  2) systemd-232-19
  3) I need to configure the IPV6 MTU for tunneling by adding an 
IPv6MTUBytes=1480 value in the .network file for an interface with an IPV6 
static address in the [Network] section
  4) networkd does not parse or read the value and does not apply this 
configuration to the interface.

  Upstream has discussed this issue here:

  https://github.com/systemd/systemd/pull/1533

  But it's been closed in favor of only setting via RA.

  However, we know of multiple use-case which are currently supported in
  ifdupdown where we want to retain control over IPV6 MTU values outside
  of PMTU Discovery configurations.

  Some context from those discussions

  >> Client systems that route their ipv6 packets to a 6in4 router also
  >> have to have their ipv6 mtu lowered.  They could lower their link mtu,
  >> so their ipv6 packets are small enough, but that reduces performance
  >> of their ipv4 network.

  Yes.  Anything that creates a PMTUD black hole can result in
  situations where the higher header overhead of IPv6 will cause IPv4 to
  pass but IPv6 traffic to be dropped.

  One example here is egress from an ipsec tunnel wherein the next
  hop MTU is too low for IPv6 datagrams to pass.  Another is VM ->
  whatever -> host bridge -> tunnel ingress.  If the datagram cannot enter
  the tunnel due to size, it is dropped, and an ICMP response uses the
  tunnel address as a source, which may not be routable back to the
  origin.  This one is an issue with IPv4 as well, and is one case where
  manually setting the IPv6 MTU lower than the (also manually set) device
  MTU is of benefit.

  In essence, any of these sort of cases that require an explicit
  setting of the device MTU will likely require a setting of the IPv6 mtu
  as well to account for its larger header overhead.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1671951/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : 

[Touch-packages] [Bug 1707611] Re: Sound does not automatically switch to HDMI when connected

2019-10-25 Thread David
I tried it on the live session USB 3.0, Ubuntu 19.10 (I checked the disk
for defects: no errors found). I still had to manually enable the sound
over HDMI for the TV.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1707611

Title:
  Sound does not automatically switch to HDMI when connected

Status in pulseaudio package in Ubuntu:
  Incomplete

Bug description:
  When connecting a HDMI cable or other audio device, the user must
  manually click on the "sound volume" in the top-right and switch to
  the newly connected device.

  Example: you connect a HDMI cable to the television, but then you must
  manually choose the HDMI sound option; it does not get selected
  automatically.

  Often times e.g. when the HDMI cable is disconnected, the user must
  then manually click on the "speakers" or "line out" setting - EVEN IF
  IT'S ALREADY SELECTED, it must be clicked on again for the sound to
  work through the computer's speakers.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1707611/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849873] [NEW] Cannot compile programs that use gtk.h and -Werror

2019-10-25 Thread Dan Kegel
Public bug reported:

To reproduce:

sudo apt install libgtk2.0-dev && echo "#include " > foo.c &&
gcc -Werror -c foo.c $(pkg-config --cflags gtk+-2.0) || echo FAIL

Should complete silently and produce foo.o, but instead, fails as
follows:

Reading package lists... Done
Building dependency tree   
Reading state information... Done
libgtk2.0-dev is already the newest version (2.24.32-4ubuntu1).
libgtk2.0-dev set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
In file included from /usr/include/gtk-2.0/gtk/gtkobject.h:37,
 from /usr/include/gtk-2.0/gtk/gtkwidget.h:36,
 from /usr/include/gtk-2.0/gtk/gtkcontainer.h:35,
 from /usr/include/gtk-2.0/gtk/gtkbin.h:35,
 from /usr/include/gtk-2.0/gtk/gtkwindow.h:36,
 from /usr/include/gtk-2.0/gtk/gtkdialog.h:35,
 from /usr/include/gtk-2.0/gtk/gtkaboutdialog.h:32,
 from /usr/include/gtk-2.0/gtk/gtk.h:33,
 from foo.c:1:
/usr/include/gtk-2.0/gtk/gtktypeutils.h:236:1: error: ‘GTypeDebugFlags’ is 
deprecated [-Werror=deprecated-declarations]
  236 | voidgtk_type_init   (GTypeDebugFlagsdebug_flags);
  | ^~~~
In file included from /usr/include/glib-2.0/gobject/gobject.h:24,
 from /usr/include/glib-2.0/gobject/gbinding.h:29,
 from /usr/include/glib-2.0/glib-object.h:23,
 from /usr/include/glib-2.0/gio/gioenums.h:28,
 from /usr/include/glib-2.0/gio/giotypes.h:28,
 from /usr/include/glib-2.0/gio/gio.h:26,
 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
 from /usr/include/gtk-2.0/gdk/gdk.h:32,
 from /usr/include/gtk-2.0/gtk/gtk.h:32,
 from foo.c:1:
/usr/include/glib-2.0/gobject/gtype.h:679:1: note: declared here
  679 | {
  | ^
In file included from /usr/include/gtk-2.0/gtk/gtktoolitem.h:31,
 from /usr/include/gtk-2.0/gtk/gtktoolbutton.h:30,
 from /usr/include/gtk-2.0/gtk/gtkmenutoolbutton.h:30,
 from /usr/include/gtk-2.0/gtk/gtk.h:126,
 from foo.c:1:
/usr/include/gtk-2.0/gtk/gtktooltips.h:73:3: error: ‘GTimeVal’ is deprecated: 
Use 'GDateTime' instead [-Werror=deprecated-declarations]
   73 |   GTimeVal last_popdown;
  |   ^~~~
In file included from /usr/include/glib-2.0/glib/galloca.h:32,
 from /usr/include/glib-2.0/glib.h:30,
 from /usr/include/glib-2.0/gobject/gbinding.h:28,
 from /usr/include/glib-2.0/glib-object.h:23,
 from /usr/include/glib-2.0/gio/gioenums.h:28,
 from /usr/include/glib-2.0/gio/giotypes.h:28,
 from /usr/include/glib-2.0/gio/gio.h:26,
 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
 from /usr/include/gtk-2.0/gdk/gdk.h:32,
 from /usr/include/gtk-2.0/gtk/gtk.h:32,
 from foo.c:1:
/usr/include/glib-2.0/glib/gtypes.h:551:8: note: declared here
  551 | struct _GTimeVal
  |^
cc1: all warnings being treated as errors
FAIL

This is a regression since ubuntu 19.04.

Noticed while building cef.

Workaround: -DGTK_DISABLE_DEPRECATED

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: libgtk2.0-dev 2.24.32-4ubuntu1
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
Date: Fri Oct 25 09:48:14 2019
InstallationDate: Installed on 2019-10-18 (7 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
SourcePackage: gtk+2.0
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: gtk+2.0 (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to gtk+2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1849873

Title:
  Cannot compile programs that use gtk.h and -Werror

Status in gtk+2.0 package in Ubuntu:
  New

Bug description:
  To reproduce:

  sudo apt install libgtk2.0-dev && echo "#include " > foo.c
  && gcc -Werror -c foo.c $(pkg-config --cflags gtk+-2.0) || echo FAIL

  Should complete silently and produce foo.o, but instead, fails as
  follows:

  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  libgtk2.0-dev is already the newest version (2.24.32-4ubuntu1).
  libgtk2.0-dev set to manually installed.
  0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
  In file included from /usr/include/gtk-2.0/gtk/gtkobject.h:37,
   from /usr/include/gtk-2.0/gtk/gtkwidget.h:36,
   from /usr/include/gtk-2.0/gtk/gtkcontainer.h:35,
   from /usr/include/gtk-2.0/gtk/gtkbin.h:35,
   

[Touch-packages] [Bug 1835738] Autopkgtest regression report (python3-stdlib-extensions/3.7.5-1~19.04)

2019-10-25 Thread Ubuntu SRU Bot
All autopkgtests for the newly accepted python3-stdlib-extensions 
(3.7.5-1~19.04) for disco have finished running.
The following regressions have been reported in tests triggered by the package:

thonny/3.1.1-1 (s390x)
python3.8/3.8.0~a3-2 (amd64, arm64, s390x, i386, armhf, ppc64el)
pandas/unknown (armhf)


Please visit the excuses page listed below and investigate the failures, 
proceeding afterwards as per the StableReleaseUpdates policy regarding 
autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-
migration/disco/update_excuses.html#python3-stdlib-extensions

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python3-defaults in
Ubuntu.
https://bugs.launchpad.net/bugs/1835738

Title:
  SRU: Update Python interpreter to 3.6.9 and 3.7.5

Status in python3-defaults package in Ubuntu:
  New
Status in python3-stdlib-extensions package in Ubuntu:
  Fix Released
Status in python3.7 package in Ubuntu:
  Fix Released
Status in python3-defaults source package in Bionic:
  New
Status in python3-stdlib-extensions source package in Bionic:
  New
Status in python3.6 source package in Bionic:
  New
Status in python3.7 source package in Bionic:
  New
Status in python3-defaults source package in Disco:
  New
Status in python3-stdlib-extensions source package in Disco:
  Fix Committed
Status in python3.7 source package in Disco:
  New
Status in python3-defaults source package in Eoan:
  New
Status in python3-stdlib-extensions source package in Eoan:
  Fix Committed
Status in python3.7 source package in Eoan:
  Fix Committed

Bug description:
  Update Python interpreter to 3.6.9 and 3.7.5.  As done with earlier
  subminor upstream releases (LP: #1822993).

  SRU: update Python 3.7 to the 3.7.5 release, update Python 3.6 to the
  3.6.9 release.

  python3-stdlib-extensions also updates the modules to the 3.6.9
  release for Python 3.6.

  Acceptance Criteria: The package builds, and the test suite doesn't
  show regressions. The test suite passes in the autopkg tests. The new
  packages don't cause regressions in a test rebuild of the main
  component.

  TODO: update after test rebuild
  
http://people.canonical.com/~doko/ftbfs-report/test-rebuild-20190404-cosmic.html
  
http://people.canonical.com/~doko/ftbfs-report/test-rebuild-20190404-gcc8-cosmic.html

  The test rebuilds are finished, and don't show any regressions for the
  main component.

  Regression Potential: Python 3.7 isn't used by default, so we don't have many 
default users.
  Regression Potential: Python 3.6 could see some regressions, although we are 
trying to minimize the risk by doing the test rebuild.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python3-defaults/+bug/1835738/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1837170] Re: Kodi package crash after the update of libdrm-amdgpu1

2019-10-25 Thread Tom Lake
Just tested your ppa with mesa 19.2.1-1ubuntu1~18.04.1~ppa2, thank you

Since mesa 19.0.8-0ubuntu0~18.04.2 the image produced by Ubuntu with all
media players and browsers is very dark, like the contrast and black
levels were adjusted at a very low value. It became worse than before,
including yours from x-swat.

I noticed this contrast darkness increases progressively with each
kernel upgrade, starting from 5.0.0-27 to 5.0.0-32; I'm using 4.18.0-15
to minimize this effect.

I tested a Radeon R7 250 card, compatible with A-10 series APUs, and got
the exact same bug. So the problem is not only with AMD APUs, but with
the entire AMD R7 Graphics series, if not all AMD stack.

You guys need to test more AMD hardware.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1837170

Title:
  Kodi package crash after the update of libdrm-amdgpu1

Status in mesa package in Ubuntu:
  Incomplete

Bug description:
  Greetings,

  The last update of libdrm-amdgpu1 caused a bug on Kodi package, making
  it to crash after loading any video or reproduce a black image.

  Version: 2.4.97-1ubuntu1~18.04.12019-07-03 15:07:54 UTC

libdrm (2.4.97-1ubuntu1~18.04.1) bionic; urgency=medium

* Backport to bionic for 18.04.3 HWE stack update. (LP: #1824111)

   -- Timo Aaltonen  Wed, 10 Apr 2019 13:54:06
  +0300

  
  Kodi gives this error:

  #3  0x7f47676c60aa in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
  #4  0x7f47676c5dd7 in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

  Repeated several times

  #3  0x7f475ce2c5a6 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1
  #4  0x7f475ce2c425 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1

  Team-Kodi stated these errors are in relation to 'Not supported GPU
  drivers', when Kodi can't find these files.

  
  I've found the cause, and a temporary solution:

  This bug was caused after an update for the latest version of libdrm-
  amdgpu1 2.4.97-1ubuntu1~18.04.1

  So I grabbed the previous version from 
  https://mirror.transip.net/ubuntu/ubuntu/pool/main/libd/libdrm/

  installed libdrm-amdgpu1_2.4.95-1~18.04.1_amd64.deb

  and now Kodi returns.

  
  I created a bug report, the problem affects multiple users.

  https://bugs.launchpad.net/ubuntu/+source/kodi/+bug/1836828

  
  We have a PointRelease coming soon, would we have time to fix this package?

  Thank you for your assistance.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1837170/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849856] Re: ip commands error with mellanox devices in switchdev mode

2019-10-25 Thread James Page
Also tried with the iproute2 in bionic-backports - same result

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iproute2 in Ubuntu.
https://bugs.launchpad.net/bugs/1849856

Title:
  ip commands error with mellanox devices in switchdev mode

Status in iproute2 package in Ubuntu:
  New

Bug description:
  Kernel: using 5.0.0-23-generic from hwe-edge

  Configuring a mellanox connectx device with configured VF's into
  switchdev (rather than legacy) mode result in the ip cli tool erroring
  when trying to query the interface state:

  $ sudo ip link
  Error: Buffer too small for object.
  Dump terminated

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: iproute2 4.15.0-2ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
  Uname: Linux 5.0.0-23-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  Date: Fri Oct 25 14:55:36 2019
  ProcEnviron:
   TERM=screen-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: iproute2
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iproute2/+bug/1849856/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849856] [NEW] ip commands error with mellanox devices in switchdev mode

2019-10-25 Thread James Page
Public bug reported:

Kernel: using 5.0.0-23-generic from hwe-edge

Configuring a mellanox connectx device with configured VF's into
switchdev (rather than legacy) mode result in the ip cli tool erroring
when trying to query the interface state:

$ sudo ip link
Error: Buffer too small for object.
Dump terminated

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: iproute2 4.15.0-2ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
Uname: Linux 5.0.0-23-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
Date: Fri Oct 25 14:55:36 2019
ProcEnviron:
 TERM=screen-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: iproute2
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: iproute2 (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic uec-images

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to iproute2 in Ubuntu.
https://bugs.launchpad.net/bugs/1849856

Title:
  ip commands error with mellanox devices in switchdev mode

Status in iproute2 package in Ubuntu:
  New

Bug description:
  Kernel: using 5.0.0-23-generic from hwe-edge

  Configuring a mellanox connectx device with configured VF's into
  switchdev (rather than legacy) mode result in the ip cli tool erroring
  when trying to query the interface state:

  $ sudo ip link
  Error: Buffer too small for object.
  Dump terminated

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: iproute2 4.15.0-2ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
  Uname: Linux 5.0.0-23-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  Date: Fri Oct 25 14:55:36 2019
  ProcEnviron:
   TERM=screen-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=C.UTF-8
   SHELL=/bin/bash
  SourcePackage: iproute2
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/iproute2/+bug/1849856/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849733] Re: resolved incorrectly limits TCP reply to edns0 payload

2019-10-25 Thread Dan Streetman
** Description changed:

  [impact]
  
  glibc's getaddrinfo() uses EDNS0 to talk to resolved, and it sets its
  payload limit to 1200.  When the response is larger than 1200, resolved
  will limit the response and set the truncate flag.  This causes
  getaddrinfo() to switch to TCP and request again, but glibc incorrectly
  keeps the EDNS0 RR opt, with the same 1200 payload limit.  Most dns
  nameservers ignore EDNS0 payload limit for TCP, since per RFC it applies
  only to UDP, but resolved does not and again marks the response as
  truncated.  This prevents getaddrinfo() from being able to resolve any
  records with a response over 1200 bytes.
  
  [test case]
  
  use ping or telnet, which use getaddrinfo(), to lookup an A record with
  a lot of results, like toomany100.ddstreet.org
  
  $ telnet toomany100.ddstreet.org
  telnet: could not resolve toomany100.ddstreet.org/telnet: Temporary failure 
in name resolution
  
  [regression potential]
  
  any regression would likely result in failure to correctly lookup a
  hostname or to provide the correct response to a local client.
  
  [other info]
+ 
+ note that on Bionic, this also requires backporting TCP pipelining
+ support in the stub resolver.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1849733

Title:
  resolved incorrectly limits TCP reply to edns0 payload

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Bionic:
  In Progress
Status in systemd source package in Disco:
  In Progress
Status in systemd source package in Eoan:
  Fix Released

Bug description:
  [impact]

  glibc's getaddrinfo() uses EDNS0 to talk to resolved, and it sets its
  payload limit to 1200.  When the response is larger than 1200,
  resolved will limit the response and set the truncate flag.  This
  causes getaddrinfo() to switch to TCP and request again, but glibc
  incorrectly keeps the EDNS0 RR opt, with the same 1200 payload limit.
  Most dns nameservers ignore EDNS0 payload limit for TCP, since per RFC
  it applies only to UDP, but resolved does not and again marks the
  response as truncated.  This prevents getaddrinfo() from being able to
  resolve any records with a response over 1200 bytes.

  [test case]

  use ping or telnet, which use getaddrinfo(), to lookup an A record
  with a lot of results, like toomany100.ddstreet.org

  $ telnet toomany100.ddstreet.org
  telnet: could not resolve toomany100.ddstreet.org/telnet: Temporary failure 
in name resolution

  [regression potential]

  any regression would likely result in failure to correctly lookup a
  hostname or to provide the correct response to a local client.

  [other info]

  note that on Bionic, this also requires backporting TCP pipelining
  support in the stub resolver.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1849733/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849714] Re: failure to install repos for raspberry pi

2019-10-25 Thread Kenneth Zadeck
I reinstalled this morning and got a lot further, but it still does not
work.

The script now works but it does not find the repo

oot@ubuntu:/home/ubuntu# apt-get update
Hit:1 http://ports.ubuntu.com/ubuntu-ports eoan InRelease
Ign:2 http://ppa.launchpad.net/ubuntu-raspi2/ppa/ubuntu eoan InRelease
Hit:3 http://ports.ubuntu.com/ubuntu-ports eoan-updates InRelease
Hit:4 http://ports.ubuntu.com/ubuntu-ports eoan-backports InRelease
Err:5 http://ppa.launchpad.net/ubuntu-raspi2/ppa/ubuntu eoan Release
  404  Not Found [IP: 91.189.95.83 80]
Hit:6 http://ports.ubuntu.com/ubuntu-ports eoan-security InRelease
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/ubuntu-raspi2/ppa/ubuntu eoan 
Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore 
disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration 
details.

Is it the case that these packages are not yet there for eaon or that
they are not there for the rpi4 and the doc needs to be updated?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1849714

Title:
  failure to install repos for raspberry pi

Status in software-properties package in Ubuntu:
  Incomplete

Bug description:
  following the directions about 1/5 down the page of
  https://wiki.ubuntu.com/ARM/RaspberryPi

  sudo add-apt-repository ppa:ubuntu-raspi2/ppa
  Cannot add PPA: 'ppa:~ubuntu-raspi2/ubuntu/ppa'.
  ERROR: '~ubuntu-raspi2' user or team does not exist.

  This seems like a failure to me.

  shire:~(13) lsb_release -rd
  Description:  Ubuntu 19.10
  Release:  19.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1849714/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849835] Re: add-apt-repository does not work in focal

2019-10-25 Thread Ubuntu QA Website
This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1849835

** Tags added: iso-testing

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1849835

Title:
  add-apt-repository does not work in focal

Status in software-properties package in Ubuntu:
  New

Bug description:
  I tested to use a ppa because I wanted to test if mkusb will work in
  focal. But

  add-apt-repository

  does not work.

  ---
  lubuntu@lubuntu:~$ sudo add-apt-repository ppa:mkusb/ppa  # existing ppa
  Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 107, in 
  sp = SoftwareProperties(options=options)
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
118, in __init__
  self.reload_sourceslist()
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
613, in reload_sourceslist
  self.distro.get_sources(self.sourceslist)
File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in 
get_sources
  (self.id, self.codename))
  aptsources.distro.NoDistroTemplateException: Error: could not find a 
distribution template for Ubuntu/focal
  lubuntu@lubuntu:~$ sudo add-apt-repository ppa:qwerty/asdf  # not existing 
ppa: same output
  Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 107, in 
  sp = SoftwareProperties(options=options)
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
118, in __init__
  self.reload_sourceslist()
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
613, in reload_sourceslist
  self.distro.get_sources(self.sourceslist)
File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in 
get_sources
  (self.id, self.codename))
  aptsources.distro.NoDistroTemplateException: Error: could not find a 
distribution template for Ubuntu/focal
  lubuntu@lubuntu:~$ lsb_release -a
  No LSB modules are available.
  Distributor ID: Ubuntu
  Description:Ubuntu Focal Fossa (development branch)
  Release:20.04
  Codename:   focal
  lubuntu@lubuntu:~$ 
  ---

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: software-properties-common 0.98.5
  ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
  Uname: Linux 5.3.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CasperVersion: 1.427
  CurrentDesktop: LXQt
  Date: Fri Oct 25 13:10:33 2019
  LiveMediaBuild: Lubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20191024)
  PackageArchitecture: all
  SourcePackage: software-properties
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1849835/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1847980] Re: Lightdm is just a black screen when booting kernel 5.3 on an i5-6500, but kernels 5.0/5.2 work

2019-10-25 Thread Claudio Fior
The video works with kernel 5.4-rc4 form https://kernel.ubuntu.com
/~kernel-ppa/mainline/.

Thank you for your patience.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1847980

Title:
  Lightdm is just a black screen when booting kernel 5.3 on an i5-6500,
  but kernels 5.0/5.2 work

Status in lightdm package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in xorg-server package in Ubuntu:
  Confirmed

Bug description:
  Xorg freeze at boot on Intel Corporation HD Graphics 530 with 
linux-image-5.3.0-17 after upgraded to the development release Ubuntu Eoan 
Ermine (development branch).
  If i boot with linux-image-5.0.0-31-generic the Xorg works well.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.0.0-31.33-generic 5.0.21
  Uname: Linux 5.0.0-31-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  Date: Mon Oct 14 11:15:23 2019
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GpuHangFrequency: Continuously
  GpuHangReproducibility: Yes, I can easily reproduce it
  GpuHangStarted: Immediately after installing this version of Ubuntu
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-31-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  dmi.chassis.asset.tag: CZC64082W1
  dmi.chassis.type: 4
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrN01Ver.02.42:bd08/19/2019:svnHP:pnHPEliteDesk800G2SFF:pvr:rvnHP:rn8054:rvrKBCVersion05.36:cvnHP:ct4:cvr:
  dmi.product.family: 103C_53307F G=D
  dmi.product.name: HP EliteDesk 800 G2 SFF
  dmi.product.sku: X3J10ET#ABZ
  dmi.sys.vendor: HP
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.1-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroRelease: Ubuntu 19.10
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  Package: xorg-server (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-17-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro nomodeset 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  ProcVersionSignature: Ubuntu 5.3.0-17.18-generic 5.3.1
  Tags:  eoan ubuntu
  Uname: Linux 5.3.0-17-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  dmi.chassis.asset.tag: CZC64082W1
  

[Touch-packages] [Bug 1848354] Re: upgrade-between-snapshots autopkgtest is flaky

2019-10-25 Thread Balint Reczey
Tested unattended-upgrades/1.10ubuntu5.2 on Disco:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
/autopkgtest-disco/disco/amd64/u/unattended-
upgrades/20191025_130642_9d5e1@/log.gz

...
E: Failed to fetch 
http://snapshot.debian.org/archive/debian/20171001T00Z/pool/main/p/python3.5/python3.5_3.5.4-4_amd64.deb
  503  Service Unavailable
E: Unable to fetch some archives, maybe run apt-get update or try with 
--fix-missing?
autopkgtest [13:06:31]: test upgrade-between-snapshots: ---]
upgrade-between-snapshots FLAKY non-zero exit status 100
autopkgtest [13:06:31]: test upgrade-between-snapshots:  - - - - - - - - - - 
results - - - - - - - - - -
autopkgtest [13:06:31]:  summary
run-testsPASS
test-systemd.py  PASS
upgrade-all-security PASS
upgrade-between-snapshots FLAKY non-zero exit status 100
...

** Tags removed: verification-needed verification-needed-disco
** Tags added: verification-done verification-done-disco

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unattended-upgrades in
Ubuntu.
https://bugs.launchpad.net/bugs/1848354

Title:
  upgrade-between-snapshots autopkgtest is flaky

Status in unattended-upgrades package in Ubuntu:
  Fix Released
Status in unattended-upgrades source package in Xenial:
  Fix Committed
Status in unattended-upgrades source package in Bionic:
  Fix Committed
Status in unattended-upgrades source package in Disco:
  Fix Committed
Status in unattended-upgrades source package in Eoan:
  Fix Committed

Bug description:
  [Impact]

   * Flaky upgrade-between-snapshots autopkgtest prevents developers to
  use the test efficiently.

  [Test Case]

   * Run autopkgtests, observe the upgrade-between-snapshots test
  passing or failing but being marked as FLAKY.

  [Regression Potential]

   * None, the test was failing often due to connectivity/internal
  errors of snapshot.debian.org.

  [Other Info]

   * The whole autopkgtest is marked to be failing on amd64 to mitigate
  the single flaky test, this marking can be removed after marking this
  single flaky test.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1848354/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849835] [NEW] add-apt-repository does not work in focal

2019-10-25 Thread sudodus
Public bug reported:

I tested to use a ppa because I wanted to test if mkusb will work in
focal. But

add-apt-repository

does not work.

---
lubuntu@lubuntu:~$ sudo add-apt-repository ppa:mkusb/ppa  # existing ppa
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 107, in 
sp = SoftwareProperties(options=options)
  File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
118, in __init__
self.reload_sourceslist()
  File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
613, in reload_sourceslist
self.distro.get_sources(self.sourceslist)
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in 
get_sources
(self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a 
distribution template for Ubuntu/focal
lubuntu@lubuntu:~$ sudo add-apt-repository ppa:qwerty/asdf  # not existing ppa: 
same output
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 107, in 
sp = SoftwareProperties(options=options)
  File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
118, in __init__
self.reload_sourceslist()
  File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
613, in reload_sourceslist
self.distro.get_sources(self.sourceslist)
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in 
get_sources
(self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a 
distribution template for Ubuntu/focal
lubuntu@lubuntu:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:Ubuntu Focal Fossa (development branch)
Release:20.04
Codename:   focal
lubuntu@lubuntu:~$ 
---

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: software-properties-common 0.98.5
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
CasperVersion: 1.427
CurrentDesktop: LXQt
Date: Fri Oct 25 13:10:33 2019
LiveMediaBuild: Lubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20191024)
PackageArchitecture: all
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: software-properties (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to software-properties in
Ubuntu.
https://bugs.launchpad.net/bugs/1849835

Title:
  add-apt-repository does not work in focal

Status in software-properties package in Ubuntu:
  New

Bug description:
  I tested to use a ppa because I wanted to test if mkusb will work in
  focal. But

  add-apt-repository

  does not work.

  ---
  lubuntu@lubuntu:~$ sudo add-apt-repository ppa:mkusb/ppa  # existing ppa
  Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 107, in 
  sp = SoftwareProperties(options=options)
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
118, in __init__
  self.reload_sourceslist()
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
613, in reload_sourceslist
  self.distro.get_sources(self.sourceslist)
File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in 
get_sources
  (self.id, self.codename))
  aptsources.distro.NoDistroTemplateException: Error: could not find a 
distribution template for Ubuntu/focal
  lubuntu@lubuntu:~$ sudo add-apt-repository ppa:qwerty/asdf  # not existing 
ppa: same output
  Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 107, in 
  sp = SoftwareProperties(options=options)
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
118, in __init__
  self.reload_sourceslist()
File 
"/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 
613, in reload_sourceslist
  self.distro.get_sources(self.sourceslist)
File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in 
get_sources
  (self.id, self.codename))
  aptsources.distro.NoDistroTemplateException: Error: could not find a 
distribution template for Ubuntu/focal
  lubuntu@lubuntu:~$ lsb_release -a
  No LSB modules are available.
  Distributor ID: Ubuntu
  Description:Ubuntu Focal Fossa (development branch)
  Release:20.04
  Codename:   focal
  lubuntu@lubuntu:~$ 
  ---

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: software-properties-common 0.98.5
  ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
  Uname: Linux 5.3.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CasperVersion: 1.427
  CurrentDesktop: LXQt
  Date: Fri Oct 25 13:10:33 2019
 

[Touch-packages] [Bug 1848202] Re: Use after free in gdbus leads to eds segfaults

2019-10-25 Thread Iain Lane
** Also affects: glib2.0 (Ubuntu Eoan)
   Importance: Undecided
   Status: New

** Changed in: glib2.0 (Ubuntu)
   Status: New => In Progress

** Changed in: glib2.0 (Ubuntu Eoan)
   Status: New => In Progress

** Changed in: glib2.0 (Ubuntu)
 Assignee: (unassigned) => Iain Lane (laney)

** Changed in: glib2.0 (Ubuntu Eoan)
 Assignee: (unassigned) => Iain Lane (laney)

** Description changed:

+ [ Description ]
+ 
  The Ubuntu Error Tracker has been receiving reports about a problem regarding 
evolution-data-server.  This problem was most recently seen with package 
version 3.34.1-1, the problem page at 
https://errors.ubuntu.com/problem/b1f62616406e36e521fd1fb1d2be4ac2fe9a2cda 
contains more details, including versions of packages affected, stacktrace or 
traceback, and individual crash reports.
  If you do not have access to the Ubuntu Error Tracker and are a software 
developer, you can request it at http://forms.canonical.com/reports/.
+ 
+ [ Fix ]
+ 
+ This bug was fixed upstream in 2.62.2 (see the links below). That update
+ is being issues to eoan.
+ 
+ [ QA ]
+ 
+ Under https://wiki.ubuntu.com/StableReleaseUpdates/GNOME, we don't need
+ to explicitly test that this bug is fixed. Nevertheless, to verify this
+ bug please give the desktop a good workout. Ideally install the SRU and
+ use your machine as you would normally for a variety of tasks. Make sure
+ there are no regressions.
+ 
+ [ Regression potential ]
+ 
+ 1) The changes involve mutexes and stuff, which is error prone.
+ 
+ 2) It's GLib, a core library, so any bad regressions will be really
+ serious for the desktop as a whole.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to glib2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1848202

Title:
  Use after free in gdbus leads to eds segfaults

Status in GLib:
  Fix Released
Status in glib2.0 package in Ubuntu:
  In Progress
Status in glib2.0 source package in Eoan:
  In Progress

Bug description:
  [ Description ]

  The Ubuntu Error Tracker has been receiving reports about a problem regarding 
evolution-data-server.  This problem was most recently seen with package 
version 3.34.1-1, the problem page at 
https://errors.ubuntu.com/problem/b1f62616406e36e521fd1fb1d2be4ac2fe9a2cda 
contains more details, including versions of packages affected, stacktrace or 
traceback, and individual crash reports.
  If you do not have access to the Ubuntu Error Tracker and are a software 
developer, you can request it at http://forms.canonical.com/reports/.

  [ Fix ]

  This bug was fixed upstream in 2.62.2 (see the links below). That
  update is being issues to eoan.

  [ QA ]

  Under https://wiki.ubuntu.com/StableReleaseUpdates/GNOME, we don't
  need to explicitly test that this bug is fixed. Nevertheless, to
  verify this bug please give the desktop a good workout. Ideally
  install the SRU and use your machine as you would normally for a
  variety of tasks. Make sure there are no regressions.

  [ Regression potential ]

  1) The changes involve mutexes and stuff, which is error prone.

  2) It's GLib, a core library, so any bad regressions will be really
  serious for the desktop as a whole.

To manage notifications about this bug go to:
https://bugs.launchpad.net/glib/+bug/1848202/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1827253] Re: [apparmor] missing 'mr' on binary for usage on containers

2019-10-25 Thread Simon Déziel
Thanks Łukasz and Christian. I find the block-proposed-* tags idea
interesting if that's not too much work on your side.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to rsyslog in Ubuntu.
https://bugs.launchpad.net/bugs/1827253

Title:
  [apparmor] missing 'mr' on binary for usage on containers

Status in rsyslog package in Ubuntu:
  Fix Released
Status in rsyslog source package in Bionic:
  Triaged
Status in rsyslog source package in Disco:
  Triaged

Bug description:
  [Impact]

   * rsyslog ships with a (Default disable) apparmor profile.
   * Security sensitive users are in general encouraged to enable such
     profiles but unfortunately due to slightly new behavior of the program
     the profile prevents its usage.
   * Allow the program to map/read its binary to get this working again

  [Test Case]

  1) Create a 'eoan' container called rs1 here:
    lxc launch ubuntu-daily:e rs1
  2) Enter the container
    lxc shell rs1
  3) Enable apparmor profile
    rm /etc/apparmor.d/disable/usr.sbin.rsyslogd
    apparmor_parser -r -T -W /etc/apparmor.d/usr.sbin.rsyslogd
    systemctl restart rsyslog
  4) notice rsyslog failed to start
    systemctl status rsyslog

  [Regression Potential]

   * This is just opening up the apparmor profile a bit. Therefore the only
     regression it could cause IMHO is a security issue. But then what it
     actually allows is reading (not writing!) its own binary which should
     be very safe.
   * Thinking further it came to my mind that package updates (independent 
 to the change) might restart services and that means if there is any 
 issue e.g. in a local config that worked but now fails (not by this 
 change but in general) then the upgrade will not cause, but trigger 
 this. This is a general regression risk for any upload, but in this 
 case worth to mention as it is about log handling - which if broken - 
 makes large scale systems hard to debug.

  [Other Info]

   * n/a

  ---

  Issue description:

  Enabling the rsyslog (disabled by default) Apparmor profile causes
  rsyslog to fail to start when running *inside a container*.

  Steps to reproduce:

  1) Create a 'eoan' container called rs1 here:
    lxc launch ubuntu-daily:e rs1
  2) Enter the container
    lxc shell rs1
  3) Enable apparmor profile
    rm /etc/apparmor.d/disable/usr.sbin.rsyslogd
    apparmor_parser -r -T -W /etc/apparmor.d/usr.sbin.rsyslogd
    systemctl restart rsyslog
  4) notice rsyslog failed to start
    systemctl status rsyslog

  Workaround:

    echo '  /usr/sbin/rsyslogd mr,' >> /etc/apparmor.d/local/usr.sbin.rsyslogd
    apparmor_parser -r -T -W /etc/apparmor.d/usr.sbin.rsyslogd
    systemctl restart rsyslog

  Additional information:

  root@rs1:~# uname -a
  Linux rs1 4.15.0-48-generic #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019 x86_64 
x86_64 x86_64 GNU/Linux
  root@rs1:~# lsb_release -rd
  Description:  Ubuntu Eoan EANIMAL (development branch)
  Release:  19.10
  root@rs1:~# dpkg -l| grep -wE 'apparmor|rsyslog'
  ii  apparmor 2.13.2-9ubuntu6  amd64user-space parser utility for 
AppArmor
  ii  rsyslog  8.32.0-1ubuntu7  amd64reliable system and kernel logging 
daemon

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: rsyslog 8.32.0-1ubuntu7
  ProcVersionSignature: Ubuntu 4.15.0-48.51-generic 4.15.18
  Uname: Linux 4.15.0-48-generic x86_64
  ApportVersion: 2.20.10-0ubuntu27
  Architecture: amd64
  Date: Wed May  1 17:36:29 2019
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: rsyslog
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/rsyslog/+bug/1827253/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Bug Watch Updater
** Changed in: libseccomp
   Status: Unknown => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp:
  New
Status in libseccomp package in Ubuntu:
  Triaged
Status in libseccomp source package in Eoan:
  Triaged

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on i386/ppc64
  On x86_64 this test succeeds:

  Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

To manage notifications about this bug go to:
https://bugs.launchpad.net/libseccomp/+bug/1849785/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1790098] Autopkgtest regression report (network-manager/1.10.6-2ubuntu1.2)

2019-10-25 Thread Ubuntu SRU Bot
All autopkgtests for the newly accepted network-manager (1.10.6-2ubuntu1.2) for 
bionic have finished running.
The following regressions have been reported in tests triggered by the package:

network-manager/1.10.6-2ubuntu1.2 (amd64, arm64, i386, ppc64el)
systemd/237-3ubuntu10.31 (i386, ppc64el)
netplan.io/0.98-0ubuntu1~18.04.1 (arm64)


Please visit the excuses page listed below and investigate the failures, 
proceeding afterwards as per the StableReleaseUpdates policy regarding 
autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-
migration/bionic/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1790098

Title:
  vlan created on bond fails auto activation on updating parent network
  bond

Status in Ubuntu on IBM z Systems:
  Won't Fix
Status in network-manager package in Ubuntu:
  Won't Fix
Status in network-manager source package in Bionic:
  Fix Committed

Bug description:
  Auto activation of Vlan created over network-bond fails if bond is 
deactivated and reactivated.
   
  Contact Information = Abhiram Kulkarni(abhir...@in.ibm.com), Mandar 
Deshpande(manda...@in.ibm.com) 
   
  ---uname output---
  Linux S36MANDAR 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:14:23 UTC 2018 
s390x s390x s390x GNU/Linux
   
  Machine Type = s390x 
   
  ---Debugger---
  A debugger is not configured
   
  ---Steps to Reproduce---
   1. Created a network bond with static IP address (and no IPv6 address); 
active backup mode; ARP polling; single slave.

  2. Created a VLAN using said network bond with static IPv4 address
  (and no IPv6 address).

  3. Can ping from the appliance to a target on both links (the parent
  bond and the VLAN).

  4. Switched to another slave for the created bond

  5. Can still ping from the appliance to a target via the parent bond;
  however, cannot ping to the target via the VLAN.

  =
  Detailed steps:

  1. Initial setup:
  
  root@S36MANDAR:~# nmcli c s
  NAMEUUID  TYPE  DEVICE  
  enc1a80 c3a2037d-60a3-3cb4-9234-45aed55f7093  ethernet  enc1a80 
  enc8f00 2423add6-1464-3765-877c-a214dc497492  ethernet  enc8f00 
  enc1d40 ff2d70f8-130e-3dc6-ab24-1dba07563605  ethernet  --  

  2. Create Netwrok-bond with one slave:
  
  root@S36MANDAR:~# nmcli c add type bond con-name mybond1 ifname mybond1 
ipv4.method disabled ipv6.method ignore
  Connection 'mybond1' (4b918a65-43a6-4ec3-b3c4-388ed52b116d) successfully 
added.

  root@S36MANDAR:~# nmcli con add type ethernet ifname enc1d40 master mybond1
  Connection 'bond-slave-enc1d40' (cfe4b245-3dda-4f45-b7b4-6d40d144a02f) 
successfully added.
  root@S36MANDAR:~# nmcli con up bond-slave-enc1d40
  Connection successfully activated (D-Bus active path: 
/org/freedesktop/NetworkManager/ActiveConnection/18)
  root@S36MANDAR:~# nmcli c s
  NAMEUUID  TYPE  DEVICE  
  bond-slave-enc1d40  cfe4b245-3dda-4f45-b7b4-6d40d144a02f  ethernet  enc1d40 
  enc1a80 c3a2037d-60a3-3cb4-9234-45aed55f7093  ethernet  enc1a80 
  enc8f00 2423add6-1464-3765-877c-a214dc497492  ethernet  enc8f00 
  mybond1 4b918a65-43a6-4ec3-b3c4-388ed52b116d  bond  mybond1 
  enc1d40 ff2d70f8-130e-3dc6-ab24-1dba07563605  ethernet  --  

  3. Create vlan over mybond1:
  ===
  root@S36MANDAR:~# nmcli con add type vlan con-name vlanbond.100 ifname 
vlanbond.100 dev mybond1 id 100  ipv4.method disabled ipv6.method ignore
  Connection 'vlanbond.100' (e054df42-97a0-492b-b2c9-b9571077493e) successfully 
added.
  root@S36MANDAR:~# nmcli c s
  NAMEUUID  TYPE  DEVICE
   
  bond-slave-enc1d40  cfe4b245-3dda-4f45-b7b4-6d40d144a02f  ethernet  enc1d40   
   
  enc1a80 c3a2037d-60a3-3cb4-9234-45aed55f7093  ethernet  enc1a80   
   
  enc8f00 2423add6-1464-3765-877c-a214dc497492  ethernet  enc8f00   
   
  mybond1 4b918a65-43a6-4ec3-b3c4-388ed52b116d  bond  mybond1   
   
  vlanbond.100e054df42-97a0-492b-b2c9-b9571077493e  vlan  
vlanbond.100 
  enc1d40 ff2d70f8-130e-3dc6-ab24-1dba07563605  ethernet  --
   

  4. Reactivate bond : 
  =
  root@S36MANDAR:~# nmcli con up mybond1
  Connection successfully activated (master waiting for slaves) (D-Bus active 
path: /org/freedesktop/NetworkManager/ActiveConnection/30)

  root@S36MANDAR:~# nmcli c s
  NAMEUUID  TYPE  DEVICE  
  enc1a80 

[Touch-packages] [Bug 1754671] Autopkgtest regression report (network-manager/1.10.6-2ubuntu1.2)

2019-10-25 Thread Ubuntu SRU Bot
All autopkgtests for the newly accepted network-manager (1.10.6-2ubuntu1.2) for 
bionic have finished running.
The following regressions have been reported in tests triggered by the package:

network-manager/1.10.6-2ubuntu1.2 (amd64, arm64, i386, ppc64el)
systemd/237-3ubuntu10.31 (i386, ppc64el)
netplan.io/0.98-0ubuntu1~18.04.1 (arm64)


Please visit the excuses page listed below and investigate the failures, 
proceeding afterwards as per the StableReleaseUpdates policy regarding 
autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-
migration/bionic/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1754671

Title:
  Full-tunnel VPN DNS leakage regression

Status in NetworkManager:
  Confirmed
Status in network-manager package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Fix Released
Status in network-manager source package in Xenial:
  Confirmed
Status in systemd source package in Xenial:
  Invalid
Status in network-manager source package in Bionic:
  Fix Committed
Status in systemd source package in Bionic:
  Fix Released
Status in network-manager source package in Cosmic:
  Fix Released
Status in systemd source package in Cosmic:
  Fix Released

Bug description:
  [Impact]
  When using a VPN the DNS requests might still be sent to a DNS server outside 
the VPN when they should not

  [Test case]
  1) Set up a VPN with split tunneling:
a) Configure VPN normally (set up remote host, any ports and options needed 
for the VPN to work)
b) Under the IPv4 tab: enable "Use this connection only for the resources 
on its network".
c) Under the IPv6 tab: enable "Use this connection only for the resources 
on its network".

  2) Connect to the VPN.

  3) Run 'systemd-resolve --status'; note the DNS servers configured:
a) For the VPN; under a separate link (probably tun0), note down the IP of 
the DNS server(s). Also note the name of the interface (link).
b) For the "main" connection; under the link for your ethernet or wireless 
devices (wl*, en*, whatever it may be), note down the IP of the DNS server(s). 
Also note the name of the interface (link).

  4) In a separate terminal, run 'sudo tcpdump -ni 
  port 53'; let it run.

  5) In a separate terminal, run 'sudo tcpdump -ni 
  port 53'; let it run.

  6) In yet another terminal, issue name resolution requests using dig:
a) For a name known to be reachable via the public network:
   'dig www.yahoo.com'
b) For a name known to be reachable only via the VPN:
   'dig '

  7) Check the output of each terminal running tcpdump. When requesting
  the public name, traffic can go through either. When requesting the
  "private" name (behind the VPN), traffic should only be going through
  the interface for the VPN. Additionally, ensure the IP receiving the
  requests for the VPN name is indeed the IP address noted above for the
  VPN's DNS server.

  If you see no traffic showing in tcpdump output when requesting a
  name, it may be because it is cached by systemd-resolved. Use a
  different name you have not tried before.

  
  [Regression potential]
  The code change the handling of DNS servers when using a VPN, we should check 
that name resolution still work whne using a VPN in different configurations

  -

  In 16.04 the NetworkManager package used to carry this patch:
  
http://bazaar.launchpad.net/~network-manager/network-manager/ubuntu/view/head:/debian/patches/Filter-DNS-servers-to-add-to-dnsmasq-based-on-availa.patch

  It fixed the DNS setup so that when I'm on the VPN, I am not sending
  unencrypted DNS queries to the (potentially hostile) local
  nameservers.

  This patch disappeared in an update. I think it was present in
  1.2.2-0ubuntu0.16.04.4 but was dropped some time later.

  This security bug exists upstream too: 
https://bugzilla.gnome.org/show_bug.cgi?id=746422
  It's not a *regression* there though, as they didn't fix it yet 
(unfortunately!)

To manage notifications about this bug go to:
https://bugs.launchpad.net/network-manager/+bug/1754671/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1825946] Autopkgtest regression report (network-manager/1.10.6-2ubuntu1.2)

2019-10-25 Thread Ubuntu SRU Bot
All autopkgtests for the newly accepted network-manager (1.10.6-2ubuntu1.2) for 
bionic have finished running.
The following regressions have been reported in tests triggered by the package:

network-manager/1.10.6-2ubuntu1.2 (amd64, arm64, i386, ppc64el)
systemd/237-3ubuntu10.31 (i386, ppc64el)
netplan.io/0.98-0ubuntu1~18.04.1 (arm64)


Please visit the excuses page listed below and investigate the failures, 
proceeding afterwards as per the StableReleaseUpdates policy regarding 
autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-
migration/bionic/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1825946

Title:
  'nm' autopkgtest fails due to GI stderr output

Status in network-manager package in Ubuntu:
  Fix Released
Status in network-manager source package in Xenial:
  New
Status in network-manager source package in Bionic:
  Fix Committed

Bug description:
  [impact]

  'nm' testcase contains:
  from gi.repository import NetworkManager, NMClient, GLib  


 

  which generates output to stderr:
  /tmp/autopkgtest.naU0ts/build.riU/src/debian/tests/nm:23: PyGIWarning: 
NetworkManager was imported without specifying a version first. Use 
gi.require_version('NetworkManager', '1.0') before import to ensure that the 
right version gets loaded.

  the gi.require_version call has already been added to cosmic and
  disco.

  [test case]

  see http://autopkgtest.ubuntu.com/packages/network-manager bionic test
  results.

  [other info]

  this only fails intermittently, but the failure is clearly not an
  actual problem.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1825946/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849824] Re: Cup over usb does not print to Brother J6530DW

2019-10-25 Thread Christine Hyde
Please ignore confusing comment about HP. It should have read my old HP
Printer had no issues :)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1849824

Title:
  Cup over usb does not print to Brother J6530DW

Status in cups package in Ubuntu:
  New

Bug description:
  I've tried everything I can find on the internet and on Ubuntu.
  Nothing works: changing parameters as per instructions, no go. cat
  text >/dev/usb/lp0 does not work either. Using cups the printer
  remains steadfastly inactive. "Catting" wakes up the printer to
  indicate data is received but nah.

  The alternative ppd for printing over the network *works* however.

  The usb cable is good: scanning works from Ubuntu.

  I've upgraded oldish HP DM3 laptop to a ThinkPad T495s (nice machine)
  but still stuffed for usb printing with this machine. (My old HP had
  no issues)

   ubuntu-bug cups report should give you all that you are asking for
  below

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: cups 2.2.7-1ubuntu2.7
  ProcVersionSignature: Ubuntu 4.15.0-66.75-generic 4.15.18
  Uname: Linux 4.15.0-66-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Fri Oct 25 12:51:07 2019
  InstallationDate: Installed on 2019-10-23 (1 days ago)
  InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 
(20170801)
  Lpstat: device for MFCJ6530DW: usb://dev/usb/lp0
  MachineType: LENOVO 20QJ000CUK
  Papersize: a4
  PpdFiles: Error: command ['fgrep', '-H', '*NickName', 
'/etc/cups/ppd/MFCJ6530DW.ppd'] failed with exit code 2: grep: 
/etc/cups/ppd/MFCJ6530DW.ppd: Permission denied
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-66-generic 
root=UUID=a01c352d-3e32-42bf-b522-dfaa9ab41f3c ro quiet splash vt.handoff=1
  SourcePackage: cups
  UpgradeStatus: Upgraded to bionic on 2019-10-23 (1 days ago)
  dmi.bios.date: 07/31/2019
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R13ET35W(1.09 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QJ000CUK
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Defined
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrR13ET35W(1.09):bd07/31/2019:svnLENOVO:pn20QJ000CUK:pvrThinkPadT495s:rvnLENOVO:rn20QJ000CUK:rvrNotDefined:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad T495s
  dmi.product.name: 20QJ000CUK
  dmi.product.version: ThinkPad T495s
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1849824/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849824] [NEW] Cup over usb does not print to Brother J6530DW

2019-10-25 Thread Christine Hyde
Public bug reported:

I've tried everything I can find on the internet and on Ubuntu. Nothing
works: changing parameters as per instructions, no go. cat text
>/dev/usb/lp0 does not work either. Using cups the printer remains
steadfastly inactive. "Catting" wakes up the printer to indicate data is
received but nah.

The alternative ppd for printing over the network *works* however.

The usb cable is good: scanning works from Ubuntu.

I've upgraded oldish HP DM3 laptop to a ThinkPad T495s (nice machine)
but still stuffed for usb printing with this machine. (My old HP had no
issues)

 ubuntu-bug cups report should give you all that you are asking for
below

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: cups 2.2.7-1ubuntu2.7
ProcVersionSignature: Ubuntu 4.15.0-66.75-generic 4.15.18
Uname: Linux 4.15.0-66-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
Date: Fri Oct 25 12:51:07 2019
InstallationDate: Installed on 2019-10-23 (1 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
Lpstat: device for MFCJ6530DW: usb://dev/usb/lp0
MachineType: LENOVO 20QJ000CUK
Papersize: a4
PpdFiles: Error: command ['fgrep', '-H', '*NickName', 
'/etc/cups/ppd/MFCJ6530DW.ppd'] failed with exit code 2: grep: 
/etc/cups/ppd/MFCJ6530DW.ppd: Permission denied
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-66-generic 
root=UUID=a01c352d-3e32-42bf-b522-dfaa9ab41f3c ro quiet splash vt.handoff=1
SourcePackage: cups
UpgradeStatus: Upgraded to bionic on 2019-10-23 (1 days ago)
dmi.bios.date: 07/31/2019
dmi.bios.vendor: LENOVO
dmi.bios.version: R13ET35W(1.09 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20QJ000CUK
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: 
dmi:bvnLENOVO:bvrR13ET35W(1.09):bd07/31/2019:svnLENOVO:pn20QJ000CUK:pvrThinkPadT495s:rvnLENOVO:rn20QJ000CUK:rvrNotDefined:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T495s
dmi.product.name: 20QJ000CUK
dmi.product.version: ThinkPad T495s
dmi.sys.vendor: LENOVO

** Affects: cups (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: amd64 apport-bug bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1849824

Title:
  Cup over usb does not print to Brother J6530DW

Status in cups package in Ubuntu:
  New

Bug description:
  I've tried everything I can find on the internet and on Ubuntu.
  Nothing works: changing parameters as per instructions, no go. cat
  text >/dev/usb/lp0 does not work either. Using cups the printer
  remains steadfastly inactive. "Catting" wakes up the printer to
  indicate data is received but nah.

  The alternative ppd for printing over the network *works* however.

  The usb cable is good: scanning works from Ubuntu.

  I've upgraded oldish HP DM3 laptop to a ThinkPad T495s (nice machine)
  but still stuffed for usb printing with this machine. (My old HP had
  no issues)

   ubuntu-bug cups report should give you all that you are asking for
  below

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: cups 2.2.7-1ubuntu2.7
  ProcVersionSignature: Ubuntu 4.15.0-66.75-generic 4.15.18
  Uname: Linux 4.15.0-66-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Fri Oct 25 12:51:07 2019
  InstallationDate: Installed on 2019-10-23 (1 days ago)
  InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 
(20170801)
  Lpstat: device for MFCJ6530DW: usb://dev/usb/lp0
  MachineType: LENOVO 20QJ000CUK
  Papersize: a4
  PpdFiles: Error: command ['fgrep', '-H', '*NickName', 
'/etc/cups/ppd/MFCJ6530DW.ppd'] failed with exit code 2: grep: 
/etc/cups/ppd/MFCJ6530DW.ppd: Permission denied
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-66-generic 
root=UUID=a01c352d-3e32-42bf-b522-dfaa9ab41f3c ro quiet splash vt.handoff=1
  SourcePackage: cups
  UpgradeStatus: Upgraded to bionic on 2019-10-23 (1 days ago)
  dmi.bios.date: 07/31/2019
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R13ET35W(1.09 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20QJ000CUK
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Defined
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrR13ET35W(1.09):bd07/31/2019:svnLENOVO:pn20QJ000CUK:pvrThinkPadT495s:rvnLENOVO:rn20QJ000CUK:rvrNotDefined:cvnLENOVO:ct10:cvrNone:
  dmi.product.family: ThinkPad T495s
  dmi.product.name: 20QJ000CUK
  dmi.product.version: ThinkPad T495s
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1849824/+subscriptions

-- 
Mailing list: 

[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
TODO:
a) wait for 2.4.2 and 2.5.0 to be released and pick those
b) if urgent pick and backport [1]

[1]:
https://github.com/seccomp/libseccomp/pull/176/commits/e4d38dcfd44743a55728b336d008ec8e37c1b344

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp:
  Unknown
Status in libseccomp package in Ubuntu:
  Triaged
Status in libseccomp source package in Eoan:
  Triaged

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on i386/ppc64
  On x86_64 this test succeeds:

  Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

To manage notifications about this bug go to:
https://bugs.launchpad.net/libseccomp/+bug/1849785/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : 

[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
Subscribing ubuntu-security to monitor this together with us as often enough 
they do libseccomp.
IMHO We don't have any urgency to go ahead of upstream, unless a fast re-build 
is needed.

** Changed in: libseccomp (Ubuntu)
   Importance: Undecided => Medium

** Changed in: libseccomp (Ubuntu Eoan)
   Importance: Undecided => Medium

** Changed in: libseccomp (Ubuntu)
   Status: Confirmed => Triaged

** Changed in: libseccomp (Ubuntu Eoan)
   Status: Confirmed => Triaged

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp:
  Unknown
Status in libseccomp package in Ubuntu:
  Triaged
Status in libseccomp source package in Eoan:
  Triaged

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on i386/ppc64
  On x86_64 this test succeeds:

  Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
   batch 

[Touch-packages] [Bug 1442050] Re: (colord:832): Cd-WARNING **: failed to get session [pid 690]: Unknown error -2

2019-10-25 Thread WinEunuchs2Unix
Bug still exists on Ubuntu 16.04.6 LTS, Kernel 4.14.140. Found when
looking for what was causing xrandr to reset screens to full brightness
and gamma. Even if `colord` isn't culprit, life is easier with less spam
in journalctl.

Ignore extra `s` in `fails` below (line wrap off) for bug report:

$ journalctl | grep "failed to get session \[pid"
Aug 24 08:43:54 alien colord[1366]: (colord:1366): Cd-WARNING **: fails
Aug 24 08:43:54 alien colord[1366]: (colord:1366): Cd-WARNING **: fails
Aug 25 07:41:51 alien colord[1366]: (colord:1366): Cd-WARNING **: fails
Aug 25 07:41:51 alien colord[1366]: (colord:1366): Cd-WARNING **: fails

.. (SNIP) ..

Oct 22 04:33:50 alien colord[1215]: (colord:1215): Cd-WARNING **: fails
Oct 22 04:33:50 alien colord[1215]: (colord:1215): Cd-WARNING **: fails
Oct 23 04:34:53 alien colord[1215]: (colord:1215): Cd-WARNING **: fails
Oct 23 04:34:53 alien colord[1215]: (colord:1215): Cd-WARNING **: fails
Oct 24 04:36:20 alien colord[1215]: (colord:1215): Cd-WARNING **: fails
Oct 24 04:36:20 alien colord[1215]: (colord:1215): Cd-WARNING **: fails
Oct 25 04:36:56 alien colord[1215]: (colord:1215): Cd-WARNING **: fails
Oct 25 04:36:56 alien colord[1215]: (colord:1215): Cd-WARNING **: fails

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to colord in Ubuntu.
https://bugs.launchpad.net/bugs/1442050

Title:
  (colord:832): Cd-WARNING **: failed to get session [pid 690]: Unknown
  error -2

Status in colord package in Ubuntu:
  Confirmed

Bug description:
  Get that error logged into journalctl

  (colord:832): Cd-WARNING **: failed to get session [pid 690]: Unknown
  error -2

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: systemd 219-6ubuntu3
  ProcVersionSignature: Ubuntu 3.19.0-12.12-generic 3.19.3
  Uname: Linux 3.19.0-12-generic i686
  NonfreeKernelModules: nvidia
  ApportVersion: 2.17-0ubuntu1
  Architecture: i386
  CurrentDesktop: GNOME
  Date: Thu Apr  9 11:57:02 2015
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 003 Device 002: ID 046d:c50e Logitech, Inc. Cordless Mouse Receiver
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-12-generic 
root=UUID=7b1f4a51-558f-468f-85e0-f815d2f791e1 ro
  SourcePackage: systemd
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/colord/+bug/1442050/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
And as usual once you know what you search:
=> https://github.com/seccomp/libseccomp/issues/166

** Bug watch added: github.com/seccomp/libseccomp/issues #166
   https://github.com/seccomp/libseccomp/issues/166

** Also affects: libseccomp via
   https://github.com/seccomp/libseccomp/issues/166
   Importance: Unknown
   Status: Unknown

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp:
  Unknown
Status in libseccomp package in Ubuntu:
  Triaged
Status in libseccomp source package in Eoan:
  Triaged

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on i386/ppc64
  On x86_64 this test succeeds:

  Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

To manage notifications about this bug go to:

[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
Well this change made the ID 392 "known" to all architectures (in a try
to sync numbers across everywhere) but it fails on those it isn't
implemented (32bit, ppc, s390x + sparc which we don't have).

The path registering these calls goes
seccomp_rule_add
 -> seccomp_rule_add_array
 -> db_col_valid
 -> _syscall_valid
 -> db_col_rule_add   <- still -204/392
 -> _db_rule_new
 -> db_col_transaction_start  <- dups old rule (-201) ITERATES
-> arch_filter_rule_add
-> arch_syscall_translate
-> arch_syscall_resolve_num  <- returns "semop" for -201
-> arch_syscall_resolve_name <- returns -201 for "semop"
Returns RC=0 (db_col_transaction_start)
The above defined the transaction start
 -> arch_filter_rule_add  <- this adds the new rule -204/392
 -> arch_syscall_translate
 -> arch_syscall_resolve_num  
  Good case returns "semtimedop" for 
  Bad  case returns 0x0 for 392
  From here it now returns -EFAULT (=> -14) and things break

So we enter:
Good: Breakpoint 14, s390x_syscall_resolve_num (num=-204) at 
arch-s390x-syscalls.c:533
Bad: Breakpoint 13, s390x_syscall_resolve_num (num=392) at 
arch-s390x-syscalls.c:533

This searches the table s390x_syscall_table and fails to find 392, from there 
things break.
The worst is, that "semtimedop" is there, but with __PNR_semtimedop as number.
As it used to have no number yet when last time generated.
If it would use __NR_semtimedop instead of __PNR_semtimedop it might even work 
as-is.
I'm not sure if src/arch-s390x-syscalls.c is allowed to use include/seccomp.h 
(where these compat defines are).
I need to suggest that upstream (or check if a change exists)

Summary of the above:
- kernel change defined numbers for all calls (implemented or not)
- due to that no more the fallback "#define __PNR_semtimedop -204" but provided 
392 is used
- arch_syscall_translate tries to translate 392 in the context of the native 
architecure to the provided architecture and fails
- src/arch-s390x-syscalls.c contains syscall tables derived from 4.15-rc7 which 
need to be updated
- Definitions in this table should use __NR_ instead of __PNR_ to get the 
kernel value once it is defined (will be ==__PNR when not defined)
- Even if not using __NR it needs a redefine for newer kernels

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 

[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
Upstream/master branch still is on 4.15-rc7 AND still uses __PNR_* for the 
definitions.
I'll open an issue to further discuss it there.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on i386/ppc64
  On x86_64 this test succeeds:

  Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libseccomp/+bug/1849785/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages

[Touch-packages] [Bug 1825946] Re: 'nm' autopkgtest fails due to GI stderr output

2019-10-25 Thread Timo Aaltonen
Hello Dan, or anyone else affected,

Accepted network-manager into bionic-proposed. The package will build
now and be available at https://launchpad.net/ubuntu/+source/network-
manager/1.10.6-2ubuntu1.2 in a few hours, and then in the -proposed
repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested and change the tag from
verification-needed-bionic to verification-done-bionic. If it does not
fix the bug for you, please add a comment stating that, and change the
tag to verification-failed-bionic. In either case, without details of
your testing we will not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: network-manager (Ubuntu Bionic)
   Status: In Progress => Fix Committed

** Tags added: verification-needed verification-needed-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1825946

Title:
  'nm' autopkgtest fails due to GI stderr output

Status in network-manager package in Ubuntu:
  Fix Released
Status in network-manager source package in Xenial:
  New
Status in network-manager source package in Bionic:
  Fix Committed

Bug description:
  [impact]

  'nm' testcase contains:
  from gi.repository import NetworkManager, NMClient, GLib  


 

  which generates output to stderr:
  /tmp/autopkgtest.naU0ts/build.riU/src/debian/tests/nm:23: PyGIWarning: 
NetworkManager was imported without specifying a version first. Use 
gi.require_version('NetworkManager', '1.0') before import to ensure that the 
right version gets loaded.

  the gi.require_version call has already been added to cosmic and
  disco.

  [test case]

  see http://autopkgtest.ubuntu.com/packages/network-manager bionic test
  results.

  [other info]

  this only fails intermittently, but the failure is clearly not an
  actual problem.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1825946/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1754671] Re: Full-tunnel VPN DNS leakage regression

2019-10-25 Thread Timo Aaltonen
Hello dwmw2, or anyone else affected,

Accepted network-manager into bionic-proposed. The package will build
now and be available at https://launchpad.net/ubuntu/+source/network-
manager/1.10.6-2ubuntu1.2 in a few hours, and then in the -proposed
repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested and change the tag from
verification-needed-bionic to verification-done-bionic. If it does not
fix the bug for you, please add a comment stating that, and change the
tag to verification-failed-bionic. In either case, without details of
your testing we will not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: network-manager (Ubuntu Bionic)
   Status: In Progress => Fix Committed

** Tags removed: verification-done verification-done-bionic
** Tags added: verification-needed verification-needed-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1754671

Title:
  Full-tunnel VPN DNS leakage regression

Status in NetworkManager:
  Confirmed
Status in network-manager package in Ubuntu:
  Fix Released
Status in systemd package in Ubuntu:
  Fix Released
Status in network-manager source package in Xenial:
  Confirmed
Status in systemd source package in Xenial:
  Invalid
Status in network-manager source package in Bionic:
  Fix Committed
Status in systemd source package in Bionic:
  Fix Released
Status in network-manager source package in Cosmic:
  Fix Released
Status in systemd source package in Cosmic:
  Fix Released

Bug description:
  [Impact]
  When using a VPN the DNS requests might still be sent to a DNS server outside 
the VPN when they should not

  [Test case]
  1) Set up a VPN with split tunneling:
a) Configure VPN normally (set up remote host, any ports and options needed 
for the VPN to work)
b) Under the IPv4 tab: enable "Use this connection only for the resources 
on its network".
c) Under the IPv6 tab: enable "Use this connection only for the resources 
on its network".

  2) Connect to the VPN.

  3) Run 'systemd-resolve --status'; note the DNS servers configured:
a) For the VPN; under a separate link (probably tun0), note down the IP of 
the DNS server(s). Also note the name of the interface (link).
b) For the "main" connection; under the link for your ethernet or wireless 
devices (wl*, en*, whatever it may be), note down the IP of the DNS server(s). 
Also note the name of the interface (link).

  4) In a separate terminal, run 'sudo tcpdump -ni 
  port 53'; let it run.

  5) In a separate terminal, run 'sudo tcpdump -ni 
  port 53'; let it run.

  6) In yet another terminal, issue name resolution requests using dig:
a) For a name known to be reachable via the public network:
   'dig www.yahoo.com'
b) For a name known to be reachable only via the VPN:
   'dig '

  7) Check the output of each terminal running tcpdump. When requesting
  the public name, traffic can go through either. When requesting the
  "private" name (behind the VPN), traffic should only be going through
  the interface for the VPN. Additionally, ensure the IP receiving the
  requests for the VPN name is indeed the IP address noted above for the
  VPN's DNS server.

  If you see no traffic showing in tcpdump output when requesting a
  name, it may be because it is cached by systemd-resolved. Use a
  different name you have not tried before.

  
  [Regression potential]
  The code change the handling of DNS servers when using a VPN, we should check 
that name resolution still work whne using a VPN in different configurations

  -

  In 16.04 the NetworkManager package used to carry this patch:
  
http://bazaar.launchpad.net/~network-manager/network-manager/ubuntu/view/head:/debian/patches/Filter-DNS-servers-to-add-to-dnsmasq-based-on-availa.patch

  It fixed the DNS setup so that when I'm on the VPN, I am not sending
  unencrypted DNS queries to the (potentially hostile) local
  nameservers.

  This patch disappeared in an update. I think it was present in
  1.2.2-0ubuntu0.16.04.4 but was dropped some time later.

  This security bug exists upstream too: 
https://bugzilla.gnome.org/show_bug.cgi?id=746422
  It's not a *regression* there though, as they didn't fix it yet 
(unfortunately!)

To manage notifications about this bug go 

[Touch-packages] [Bug 1790098] Re: vlan created on bond fails auto activation on updating parent network bond

2019-10-25 Thread Timo Aaltonen
Hello bugproxy, or anyone else affected,

Accepted network-manager into bionic-proposed. The package will build
now and be available at https://launchpad.net/ubuntu/+source/network-
manager/1.10.6-2ubuntu1.2 in a few hours, and then in the -proposed
repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested and change the tag from
verification-needed-bionic to verification-done-bionic. If it does not
fix the bug for you, please add a comment stating that, and change the
tag to verification-failed-bionic. In either case, without details of
your testing we will not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

** Changed in: network-manager (Ubuntu Bionic)
   Status: New => Fix Committed

** Tags added: verification-needed verification-needed-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1790098

Title:
  vlan created on bond fails auto activation on updating parent network
  bond

Status in Ubuntu on IBM z Systems:
  Won't Fix
Status in network-manager package in Ubuntu:
  Won't Fix
Status in network-manager source package in Bionic:
  Fix Committed

Bug description:
  Auto activation of Vlan created over network-bond fails if bond is 
deactivated and reactivated.
   
  Contact Information = Abhiram Kulkarni(abhir...@in.ibm.com), Mandar 
Deshpande(manda...@in.ibm.com) 
   
  ---uname output---
  Linux S36MANDAR 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:14:23 UTC 2018 
s390x s390x s390x GNU/Linux
   
  Machine Type = s390x 
   
  ---Debugger---
  A debugger is not configured
   
  ---Steps to Reproduce---
   1. Created a network bond with static IP address (and no IPv6 address); 
active backup mode; ARP polling; single slave.

  2. Created a VLAN using said network bond with static IPv4 address
  (and no IPv6 address).

  3. Can ping from the appliance to a target on both links (the parent
  bond and the VLAN).

  4. Switched to another slave for the created bond

  5. Can still ping from the appliance to a target via the parent bond;
  however, cannot ping to the target via the VLAN.

  =
  Detailed steps:

  1. Initial setup:
  
  root@S36MANDAR:~# nmcli c s
  NAMEUUID  TYPE  DEVICE  
  enc1a80 c3a2037d-60a3-3cb4-9234-45aed55f7093  ethernet  enc1a80 
  enc8f00 2423add6-1464-3765-877c-a214dc497492  ethernet  enc8f00 
  enc1d40 ff2d70f8-130e-3dc6-ab24-1dba07563605  ethernet  --  

  2. Create Netwrok-bond with one slave:
  
  root@S36MANDAR:~# nmcli c add type bond con-name mybond1 ifname mybond1 
ipv4.method disabled ipv6.method ignore
  Connection 'mybond1' (4b918a65-43a6-4ec3-b3c4-388ed52b116d) successfully 
added.

  root@S36MANDAR:~# nmcli con add type ethernet ifname enc1d40 master mybond1
  Connection 'bond-slave-enc1d40' (cfe4b245-3dda-4f45-b7b4-6d40d144a02f) 
successfully added.
  root@S36MANDAR:~# nmcli con up bond-slave-enc1d40
  Connection successfully activated (D-Bus active path: 
/org/freedesktop/NetworkManager/ActiveConnection/18)
  root@S36MANDAR:~# nmcli c s
  NAMEUUID  TYPE  DEVICE  
  bond-slave-enc1d40  cfe4b245-3dda-4f45-b7b4-6d40d144a02f  ethernet  enc1d40 
  enc1a80 c3a2037d-60a3-3cb4-9234-45aed55f7093  ethernet  enc1a80 
  enc8f00 2423add6-1464-3765-877c-a214dc497492  ethernet  enc8f00 
  mybond1 4b918a65-43a6-4ec3-b3c4-388ed52b116d  bond  mybond1 
  enc1d40 ff2d70f8-130e-3dc6-ab24-1dba07563605  ethernet  --  

  3. Create vlan over mybond1:
  ===
  root@S36MANDAR:~# nmcli con add type vlan con-name vlanbond.100 ifname 
vlanbond.100 dev mybond1 id 100  ipv4.method disabled ipv6.method ignore
  Connection 'vlanbond.100' (e054df42-97a0-492b-b2c9-b9571077493e) successfully 
added.
  root@S36MANDAR:~# nmcli c s
  NAMEUUID  TYPE  DEVICE
   
  bond-slave-enc1d40  cfe4b245-3dda-4f45-b7b4-6d40d144a02f  ethernet  enc1d40   
   
  enc1a80 c3a2037d-60a3-3cb4-9234-45aed55f7093  ethernet  enc1a80   
   
  enc8f00 

[Touch-packages] [Bug 1848354] Re: upgrade-between-snapshots autopkgtest is flaky

2019-10-25 Thread Balint Reczey
Tested 1.14ubuntu1.1 on Eoan:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac
/autopkgtest-eoan/eoan/amd64/u/unattended-
upgrades/20191016_223206_2d8a4@/log.gz

...
autopkgtest [22:31:56]:  summary
run-testsPASS
test-systemd.py  PASS
upgrade-all-security SKIP exit status 77 and marked as skippable
upgrade-between-snapshots PASS
kernel-patterns  PASS
Exit request sent.
...

** Tags removed: verification-needed-eoan
** Tags added: verification-done-eoan

** Tags removed: block-proposed-eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unattended-upgrades in
Ubuntu.
https://bugs.launchpad.net/bugs/1848354

Title:
  upgrade-between-snapshots autopkgtest is flaky

Status in unattended-upgrades package in Ubuntu:
  Fix Released
Status in unattended-upgrades source package in Xenial:
  Fix Committed
Status in unattended-upgrades source package in Bionic:
  Fix Committed
Status in unattended-upgrades source package in Disco:
  Fix Committed
Status in unattended-upgrades source package in Eoan:
  Fix Committed

Bug description:
  [Impact]

   * Flaky upgrade-between-snapshots autopkgtest prevents developers to
  use the test efficiently.

  [Test Case]

   * Run autopkgtests, observe the upgrade-between-snapshots test
  passing or failing but being marked as FLAKY.

  [Regression Potential]

   * None, the test was failing often due to connectivity/internal
  errors of snapshot.debian.org.

  [Other Info]

   * The whole autopkgtest is marked to be failing on amd64 to mitigate
  the single flaky test, this marking can be removed after marking this
  single flaky test.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1848354/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848354] Re: upgrade-between-snapshots autopkgtest is flaky

2019-10-25 Thread Balint Reczey
Dropping block-proposed-eoan tag, since releasing to release pocket is
now to be approved by the SRU team.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unattended-upgrades in
Ubuntu.
https://bugs.launchpad.net/bugs/1848354

Title:
  upgrade-between-snapshots autopkgtest is flaky

Status in unattended-upgrades package in Ubuntu:
  Fix Released
Status in unattended-upgrades source package in Xenial:
  Fix Committed
Status in unattended-upgrades source package in Bionic:
  Fix Committed
Status in unattended-upgrades source package in Disco:
  Fix Committed
Status in unattended-upgrades source package in Eoan:
  Fix Committed

Bug description:
  [Impact]

   * Flaky upgrade-between-snapshots autopkgtest prevents developers to
  use the test efficiently.

  [Test Case]

   * Run autopkgtests, observe the upgrade-between-snapshots test
  passing or failing but being marked as FLAKY.

  [Regression Potential]

   * None, the test was failing often due to connectivity/internal
  errors of snapshot.debian.org.

  [Other Info]

   * The whole autopkgtest is marked to be failing on amd64 to mitigate
  the single flaky test, this marking can be removed after marking this
  single flaky test.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1848354/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848354] Re: upgrade-between-snapshots autopkgtest is flaky

2019-10-25 Thread Balint Reczey
Tested 1.1ubuntu1.18.04.7~16.04.4 on Xenial:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/u/unattended-upgrades/20191024_220650_7dfdf@/log.gz
...
The URI 
http://snapshot.debian.org/archive/debian/20171210T00Z/pool/main/m/mesa/libxatracker2_17.2.5-1_amd64.deb
 failed to download, aborting
Command exited with non-zero status 1
96.85user 2.46system 1:43.88elapsed 95%CPU (0avgtext+0avgdata 82204maxresident)k
0inputs+23400outputs (0major+43885minor)pagefaults 0swaps
autopkgtest [22:06:37]: test upgrade-between-snapshots: ---]
autopkgtest [22:06:37]: test upgrade-between-snapshots:  - - - - - - - - - - 
results - - - - - - - - - -
upgrade-between-snapshots FLAKY non-zero exit status 1
autopkgtest [22:06:37]:  summary
run-testsPASS
test-systemd.py  PASS
upgrade-all-security PASS
upgrade-between-snapshots FLAKY non-zero exit status 1
...

** Tags removed: verification-needed-xenial
** Tags added: verification-done-xenial

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unattended-upgrades in
Ubuntu.
https://bugs.launchpad.net/bugs/1848354

Title:
  upgrade-between-snapshots autopkgtest is flaky

Status in unattended-upgrades package in Ubuntu:
  Fix Released
Status in unattended-upgrades source package in Xenial:
  Fix Committed
Status in unattended-upgrades source package in Bionic:
  Fix Committed
Status in unattended-upgrades source package in Disco:
  Fix Committed
Status in unattended-upgrades source package in Eoan:
  Fix Committed

Bug description:
  [Impact]

   * Flaky upgrade-between-snapshots autopkgtest prevents developers to
  use the test efficiently.

  [Test Case]

   * Run autopkgtests, observe the upgrade-between-snapshots test
  passing or failing but being marked as FLAKY.

  [Regression Potential]

   * None, the test was failing often due to connectivity/internal
  errors of snapshot.debian.org.

  [Other Info]

   * The whole autopkgtest is marked to be failing on amd64 to mitigate
  the single flaky test, this marking can be removed after marking this
  single flaky test.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1848354/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849658] Re: resolved fallback to TCP fails for truncated UDP replies

2019-10-25 Thread Balint Reczey
** Changed in: systemd (Ubuntu Focal)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1849658

Title:
  resolved fallback to TCP fails for truncated UDP replies

Status in systemd package in Ubuntu:
  Fix Committed
Status in systemd source package in Disco:
  In Progress
Status in systemd source package in Eoan:
  In Progress
Status in systemd source package in Focal:
  Fix Committed

Bug description:
  [impact]

  for DNS UDP replies larger than 512 bytes, fallback to TCP is used.
  For example 'host toomany.ddstreet.org'.

  Due to a bug in resolved in refcounting DNS stream types, the refcount
  underflows for type 0 streams (which resolved uses to talk to upstream
  nameservers), resulting in resolved being unable to fallback to TCP to
  handle truncated UDP replies.

  [test case]

  ubuntu@sf247344-upstream:~$ dig +noanswer +noedns toomany.ddstreet.org
  ;; Truncated, retrying in TCP mode.

  ; <<>> DiG 9.11.3-1ubuntu1.9-Ubuntu <<>> +noanswer +noedns 
toomany.ddstreet.org
  ;; global options: +cmd
  ;; Got answer:
  ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2683
  ;; flags: qr rd ra; QUERY: 1, ANSWER: 40, AUTHORITY: 0, ADDITIONAL: 0

  ;; QUESTION SECTION:
  ;toomany.ddstreet.org.IN  A

  ;; Query time: 0 msec
  ;; SERVER: 127.0.0.53#53(127.0.0.53)
  ;; WHEN: Thu Oct 24 11:40:29 UTC 2019
  ;; MSG SIZE  rcvd: 678

  ubuntu@sf247344-upstream:~$ sudo resolvectl flush-caches
  ubuntu@sf247344-upstream:~$ dig +noanswer +noedns toomany.ddstreet.org

  ; <<>> DiG 9.11.3-1ubuntu1.9-Ubuntu <<>> +noanswer +noedns 
toomany.ddstreet.org
  ;; global options: +cmd
  ;; connection timed out; no servers could be reached

  [regression potential]

  very low, as this only properly sets the stream type in the DnsStream
  object; any regression would be a failure to be able to use TCP for
  DNS requests or replies.

  [other info]

  https://github.com/systemd/systemd/pull/13838

  The commit adding stream types is not present in x/b, so this is
  needed only for disco and later.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1849658/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849608] Re: systemd resolv should separate the output of stdout and stderr

2019-10-25 Thread Balint Reczey
** Changed in: systemd (Ubuntu Focal)
   Status: Confirmed => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1849608

Title:
  systemd resolv should separate the output of stdout and stderr

Status in systemd package in Ubuntu:
  Fix Committed
Status in systemd source package in Eoan:
  New
Status in systemd source package in Focal:
  Fix Committed

Bug description:
  [impact]

  dhclient fails to notify resolved about DNS servers due to bash-
  specific redirect inside 'resolved' hook script

  [test case]

  see original description below

  [regression potential]

  any regression would likely cause resolved not to be aware of
  dhclient-provided dns servers

  [other info]

  This is needed only in Eoan and later; X/B/D do not have the bash-
  specific redirect '&>' in their hook file.

  original description:
  ---

  
  The file /etc/dhcp/dhclient-enter-hooks.d/resolved
  provided by systemd (242-7ubuntu3) causes the dhclient failing to get DNS due 
to systemd-resolved is not run.
  This issue can be reproduced on Ubuntu Eoan:
  ==
  root@eoan:~# dhclient -v
  Internet Systems Consortium DHCP Client 4.4.1
  Copyright 2004-2018 Internet Systems Consortium.
  All rights reserved.
  For info, please visit https://www.isc.org/software/dhcp/

  Listening on LPF/ens224/00:0c:29:92:d4:da
  Sending on   LPF/ens224/00:0c:29:92:d4:da
  Listening on LPF/ens192/00:0c:29:92:d4:d0
  Sending on   LPF/ens192/00:0c:29:92:d4:d0
  Listening on LPF/ens160/00:0c:29:92:d4:c6
  Sending on   LPF/ens160/00:0c:29:92:d4:c6
  Sending on   Socket/fallback
  DHCPDISCOVER on ens224 to 255.255.255.255 port 67 interval 3 (xid=0x6d9fb33d)
  DHCPDISCOVER on ens192 to 255.255.255.255 port 67 interval 3 (xid=0xeb8fda26)
  DHCPREQUEST for 192.168.120.4 on ens160 to 255.255.255.255 port 67 
(xid=0x6d39545d)
  DHCPACK of 192.168.120.4 from 192.168.120.254 (xid=0x5d54396d)
  RTNETLINK answers: File exists
  d41d8cd98f00b204e9800998ecf8427e  
/run/systemd/resolved.conf.d/isc-dhcp-v4-ens160.conf
  md5sum: /run/systemd/resolved.conf.d/isc-dhcp-v6-ens160.conf: No such file or 
directory
  5025823d750dda1f3f15e306c4a0afce  
/run/systemd/resolved.conf.d/isc-dhcp-v4-ens160.conf
  md5sum: /run/systemd/resolved.conf.d/isc-dhcp-v6-ens160.conf: No such file or 
directory
  bound to 192.168.120.4 -- renewal in 111 seconds.
  root@eoan:~# resolvectl status |grep DNS
  MulticastDNS setting: no
    DNSOverTLS setting: no
    DNSSEC setting: no
  DNSSEC supported: no
    DNSSEC NTA: 10.in-addr.arpa
  MulticastDNS setting: no
    DNSOverTLS setting: no
    DNSSEC setting: no
  DNSSEC supported: no
  MulticastDNS setting: no
    DNSOverTLS setting: no
    DNSSEC setting: no
  DNSSEC supported: no
  MulticastDNS setting: no
    DNSOverTLS setting: no
    DNSSEC setting: no
  DNSSEC supported: no
  ==

  Attached please find the patch for this. The output for md5sum in the
  hook file resolv should separate the stdout and stderr so it won't
  compare the wrong data.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1849608/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848354] Re: upgrade-between-snapshots autopkgtest is flaky

2019-10-25 Thread Balint Reczey
Tested 1.1ubuntu1.18.04.12 on Bionic:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/amd64/u/unattended-upgrades/20191024_213859_e45c8@/log.gz
...
Allowed origins are: origin=Debian,codename=sid,label=Debian, 
origin=Debian,codename=sid,label=Debian-Security
An error occurred: 503  Service Unavailable
An error occurred: 503  Service Unavailable
The URI 
http://snapshot.debian.org/archive/debian/20171210T00Z/pool/main/libe/libepoxy/libepoxy0_1.4.3-1_amd64.deb
 failed to download, aborting
The URI 
http://snapshot.debian.org/archive/debian/20171210T00Z/pool/main/libe/libepoxy/libepoxy0_1.4.3-1_amd64.deb
 failed to download, aborting
Command exited with non-zero status 1
45.30user 1.77system 3:18.70elapsed 23%CPU (0avgtext+0avgdata 82468maxresident)k
632inputs+69168outputs (0major+43798minor)pagefaults 0swaps
autopkgtest [21:38:49]: test upgrade-between-snapshots: ---]
autopkgtest [21:38:49]: test upgrade-between-snapshots:  - - - - - - - - - - 
results - - - - - - - - - -
upgrade-between-snapshots FLAKY non-zero exit status 1
autopkgtest [21:38:49]:  summary
run-testsPASS
test-systemd.py  PASS
upgrade-all-security PASS
upgrade-between-snapshots FLAKY non-zero exit status 1
Exit request sent.
...

** Tags removed: verification-needed-bionic
** Tags added: verification-done-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to unattended-upgrades in
Ubuntu.
https://bugs.launchpad.net/bugs/1848354

Title:
  upgrade-between-snapshots autopkgtest is flaky

Status in unattended-upgrades package in Ubuntu:
  Fix Released
Status in unattended-upgrades source package in Xenial:
  Fix Committed
Status in unattended-upgrades source package in Bionic:
  Fix Committed
Status in unattended-upgrades source package in Disco:
  Fix Committed
Status in unattended-upgrades source package in Eoan:
  Fix Committed

Bug description:
  [Impact]

   * Flaky upgrade-between-snapshots autopkgtest prevents developers to
  use the test efficiently.

  [Test Case]

   * Run autopkgtests, observe the upgrade-between-snapshots test
  passing or failing but being marked as FLAKY.

  [Regression Potential]

   * None, the test was failing often due to connectivity/internal
  errors of snapshot.debian.org.

  [Other Info]

   * The whole autopkgtest is marked to be failing on amd64 to mitigate
  the single flaky test, this marking can be removed after marking this
  single flaky test.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1848354/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1847980] Re: Lightdm is just a black screen when booting kernel 5.3 on an i5-6500, but kernels 5.0/5.2 work

2019-10-25 Thread Timo Aaltonen
the kernel driver seems perfectly happy though.. could you change to
tty1 and copy /var/log/Xorg.0.log somewhere and then attach here

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1847980

Title:
  Lightdm is just a black screen when booting kernel 5.3 on an i5-6500,
  but kernels 5.0/5.2 work

Status in lightdm package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in xorg-server package in Ubuntu:
  Confirmed

Bug description:
  Xorg freeze at boot on Intel Corporation HD Graphics 530 with 
linux-image-5.3.0-17 after upgraded to the development release Ubuntu Eoan 
Ermine (development branch).
  If i boot with linux-image-5.0.0-31-generic the Xorg works well.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.0.0-31.33-generic 5.0.21
  Uname: Linux 5.0.0-31-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  Date: Mon Oct 14 11:15:23 2019
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GpuHangFrequency: Continuously
  GpuHangReproducibility: Yes, I can easily reproduce it
  GpuHangStarted: Immediately after installing this version of Ubuntu
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-31-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  dmi.chassis.asset.tag: CZC64082W1
  dmi.chassis.type: 4
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrN01Ver.02.42:bd08/19/2019:svnHP:pnHPEliteDesk800G2SFF:pvr:rvnHP:rn8054:rvrKBCVersion05.36:cvnHP:ct4:cvr:
  dmi.product.family: 103C_53307F G=D
  dmi.product.name: HP EliteDesk 800 G2 SFF
  dmi.product.sku: X3J10ET#ABZ
  dmi.sys.vendor: HP
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.1-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroRelease: Ubuntu 19.10
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  Package: xorg-server (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-17-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro nomodeset 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  ProcVersionSignature: Ubuntu 5.3.0-17.18-generic 5.3.1
  Tags:  eoan ubuntu
  Uname: Linux 5.3.0-17-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  dmi.chassis.asset.tag: 

[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
I think this comes from [1] which is in since 5.3.
This will be generated into s390x-linux-gnu/asm/unistd_64.h and such.

on x86-64 it was 220 all along, no change there.
/usr/include/x86_64-linux-gnu/asm/unistd_64.h:#define __NR_semtimedop 220


https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=0d6040d4

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on i386/ppc64
  On x86_64 this test succeeds:

  Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

To manage notifications about this bug go to:

[Touch-packages] [Bug 1849733] Re: resolved incorrectly limits TCP reply to edns0 payload

2019-10-25 Thread Dan Streetman
** Tags removed: eoan

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1849733

Title:
  resolved incorrectly limits TCP reply to edns0 payload

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Bionic:
  In Progress
Status in systemd source package in Disco:
  In Progress
Status in systemd source package in Eoan:
  Fix Released

Bug description:
  [impact]

  glibc's getaddrinfo() uses EDNS0 to talk to resolved, and it sets its
  payload limit to 1200.  When the response is larger than 1200,
  resolved will limit the response and set the truncate flag.  This
  causes getaddrinfo() to switch to TCP and request again, but glibc
  incorrectly keeps the EDNS0 RR opt, with the same 1200 payload limit.
  Most dns nameservers ignore EDNS0 payload limit for TCP, since per RFC
  it applies only to UDP, but resolved does not and again marks the
  response as truncated.  This prevents getaddrinfo() from being able to
  resolve any records with a response over 1200 bytes.

  [test case]

  use ping or telnet, which use getaddrinfo(), to lookup an A record
  with a lot of results, like toomany100.ddstreet.org

  $ telnet toomany100.ddstreet.org
  telnet: could not resolve toomany100.ddstreet.org/telnet: Temporary failure 
in name resolution

  [regression potential]

  any regression would likely result in failure to correctly lookup a
  hostname or to provide the correct response to a local client.

  [other info]

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1849733/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1846499] Re: e2scrub_all.service is a disabled or a static unit not running, not starting it.

2019-10-25 Thread Richard Kmausenberger
I had the same bug. What I did:

sudo systemctl stop e2scrub_reap.service

(I had to run it in Xterm, because the gnome-terminal didn't launch)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to e2fsprogs in Ubuntu.
https://bugs.launchpad.net/bugs/1846499

Title:
  e2scrub_all.service is a disabled or a static unit not running, not
  starting it.

Status in e2fsprogs package in Ubuntu:
  New

Bug description:
  Upon attempting to upgrade form Ubuntu 19.04 to Ubuntu 19.10. The
  installation got stuck with this being the last command line output:

  "e2scrub_all.service is a disabled or a static unit not running, not
  starting it."

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/e2fsprogs/+bug/1846499/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1847980] Re: Lightdm is just a black screen when booting kernel 5.3 on an i5-6500, but kernels 5.0/5.2 work

2019-10-25 Thread Timo Aaltonen
and test newer mainline kernels
https://kernel.ubuntu.com/~kernel-ppa/mainline/

try 5.4-rc4 and if it doesn't work, drm-tip

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1847980

Title:
  Lightdm is just a black screen when booting kernel 5.3 on an i5-6500,
  but kernels 5.0/5.2 work

Status in lightdm package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in xorg-server package in Ubuntu:
  Confirmed

Bug description:
  Xorg freeze at boot on Intel Corporation HD Graphics 530 with 
linux-image-5.3.0-17 after upgraded to the development release Ubuntu Eoan 
Ermine (development branch).
  If i boot with linux-image-5.0.0-31-generic the Xorg works well.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.0.0-31.33-generic 5.0.21
  Uname: Linux 5.0.0-31-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  Date: Mon Oct 14 11:15:23 2019
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GpuHangFrequency: Continuously
  GpuHangReproducibility: Yes, I can easily reproduce it
  GpuHangStarted: Immediately after installing this version of Ubuntu
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-31-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  dmi.chassis.asset.tag: CZC64082W1
  dmi.chassis.type: 4
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrN01Ver.02.42:bd08/19/2019:svnHP:pnHPEliteDesk800G2SFF:pvr:rvnHP:rn8054:rvrKBCVersion05.36:cvnHP:ct4:cvr:
  dmi.product.family: 103C_53307F G=D
  dmi.product.name: HP EliteDesk 800 G2 SFF
  dmi.product.sku: X3J10ET#ABZ
  dmi.sys.vendor: HP
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.1-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroRelease: Ubuntu 19.10
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  Package: xorg-server (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-17-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro nomodeset 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  ProcVersionSignature: Ubuntu 5.3.0-17.18-generic 5.3.1
  Tags:  eoan ubuntu
  Uname: Linux 5.3.0-17-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  dmi.chassis.asset.tag: 

[Touch-packages] [Bug 1849658] Re: resolved fallback to TCP fails for truncated UDP replies

2019-10-25 Thread Launchpad Bug Tracker
** Merge proposal linked:
   
https://code.launchpad.net/~ddstreet/ubuntu/+source/systemd/+git/systemd/+merge/374714

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1849658

Title:
  resolved fallback to TCP fails for truncated UDP replies

Status in systemd package in Ubuntu:
  In Progress
Status in systemd source package in Disco:
  In Progress
Status in systemd source package in Eoan:
  In Progress
Status in systemd source package in Focal:
  In Progress

Bug description:
  [impact]

  for DNS UDP replies larger than 512 bytes, fallback to TCP is used.
  For example 'host toomany.ddstreet.org'.

  Due to a bug in resolved in refcounting DNS stream types, the refcount
  underflows for type 0 streams (which resolved uses to talk to upstream
  nameservers), resulting in resolved being unable to fallback to TCP to
  handle truncated UDP replies.

  [test case]

  ubuntu@sf247344-upstream:~$ dig +noanswer +noedns toomany.ddstreet.org
  ;; Truncated, retrying in TCP mode.

  ; <<>> DiG 9.11.3-1ubuntu1.9-Ubuntu <<>> +noanswer +noedns 
toomany.ddstreet.org
  ;; global options: +cmd
  ;; Got answer:
  ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2683
  ;; flags: qr rd ra; QUERY: 1, ANSWER: 40, AUTHORITY: 0, ADDITIONAL: 0

  ;; QUESTION SECTION:
  ;toomany.ddstreet.org.IN  A

  ;; Query time: 0 msec
  ;; SERVER: 127.0.0.53#53(127.0.0.53)
  ;; WHEN: Thu Oct 24 11:40:29 UTC 2019
  ;; MSG SIZE  rcvd: 678

  ubuntu@sf247344-upstream:~$ sudo resolvectl flush-caches
  ubuntu@sf247344-upstream:~$ dig +noanswer +noedns toomany.ddstreet.org

  ; <<>> DiG 9.11.3-1ubuntu1.9-Ubuntu <<>> +noanswer +noedns 
toomany.ddstreet.org
  ;; global options: +cmd
  ;; connection timed out; no servers could be reached

  [regression potential]

  very low, as this only properly sets the stream type in the DnsStream
  object; any regression would be a failure to be able to use TCP for
  DNS requests or replies.

  [other info]

  https://github.com/systemd/systemd/pull/13838

  The commit adding stream types is not present in x/b, so this is
  needed only for disco and later.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1849658/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1556439] Re: pulseaudio crashed with SIGABRT in pa_sink_input_assert_ref() from pa_sink_input_finish_move() from pa_sink_move_all_finish() from card_set_profile() from pa_card_se

2019-10-25 Thread Daniel van Vugt
Verified in version 1:11.1-1ubuntu7.4 best I can tell due to no
crashes...

** Tags removed: verification-needed-bionic
** Tags added: verification-done-bionic

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.
https://bugs.launchpad.net/bugs/1556439

Title:
  pulseaudio crashed with SIGABRT in pa_sink_input_assert_ref() from
  pa_sink_input_finish_move() from pa_sink_move_all_finish() from
  card_set_profile() from pa_card_set_profile

Status in PulseAudio:
  Fix Released
Status in pulseaudio package in Ubuntu:
  Fix Released
Status in pulseaudio source package in Bionic:
  Fix Committed
Status in pulseaudio source package in Cosmic:
  Fix Released
Status in pulseaudio source package in Disco:
  Fix Released
Status in pulseaudio source package in Eoan:
  Fix Released

Bug description:
  [Impact]

  https://errors.ubuntu.com/problem/a83a007593c81501c4fbb4e9ac0f47e0b3880d17

  This is one of the top pulseaudio crashes in Ubuntu 18.04 according to:
  
https://errors.ubuntu.com/?release=Ubuntu%2018.04=pulseaudio=year

  [Test Case]

  No manual test case known. Just watch errors.ubuntu.com to check for
  recurrences.

  [Regression Potential]

  Low. The fix is already in PulseAudio 12 so has been used in Ubuntu
  18.10 and later for a year so far.

  [Original Report]

  Changing between Logitech G933 digital and analog and Logitech G930
  digital and analog

  ProblemType: Crash
  DistroRelease: Ubuntu 16.04
  Package: pulseaudio 1:8.0-0ubuntu2
  ProcVersionSignature: Ubuntu 4.4.0-12.28-generic 4.4.4
  Uname: Linux 4.4.0-12-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset wl nvidia
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sat Mar 12 17:20:34 2016
  EcryptfsInUse: Yes
  ExecutablePath: /usr/bin/pulseaudio
  InstallationDate: Installed on 2016-02-22 (19 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  ProcCmdline: /usr/bin/pulseaudio --start --log-target=syslog
  ProcEnviron:
   PATH=(custom, no user)
   SHELL=/bin/bash
   LANG=sv_SE.UTF-8
   LANGUAGE=sv
   XDG_RUNTIME_DIR=
  Signal: 6
  SourcePackage: pulseaudio
  StacktraceTop:
   pa_sink_input_finish_move () from 
/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecore-8.0.so
   pa_sink_move_all_finish () from 
/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecore-8.0.so
   ?? () from /usr/lib/pulse-8.0/modules/module-alsa-card.so
   pa_card_set_profile () from 
/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecore-8.0.so
   ?? () from /usr/lib/pulse-8.0/modules/libprotocol-native.so
  Title: pulseaudio crashed with SIGABRT in pa_sink_input_finish_move()
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 09/30/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 2001
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: X99-DELUXE
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr2001:bd09/30/2015:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnX99-DELUXE:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: All Series
  dmi.product.version: System Version
  dmi.sys.vendor: ASUS

To manage notifications about this bug go to:
https://bugs.launchpad.net/pulseaudio/+bug/1556439/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
The difference is in the includes:

Good:
grep -Hrn __NR_semtimedop *
asm-generic/unistd.h:539:#define __NR_semtimedop 192
asm-generic/unistd.h:540:__SC_COMP(__NR_semtimedop, sys_semtimedop, 
compat_sys_semtimedop)
s390x-linux-gnu/bits/syscall.h:1782:#ifdef __NR_semtimedop
s390x-linux-gnu/bits/syscall.h:1783:# define SYS_semtimedop __NR_semtimedop

Bad:
# grep -Hrn __NR_semtimedop *
asm-generic/unistd.h:571:#define __NR_semtimedop 192
asm-generic/unistd.h:572:__SC_3264(__NR_semtimedop, sys_semtimedop_time32, 
sys_semtimedop)
>>>  s390x-linux-gnu/asm/unistd_64.h:336:#define __NR_semtimedop 392
s390x-linux-gnu/bits/syscall.h:1894:#ifdef __NR_semtimedop
s390x-linux-gnu/bits/syscall.h:1895:# define SYS_semtimedop __NR_semtimedop

That is from Package: linux-libc-dev:s390x
Which is from source "linux" so the kernel I'd think then.

Good: 5.0.0-32.34
Bad: 5.3.0-19.20

Hmm, a kernel change then?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  

[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
include/seccomp.h
#define __PNR_semtimedop-204
#ifndef __NR_semtimedop
#define __NR_semtimedop __PNR_semtimedop
#endif /* __NR_semtime */

So if __NR_semtimedop is 392 then it would not set -204 and we'd get
this result.

Turns out that all but SCMP_SYS(semop) have changed on this s390x build.
A build with -E shows that.


Good:
 rc = seccomp_rule_add(ctx, 0x7fffU, (-201), 0);
 if (rc != 0)
  goto out;
 rc = seccomp_rule_add(ctx, 0x7fffU, (-204), 0);
 if (rc != 0)
  goto out;
 rc = seccomp_rule_add(ctx, 0x7fffU, (-202), 0);
 if (rc != 0)
  goto out;

Bad:
 rc = seccomp_rule_add(ctx, 0x7fffU, (-201), 0);
 if (rc != 0)
  goto out;
 rc = seccomp_rule_add(ctx, 0x7fffU, (
# 61 "36-sim-ipc_syscalls.c" 3 4
   392
# 61 "36-sim-ipc_syscalls.c"
   ), 0);
 if (rc != 0)
  goto out;
 rc = seccomp_rule_add(ctx, 0x7fffU, (
# 65 "36-sim-ipc_syscalls.c" 3 4
   393
# 65 "36-sim-ipc_syscalls.c"
   ), 0);
 if (rc != 0)
  goto out;

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test 

[Touch-packages] [Bug 1849608] Re: systemd resolv should separate the output of stdout and stderr

2019-10-25 Thread Launchpad Bug Tracker
** Merge proposal linked:
   
https://code.launchpad.net/~ddstreet/ubuntu/+source/systemd/+git/systemd/+merge/374715

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1849608

Title:
  systemd resolv should separate the output of stdout and stderr

Status in systemd package in Ubuntu:
  Confirmed
Status in systemd source package in Eoan:
  New
Status in systemd source package in Focal:
  Confirmed

Bug description:
  [impact]

  dhclient fails to notify resolved about DNS servers due to bash-
  specific redirect inside 'resolved' hook script

  [test case]

  see original description below

  [regression potential]

  any regression would likely cause resolved not to be aware of
  dhclient-provided dns servers

  [other info]

  This is needed only in Eoan and later; X/B/D do not have the bash-
  specific redirect '&>' in their hook file.

  original description:
  ---

  
  The file /etc/dhcp/dhclient-enter-hooks.d/resolved
  provided by systemd (242-7ubuntu3) causes the dhclient failing to get DNS due 
to systemd-resolved is not run.
  This issue can be reproduced on Ubuntu Eoan:
  ==
  root@eoan:~# dhclient -v
  Internet Systems Consortium DHCP Client 4.4.1
  Copyright 2004-2018 Internet Systems Consortium.
  All rights reserved.
  For info, please visit https://www.isc.org/software/dhcp/

  Listening on LPF/ens224/00:0c:29:92:d4:da
  Sending on   LPF/ens224/00:0c:29:92:d4:da
  Listening on LPF/ens192/00:0c:29:92:d4:d0
  Sending on   LPF/ens192/00:0c:29:92:d4:d0
  Listening on LPF/ens160/00:0c:29:92:d4:c6
  Sending on   LPF/ens160/00:0c:29:92:d4:c6
  Sending on   Socket/fallback
  DHCPDISCOVER on ens224 to 255.255.255.255 port 67 interval 3 (xid=0x6d9fb33d)
  DHCPDISCOVER on ens192 to 255.255.255.255 port 67 interval 3 (xid=0xeb8fda26)
  DHCPREQUEST for 192.168.120.4 on ens160 to 255.255.255.255 port 67 
(xid=0x6d39545d)
  DHCPACK of 192.168.120.4 from 192.168.120.254 (xid=0x5d54396d)
  RTNETLINK answers: File exists
  d41d8cd98f00b204e9800998ecf8427e  
/run/systemd/resolved.conf.d/isc-dhcp-v4-ens160.conf
  md5sum: /run/systemd/resolved.conf.d/isc-dhcp-v6-ens160.conf: No such file or 
directory
  5025823d750dda1f3f15e306c4a0afce  
/run/systemd/resolved.conf.d/isc-dhcp-v4-ens160.conf
  md5sum: /run/systemd/resolved.conf.d/isc-dhcp-v6-ens160.conf: No such file or 
directory
  bound to 192.168.120.4 -- renewal in 111 seconds.
  root@eoan:~# resolvectl status |grep DNS
  MulticastDNS setting: no
    DNSOverTLS setting: no
    DNSSEC setting: no
  DNSSEC supported: no
    DNSSEC NTA: 10.in-addr.arpa
  MulticastDNS setting: no
    DNSOverTLS setting: no
    DNSSEC setting: no
  DNSSEC supported: no
  MulticastDNS setting: no
    DNSOverTLS setting: no
    DNSSEC setting: no
  DNSSEC supported: no
  MulticastDNS setting: no
    DNSOverTLS setting: no
    DNSSEC setting: no
  DNSSEC supported: no
  ==

  Attached please find the patch for this. The output for md5sum in the
  hook file resolv should separate the stdout and stderr so it won't
  compare the wrong data.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1849608/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
Note: it became a PIE executable in Eoan, but haven't we had pie as
default much longer?

The difference is in:
  rc = seccomp_rule_add(ctx, SCMP_ACT_ALLOW, SCMP_SYS(semtimedop), 0);

In the bad case it returns -14

Good:
Breakpoint 2, seccomp_rule_add (ctx=0x2aa00049260, action=2147418112, 
syscall=-204, arg_cnt=0) at api.c:429
Bad:
Breakpoint 2, seccomp_rule_add (ctx=0x2aa000492a0, action=2147418112, 
syscall=392, arg_cnt=0) at api.c:429

Look at the syscall number it is very different.
In the good case all are -2xx (also all following ones)


So maybe "SCMP_SYS(semtimedop)" for s390x no more works well?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on 

[Touch-packages] [Bug 1837170] Re: Kodi package crash after the update of libdrm-amdgpu1

2019-10-25 Thread Timo Aaltonen
please test mesa 19.2.1 from ppa:ubuntu-x-swat/updates

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1837170

Title:
  Kodi package crash after the update of libdrm-amdgpu1

Status in mesa package in Ubuntu:
  Incomplete

Bug description:
  Greetings,

  The last update of libdrm-amdgpu1 caused a bug on Kodi package, making
  it to crash after loading any video or reproduce a black image.

  Version: 2.4.97-1ubuntu1~18.04.12019-07-03 15:07:54 UTC

libdrm (2.4.97-1ubuntu1~18.04.1) bionic; urgency=medium

* Backport to bionic for 18.04.3 HWE stack update. (LP: #1824111)

   -- Timo Aaltonen  Wed, 10 Apr 2019 13:54:06
  +0300

  
  Kodi gives this error:

  #3  0x7f47676c60aa in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
  #4  0x7f47676c5dd7 in ?? () from 
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

  Repeated several times

  #3  0x7f475ce2c5a6 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1
  #4  0x7f475ce2c425 in ?? () from /usr/lib/x86_64-linux-gnu/libLLVM-8.so.1

  Team-Kodi stated these errors are in relation to 'Not supported GPU
  drivers', when Kodi can't find these files.

  
  I've found the cause, and a temporary solution:

  This bug was caused after an update for the latest version of libdrm-
  amdgpu1 2.4.97-1ubuntu1~18.04.1

  So I grabbed the previous version from 
  https://mirror.transip.net/ubuntu/ubuntu/pool/main/libd/libdrm/

  installed libdrm-amdgpu1_2.4.95-1~18.04.1_amd64.deb

  and now Kodi returns.

  
  I created a bug report, the problem affects multiple users.

  https://bugs.launchpad.net/ubuntu/+source/kodi/+bug/1836828

  
  We have a PointRelease coming soon, would we have time to fix this package?

  Thank you for your assistance.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1837170/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
This is non stripped and only 112 lines of C

./36-sim-ipc_syscalls: ELF 64-bit MSB pie executable, IBM S/390, version
1 (SYSV), dynamically linked, interpreter /lib/ld64.so.1,
BuildID[sha1]=15c4946540be396acecc4273529e252eceff398f, for GNU/Linux
3.2.0, with debug_info, not stripped

wc -l 36-sim-ipc_syscalls.c
112 36-sim-ipc_syscalls.c

That should be debuggable I guess ...

Re-Build without optimization:
# gcc -DHAVE_CONFIG_H -I. -I..  -I../include -Wdate-time -D_FORTIFY_SOURCE=2 
-Wall -g -O0 -fdebug-prefix-map=/root/libseccomp-2.4.1=. 
-fstack-protector-strong -Wformat -Werror=format-security -c -o 
36-sim-ipc_syscalls.o 36-sim-ipc_syscalls.c
# gcc -Wall -g -O0 -fdebug-prefix-map=/root/libseccomp-2.4.1=. 
-fstack-protector-strong -Wformat -Werror=format-security 
-Wl,-Bsymbolic-functions -Wl,-z -Wl,relro -o 36-sim-ipc_syscalls 
36-sim-ipc_syscalls.o  -lpthread ./.libs/util.a ../src/.libs/libseccomp.a

Install gdb and check what might be going on ...

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 

[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
Note: the debug needs nothing very special
$ apt build-dep libseccomp
$ pull-lp-source libseccomp
$ cd libseccomp-2.4.1/
$ ./debian/rules build

Is enough to trigger the failing build.
To then afterwards re-iterate on the failing code run:

$ cd tests
$ ./36-sim-ipc_syscalls

Good: some output and RC=0
Bad: no output, RC=14

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on i386/ppc64
  On x86_64 this test succeeds:

  Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

To manage notifications about this bug go to:

[Touch-packages] [Bug 1849785] Re: FTBFS on i386/ppc64/s390x (Eoan+Focal)

2019-10-25 Thread Christian Ehrhardt 
I wanted to have a good case for comparison, so I also spawned Disco and there 
the same passes.
The subtests are reporting "SUCCESS" and overall it is skipped for non native.
Test 36-sim-ipc_syscalls%%023-1 result:   SUCCESS
...
Test 36-sim-ipc_syscalls%%025-1 result:   SKIPPED (only valid in native/c 
mode)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when running on i386/ppc64
  On x86_64 this test succeeds:

  Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

To manage notifications about this bug go to:

[Touch-packages] [Bug 1726068] Re: debconf socket closes if aptdaemon/PK client exits

2019-10-25 Thread Timo Aaltonen
ping, will the test case be improved?

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to packagekit in Ubuntu.
https://bugs.launchpad.net/bugs/1726068

Title:
  debconf socket closes if aptdaemon/PK client exits

Status in apper package in Ubuntu:
  New
Status in aptdaemon package in Ubuntu:
  Fix Released
Status in packagekit package in Ubuntu:
  Fix Released
Status in software-properties package in Ubuntu:
  Invalid
Status in apper source package in Bionic:
  New
Status in aptdaemon source package in Bionic:
  New
Status in packagekit source package in Bionic:
  New
Status in apper source package in Disco:
  New
Status in aptdaemon source package in Disco:
  New
Status in packagekit source package in Disco:
  Incomplete

Bug description:
  [Impact]
  Closing an application using PackageKit or aptdaemon to install packages 
kills the debconf endpoint (because it's a subprocess that's cleaned up), 
causing debconf to use defaults which might lead to wrong results, or even 
cause installations to fail.

  [Solution]
  The solution is to move the end point into a socket-activated systemd unit, 
so that it is independent of the graphical frontend that started the 
transaction. The other advantage is that this offers us restart if the end 
point crashes.

  [Test case]
  1. Install opera deb using packagekit, ensure service is activated
  2. Install opera deb using aptdaemon, ensure service is activated

  Alternatively, you might use another deb that has debconf prompts.

  [Regression potential]
  Systems that do not yet use systemd will fall back to the old method, so 
should not regress.

  Otherwise, if there are bugs, they'd affect the ability to show
  debconf prompts, and behavior would revert to using the defaults.

  There might be some uncertainty if you restart your desktop while the
  helper is running and it does not pick up the new X/Wayland display
  until it restarts (it should fail to connect and restart). Given that
  the helper times out, this should not be an issue in practice, as
  you'd have to logout, login, and start a new install within 60
  seconds.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apper/+bug/1726068/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849785] Re: Build error on i386/ppc64/s390x (Focal)

2019-10-25 Thread Christian Ehrhardt 
Interestingly this is already FTBFS in Eoan.
I have created LXD environments doing rebuilds of the same source and they fail 
the same way in Eoan and Focal.

The last successful build in Launchpad if from 4th of May, so something
else going into Eoan already broke this.

** Summary changed:

- Build error on i386/ppc64/s390x (Focal)
+ FTBFS on i386/ppc64/s390x (Eoan+Focal)

** Tags added: ftbfs

** Also affects: libseccomp (Ubuntu Eoan)
   Importance: Undecided
   Status: New

** Changed in: libseccomp (Ubuntu)
   Status: New => Confirmed

** Changed in: libseccomp (Ubuntu Eoan)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  FTBFS on i386/ppc64/s390x (Eoan+Focal)

Status in libseccomp package in Ubuntu:
  Confirmed
Status in libseccomp source package in Eoan:
  Confirmed

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls 
rc=14
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390

  
   batch name: 37-sim-ipc_syscalls_be
   test mode:  c
   test type:  bpf-sim
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test arch:  s390
  Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
   test mode:  c
   test type:  bpf-valgrind
  Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 
37-sim-ipc_syscalls_be rc=14

  
  It is always the s390x test - even when 

[Touch-packages] [Bug 1847980] Re: Lightdm is just a black screen when booting kernel 5.3 on an i5-6500, but kernels 5.0/5.2 work

2019-10-25 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: lightdm (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1847980

Title:
  Lightdm is just a black screen when booting kernel 5.3 on an i5-6500,
  but kernels 5.0/5.2 work

Status in lightdm package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in xorg-server package in Ubuntu:
  Confirmed

Bug description:
  Xorg freeze at boot on Intel Corporation HD Graphics 530 with 
linux-image-5.3.0-17 after upgraded to the development release Ubuntu Eoan 
Ermine (development branch).
  If i boot with linux-image-5.0.0-31-generic the Xorg works well.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.0.0-31.33-generic 5.0.21
  Uname: Linux 5.0.0-31-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  Date: Mon Oct 14 11:15:23 2019
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GpuHangFrequency: Continuously
  GpuHangReproducibility: Yes, I can easily reproduce it
  GpuHangStarted: Immediately after installing this version of Ubuntu
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-31-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  dmi.chassis.asset.tag: CZC64082W1
  dmi.chassis.type: 4
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrN01Ver.02.42:bd08/19/2019:svnHP:pnHPEliteDesk800G2SFF:pvr:rvnHP:rn8054:rvrKBCVersion05.36:cvnHP:ct4:cvr:
  dmi.product.family: 103C_53307F G=D
  dmi.product.name: HP EliteDesk 800 G2 SFF
  dmi.product.sku: X3J10ET#ABZ
  dmi.sys.vendor: HP
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.1-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroRelease: Ubuntu 19.10
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  Package: xorg-server (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-17-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro nomodeset 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  ProcVersionSignature: Ubuntu 5.3.0-17.18-generic 5.3.1
  Tags:  eoan ubuntu
  Uname: Linux 5.3.0-17-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  

[Touch-packages] [Bug 1847980] Re: Lightdm is just a black screen when booting kernel 5.3 on an i5-6500, but kernels 5.0/5.2 work

2019-10-25 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: xorg-server (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1847980

Title:
  Lightdm is just a black screen when booting kernel 5.3 on an i5-6500,
  but kernels 5.0/5.2 work

Status in lightdm package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in xorg-server package in Ubuntu:
  Confirmed

Bug description:
  Xorg freeze at boot on Intel Corporation HD Graphics 530 with 
linux-image-5.3.0-17 after upgraded to the development release Ubuntu Eoan 
Ermine (development branch).
  If i boot with linux-image-5.0.0-31-generic the Xorg works well.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.0.0-31.33-generic 5.0.21
  Uname: Linux 5.0.0-31-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  Date: Mon Oct 14 11:15:23 2019
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GpuHangFrequency: Continuously
  GpuHangReproducibility: Yes, I can easily reproduce it
  GpuHangStarted: Immediately after installing this version of Ubuntu
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-31-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  dmi.chassis.asset.tag: CZC64082W1
  dmi.chassis.type: 4
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrN01Ver.02.42:bd08/19/2019:svnHP:pnHPEliteDesk800G2SFF:pvr:rvnHP:rn8054:rvrKBCVersion05.36:cvnHP:ct4:cvr:
  dmi.product.family: 103C_53307F G=D
  dmi.product.name: HP EliteDesk 800 G2 SFF
  dmi.product.sku: X3J10ET#ABZ
  dmi.sys.vendor: HP
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.1-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: XFCE
  DistUpgraded: Fresh install
  DistroCodename: eoan
  DistroRelease: Ubuntu 19.10
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   Intel Corporation HD Graphics 530 [8086:1912] (rev 06) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 530 [103c:8054]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 047d:2048 Kensington Orbit Trackball with Scroll Ring
   Bus 001 Device 002: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: HP HP EliteDesk 800 G2 SFF
  Package: xorg-server (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-17-generic 
root=UUID=714cc192-0d1c-4899-b891-16e6e504c662 ro nomodeset 
resume=UUID=316a3e2d-ef98-4c31-8ba1-52e1cd0e8c05
  ProcVersionSignature: Ubuntu 5.3.0-17.18-generic 5.3.1
  Tags:  eoan ubuntu
  Uname: Linux 5.3.0-17-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 08/19/2019
  dmi.bios.vendor: HP
  dmi.bios.version: N01 Ver. 02.42
  dmi.board.name: 8054
  dmi.board.vendor: HP
  dmi.board.version: KBC Version 05.36
  

[Touch-packages] [Bug 1849785] [NEW] Build error on i386/ppc64/s390x (Focal)

2019-10-25 Thread Christian Ehrhardt 
Public bug reported:

Due to the python 3.8 transition in focal this was rebuilt but fails atm.
=> 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

The simulations fail in this case:
 batch name: 36-sim-ipc_syscalls
 test mode:  c
 test type:  bpf-sim
Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%003-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%004-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%005-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%006-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%007-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%008-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%009-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%010-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%011-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%012-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%013-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%014-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%015-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%016-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%017-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%018-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%019-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%020-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%021-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%022-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%023-1 result:   ERROR 36-sim-ipc_syscalls rc=14
Test 36-sim-ipc_syscalls%%024-1 result:   ERROR 36-sim-ipc_syscalls rc=14
 test mode:  c
 test type:  bpf-valgrind
Test 36-sim-ipc_syscalls%%025-1 result:   FAILURE 36-sim-ipc_syscalls rc=14
 batch name: 37-sim-ipc_syscalls_be
 test mode:  c
 test type:  bpf-sim
 test arch:  s390


 batch name: 37-sim-ipc_syscalls_be
 test mode:  c
 test type:  bpf-sim
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%001-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%002-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%003-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%004-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%005-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%006-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%007-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%008-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%009-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%010-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%011-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test arch:  s390
Test 37-sim-ipc_syscalls_be%%012-1 result:   ERROR 37-sim-ipc_syscalls_be 
rc=14
 test mode:  c
 test type:  bpf-valgrind
Test 37-sim-ipc_syscalls_be%%013-1 result:   FAILURE 37-sim-ipc_syscalls_be 
rc=14


It is always the s390x test - even when running on i386/ppc64
On x86_64 this test succeeds:

Test 36-sim-ipc_syscalls%%025-1 result:   SUCCESS
 batch name: 37-sim-ipc_syscalls_be
 test mode:  c
 test type:  bpf-sim
 test arch:  s390

** Affects: libseccomp (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: update-excuse

** Tags added: update-excuse

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to libseccomp in Ubuntu.
https://bugs.launchpad.net/bugs/1849785

Title:
  Build error on i386/ppc64/s390x (Focal)

Status in libseccomp package in Ubuntu:
  New

Bug description:
  Due to the python 3.8 transition in focal this was rebuilt but fails atm.
  => 
https://launchpadlibrarian.net/448119198/buildlog_ubuntu-focal-s390x.libseccomp_2.4.1-0ubuntu0.19.10.4_BUILDING.txt.gz

  The simulations fail in this case:
   batch name: 36-sim-ipc_syscalls
   test mode:  c
   test type:  bpf-sim
  Test 36-sim-ipc_syscalls%%001-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 36-sim-ipc_syscalls%%002-1 result:   ERROR 36-sim-ipc_syscalls rc=14
  Test 

[Touch-packages] [Bug 1826085] Re: Mesa Vulkan VK_INTEL_performance_query extension

2019-10-25 Thread Timo Aaltonen
19.10 shipped with mesa 19.2.1

** Project changed: mesa => mesa (Ubuntu)

** Changed in: mesa (Ubuntu)
   Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1826085

Title:
  Mesa Vulkan VK_INTEL_performance_query extension

Status in intel:
  Fix Released
Status in mesa package in Ubuntu:
  Fix Released

Bug description:
  Description:
  Mesa Vulkan VK_INTEL_performance_query extension

  Adds support to Mesa and kernel for a new Vulkan extension called 
“VK_INTEL_performance_query” enabling exposure of Intel based GPU metric 
collection. Enable support for query based metrics in Linux Vulkan for Intel 
Graphics Performance Analyzers (Intel GPA), Enables metrics to be collected on 
Integrated graphics beginning with Broadwell (Skylake, Kabylake, Coffeelake, 
Icelake, …).
  Intel GPA already supports Linux OpenGL hardware based metrics. Obtaining 
hardware metrics for Vulkan based workloads is essential to make GPA’s 
profiling capabilities usable.
  Several internal customers and ISV’s rely on GPA to enable best in class game 
performance on Intel hardware.
  Key for hardware design win that depends upon holistic Vulkan support in 
Linux including query based performance metric analysis.

  External links:
  mesa (https://github.intel.com/lglandwe/mesa.git) Branch: 
wip/djdeath/vk_intel_performance_query
  kernel (https://github.com/djdeath/linux.git) Branch: 
wip/djdeath/oa-hold-preempt

  
  Targeted Ubuntu Release: 18.04.3/19.10
  Targeted Mesa version: TBD

To manage notifications about this bug go to:
https://bugs.launchpad.net/intel/+bug/1826085/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1826085] [NEW] Mesa Vulkan VK_INTEL_performance_query extension

2019-10-25 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

Description:
Mesa Vulkan VK_INTEL_performance_query extension

Adds support to Mesa and kernel for a new Vulkan extension called 
“VK_INTEL_performance_query” enabling exposure of Intel based GPU metric 
collection. Enable support for query based metrics in Linux Vulkan for Intel 
Graphics Performance Analyzers (Intel GPA), Enables metrics to be collected on 
Integrated graphics beginning with Broadwell (Skylake, Kabylake, Coffeelake, 
Icelake, …).
Intel GPA already supports Linux OpenGL hardware based metrics. Obtaining 
hardware metrics for Vulkan based workloads is essential to make GPA’s 
profiling capabilities usable.
Several internal customers and ISV’s rely on GPA to enable best in class game 
performance on Intel hardware.
Key for hardware design win that depends upon holistic Vulkan support in Linux 
including query based performance metric analysis.

External links:
mesa (https://github.intel.com/lglandwe/mesa.git) Branch: 
wip/djdeath/vk_intel_performance_query
kernel (https://github.com/djdeath/linux.git) Branch: 
wip/djdeath/oa-hold-preempt


Targeted Ubuntu Release: 18.04.3/19.10
Targeted Mesa version: TBD

** Affects: intel
 Importance: Undecided
 Status: Fix Released

** Affects: mesa (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: intel-upkg-19.10
-- 
Mesa Vulkan VK_INTEL_performance_query extension 
https://bugs.launchpad.net/bugs/1826085
You received this bug notification because you are a member of Ubuntu Touch 
seeded packages, which is subscribed to mesa in Ubuntu.

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1835541] Re: ibus only provides non-standard UK keyboard layouts

2019-10-25 Thread Bug Watch Updater
** Changed in: ibus (Debian)
   Status: Unknown => New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ibus in Ubuntu.
https://bugs.launchpad.net/bugs/1835541

Title:
  ibus only provides non-standard UK keyboard layouts

Status in ibus package in Ubuntu:
  Confirmed
Status in ibus package in Debian:
  New

Bug description:
  When I attempt to add my standard UK keyboard to the layouts ibus
  knows about, I cannot do so.

  (See the attached image for the list of available layouts.)

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: ibus 1.5.19-4ubuntu1
  ProcVersionSignature: Ubuntu 5.0.0-20.21-generic 5.0.8
  Uname: Linux 5.0.0-20-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.11-0ubuntu3
  Architecture: amd64
  CurrentDesktop: i3
  Date: Fri Jul  5 10:07:41 2019
  InstallationDate: Installed on 2019-05-07 (58 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  SourcePackage: ibus
  UpgradeStatus: Upgraded to eoan on 2019-05-08 (57 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1835541/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1849751] Re: vulkan support on intel broken after 19.10 upgrade

2019-10-25 Thread Timo Aaltonen
using 'nomodeset' disables the intel gpu completely, so vulkan not
working is the least of your problems ;)

you could try installing newer mainline kernels from 
kernel.ubuntu.com/~kernel-ppa/mainline/

maybe start from v5.4-rc and if it doesn't work, try drm-tip. Install
the amd64 version of unsigned and modules packages

** Package changed: mesa (Ubuntu) => linux (Ubuntu)

** Changed in: linux (Ubuntu)
   Status: New => Incomplete

** Changed in: linux (Ubuntu)
 Assignee: (unassigned) => Timo Aaltonen (tjaalton)

** Summary changed:

- vulkan support on intel broken after 19.10 upgrade
+ [i915] doesn't boot after 19.10 upgrade

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.
https://bugs.launchpad.net/bugs/1849751

Title:
  [i915] doesn't boot after 19.10 upgrade

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  after upgrading to ubuntu 19.10, vulkan support when using the intel
  card in my laptop is broken. running any of my example vulkan apps
  shows the following error:

  $ vkcube
  vkcube: 
/build/vulkan-tools-IZAxVX/vulkan-tools-1.1.114.0+dfsg1/cube/cube.c:3175: 
demo_init_vk: Assertion `!err' failed.
  Aborted (core dumped)

  note that since the update I can no longer boot my system at all
  without adding "nomodeset" the kernel params, something is broken in
  the intel modeset driver since 19.04. so this may very well be
  related.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: mesa-vulkan-drivers 19.2.1-1ubuntu1
  ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
  Uname: Linux 5.3.0-19-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
  ApportVersion: 2.20.11-0ubuntu8
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Thu Oct 24 20:04:54 2019
  DistUpgraded: 2019-10-23 18:54:04,373 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: eoan
  DistroVariant: ubuntu
  DkmsStatus: zfs, 0.8.1, 5.3.0-19-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation HD Graphics 630 [8086:591b] (rev 04) (prog-if 00 [VGA 
controller])
 Subsystem: CLEVO/KAPOK Computer HD Graphics 630 [1558:65a1]
   NVIDIA Corporation GP104BM [GeForce GTX 1070 Mobile] [10de:1be1] (rev a1) 
(prog-if 00 [VGA controller])
 Subsystem: CLEVO/KAPOK Computer GP104BM [GeForce GTX 1070 Mobile] 
[1558:65a3]
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 04f2:b5a7 Chicony Electronics Co., Ltd Chicony USB 
2.0 Camera
   Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
   Bus 001 Device 002: ID 1c7a:0603 LighTuning Technology Inc. EgisTec_ES603
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: System76 Oryx Pro
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.3.0-19-generic root=ZFS=rpool/root 
ro root=ZFS=rpool/root quiet nomodeset
  SourcePackage: mesa
  UpgradeStatus: Upgraded to eoan on 2019-10-23 (1 days ago)
  dmi.bios.date: 02/20/2017
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1.05.02dRSA2
  dmi.board.asset.tag: Tag 12345
  dmi.board.name: Oryx Pro
  dmi.board.vendor: System76
  dmi.board.version: oryp3-ess
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: System76
  dmi.chassis.version: N/A
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr1.05.02dRSA2:bd02/20/2017:svnSystem76:pnOryxPro:pvroryp3-ess:rvnSystem76:rnOryxPro:rvroryp3-ess:cvnSystem76:ct10:cvrN/A:
  dmi.product.family: Not Applicable
  dmi.product.name: Oryx Pro
  dmi.product.sku: Not Applicable
  dmi.product.version: oryp3-ess
  dmi.sys.vendor: System76
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 19.2.1-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20190815-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1849751/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp