[Touch-packages] [Bug 1703821] Re: Dovecot and Apparmor complains at operation file_inherit

2020-02-15 Thread Launchpad Bug Tracker
[Expired for AppArmor because there has been no activity for 60 days.]

** Changed in: apparmor
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1703821

Title:
  Dovecot and Apparmor complains at operation file_inherit

Status in AppArmor:
  Expired
Status in apparmor package in Ubuntu:
  Expired
Status in dovecot package in Ubuntu:
  Invalid

Bug description:
  My server is running Ubuntu 17.04 and Dovecot 2.2.27 (c0f36b0).
  Apparmor is still complaining about problems with file_inherit. I have
  put the profiles in complain-only mode, so I can continue, but still,
  it's a problem.

  Jul 12 13:31:19 myserver kernel: [ 3905.672577] audit: type=1400
  audit(1499859079.016:363): apparmor="ALLOWED" operation="file_inherit"
  profile="/usr/lib/dovecot/anvil" pid=3766 comm="anvil" family="unix"
  sock_type="stream" protocol=0 requested_mask="send receive"
  denied_mask="send receive" addr=none peer_addr=none
  peer="/usr/sbin/dovecot"

  Jul 12 13:31:19 myserver kernel: [ 3905.672578] audit: type=1400
  audit(1499859079.016:364): apparmor="ALLOWED" operation="file_inherit"
  profile="/usr/sbin/dovecot" pid=3766 comm="anvil" family="unix"
  sock_type="stream" protocol=0 requested_mask="send receive"
  denied_mask="send receive" addr=none peer_addr=none
  peer="/usr/lib/dovecot/anvil"

  My configuration of Dovecot has changed slightly:

  /etc/dovecot/dovecot-sql.conf.ext
 driver = mysql
 connect = host=localhost dbname=mail user=mail password=mailpassword
 default_pass_scheme = MD5-CRYPT
 password_query = ...
 user_query = ...

  /etc/dovecot/conf.d/10-auth.conf
 disable_plaintext_auth = yes
 auth_mechanisms = plain login
 #!include auth-system.conf.ext
 !include auth-sql.conf.ext

  /etc/dovecot/conf.d/10-mail.conf
 mail_location = maildir:/var/vmail/%d/%n
 mail_uid = vmail
 mail_gid = mail
 first_valid_uid = 150
 last_valid_uid = 150

  /etc/dovecot/conf.d/10-ssl.conf
 ssl = required
 ssl_cert = 

  /usr/sbin/dovecot flags=(complain,attach_disconnected) {
#include 
#include 
#include 
#include 
#include 
#include 
#include 

capability chown,
capability dac_override,
capability fsetid,
capability kill,
capability net_bind_service,
capability setuid,
capability sys_chroot,
capability sys_resource,

/etc/dovecot/** r,
/etc/mtab r,
/etc/lsb-release r,
/etc/SuSE-release r,
@{PROC}/@{pid}/mounts r,
/usr/bin/doveconf rix,
/usr/lib/dovecot/anvil Px,
/usr/lib/dovecot/auth Px,
/usr/lib/dovecot/config Px,
/usr/lib/dovecot/dict Px,
/usr/lib/dovecot/dovecot-auth Pxmr,
/usr/lib/dovecot/imap Pxmr,
/usr/lib/dovecot/imap-login Pxmr,
/usr/lib/dovecot/lmtp Px,
/usr/lib/dovecot/log Px,
/usr/lib/dovecot/managesieve Px,
/usr/lib/dovecot/managesieve-login Pxmr,
/usr/lib/dovecot/pop3 Px,
/usr/lib/dovecot/pop3-login Pxmr,
/usr/lib/dovecot/ssl-build-param rix,
/usr/lib/dovecot/ssl-params Px,
/usr/sbin/dovecot mrix,
/usr/share/dovecot/protocols.d/   r,
/usr/share/dovecot/protocols.d/** r,
/var/lib/dovecot/ w,
/var/lib/dovecot/* rwkl,
/var/spool/postfix/private/auth w,
/var/spool/postfix/private/dovecot-lmtp w,
/{,var/}run/dovecot/ rw,
/{,var/}run/dovecot/** rw,
link /{,var/}run/dovecot/** -> /var/lib/dovecot/**,

# Site-specific additions and overrides. See local/README for details.
#include 
  }

  Profile usr.lib.dovecot.anvil:

  #include 

  /usr/lib/dovecot/anvil flags=(complain) {
#include 
#include 

capability setuid,
capability sys_chroot,

/usr/lib/dovecot/anvil mr,

# Site-specific additions and overrides. See local/README for details.
#include 
  }

To manage notifications about this bug go to:
https://bugs.launchpad.net/apparmor/+bug/1703821/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1855747] Re: systemd-udevd appears to be attempting to load Nvidia kernel modules in a tight loop

2020-02-15 Thread Launchpad Bug Tracker
[Expired for systemd (Ubuntu) because there has been no activity for 60
days.]

** Changed in: systemd (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1855747

Title:
  systemd-udevd appears to be attempting to load Nvidia kernel modules
  in a tight loop

Status in nvidia-graphics-drivers-440 package in Ubuntu:
  Expired
Status in systemd package in Ubuntu:
  Expired

Bug description:
  I'm seeing these lines repeated:

  ```
  Dec 09 12:01:45 surprise systemd-udevd[731]: nvidia: Process 
'/usr/bin/nvidia-smi' failed with exit code 9.
  Dec 09 12:01:46 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-modeset' failed with exit code 1.
  Dec 09 12:01:46 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-drm' failed with exit code 1.
  Dec 09 12:01:47 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-uvm' failed with exit code 1.
  Dec 09 12:01:48 surprise systemd-udevd[731]: nvidia: Process 
'/usr/bin/nvidia-smi' failed with exit code 9.
  Dec 09 12:01:49 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-modeset' failed with exit code 1.
  Dec 09 12:01:49 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-drm' failed with exit code 1.
  Dec 09 12:01:50 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-uvm' failed with exit code 1.
  ```

  My system has been up ~an hour:

  $ uptime
   12:02:28 up  1:00,  1 user,  load average: 4.52, 4.80, 5.50

  and I've seen a lot of these:

  $ journalctl -u systemd-udevd.service -b0 | grep -c "exit code 9"
  1333

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: udev 243-3ubuntu1
  ProcVersionSignature: Ubuntu 5.3.0-25.27-generic 5.3.13
  Uname: Linux 5.3.0-25-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.20.11-0ubuntu13
  Architecture: amd64
  CurrentDesktop: i3
  CustomUdevRuleFiles: 70-snap.core.rules 70-snap.spotify.rules
  Date: Mon Dec  9 11:59:10 2019
  InstallationDate: Installed on 2019-05-07 (215 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: Gigabyte Technology Co., Ltd. B450M DS3H
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.3.0-25-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash 
resume=UUID=73909634-a75d-42c9-8f66-a69138690756 vt.handoff=7
  SourcePackage: systemd
  UpgradeStatus: Upgraded to focal on 2019-11-15 (23 days ago)
  dmi.bios.date: 01/25/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F4
  dmi.board.asset.tag: Default string
  dmi.board.name: B450M DS3H-CF
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrF4:bd01/25/2019:svnGigabyteTechnologyCo.,Ltd.:pnB450MDS3H:pvrDefaultstring:rvnGigabyteTechnologyCo.,Ltd.:rnB450MDS3H-CF:rvrx.x:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: Default string
  dmi.product.name: B450M DS3H
  dmi.product.sku: Default string
  dmi.product.version: Default string
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.
  modified.conffile..etc.apport.crashdb.conf: [modified]
  modified.conffile..etc.udev.udev.conf: [modified]
  mtime.conffile..etc.apport.crashdb.conf: 2019-11-25T16:40:26.261317
  mtime.conffile..etc.udev.udev.conf: 2019-11-28T09:22:42.096686

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-440/+bug/1855747/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1855747] Re: systemd-udevd appears to be attempting to load Nvidia kernel modules in a tight loop

2020-02-15 Thread Launchpad Bug Tracker
[Expired for nvidia-graphics-drivers-440 (Ubuntu) because there has been
no activity for 60 days.]

** Changed in: nvidia-graphics-drivers-440 (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1855747

Title:
  systemd-udevd appears to be attempting to load Nvidia kernel modules
  in a tight loop

Status in nvidia-graphics-drivers-440 package in Ubuntu:
  Expired
Status in systemd package in Ubuntu:
  Expired

Bug description:
  I'm seeing these lines repeated:

  ```
  Dec 09 12:01:45 surprise systemd-udevd[731]: nvidia: Process 
'/usr/bin/nvidia-smi' failed with exit code 9.
  Dec 09 12:01:46 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-modeset' failed with exit code 1.
  Dec 09 12:01:46 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-drm' failed with exit code 1.
  Dec 09 12:01:47 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-uvm' failed with exit code 1.
  Dec 09 12:01:48 surprise systemd-udevd[731]: nvidia: Process 
'/usr/bin/nvidia-smi' failed with exit code 9.
  Dec 09 12:01:49 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-modeset' failed with exit code 1.
  Dec 09 12:01:49 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-drm' failed with exit code 1.
  Dec 09 12:01:50 surprise systemd-udevd[731]: nvidia: Process '/sbin/modprobe 
nvidia-uvm' failed with exit code 1.
  ```

  My system has been up ~an hour:

  $ uptime
   12:02:28 up  1:00,  1 user,  load average: 4.52, 4.80, 5.50

  and I've seen a lot of these:

  $ journalctl -u systemd-udevd.service -b0 | grep -c "exit code 9"
  1333

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: udev 243-3ubuntu1
  ProcVersionSignature: Ubuntu 5.3.0-25.27-generic 5.3.13
  Uname: Linux 5.3.0-25-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.20.11-0ubuntu13
  Architecture: amd64
  CurrentDesktop: i3
  CustomUdevRuleFiles: 70-snap.core.rules 70-snap.spotify.rules
  Date: Mon Dec  9 11:59:10 2019
  InstallationDate: Installed on 2019-05-07 (215 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: Gigabyte Technology Co., Ltd. B450M DS3H
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.3.0-25-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash 
resume=UUID=73909634-a75d-42c9-8f66-a69138690756 vt.handoff=7
  SourcePackage: systemd
  UpgradeStatus: Upgraded to focal on 2019-11-15 (23 days ago)
  dmi.bios.date: 01/25/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F4
  dmi.board.asset.tag: Default string
  dmi.board.name: B450M DS3H-CF
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrF4:bd01/25/2019:svnGigabyteTechnologyCo.,Ltd.:pnB450MDS3H:pvrDefaultstring:rvnGigabyteTechnologyCo.,Ltd.:rnB450MDS3H-CF:rvrx.x:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: Default string
  dmi.product.name: B450M DS3H
  dmi.product.sku: Default string
  dmi.product.version: Default string
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.
  modified.conffile..etc.apport.crashdb.conf: [modified]
  modified.conffile..etc.udev.udev.conf: [modified]
  mtime.conffile..etc.apport.crashdb.conf: 2019-11-25T16:40:26.261317
  mtime.conffile..etc.udev.udev.conf: 2019-11-28T09:22:42.096686

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-440/+bug/1855747/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1703821] Re: Dovecot and Apparmor complains at operation file_inherit

2020-02-15 Thread Launchpad Bug Tracker
[Expired for apparmor (Ubuntu) because there has been no activity for 60
days.]

** Changed in: apparmor (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apparmor in Ubuntu.
https://bugs.launchpad.net/bugs/1703821

Title:
  Dovecot and Apparmor complains at operation file_inherit

Status in AppArmor:
  Expired
Status in apparmor package in Ubuntu:
  Expired
Status in dovecot package in Ubuntu:
  Invalid

Bug description:
  My server is running Ubuntu 17.04 and Dovecot 2.2.27 (c0f36b0).
  Apparmor is still complaining about problems with file_inherit. I have
  put the profiles in complain-only mode, so I can continue, but still,
  it's a problem.

  Jul 12 13:31:19 myserver kernel: [ 3905.672577] audit: type=1400
  audit(1499859079.016:363): apparmor="ALLOWED" operation="file_inherit"
  profile="/usr/lib/dovecot/anvil" pid=3766 comm="anvil" family="unix"
  sock_type="stream" protocol=0 requested_mask="send receive"
  denied_mask="send receive" addr=none peer_addr=none
  peer="/usr/sbin/dovecot"

  Jul 12 13:31:19 myserver kernel: [ 3905.672578] audit: type=1400
  audit(1499859079.016:364): apparmor="ALLOWED" operation="file_inherit"
  profile="/usr/sbin/dovecot" pid=3766 comm="anvil" family="unix"
  sock_type="stream" protocol=0 requested_mask="send receive"
  denied_mask="send receive" addr=none peer_addr=none
  peer="/usr/lib/dovecot/anvil"

  My configuration of Dovecot has changed slightly:

  /etc/dovecot/dovecot-sql.conf.ext
 driver = mysql
 connect = host=localhost dbname=mail user=mail password=mailpassword
 default_pass_scheme = MD5-CRYPT
 password_query = ...
 user_query = ...

  /etc/dovecot/conf.d/10-auth.conf
 disable_plaintext_auth = yes
 auth_mechanisms = plain login
 #!include auth-system.conf.ext
 !include auth-sql.conf.ext

  /etc/dovecot/conf.d/10-mail.conf
 mail_location = maildir:/var/vmail/%d/%n
 mail_uid = vmail
 mail_gid = mail
 first_valid_uid = 150
 last_valid_uid = 150

  /etc/dovecot/conf.d/10-ssl.conf
 ssl = required
 ssl_cert = 

  /usr/sbin/dovecot flags=(complain,attach_disconnected) {
#include 
#include 
#include 
#include 
#include 
#include 
#include 

capability chown,
capability dac_override,
capability fsetid,
capability kill,
capability net_bind_service,
capability setuid,
capability sys_chroot,
capability sys_resource,

/etc/dovecot/** r,
/etc/mtab r,
/etc/lsb-release r,
/etc/SuSE-release r,
@{PROC}/@{pid}/mounts r,
/usr/bin/doveconf rix,
/usr/lib/dovecot/anvil Px,
/usr/lib/dovecot/auth Px,
/usr/lib/dovecot/config Px,
/usr/lib/dovecot/dict Px,
/usr/lib/dovecot/dovecot-auth Pxmr,
/usr/lib/dovecot/imap Pxmr,
/usr/lib/dovecot/imap-login Pxmr,
/usr/lib/dovecot/lmtp Px,
/usr/lib/dovecot/log Px,
/usr/lib/dovecot/managesieve Px,
/usr/lib/dovecot/managesieve-login Pxmr,
/usr/lib/dovecot/pop3 Px,
/usr/lib/dovecot/pop3-login Pxmr,
/usr/lib/dovecot/ssl-build-param rix,
/usr/lib/dovecot/ssl-params Px,
/usr/sbin/dovecot mrix,
/usr/share/dovecot/protocols.d/   r,
/usr/share/dovecot/protocols.d/** r,
/var/lib/dovecot/ w,
/var/lib/dovecot/* rwkl,
/var/spool/postfix/private/auth w,
/var/spool/postfix/private/dovecot-lmtp w,
/{,var/}run/dovecot/ rw,
/{,var/}run/dovecot/** rw,
link /{,var/}run/dovecot/** -> /var/lib/dovecot/**,

# Site-specific additions and overrides. See local/README for details.
#include 
  }

  Profile usr.lib.dovecot.anvil:

  #include 

  /usr/lib/dovecot/anvil flags=(complain) {
#include 
#include 

capability setuid,
capability sys_chroot,

/usr/lib/dovecot/anvil mr,

# Site-specific additions and overrides. See local/README for details.
#include 
  }

To manage notifications about this bug go to:
https://bugs.launchpad.net/apparmor/+bug/1703821/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861481] Re: language-options causes live CD sessions to be untranslated

2020-02-15 Thread Martin Wimpress
** Changed in: lightdm (Ubuntu)
   Status: In Progress => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.
https://bugs.launchpad.net/bugs/1861481

Title:
  language-options causes live CD sessions to be untranslated

Status in lightdm package in Ubuntu:
  Fix Released

Bug description:
  Since Ubuntu 19.10, for all Ubuntu live CDs that use LightDM (e.g.
  MATE and Xubuntu), if a user selects a language in syslinux other than
  those with an included langpack, the session is then untranslated.

  For example, if one boots Ubuntu MATE 20.04 and selects Greek in
  syslinux, he ends up with LANGUAGE=en in the session.

  The chain of events is:
  LightDM has an Ubuntu-specific patch that makes it call 
/usr/share/language-tools/language-options instead of the upstream `locale -a`.
  `locale -a` does list el_GR as a supported locale because casper correctly 
updated the locales.
  But language-options doesn't list el_GR, so it fools LightDM into thinking 
that Greek aren't supported; while they're all there, since e.g. MATE doesn't 
rely on langpacks; mate-panel.mo and mate-calc.mo etc are all there.

  I believe the correct fix would be for language-options to list el_GR
  on live CDs (to merge the output of locale -a in its output).

  Thanks!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1861481/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 540751] Re: Unable to use dead keys with java and ibus

2020-02-15 Thread Johny
I've created a new bug report here:
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1863080

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to ibus in Ubuntu.
https://bugs.launchpad.net/bugs/540751

Title:
  Unable to use dead keys with java and ibus

Status in ibus package in Ubuntu:
  Invalid
Status in openjdk-6 package in Ubuntu:
  Invalid
Status in openjdk-7 package in Ubuntu:
  Invalid

Bug description:
  Using latest Lucid packages, I am unable to use ^ key to generate ê
  french character in every Java programs (jEdit, Netbeans, etc.).

  Typing ^ + e give just the e character.
  Typing ^ + Space and nothing appears.

  I've tried with Sun JDK (6u18, 6u20, 7) and the bug is still present.

  I've tried to remove ibus and everything works again (I've just unset
  XMODIFIERS and GTK_IM_MODULE).

  I don't know if it's an ibus bug or openjdk one.

  ProblemType: Bug
  Architecture: amd64
  Date: Thu Mar 18 09:03:11 2010
  DistroRelease: Ubuntu 10.04
  ExecutablePath: /usr/lib/jvm/java-6-openjdk/jre/bin/java
  InstallationMedia: Error: [Errno 13] Permission non accordée: 
'/var/log/installer/media-info'
  NonfreeKernelModules: nvidia
  Package: openjdk-6-jre-headless 6b18~pre2-1ubuntu1
  ProcEnviron:
   SHELL=/bin/bash
   PATH=(custom, user)
   LANG=fr_FR.utf8
  ProcVersionSignature: Ubuntu 2.6.32-16.25-genUser Name
  SourcePackage: openjdk-6
  Uname: Linux 2.6.32-16-generic x86_64

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/540751/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1863447] [NEW] openssh outdated by 8.2

2020-02-15 Thread Hadmut Danisch
Public bug reported:

Hi,

yeah, it's not yet a bug, but it will become a (security) bug within
lifetime of 20.04 if not 'fixed'.

Currently openssh for Ubuntu 20.04 is still on 8.1p1, while upstream the
version 8.2 has just been released:

https://lists.mindrot.org/pipermail/openssh-unix-
announce/2020-February/000138.html

It comes with important security updates, e.g. not accepting SHA-1 for
key generation/signature anymore, and using FIDO2/U2F-tokens as a second
factor. Especially the latter significantly improves security and helps
against stealing keys and hijacking machines.

It would be important (and nice) to have these improvements of security
in Ubuntu 20.04.


It might not yet be seen as a security vulnerability, but it will probably 
become one soon. 

Thanks

** Affects: openssh (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.
https://bugs.launchpad.net/bugs/1863447

Title:
  openssh outdated by 8.2

Status in openssh package in Ubuntu:
  New

Bug description:
  Hi,

  yeah, it's not yet a bug, but it will become a (security) bug within
  lifetime of 20.04 if not 'fixed'.

  Currently openssh for Ubuntu 20.04 is still on 8.1p1, while upstream
  the version 8.2 has just been released:

  https://lists.mindrot.org/pipermail/openssh-unix-
  announce/2020-February/000138.html

  It comes with important security updates, e.g. not accepting SHA-1 for
  key generation/signature anymore, and using FIDO2/U2F-tokens as a
  second factor. Especially the latter significantly improves security
  and helps against stealing keys and hijacking machines.

  It would be important (and nice) to have these improvements of
  security in Ubuntu 20.04.

  
  It might not yet be seen as a security vulnerability, but it will probably 
become one soon. 

  Thanks

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1863447/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1828901] Re: add PTY support for runuser

2020-02-15 Thread Eric Desrochers
The sosreport juju plugin refactoring has been simplified.

For now, we don't expect the juju plugin to drop privileges any time
soon.

Thanks !

** Changed in: util-linux (Ubuntu Xenial)
   Status: In Progress => Won't Fix

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to util-linux in Ubuntu.
https://bugs.launchpad.net/bugs/1828901

Title:
  add PTY support for runuser

Status in util-linux package in Ubuntu:
  Fix Released
Status in util-linux source package in Xenial:
  Won't Fix
Status in util-linux package in Debian:
  Fix Released

Bug description:
  [IMPACT]

  [TEST CASE]

  [REGRESSION POTENTIAL]

  [OTHER INFORMATION]

  Debbug:
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815922

  This is fixing a CVE vulnerability:
  https://security-tracker.debian.org/tracker/CVE-2016-2779

  Restricting ioctl on the kernel side seems the better approach, patches have 
been posted to kernel-hardening list
  http://www.openwall.com/lists/oss-security/2016/02/27/1
  https://marc.info/?l=util-linux-ng=145694736107128=2
  2.31 introduces a new --pty option to separate privileged and unprivileged
  shells (not enabled by default and the cli switch is necessary).

  [ORIGINAL DESCRIPTION]
  After a discussion with security team on what would be their recommended way 
to run command as 'juju-user' inside the sosreport juju plugin which is run as 
root, in order to avoid using 'sudo' or 'su' command.

  The recommendation was to use 'runuser -P'

  runuser PTY support is present in Bionic and late, but not in Xenial.

  I'm opening this bug in the effort to update util-linux/runuser code
  in Xenial to add the PTY support.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1828901/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1848784] Re: Crash in Qt 5.12.2

2020-02-15 Thread Dmitry Shachnev
Fixed in eoan by https://launchpad.net/ubuntu/+source/qtbase-opensource-
src/5.12.4+dfsg-4ubuntu1.1.

disco has reached end of life on 2020-01-18, so this won't be fixed
there.

** Changed in: qtbase-opensource-src (Ubuntu Eoan)
   Status: New => Fix Released

** Changed in: qtbase-opensource-src (Ubuntu Disco)
   Status: New => Won't Fix

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1848784

Title:
  Crash in Qt 5.12.2

Status in qtbase-opensource-src package in Ubuntu:
  Fix Released
Status in qtbase-opensource-src source package in Disco:
  Won't Fix
Status in qtbase-opensource-src source package in Eoan:
  Fix Released

Bug description:
  Originally reported by Robert Loehning in
  :

  Every application based on Qt will crash when opening a crafted plain
  text file. Could you please add the patch below to your builds to fix
  this?

  https://codereview.qt-project.org/c/qt/qtbase/+/271889

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1848784/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1851385] Re: ubuntu 19.10 / print bug : requires authentication

2020-02-15 Thread Alexey Nikitin
*** This bug is a duplicate of bug 1849859 ***
https://bugs.launchpad.net/bugs/1849859

I have the same issue on two PCs with HP LaserJet 1020 printer connected
to the Wi-Fi router on Ubuntu 19.10.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.
https://bugs.launchpad.net/bugs/1851385

Title:
  ubuntu 19.10 / print bug : requires authentication

Status in cups package in Ubuntu:
  Confirmed

Bug description:
  Hello,

  I have 2 computers(one laptop and one desktop) which have a dual boot
  Windows / Ubuntu. My printer (Xerox WorkCentre 6015B) is plugged on a
  USB port from my modem on which my computers are connected using Wi-
  Fi.

  Since the upgrade of Ubuntu to version 19.10, I cannot print. On both
  computers I get the same message : [The printer] requires
  authentication / credentials required in order to print.

  With Ubuntu 19.04, I had absolutely no problem. I tried with a live
  USB with Ubuntu 19.04, there is no problem, the printer works. With a
  Ubuntu live 19.10, it doesn't work.

  If I plug the printer directly on a USB port on my computer, I get the
  same error message : [The printer] requires authentication /
  credentials required in order to print.

  It's the same behaviour on both computers, no I guess it must be a
  bug. Anyway I don't know which authentication I could do, with which
  ID and password ?

  Thank you very much

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: cups 2.2.12-2ubuntu1
  ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
  Uname: Linux 5.3.0-18-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8.2
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Nov  5 15:12:07 2019
  Lpstat: device for Xerox_WorkCentre_6015B_Wi-Fi: 
smb://FREEBOX_SERVER/Xerox%20WorkCentre%206015B
  MachineType: Acer Aspire V5-571
  Papersize: a4
  PpdFiles: Error: command ['fgrep', '-H', '*NickName', 
'/etc/cups/ppd/Xerox_WorkCentre_6015B_Wi-Fi.ppd'] failed with exit code 2: 
grep: /etc/cups/ppd/Xerox_WorkCentre_6015B_Wi-Fi.ppd: Permission denied
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-18-generic 
root=UUID=fb8ccf3e-9970-4066-bae2-26fe4387c122 ro quiet splash vt.handoff=7
  SourcePackage: cups
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/21/2012
  dmi.bios.vendor: Phoenix Technologies Ltd.
  dmi.bios.version: V2.15
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: Aspire V5-571
  dmi.board.vendor: Acer
  dmi.board.version: V2.15
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: Acer
  dmi.chassis.version: V2.15
  dmi.modalias: 
dmi:bvnPhoenixTechnologiesLtd.:bvrV2.15:bd12/21/2012:svnAcer:pnAspireV5-571:pvrV2.15:rvnAcer:rnAspireV5-571:rvrV2.15:cvnAcer:ct9:cvrV2.15:
  dmi.product.family: Aspire V5-571
  dmi.product.name: Aspire V5-571
  dmi.product.sku: Aspire V5-571_072A_2.15
  dmi.product.version: V2.15
  dmi.sys.vendor: Acer

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1851385/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1863427] Re: apport-gtk crashed with SIGSEGV

2020-02-15 Thread Apport retracing service
*** This bug is a duplicate of bug 1842439 ***
https://bugs.launchpad.net/bugs/1842439

Thank you for taking the time to report this crash and helping to make
this software better.  This particular crash has already been reported
and is a duplicate of bug #1842439, so is being marked as such.  Please
look at the other bug report to see if there is any missing information
that you can provide, or to see if there is a workaround for the bug.
Additionally, any further discussion regarding the bug should occur in
the other report.  Please continue to report any other bugs you may
find.

** Attachment removed: "CoreDump.gz"
   
https://bugs.launchpad.net/bugs/1863427/+attachment/5328432/+files/CoreDump.gz

** Attachment removed: "Disassembly.txt"
   
https://bugs.launchpad.net/bugs/1863427/+attachment/5328434/+files/Disassembly.txt

** Attachment removed: "ProcMaps.txt"
   
https://bugs.launchpad.net/bugs/1863427/+attachment/5328437/+files/ProcMaps.txt

** Attachment removed: "ProcStatus.txt"
   
https://bugs.launchpad.net/bugs/1863427/+attachment/5328438/+files/ProcStatus.txt

** Attachment removed: "Registers.txt"
   
https://bugs.launchpad.net/bugs/1863427/+attachment/5328439/+files/Registers.txt

** Attachment removed: "Stacktrace.txt"
   
https://bugs.launchpad.net/bugs/1863427/+attachment/5328440/+files/Stacktrace.txt

** Attachment removed: "ThreadStacktrace.txt"
   
https://bugs.launchpad.net/bugs/1863427/+attachment/5328441/+files/ThreadStacktrace.txt

** This bug has been marked a duplicate of bug 1842439
   apport-gtk crashed with SIGSEGV in _gtk_settings_get_screen(settings=0x0)

** Information type changed from Private to Public

** Tags removed: need-amd64-retrace

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1863427

Title:
  apport-gtk crashed with SIGSEGV

Status in apport package in Ubuntu:
  New

Bug description:
  Auto-report. No obvious symptoms.

  ProblemType: Crash
  DistroRelease: Ubuntu 20.04
  Package: apport-gtk 2.20.11-0ubuntu16
  ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
  Uname: Linux 5.4.0-12-generic x86_64
  ApportVersion: 2.20.11-0ubuntu16
  Architecture: amd64
  CrashReports:
   640:1000:125:110309:2020-02-15 10:36:12.706718921 -0500:2020-02-15 
10:36:13.706718921 -0500:/var/crash/_usr_bin_systemctl.1000.crash
   640:1000:125:6776078:2020-02-15 10:36:17.569774627 -0500:2020-02-15 
10:36:18.569774627 -0500:/var/crash/_usr_share_apport_apport-gtk.1000.crash
  CurrentDesktop: Unity:Unity7:ubuntu
  Date: Sat Feb 15 10:36:16 2020
  ExecutablePath: /usr/share/apport/apport-gtk
  ExecutableTimestamp: 1578317320
  InstallationDate: Installed on 2020-02-10 (4 days ago)
  InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200210)
  InterpreterPath: /usr/bin/python3.8
  PackageArchitecture: all
  ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk
  ProcCwd: /home/rodsmith
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=en_US.UTF-8
   LD_PRELOAD=
   SHELL=/bin/bash
  Python3Details: /usr/bin/python3.8, Python 3.8.2rc1, python3-minimal, 3.8.0-3
  PythonDetails: N/A
  SegvAnalysis:
   Segfault happened at: 0x7ff43cc357e4:mov0x18(%rdi),%rax
   PC (0x7ff43cc357e4) ok
   source "0x18(%rdi)" (0x0018) not located in a known VMA region (needed 
readable region)!
   destination "%rax" ok
  SegvReason: reading NULL VMA
  Signal: 11
  SourcePackage: apport
  StacktraceTop:
   ?? () from /lib/x86_64-linux-gnu/libgtk-3.so.0
   ?? () from /lib/x86_64-linux-gnu/libgtk-3.so.0
   ?? () from /lib/x86_64-linux-gnu/libgtk-3.so.0
   ?? () from /lib/x86_64-linux-gnu/libgtk-3.so.0
   ?? () from /lib/x86_64-linux-gnu/libgtk-3.so.0
  Title: apport-gtk crashed with SIGSEGV
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
  separator:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1863427/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1842439] Re: apport-gtk crashed with SIGSEGV in _gtk_settings_get_screen(settings=0x0)

2020-02-15 Thread Apport retracing service
** Tags added: focal

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apport in Ubuntu.
https://bugs.launchpad.net/bugs/1842439

Title:
  apport-gtk crashed with SIGSEGV in
  _gtk_settings_get_screen(settings=0x0)

Status in apport package in Ubuntu:
  Confirmed

Bug description:
  https://errors.ubuntu.com/problem/815a179408135a894bbb5921adef3757563c75c5

  ---

  Session suddenly stopped and came back to login screen, all opened
  windows lost.

  ProblemType: Crash
  DistroRelease: Ubuntu 19.10
  Package: apport-gtk 2.20.11-0ubuntu7
  ProcVersionSignature: Ubuntu 5.2.0-15.16-generic 5.2.9
  Uname: Linux 5.2.0-15-generic x86_64
  ApportVersion: 2.20.11-0ubuntu7
  Architecture: amd64
  CrashReports:
   640:1000:117:7292709:2019-09-03 16:20:13.909392833 +0200:2019-09-03 
16:20:14.909392833 +0200:/var/crash/_usr_share_apport_apport-gtk.1000.crash
   640:1000:117:48937942:2019-09-03 16:20:11.681426286 +0200:2019-09-03 
16:20:12.681426286 +0200:/var/crash/_usr_bin_gnome-shell.1000.crash
   640:1000:117:32054:2019-08-27 17:39:07.125607490 +0200:2019-08-28 
12:36:17.087672961 +0200:/var/crash/_usr_bin_dbus-daemon.1000.crash
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Sep  3 16:20:13 2019
  ExecutablePath: /usr/share/apport/apport-gtk
  InstallationDate: Installed on 2018-06-16 (443 days ago)
  InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180611)
  InterpreterPath: /usr/bin/python3.7
  PackageArchitecture: all
  ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=
   LANG=fr_FR.UTF-8
   SHELL=/bin/bash
  Python3Details: /usr/bin/python3.7, Python 3.7.4, python3-minimal, 3.7.3-1
  PythonDetails: /usr/bin/python2.7, Python 2.7.16+, python-minimal, 2.7.16-1
  SegvAnalysis:
   Segfault happened at: 0x7f532548f8c4:mov0x18(%rdi),%rax
   PC (0x7f532548f8c4) ok
   source "0x18(%rdi)" (0x0018) not located in a known VMA region (needed 
readable region)!
   destination "%rax" ok
  SegvReason: reading NULL VMA
  Signal: 11
  SourcePackage: apport
  StacktraceTop:
   ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
   ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
  Title: apport-gtk crashed with SIGSEGV
  UpgradeStatus: Upgraded to eoan on 2019-06-10 (84 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  separator:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1842439/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1863165] Re: autoremove-kernels doesn't purge kernels

2020-02-15 Thread Christian Kujau
I'd consider having remnants of old package versions (and lots of them)
to be a bug, but it's your distribution, so having this dismissed is an
answer to this problem nonetheless. Thanks!

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1863165

Title:
  autoremove-kernels doesn't purge kernels

Status in apt package in Ubuntu:
  Invalid

Bug description:
  Maybe this is a configuration issue, but:

  # apt-get --purge autoremove
  Reading package lists... Done
  Building dependency tree
  Reading state information... Done
  0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  # dpkg -l | grep ^rc | cut -c-70
  rc linux-image-4.15.0-66-generic 4.15.0-66.75 amd64 Signed kernel imag
  rc linux-image-4.15.0-67-generic 4.15.0-67.76 amd64 Signed kernel imag
  rc linux-image-4.15.0-71-generic 4.15.0-71.80 amd64 Signed kernel imag
  rc linux-image-4.15.0-72-generic 4.15.0-72.81 amd64 Signed kernel imag
  rc linux-image-4.15.0-73-generic 4.15.0-73.82 amd64 Signed kernel imag
  rc linux-image-4.15.0-74-generic 4.15.0-74.84 amd64 Signed kernel imag
  rc linux-image-4.15.0-75-generic 4.15.0-75.85 amd64 Signed kernel imag
  rc linux-image-4.15.0-76-generic 4.15.0-76.86 amd64 Signed kernel imag
  rc linux-modules-4.15.0-66-generic 4.15.0-66.75 amd64 Linux kernel ext
  rc linux-modules-4.15.0-67-generic 4.15.0-67.76 amd64 Linux kernel ext
  rc linux-modules-4.15.0-71-generic 4.15.0-71.80 amd64 Linux kernel ext
  rc linux-modules-4.15.0-72-generic 4.15.0-72.81 amd64 Linux kernel ext
  rc linux-modules-4.15.0-73-generic 4.15.0-73.82 amd64 Linux kernel ext
  rc linux-modules-4.15.0-74-generic 4.15.0-74.84 amd64 Linux kernel ext
  rc linux-modules-4.15.0-75-generic 4.15.0-75.85 amd64 Linux kernel ext
  rc linux-modules-4.15.0-76-generic 4.15.0-76.86 amd64 Linux kernel ext

  And the "rc" translates to "Remove/Conf-files". For some reason
  /etc/apt/apt.conf.d/01autoremove-kernels (triggered by unattended-
  upgrades.service) doesn't seem to remove the kernel's configuration
  files.

  The kernel images and modules are removed, only the package list (and
  maybe /usr/share/doc/linux*) is cluttered with the remnants of old
  kernels.

  Workaround:

   dpkg -l | awk '/^rc.*linux-(image|modules)/ {print $2}' | xargs dpkg
  -P

  # lsb_release -r; dpkg -s apt | grep Ver; uname -r
  Release:18.04
  Version: 1.6.12
  5.3.0-23-generic

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1863165/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1861345] Re: Gigabyte x570 Aorus Master with ALC1220 and ESS SABRE 9118 DAC Muted Front speakers 5.1

2020-02-15 Thread Richard Anthony Horan
sudo alsactl store does not save the headphone volume so I have to re-
adjust every boot.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to alsa-driver in Ubuntu.
https://bugs.launchpad.net/bugs/1861345

Title:
  Gigabyte x570 Aorus Master with ALC1220 and ESS SABRE 9118 DAC Muted
  Front speakers 5.1

Status in alsa-driver package in Ubuntu:
  New
Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Ubuntu 18.04.3 LTS
  Kernel 5.5.0
  pulseaudio:
Installed: 1:11.1-1ubuntu7.4
  X570 Aorus Master Motherboard. ALC1220 ESS Sabre sound.

  I have surround 5.1 speakers and the Front Left and Right are Muted.  
  I have to unmute Headphones in alsamixer to hear sound from the front left 
and right speakers is the workaround.

  This step should not be required for speakers 5.1 to work.
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.9-0ubuntu7.9
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC2:  richard2533 F pulseaudio
   /dev/snd/controlC1:  richard2533 F pulseaudio
   /dev/snd/controlC0:  richard2533 F pulseaudio
  CurrentDesktop: ubuntu:GNOME
  DistroRelease: Ubuntu 18.04
  InstallationDate: Installed on 2020-01-28 (2 days ago)
  InstallationMedia: Ubuntu 18.04.3 LTS "Bionic Beaver" - Release amd64 
(20190805)
  MachineType: Gigabyte Technology Co., Ltd. X570 AORUS MASTER
  Package: linux (not installed)
  ProcFB:
   
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-28-generic 
root=UUID=51fe9653-53b0-475f-836e-a1662c6d8b79 ro quiet splash amd_iommu=on 
vt.handoff=1
  ProcVersionSignature: Ubuntu 5.3.0-28.30~18.04.1-generic 5.3.13
  RelatedPackageVersions:
   linux-restricted-modules-5.3.0-28-generic N/A
   linux-backports-modules-5.3.0-28-generic  N/A
   linux-firmware1.173.14
  Tags:  bionic
  Uname: Linux 5.3.0-28-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip kvm libvirt lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 12/06/2019
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F11
  dmi.board.asset.tag: Default string
  dmi.board.name: X570 AORUS MASTER
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: Default string
  dmi.chassis.asset.tag: Default string
  dmi.chassis.type: 3
  dmi.chassis.vendor: Default string
  dmi.chassis.version: Default string
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrF11:bd12/06/2019:svnGigabyteTechnologyCo.,Ltd.:pnX570AORUSMASTER:pvr-CF:rvnGigabyteTechnologyCo.,Ltd.:rnX570AORUSMASTER:rvrDefaultstring:cvnDefaultstring:ct3:cvrDefaultstring:
  dmi.product.family: Default string
  dmi.product.name: X570 AORUS MASTER
  dmi.product.sku: Default string
  dmi.product.version: -CF
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1861345/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1863414] Re: Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used" o

2020-02-15 Thread Julian Andres Klode
Deleting unrelated tasks.

** No longer affects: python-apt (Ubuntu)

** No longer affects: aptdaemon (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1863414

Title:
  Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line
  buffering (buffering=1) isn't supported in binary mode, the default
  buffer size will be used" on simple APT usage

Status in python3.8 package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Have Ubuntu 20.04 LTS installed
  2. Run regular APT task such as `sudo apt dist-upgrade`
  3. Wait it to finish

  Expected results:
  * APT runs without any warnings and/or errors

  Actual results:
  * APT runs with many python-related warnings like

  >```
  >/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering 
(buffering=1) isn't supported >in binary mode, the default buffer size will be 
used
  >  self.stdin = io.open(p2cwrite, 'wb', bufsize)
  >
  >```

  Full output below:

  ```
  $ sudo apt dist-upgrade 
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  Calculating upgrade... Done
  The following packages were automatically installed and are no longer 
required:
ruby-json ruby-pg ruby-sequel ruby-sequel-pg
  Use 'sudo apt autoremove' to remove them.
  The following NEW packages will be installed:
kdevelop55-libs libxentoolcore1 ubuntu-mate-wallpapers-focal
  The following packages will be upgraded:
atril atril-common debootstrap dmeventd dmsetup dnsmasq-base engrampa 
engrampa-common fwupd fwupd-signed gir1.2-atrildocument-1.5.0
gir1.2-atrilview-1.5.0 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-pluma-1.0 
initramfs-tools initramfs-tools-bin initramfs-tools-core
iproute2 isc-dhcp-client isc-dhcp-common jekyll k3b k3b-data k3b-i18n 
kdevelop kdevelop-data libatrildocument-dev libatrildocument3
libatrilview-dev libatrilview3 libdevmapper-event1.02.1 libdevmapper1.02.1 
libdistro-info-perl libfwupd2 libfwupdplugin1
libgirepository-1.0-1 libk3b7 libk3b7-extracodecs liblvm2cmd2.03 
libmate-sensors-applet-plugin-dev libmate-sensors-applet-plugin0
libmate-slab0 libmate-window-settings-dev libmate-window-settings1 
libmatedict-dev libmatedict6 libmysqlclient21 libmysqlclient21:i386
libvirt-clients libvirt-daemon libvirt-daemon-driver-qemu 
libvirt-daemon-driver-storage-rbd libvirt-daemon-system
libvirt-daemon-system-systemd libvirt0 libxenstore3.0 
libxmlgraphics-commons-java lvm2 mate-applets mate-applets-common mate-common
mate-control-center mate-control-center-common mate-core 
mate-desktop-environment mate-desktop-environment-core
mate-desktop-environment-extra mate-desktop-environment-extras 
mate-dock-applet mate-media mate-media-common mate-netbook
mate-netbook-common mate-notification-daemon 
mate-notification-daemon-common mate-power-manager mate-power-manager-common
mate-screensaver mate-screensaver-common mate-sensors-applet 
mate-sensors-applet-common mate-sensors-applet-nvidia mate-system-monitor
mate-system-monitor-common mate-terminal mate-terminal-common 
mate-user-share mate-user-share-common mate-utils mate-utils-common maxima
maxima-doc maxima-share mozo nano pluma pluma-common pluma-dev pluma-doc 
plymouth-theme-ubuntu-mate-logo plymouth-theme-ubuntu-mate-text
python-caja-common python3-caja python3-distro-info python3-macaroonbakery 
qemu-block-extra qemu-kvm qemu-system-common qemu-system-data
qemu-system-gui qemu-system-x86 qemu-utils ubuntu-mate-artwork 
ubuntu-mate-default-settings ubuntu-mate-icon-themes
ubuntu-mate-lightdm-theme ubuntu-mate-live-settings ubuntu-mate-themes 
ubuntu-mate-wallpapers ubuntu-mate-wallpapers-artful
ubuntu-mate-wallpapers-bionic ubuntu-mate-wallpapers-common 
ubuntu-mate-wallpapers-complete ubuntu-mate-wallpapers-cosmic
ubuntu-mate-wallpapers-disco ubuntu-mate-wallpapers-eoan 
ubuntu-mate-wallpapers-legacy ubuntu-mate-wallpapers-photos
ubuntu-mate-wallpapers-utopic ubuntu-mate-wallpapers-vivid 
ubuntu-mate-wallpapers-wily ubuntu-mate-wallpapers-xenial
ubuntu-mate-wallpapers-yakkety ubuntu-mate-wallpapers-zesty umbrello
  136 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
  Need to get 215 MB of archives.
  After this operation, 12,8 MB of additional disk space will be used.
  Do you want to continue? [Y/n] 
  Get:1 http://archive.ubuntu.com/ubuntu focal/universe amd64 mate-common all 
1.24.0-1ubuntu1 [17,0 kB]
  ...
  Get:139 http://archive.ubuntu.com/ubuntu focal/universe amd64 
mate-dock-applet amd64 20.04.0-0ubuntu1 [91,8 kB]
  Fetched 215 MB in 4min 4s (882 kB/s)  
 
  Extracting templates from packages: 100%
  Preconfiguring packages ...
  (Reading database ... 961594 

[Touch-packages] [Bug 1863414] Re: Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used" o

2020-02-15 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: python3.8 (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1863414

Title:
  Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line
  buffering (buffering=1) isn't supported in binary mode, the default
  buffer size will be used" on simple APT usage

Status in aptdaemon package in Ubuntu:
  Confirmed
Status in python-apt package in Ubuntu:
  Confirmed
Status in python3.8 package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Have Ubuntu 20.04 LTS installed
  2. Run regular APT task such as `sudo apt dist-upgrade`
  3. Wait it to finish

  Expected results:
  * APT runs without any warnings and/or errors

  Actual results:
  * APT runs with many python-related warnings like

  >```
  >/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering 
(buffering=1) isn't supported >in binary mode, the default buffer size will be 
used
  >  self.stdin = io.open(p2cwrite, 'wb', bufsize)
  >
  >```

  Full output below:

  ```
  $ sudo apt dist-upgrade 
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  Calculating upgrade... Done
  The following packages were automatically installed and are no longer 
required:
ruby-json ruby-pg ruby-sequel ruby-sequel-pg
  Use 'sudo apt autoremove' to remove them.
  The following NEW packages will be installed:
kdevelop55-libs libxentoolcore1 ubuntu-mate-wallpapers-focal
  The following packages will be upgraded:
atril atril-common debootstrap dmeventd dmsetup dnsmasq-base engrampa 
engrampa-common fwupd fwupd-signed gir1.2-atrildocument-1.5.0
gir1.2-atrilview-1.5.0 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-pluma-1.0 
initramfs-tools initramfs-tools-bin initramfs-tools-core
iproute2 isc-dhcp-client isc-dhcp-common jekyll k3b k3b-data k3b-i18n 
kdevelop kdevelop-data libatrildocument-dev libatrildocument3
libatrilview-dev libatrilview3 libdevmapper-event1.02.1 libdevmapper1.02.1 
libdistro-info-perl libfwupd2 libfwupdplugin1
libgirepository-1.0-1 libk3b7 libk3b7-extracodecs liblvm2cmd2.03 
libmate-sensors-applet-plugin-dev libmate-sensors-applet-plugin0
libmate-slab0 libmate-window-settings-dev libmate-window-settings1 
libmatedict-dev libmatedict6 libmysqlclient21 libmysqlclient21:i386
libvirt-clients libvirt-daemon libvirt-daemon-driver-qemu 
libvirt-daemon-driver-storage-rbd libvirt-daemon-system
libvirt-daemon-system-systemd libvirt0 libxenstore3.0 
libxmlgraphics-commons-java lvm2 mate-applets mate-applets-common mate-common
mate-control-center mate-control-center-common mate-core 
mate-desktop-environment mate-desktop-environment-core
mate-desktop-environment-extra mate-desktop-environment-extras 
mate-dock-applet mate-media mate-media-common mate-netbook
mate-netbook-common mate-notification-daemon 
mate-notification-daemon-common mate-power-manager mate-power-manager-common
mate-screensaver mate-screensaver-common mate-sensors-applet 
mate-sensors-applet-common mate-sensors-applet-nvidia mate-system-monitor
mate-system-monitor-common mate-terminal mate-terminal-common 
mate-user-share mate-user-share-common mate-utils mate-utils-common maxima
maxima-doc maxima-share mozo nano pluma pluma-common pluma-dev pluma-doc 
plymouth-theme-ubuntu-mate-logo plymouth-theme-ubuntu-mate-text
python-caja-common python3-caja python3-distro-info python3-macaroonbakery 
qemu-block-extra qemu-kvm qemu-system-common qemu-system-data
qemu-system-gui qemu-system-x86 qemu-utils ubuntu-mate-artwork 
ubuntu-mate-default-settings ubuntu-mate-icon-themes
ubuntu-mate-lightdm-theme ubuntu-mate-live-settings ubuntu-mate-themes 
ubuntu-mate-wallpapers ubuntu-mate-wallpapers-artful
ubuntu-mate-wallpapers-bionic ubuntu-mate-wallpapers-common 
ubuntu-mate-wallpapers-complete ubuntu-mate-wallpapers-cosmic
ubuntu-mate-wallpapers-disco ubuntu-mate-wallpapers-eoan 
ubuntu-mate-wallpapers-legacy ubuntu-mate-wallpapers-photos
ubuntu-mate-wallpapers-utopic ubuntu-mate-wallpapers-vivid 
ubuntu-mate-wallpapers-wily ubuntu-mate-wallpapers-xenial
ubuntu-mate-wallpapers-yakkety ubuntu-mate-wallpapers-zesty umbrello
  136 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
  Need to get 215 MB of archives.
  After this operation, 12,8 MB of additional disk space will be used.
  Do you want to continue? [Y/n] 
  Get:1 http://archive.ubuntu.com/ubuntu focal/universe amd64 mate-common all 
1.24.0-1ubuntu1 [17,0 kB]
  ...
  Get:139 http://archive.ubuntu.com/ubuntu focal/universe amd64 
mate-dock-applet amd64 20.04.0-0ubuntu1 [91,8 kB]
  Fetched 215 MB in 4min 4s (882 kB/s)  

[Touch-packages] [Bug 1863414] Re: Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used" o

2020-02-15 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: python-apt (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1863414

Title:
  Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line
  buffering (buffering=1) isn't supported in binary mode, the default
  buffer size will be used" on simple APT usage

Status in aptdaemon package in Ubuntu:
  Confirmed
Status in python-apt package in Ubuntu:
  Confirmed
Status in python3.8 package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Have Ubuntu 20.04 LTS installed
  2. Run regular APT task such as `sudo apt dist-upgrade`
  3. Wait it to finish

  Expected results:
  * APT runs without any warnings and/or errors

  Actual results:
  * APT runs with many python-related warnings like

  >```
  >/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering 
(buffering=1) isn't supported >in binary mode, the default buffer size will be 
used
  >  self.stdin = io.open(p2cwrite, 'wb', bufsize)
  >
  >```

  Full output below:

  ```
  $ sudo apt dist-upgrade 
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  Calculating upgrade... Done
  The following packages were automatically installed and are no longer 
required:
ruby-json ruby-pg ruby-sequel ruby-sequel-pg
  Use 'sudo apt autoremove' to remove them.
  The following NEW packages will be installed:
kdevelop55-libs libxentoolcore1 ubuntu-mate-wallpapers-focal
  The following packages will be upgraded:
atril atril-common debootstrap dmeventd dmsetup dnsmasq-base engrampa 
engrampa-common fwupd fwupd-signed gir1.2-atrildocument-1.5.0
gir1.2-atrilview-1.5.0 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-pluma-1.0 
initramfs-tools initramfs-tools-bin initramfs-tools-core
iproute2 isc-dhcp-client isc-dhcp-common jekyll k3b k3b-data k3b-i18n 
kdevelop kdevelop-data libatrildocument-dev libatrildocument3
libatrilview-dev libatrilview3 libdevmapper-event1.02.1 libdevmapper1.02.1 
libdistro-info-perl libfwupd2 libfwupdplugin1
libgirepository-1.0-1 libk3b7 libk3b7-extracodecs liblvm2cmd2.03 
libmate-sensors-applet-plugin-dev libmate-sensors-applet-plugin0
libmate-slab0 libmate-window-settings-dev libmate-window-settings1 
libmatedict-dev libmatedict6 libmysqlclient21 libmysqlclient21:i386
libvirt-clients libvirt-daemon libvirt-daemon-driver-qemu 
libvirt-daemon-driver-storage-rbd libvirt-daemon-system
libvirt-daemon-system-systemd libvirt0 libxenstore3.0 
libxmlgraphics-commons-java lvm2 mate-applets mate-applets-common mate-common
mate-control-center mate-control-center-common mate-core 
mate-desktop-environment mate-desktop-environment-core
mate-desktop-environment-extra mate-desktop-environment-extras 
mate-dock-applet mate-media mate-media-common mate-netbook
mate-netbook-common mate-notification-daemon 
mate-notification-daemon-common mate-power-manager mate-power-manager-common
mate-screensaver mate-screensaver-common mate-sensors-applet 
mate-sensors-applet-common mate-sensors-applet-nvidia mate-system-monitor
mate-system-monitor-common mate-terminal mate-terminal-common 
mate-user-share mate-user-share-common mate-utils mate-utils-common maxima
maxima-doc maxima-share mozo nano pluma pluma-common pluma-dev pluma-doc 
plymouth-theme-ubuntu-mate-logo plymouth-theme-ubuntu-mate-text
python-caja-common python3-caja python3-distro-info python3-macaroonbakery 
qemu-block-extra qemu-kvm qemu-system-common qemu-system-data
qemu-system-gui qemu-system-x86 qemu-utils ubuntu-mate-artwork 
ubuntu-mate-default-settings ubuntu-mate-icon-themes
ubuntu-mate-lightdm-theme ubuntu-mate-live-settings ubuntu-mate-themes 
ubuntu-mate-wallpapers ubuntu-mate-wallpapers-artful
ubuntu-mate-wallpapers-bionic ubuntu-mate-wallpapers-common 
ubuntu-mate-wallpapers-complete ubuntu-mate-wallpapers-cosmic
ubuntu-mate-wallpapers-disco ubuntu-mate-wallpapers-eoan 
ubuntu-mate-wallpapers-legacy ubuntu-mate-wallpapers-photos
ubuntu-mate-wallpapers-utopic ubuntu-mate-wallpapers-vivid 
ubuntu-mate-wallpapers-wily ubuntu-mate-wallpapers-xenial
ubuntu-mate-wallpapers-yakkety ubuntu-mate-wallpapers-zesty umbrello
  136 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
  Need to get 215 MB of archives.
  After this operation, 12,8 MB of additional disk space will be used.
  Do you want to continue? [Y/n] 
  Get:1 http://archive.ubuntu.com/ubuntu focal/universe amd64 mate-common all 
1.24.0-1ubuntu1 [17,0 kB]
  ...
  Get:139 http://archive.ubuntu.com/ubuntu focal/universe amd64 
mate-dock-applet amd64 20.04.0-0ubuntu1 [91,8 kB]
  Fetched 215 MB in 4min 4s (882 kB/s)  
   

[Touch-packages] [Bug 1863414] Re: Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used" o

2020-02-15 Thread Launchpad Bug Tracker
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: aptdaemon (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to python-apt in Ubuntu.
https://bugs.launchpad.net/bugs/1863414

Title:
  Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line
  buffering (buffering=1) isn't supported in binary mode, the default
  buffer size will be used" on simple APT usage

Status in aptdaemon package in Ubuntu:
  Confirmed
Status in python-apt package in Ubuntu:
  Confirmed
Status in python3.8 package in Ubuntu:
  Confirmed

Bug description:
  Steps to reproduce:
  1. Have Ubuntu 20.04 LTS installed
  2. Run regular APT task such as `sudo apt dist-upgrade`
  3. Wait it to finish

  Expected results:
  * APT runs without any warnings and/or errors

  Actual results:
  * APT runs with many python-related warnings like

  >```
  >/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering 
(buffering=1) isn't supported >in binary mode, the default buffer size will be 
used
  >  self.stdin = io.open(p2cwrite, 'wb', bufsize)
  >
  >```

  Full output below:

  ```
  $ sudo apt dist-upgrade 
  Reading package lists... Done
  Building dependency tree   
  Reading state information... Done
  Calculating upgrade... Done
  The following packages were automatically installed and are no longer 
required:
ruby-json ruby-pg ruby-sequel ruby-sequel-pg
  Use 'sudo apt autoremove' to remove them.
  The following NEW packages will be installed:
kdevelop55-libs libxentoolcore1 ubuntu-mate-wallpapers-focal
  The following packages will be upgraded:
atril atril-common debootstrap dmeventd dmsetup dnsmasq-base engrampa 
engrampa-common fwupd fwupd-signed gir1.2-atrildocument-1.5.0
gir1.2-atrilview-1.5.0 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-pluma-1.0 
initramfs-tools initramfs-tools-bin initramfs-tools-core
iproute2 isc-dhcp-client isc-dhcp-common jekyll k3b k3b-data k3b-i18n 
kdevelop kdevelop-data libatrildocument-dev libatrildocument3
libatrilview-dev libatrilview3 libdevmapper-event1.02.1 libdevmapper1.02.1 
libdistro-info-perl libfwupd2 libfwupdplugin1
libgirepository-1.0-1 libk3b7 libk3b7-extracodecs liblvm2cmd2.03 
libmate-sensors-applet-plugin-dev libmate-sensors-applet-plugin0
libmate-slab0 libmate-window-settings-dev libmate-window-settings1 
libmatedict-dev libmatedict6 libmysqlclient21 libmysqlclient21:i386
libvirt-clients libvirt-daemon libvirt-daemon-driver-qemu 
libvirt-daemon-driver-storage-rbd libvirt-daemon-system
libvirt-daemon-system-systemd libvirt0 libxenstore3.0 
libxmlgraphics-commons-java lvm2 mate-applets mate-applets-common mate-common
mate-control-center mate-control-center-common mate-core 
mate-desktop-environment mate-desktop-environment-core
mate-desktop-environment-extra mate-desktop-environment-extras 
mate-dock-applet mate-media mate-media-common mate-netbook
mate-netbook-common mate-notification-daemon 
mate-notification-daemon-common mate-power-manager mate-power-manager-common
mate-screensaver mate-screensaver-common mate-sensors-applet 
mate-sensors-applet-common mate-sensors-applet-nvidia mate-system-monitor
mate-system-monitor-common mate-terminal mate-terminal-common 
mate-user-share mate-user-share-common mate-utils mate-utils-common maxima
maxima-doc maxima-share mozo nano pluma pluma-common pluma-dev pluma-doc 
plymouth-theme-ubuntu-mate-logo plymouth-theme-ubuntu-mate-text
python-caja-common python3-caja python3-distro-info python3-macaroonbakery 
qemu-block-extra qemu-kvm qemu-system-common qemu-system-data
qemu-system-gui qemu-system-x86 qemu-utils ubuntu-mate-artwork 
ubuntu-mate-default-settings ubuntu-mate-icon-themes
ubuntu-mate-lightdm-theme ubuntu-mate-live-settings ubuntu-mate-themes 
ubuntu-mate-wallpapers ubuntu-mate-wallpapers-artful
ubuntu-mate-wallpapers-bionic ubuntu-mate-wallpapers-common 
ubuntu-mate-wallpapers-complete ubuntu-mate-wallpapers-cosmic
ubuntu-mate-wallpapers-disco ubuntu-mate-wallpapers-eoan 
ubuntu-mate-wallpapers-legacy ubuntu-mate-wallpapers-photos
ubuntu-mate-wallpapers-utopic ubuntu-mate-wallpapers-vivid 
ubuntu-mate-wallpapers-wily ubuntu-mate-wallpapers-xenial
ubuntu-mate-wallpapers-yakkety ubuntu-mate-wallpapers-zesty umbrello
  136 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
  Need to get 215 MB of archives.
  After this operation, 12,8 MB of additional disk space will be used.
  Do you want to continue? [Y/n] 
  Get:1 http://archive.ubuntu.com/ubuntu focal/universe amd64 mate-common all 
1.24.0-1ubuntu1 [17,0 kB]
  ...
  Get:139 http://archive.ubuntu.com/ubuntu focal/universe amd64 
mate-dock-applet amd64 20.04.0-0ubuntu1 [91,8 kB]
  Fetched 215 MB in 4min 4s (882 kB/s)  

[Touch-packages] [Bug 1410558] Re: ps doesn't support "thcount" format specifier on Xenial

2020-02-15 Thread Heitor Alves de Siqueira
** Description changed:

  [Impact]
- ps -o thcount doesn't print out an error (error: unknown user-defined format 
specifier "thcount")
+ ps -o thcount prints out an error (error: unknown user-defined format 
specifier "thcount")
  
  [Description]
  The Xenial version of procps has a bug in the thcount format specifier. ps 
doesn't recognize it, and complains about an unknown user-defined format.
  This is due to the format specifier table in ps/output.c, which is queried 
with a binary search. Since the "thcount" entry appears out of order in Xenial, 
it can't be looked up and the program fails with the "unknown user-defined 
format specifier" error.
  
  This has been fixed upstream by the commit below:
  - Fix for Bug:1174313 (3a52dfa34027)
  
  $ git describe --contains 3a52dfa34027
  v3.3.12~58^2
  
  $ rmadison procps
-  procps | 2:3.3.10-4ubuntu2   | xenial  | source, ...
-  procps | 2:3.3.10-4ubuntu2.4 | xenial-security | source, ...
-  procps | 2:3.3.10-4ubuntu2.4 | xenial-updates  | source, ... <
-  procps | 2:3.3.12-3ubuntu1   | bionic  | source, ...
-  procps | 2:3.3.12-3ubuntu1.1 | bionic-security | source, ...
-  procps | 2:3.3.12-3ubuntu1.2 | bionic-updates  | source, ...
+  procps | 2:3.3.10-4ubuntu2   | xenial  | source, ...
+  procps | 2:3.3.10-4ubuntu2.4 | xenial-security | source, ...
+  procps | 2:3.3.10-4ubuntu2.4 | xenial-updates  | source, ... <
+  procps | 2:3.3.12-3ubuntu1   | bionic  | source, ...
+  procps | 2:3.3.12-3ubuntu1.1 | bionic-security | source, ...
+  procps | 2:3.3.12-3ubuntu1.2 | bionic-updates  | source, ...
  
  Releases starting with Bionic already have this fix, so it's only needed
  for Xenial.
  
  [Test case]
  1. Boot up a Xenial environment with e.g. an lxd container:
  # lxc launch images:ubuntu/xenial xenial
  
  2. Execute ps with the '-o thcount' options:
  # lxc exec xenial -- ps -o thcount
  error: unknown user-defined format specifier "thcount"
  
  Usage:
-  ps [options]
+  ps [options]
  
-  Try 'ps --help '
-   or 'ps --help '
-  for additional help text.
+  Try 'ps --help '
+   or 'ps --help '
+  for additional help text.
  
  For more details see ps(1).
  
  [Regression Potential]
  The fix just fixes the order of two entries in the format specifier array, so 
the regression potential is very low. Furthermore, the patch has been present 
and tested in up-to-date versions of procps since Bionic. Any new regressions 
introduced in Xenial will be checked with autopkgtest.
  
  [Original Description]
  In Ubuntu 12.04.5 LTS (procps 1:3.2.8-11ubuntu6.3), the following worked fine:
  
  $ export PS_FORMAT=thcount
  $ ps
  THCNT
  1
  1
  
  In Ubuntu 14.04.1 LTS (procps 1:3.3.9-1ubuntu2), it does not work
  anymore:
  
  $ export PS_FORMAT=thcount
  $ ps
  warning: $PS_FORMAT ignored. (unknown user-defined format specifier "thcount")
    PID TTY  TIME CMD
   6593 pts/100:00:00 ps
  16633 pts/100:00:00 bash
  
  Other PS_FORMAT specifiers still work fine (I have tried many, but not
  all).
  
  In real-life usage, a more complex PS_FORMAT would of course be used,
  such as
  
PS_FORMAT=pid,s,thcount,nice,euser,egroup,etime,cputime,%mem,rssize:6,size:7,vsize:7,command
  
  Workaround: use nlwp instead of thcount (they are alias to the same
  data, and nlwp works fine in both versions).

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to procps in Ubuntu.
https://bugs.launchpad.net/bugs/1410558

Title:
  ps doesn't support "thcount" format specifier on Xenial

Status in procps package in Ubuntu:
  Fix Released
Status in procps source package in Xenial:
  In Progress

Bug description:
  [Impact]
  ps -o thcount prints out an error (error: unknown user-defined format 
specifier "thcount")

  [Description]
  The Xenial version of procps has a bug in the thcount format specifier. ps 
doesn't recognize it, and complains about an unknown user-defined format.
  This is due to the format specifier table in ps/output.c, which is queried 
with a binary search. Since the "thcount" entry appears out of order in Xenial, 
it can't be looked up and the program fails with the "unknown user-defined 
format specifier" error.

  This has been fixed upstream by the commit below:
  - Fix for Bug:1174313 (3a52dfa34027)

  $ git describe --contains 3a52dfa34027
  v3.3.12~58^2

  $ rmadison procps
   procps | 2:3.3.10-4ubuntu2   | xenial  | source, ...
   procps | 2:3.3.10-4ubuntu2.4 | xenial-security | source, ...
   procps | 2:3.3.10-4ubuntu2.4 | xenial-updates  | source, ... <
   procps | 2:3.3.12-3ubuntu1   | bionic  | source, ...
   procps | 2:3.3.12-3ubuntu1.1 | bionic-security | source, ...
   procps | 2:3.3.12-3ubuntu1.2 | bionic-updates  | source, ...

  Releases starting with Bionic already have this fix, so it's only
  needed for Xenial.

  [Test case]
  1. Boot up a Xenial environment with e.g. an lxd 

[Touch-packages] [Bug 1863414] [NEW] Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used"

2020-02-15 Thread Norbert
Public bug reported:

Steps to reproduce:
1. Have Ubuntu 20.04 LTS installed
2. Run regular APT task such as `sudo apt dist-upgrade`
3. Wait it to finish

Expected results:
* APT runs without any warnings and/or errors

Actual results:
* APT runs with many python-related warnings like

>```
>/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering 
>(buffering=1) isn't supported >in binary mode, the default buffer size will be 
>used
>  self.stdin = io.open(p2cwrite, 'wb', bufsize)
>
>```

Full output below:

```
$ sudo apt dist-upgrade 
Reading package lists... Done
Building dependency tree   
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  ruby-json ruby-pg ruby-sequel ruby-sequel-pg
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  kdevelop55-libs libxentoolcore1 ubuntu-mate-wallpapers-focal
The following packages will be upgraded:
  atril atril-common debootstrap dmeventd dmsetup dnsmasq-base engrampa 
engrampa-common fwupd fwupd-signed gir1.2-atrildocument-1.5.0
  gir1.2-atrilview-1.5.0 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-pluma-1.0 
initramfs-tools initramfs-tools-bin initramfs-tools-core
  iproute2 isc-dhcp-client isc-dhcp-common jekyll k3b k3b-data k3b-i18n 
kdevelop kdevelop-data libatrildocument-dev libatrildocument3
  libatrilview-dev libatrilview3 libdevmapper-event1.02.1 libdevmapper1.02.1 
libdistro-info-perl libfwupd2 libfwupdplugin1
  libgirepository-1.0-1 libk3b7 libk3b7-extracodecs liblvm2cmd2.03 
libmate-sensors-applet-plugin-dev libmate-sensors-applet-plugin0
  libmate-slab0 libmate-window-settings-dev libmate-window-settings1 
libmatedict-dev libmatedict6 libmysqlclient21 libmysqlclient21:i386
  libvirt-clients libvirt-daemon libvirt-daemon-driver-qemu 
libvirt-daemon-driver-storage-rbd libvirt-daemon-system
  libvirt-daemon-system-systemd libvirt0 libxenstore3.0 
libxmlgraphics-commons-java lvm2 mate-applets mate-applets-common mate-common
  mate-control-center mate-control-center-common mate-core 
mate-desktop-environment mate-desktop-environment-core
  mate-desktop-environment-extra mate-desktop-environment-extras 
mate-dock-applet mate-media mate-media-common mate-netbook
  mate-netbook-common mate-notification-daemon mate-notification-daemon-common 
mate-power-manager mate-power-manager-common
  mate-screensaver mate-screensaver-common mate-sensors-applet 
mate-sensors-applet-common mate-sensors-applet-nvidia mate-system-monitor
  mate-system-monitor-common mate-terminal mate-terminal-common mate-user-share 
mate-user-share-common mate-utils mate-utils-common maxima
  maxima-doc maxima-share mozo nano pluma pluma-common pluma-dev pluma-doc 
plymouth-theme-ubuntu-mate-logo plymouth-theme-ubuntu-mate-text
  python-caja-common python3-caja python3-distro-info python3-macaroonbakery 
qemu-block-extra qemu-kvm qemu-system-common qemu-system-data
  qemu-system-gui qemu-system-x86 qemu-utils ubuntu-mate-artwork 
ubuntu-mate-default-settings ubuntu-mate-icon-themes
  ubuntu-mate-lightdm-theme ubuntu-mate-live-settings ubuntu-mate-themes 
ubuntu-mate-wallpapers ubuntu-mate-wallpapers-artful
  ubuntu-mate-wallpapers-bionic ubuntu-mate-wallpapers-common 
ubuntu-mate-wallpapers-complete ubuntu-mate-wallpapers-cosmic
  ubuntu-mate-wallpapers-disco ubuntu-mate-wallpapers-eoan 
ubuntu-mate-wallpapers-legacy ubuntu-mate-wallpapers-photos
  ubuntu-mate-wallpapers-utopic ubuntu-mate-wallpapers-vivid 
ubuntu-mate-wallpapers-wily ubuntu-mate-wallpapers-xenial
  ubuntu-mate-wallpapers-yakkety ubuntu-mate-wallpapers-zesty umbrello
136 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 215 MB of archives.
After this operation, 12,8 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://archive.ubuntu.com/ubuntu focal/universe amd64 mate-common all 
1.24.0-1ubuntu1 [17,0 kB]
...
Get:139 http://archive.ubuntu.com/ubuntu focal/universe amd64 mate-dock-applet 
amd64 20.04.0-0ubuntu1 [91,8 kB]
Fetched 215 MB in 4min 4s (882 kB/s)
   
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 961594 files and directories currently installed.)
Preparing to unpack .../000-mate-common_1.24.0-1ubuntu1_all.deb ...
Unpacking mate-common (1.24.0-1ubuntu1) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../001-libdevmapper1.02.1_2%3a1.02.167-1ubuntu1_amd64.deb 
...
Unpacking libdevmapper1.02.1:amd64 (2:1.02.167-1ubuntu1) over 
(2:1.02.155-2ubuntu8) ...
Preparing to unpack .../002-dmsetup_2%3a1.02.167-1ubuntu1_amd64.deb ...
Unpacking dmsetup (2:1.02.167-1ubuntu1) over (2:1.02.155-2ubuntu8) ...
Preparing to unpack .../003-gir1.2-freedesktop_1.62.0-5ubuntu1_amd64.deb ...
Unpacking gir1.2-freedesktop:amd64 (1.62.0-5ubuntu1) over (1.62.0-4ubuntu3) ...

[Touch-packages] [Bug 1862437] Re: Ubuntu 16.10 & later, & derivatives do not query the assigned DNS server

2020-02-15 Thread Bruce Goodman
My sincere apologies, I have been wasting your time !

The Ubuntu and derivatives distributions that use systemd-resolved do
indeed query the assigned DNS.   I verified  this by stopping the
DNSMASQ service, which resulted in the loss of external name resolution.
Turning the service on again restored resolution of internet domain
names.

There is still an issue in distributions using systemd-resolved with
resolution of LAN host names.   As shown above resolution of a simple
host name, in my examples BGOWIKI01v, fails.   But when I add a 2nd name
for that host to the /etc/hosts file on my DNSMASQ machine, with a
suffix that looks like a domain name, like BGOWIKI01v.somedomain.local I
can resolve the name correctly using the nslookup command.

The solution for my reported issue will be to migrate my home LAN away
an old-fashioned Workgroup model, to something that looks like a domain.


Regards
Bruce Goodman

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.
https://bugs.launchpad.net/bugs/1862437

Title:
  Ubuntu 16.10 & later, & derivatives do not query the assigned DNS
  server

Status in bind9 package in Ubuntu:
  New
Status in systemd package in Ubuntu:
  New

Bug description:
  Starting Ubuntu 16.10 resolution of LAN addresses fails.   This name
  resolution failure is evident in every post 16.0 Ubuntu & derivative
  that I have tested.   See below - which shows 16.04 resolves, 18.04
  and Pop!_OS 19.04 fail, and other distros - Fedora 31, openSUSE Leap
  15.1, and Debian GNU/Linux 10 (buster) - all resolve as expected.

  == Test Case ==
  $ name=$(hostnamectl | grep "Static hostname:" | cut -d: -f2 | xargs)
  $ echo "${name}"
  $ hostnamectl | grep System
  $ hostnamectl | grep Kernel
  $ nmcli dev show | grep DNS
  $ nslookup "${name}"

  == Additional Information ==
  Operating System: Ubuntu 16.04.6 LTS
     Kernel: Linux 4.4.0-170-generic
   IP4.DNS[1]: 192.168.3.2
   Server:127.0.1.1
   Address:   127.0.1.1#53
   Name:  BGOWIKI01v
   Address: 192.168.3.60
   
   Operating System: Ubuntu 18.04.3 LTS
  Kernel: Linux 4.15.0-72-generic
   IP4.DNS[1]: 192.168.3.2
   Server:127.0.0.53
   Address:   127.0.0.53#53
   ** server can't find BGOWIKI01v: SERVFAIL
   
   Operating System: Pop!_OS 19.04
  Kernel: Linux 5.0.0-21-generic
   IP4.DNS[1]: 192.168.3.2
   Server:127.0.0.53
   Address:   127.0.0.53#53
   ** server can't find BGOWIKI01v: SERVFAIL
   
   Operating System: Fedora 31 (Workstation Edition)
  Kernel: Linux 5.3.7-301.fc31.x86_64
   IP4.DNS[1]: 192.168.3.2
   Server:192.168.3.2
   Address:   192.168.3.2#53
   Name:  BGOWIKI01v
   Address: 192.168.3.60
   
   Operating System: openSUSE Leap 15.1
  Kernel: Linux 4.12.14-lp151.28.36-default
   IP4.DNS[1]: 192.168.3.2
   Server:192.168.3.2
   Address:   192.168.3.2#53
   Name:  BGOWIKI01v
   Address: 192.168.3.60
   
   Operating System: Debian GNU/Linux 10 (buster)
  Kernel: Linux 4.19.0-6-amd64
   IP4.DNS[1]: 192.168.3.2
   Server:192.168.3.2
   Address:   192.168.3.2#53
   Name:  BGOWIKI01v
   Address: 192.168.3.60

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: dnsutils 1:9.11.3+dfsg-1ubuntu1.11
  ProcVersionSignature: Ubuntu 4.15.0-72.81-generic 4.15.18
  Uname: Linux 4.15.0-72-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.9
  Architecture: amd64
  CurrentDesktop: MATE
  Date: Sat Feb  8 17:36:28 2020
  InstallationDate: Installed on 2019-12-22 (47 days ago)
  InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 
(20180426)
  SourcePackage: bind9
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bind9/+bug/1862437/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp


[Touch-packages] [Bug 1863165] Re: autoremove-kernels doesn't purge kernels

2020-02-15 Thread Julian Andres Klode
This is not a support forum. Purging automatically is not recommended.
Purge interactively a few times a year.

** Changed in: apt (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1863165

Title:
  autoremove-kernels doesn't purge kernels

Status in apt package in Ubuntu:
  Invalid

Bug description:
  Maybe this is a configuration issue, but:

  # apt-get --purge autoremove
  Reading package lists... Done
  Building dependency tree
  Reading state information... Done
  0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  # dpkg -l | grep ^rc | cut -c-70
  rc linux-image-4.15.0-66-generic 4.15.0-66.75 amd64 Signed kernel imag
  rc linux-image-4.15.0-67-generic 4.15.0-67.76 amd64 Signed kernel imag
  rc linux-image-4.15.0-71-generic 4.15.0-71.80 amd64 Signed kernel imag
  rc linux-image-4.15.0-72-generic 4.15.0-72.81 amd64 Signed kernel imag
  rc linux-image-4.15.0-73-generic 4.15.0-73.82 amd64 Signed kernel imag
  rc linux-image-4.15.0-74-generic 4.15.0-74.84 amd64 Signed kernel imag
  rc linux-image-4.15.0-75-generic 4.15.0-75.85 amd64 Signed kernel imag
  rc linux-image-4.15.0-76-generic 4.15.0-76.86 amd64 Signed kernel imag
  rc linux-modules-4.15.0-66-generic 4.15.0-66.75 amd64 Linux kernel ext
  rc linux-modules-4.15.0-67-generic 4.15.0-67.76 amd64 Linux kernel ext
  rc linux-modules-4.15.0-71-generic 4.15.0-71.80 amd64 Linux kernel ext
  rc linux-modules-4.15.0-72-generic 4.15.0-72.81 amd64 Linux kernel ext
  rc linux-modules-4.15.0-73-generic 4.15.0-73.82 amd64 Linux kernel ext
  rc linux-modules-4.15.0-74-generic 4.15.0-74.84 amd64 Linux kernel ext
  rc linux-modules-4.15.0-75-generic 4.15.0-75.85 amd64 Linux kernel ext
  rc linux-modules-4.15.0-76-generic 4.15.0-76.86 amd64 Linux kernel ext

  And the "rc" translates to "Remove/Conf-files". For some reason
  /etc/apt/apt.conf.d/01autoremove-kernels (triggered by unattended-
  upgrades.service) doesn't seem to remove the kernel's configuration
  files.

  The kernel images and modules are removed, only the package list (and
  maybe /usr/share/doc/linux*) is cluttered with the remnants of old
  kernels.

  Workaround:

   dpkg -l | awk '/^rc.*linux-(image|modules)/ {print $2}' | xargs dpkg
  -P

  # lsb_release -r; dpkg -s apt | grep Ver; uname -r
  Release:18.04
  Version: 1.6.12
  5.3.0-23-generic

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1863165/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp